パッド・ビアテンプレートの使用方法

概略

この記事では、Altium Designerでパッドとビアのテンプレートを使用して、PCB設計における再利用性、一貫性、管理性を向上させる方法を説明します。基板内でローカルテンプレートが自動的に作成される仕組み、外部のパッド・ビアテンプレートライブラリを利用する方法、そしてテンプレート定義の表示、配置、フィルタリング、管理を一元的に行うPCB Pad Via Templatesパネルの役割を紹介します。また、テンプレートとライブラリソースのリンクが維持される仕組み、そのリンクが編集に与える影響、設計ワークフローの各段階でテンプレートを適用できる箇所についても解説します。これらのツールを活用して、より効率的に、より細かく制御しながら作業を進める方法をご覧ください。

- ローカルのパッド・ビアテンプレートと、外部のパッド・ビアライブラリに保存されたテンプレートの違い、およびPCB設計でのそれぞれの使用方法を学びます。
- PCB Pad Via Templatesパネルを使用して、テンプレートの配置、利用可能なライブラリの確認、テンプレートリストのフィルタリング、現在の基板で使用されているテンプレートの確認を行う方法を紹介します。
- テンプレート名が生成される仕組み、ライブラリにリンクされたテンプレートが編集の可否に与える影響、設計ルールやPCB設計ワークフローでテンプレートを適用できる箇所を理解します。
AIでさらに深掘り:
 

パッドとビアは、トラックオブジェクトとともに、あらゆる回路基板設計の基本要素です。各パッドとビアは、配置中または配置後にカスタムオブジェクトとして設定できます。

3D表示のパッドとビア 
3D表示のパッドとビア

PCB設計におけるパッドとビアの設計再利用性と管理機能を向上させるため、Altium Designerは、パッド/ビアテンプレートの自動作成、パッド/ビアテンプレートライブラリ、および関連する各種パッド/ビア管理パネルもサポートしています。

パッドとビアのテンプレートをライブラリにまとめるという考え方は、PCBフットプリントライブラリと似ていますが、より基本的なものです。パッド/ビアテンプレートライブラリには、実際のパッドやビアではなく、パッドまたはビアのインスタンスを配置するときに適用される、あらかじめ設定された定義が保存されます。保存したパッド/ビアテンプレートライブラリを読み込むことで、定義済みのパッドとビアのインスタンスを任意のPCB設計やPCBフットプリントに配置できます。

パッド/ビアライブラリの作成について詳しくは、パッド/ビアテンプレートとライブラリの作成ページをご覧ください。

前述のとおり、既存のテンプレートをパッド/ビアテンプレートライブラリに保存したり、新しいテンプレートを作成したりできます。これらのライブラリ内のテンプレートは、PCB Pad Via Templatesパネルから利用できます。ローカルテンプレートもこのパネルに一覧表示されるため、パッド/ビアテンプレートライブラリを扱う際の中心的なリソースとなります。

PCB Pad Via Templatesパネル

PCB Pad Via Templatesパネルは、現在のPCBドキュメントに保存されているパッド/ビアテンプレート(ローカル)と、インストール済みまたは現在の設計プロジェクトに含まれているパッド/ビアライブラリから利用できるテンプレート(利用可能なライブラリ)の両方を一覧表示する専用パネルです。

設計スペースの右下にあるボタンをクリックし、PCB Pad Via Templatesを選択してパネルを開きます。

このパネルには、ローカルテンプレートとライブラリベースのテンプレートの両方にアクセスする機能があります。
このパネルには、ローカルテンプレートとライブラリベースのテンプレートの両方にアクセスする機能があります。

パネルで扱う2つのライブラリの概念は、次のようにまとめられます。

  • Available Pad/Via Template Libraries – 読み込み済みまたはインストール済みのパッド/ビアライブラリ(パッド/ビアテンプレートをまとめたファイル)。パネルのこの領域には、現在選択されているパッド/ビアライブラリに含まれるテンプレートが一覧表示されます。
  • Local Pad & Via Library – 現在の基板設計で使用されているパッド/ビアテンプレートの総称です。パッド/ビアライブラリから取得または追加されたテンプレートも含まれます。パネルのこの領域には、現在の基板設計のパッド/ビアに適用されているテンプレートが一覧表示されます。

ローカルのパッド/ビアライブラリ

パネル下部のLocal Pad & Via Library領域に表示される項目は、現在の基板設計で使用され、保存されているパッド/ビアの設定(テンプレート)を表します。選択したテンプレートのプレビューは、この領域の下部に表示されます。

ここに表示されるテンプレートは、PCBファイル内に保存されたパッド/ビアテンプレートであり、別途定義された「ライブラリ」に含まれているわけではありません。選択したテンプレートをレイアウト上にドラッグするか、パネルの右クリックコンテキストメニューからPlaceを選択すると、現在の基板上で新しいパッドまたはビアのインスタンスとして再利用できます。

ローカルのパッドテンプレートのインスタンスを配置する例。
ローカルのパッドテンプレートのインスタンスを配置する例。

利用可能なパッド/ビアテンプレートのファイルライブラリ

パネル上部のAvailable Pad/Via template Libraries領域では、パッド/ビアテンプレートのファイルライブラリを扱います。

選択したライブラリのテンプレートは、パネルからドラッグするか、右クリックコンテキストメニューを使用してPCBに配置できます。パッド/ビアは外部のテンプレートファイルライブラリから配置されるため、下の右側にあるPropertiesパネルの画像に示すように、PCB上ではそのプロパティを編集できません。ライブラリベースのパッド/ビアのプロパティを編集するには、テンプレートのリンクを解除する必要があります。詳しくは、ライブラリからテンプレートのリンクを解除するセクションをご覧ください。

アクティブなパッド/ビアライブラリ(この例ではPreferred.PvLib)内のテンプレート。2枚目の画像には、選択したパッドを配置したインスタンスのプロパティが表示されています。パッド形状や穴サイズなどの物理的なプロパティは編集できない点に注意してください。 
アクティブなパッド/ビアライブラリ(この例ではPreferred.PvLib)内のテンプレート。2枚目の画像には、選択したパッドを配置したインスタンスのプロパティが表示されています。パッド形状や穴サイズなどの物理的なプロパティは編集できない点に注意してください。

ファイルベースのパッドまたはビアテンプレートを基板設計に配置すると、配置元のライブラリテンプレートおよびライブラリ名とのリンクが維持されます。配置元は外部ファイルであるため、そのテンプレートを使用するパッドまたはビアの物理的なプロパティは編集できず、外部ライブラリファイル内の元のテンプレートの整合性が保護されます。ファイルベースのパッドまたはビアテンプレートを編集するには、リンクを解除します。詳しくは、ライブラリからテンプレートのリンクを解除するセクションをご覧ください。

パネル上部のドロップダウンでは、利用可能なライブラリのうち、どれをアクティブにするかを選択します。下の画像ではExampleViaLib.PvLibが選択されています。 ボタンをクリックすると、テンプレートライブラリファイルを追加または削除できるAvailable Librariesダイアログが開きます。利用可能なライブラリについては、後述します。Filterフィールドを使用すると、Nameが指定した文字列で始まるテンプレートのみを表示できます。

Filterフィールドを使用すると、テンプレート一覧をすばやく絞り込めます。
Filterフィールドを使用すると、テンプレート一覧をすばやく絞り込めます。

パッド/ビアテンプレートライブラリを利用可能にする

Available Librariesとは、現在の基板設計でテンプレートを使用できるパッド/ビアテンプレートライブラリを意味します。これには、現在のプロジェクトに追加されたテンプレートライブラリと、Altium Designerにインストールされたテンプレートライブラリが含まれます。どちらの種類も、Available Librariesダイアログで確認および管理できます。PCB Pad Via Templatesパネル上部の ボタンをクリックすると、このダイアログが開きます。

外部のパッド/ビアライブラリをインストールするか、Projectタブを使用して既存のライブラリを現在のプロジェクトに追加します。
外部のパッド/ビアライブラリをインストールするか、Projectタブを使用して既存のライブラリを現在のプロジェクトに追加します。

  • ダイアログのProjectタブには、プロジェクトに含まれるすべてのPvLibファイルが一覧表示され、プロジェクトにライブラリを追加したり、プロジェクトから削除したりするためのボタンも用意されています。
  • Installedタブには、このAltium Designer環境で現在利用できるすべてのパッド/ビアテンプレートライブラリが一覧表示されます。これらは、すべてのPCB設計プロジェクトで利用できます。インストール済みライブラリは、対応するActivated オプションを有効または無効にすることで、使用可能にするかどうかを制御できます。これにより、ライブラリの削除と再追加を繰り返す必要がなくなります。

設計でテンプレートを使用する

PCB Pad Via Templatesパネルに表示されるテンプレートは、現在の基板設計で次のように使用できます。

  • 配置 – ローカルまたはテンプレートライブラリのパッド/ビアを、パネルから直接配置します。
  • Templateドロップダウンで選択 – パッドまたはビアを選択した状態で、Propertiesパネルから選択します。この方法で、選択したパッドまたはビアが使用するテンプレートを別のテンプレートに変更できます。
  • ルールの制約として使用 – Routing Via Style設計ルールの制約として、パッド/ビアテンプレートを選択できます(下図参照)。
  • ルールの適用範囲として使用 – 設計ルール(Testpoint Style設計ルールなど)の適用範囲を設定する際に、次のクエリキーワードを使用できます。
  • ビアスティッチング/シールディングの場合は、ネットへのスティッチング追加ダイアログまたはネットへのシールディング追加ダイアログで、必要なVia Templateを選択します。

Routing Via Styleデザインルールで、またはネットにビアスティッチングを追加する際に、ビアテンプレートを使用します。
Routing Via Styleデザインルールで、またはネットにビアスティッチングを追加する際に、ビアテンプレートを使用します。

パッド/ビアテンプレートとその命名方法

基板設計に配置された固有のパッドまたはビアごとに、パッド/ビアテンプレートが自動的に作成され、名前が付けられ、基板ファイルに保存されます。テンプレートには、サイズ、形状、パッドスタックタイプ、ペースト/ソルダーマスク、穴の情報など、パッド/ビアの基本構成が保存されます。この構成には、IPC規格(具体的にはIPC-7251/7351のパッドスタック命名規則)に従って自動的に名前が付けられます。設計で使用されるすべてのパッドとビアは、それぞれのテンプレートを参照します。これは、以下に示すようにPropertiesパネルで確認できます。

IPCの命名体系はメートル法に基づいており、1単位は100分の1ミリメートル(10-5メートル、10µm)に相当します。たとえば、穴径0.8mmの1.5mm円形パッドのテンプレートには、c150h80という名前が付けられます。ここで、cは円形(丸)を示し、hは穴径の前に付く接頭辞です。r155_125という名前のパッドは、サイズが1.55mm x 1.25mmの長方形の表面実装パッドです。また、s160h100という名前のパッドは、サイズが1.6mm、穴径が1.0mmの正方形のスルーホールパッドです。カスタム形状パッドのテンプレート名には、接頭辞としてuが付けられます。指定されたペースト/ソルダーマスクのプロパティに応じて、さらに文字と整数の組み合わせが追加されます。

この動作を確認するには、既存のパッドまたはビアをダブルクリックするか、オブジェクトを選択して右クリックのコンテキストメニューから Propertiesを選択し、対応するPropertiesパネルでプロパティを確認します。

Propertiesパネルに表示された、自動生成されたパッドまたはビアのテンプレート名。
Propertiesパネルに表示された、自動生成されたパッドまたはビアのテンプレート名。

パネルのPad/Via Template領域に割り当てられたTemplate名に注目してください。IPCガイドラインに従い、この名前は寸法、形状、穴、ペースト/ソルダーマスク構成など、パッド/ビアの基本プロパティから生成されます。これらのプロパティを変更すると、新しい構成を反映するようにテンプレート名も変わります。当然ながら、メートル法ではなくヤード・ポンド法の単位を使用している場合、パッドまたはビアのプロパティとテンプレート名の関係はわかりにくくなります。

PCB設計スペースでパッドまたはビアを見つける

PlaceメニューまたはActive Barを使用して、固有のサイズを持つパッドまたはビアをPCB設計に配置するたびに、新しいパッド/ビアテンプレートが基板ファイル内に自動的に作成されます。これらのテンプレートは、<Local>テンプレートと呼ばれます。現在のPCBで使用されているすべてのパッドおよびビアテンプレートの一覧は、PCBパネルをパッド&ビアテンプレートモードに設定すると確認できます。

Pad &amp; Via TemplatesモードのPCBパネル
Pad & Via TemplatesモードのPCBパネル

Pad & Via Templatesモードでは、現在のPCBドキュメントで使用されているパッドおよびビアテンプレートを詳細に制御できます。 このモードのパネルは、次の3つのセクションに分かれています。

  • Library Name
  • Templates
  • Pads/Vias

ライブラリ名

この一覧には、設計内のパッド&ビアテンプレートのインスタンスが、仮想ライブラリと物理ライブラリの集合として表示されます。 これらはパネル下部の一覧に含まれるテンプレートをフィルタリングするもので、次のように分類されています。

  • All – パッド&ビアライブラリから使用されているものを含む、すべてのパッドおよびビアテンプレートを表示します。
  • Pads – ローカルとライブラリベースの両方の、すべてのパッドを表示します。
  • Vias – ローカルとライブラリベースの両方の、すべてのビアを表示します。
  • Local – 基板に適用されているすべてのパッドおよびビアテンプレートを表示します。ただし、パッド/ビアライブラリから追加されたものは除きます。
  • Pad & Via Libraries – 選択したパッド/ビアライブラリから適用されたパッドおよびビアテンプレートのみを表示します。

テンプレート

この領域には、現在のPCB設計で使用されているすべてのパッド/ビアテンプレートの一覧が表示されます。列には、テンプレートのソースLibrary Name(ローカルまたはパッド/ビアライブラリ名)と、各テンプレートのパッド/ビアインスタンス数(Count)が含まれます。

パネルのLibrary Nameセクションが特定のパッド/ビアライブラリに設定されている場合、Templateセクションに、インスタンス数を示すCountがゼロの項目が表示されることがあります。これは、そのテンプレートが現在の基板レイアウト内のどのパッド/ビアにも使用されていないものの、設計プロジェクトでは使用されていることを示します。たとえば、デフォルトのパッド/ビア設定として使用されている場合や、Routing Via Styleなどのデザインルールの制約を定義するために使用されている場合があります。

一覧内のテンプレートは、任意の数を選んで別のパッド/ビアライブラリに保存できます。これを行うには、標準的なShift+ClickおよびCtrl+Clickの操作で複数のテンプレートを選択し、Save as Libraryボタンをクリックします。ライブラリはプロジェクトに自動的に追加され、ProjectsパネルのFile » Save Asを使用して、任意の*.PvLibファイル名で保存できます。パッド/ビアテンプレートライブラリの作成について詳しくは、パッド/ビアテンプレートライブラリの作成と編集ページを参照してください。

Templates セクションでは、Placeボタンを使用して、パッド/ビアライブラリに基づくテンプレートをPCB設計に配置することもできます。この機能を有効にするには、パネル上部のLibrary Nameセクションで目的のパッド/ビアライブラリを選択します。

選択したパッド/ビアテンプレートがパッド/ビアテンプレートライブラリ内にある場合は、Placeボタンを使用して配置できます。ローカルのパッド/ビアを配置するには、以下で説明するPCB Pad Via Templatesパネルを使用します。

パッド/ビア

パネルのこの領域には、上のTemplatesセクションで選択したテンプレートの個々のパッド/ビアインスタンスが表示されます。

各パッド/ビアインスタンスを選択すると、PCBパネル上部にある標準のハイライト、ズーム、選択オプションの設定に従って、設計スペース内のオブジェクトがグラフィカルにハイライトされます。 選択したパッドまたはビアは、Propertiesパネルで編集して別のテンプレートを使用するように変更できます。Templateドロップダウンで必要なテンプレートを選択してください。

この領域に表示される各インスタンスには、Changedインジケーターボックスが付いています。リンクされたライブラリのソーステンプレートが、ローカルのパッドまたはビアで使用されているテンプレートと異なる場合、つまりソースのパッド/ビアライブラリが更新された場合に、このボックスにチェックが入ります。また、ローカルのパッド/ビアのパッドスタックタイプが変更された場合にも、Changed インジケーターにチェックが入ります。たとえば、パッドインスタンスがローカルで多層から単層に変更された場合などです。

いずれの場合も、PCBパッド/ビアテンプレートパネル Updateのボタンを使用して、ローカルのパッドまたはビアを、ソースのパッド/ビアライブラリ内の現在のテンプレートに更新(または復元)できます。

パッド/ビアテンプレートの編集と管理

このセクションでは、パッドまたはビアのテンプレートを編集する必要があるさまざまなケースについて説明します。

既存のパッド/ビアに別のテンプレートを適用する

既存のパッドやビアに別のテンプレートを適用したい場合があります(たとえば、設計で使用するビアの種類を減らす場合など)。この場合は、PCBパネルのPad & Via Templatesモードを使用して、変更するパッド/ビアを見つけて選択します。選択したパッドまたはビアは、PropertiesパネルのTemplateドロップダウンで必要なテンプレートを選択することで、別のテンプレートを使用するように変更できます。

別のテンプレートを適用している様子。
別のテンプレートを適用している様子。

テンプレートとライブラリのリンクを解除する

ファイルベースのテンプレートライブラリのテンプレートを使用しているパッド/ビアのプロパティは編集できません。編集できると、ローカルのインスタンスが参照先のライブラリテンプレートと一致しなくなるためです。ライブラリテンプレートを参照しているパッドまたはビアを編集するには、テンプレートのリンクを解除する必要があります。

Linked button, click to copy the template from the file library to the local library and reference the local templateボタンをクリックすると、テンプレートのリンクが解除されます。このボタンをクリックすると、そのテンプレートのコピーがローカルライブラリに作成され、選択したパッド/ビアのインスタンスはローカルテンプレートを参照するようになります。なお、Linked button, click to copy the template from the file library to the local library and reference the local templateボタンがグレー表示されている場合は、テンプレートがすでにローカルにあることを示します。

クリックして、テンプレートとファイルベースのライブラリのリンクを解除します。テンプレートがローカルライブラリにコピーされ、そのテンプレートが使用されます。
クリックして、テンプレートとファイルベースのライブラリのリンクを解除します。テンプレートがローカルライブラリにコピーされ、そのテンプレートが使用されます。

リンクを解除するパッド/ビアに、パッド/ビアテンプレートライブラリでカスタム名が定義されていた場合、その名前は削除され、ローカルテンプレートにはIPC標準の命名規則が適用されます。

ライブラリテンプレートをローカルライブラリに追加する

必要に応じて、ライブラリテンプレートをローカルライブラリに追加できます。テンプレート名を右クリックしてコンテキストメニューからAdd to Internal Libraryを選択するか、パネルのPad/Via Library領域からテンプレートをドラッグして、Local Pad & Via Library領域の空白部分にドロップします。

右クリックメニューまたはドラッグ&ドロップ操作を使用して、パッド/ビアテンプレートをローカルライブラリに追加します。
右クリックメニューまたはドラッグ&ドロップ操作を使用して、パッド/ビアテンプレートをローカルライブラリに追加します。

使用していないパッド/ビアのライブラリテンプレートは、Removed Unused Pad/Viaボタンをクリックしてローカルライブラリから削除できます。

これは、パッド/ビアライブラリのテンプレートを使用してパッド/ビアを配置してから基板上から削除し、そのテンプレートをローカルで利用可能なものとして登録する操作と同じです。ローカルリストに追加するのではなく、ローカルテンプレートをreplaceするには、以下のローカルテンプレートを置き換えるを参照してください。

パッド/ビアライブラリから更新する

パッド/ビアのテンプレートがライブラリで更新され、そのテンプレートがすでに基板設計で使用されている場合は、PCB Pad Via TemplatesパネルのUpdateボタンをクリックして、設計内のパッド/ビアテンプレートを更新します。更新は、基板上でそのテンプレートを使用しているすべてのパッド/ビアのインスタンスに自動的に反映されます。

ライブラリで更新されたテンプレートを使用しているパッド/ビアは、PCB Pad Via TemplatesパネルのUpdateボタンを使用してPCB設計内で更新できます。
ライブラリで更新されたテンプレートを使用しているパッド/ビアは、PCB Pad Via TemplatesパネルのUpdateボタンを使用してPCB設計内で更新できます。

更新を開始すると、Update Pads/Vias on Boardダイアログが開き、適用される変更の詳細が一覧表示されます。

参照元ライブラリのバージョンと異なることが検出されたパッド/ビアテンプレートは、ライブラリからPCB設計に更新できます。
参照元ライブラリのバージョンと異なることが検出されたパッド/ビアテンプレートは、ライブラリからPCB設計に更新できます。

このダイアログには、更新処理を制御するための3つの更新オプションがあります。

  • Update locked objects – ロック状態にかかわらず、パッド/ビアオブジェクトのテンプレートを強制的に更新します。
  • Update free objects – フリーパッドおよびフリービアに適用されているパッド/ビアテンプレートのみを更新します。
  • Update component objects – コンポーネントで使用されているパッドおよびビアに適用されているパッド/ビアテンプレートのみを更新します。

この同期動作は、パッドおよびビアのLibraryプロパティによって設定されます。このプロパティは、パッドまたはビアを選択してプロパティを表示したときに、Propertiesパネルで確認できます。テンプレートのローカルバージョンと参照元テンプレートに差異がある場合は、PCBパネルのPad & Via TemplatesモードにあるPads/Vias領域のChanged列に表示されます。

参照元のパッド/ビアライブラリでテンプレート名が変更されても、基板設計データに保存されているテンプレートのGUID参照によって、PCB設計内のパッド/ビアへの適用先とのリンクは維持されます。

ダイアログの下部には、更新対象のパッド/ビアが一覧表示されます。各項目には、Type、Description、Library、Template、Actionなどの情報が表示されます。また、各パッド/ビアにLockedおよび/またはIn Componentのマークを付けることもできます。これらのオプションを有効にすると、そのオブジェクトにはダイアログ上部の設定が適用されます。

ローカルテンプレートを置き換える

ライブラリベースのパッド/ビアテンプレートでローカルテンプレートをreplaceすることもできます。これにより、そのローカルテンプレートを使用している基板上のパッドまたはビアが更新されます。

これを行うには、目的のライブラリテンプレートをパネルのPad/Via Library領域からLocal Pad & Via Library領域へドラッグします。ただし、この場合は、既存のローカルテンプレートの項目on top ofライブラリテンプレートをドロップします。そのテンプレートを使用するフリーまたはコンポーネントのパッド/ビアのすべてのインスタンスが、新しいライブラリテンプレートのスタイルに更新されます。

以下のアニメーションでは、C1およびC2のコンポーネントパッドの形状が、ドロップされたライブラリテンプレートで指定されたタイプに従って、r110_100からs120へ変化することに注目してください。

ライブラリテンプレートをローカルテンプレートの項目の上にドロップすると、設計内のすべてのインスタンスでそのテンプレートが置き換えられます。
ライブラリテンプレートをローカルテンプレートの項目の上にドロップすると、設計内のすべてのインスタンスでそのテンプレートが置き換えられます。

未使用のパッド/ビアを削除する

ローカルライブラリに表示されるテンプレート名は、現在のPCBレイアウト内のパッドとビアから生成されます。そのため、特定のローカルパッド/ビア構成のすべてのインスタンスを基板から削除すると、対応するテンプレートもローカルリストから削除されます。

ただし、配置されたパッドまたはビアがパッド/ビアライブラリを参照元としている場合、そのパッド/ビアのすべてのインスタンスを基板から削除しても、テンプレートはローカルリストに保持されます。不要になったパッド/ビアライブラリテンプレートのインスタンスは、Remove Unused Pad/Viaボタンを使用してローカルの「データベース」レコードから削除できます。Update Templates from Libraryダイアログが開き、ローカルのパッド/ビアライブラリから削除するパッドおよびビアのテンプレートを選択できます。Templates ボタンまたは右クリックメニューを使用して、リスト内のすべてのテンプレートを選択/選択解除したり、選択状態を反転したりできます。

Update Templates from Libraryダイアログ
Update Templates from Libraryダイアログ

AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
Nav
Contents
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Contents