曲げ線の定義 - 標準モード

概略

この記事では、Altium Designerの標準リジッドフレックスモードで、フレックス領域の曲げ線を定義、配置、移動、削除、設定する方法を説明します。また、標準リジッドフレックスモードと高度なリジッドフレックスモードの違い、基板で使用しているモードの確認方法、曲げを正確に管理するためのエディタ表示やパネルについても解説します。適切なモードで曲げ位置、角度、半径、影響領域の幅、折り曲げ順序を設定する具体的な手順を知りたい方に役立つガイドです。ぜひ読み進めて、次の設計にこれらの手順を活用してください。

- 標準リジッドフレックスモードで曲げ線を使用できる条件と、基板領域の定義における高度なリジッドフレックスモードとの違いを学びます。
- 基板プランニングモードで曲げ線を配置、移動、削除し、正確に位置合わせするための具体的な手順を確認します。
- 曲げ角度、半径、影響領域の幅、3Dでの折り曲げ確認に使用する折り曲げ順序など、設定可能な曲げ線のプロパティを理解します。
AIでさらに深掘り:

AltiumのPCB設計ソフトウェアでは、2つのリジッドフレックス設計モードを使用できます。従来の標準モードであるRigid-Flexは、シンプルなリジッドフレックス設計に対応しています。フレックス領域の重なりなど、より複雑なリジッドフレックス要件がある設計では、Advanced Rigid-Flexモード(リジッドフレックス2.0とも呼ばれます)が必要です。モードは、レイヤースタックマネージャーのToolsメニューで選択します。

両モードの基本的な違いは、従来のモードでは分割線を配置して基板外形を個別の基板領域に分割し、その分割線が、ある基板領域の終わりと次の基板領域の始まりを定義するオブジェクトとして残ることです。Advancedモードでは、各基板領域を個別に配置します。また、大きな領域をスライスすると、2つの独立した領域オブジェクトになります。Advancedモードでは、2つの領域の境界は分割線の有無ではなく、隣接する基板領域のエッジによって定義されます。この違いにより、Advanced Rigid-Flexモードの基板には分割線オブジェクトが存在しません。

► 詳細はこちら:リジッドフレックスPCBの設計

Viewメニューには、覚えやすいショートカットが割り当てられた3つのPCBエディター作業モードがあり、次のモードをすばやく切り替えられます。

  • Board Planning Mode(1)
  • 2D Layout Mode(2)
  • 3D Layout Mode(3)

2D表示モードと3D表示モードを切り替えると、デフォルトでは各表示モードのズームと向きの設定が個別に保持されます。切り替え時に基板の同じ位置と向きを表示したい場合は、2または3の代わりに、Ctrl+Alt+2 または Ctrl+Alt+3を押してください。

開いたPCBが標準リジッドフレックスモードとAdvanced Rigid-Flexモードのどちらを使用しているか、確認したい場合はどうすればよいでしょうか。

レイヤースタックマネージャーを開いて確認できます。または、基板プランニングモード(ショートカット:1)に切り替えて、アクティブバーを確認してください。

標準リジッドフレックスモード
Advanced Rigid-Flexモード

フレックス基板の曲げ方を定義するには、1本以上の曲げ線を配置します。曲げ線は、フレックス領域の表面のどこで曲げるかを定義します。また、曲げ角度と曲げ半径に加え、曲げられる基板表面の帯状部分の幅も定義します。曲げ線の配置と編集は、PCBエディターをBoard Planning Modeにして行います(View » Board Planning Mode、またはショートカット 1を押します)。

曲げ線は、Layer Stack ManagerでFlex領域として設定された領域にのみ配置できます。


フレックス領域に曲げ線を配置し、基板を180度折り曲げられるように設定します。この動画では、標準リジッドフレックスモードで曲げ線を配置する方法を紹介します。

曲げ線の配置

曲げ線を配置するには:

  1. View » Board Planning Modeを選択するか、ショートカット 1を押して、Board Planning Modeに切り替えます。

  2. 曲げ線はMulti-Layerに配置されます。編集スペースの下部にMutli-Layer タブが表示されていない場合は、View Configurationパネルでそのレイヤーを有効にしてください(ショートカットLでパネルを表示できます)。

  3. Design » Define Bending Lineコマンドを選択します。

  4. 曲げ線を配置する基板領域内をクリックします。線の一端はクリック位置に最も近い領域のエッジに接続され、もう一端はカーソルに追従します。

  5. もう一端を目的の位置に移動し、1回クリックして配置します。

  6. 曲げ線配置モードは継続するため、必要に応じて別の曲げ線を配置できます。配置を終了する場合は、右クリックするかEscを押して、曲げ線配置モードを終了します。

Layer Stack RegionsモードのPCBパネルには、Bending Linesデータが表示されます。エントリーをダブルクリックすると、曲げ線ダイアログが開きます。 

このフレックス基板領域には、3本の曲げ線が配置されています。オレンジ色の帯の幅は、影響領域の幅です。
このフレックス基板領域には、3本の曲げ線が配置されています。オレンジ色の帯の幅は、影響領域の幅です。

基板領域にフレックスレイヤースタックを使用するように設定すると、その幾何学的中心を縦方向に通る曲げ線が自動的に追加されます。必要に応じて、この曲げ線を削除するか、位置を変更して設定してください。

曲げ線の移動

既存の曲げ線の位置を変更するには:

  1. View » Board Planning Mode を選択するか、ショートカット 1を押して、Board Planning Modeに切り替えます。
  2. 曲げ線が含まれる基板領域を1回クリックして選択します。その領域内にあるすべての曲げ線のハンドルが表示されます。
  3. 線の端点を移動するには、ノードをクリックしたまま、基板領域の外周上の目的の位置までドラッグします。カーソルの移動は、現在のスナップグリッドや既存の設計オブジェクトによって制約されます。
  4. 曲げ線の新しい位置によって、曲げ位置が再定義されます。

曲げ線の端点ノードを選択してドラッグすると、基板上の曲げ位置を変更できます。
曲げ線の端点ノードを選択してドラッグすると、基板上の曲げ位置を変更できます。

曲げ線の正確な位置決め

曲げ線を移動すると、ハンドルは現在のスナップグリッド上の位置にスナップします。移動中に、メカニカルレイヤー上の線など、既存の設計オブジェクトにスナップさせることもできます。下の画像は、Mechanical 2レイヤー上の線の端点に曲げ線のハンドルを配置している様子を示しています(番号1で強調表示)。このスナップ動作を使用するには、メカニカルレイヤーがアクティブな設計レイヤーになっている必要があります。

番号1は、Mechanical 2上の線にスナップした曲げ線のハンドルを示しています。このレイヤーがアクティブレイヤーになっていることに注目してください。
番号1は、Mechanical 2上の線にスナップした曲げ線のハンドルを示しています。このレイヤーがアクティブレイヤーになっていることに注目してください。

上記の手順を詳しく示すため、以下の画像では、2D Layout ModeでMechanical 2上に配置した補助線を示しています。これらの補助線は、45度の曲げ線を配置するために使用できる上下の基準点を正確に定義しています。

2Dレイアウトモードの基板。斜めの曲げ線を正確に配置するための補助線が表示されています。2Dレイアウトモードの基板。斜めの曲げ線を正確に配置するための補助線が表示されています。

基板プランニングモードの基板。Mechanical 2上の補助線にスナップさせた斜めの曲げ線が表示されています。基板プランニングモードの基板。Mechanical 2上の補助線にスナップさせた斜めの曲げ線が表示されています。

曲げ線の削除

曲げ線を削除するには:

  1. View » Board Planning Modeを選択するか、ショートカット 1を押して、Board Planning Modeに切り替えます。
  2. 曲げ線の一方の端点をクリックしたまま、Deleteキーを押します。または、PCBパネルのBending Lines領域で曲げ線のエントリーを選択し、削除します。

基板領域にフレックスレイヤースタックを使用するように設定すると、その幾何学的中心を縦方向に通る曲げ線が自動的に追加されます。必要に応じて、この曲げ線を削除するか、位置を変更して設定してください。

曲げ線のプロパティの設定

基板領域、分割線、曲げ線は、Board Planning Modeで確認および編集します(1を押します)。曲げ線は、設計スペースで対話的に編集することも、次の項目から編集することもできます:PCBLayer Stack Regionsモードに設定されている場合のパネル。 パネルを表示するには、Altium Designerの右下にあるPanelsボタンをクリックし、メニューからPCBを選択します。パネル上部のドロップダウンでLayer Stack Regionsを選択します。 このモードでは、パネルに次の情報が表示されます。

  • Layer Stacks領域に、使用可能な基板レイヤースタック。
  • Stackup Regions領域に、それらのスタックに割り当てられた領域。
  • Bending Lines領域に、選択した領域内で定義されているベンディングライン。

Board Planning Modeに入ると、PCBパネルは自動的にLayer Stack Regionsモードに設定されます。

PCBパネルでベンディングラインのプロパティを編集するには、次の手順に従います。

  1. ベンディングラインは、2D Layout Mode(2を押す)またはBoard Planning Mode(1を押す)のいずれでも編集できます。
  2. パネル上部のSelectチェックボックスをオンにします。
  3. PCB パネルのStackup Regionsエリアで、ベンディングラインを含む基板領域を選択します。
  4. パネルのBending Lines領域のリストからベンディングラインを選択します。PCB パネルのSelectオプションが有効になっている場合、基板上のベンディングラインがハイライト表示(選択)されます。ベンディングラインのエントリは、Bending Lines領域から削除することもできます。
  5. Bending Lines領域のベンディングラインのエントリをダブルクリックすると、下図のようにBending Lineダイアログが開きます。

  6. Bending Lineダイアログで、最初の3つのプロパティのうち2つを編集します。たとえば、Radius(曲げ面から曲げの中心点までの距離)とBending Angle(フレックス領域の表面を曲げる角度)を編集します。3つ目のプロパティであるAffected area width(指定されたRadiusとBending Angleに対して曲げられる表面領域の幅)は自動的に計算されます(詳細は後述)。各ベンディングラインのAffected area widthは、オレンジ色の網掛け領域として表示されます。
  7. Bending Lineダイアログで、必要に応じてFold Indexを設定し、曲げを適用する順序を定義します。この順序は、3Dモードで基板を折り曲げるために、PCBパネルのFold StateスライダーまたはView » Fold/Unfoldコマンドを使用したときに適用されます。 値が最も小さい曲げから順に、最も大きい曲げまで適用されます。

3D表示モードの物理的な基準面(Z = 0)を定義するには、いずれか1つの基板領域について、Board Regionダイアログの3D Lockedチェックボックスをオンにする必要があります。これを行わないと、定義された各ベンディングラインのAffected area widthは表示されません。

Bending Lineダイアログは、ベンディングラインのハンドルを配置または移動しているときにTabを押すか、ベンディングラインのハンドルをダブルクリックして開くこともできます。

曲げの定義の概要

ベンディングラインは、領域を横切るように配置する線形オブジェクトで、基板のフレックス領域に適用する曲げの位置、半径、角度を定義します。

ベンディングラインの定義:

  • ベンディングラインは、基板プランニングモード(ショートカット:1)で配置します。
  • ベンディングラインを配置するには、Design » Define Bending Lineコマンドを実行します。
  • フレックス基板領域を横切るようにベンディングラインを配置します。ベンディングラインの始点と終点を領域の各端に正確に合わせる必要はありません。ソフトウェアが自動的に、短すぎる場合は延長し、長すぎる場合は短縮します。ベンディングラインの少なくとも一方の端は、領域の端に接しているか、端を越えている必要があります。
  • ベンディングラインのプロパティを編集するには、領域内の任意の場所をクリックして、その領域内のすべてのベンディングラインの頂点を表示し、次の操作を行います。
    • ベンディングラインの頂点をダブルクリックして、ベンディングラインダイアログを開きます。または、
    • PCBパネルを表示し、Layer Stack Regionsモードに設定します。このモードでは、領域とベンディングラインを確認および編集できます。
    • 必要に応じて、Bending Angleと曲げのRadiusを設定します。
    • 曲げはFold Indexの順序で適用されます。折り曲げる順序の確認が重要な場合は、この機能を使用してください。
  • ベンディングラインを移動するには、各頂点をクリックしてドラッグします。
  • ベンディングラインを削除するには、いずれかの頂点をクリックしたまま、キーボードのDeleteを押します。
  • ベンディングラインは、基板カットアウトの端には適用できません。基板でこれが必要な場合は、リジッドフレックス詳細モードに切り替えてください。
AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
Nav
Contents
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Contents