Setting Up a Schematic Document in Altium Designer

Created: January 17, 2024 | Updated: January 17, 2024

Parent page: Capturing Your Design Idea as a Schematic

To start capturing the schematic for your PCB design, add a new schematic document to the PCB project. To do this, right-click the project's entry in the Projects panel and select Add New to Project » Schematic command from the context menu (or use the File » New » Schematic command from the main menus).

Grids and Cursors

Before placing objects in the Schematic Editor, set the grids to enable easier placement. Altium Designer offers three grid types: visible grids for navigation, snap grids for placement, and electrical grids for aiding the creation of connections. Grids are document options, meaning that they are saved with the individual design, and therefore, grid settings may differ between one design document and the next. Set the grids initially in the General region of the Document Options mode of the Properties panel.

The Visible Grid appears whenever the zoom level allows them to be sufficiently spaced, displayed as either lines or dots. To turn the visible grid on or off in the current document, click the toggle Visible Grid button () in the panel, choose the View » Grids » Toggle Visible Grid command from the main menus or use the Shift+Ctrl+G keyboard shortcut.

The Snap Grid is the grid that the cursor is locked to when placing or moving schematic design objects. The current value of the snap grid is displayed on the left-hand side of the Status Bar. You can also use the View » Grids » Set Snap Grid command to set a specific value for the snap grid through the Choose a snap grid size dialog.

Electrical grids override snap grids since they allow connections to be made to off-grid parts. Enable Snap to Electrical Object Hotspots (can be toggled using the View » Grids » Toggle Electrical Grid command from the main menus or the Shift+E shortcut) so that when moving an electrical object in the design space, if it falls within the electrical grid range of another electrical object to which it could connect, it will snap to the fixed object and a hotspot (red cross) will appear. The electrical grid should be set slightly lower than the current snap grid or else it becomes difficult to position electrical objects one snap grid apart.

Grids can be quickly modified or toggled between enabled and disabled through keyboard or mouse shortcuts, for example, press G/Shift+G to cycle forward or back through the Snap grid settings defined on the Schematic - Grids page of the Preferences dialog for the current measurement system in force (Imperial or Metric). You can also use the View » Grids » Cycle Snap Grid and the View » Grids » Cycle Snap Grid (Reverse) commands from the main menus. If you change the grid size in this manner, your entered setting (through the Choose a snap grid size dialog) will be lost since cycling only involves the currently chosen preset interval settings.

You can change the Cursor type to suit your needs in the Cursor region of the Schematic - Graphical Editing page of the Preferences dialog. For example, a large 90 degree cross that extends to the edges of the design window (Large Cursor 90 option) can be useful when placing and aligning design objects.

Altium components are designed on an Imperial grid, be aware that their pins will not fall on logical grid increments if you choose to use a Metric grid. You can use an Imperial grid with a Metric sheet, the sheet Template and Units are set in the Document Options mode of the Properties panel, which is displayed when there is nothing selected on the schematic sheet.

Applying a Schematic Template to the Schematic Sheet

A schematic template is a document that holds user-defined sheet size, border and title block descriptions that can be referenced by (linked to) a schematic sheet negating the need to define these common attributes again and again. Available schematic templates can be applied to the active schematic sheet document as described below.

If you are not connected to your Workspace, you can still work with Altium Designer (under your valid Altium Designer license), but you will not be able to access that Workspace or any other services it provides. You will, therefore, not be able to use any Workspace schematic templates. You will only be able to use file-based templates defined locally and available from the templates folder specified on the Data Management – Templates page of the Preferences dialog (if the Template visibility option is set to Server & Local on this page).
A schematic template can be selected as a default template for new schematic sheet documents. On the Data Management – Templates page of the Preferences dialog, either hover the cursor over the required template in the list on the Templates tab and click the Set as Default control in the Default column, or click the Add button on the Defaults tab and select Schematic in the From Server menu (to choose a Workspace Schematic Template from the connected Workspace) or From File menu (to choose a schematic document file (*.SchDoc) or schematic template file (*.SchDot) from your hard drive). The default schematic template will be shown in the list on the Defaults tab of the page.
To learn more about creating a schematic template, refer to the Schematic Templates Creation page.

Applying a Template from the Properties Panel

Accessing the Properties panel for the active schematic document, with no design objects selected in the design space, will present the Document Options. In the Formatting and Size region of the Page Options section of the panel (on its General tab), choose the Template mode and then use the Template field to choose which template to use for the sheet. The list is grouped into Workspace templates (shared with you in the Workspace) and local, file-based templates.

A chosen revision of a schematic template is reflected in the Properties panel when browsing the Document Options for the active schematic sheet.
A chosen revision of a schematic template is reflected in the Properties panel when browsing the Document Options for the active schematic sheet.

After selecting a template (or updating a template), the Update Template dialog opens in which you can update to the current template then an Information dialog opens displaying that the template was updated.

The Update Template dialog
The Update Template dialog

  • Choose Document Scope – choose one of the following options to determine the scope of the update:
    • Just this document – choose this option to update the active schematic document only with changes to its current template.
    • All schematic documents in the current project – choose this option to update the active schematic document and all other schematic documents in the active project with changes to their respective current templates. Schematics that are currently closed will be opened.
    • All open schematic documents – choose this option to update the active schematic document and all other open schematic documents (regardless of parent project) with changes to their respective current templates.
  • Choose Parameter Actions – choose one of the following options to determine how parameter changes are handled:
    • Do not update any parameters – choose this option to leave all parameters sourced from the associated template unchanged.
    • Add new parameters that exist in the template only – choose this option to add any parameters that exist in the template but do not currently exist on the schematic sheet.
    • Replace all matching parameters – choose this option to update the value of each parameter that is found to exist in both the template and the schematic sheet with the value present in the template.

Note that text and graphical objects defined in the schematic template cannot be selected or edited when the template is applied to a schematic sheet  – these objects become a kind of watermark.

The only aspect in which an applied template can be changed is updating the placeholder Text Strings set as special strings with the values of the document, project, or variant parameters by changing these values in relevant locations: the Parameters tab of the Properties panel in its Documents Options mode, the Parameters tab of the Project Options dialog, and the Edit Project Variant dialog, respectively.

Applying a Template from the Design Menu

On the Schematic Editor's main Design » Sheet Templates sub-menu, you have the ability to freely select a different Workspace or local template.

Select the Load From File command from the Design » Sheet Templates » Local sub-menu to browse to and select a schematic template file on your hard drive. Select the Manage Templates command to open the Data Management – Templates page of the Preferences dialog

Applying a Workspace Template when using an Environment Configuration

In addition and available with Altium Designer Enterprise Subscription, a Workspace schematic template can be used as a configuration data item in one or more defined Environment Configurations. When connected to the Workspace and using an environment configuration that does not control the use of schematic templates, you are free to manually choose a revision of a schematic template. To do so, use the Design » Sheet Templates » Set Template from server command. This presents the Choose Template dialog, from where you can browse to, and select the required template in the Workspace.

Use the Set Template from server command to manually reuse (and switch between) schematic templates that are available to you.
Use the Set Template from server command to manually reuse (and switch between) schematic templates that are available to you.

You are also free to use local schematic templates in addition to using those from your Workspace, should this be required.
For more information, see Environment Configuration Management (Altium 365 Workspace, Enterprise Server Workspace).

Updating a Template

To update a Workspace schematic template being currently used in the active schematic sheet to the latest revision of the associated Schematic Template Item (or to refresh the local template that may have had its information changed in some way), use the  button next to the Template drop-down in the Properties panel in its Document Options mode or select the Design » Sheet Templates »  Update Current Template command from the main menus.

Removing a Template from the Schematic Sheet

To remove the current schematic template used, choose the Design » Sheet Templates » Remove Current Template command from the main menus. After launching the command, the Remove Template Graphics dialog will open.

The Remove Template Graphics dialog
The Remove Template Graphics dialog

Use this dialog to define from which documents the current template will be removed - either the current document only, all schematic documents in the current (active) project (schematics that are currently closed will be opened), or all open schematic documents (regardless of parent project). After using this command, the entry for the currently used template will be blank.

When removing the current template from all schematic documents in the current project, all documents that are currently closed will be opened as the removal is performed. When removing the current template from all open schematic documents, it is removed regardless of the project to which a document belongs.

Alternatively, remove use of the template by switching to a different Formatting and Size mode (Standard or Custom) in the Properties panel.

Document-level Parameters

Document-level parameters can be configured for each schematic document. The document parameters are defined in the Document Options mode of the Properties panel. This mode is accessed when no objects are selected in the schematic. The Parameters tab of the panel is where you add, edit or delete parameters for the schematic. Use the buttons above the list of parameters to display only parameters in the list, as shown in the image below.

Adding a parameter is done by clicking the Add button and then selecting Parameter as shown in the image below. A new parameter named Parameter n will appear in the list. Click on the name then enter the desired parameter name. Click in the Value column then enter the desired value of the parameter.

To edit a parameter's value, click the cell in the Value column then edit as needed.

To delete a parameter, select it in the list then click . Within the panel, you will be asked to confirm the deletion by clicking Yes to delete or No to cancel the deletion. You can select one or more parameters in the list to delete at one time.

Properties Panel

When the active document is a schematic document (*.SchDoc) and no design object is selected in the design space, the Properties panel presents the Document Options.

The following collapsible sections contain information about the options and controls available under the panel's General tab:

The options in this section of the panel determine which schematic objects may be selected in the design space.

  • All - On button – select to remove object filtering so that all types of objects may be selected.
  • Object buttons – toggle each object button to enable/disable the ability to select that object type.

  • Units – select the desired unit. Choose either mm or mils.

    You can quickly verify the active units from the Status Bar, by looking at the Grid entry at the left-hand end of the bar.
    To toggle between the use of mils and mm measurement units for the active schematic sheet, you can also use the View » Toggle Units command from the main menus.
  • Visible Grid – enter the desired grid. Use the or to show/hide the grid in the design space.
  • Snap Grid – check the box to enable snap grids. Enter the desired grid in the text box or use the G shortcut to cycle through the different grids.
    • Snap to Electrical Object Hotspots – enable to use the snap grid to snap to an object's electrical hotspots or use the Shift+E shortcut.
  • Snap Distance – when the cursor is within this distance from an enabled object snap point (and snapping is enabled for the active layer), the cursor will snap to that point.
  • Document Font – set the font size, style and any additional font attributes that will be used for the text associated with all objects in the document sheet. For any given object, the font settings may be overridden in its corresponding Properties panel mode, which is enabled when that object is selected.
  • Sheet Border – check the box to enable a sheet border then click the colored box to change the border color.
  • Sheet Color – click the colored box to change the sheet color.

  • Formatting and Size
    • Template mode – set the page size and format by selecting from a range of predefined schematic sheet templates. A schematic template is a document that holds user-defined sheet size, border and title block descriptions that can be referenced by (linked to) a schematic sheet negating the need to define these common attributes again and again. The list includes local and Workspace templates found in the location specified in the Data Management – Templates page of the Preferences dialog. Note that a default schematic sheet to be used for new schematic documents can be defined on that page of the Preferences dialog.
      • Template – use the drop-down menu to select from a list of Workspace and local templates, and if required, use the button to refresh the template that may have had its information changed in some way.
      • Width/Height – the dimensions of the current page size shown in the current document units (see the General section above).
    • Standard mode – set the sheet size to a standard page format.
      • Sheet Size – use the drop-down menu to select from a list of standard page dimensions.
      • Width/Height – the dimensions of the current page size in the current document units.
      • Orientation – use the drop-down to select the desired orientation.
      • Title Block – enable this option to display one of two predefined title blocks on the schematic sheet. Use the associated drop-down to choose from either a Standard or ANSI title block style.
    • Custom mode – set the sheet size to specified custom dimensions.
      • Width – enter the required sheet width measurement.
      • Height – enter the required sheet height measurement.
      • Orientation – use the drop-down to select the desired orientation.
      • Title Block – enable this option to display one of two predefined title blocks on the schematic sheet. Use the associated drop-down field to choose from either a Standard or ANSI title block style.
  • Margin and Zones – defines the size of the sheet border graphics and its zone divisions. Uncheck the Show Zones box to hide the zone divisions in the border graphics.
    • Vertical – set the number of divisions (rows) in the vertical sheet margin. The alpha-numeric zone labeling type is defined by the Origin setting.
    • Horizontal – set the number of divisions (columns) in the horizontal sheet margin.
    • Origin – sets which corner of the document sheet(s) the perimeter zone alpha-numeric indicators will begin from (zone position A-1 or 1-A).
    • Margin Width – set the distance (in the current units) between the page edge and each of the four border lines as indicated by the arrows associated with each entry field.

The following collapsible section contains information about the options and controls available under the panel's Parameters tab:

The Properties panel Parameters tab lists all available Parameters and Rules available in the current project document.

When using the Constraint Manager functionality, note that rules added in the Properties panel will not be detected and transferred when updating the PCB from the schematic. Only the design rules defined in the Constraint Manager will be transferred.
  • All button – select to view both Parameters and Rules.
  • Parameters button – select to only view Parameters.
  • Rules button – select to only view Rules.
  • Parameters
    • Name and Value columns – lists the available parameters grouped by type.

    When the same parameter exists in more than one location (Variant, Document, Project) and the Document parameter has no value, the parameter's value is inherited from the highest priority parameter that has a value (the parameter value defined in the schematic document overrides the value defined in the project options; the value defined in the variant overrides the value defined in the schematic document). When a Document parameter value is inherited (is being sourced from a Variant or Project parameter of the same name), the value is displayed in the Properties panel in gray italics, indicating that the parameter value is inherited. The Document parameter value can still be edited, as required.

    The following parameters are reserved for internal use:

    • ConfigurationParameters
    • IsUserConfigurable

    While these parameters are not shown in the list, it is not possible to add user-defined parameters with these names. 

  • Rules
    • Name and Value columns – these list the current specified rules and their values.
  • Add – use the drop-down menu to select to add a Parameter or a Rule. Selecting to add a new Rule will open the Choose Design Rule Type dialog to specify the type of rule to be used when adding a parameter as a rule to a supported design object in the schematic domain or a schematic document.
  • – only accessible when a rule is selected. Click to open the Edit PCB Rule dialog to edit the selected rule.
  • – click to delete the currently selected parameter or rule.

When a design object is selected, the panel will present options specific to that object type. The following table lists the object types available for placement on a schematic sheet – click a link to access the properties page for that object.

Arc Bezier
Blanket Bus
Bus Entry Comment
Compile Mask Designator
Ellipse Graphic
Generic Component Harness Connector
Harness Connector Type Harness Entry
Net Label No ERC
Note Offsheet Connector
Parameter Parameter Set
Part Polygon
Polyline Port
Power Object Probe
Rectangle Round Rectangle
Sheet Entry Sheet Symbol
Sheet Symbol Designator Sheet Symbol Filename
Signal Harness Text Frame
Text String Wire
Pin  
Found an issue with this document? Highlight the area, then use Ctrl+Enter to report it.

お問合せ

お近くの営業所にお問合せください。

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
You are reporting an issue with the following selected text
and/or image within the active document: