Database Library Migration Tools
W skrócie
- Dowiedz się, kiedy używać biblioteki DbLib, a kiedy SVNDbLib.
- Naucz się konfigurować kreatory konwersji, wybierać biblioteki źródłowe oraz określać docelowe bazy danych i repozytoria.
- Poznaj istotne wymagania i ograniczenia, w tym obsługę konwersji wyłącznie do baz danych Access, przygotowanie repozytorium SVN oraz obsługę powiązań z modelami.
Oprogramowanie projektowe Altium umożliwia umieszczanie komponentów bezpośrednio z firmowej bazy danych poprzez utworzenie i używanie biblioteki bazodanowej. Typ używanej biblioteki bazodanowej zależy od sposobu zarządzania źródłowymi bibliotekami symboli i modeli. Jeśli biblioteki mają być przechowywane na dysku twardym lub dysku sieciowym, wystarczy użyć biblioteki bazodanowej (DbLib). Jeśli natomiast chcesz objąć biblioteki kontrolą wersji przy użyciu repozytorium Subversion, użyj biblioteki bazodanowej SVN (SVNDbLib).
Niezależnie od typu używanej biblioteki bazodanowej podstawowa zasada działania tej funkcji pozostaje taka sama — umożliwia ona umieszczanie komponentów bezpośrednio z powiązanej zewnętrznej bazy danych. Aby maksymalnie ułatwić korzystanie z tej rozbudowanej funkcji, dostępne są narzędzia pozwalające szybko przenieść istniejące biblioteki do struktury biblioteki bazodanowej. Narzędzia te umożliwiają migrację:
- Z biblioteki zintegrowanej do biblioteki bazodanowej (DbLib lub SVNDbLib).
- Z biblioteki bazodanowej (DbLib lub SVNDbLib) do biblioteki zintegrowanej.
- Ze źródłowych bibliotek schematowych/PCB do biblioteki bazodanowej SVN.
- Z biblioteki bazodanowej do biblioteki bazodanowej SVN.
- Z systemu OrCAD Component Information System (CIS) do biblioteki bazodanowej (DbLib).
W kolejnych sekcjach szczegółowo opisano sposób przeprowadzania tych migracji w oprogramowaniu.
Tworzenie biblioteki bazodanowej z biblioteki zintegrowanej
Biblioteki zintegrowane są z natury bezpieczne. Dodatkowo doskonale nadają się do przenoszenia projektów przekazywanych poza firmę. Jeśli projekt ma pozostać w firmie i/lub chcesz ściśle powiązać komponenty Altium Design z firmową bazą danych, biblioteki bazodanowe są idealnym wyborem. Oprogramowanie umożliwia szybkie przekształcenie firmowych bibliotek zintegrowanych w strukturę biblioteki bazodanowej (DbLib) lub biblioteki bazodanowej SVN (SVNDbLib). Konwersja może obejmować wiele bibliotek zintegrowanych, z których każda zostanie dodana jako osobna tabela do docelowej bazy danych.
Konwersja do DbLib
Tworzenie standardowej biblioteki bazodanowej (DbLib) z biblioteki zintegrowanej (IntLib) odbywa się za pomocą kreatora Integrated Library to Database Library Translator Wizard. Kreator dekompiluje wskazane biblioteki zintegrowane, a następnie na podstawie każdej z nich tworzy osobną tabelę w wybranej docelowej bazie danych, wraz z informacjami o parametrach i modelach wyodrębnionymi z zawartych w niej komponentów. Wskazany plik biblioteki bazodanowej służy następnie do zapewnienia połączenia z tą bazą danych.
Przeniesienie jednej lub kilku źródłowych bibliotek zintegrowanych do struktury biblioteki bazodanowej jest prostym procesem realizowanym za pomocą kreatora Integrated Library to Database Library Translator Wizard.
Proces obejmuje następujące kroki:
- Utwórz nowy lub otwórz istniejący plik biblioteki bazodanowej (*.DbLib). Istniejącego pliku DbLib używa się zazwyczaj podczas konwersji jednej lub kilku bibliotek zintegrowanych do istniejącej bazy danych Access, z którą ten plik DbLib jest obecnie połączony.
- Gdy plik biblioteki bazodanowej (*.DbLib) jest otwarty jako aktywny dokument, wybierz polecenie Tools » Import From Integrated Libraries z menu głównego, aby uruchomić kreator Integrated Library to Database Library Translator Wizard.
-
Na początkowej stronie Specify your Database details kreatora wskaż docelową bazę danych — nową lub istniejącą bazę danych Access. Jeśli tworzysz nową bazę danych, kliknij ikonę folderu po prawej stronie pola Database Location, aby otworzyć standardowe okno dialogowe Open . W tym oknie określ, gdzie i pod jaką nazwą ma zostać utworzona nowa baza danych. Wybrana nazwa i ścieżka zostaną wprowadzone w polu Database Location.
-
Na kolejnej stronie Specify your Target Database Library kreatora wskaż docelowy plik biblioteki bazodanowej. Podaj ścieżkę i nazwę nowego pliku DbLib, który ma zostać utworzony, lub odszukaj i otwórz istniejący plik. Istniejącego pliku DbLib używa się zazwyczaj podczas konwersji jednej lub kilku bibliotek zintegrowanych do istniejącej bazy danych Access, z którą ten plik DbLib jest obecnie połączony. Domyślnie pole zostanie wstępnie wypełnione danymi aktywnego pliku DbLib.
-
Na następnej stronie Locate the Integrated Libraries to Import kreatora wskaż biblioteki zintegrowane, które chcesz przekonwertować. Użyj przycisku Add, aby otworzyć okno dialogowe Select Source Integrated Libraries, w którym możesz odszukać i wybrać wymagane biblioteki. Składowe biblioteki symboli schematowych i modeli (jeśli istnieją) zostaną wyodrębnione i zapisane w lokalizacji wskazanej w polu Destination Folder. Użyj przycisków Remove i Clear , aby usunąć wybraną bibliotekę z listy lub z dysku.
-
Po wybraniu źródłowych bibliotek zintegrowanych kliknij Next, aby rozpocząć konwersję. Zostanie wyświetlony pasek postępu wraz z informacjami o aktualnie konwertowanej bibliotece. Po zakończeniu konwersji kliknij Finish na ostatniej stronie kreatora, aby uaktywnić wskazany plik DbLib w głównym oknie projektowym (jeśli nie jest jeszcze aktywny).

Wynikowy plik DbLib po zakończeniu procesu konwersji.
Po zakończeniu konwersji możesz otworzyć źródłowe biblioteki schematowe i usunąć z symboli wszystkie informacje o parametrach i modelach. Następnie możesz w razie potrzeby dostosować konfigurację mapowania pól w dokumencie DbLib, aby odwoływały się do odpowiednich kolumn bazy danych. Więcej informacji znajdziesz w sekcji Mapowanie pól bazy danych na parametry projektu na stronie Tworzenie i definiowanie biblioteki bazodanowej.
Konwersja do SVNDbLib
Tworzenie biblioteki bazodanowej z kontrolą wersji (SVNDbLib) na podstawie biblioteki zintegrowanej (IntLib) odbywa się za pomocą SVN Database Library Conversion Wizard. Kreator zasadniczo dekompiluje wskazane biblioteki zintegrowane — każda z nich służy do utworzenia osobnej tabeli w nowej docelowej bazie danych wraz z informacjami o parametrach i modelach wyodrębnionymi z zawartych w niej komponentów. Następnie tworzony jest wskazany plik biblioteki bazodanowej SVN, który zapewnia połączenie z tą bazą danych. Składowe biblioteki schematów i PCB są dzielone i zatwierdzane we wskazanych katalogach wybranego repozytorium kontroli wersji SVN, do których odwołuje się plik SVNDbLib.
Przenoszenie jednej lub większej liczby źródłowych bibliotek zintegrowanych do struktury biblioteki bazodanowej SVN jest prostym procesem, realizowanym za pomocą SVN Database Library Conversion Wizard.
Proces obejmuje następujące kroki:
- Otwórz SVN Database Library Conversion Wizard. Możesz to zrobić na jeden z poniższych sposobów:
- Wybierz polecenie Tools » SVN Database Library Maker z menu głównego edytora bibliotek schematów, edytora bibliotek PCB lub edytora bibliotek bazodanowych.
- W panelu Projekty kliknij prawym przyciskiem myszy pozycję biblioteki projektu (SchLib, PcbLib lub IntLib), a następnie wybierz polecenie SVN Database Library Maker z menu kontekstowego.
- Na stronie Libraries to Convert wskaż biblioteki zintegrowane, które chcesz przekonwertować. Lista będzie początkowo zawierać jedną lub więcej bibliotek (aktywną bibliotekę lub wszystkie biblioteki projektu dodane do projektu — zależnie od sposobu uruchomienia kreatora). Usuń je z listy przed wybraniem bibliotek zintegrowanych do konwersji. Użyj przycisku Add, aby otworzyć okno dialogowe Library Files, w którym możesz odszukać i wybrać wymagane biblioteki zintegrowane.
-
Na stronie Options określ opcje konwersji, w tym sposób podziału bibliotek źródłowych, katalogi i repozytorium, w których mają być przechowywane, oraz katalog wyjściowy dla pliku SVNDbLib. W przypadku biblioteki schematów dostępne są również dwie opcje umożliwiające usunięcie informacji o parametrach i/lub modelach z każdego komponentu tak, aby pozostał sam symbol.
-
Po wybraniu źródłowych bibliotek zintegrowanych i odpowiednim ustawieniu opcji konwersji kliknij Next , aby rozpocząć konwersję. Zostanie wyświetlony pasek postępu wraz z informacją o aktualnie konwertowanej bibliotece. Proces konwersji obejmuje:
- Wyodrębnienie bibliotek źródłowych z dostarczonych bibliotek zintegrowanych.
- Podział bibliotek schematów i PCB na pliki bibliotek zawierające pojedyncze symbole lub footprinty.
- Zatwierdzenie podzielonych bibliotek symboli i footprintów w repozytorium we wskazanych katalogach bazowych.
- Kreator wyodrębnia wyłącznie informacje o odwołaniach do modeli footprintów. Biblioteka bazodanowa z kontrolą wersji (SVNDbLib) obsługuje powiązane modele symulacyjne, ale przechowywanie plików modeli symulacyjnych w repozytorium Subversion nie jest obsługiwane. Jeśli takie powiązania istnieją, zostaną dodane jako parametry.
- Utworzenie osobnej tabeli w wygenerowanej bazie danych Access (o takiej samej nazwie jak nazwa określona dla pliku SVNDbLib) dla każdej konwertowanej biblioteki zintegrowanej, wraz z informacjami o parametrach i modelach wyodrębnionymi z zawartych w niej komponentów. Każda tabela otrzymuje nazwę biblioteki zintegrowanej z przyrostkiem _IntLib (np. Capacitor - Ceramic_IntLib).
- Utworzenie wskazanego pliku SVNDbLib i połączenie go z bazą danych oraz repozytorium.
- Po zakończeniu konwersji kliknij Finish , aby zamknąć kreator i ustawić plik SVNDbLib jako aktywny dokument.
Wynikowy plik SVNDbLib po zakończeniu procesu konwersji.
Tworzenie biblioteki zintegrowanej na podstawie biblioteki bazodanowej
Biblioteki bazodanowe są idealnym wyborem, jeśli chcesz, aby komponenty projektowe Altium były ściśle powiązane z firmową bazą danych. Jeśli projekt musi zostać przekazany poza firmę lub wolisz, aby projektanci pracowali z bezpiecznymi bibliotekami zintegrowanymi, możesz to łatwo osiągnąć. Oprogramowanie umożliwia skompilowanie biblioteki zintegrowanej bezpośrednio z biblioteki bazodanowej — standardowej biblioteki bazodanowej (DbLib) lub biblioteki bazodanowej SVN z kontrolą wersji (SVNDbLib). Dzięki temu osoby zarządzające bibliotekami CAD mogą nadal korzystać z bibliotek bazodanowych, a projektanci — z regularnie generowanych bibliotek zintegrowanych, pracując niejako w trybie „offline”.
Konwersja odbywa się za pomocą Offline Integrated Library Maker. Proces jest realizowany osobno dla każdej tabeli bazy danych z pełną kontrolą nad tym, które tabele mają zostać uwzględnione. Konwersja obejmuje komponenty schematów oraz modele PCB, PCB3D i modele symulacyjne. Dla każdej uwzględnionej tabeli zostanie wygenerowana osobna biblioteka zintegrowana. Tabele te są przekształcane w oddzielne biblioteki zintegrowane, które następnie są dodawane do Installed Libraries.

Konwertuj biblioteki bazodanowe (DbLib lub SVNDbLib) na biblioteki zintegrowane do pracy „offline” za pomocą Offline Integrated Library Maker.
Proces obejmuje następujące kroki:
- Gdy plik biblioteki bazodanowej (*.DbLib) lub biblioteki bazodanowej SVN (*.SVNDbLib), który chcesz przekonwertować, jest otwarty jako aktywny dokument, wybierz polecenie Tools » Offline Integrated Library Maker z menu głównego, aby otworzyć Offline Integrated Library Maker.
-
Na stronie Library to Convert wskaż bibliotekę DbLib lub SVNDbLib do przetworzenia. Aktywna biblioteka, z której uruchomiono Offline Integrated Library Maker , zostanie domyślnie wskazana jako biblioteka do konwersji. W razie potrzeby możesz odszukać i wybrać inną bibliotekę bazodanową.
-
Na stronie Options określ, które tabele z powiązanej bazy danych mają zostać uwzględnione w konwersji. Domyślnie uwzględniane są wszystkie tabele bazy danych. Aby wykluczyć tabelę, upewnij się, że odpowiadająca jej opcja Convert jest wyłączona. Na tej stronie możesz również wskazać katalog wyjściowy, w którym będą przechowywane wygenerowane biblioteki zintegrowane. Wprowadź ścieżkę do tego katalogu bazowego bezpośrednio lub kliknij ikonę
po prawej stronie pola, aby otworzyć okno dialogowe, w którym możesz odszukać i wybrać wymagany katalog. Wygenerowany wynik (biblioteka zintegrowana) dla każdej uwzględnionej tabeli bazy danych zostanie zapisany w osobnym podfolderze wskazanego katalogu wyjściowego, nazwanym zgodnie z nazwą tabeli.
- Po wybraniu biblioteki bazodanowej i odpowiednim skonfigurowaniu opcji konwersji kliknij Next , aby rozpocząć konwersję. Zostanie wyświetlony pasek postępu wraz z informacją o aktualnie konwertowanej tabeli bazy danych. Pamiętaj, że proces konwersji jest wykonywany dla każdej tabeli bazy danych wybranej do konwersji. Poniżej przedstawiono przebieg tego procesu:
- Tworzony jest pakiet biblioteki zintegrowanej (*.LibPkg), który następnie zostaje otwarty w panelu Projects. Pakiet otrzymuje nazwę tabeli. Na przykład dla tabeli o nazwie Capacitor - Ceramic będzie to Capacitor - Ceramic.LibPkg.
- Tworzony jest dokument biblioteki schematowej, który następnie zostaje dodany do pakietu LibPkg. On również otrzymuje nazwę tabeli (np. Capacitor - Ceramic.SchLib).
- Następnie przetwarzany jest każdy rekord tabeli i tworzony jest odpowiedni komponent Altium Design. W tym celu wskazany symbol schematowy jest pobierany z odpowiedniej biblioteki źródłowej i dodawany jako komponent do nowego dokumentu biblioteki schematowej. Następnie do tego komponentu dodawane są parametry i informacje o powiązaniach z modelami zdefiniowane w rekordzie.
- Modele obudów PCB wskazane w rekordzie są pobierane i dodawane do dokumentu biblioteki PCB. Ten dokument również otrzymuje nazwę tabeli (np. Capacitor - Ceramic.PcbLib). Następnie dokument biblioteki PCB jest dodawany do pakietu LibPkg.
- Jeśli biblioteką źródłową jest DbLib, a w rekordzie bazy danych zdefiniowano powiązania z modelami symulacyjnymi, wskazane pliki modeli symulacyjnych są również dodawane do pakietu LibPkg. Lokalizacja tych modeli pozostaje bez zmian. Pełna ścieżka do modelu jest określona w odpowiadającym mu powiązaniu.
- Następnie pakiet LibPkg jest kompilowany w celu utworzenia biblioteki zintegrowanej (np. Capacitor - Ceramic.IntLib), która zostaje dodana do bibliotek zainstalowanych w oprogramowaniu.

Wyniki procesu konwersji — projekty pakietów bibliotek wraz z dokumentami symboli i modeli obudów PCB oraz skompilowane biblioteki IntLib, które są również dodawane jako biblioteki zainstalowane, dzięki czemu są dostępne we wszystkich projektach PCB.
Tworzenie biblioteki SVNDbLib z bibliotek źródłowych (SCHLib/PCBLib)
SVN Database Library Conversion Wizard pomaga konwertować biblioteki schematowe, PCB, bazodanowe i zintegrowane na biblioteki bazodanowe SVN. Kreator ten usprawnia przejście z różnych metod zarządzania komponentami na bibliotekę bazodanową SVN (*.SVNDBLib). Biblioteka bazodanowa SVN rozszerza możliwość umieszczania komponentów bezpośrednio z bazy danych o obsługę bibliotek objętych kontrolą wersji — symbole schematowe i modele obudów PCB są przechowywane w repozytorium opartym na systemie Subversion. Powiązanie z repozytorium i zewnętrzną bazą danych jest zdefiniowane w pliku biblioteki bazodanowej SVN (*.SVNDBLib), który stanowi rozszerzenie pliku biblioteki bazodanowej (*.DBLib) i jest często określany jako Version-Controlled Database Library.
Za pomocą kreatora zdefiniuj opcje konwersji, w tym sposób podziału bibliotek źródłowych, katalogi i repozytorium, w których mają być przechowywane, oraz katalog wyjściowy pliku SVNDBLib.
Należy wybrać biblioteki bazodanowe, schematowe (*.SchLib), PCB (*.PcbLib) lub zintegrowane (*.IntLib) do konwersji. Zostaną one następnie przesłane do repozytorium SVN. Utworzona zostanie również jedna biblioteka bazodanowa SVN.
Ten kreator umożliwia zdefiniowanie połączenia z repozytorium SVN, katalogu bazowego symboli i modeli oraz ścieżki do dokumentu biblioteki bazodanowej SVN. Domyślnie katalog wyjściowy jest ustawiony na katalog, w którym przechowywana jest biblioteka źródłowa.
Jeśli wygenerowany plik SVNDBLib i baza danych mają znajdować się w tej samej lokalizacji, dostępne są zasadniczo dwie możliwości. Pierwsza polega na ustawieniu ścieżki wyjściowej pliku SVNDBLib na katalog, w którym obecnie znajduje się baza danych. Druga to wygenerowanie pliku SVNDBLib w innym katalogu, a następnie przeniesienie bazy danych do tego katalogu. W takim przypadku należy pamiętać o zmodyfikowaniu połączenia w pliku SVNDBLib tak, aby wskazywało nową lokalizację bazy danych, a następnie o ponownym nawiązaniu połączenia.
Przeniesienie jednej lub większej liczby źródłowych bibliotek schematowych i PCB do struktury biblioteki bazodanowej SVN jest prostym procesem z wykorzystaniem SVN Database Library
Conversion Wizard.
Proces obejmuje następujące kroki:
-
Otwórz SVN Database Library Conversion Wizard w jeden z następujących sposobów:
- Kliknij Tools » SVN Database Library Maker z poziomu pliku biblioteki schematowej (*.SchLib), pliku biblioteki PCB (*.PcbLib), pliku biblioteki zintegrowanej (*.IntLib) lub pliku biblioteki bazodanowej (*.DbLib). Jeśli jednak uruchamiasz kreator z poziomu biblioteki schematowej i chcesz uwzględnić w konwersji powiązane modele obudów PCB, musisz odszukać i dodać odpowiednie biblioteki obudów PCB. Ponadto konwersja samych bibliotek obudów PCB nie jest typowym scenariuszem, dlatego należy odszukać i dodać odpowiednie biblioteki komponentów schematowych.
- W panelu Projects kliknij prawym przyciskiem myszy pozycję odpowiadającą wymaganej bibliotece (*.SchLib, *.PcbLib lub *.IntLib), a następnie wybierz SVN Database Library Maker. Kreator automatycznie wczyta wszystkie biblioteki projektu. Jest to zdecydowanie najprostsza metoda, ale wymaga dodania źródłowych bibliotek schematowych i PCB do projektu. Często ma to miejsce, gdy nie korzystano z bibliotek zintegrowanych.
-
Na stronie Libraries to Convert wybierz biblioteki, które chcesz przekonwertować. Możesz wybrać biblioteki bazodanowe albo biblioteki schematowe, PCB i zintegrowane. Wybrane biblioteki zostaną podzielone na biblioteki pojedynczych komponentów, a następnie przesłane do repozytorium SVN. Zostanie utworzona jedna baza danych SVN.
-
Converting a Database Library
Podczas konwersji Database Libraries proces obejmuje:
- Podział bibliotek schematowych i bibliotek PCB wskazywanych przez rekordy komponentów w połączonej bazie danych na pliki bibliotek zawierające pojedyncze symbole lub footprinty.
- Zatwierdzenie wydzielonych bibliotek symboli i footprintów w repozytorium, we wskazanych katalogach bazowych.
- Utworzenie wskazanego pliku SVNDBLib i połączenie go z bazą danych oraz repozytorium.
-
Converting Schematic, PCB, and Integrated Libraries
Użyj przycisku Add, aby otworzyć standardowe okno dialogowe umożliwiające wyszukanie i wybranie pliku do dodania. Kliknij przycisk Remove , aby usunąć aktualnie wybraną bibliotekę.
Podczas konwersji bibliotek schematowych, PCB i zintegrowanych proces obejmuje:
- Wyodrębnienie bibliotek źródłowych ze wszystkich dostarczonych bibliotek zintegrowanych.
- Podział bibliotek schematowych i bibliotek PCB na pliki bibliotek zawierające pojedyncze symbole lub footprinty
- Zatwierdzenie wydzielonych bibliotek symboli i footprintów w repozytorium we wskazanych katalogach bazowych.
- Kreator wyodrębni wyłącznie informacje o odwołaniach do modeli footprintów. Powiązane modele PCB3D i modele symulacyjne nie są obsługiwane w bibliotekach SVNDBLib. Jeśli takie powiązania istnieją, zostaną dodane jako parametry.
- Utworzenie osobnej tabeli w wygenerowanej bazie danych Access dla każdej konwertowanej biblioteki schematowej i/lub zintegrowanej, wraz z informacjami o parametrach i modelach wyodrębnionymi z komponentów. Każda tabela otrzymuje nazwę biblioteki schematowej z przyrostkiem _SchLib(np. Mixer_SchLib) i/lub nazwę biblioteki zintegrowanej z przyrostkiem _IntLib (np. AD Differential Amplifier_IntLib).
- Utworzenie wskazanego pliku SVNDBLib i połączenie go z bazą danych oraz repozytorium.
-
-
Na stronie Options określ opcje konwersji, w tym sposób podziału bibliotek źródłowych, katalogi i repozytorium, w których mają być przechowywane, oraz katalog wyjściowy pliku SVNDbLib. W przypadku biblioteki schematowej dostępne są również dwie opcje umożliwiające usunięcie informacji o parametrach i/lub modelach z każdego komponentu, tak aby pozostał tylko sam symbol.
SVN Options
W tej sekcji określ ustawienia połączenia z repozytorium SVN.
Z listy rozwijanej Method wybierz metodę połączenia: file (repozytorium oparte na plikach), http (repozytorium w chmurze), https (bezpieczne repozytorium w chmurze), svn lub svn+ssh.
Sekcja Location (dostępna tylko wtedy, gdy dla Method wybrano file) służy do ustawienia ścieżki do repozytorium. Użyj ikony przeglądania folderów, aby wyszukać i wybrać odpowiednią lokalizację.
Sekcja Server (dostępna tylko wtedy, gdy dla Method wybrano file not) służy do ustawienia odpowiedniego serwera.
Ustaw Server Port na Default lub Non-Default. Jeśli wybrano Non-Default, wpisz port serwera w polu tekstowym. W odpowiednim polu tekstowym należy również wprowadzić nazwę Repository folder.
Wskaż katalog bazowy repozytorium dla Symbols i Footprints, klikając ..., aby wyszukać i wybrać odpowiednie foldery dla obu pozycji.
SVN DB Library Options
Sekcja SVN DB Library Options umożliwia określenie ścieżki do dokumentu biblioteki bazodanowej SVN. Jeśli baza danych Access stanowiąca zaplecze biblioteki jeszcze nie istnieje, zostanie utworzona w tym samym folderze. Użyj ikony przeglądania folderów, aby wyszukać i wybrać ścieżkę.
Library Splitting Options
Z listy rozwijanej wybierz, czy pliki mają być Overwrite Existing Files, czy Append Incrementing Number To File Names (aby podczas podziału bibliotek tworzyć nowe pliki z dodanym przyrostkiem). Gdy wybrano Overwrite Existing Files, wszystkie istniejące pliki w repozytoriach zostaną nadpisane podczas podziału bibliotek. Jeśli wybrano Append Incrementing Number To File Names, wszystkie pliki we wskazanych repozytoriach będą chronione przed nadpisaniem, a do nazw nowych bibliotek komponentów o tych samych nazwach zostanie dodany przyrostek „
_#IncrementNumber”.W przypadku biblioteki schematowej dostępne są również dwie opcje umożliwiające usunięcie informacji o parametrach i/lub modelach z wydzielonych komponentów schematowych, tak aby pozostał tylko sam symbol. Wybierz Remove All Parameters i/lub Remove All Models. Ponieważ zewnętrzna baza danych już istnieje i jest połączona z oryginalnym plikiem DBLib, nowa baza nie zostanie utworzona. Baza danych pozostanie w dotychczasowej lokalizacji.
-
Po wybraniu źródłowych bibliotek schematowych i bibliotek PCB oraz ustawieniu odpowiednich opcji konwersji kliknij Next , aby rozpocząć konwersję. Zostanie wyświetlony pasek postępu wraz z informacjami o aktualnie konwertowanej bibliotece. Proces konwersji obejmuje:
- Podział bibliotek schematowych i bibliotek PCB na pliki bibliotek zawierające pojedyncze symbole lub footprinty.
- Zatwierdzenie wydzielonych bibliotek symboli i footprintów w repozytorium, we wskazanych katalogach bazowych.
- Kreator wyodrębni wyłącznie informacje o odwołaniach do modeli footprintów. Powiązane modele symulacyjne są obsługiwane w bibliotece bazodanowej objętej kontrolą wersji (SVNDbLib), jednak przechowywanie plików modeli symulacyjnych w repozytorium Subversion nie jest obsługiwane. Jeśli takie powiązania istnieją, zostaną dodane jako parametry.
- Utworzenie osobnej tabeli w wygenerowanej bazie danych Access (o nazwie takiej samej jak nazwa określona dla pliku SVNDbLib) dla każdej konwertowanej biblioteki schematowej, wraz z informacjami o parametrach i modelach wyodrębnionymi z jej komponentów. Każda tabela otrzymuje nazwę biblioteki schematowej z przyrostkiem _SchLib (np. Capacitor - Ceramic_SchLib).
- Utworzenie wskazanego pliku SVNDbLib i połączenie go z bazą danych oraz repozytorium.
- Po zakończeniu konwersji kliknij Finish , aby zamknąć kreator i ustawić plik SVNDbLib jako aktywny dokument.
Wynikowy plik SVNDbLib po zakończeniu procesu konwersji.
Konwersja DbLib na SVNDbLib
Być może korzystasz już z możliwości bibliotek bazodanowych po przekonwertowaniu istniejących bibliotek zintegrowanych do struktury DbLib lub utworzeniu biblioteki DbLib od podstaw. Kolejnym krokiem może być przeniesienie źródłowych bibliotek symboli i footprintów do bezpiecznego repozytorium kontroli wersji. Oprogramowanie udostępnia narzędzia umożliwiające migrację z bieżącej standardowej biblioteki bazodanowej (DbLib) do biblioteki bazodanowej objętej kontrolą wersji (SVNDbLib).
Konwersję przeprowadza się za pomocą SVN Database Library Conversion Wizard w sposób bardzo podobny do konwersji biblioteki zintegrowanej.
Konwersja istniejącej standardowej biblioteki bazodanowej (DbLib) do biblioteki bazodanowej objętej kontrolą wersji (SVNDbLib) to prosty proces realizowany za pomocą SVN Database
Library Conversion Wizard.
Proces obejmuje następujące kroki:
- Otwórz istniejącą bibliotekę DbLib przeznaczoną do konwersji, a następnie wybierz Tools » SVN Database Library Maker z menu głównego. Otworzy się SVN Database Library Conversion Wizard.
-
Na stronie Libraries to Convert wskaż źródłową bibliotekę bazodanową, którą chcesz przekonwertować. Opcja Database Libraries będzie już włączona, a powiązane z nią pole będzie zawierać ścieżkę do aktywnej biblioteki. Jeśli chcesz przekonwertować inną bibliotekę DbLib, kliknij przycisk
i odszukaj ją w wyświetlonym oknie dialogowym.
- Po kliknięciu Next wybrany plik DbLib zostanie przeanalizowany i pojawi się okno potwierdzenia z informacją, że powiązana baza danych może zostać zmodyfikowana. Kliknij Yes , aby kontynuować.
- Na stronie Options określ opcje konwersji, w tym sposób podziału bibliotek źródłowych, katalogi i repozytorium, w których mają być przechowywane, oraz katalog wyjściowy pliku SVNDbLib. W przypadku biblioteki schematów dostępne są również dwie opcje umożliwiające usunięcie informacji o parametrach i/lub modelach z każdego zawartego w niej komponentu, tak aby pozostał sam symbol.
-
Po wybraniu źródłowego pliku DbLib i odpowiednim ustawieniu opcji konwersji kliknij Next , aby rozpocząć konwersję. Zostanie wyświetlony pasek postępu wraz z informacjami o konwertowanej bibliotece. Proces konwersji obejmuje:
- Podział bibliotek schematów i PCB, do których odwołują się rekordy komponentów w połączonej bazie danych, na pliki bibliotek zawierające pojedynczy symbol lub footprint.
- Zatwierdzenie podzielonych bibliotek symboli i footprintów w repozytorium we wskazanych katalogach bazowych.
- Utworzenie wskazanego pliku SVNDbLib i połączenie go z bazą danych oraz repozytorium.
- Po zakończeniu konwersji kliknij Finish , aby zamknąć kreator i ustawić plik SVNDbLib jako aktywny dokument.
Wynikowy plik SVNDbLib po zakończeniu procesu konwersji.
Kilka słów o mapowaniu pól
W wygenerowanej bibliotece SVNDbLib mapowania między polami bazy danych a parametrami projektu zdefiniowane na karcie Field Mappings pozostają takie same jak w oryginalnej bibliotece DbLib.
Mapowania pól w oryginalnej bibliotece DbLib i wygenerowanej bibliotece SVNDbLib pozostają takie same.
Należy jednak zwrócić uwagę na dwie ważne kwestie:
- Wszystkie zdefiniowane mapowania ścieżek do symboli i modeli footprintów są ignorowane. Biblioteka SVNDbLib używa wyłącznie zmapowanych pól odniesienia — [Library Ref] i [Footprint Ref] — do odnajdywania wymaganego symbolu i footprintu w bibliotekach zatwierdzonych w repozytorium. Informacje o ścieżkach zdefiniowane w bazie danych są ignorowane, ponieważ wskazują biblioteki znajdujące się na dysku twardym lub innym nośniku lokalnym bądź sieciowym.
- Wszystkie zdefiniowane mapowania modeli symulacyjnych również pozostaną w pliku SVNDbLib. Przechowywanie plików modeli symulacyjnych w repozytorium Subversion nie jest jednak obsługiwane. Chociaż podczas umieszczania instancji komponentu zostaną do niej dodane odnośniki do modeli, same modele nie zostaną odnalezione.
Bezpośrednia obsługa OrCAD® CIS
Oprogramowanie, oparte na systemie bibliotek bazodanowych, zapewnia pełną obsługę połączeń z istniejącymi systemami OrCAD Component Information System (CIS) oraz korzystania z nich. Struktura CIS jest zasadniczo konwertowana na strukturę standardowej biblioteki bazodanowej (DbLib) programu Altium Designer.
Z OrCAD do Altium Designer — wymagane konwersje
Aby umożliwić bezpośrednie umieszczanie komponentów z zewnętrznej bazy danych (*.mdb, *.xls), wymagane są następujące konwersje plików:
- Plik konfiguracyjny OrCAD CIS (*.dbc), który obsługuje połączenie z zewnętrzną bazą danych i zawiera informacje o mapowaniu pól bazy danych na parametry projektu, musi zostać przekonwertowany na plik biblioteki bazodanowej Altium Designer (*.DbLib).
-
Odpowiednie pliki bibliotek OrCAD muszą zostać przekonwertowane na pliki bibliotek Altium Designer:
- Biblioteka OrCAD Capture (*.olb) ---> Biblioteka schematów (*.SchLib).
- Plik biblioteki OrCAD Max (*.llb) ---> Biblioteka PCB (*.PcbLib).
Automatyczne tworzenie biblioteki bazodanowej
Najprostszą i najefektywniejszą metodą utworzenia pliku DbLib oraz źródłowych bibliotek Altium Designer jest użycie kreatora importu (File » Import Wizard). Na drugiej stronie kreatora upewnij się, że jako typ importowanego pliku wybrano pozycję OrCAD CIS Configuration Files and Libraries.
Przejdź przez kolejne strony kreatora, na których należy określić:
- Lokalizację zewnętrznej bazy danych.
- Lokalizację pliku konfiguracji CIS (*.dbc) — pamiętaj, że musi on mieć format binarny, a nie XML.
- Miejsce i nazwę, pod którą ma zostać utworzony docelowy plik DbLib.
- Biblioteki schematów i/lub PCB programu OrCAD, do których odwołuje się zewnętrzna baza danych.
Po wskazaniu wymaganych plików i katalogów źródłowych oraz docelowych kliknij Next, aby rozpocząć import. Po zakończeniu importu kliknij Finish , aby zamknąć kreator i ustawić plik DbLib jako aktywny dokument.

Wynikowy plik DbLib po zakończeniu procesu importu.

Wynikowy plik DbLib po zakończeniu procesu importu.
O czym należy pamiętać:
- Do pliku DbLib automatycznie dodawana jest ścieżka wyszukiwania bibliotek na karcie Symbol & Model Search Paths w oknie dialogowym Database Library Options. Wskazuje ona katalog zawierający przekonwertowane pliki bibliotek.
- Informacje o mapowaniu parametrów — w tym zdefiniowany klucz wyszukiwania — są pobierane bezpośrednio z pliku konfiguracji OrCAD CIS.
-
Automatycznie ustawiane są dwa wpisy mapowania modeli. Przykładowe nazwy pól bazy danych oraz przypisane im wpisy Design Parameter to:
- Footprint Name ---> [Orcad Footprint]
- Symbol Name ---> [Orcad Library]
Wpisy te zapewniają powiązanie danego rekordu komponentu w zewnętrznej bazie danych ze źródłowym symbolem schematowym oraz odpowiednim modelem obudowy PCB przypisanym do tego komponentu.
- W razie potrzeby określ opcje aktualizacji mapowanych parametrów. Więcej informacji można znaleźć w sekcji Mapowanie pól bazy danych na parametry projektu dokumentu Tworzenie i definiowanie biblioteki bazy danych.
Ręczne tworzenie biblioteki bazy danych
- Utworzenie pliku DbLib za pomocą Import Wizard jest najszybszą, ale nie jedyną metodą. Plik DbLib można również utworzyć ręcznie. W tym celu:
- Utwórz nowy plik DbLib, połącz go z zewnętrzną bazą danych i odpowiednio zdefiniuj mapowanie oraz opcje aktualizacji parametrów.
-
Następnie zaimportuj biblioteki OrCAD. Można to zrobić za pomocą Import Wizard, konwertując pliki bibliotek OrCAD (*.olb, *.llb) na biblioteki Altium Designer (*.SchLib, *.PcbLib).
-
Podczas wybierania typów plików do zaimportowania wybierz pozycję OrCAD Designs and Libraries Files.
-
Pomiń stronę dotyczącą Importing OrCAD Designs i przejdź do strony dotyczącej Importing OrCAD Libraries. Dodaj wszystkie biblioteki źródłowe OrCAD, do których odwołuje się baza danych.
-
Pomiń pozostałe kolejne strony dotyczące importowania plików projektu.
-
Na stronie Output Library Options pozostaw włączoną domyślną opcję Output Libraries as PCB Project.
-
Na stronie Output Libraries określ katalog wyjściowy dla wygenerowanych plików bibliotek.
-
- Po zakończeniu importu we wskazanym katalogu zostanie utworzony folder o nazwie Imported OrCAD Libraries.PrjPcb. W razie potrzeby można przenieść wygenerowane biblioteki Altium Designer do innej lokalizacji. Na przykład można przenieść biblioteki do folderu o nazwie Libraries, utworzonego w katalogu zawierającym plik DbLib.
- Gdy biblioteki symboli i obudów są już gotowe, wróć do pliku DbLib i skonfiguruj ścieżki wyszukiwania bibliotek (na karcie Symbol & Model Search Paths w oknie dialogowym Database Library Options) tak, aby wskazywały folder, w którym przechowywane są te biblioteki.
















