Linking to Supply Chain Data for Database and File-based Component Libraries

W skrócie

Korzystaj z aktualnych informacji od dostawców podczas projektowania z użyciem bazodanowych i plikowych bibliotek komponentów w Altium Designer. W tym artykule przedstawiono dostęp do danych dostawców w procesach projektowych opartych na bibliotekach SchLib, DbLib i SVNDbLib, wyjaśniono, jak skonfigurować preferencje dostawców, oraz omówiono panel Manufacturer Part Search, który umożliwia wyszukiwanie części i sprawdzanie informacji o cenach, stanach magazynowych i cyklu życia. Czytaj dalej, aby podejmować bardziej świadome decyzje dotyczące zaopatrzenia w komponenty w ramach procesu projektowego.

- Skonfiguruj preferowanych dostawców, regiony geograficzne i waluty na potrzeby wyszukiwania części.
- Korzystaj ze słów kluczowych, kategorii i filtrów parametrycznych, aby znaleźć odpowiednie części producentów.
- Sprawdzaj ceny u dostawców, dostępność i szczegółowe informacje o komponentach, aby ułatwić ich dobór i zakup.
Zagłęb się w temat dzięki AI:

Altium Designer umożliwia powiązanie komponentów projektu z rzeczywistymi częściami, zapewniając dostęp do aktualnych danych dostawców podczas projektowania. Dzięki bezpośredniemu połączeniu z usługami internetowymi Altium udostępniającymi dane komponentów można wyszukiwać części producentów i wybierać spośród obsługiwanych dostawców, którzy je oferują. Te aktualne dane dostawców można następnie wykorzystać w procesie projektowania — na etapie tworzenia bibliotek, podczas projektowania oraz przy wydawaniu projektu. Krótko mówiąc, funkcja ta zapewnia dostęp do baz danych dostawców z poziomu Altium Designer poprzez wyszukiwanie i wybieranie komponentów producentów do projektu.

Powiązane dane części i dostawcy zostaną również uwzględnione lub mogą zostać dodane do zestawienia materiałowego podczas wydawania projektu — jest to szczególnie przydatne przy szacowaniu kosztów projektu i zaopatrzeniu.

Możliwość powiązania z danymi dostawców not wymaga zalogowania się na konto Altium. Wyszukiwanie części producentów i dostawców odbywa się za pośrednictwem usług internetowych Altium. Jednak podczas wyświetlania cen w innych walutach kursy wymiany używane do przeliczania walut są odświeżane codziennie, pod warunkiem że are zalogowano się na konto.

W tym dokumencie opisano powiązania z danymi dostawców w metodach zarządzania komponentami, w których podstawą przechowywania komponentów są biblioteki SchLib, DbLib lub SVNDbLib. Jeśli korzystasz z połączonej przestrzeni roboczej — i komponentów przestrzeni roboczej — podobne, lecz odrębne i bardziej rozbudowane powiązanie między komponentem projektu a łańcuchem dostaw jest realizowane za pomocą mechanizmu Part Choices. Gdy funkcja Custom Parts Provider Synchronization jest włączona w Altium Designer (więcej informacji o zmianie zainstalowanych podstawowych funkcji znajdziesz na Installing & Managing stronie (Altium Designer Develop, Altium Designer Agile, Altium Designer)), połączona przestrzeń robocza zapewnia interfejs do dowolnego połączenia z bazą danych części skonfigurowanego w tej przestrzeni, na przykład połączenia z wewnętrzną bazą danych części firmy (bezpośrednio lub za pośrednictwem interfejsu ODBC bądź OLE-DB). Aby uzyskać dostęp do tych danych komponentów, musisz mieć połączenie z przestrzenią roboczą. Funkcja ta nie jest zatem dostępna w metodach zarządzania komponentami opartych na plikach ani nie dotyczy możliwości wiązania komponentów z danymi dostawców w tych metodach.

Więcej informacji o scentralizowanej konfiguracji dostawców w ramach instalacji Altium On-Prem Enterprise Server, w tym o konfigurowaniu interfejsu do bazy danych części, znajdziesz w sekcji Konfiguracja źródeł części.

Preferencje dostawców

Strona Zarządzanie danymi – Dostawcy części w oknie dialogowym Preferences stanowi centrum konfiguracji dostawców dostępnych podczas wyszukiwania danych części oraz innych opcji związanych z powiązaniami z danymi dostawców.

Skonfiguruj opcje funkcji powiązań z danymi dostawców w preferencjach Altium Designer.
Skonfiguruj opcje funkcji powiązań z danymi dostawców w preferencjach Altium Designer.

Użyj sekcji Altium Parts Options na tej stronie, aby dostosować usługę do swoich potrzeb.

Dostępne są następujące opcje:

  • Location – wybierz regiony geograficzne, z których usługa części będzie gromadzić dane. Chociaż wielu dostawców działa w wielu regionach, część dostępna wyłącznie w określonej lokalizacji pojawi się na liście tylko wtedy, gdy dany region jest włączony. Przeciągaj i upuszczaj pozycje lokalizacji na liście, aby ustalić kolejność ich priorytetów.

  • Currency – wybierz waluty międzynarodowe, które będą dostępne podczas wyszukiwania części i przeglądania wyników. Przeciągaj i upuszczaj ikony walut na liście, aby ustalić kolejność ich priorytetów.

  • Supplier – wybierz dostawców uwzględnianych podczas wyszukiwania danych dostawców. Zwracane będą wyłącznie wyniki dotyczące części od tych dostawców. Uwzględnienie większej liczby dostawców pozwala porównywać oferty i wybierać najkorzystniejsze warunki zakupu komponentów wymaganych w projekcie. Symbol w kolumnie Verified przy dostawcy oznacza, że Altium Parts Provider otrzymuje dane bezpośrednio od tego dostawcy.

Pamiętaj, że po zalogowaniu się na serwer obszar Altium Parts Options staje się dostępny tylko do odczytu i przyjmuje ustawienia zdefiniowane na serwerze. Wskazuje na to ikona obok nazwy strony w drzewie nawigacji.

Wyszukiwanie danych dostawców komponentów

Głównym interfejsem dostępu do dostępnych części producentów i powiązanych z nimi aktualnych danych dostawców jest panel Manufacturer Part Search. Panel oferuje zaawansowane funkcje wyszukiwania i znajdowania części oparte na kategoriach oraz filtrowaniu parametrycznym, a także pełni rolę bezpośredniego portalu do rzeczywistych części oferowanych przez dostawców włączonych dla tej funkcji. Aby otworzyć ten panel, wybierz View » Panels » Manufacturer Part Search z menu głównego lub opcję Manufacturer Part Search z menu przycisku w prawym dolnym rogu ekranu głównego.

Wyszukuj rzeczywiste pozycje z ofert dostawców za pomocą panelu Manufacturer Part Search.Wyszukuj rzeczywiste pozycje z ofert dostawców za pomocą panelu Manufacturer Part Search.

Jak pokazano, panel jest zasadniczo podzielony na trzy sekcje funkcjonalne:

  • Component Search, Type and Filtering:
    • W górnym polu Search wpisz co najmniej jedno słowo kluczowe związane z poszukiwanym komponentem. Zwrócone wyniki zawierają łącza do dostawców dla każdej wymienionej części producenta.
    • Użyj listy rozwijanej Categories (), aby ograniczyć wyniki do wybranego typu komponentu.
    • Zaznacz odpowiednie opcje parametrów w okienku Filters po lewej stronie (włączanym ikoną ), aby przefiltrować wyniki do komponentów spełniających te wartości parametrów.
Wszystkie powyższe funkcje można stosować łącznie, aby szybko i precyzyjnie znaleźć wymagane komponenty oraz powiązane z nimi aktualne dane dostawców.
  • Search Results:
    • Ten środkowy obszar panelu jest wypełniany wszystkimi częściami producentów, które spełniają bieżące kryteria wyszukiwania, kategorii i filtrów. Kolumna Supply Info zawiera podsumowanie danych dostaw dla każdej pozycji na podstawie ceny jednostkowej, minimalnej wielkości zamówienia (MOQ) oraz dostępnych zapasów u najbardziej odpowiedniego dostawcy. Kolorowy pasek powiązany z każdą częścią producenta pozwala szybko ocenić jej status w cyklu życia — na przykład zielony oznacza, że część nadaje się do produkcji seryjnej, a czerwony wskazuje część uznawaną za przestarzałą.
    • Wybrana pozycja części zawiera w kolumnie Manufacturer Part łącze do danych dostawców (na przykład 9 SPNs), które otwiera poziomą listę kafelków wyboru dostawcy dla tej części producenta. Każdy kafelek na tej liście dotyczy określonego dostawcy i przedstawia aktualny stan zapasów, ceny oraz numer części u dostawcy. Informacje o stosowaniu tych danych do komponentów projektu znajdziesz poniżej w sekcji Tworzenie powiązania z pozycją dostawcy.
    • Ustawienia opcji panelu, dostępne z  przycisku w prawym górnym rogu panelu skonfiguruj sposób wyświetlania wyników wyszukiwania:
      • Currency menu – Waluta używana w informacjach o cenach w panelu jest określana przez ustawienie priorytetu walut na stronie Zarządzanie danymi – Dostawcy części. Aby szybko zmienić bieżące ustawienie panelu, wybierz inną walutę z tego menu rozwijanego.

      • Exclude Invalid SPNs opcja – Włącz tę opcję, aby usunąć łącze do danych dostawcy w kolumnie Manufacturer Part dla pozycji, w których dane dostawcy dotyczące danej części nie nadają się do użycia (są nieprawidłowe) – na przykład gdy informacje o cenie lub stanie magazynowym są niedostępne.

      • Preferencje dostawców części łącze – Zapewnia bezpośredni dostęp do strony Zarządzanie danymi – Dostawcy części Preferences. Na liście dostawców/sprzedawców danej części producenta będą uwzględniani tylko dostawcy włączeni na stronie preferencji.

  • Component Details:
    • Obszar Details panelu (otwierany przyciskiem w prawym górnym rogu) przedstawia wszystkie dostępne dane wybranego komponentu, w tym jego parametry, modele, karty katalogowe i łącza do internetowych informacji dostawców.
    • Obszar ten zawiera również opcje pobierania umożliwiające wyświetlenie/zapisanie specyfikacji części producenta () lub lokalne zapisanie samego komponentu () poprzez:
      • Zapisanie komponentu w aktualnie połączonym obszarze roboczym Altium lub
      • Pobranie komponentu jako biblioteki plikowej w archiwum ZIP lub 
      • Umieszczenie komponentu na aktywnym arkuszu schematu.

► Szczegółowe informacje o funkcjach i zastosowaniu tego panelu można znaleźć na stronie Wyszukiwanie części producentów.

Wyświetlanie i edytowanie powiązań z dostawcami

Powiązania z dostawcami zdefiniowane obecnie dla komponentu bibliotecznego lub komponentu umieszczonego na arkuszu schematu można wyświetlać i edytować w oknie dialogowym Supplier Links for. Aby otworzyć to okno:

  • For a schematic library component – kliknij prawym przyciskiem myszy w dowolnym miejscu obszaru projektowego i wybierz polecenie Supplier Links z menu kontekstowego.
  • For a Database library / SVN Database Library component – kliknij prawym przyciskiem myszy pozycję komponentu na karcie Table Browser odpowiedniego pliku DbLib/SVNDbLib i wybierz polecenie Edit Supplier Links z menu kontekstowego.
  • For a placed component on a schematic sheet – kliknij komponent prawym przyciskiem myszy i wybierz polecenie Supplier Links z menu kontekstowego.

Po uruchomieniu polecenia otworzy się okno dialogowe Supplier Links for. Zawiera ono listę wszystkich aktualnie zdefiniowanych powiązań dla danego komponentu. Jeśli dostępnych jest wiele części producentów — co oznacza, że istnieje wiele rozwiązań — rozwiązania są automatycznie szeregowane od najlepszego do najgorszego na podstawie dostępności części, ceny i statusu cyklu życia określonego przez producenta. Część producenta jest wyświetlana po lewej stronie, a szczegóły wybranego dostępnego dostawcy — po prawej.

Okno dialogowe Supplier Links for
Okno dialogowe Supplier Links for

Wszystkie aktualnie zdefiniowane powiązania z dostawcami dla komponentu biblioteki schematowej można również wyświetlać i edytować bezpośrednio w panelu Właściwości wybranego komponentu. Zdefiniowane powiązania z dostawcami dla wybranego komponentu są wyświetlane w obszarze Part Choices panelu. Szczegółowe dane dotyczące wybranego powiązania z dostawcą są dostępne za pośrednictwem klikalnego łącza w kafelku dostawcy (jak pokazano poniżej) lub po wyszukaniu wartości parametru Supplier Part Number 1 tego komponentu w panelu Wyszukiwanie części producentów.

Aby dodać kolejne powiązanie z dostawcą, kliknij przycisk u dołu obszaru Part Choices. Otworzy się okno dialogowe Supplier Links for; kliknij przycisk  , aby otworzyć okno dialogowe Add Supplier Links, które umożliwia wyszukiwanie i dodawanie kolejnych powiązań z wymaganą pozycją. Użyj przycisku w oknie dialogowym Add Supplier Links, aby usunąć wybrane powiązanie z dostawcą z komponentu bibliotecznego.

Okno dialogowe Add Supplier Links oferuje funkcję wyszukiwania opartą na kategoriach i filtrowaniu parametrycznym, podobną do tej w panelu Wyszukiwanie części producentów. Więcej szczegółów znajdziesz na stronie poświęconej temu panelowi.

Wielu dostawców oferuje rabaty przy zamówieniach hurtowych. Kliknij łącze Show more na kafelku SPN, aby wyświetlić różne ceny jednostkowe zależne od liczby sztuk zamawianych u dostawcy. (Następnie możesz kliknąć łącze Show less, aby zwinąć cennik dla zamówień hurtowych).

Dostosowywanie procesu wyszukiwania — sugerowane słowa kluczowe

Gdy okno dialogowe Dodaj łącza do dostawców jest używane do wyszukiwania i wybierania odpowiednich danych dostawców komponentów, oprogramowanie automatycznie wyszukuje części producentów na podstawie parametrów pobranych z komponentu docelowego. Zapytanie wyszukiwania używane przez oprogramowanie jest definiowane w obszarze Suggested Keywords na stronie Zarządzanie danymi — dostawcy części okna dialogowego Preferences, co pozwala dostosować stosowane wyrażenie wyszukiwania do struktury biblioteki komponentów. Masz pełną kontrolę nad tym, które parametry części są używane jako słowa kluczowe wyszukiwania i w jakiej kolejności.

Domyślne sugerowane słowa kluczowe używane podczas automatycznego wyszukiwania części w bazach danych dostawców.Domyślne sugerowane słowa kluczowe używane podczas automatycznego wyszukiwania części w bazach danych dostawców.

W obszarze Suggested Keywords okna dialogowego domyślne przypisanie priorytetów (z najwyższym priorytetem na górze listy) oznacza, że jako pierwsza w kryteriach wyszukiwania zostanie użyta wartość Comment. Jeśli komponent źródłowy nie ma komentarza, przy kolejnej próbie zostanie użyta jego wartość Description. Jeśli ona również jest pusta, zostanie użyta wartość Name komponentu.

W razie potrzeby możesz dodać własne parametry słów kluczowych, klikając przycisk Add . Spowoduje to dodanie nowej pozycji parametru (o domyślnej nazwie Parameter Name) na dole listy (a zatem przypisanie jej najniższego priorytetu). Nowy parametr zostanie automatycznie uaktywniony i będzie gotowy do zmiany nazwy. Aby zmienić nazwę istniejącego parametru, kliknij raz pole jego nazwy, aby je uaktywnić, a następnie wprowadź nową nazwę. Możesz też wybrać parametr, klikając powiązane z nim pole priorytetu, a następnie kliknąć przycisk Edit .

Kliknij w dowolnym miejscu kolumny Priority , aby zatwierdzić zmianę nazwy. Możesz również nacisnąć Enter, ale pamiętaj, że spowoduje to zatwierdzenie zmiany i zamknięcie okna dialogowego Preferences .

Użyj przycisków Move Up lub Move Down, aby przesunąć aktualnie wybrany parametr odpowiednio w górę lub w dół listy — zwiększając lub zmniejszając przypisany mu Priority .

Przykład sugerowanego parametru słowa kluczowego zdefiniowanego przez użytkownika, dodanego i oznaczonego najwyższym priorytetem.Przykład sugerowanego parametru słowa kluczowego zdefiniowanego przez użytkownika, dodanego i oznaczonego najwyższym priorytetem.

Choć domyślne parametry można edytować, a nawet usuwać, można je przywrócić za pomocą listy rozwijanej powiązanej z pozycją parametru.

Liczba sztuk i ceny

Dostawcy zazwyczaj oferują różne ceny w zależności od liczby kupowanych sztuk danego produktu. Progi ilościowe umożliwiające uzyskanie coraz niższych cen jednostkowych różnią się nie tylko między dostawcami, ale także między produktami tego samego dostawcy. Podczas wybierania danych dostawcy części producenta w panelu Wyszukiwanie części producentów podsumowanie tych informacji jest dostępne na kafelku dostawcy części po wybraniu łącza Show more. Pozwala to świadomie wybrać łącze do dostawcy z uwzględnieniem ceny (i stanu magazynowego), na podstawie aktualnych danych.

Ceny i stany magazynowe dostawców zmieniają się. Pamiętaj, że informacje od dostawców są aktualizowane z opóźnieniem w bazie danych usługi agregującej udostępnianej przez Altium Parts Provider. Najedź kursorem myszy na symbol na kafelku dostawcy, aby sprawdzić, kiedy informacje zostały ostatnio zaktualizowane.

Łącza do dostawców dodane do komponentu bibliotecznego również udostępniają szczegółowe informacje o cenach w zależności od liczby sztuk w obszarze Part Choices panelu Properties dla aktualnie wybranego komponentu bibliotecznego. 

Przykład wyświetlanej wartości Unit Price na podstawie określonej wartości Order Quantity, gdy zamówienie 100 sztuk obniża cenę z 0,1 USD do 0,018 USD za kondensator. Przykład wyświetlanej wartości Unit Price na podstawie określonej wartości Order Quantity, gdy zamówienie 100 sztuk obniża cenę z 0,1 USD do 0,018 USD za kondensator.

Przeliczanie walut

Poszczególni dostawcy działają w różnych, często wielu regionach świata, dlatego ceny produktów są często podawane w różnych walutach. Altium Designer umożliwia przeliczanie wyświetlanych informacji cenowych na jedną z obsługiwanych walut.

Aby szybko wyświetlić wszystkie informacje cenowe w jednej walucie w panelu Wyszukiwanie części producentów, wybierz żądaną walutę z menu rozwijanego Currency dostępnego pod przyciskiem panelu. Aby wyświetlać ceny w domyślnej walucie używanej przez dostawcę, wybierz pozycję None z menu.

Przeliczanie walut odbywa się według obowiązujących kursów wymiany. Kursy te są aktualizowane codziennie (co 24 godziny), jednak aby zastosować aktualne kursy przeliczeniowe, musisz zalogować się na swoje konto Altium.

Aby ustawić preferencje dotyczące używania walut w Altium Designer, włącz lub wyłącz waluty i określ ich priorytet na stronie Zarządzanie danymi – Dostawcy części w oknie dialogowym Preferences.

► Więcej informacji znajdziesz powyżej w sekcji Preferencje dostawców.

Importowanie określonych parametrów

Wybrane parametry producenta/dostawcy można zaimportować z panelu Wyszukiwanie części producentów do komponentu w bibliotece lub umieszczonego w projekcie za pomocą polecenia Add Parameter(s) To, dostępnego w obszarze Details panelu, otwieranym przyciskiem .

W tym celu wybierz część producenta lub jeden z jej podrzędnych wpisów dostawców na liście wyników wyszukiwania w panelu, a następnie żądane parametry w obszarze Details panelu. Kliknij prawym przyciskiem myszy wybrany (podświetlony) wpis parametru i wybierz polecenie Add Parameter(s) To, aby przenieść parametry do komponentu docelowego.

  • W przypadku komponentu bibliotecznego celem jest wpis wybrany w panelu Biblioteka SCH lub (w przypadku biblioteki bazodanowej) Table Browser biblioteki DBLib.

  • W przypadku umieszczonego komponentu cel wybiera się w edytorze schematów za pomocą kursora krzyżowego.

Ważne informacje dotyczące przenoszenia par parametr–wartość:

  • Jeśli parametr już istnieje w komponencie docelowym, jego wartość zostanie zaktualizowana — patrz Voltage Rating na powyższych ilustracjach przykładowych.

  • Jeśli parametr jeszcze nie istnieje, zaimportowana para parametr–wartość zostanie dodana do komponentu docelowego — Tolerance i Material na powyższej ilustracji.

  • Proces będzie przebiegać zgodnie z ustawieniami w obszarze Parameter Import Options na stronie Zarządzanie danymi – Dostawcy części w oknie dialogowym Preferences. Na przykład jeśli Capacitance jest mapowany na Value, ten drugi parametr zostanie dodany do komponentu docelowego jako wartość pojemności — Value 1nF.

  • Parametry dostawcy, takie jak Stock i Pricing, są dostępne w obszarze Details panelu Manufacturer Part Search tylko wtedy, gdy jako źródło wybrano kafelek dostawcy (a nie część producenta).

  • Podobnie jak w przypadku innych parametrów, dodane dane dostawcy update istniejące parametry dostawcy w komponencie docelowym. Sufiks danych dostawcy pozostaje równy 1, a kolejne operacje dodawania nie zwiększają jego wartości.

Uwzględnianie danych dostawców w zestawieniu materiałowym

Powiązania z danymi dostawców dodane do komponentów w projekcie lub powiązania zawarte w komponencie umieszczonym z biblioteki są zapisywane wraz z projektem i można je uwzględnić w Bill of Materials (BOM).

Raport BOM

W najprostszym przypadku powiązania komponentów z dostawcami są dostępne w raporcie BOM generowanym na podstawie dokumentów źródłowych projektu. Wybierz Reports » Bill of Materials, aby otworzyć okno dialogowe Zestawienie materiałowe projektu, w którym można skonfigurować raport zgodnie z potrzebami i wygenerować go w różnych formatach (Excel, PDF, HTML itp.). Raport BOM można również uwzględnić jako raport wyjściowy w projektowym zadaniu generowania plików wyjściowych.

► Szczegółowe informacje znajdziesz w sekcji Konfiguracja BOM w menedżerze raportów.

Prosty raport BOM przedstawia parametry danych dostawców dla komponentów zawierających powiązania z dostawcami.Prosty raport BOM przedstawia parametry danych dostawców dla komponentów zawierających powiązania z dostawcami.

Jeśli projekt zawiera dokument ActiveBOM (patrz poniżej), raport BOM pobierze dane powiązań z dostawcami z tego dokumentu, a nie z dokumentów projektowych.

Dokument ActiveBOM

Znacznie bardziej zaawansowanym i zalecanym podejściem do zarządzania powiązaniami z producentami i dostawcami w zestawieniu materiałowym projektu jest dodanie do projektu dokumentu ActiveBOM — File » New » ActiveBOM Document. Pamiętaj, że pełne korzyści z tego podejścia uzyskuje się przy użyciu komponentów bibliotecznych Workspace.

► Szczegółowe informacje znajdziesz w sekcji Zarządzanie BOM za pomocą ActiveBOM.

ActiveBOM wykorzystuje Solutions danych komponentów, aby dodać kompleksowy zestaw aktualnych informacji o częściach, takich jak szczegóły części producenta (w tym status cyklu życia), ceny u dostawców i stany magazynowe.

Istniejące powiązania komponentów z dostawcami, dodane wcześniej na poziomie biblioteki lub dokumentu schematu, są automatycznie przekształcane w rozwiązania ActiveBOM. Pamiętaj, że nadal będą one wyświetlać tylko jednego dostawcę dodanego podczas definiowania powiązania z dostawcą, nawet jeśli dana część producenta jest dostępna u wielu dostawców.

Kolejnym krokiem, wykraczającym poza rozwiązania BOM utworzone na podstawie istniejących powiązań z dostawcami dodanych do komponentów w bibliotece lub na schemacie, jest dodanie nowych rozwiązań dla komponentów w interfejsie ActiveBOM.

Natywne rozwiązania ActiveBOM, zorientowane na producenta, zapewniają zaawansowane mapowanie danych między komponentem projektowym a częścią producenta oraz all of the approved Suppliers tej części. Aktualizowane na bieżąco dane rozwiązania są dostępne przez cały proces projektowania i stają się źródłem wszystkich plików wyjściowych typu BOM.

Z komponentem projektowym (rozwiązaniem) można powiązać nie tylko wielu dostawców określonej części producenta, lecz także wiele części producentów. Jeśli powiązanie DesignPart - ManufacturerPart jest zapisane jako część komponentu projektowego w Workspace, podejście to jest określane jako Part Choices; jeśli powiązanie jest zapisane w dokumencie ActiveBOM (BomDoc), jest określane jako Manufacturer Links.

Dzięki temu zaawansowanemu podejściu komponent projektowy nie musi przechowywać żadnych informacji o dostawcach ani o numerach części dostawców. 

► Dowiedz się więcej o dodawaniu informacji o łańcuchu dostaw do komponentu w Altium Designer.

Jeśli projekt nie korzysta z komponentów Workspace, użyj opcji Create/Edit Manufacturer Links z menu przycisku , aby dodać rozwiązanie ActiveBOM do aktualnie wybranego wpisu komponentu. Wybierz przycisk w kolejnym oknie dialogowym Edit Manufacturer Links, a następnie odpowiedni wpis komponentu producenta w oknie dialogowym Add Part Choices. Po zatwierdzeniu (OK) to powiązanie z częścią zostanie dodane jako nowy wpis w oknie dialogowym Edit Manufacturer Links.

Po zatwierdzeniu dodania w oknie dialogowym () rozwiązanie ActiveBOM zostanie dodane do wpisu komponentu BOM. Pamiętaj, że w tym przypadku rozwiązanie obejmuje pełną listę opcji dostawców, a wybrana opcja (oznaczona na zielono) jest wskazana jako „najlepsze” rozwiązanie dostawcy dla części producenta.

Użyj powiązanego panelu Właściwości, aby skonfigurować funkcje ActiveBOM, takie jak używana waluta, źródło danych powiązań z producentami, widoczne kolumny danych, grupowanie pozycji BOM, ostrzeżenia kontroli BOM itp.

► Więcej informacji znajdziesz w sekcji Zarządzanie BOM za pomocą ActiveBOM.

AI-LocalizedTłumaczenie SI
Jeśli znajdziesz błąd, zaznacz tekst/obraz i naciśnij Ctrl + Enter aby wysłać nam wiadomość.
Contents
Dostępność funkcji

Dostępne funkcje zależą od tego, z którego rozwiązania Altium korzystasz – Altium Develop, Altium Agile Teams, Altium Agile Enterprise lub Altium Designer (w ramach aktywnej subskrypcji terminowej).

Jeśli opisana funkcja nie jest widoczna w Twoim oprogramowaniu, skontaktuj się z działem sprzedaży Altium, aby dowiedzieć się więcej.

Starsza dokumentacja

Dokumentacja Altium Designer nie jest już wersjonowana. Jeśli potrzebujesz dostępu do dokumentacji dla starszych wersji Altium Designer, odwiedź sekcję Starsza dokumentacja na stronie Inne instalatory.

Contents