Linking Existing Components to a Company Database using a Database Link File

W skrócie

Połącz istniejące komponenty na schematach lub w bibliotekach z centralną bazą danych komponentów swojej firmy za pomocą pliku Database Link w Altium Designer. W tym artykule wyjaśniamy, czym DbLink różni się od rozwiązań opartych na bibliotekach bazodanowych, jak utworzyć plik DbLink i jak skonfigurować połączenie z zewnętrzną bazą danych. Omawiamy również synchronizację zmapowanych parametrów komponentów z rekordami bazy danych, dzięki której informacje te można uwzględnić w zestawieniu materiałowym (BOM). Czytaj dalej, aby zrobić kolejny krok w kierunku utrzymywania spójności danych komponentów.

- Dowiedz się, kiedy używać DbLink zamiast DbLib lub SVNDbLib.
- Naucz się tworzyć plik Database Link i konfigurować połączenia z bazami danych Access, arkuszami Excel i innymi obsługiwanymi bazami danych.
- Poznaj wymagania dotyczące łączenia za pomocą pól kluczowych oraz kwestie związane z 64-bitowymi silnikami baz danych.
Zagłęb się w temat dzięki AI:

Wiele organizacji wymaga możliwości powiązania komponentów w elektronicznym systemie CAD z centralną bazą danych komponentów firmy. Altium Designer umożliwia to poprzez tworzenie i używanie pliku Database Link, który pozwala powiązać istniejące komponenty z rekordami w firmowej bazie danych. Plik Database Link dodaje się do projektu lub pakietu bibliotek, co umożliwia powiązanie odpowiednio komponentów już umieszczonych na arkuszach schematu lub — co jest częstszym rozwiązaniem — komponentów zdefiniowanych w źródłowej bibliotece schematowej.

Po utworzeniu powiązań można przesyłać zmapowane dane parametryczne z rekordów bazy danych do parametrów projektowych komponentów za pomocą polecenia Tools » Update Parameters From Database. Informacje te można następnie uwzględnić w końcowym zestawieniu materiałowym (BOM), gotowym do wykorzystania przy zakupie komponentów.

The Move from 32-bit to 64-bit Software

Od wersji Altium Designer 18.0 i Altium NEXUS 1.0 oprogramowanie projektowe jest 64-bitowe. Aby powiązać komponenty projektu z bazą danych w 64-bitowej wersji oprogramowania Altium, silnik bazy danych również musi być 64-bitowy. Jeśli do zarządzania danymi w bazie używasz programu Microsoft Access lub Excel i masz zainstalowaną 32-bitową wersję pakietu Office, możesz dodatkowo zainstalować 64-bitowy silnik bazy danych Microsoft Access. Szczegółowe informacje na ten temat znajdziesz w instrukcjach na stronie Korzystanie z bibliotek bazodanowych w 32-bitowej i 64-bitowej wersji Altium Designer na tym samym komputerze.

Przy próbie połączenia za pośrednictwem 32-bitowego silnika bazy danych Microsoft Access pojawi się następujący komunikat o błędzie.

Error dialog, reporting that a 64-bit version of the Microsoft Access Database engine is required for database linking

Pamiętaj, że niektóre błędy połączenia, takie jak nieprawidłowa składnia w szczegółach Provider w Connection String, mogą spowodować wywołanie niewłaściwego silnika bazy danych i wyświetlenie pokazanego powyżej okna błędu nawet po zainstalowaniu 64-bitowego silnika bazy danych.

Kilka słów o metodach tworzenia powiązań...

Altium Designer udostępnia trzy metody powiązania komponentu z bazą danych — za pomocą pliku Database Link (*.DbLink), pliku Database Library (*.DbLib) lub pliku SVN Database Library (*.SVNDbLib). Metoda DbLink zapewnia skuteczny sposób tworzenia powiązań i synchronizowania komponentów używanych w projekcie (lub bibliotekach) z danymi wprowadzonymi do bazy danych. Metoda DbLib/SVNDbLib wykorzystuje tę sprawdzoną skuteczność powiązań, a dodatkowo umożliwia umieszczanie komponentów bezpośrednio z bazy danych — w praktyce komponent jest tworzony dynamicznie na podstawie informacji zapisanych w odpowiadającym mu rekordzie bazy danych.

Zanim szczegółowo omówimy funkcję powiązania z bazą danych, warto przedstawić różnice w sposobie korzystania z tych dwóch metod.

Tworzenie powiązań za pomocą pliku Database Link

  • W tej metodzie plik Database Link definiuje powiązanie między komponentem schematowym a pasującym rekordem w bazie danych. Dopasowanie rekordu odbywa się za pomocą pól kluczowych: pojedynczego pola kluczowego (na przykład numeru części) lub wielu pól kluczowych (przez zdefiniowanie klauzuli WHERE).
  • W tej metodzie informacje o modelach i parametrach komponentu muszą być wcześniej zdefiniowane w komponencie bibliotecznym Altium Designer. Definicja komponentu bibliotecznego musi również zawierać niezbędne informacje o polach kluczowych. Po ich zdefiniowaniu należy dodać plik Database Link do pakietu bibliotek lub projektu. Następnie można synchronizować informacje o komponencie (parametry) z zawartością pól w bazie danych.
  • Chociaż każdy fizyczny komponent zdefiniowany w rekordzie bazy danych nie musi odpowiadać unikatowemu komponentowi bibliotecznemu Altium Designer — wiele komponentów z bazy danych może współdzielić ten sam symbol — tę metodę powiązania stosuje się zazwyczaj w relacji „jeden rekord bazy danych — jeden komponent Altium Designer”. Unikatowy komponent Altium Designer może być instancją umieszczoną na arkuszu schematu lub unikatowym komponentem w bibliotece komponentów.
  • W przypadku powiązania z bazą danych metodą DbLink plik Database Link dołącza się do pakietu bibliotek lub projektu.

Powiązanie komponentów bibliotecznych z zewnętrzną bazą danych jest możliwe tylko wtedy, gdy biblioteka należy do pakietu biblioteki zintegrowanej (*.LibPkg). Wybierz polecenie File » New » Library » Integrated Library, aby utworzyć nowy pakiet bibliotek, a następnie dodaj do niego źródłowe biblioteki schematowe.

► Dowiedz się więcej o bibliotekach zintegrowanych.

Tworzenie powiązań za pomocą pliku Database Library

Related page: Biblioteki bazodanowe

  • W tej metodzie plik Database Library również definiuje powiązanie między komponentem schematowym a pasującym rekordem w bazie danych. Także tutaj dopasowanie rekordu odbywa się za pomocą pól kluczowych: pojedynczego pola kluczowego (na przykład numeru części) lub wielu pól kluczowych (przez zdefiniowanie klauzuli WHERE).
  • W tej metodzie symbol komponentu oraz informacje o jego modelach i parametrach są zapisane jako część definicji rekordu danego komponentu w zewnętrznej bazie danych. Wskazany komponent schematowy (przechowywany w bazowej bibliotece komponentów (*.SchLib)) jest wyłącznie symbolem — nie ma powiązanych modeli ani zdefiniowanych parametrów projektowych.
  • Podczas umieszczania komponentu informacje o jego parametrach i modelach są tworzone na bieżąco na podstawie odpowiednich pól w dopasowanym rekordzie bazy danych, zgodnie ze zdefiniowanym mapowaniem. Co najmniej jeden z tych parametrów jest następnie używany do utrzymywania powiązania z bazą danych zgodnie ze zdefiniowanymi kryteriami dopasowania, co umożliwia późniejszą synchronizację po umieszczeniu komponentu.
  • Ze względu na dynamiczne tworzenie komponentów w momencie ich umieszczania ta metoda doskonale sprawdza się w relacji „wiele rekordów bazy danych — jeden komponent Altium Designer”. Na przykład baza danych może zawierać szereg rezystorów E96, a każdy rekord może wskazywać ten sam symbol schematowy rezystora i ten sam footprint PCB.
  • W przeciwieństwie do metody DbLink, w której plik DbLink musi być dołączony do pakietu bibliotek (lub projektu), pliku DbLib/SvnDbLib nie trzeba dodawać do projektu. Biblioteka bazodanowa (DbLib) znajduje się wśród dostępnych bibliotek, do których można uzyskać dostęp z panelu Components. Pamiętaj, że dostępne biblioteki mogą obejmować biblioteki projektu, biblioteki zainstalowane lub biblioteki znalezione we wskazanych ścieżkach wyszukiwania.
  • Pliki DbLib/SVNDbLib zazwyczaj konfiguruje się według podziału na biblioteki. Na przykład jeden plik może obejmować wszystkie rezystory opisane w firmowej bazie danych, drugi — kondensatory i tak dalej.
Biblioteka SVN Database Library (*.SVNDbLib) jest rozszerzeniem modelu powiązań DbLib. Tego typu pliku używa się dokładnie tak samo jak pliku DbLib, ale symbol schematowy i powiązane modele są przechowywane w bibliotekach objętych kontrolą wersji (Subversion).

Tworzenie pliku Database Link

Jak wspomniano, podstawą funkcji powiązania z bazą danych jest plik Database Link. Plik ten tworzy się i zarządza nim w edytorze DatabaseLink programu Altium Designer. Edytor jest dostępny, gdy aktywnym dokumentem w głównym oknie projektowym jest plik *.DbLink.

Przykładowy plik DbLink otwarty w edytorze DatabaseLink.Przykładowy plik DbLink otwarty w edytorze DatabaseLink.

Nowy plik tego typu można utworzyć na jeden z następujących sposobów:

  • Wybierając polecenie File » New » Library » Database Link File z menu głównego.
  • Klikając prawym przyciskiem myszy pozycję wybranego projektu w panelu Projects i wybierając polecenie Add New to Project » Database Link File z menu kontekstowego.

Pliki Database Link dodane do projektu są wyświetlane w panelu Projects w podfolderze Settings\Database Link Files.

The DbLink file appears in the Settings folder in the Projects panel

Jeśli na stronie System - New Document Defaults w oknie dialogowym Preferences określono dokument domyślny, plik Database Link zostanie utworzony z użyciem tego dokumentu jako szablonu. Można przypisać różne dokumenty domyślne dla pliku Database Link tworzonego jako część projektu PCB, pakietu biblioteki zintegrowanej lub jako dokument niezależny.

Łączenie z zewnętrzną bazą danych

Dane tabel i mapowania pojawią się w głównym oknie edytora dopiero po pomyślnym połączeniu aktywnego pliku Database Link z wymaganą zewnętrzną bazą danych. Połączenie definiuje się za pomocą elementów sterujących dostępnych w sekcji Source of Connection.

Określanie połączenia z zewnętrzną bazą danych.Określanie połączenia z zewnętrzną bazą danych.

Można połączyć się z dowolną bazą danych obsługującą OLE DB. Każda z opcji dostępnych w tej sekcji wykorzystuje parametry połączenia OLE DB do nawiązania połączenia z docelową bazą danych. Niektóre bazy danych mogą nie obsługiwać OLE DB. Jednak praktycznie wszystkie używane obecnie systemy zarządzania bazami danych są dostępne za pośrednictwem interfejsu Open Database Connectivity (ODBC). Funkcja łączenia z bazą danych korzysta z dostawcy ODBC firmy Microsoft, który umożliwia obiektowi ADO (ActiveX Data Object) łączenie się z dowolnym źródłem danych ODBC. Dzięki temu można połączyć się z dowolną bazą danych ODBC. Dostawca OLE DB dla bazy danych ODBC jest określany w parametrach połączenia.

Połączenie można również zdefiniować na karcie Connection okna dialogowego Database Connection, dostępnego z menu głównego Tools lub po kliknięciu przycisku Advanced (po prawej stronie przycisku Connect , u dołu sekcji).

Szybkie łączenie z bazami danych Access i Excel

Opcja Select Database Type umożliwia szybkie utworzenie parametrów połączenia, gdy docelowa baza danych została utworzona w programie Microsoft Access lub Microsoft Excel. Korzystając z tej opcji, wybierz typ bazy danych, a następnie wyszukaj i wybierz wymagany plik bazy danych. Odpowiednie parametry połączenia zostaną automatycznie utworzone i wprowadzone w polu opcji Use Connection String.

Można podać pełną ścieżkę lub wybrać zapisanie ścieżki względnej wobec pliku Database Link.

Tworzenie parametrów połączenia

Jeśli firmowa baza danych nie jest oparta na programie Access ani Excel i chcesz samodzielnie utworzyć parametry połączenia, włącz opcję Use Connection String, a następnie kliknij powiązany przycisk Build po prawej stronie. Pojawi się okno dialogowe Data Link Properties.

Tworzenie parametrów połączenia w oknie dialogowym Data Link Properties. Tworzenie parametrów połączenia w oknie dialogowym Data Link Properties.

Okno dialogowe otwiera się na karcie Connection . Na karcie Provider tego okna domyślnie ustawiony jest dostawca OLE DB Microsoft Office <Version> Access Database Engine OLE DB Provider. Jest to domyślne ustawienie dostawcy dla nowych plików Database Link, używane również do łączenia się z plikami baz danych Access (*.mdb). W razie potrzeby zmień dostawcę.

Na karcie Connection wprowadź nazwę bazy danych (wraz ze ścieżką), z którą chcesz się połączyć.

Jeśli baza danych wymaga uwierzytelnienia, wprowadź wymagane dane logowania oraz skonfiguruj pozostałe ustawienia zaawansowane dostępne na karcie Advanced okna dialogowego. Karta All zawiera podsumowanie zdefiniowanych opcji połączenia, a także rozszerzone opcje dotyczące wybranego dostawcy OLE DB. W razie potrzeby opcje można również modyfikować na tej karcie.

Po zdefiniowaniu opcji połączenia można sprawdzić, czy połączenie działa poprawnie, klikając przycisk Test Connection (na karcie Connection ). Jeśli połączenie zostanie nawiązane pomyślnie, pojawi się okno dialogowe z potwierdzeniem.

Okno dialogowe Data Link Properties jest oknem firmy Microsoft, dlatego naciśnięcie klawisza F1 lub użycie dostępnego przycisku Help otworzy plik Microsoft Data Link Help. Plik ten nie należy do dokumentacji Altium.

Wskazywanie pliku Data Link

Jeśli źródło danych, z którym chcesz się połączyć, jest opisane za pomocą pliku Microsoft Data Link (*.udl), włącz trzecią opcję połączenia — Use Data Link File — i kliknij powiązany przycisk Browse , aby znaleźć wymagany plik. Plik Data Link służy zasadniczo do przechowywania parametrów połączenia.

Nawiązywanie połączenia

Po zdefiniowaniu połączenia z zewnętrzną bazą danych tekst na przycisku Connect zostanie pogrubiony, co oznacza, że można nawiązać połączenie. Jeśli dane połączenia są poprawne, informacje o tabelach i mapowaniu docelowej bazy danych zostaną wczytane do pliku Database Link. Tekst na przycisku Connect zmieni się na Connected, a przycisk zostanie wyszarzony.

Jeśli wystąpi problem z danymi połączenia, na przykład parametry połączenia zostaną nieprawidłowo utworzone lub ścieżka zostanie błędnie wprowadzona, połączenie nie powiedzie się i pojawi się odpowiedni komunikat. Sprawdź ustawienia połączenia i ponownie kliknij przycisk Connect .

Przykłady sygnalizowania niepowodzenia połączenia.Przykłady sygnalizowania niepowodzenia połączenia.

Jeśli zmienisz ustawienia połączenia podczas połączenia z bazą danych, aktywne połączenie zostanie przerwane, a tekst na przycisku Connect zmieni się na Reconnect. Kliknij go, aby ponownie nawiązać połączenie.

Po pierwszym pomyślnym połączeniu i zapisaniu pliku Database Link połączenie będzie nawiązywane automatycznie przy każdym otwarciu pliku, pod warunkiem że lokalizacja i nazwa pliku docelowej bazy danych nie ulegną zmianie.

Lista tabel bazy danych

Po pomyślnym połączeniu z zewnętrzną bazą danych zostaną wczytane dane tabel i mapowania. Po lewej stronie dokumentu DbLink znajduje się lista wszystkich tabel istniejących w połączonej bazie danych.

Tabele istniejące w połączonej bazie danych.Tabele istniejące w połączonej bazie danych.

Opcja Enable obok każdej pozycji tabeli pozwala określić, czy dana tabela ma być używana podczas aktualizowania parametrów z bazy danych.

Po kliknięciu tabeli na liście jej ikona zmienia się z Database table icon, inactive table na Database table icon, active table, aby oznaczyć ją jako aktualnie aktywną tabelę. Tabela wraz ze wszystkimi danymi jest wyświetlana na karcie Table Browser dokumentu. Jest to nieedytowalna kopia tabeli, która umożliwia szybki wgląd w jej zawartość bez konieczności otwierania samej zewnętrznej bazy danych.

Przeglądanie tabeli źródłowej w połączonej bazie danych.Przeglądanie tabeli źródłowej w połączonej bazie danych.

Aby powiększyć obszar przeglądarki tabel (jak pokazano na ilustracji powyżej), zwiń cały obszar powyżej niego (ustawienia połączenia i pól), klikając element sterujący Collapse icon - collapse a region of the DbLink document w prawym górnym rogu widoku dokumentu DbLink. Kliknij Expand icon - expand a region of the DbLink document, aby ponownie go rozwinąć.

Określanie kryteriów dopasowania

Aby zaktualizować informacje o parametrach elementów na podstawie danych zapisanych w polach zewnętrznej bazy danych, należy najpierw dopasować każdy element w projekcie do jednego wiersza w jednej z tabel bazy danych. Sekcja Field Settings dokumentu umożliwia zdefiniowanie kryteriów dopasowania — prostego wyszukiwania według pojedynczego klucza lub bardziej zaawansowanego dopasowania z użyciem klauzuli WHERE.

Kryteria dopasowania określa się osobno dla każdej tabeli.

Konfigurowanie kryteriów dopasowania.Konfigurowanie kryteriów dopasowania.

Wyszukiwanie według pojedynczego klucza

Jeśli opcja Single key lookup jest włączona (domyślnie), pola Database field i Part parameter stają się dostępne. Lista Database field zawiera wszystkie dostępne nazwy pól (nagłówki kolumn) w aktywnej tabeli bazy danych. Pole Part parameter zawiera listę wszystkich parametrów występujących we wszystkich elementach projektu — zarówno systemowych, jak i zdefiniowanych przez użytkownika.

Użyj tych pól, aby określić powiązanie między jednym polem w tabeli a jednym parametrem elementu (wspólnym dla wszystkich elementów). Zazwyczaj pole dopasowania w obu przypadkach jednoznacznie identyfikuje każdy komponent w zewnętrznej bazie danych, na przykład numer katalogowy. Wybrane pole wyszukiwania jest wyróżnione na karcie Field Mappings dokumentu przez wyszarzony wpis Design Parameter.

Mapowanie według pojedynczego klucza — numeru katalogowegoMapowanie według pojedynczego klucza — numeru katalogowego

Podczas korzystania z funkcji Tools » Update Parameters From Database informacje są odczytywane z wybranego parametru kluczowego w komponentach umieszczonych na schemacie, a następnie wyszukiwane w wybranym polu kluczowym bazy danych — we wszystkich włączonych tabelach. Po znalezieniu dopasowania informacje z pozostałych komórek tego rekordu tabeli nadrzędnej mogą zostać przeniesione do zmapowanych parametrów komponentu na schemacie.

Zaawansowane dopasowywanie — klauzula WHERE

Opcja Single key lookup sprawdza się dobrze, gdy dopasowanie jest oparte na unikatowym numerze katalogowym lub identyfikatorze, ale jest mniej skuteczna przy dopasowywaniu według parametru, który nie jest unikatowy, takiego jak pojemność lub rezystancja. W takim przypadku należy użyć bardziej zaawansowanej klauzuli WHERE, która umożliwia określenie dopasowania według wielu kluczy w celu powiązania komponentu na schemacie z wymaganym wierszem odpowiedniej tabeli bazy danych.

W najprostszej postaci klauzula WHERE (zapisana przy użyciu składni SQL) odzwierciedla wybrane wpisy definiujące wyszukiwanie według pojedynczego klucza. Na przykład, jeśli jako Database field wybrano Part Number, a jako unikatowy Part parameter (istniejący dla wszystkich elementów w projekcie) wybrano Part Number, wpis klauzuli WHERE miałby postać:

[Part Number] = '{Part Number}'

Nawiasy kwadratowe otaczające pole bazy danych (kolumnę tabeli) są znakami cytowania określonymi na karcie Advanced okna dialogowego Database Connection. Okno to można otworzyć, klikając przycisk Advanced w obszarze Source of Connection dokumentu lub z menu głównego Tools .

Karta Advanced  okna dialogowego Database Connection udostępnia dodatkowe opcje SQL dotyczące cytowania nazw tabel lub używania nazw schematów tabel w tworzonej klauzuli WHERE. Karta Advanced okna dialogowego Database Connection udostępnia dodatkowe opcje SQL dotyczące cytowania nazw tabel lub używania nazw schematów tabel w tworzonej klauzuli WHERE.

Podczas cytowania nazw tabel stosowane znaki cytowania zależą od używanej bazy danych. Na przykład nawiasów kwadratowych [ ] można używać tylko w bazach danych Microsoft, takich jak Access, Excel przez ADO lub MSSQL (w nowszych wersjach). W MYSQL do cytowania używany jest znak '. W każdej bazie danych nazwy kolumn wymagają cytowania właściwie tylko wtedy, gdy zawierają spacje lub są słowami zastrzeżonymi dla danej bazy. Sprawdź dokumentację używanego oprogramowania bazy danych, aby ustalić, jakie znaki cytowania są stosowane (jeśli w ogóle).

Nawiasy klamrowe wskazują, że przywoływany wpis jest parametrem projektu. Apostrofy oznaczają, że parametr projektu ma być traktowany jako ciąg znaków, a nie liczba (bez apostrofów). Dopasowanie typów jest bardzo ważne, ponieważ SQL rozróżnia typy danych. Parametr projektu powinien mieć ten sam typ co kolumna w bazie danych.

Przy użyciu standardowej składni SQL klauzulę WHERE można następnie rozszerzyć, aby dopasowywać według wielu wpisów Database field/Part parameter, na przykład:

[Capacitance] = '{Capacitance}' AND [Tolerance] = {Tolerance} AND [Manufacturer] = '{Manufacturer}'

W tym przypadku powiązanie z pojedynczym rekordem w odpowiedniej tabeli bazy danych byłoby tworzone przy użyciu trzech różnych parametrów projektu. Zwróć uwagę, że wpis parametru projektu Tolerance nie jest ujęty w apostrofy. Oznacza to, że typ kolumny w powiązanej tabeli bazy danych to Number, a nie String.

Przy użyciu standardowej składni SQL można tworzyć zarówno proste, jak i dowolnie złożone klauzule WHERE. Przykład bardziej złożonej klauzuli:

[Tolerance] BETWEEN {Min Tolerance} AND {Max Tolerance} AND [Price] <= {Max Price} AND [Manufacturer] IN ('{Preferred Manufacturer 1}', '{Preferred Manufacturer 2}')

W tym przypadku tabela byłaby przeszukiwana pod kątem pasujących elementów na podstawie trzech pól bazy danych — Tolerance, Price i Manufacturer. Tolerancja musi mieścić się w zakresie określonym przez parametry projektu Min Tolerance i Max Tolerance. Cena musi być mniejsza lub równa wartości określonej w parametrze projektu Max Price, a producentem może być dowolny z dwóch kandydatów określonych przez parametry projektu Preferred Manufacturer 1 i Preferred Manufacturer 2.

Tworzenie parametru elementu

Jeśli komponenty w Altium Designer nie mają odpowiedniego parametru, którego można użyć jako Part parameter do dopasowywania w pliku DbLink, należy go utworzyć. Ten „bazowy” parametr można szybko dodać za pomocą polecenia Tools » Parameter Manager lub panelu Properties odpowiedniego edytora.

Dodawanie parametru za pomocą funkcji zarządzania parametrami

Aby dodać nowy parametr za pomocą funkcji zarządzania parametrami:

  1. W dokumencie schematu (lub dokumencie biblioteki schematów) wybierz Tools » Parameter Manager z menu głównego. Pojawi się okno dialogowe Parameter Editor Options. Aby dodać nowy parametr do wszystkich elementów, upewnij się, że opcja Parts jest włączona w obszarze Include Parameters Owned By, a w obszarze That Meet the Following Criteria jako kryterium ustawiono All Objects.

Konfigurowanie opcji zarządzania parametrami.Konfigurowanie opcji zarządzania parametrami.

  1. Kliknięcie OK spowoduje otwarcie okna dialogowego Parameter Table Editor, zawierającego wszystkie parametry należące obecnie do wszystkich obiektów elementów w źródłowych dokumentach schematów aktywnego projektu (lub komponentów w aktywnej bibliotece schematów). Kliknij przycisk Add Column i w wyświetlonym oknie dialogowym Add Parameter zdefiniuj nazwę parametru. Upewnij się, że opcja Add to all objects jest włączona, aby nowy parametr został dodany do wszystkich elementów.

Za pierwszym razem pozostaw Value parametru bez przypisanej wartości — po prostu dodaj parametr do każdego elementu. Możesz uruchomić Parameter Table Editor ponownie, aby określić wartość każdego parametru. Okno dialogowe obsługuje standardowe skróty edycji systemu Windows, takie jak: przechodzenie między komórkami za pomocą klawiszy strzałek; edycja wartości bieżącej komórki klawiszem F2; a także kopiowanie i wklejanie bloków danych z edytora tekstu lub arkusza kalkulacyjnego do wybranej komórki i wymaganej liczby komórek poniżej niej.

Przykład użycia funkcji zarządzania parametrami do dodania nowego parametru do wszystkich elementów we wszystkich schematach źródłowych projektu.Przykład użycia funkcji zarządzania parametrami do dodania nowego parametru do wszystkich elementów we wszystkich schematach źródłowych projektu.

  1. Po dodaniu nowej kolumny kliknij przycisk Accept Changes (Create ECO). W wyświetlonym oknie dialogowym Engineering Change Order wykonaj kolejno Validate i Execute, aby wprowadzić zmiany — dodać parametr do każdego z wymaganych elementów.

Wprowadzanie zmian parametrów (dodawanie nowego parametru do wszystkich elementów) za pomocą zlecenia zmiany inżynierskiej (ECO).Wprowadzanie zmian parametrów (dodawanie nowego parametru do wszystkich elementów) za pomocą zlecenia zmiany inżynierskiej (ECO).

Dodawanie parametru za pomocą panelu Properties

Nowy parametr można dodać do wszystkich zaznaczonych elementów za pomocą panelu Properties. Poniższa procedura opisuje przypadek dodawania tego samego parametru do wszystkich komponentów w aktywnym dokumencie biblioteki schematów przy użyciu paneli SCHLIB Filter i Properties.

Procedura dodawania parametru do elementów umieszczonych w źródłowych dokumentach schematów jest podobna. W tym przypadku używane są panele SCH Filter i Properties edytora schematów.
  1. Najpierw zaznacz wszystkie komponenty w bibliotece, korzystając z panelu SCH Filter i zapytania IsPart. Upewnij się, że opcja Whole Library jest włączona, w przeciwnym razie uwzględniony zostanie tylko aktywny komponent biblioteczny.

Konfigurowanie filtra w celu zaznaczenia wszystkich elementów w aktywnym dokumencie biblioteki schematów.Konfigurowanie filtra w celu zaznaczenia wszystkich elementów w aktywnym dokumencie biblioteki schematów.

  1. W panelu Properties edytora biblioteki sprawdź — na podstawie tekstu u dołu panelu — czy wszystkie komponenty w bibliotece są obecnie zaznaczone. Jeśli panel Properties nie jest widoczny, kliknij przycisk  Panels button, click to display a menu of available panels w prawym dolnym rogu obszaru roboczego, aby go wyświetlić.

Sprawdź, czy wszystkie elementy są zaznaczone. Sprawdź, czy wszystkie elementy są zaznaczone.

  1. Dodaj wymagany parametr na karcie Parameters panelu. Kliknij przycisk Add, aby dodać nowy parametr domyślny, a następnie zmień jego nazwę zgodnie z potrzebami. Pamiętaj, że parametr został już dodany do wszystkich zaznaczonych komponentów — ponowne kliknięcie przycisku Add spowoduje dodanie kolejnego nowego parametru.

Dodaj wymagany nowy parametr do wszystkich zaznaczonych elementów. Dodaj wymagany nowy parametr do wszystkich zaznaczonych elementów.

Mapowanie pól bazy danych na parametry projektu

Parametry projektu istniejących komponentów — zarówno tych umieszczonych na źródłowych arkuszach schematu projektu, jak i tych zdefiniowanych w bibliotece komponentów schematowych dodanej do pakietu bibliotek — są aktualizowane informacjami przechowywanymi w zewnętrznej firmowej bazie danych za pomocą polecenia Update Parameters From Database, dostępnego w menu głównym Tools, gdy aktywny jest dokument schematu lub biblioteki schematowej.

Gdy komponent projektu zostanie dopasowany do rekordu w tabeli powiązanej bazy danych, dalsze działania zależą od ustawień mapowania i aktualizacji określonych w pliku Database Link. Ustawienia te konfiguruje się na karcie Field Mappings w głównym widoku dokumentu.

Opcje mapowania i aktualizacji określa się osobno dla każdej tabeli.

Określ opcje mapowania i aktualizacji parametrów na karcie Field Mappings dokumentu DbLink.Określ opcje mapowania i aktualizacji parametrów na karcie Field Mappings dokumentu DbLink.

Mapowanie parametrów

Pierwsze dwie kolumny (od lewej) na karcie Field Mappings pozwalają określić, które informacje z bazy danych mają być mapowane na parametry komponentu.

Kolumna Database Field Name zawiera wszystkie nazwy pól (kolumn) w aktualnie aktywnej tabeli bazy danych. Kolumna Design Parameter pozwala określić parametr projektu, który ma być mapowany na odpowiednie pole w bazie danych. Wstępne mapowanie jest wykonywane automatycznie po nawiązaniu połączenia z bazą danych: wszystkie pola bazy danych są mapowane na parametry projektu o takich samych nazwach. Na przykład, jeśli pole w bazie danych nosi nazwę Tolerance, zostanie do niego przypisany parametr projektu o nazwie Tolerance.

Przypisanie parametru projektu można zmienić przez:

  • Kliknięcie jego komórki i bezpośrednie wpisanie nazwy innego parametru.
  • Wybranie istniejącego parametru projektu z listy rozwijanej powiązanej z komórką.

Z komponentem w bazie danych może być powiązana duża liczba pól danych, z których nie wszystkie chcesz lub musisz dodawać jako parametry projektu do istniejącego komponentu projektu. Wiele z tych informacji może być potrzebnych wyłącznie podczas generowania zestawienia materiałowego (BOM). Okno dialogowe Report Manager zawiera opcję umożliwiającą dodawanie informacji o parametrach do zestawienia BOM bezpośrednio z powiązanej bazy danych — pozwala to ograniczyć ilość informacji „przenoszonych” wraz ze źródłowymi dokumentami schematu. Więcej informacji można znaleźć w sekcji Dodawanie informacji z bazy danych bezpośrednio do zestawienia BOM.

W przypadku pól, których nie chcesz mapować z bazy danych, ustaw wartość Design Parameter na [None]. Niezmapowane pola bazy danych są oznaczone na karcie ikoną czerwonego krzyżyka (Cross icon, indicating that a database field is not mapped to a component parameter). Zmapowane pola bazy danych są oznaczone ikoną zielonego znacznika wyboru (Tick icon, indicating that a database field is mapped to a component parameter).

Zdefiniuj mapowanie parametrów zgodnie z potrzebami. Zdefiniuj mapowanie parametrów zgodnie z potrzebami.

Aby szybko ponownie zmapować niezmapowane pole, kliknij wiersz tego pola i użyj skrótu klawiaturowego Ctrl+D. Nazwa parametru projektu będzie identyczna z nazwą odpowiadającego mu pola Database Field Name.

Opcje aktualizacji parametrów

Pozostałe kolumny na karcie Field Mappings pozwalają określić działania wykonywane na parametrach podczas aktualizacji komponentu za pomocą polecenia Tools » Update Parameters From Database. W poniższych opisach termin Altium component oznacza komponent umieszczony na arkuszu schematu lub komponent zdefiniowany w bibliotece komponentów schematowych (będącej częścią pakietu bibliotek).

Są to następujące cztery kolumny:

  • Update Values — komórka w tej kolumnie służy do określenia działania, które należy wykonać, jeśli parametr istnieje zarówno dla komponentu Altium, jak i w bazie danych, ale jego wartości są obecnie różne. Można zaktualizować parametr komponentu Altium wartością zapisaną w bazie danych (Update) albo nie aktualizować go w ogóle (Do not update).
  • Add To Design — komórka w tej kolumnie służy do określenia działania, które należy wykonać, jeśli parametr znajduje się w bazie danych, ale nie istnieje dla komponentu Altium Designer. Można dodać parametr (Add), nie dodawać parametru (Do not add) lub dodać parametr tylko wtedy, gdy ma przypisaną wartość w bazie danych (Add only if not blank in database).
  • Visible On Add — pole wyboru w tej kolumnie określa, czy nowo dodany parametr ma być widoczny dla komponentu Altium (pole zaznaczone), czy nie (pole niezaznaczone).
  • Remove From Design — komórka w tej kolumnie służy do określenia działania, które należy wykonać, jeśli parametr istnieje dla komponentu Altium Designer, ale nie ma go w bazie danych lub istnieje w niej, lecz nie ma wartości. Można nie usuwać parametru w ogóle (Do not remove) albo usuwać go tylko wtedy, gdy nie ma przypisanej wartości w bazie danych (Remove only if blank in database).

Początkowo pola Update Values, Add To Design i Remove From Design — dla każdego zmapowanego pola bazy danych — mają ustawioną wartość Default, a opcja Visible On Add jest wyłączona, jak pokazano na poniższej ilustracji.

Początkowe (domyślne) opcje aktualizacji parametrów.Początkowe (domyślne) opcje aktualizacji parametrów.

Na podstawie ilustracji warto zwrócić uwagę na trzy istotne kwestie dotyczące opcji aktualizacji:

  1. Niezmapowane pola bazy danych nie mają przypisanych opcji aktualizacji.
  2. Pole klucza (np. Part Number na ilustracji) nie ma przypisanych opcji aktualizacji. To pole służy wyłącznie do dopasowywania parametrów.
  3. Ustawienie Default powoduje, że opcja aktualizacji korzysta z odpowiadającej jej definicji domyślnej, określonej na karcie Default Actions w oknie dialogowym Database Link Options (Tools » Options). To okno dialogowe można również otworzyć, klikając przycisk Options w obszarze Field Settings widoku dokumentu.

Zdefiniuj domyślne opcje aktualizacji parametrów w jednym centralnym miejscu.Zdefiniuj domyślne opcje aktualizacji parametrów w jednym centralnym miejscu.

Trzecia kwestia jest przydatna, ponieważ pozwala określić opcje aktualizacji w jednym centralnym miejscu, a następnie odwoływać się do niego podczas definiowania opcji aktualizacji dla każdego zmapowanego pola. Dlatego wartość Default jest automatycznie wprowadzana do odpowiednich pól aktualizacji po zmapowaniu pola bazy danych na parametr projektu.

Aby zastąpić domyślne ustawienie opcji aktualizacji, kliknij odpowiednie pole aktualizacji na karcie Field Mappings, a następnie kliknij ponownie, aby otworzyć listę rozwijaną z dostępnymi opcjami aktualizacji.

W razie potrzeby można ręcznie zastąpić domyślne opcje aktualizacji parametrów.W razie potrzeby można ręcznie zastąpić domyślne opcje aktualizacji parametrów.

W ten sposób masz pełną kontrolę nad aktualizacją parametrów w projekcie. Możesz ustawić wszystkie pola na Default i podejmować wymagane decyzje dotyczące aktualizacji w oknie dialogowym Database Link Options, ustawić każde pole aktualizacji osobno lub połączyć oba podejścia — wybór należy wyłącznie do Ciebie. Aktualizacja jest przeprowadzana za pomocą okna dialogowego Engineering Change Order. Jeśli na tym etapie pojawią się aktualizacje, których wolisz nie wprowadzać, możesz wykluczyć te konkretne zmiany — dzięki temu to Ty ostatecznie decydujesz, które parametry projektu zostaną zaktualizowane.

Zapewnienie synchronizacji

Po skonfigurowaniu opcji mapowania i aktualizacji w pliku Database Link zgodnie z wymaganiami oraz zapisaniu pliku możesz przekazywać informacje z bazy danych do zmapowanych parametrów komponentów Altium Designer. Pamiętaj, że wybrany parametr pola kluczowego służy do utrzymania powiązania komponentu Altium Designer z odpowiadającym mu rekordem w zewnętrznej bazie danych. Oznacza to, że w dowolnym momencie w przyszłości zmiany informacji o parametrach w bazie danych można łatwo przenieść do komponentu Altium Designer, synchronizując oba źródła. Aktualizacje wykonuje się za pomocą polecenia Update Parameters From Database, dostępnego w menu głównym Tools edytora schematów lub edytora bibliotek schematów.

Podwójna synchronizacja — DbLib/SVNDbLib i DBLink

Możesz mieć istniejący projekt, w którym większość umieszczonych elementów została powiązana z zewnętrzną bazą danych za pomocą pliku DbLink. Zmiany w projekcie mogą wymagać dodania nowych obwodów, których komponenty można umieścić za pomocą funkcji Biblioteka bazodanowa. Powiązany plik DbLib/SVNDbLib może przy tym wskazywać inną zewnętrzną bazę danych.

Podczas korzystania z polecenia Update Parameters From Database sprawdzane są wszystkie powiązane parametry umieszczonych komponentów — we wszystkich powiązanych bazach danych, niezależnie od zastosowanej metody powiązania — a wykryte różnice w tych parametrach są wyświetlane w oknie dialogowym wyboru zmian parametrów.

Jeśli do dopasowywania w plikach DbLink i DbLib/SVNDbLib użyto tego samego pola bazy danych, najpierw zostanie przeszukana baza danych powiązana przez plik DbLink, a następnie baza danych powiązana przez plik DbLib/SVNDbLib. Jeśli komponent występuje w obu bazach danych, może dojść do dopasowania i aktualizacji na podstawie niewłaściwego rekordu zewnętrznego.

Dodawanie informacji z bazy danych bezpośrednio do BOM

Related page: Konfiguracja BOM w menedżerze raportów

W przeszłości informacje źródłowe do zestawienia materiałowego (BOM) pobierano z parametrów komponentów umieszczonych w projekcie. Może to jednak prowadzić do dołączania do schematu dużej ilości informacji wykorzystywanych wyłącznie w BOM. Jeśli umieszczone komponenty Altium Designer są powiązane z zewnętrzną bazą danych za pomocą pliku DbLink, generator BOM może pobrać wszelkie pozostałe informacje z rekordu, które nie zostały dodane do komponentów jako parametry projektu.

Parametry z zewnętrznej bazy danych można uwzględniać niezależnie od metody użytej do powiązania z tą bazą — DbLink, DbLib lub SVNDbLib.

Podczas konfigurowania raportu zestawienia materiałowego w oknie dialogowym menedżera raportów kliknij przycisk Database Parameters (  Database Parameters source button, click to make linked database parameters available in the Report Manager ) na karcie Columns, aby uwzględnić je jako źródło danych dla BOM, jak pokazano poniżej. Ta opcja jest dostępna tylko wtedy, gdy co najmniej jeden komponent w projekcie jest powiązany z zewnętrzną bazą danych.

Na liście Columns ikona Database icon, indicates that this parameter comes from the database służy do oznaczania parametrów, które występują w powiązanej zewnętrznej bazie danych dla co najmniej jednego umieszczonego komponentu. Kliknij ikonę widoczności, aby zmieniła się w ikonę oka ( Visibility icon ) i uwzględnić daną kolumnę (parametr) w BOM.

Uwzględnij dodatkowe informacje o komponentach dostępne wyłącznie w zewnętrznej bazie danych.Uwzględnij dodatkowe informacje o komponentach dostępne wyłącznie w zewnętrznej bazie danych.

W przypadku projektu zawierającego warianty parametry używane do wyszukiwania w bazie danych są modyfikowane w oknie dialogowym zarządzania wariantami. Ponieważ te wartości parametrów istnieją tylko w oknie dialogowym Variant Management, są używane do wyszukiwania i dopasowywania rekordów w bazie danych wyłącznie podczas konfigurowania BOM do wygenerowania. W tym celu upewnij się, że na karcie General we właściwościach Report Manager włączona jest opcja podrzędna — Include DB Parameters in Variations.

Altium Designer zawiera również zaawansowany edytor BOM o nazwie ActiveBOM. ActiveBOM oferuje pełny zestaw funkcji zarządzania BOM, w tym możliwość dodawania kolejnych pozycji BOM, a także ścisłą integrację z łańcuchem dostaw komponentów.

► Dowiedz się więcej o ActiveBOM

AI-LocalizedTłumaczenie SI
Jeśli znajdziesz błąd, zaznacz tekst/obraz i naciśnij Ctrl + Enter aby wysłać nam wiadomość.
Nav
Contents
Dostępność funkcji

Dostępne funkcje zależą od tego, z którego rozwiązania Altium korzystasz – Altium Develop, Altium Agile Teams, Altium Agile Enterprise lub Altium Designer (w ramach aktywnej subskrypcji terminowej).

Jeśli opisana funkcja nie jest widoczna w Twoim oprogramowaniu, skontaktuj się z działem sprzedaży Altium, aby dowiedzieć się więcej.

Starsza dokumentacja

Dokumentacja Altium Designer nie jest już wersjonowana. Jeśli potrzebujesz dostępu do dokumentacji dla starszych wersji Altium Designer, odwiedź sekcję Starsza dokumentacja na stronie Inne instalatory.

Contents