Praca z blokami wielokrotnego użytku i fragmentami kodu (stary panel ponownego użycia projektu)
W skrócie
- Poznaj różnice między blokami wielokrotnego użytku, fragmentami schematów i fragmentami PCB oraz dowiedz się, kiedy korzystać z każdego z nich.
- Zobacz, jak korzystać z panelu Design Reuse do znajdowania, filtrowania, sortowania i przeszukiwania treści projektowych wielokrotnego użytku oraz zarządzania nimi.
- Prześledź kroki tworzenia, zapisywania, zmieniania nazw i porządkowania bloków wielokrotnego użytku oraz fragmentów projektów zarówno w przestrzeni roboczej, jak i w lokalizacjach lokalnych.
Jeśli Twoje projekty często zawierają powtarzające się „sekcje” obwodów, Altium Designer zapewnia prosty i wygodny sposób zapisywania i ponownego wykorzystywania fragmentów obwodów — zarówno przechowywanych w Workspace, jak i lokalnie, w plikach. Takie sekcje można dodawać do dowolnego projektu PCB bez konieczności rozpoczynania za każdym razem od zera. To doskonałe rozwiązanie dla często używanych fragmentów i mniejszych sekcji obwodów, które chcesz wykorzystywać ponownie. System umożliwia zapisanie dowolnego zaznaczonego fragmentu:
-
Obwodu na pojedynczym arkuszu schematu (fragment schematu).
-
Obwodu w projekcie PCB, wraz z komponentami i ścieżkami (fragment PCB).
Po połączeniu z Workspace możesz utworzyć pojedynczy obiekt — blok do ponownego wykorzystania — zawierający zarówno obwód na schemacie, jak i jego fizyczną reprezentację na PCB. Po umieszczeniu takiego bloku na arkuszu schematu jego fizyczna reprezentacja zostanie automatycznie umieszczona w dokumencie PCB podczas procesu ECO.
Panel Design Reuse stanowi centrum tworzenia i zarządzania blokami oraz fragmentami do ponownego wykorzystania, a także korzystania z nich — zarówno tych przechowywanych w Workspace, jak i lokalnie w plikach.
Panel można otworzyć na następujące sposoby:
- Kliknij przycisk Panels w prawym dolnym rogu obszaru projektowania, a następnie kliknij Design Reuse.
- Wybierz View » Panels » Design Reuse z menu głównego.
- Wybierz Place » Reuse Block z menu głównego.
Górna lista rozwijana panelu zawiera wszystkie dostępne foldery istniejące w połączonym Workspace, które zawierają bloki i fragmenty do ponownego wykorzystania przechowywane w Workspace. Liczba obok nazwy każdego folderu wskazuje, ile bloków i fragmentów do ponownego wykorzystania zawiera ten folder wraz z podfolderami. Wybierz folder z listy rozwijanej, aby wyświetlić w głównej części panelu bloki i fragmenty zawarte w tym folderze i jego podfolderach. Wybierz z listy pozycję odpowiadającą połączonemu Workspace, aby wyświetlić wszystkie dostępne bloki i fragmenty do ponownego wykorzystania.
Użyj przycisków filtrowania w menu podręcznym ikony
, aby pokazać lub ukryć w panelu zawartość określonych typów (Reuse Blocks, Schematic Snippets, PCB Snippets). Użyj elementu sterującego Sort By, aby wybrać preferowaną opcję sortowania.

Użyj opcji filtrowania i sortowania, aby skonfigurować wyświetlanie zawartości w panelu
Aby wyszukać dostępne bloki i fragmenty do ponownego wykorzystania w wybranym folderze według nazwy lub opisu, wpisz frazę w polu Search. Pozwoli to skutecznie przefiltrować listę i zawęzić ją do pozycji odpowiadających Twoim potrzebom.
Każdy blok i fragment do ponownego wykorzystania jest prezentowany w głównej części panelu jako kafelek zawierający następujące dane:
-
Obraz podglądu — kliknięcie umożliwia przełączanie między widokiem normalnym a pełnowymiarowym. W przypadku bloku do ponownego wykorzystania użyj przycisku
, aby przełączać się między podglądem dokumentu PCB a podglądem schematu;
-
Ikona typu —
dla bloku do ponownego wykorzystania,
dla fragmentu schematu,
dla fragmentu PCB;
-
Nazwa i opis (jeśli został zdefiniowany);
-
Identyfikator najnowszej rewizji, data utworzenia i autor bloku do ponownego wykorzystania lub fragmentu schematu/PCB przechowywanego w Workspace.

Informacje o bloku lub fragmencie do ponownego wykorzystania oraz elementy sterujące są prezentowane na kafelku w panelu.
Tworzenie bloku do ponownego wykorzystania
Nowy blok do ponownego wykorzystania można utworzyć na następujące sposoby:
-
Wybierz polecenie tworzenia nowego bloku do ponownego wykorzystania:
-
W panelu Design Reuse, klikając przycisk
u góry panelu.
-
Za pomocą polecenia File » New » Reuse Block z menu głównego.
-
W panelu Explorer, klikając przycisk
w prawym górnym rogu panelu podczas przeglądania folderu typu Design Reuse Blocks.
-
-
W panelu Projects (pod pozycją odpowiadającą aktualnie połączonemu Workspace) zostanie otwarta tymczasowa, edytowalna struktura bloku do ponownego wykorzystania, przypominająca projekt PCB. W głównym oknie projektowania zostanie otwarty tymczasowy edytor schematów, gotowy do zdefiniowania dokumentu schematu tego bloku. Użyj standardowych poleceń i technik umieszczania obiektów, aby zdefiniować dokument schematu bloku do ponownego wykorzystania.
-
Po zakończeniu użyj polecenia Design » Update PCB Document i procesu ECO, aby przenieść utworzony schemat do dokumentu PCB bloku do ponownego wykorzystania, a następnie wprowadź w tym dokumencie niezbędne zmiany (rozmieszczenie komponentów, trasowanie ścieżek itp.).
Po zdefiniowaniu dokumentów schematu i PCB bloku do ponownego wykorzystania zapisz go w Workspace za pomocą polecenia Save to Server z menu kontekstowego pozycji tego bloku w panelu Projects lub elementu sterującego Save to Server po prawej stronie tej pozycji.
-
Pojawi się okno dialogowe New Reuse Block, w którym można określić Name, Description oraz Folder w Workspace, w którym zostanie zapisany nowy blok wielokrotnego użytku.

Okno dialogowe New Reuse BlockOpcje i elementy sterujące okna dialogowego nowego bloku wielokrotnego użytku
- Name – wprowadź nazwę nowego bloku wielokrotnego użytku lub fragmentu.
- Description – w tym polu wprowadź opis, który jasno wyjaśnia, co przedstawia ten blok wielokrotnego użytku lub fragment.
-
Folder – folder w Workspace, w którym będzie przechowywany ten blok wielokrotnego użytku lub fragment. Kliknij
, aby otworzyć okno dialogowe Choose Folder i wybrać lub utworzyć inny folder.
-
Po kliknięciu OK blok wielokrotnego użytku zostanie zapisany w Workspace, a jego tymczasowa struktura zostanie zamknięta.
Zapisany blok wielokrotnego użytku można następnie znaleźć w panelu Design Reuse, wybierając z górnej listy rozwijanej folder, w którym został zapisany (lub pozycję odpowiadającą połączonemu Workspace). Aby nowy blok wielokrotnego użytku pojawił się w panelu, może być konieczne użycie polecenia Refresh z menu przycisku
.
Zmiana nazwy bloku wielokrotnego użytku
Po utworzeniu bloku wielokrotnego użytku można w razie potrzeby nadać mu bardziej odpowiednią nazwę. Aby zmienić nazwę bloku wielokrotnego użytku, użyj polecenia Rename , dostępnego w podmenu
oraz w menu kontekstowym otwieranym prawym przyciskiem myszy w panelu Design Reuse . W otwartym oknie dialogowym Rename Reuse Block wprowadź nową nazwę, a następnie kliknij OK. Blok wielokrotnego użytku ma teraz żądaną nazwę, jak pokazano na poniższych ilustracjach.
Tworzenie fragmentu
Nowy fragment schematu lub PCB można szybko utworzyć z istniejącego układu na arkuszu schematu lub w dokumencie PCB:
-
Zaznacz żądany układ w edytorze schematów lub PCB.
-
Kliknij prawym przyciskiem myszy i wybierz Snippets » Create Snippet from selected objects z menu kontekstowego lub wybierz polecenie Tools » Convert » Create Snippet from selected objects z menu głównego.
-
Pojawi się okno dialogowe New Schematic Snippet lub New PCB Snippet, w którym można określić nazwę, opis, miejsce zapisu (Workspace lub folder lokalny) oraz folder, w którym zostanie zapisany nowy fragment.
Podczas zapisywania fragmentu w folderze lokalnym kliknij przycisk
po prawej stronie pola Path w oknie dialogowym, aby otworzyć okno dialogowe Choose Snippet Folder, które umożliwia wybranie istniejącego lokalnego folderu fragmentów jako miejsca zapisu lub utworzenie nowego podfolderu w istniejącym lokalnym folderze fragmentów.
-
Po kliknięciu OK fragment zostanie zapisany.
Zapisany fragment można następnie znaleźć w panelu Design Reuse, wybierając z górnej listy rozwijanej pozycję odpowiadającą połączonemu Workspace (lub folder, w którym został zapisany).

Fragment można utworzyć z zestawu zaznaczonych obiektów. Tutaj pokazano tworzenie fragmentu schematu. Najedź kursorem na ilustrację, aby zobaczyć tworzenie fragmentu PCB.
Aby nowy blok wielokrotnego użytku pojawił się w panelu, może być konieczne użycie polecenia Refresh z menu przycisku
panelu.
Fragment przechowywany w Workspace można również utworzyć z istniejącego fragmentu lokalnego, klikając przycisk
na kafelku fragmentu (lub klikając prawym przyciskiem myszy w dowolnym miejscu kafelka) i wybierając z menu polecenie Save to Server. W wyświetlonym oknie dialogowym New Schematic Snippet lub New PCB Snippet określ Name, Description oraz Folder w Workspace, w którym zostanie zapisany fragment.

Lokalny fragment można zapisać w połączonym Workspace za pomocą polecenia Save to Server.
Organizacja lokalnych fragmentów
Panel Design Reuse umożliwia organizowanie lokalnych fragmentów w folderach, dzięki czemu powiązane fragmenty można grupować, co ułatwia ich znajdowanie. Foldery fragmentów to istniejące foldery systemu Windows, których nie można tworzyć z poziomu panelu Design Reuse. Zamiast tego są one „otwierane” lub „zamykane” podczas przeglądania zawartych w nich lokalnych fragmentów. Foldery te można tworzyć wyłącznie bezpośrednio na dysku twardym lub w sieci, poza Altium Designer.
Foldery fragmentów można otwierać i zamykać w oknie dialogowym Available Snippets Folders, dostępnym po kliknięciu przycisku
w prawym górnym rogu panelu Design Reuse i wybraniu z menu polecenia Snippet Folders. Kliknij Open Folder, aby wskazać żądany folder na dysku twardym lub w sieci. Wybrany folder zostanie dodany do listy w oknie dialogowym, a następnie pojawi się na liście rozwijanej u góry panelu Design Reuse.
Aby usunąć folder fragmentów z listy (czyli zamknąć go na potrzeby przeglądania), zaznacz go na liście, a następnie kliknij Remove Folder. Użyj przycisków Move Up i Move Down, aby zmienić kolejność wyświetlania lokalnych fragmentów w panelu Design Reuse, gdy na liście rozwijanej panelu wybrana jest pozycja Local.
Umieszczanie bloków wielokrotnego użytku i fragmentów
Aby umieścić blok wielokrotnego użytku lub fragment w projekcie, kliknij jego kafelek, a następnie przycisk
, kliknij przycisk
na jego kafelku lub kliknij prawym przyciskiem myszy w dowolnym miejscu kafelka i wybierz jedno z poniższych poleceń:
- Place – wybierz, aby umieścić blok wielokrotnego użytku lub fragment bezpośrednio w aktywnym dokumencie schematu lub PCB.
- Place as Sheet Symbol – gdy aktywny jest dokument schematu, wybierz, aby umieścić blok wielokrotnego użytku lub fragment schematu jako symbol arkusza na arkuszu schematu. Zawartość bloku wielokrotnego użytku lub fragmentu schematu zostanie umieszczona na automatycznie utworzonym podrzędnym arkuszu schematu, do którego odwołuje się umieszczony symbol arkusza.

Umieść blok do ponownego użycia lub fragment, korzystając z menu przycisku Place na jego kafelku w panelu. Tutaj pokazano wybór polecenia Place, które umieszcza blok do ponownego użycia / fragment schematu na aktywnym arkuszu schematu. Najedź kursorem na obraz, aby zobaczyć wybór polecenia Place as Sheet Symbol, które umieszcza blok do ponownego użycia / fragment schematu na arkuszu podrzędnym wskazywanym przez umieszczony symbol arkusza.
Kliknij element sterujący Show more na kafelku bloku do ponownego użycia, aby wyświetlić sekcję PCB zawierającą listę dokumentów PCB tego bloku. Wybierz wymagany dokument PCB z listy, a blok do ponownego użycia zostanie umieszczony wraz z tym dokumentem. Wybrany dokument PCB jest wyświetlany w obszarze podglądu kafelka bloku do ponownego użycia, gdy do podglądu wybrano PCB.

Wybierz dokument PCB, który ma zostać umieszczony wraz z blokiem do ponownego użycia, aby wyświetlić jego podgląd.
Po umieszczeniu dokumentu schematu bloku do ponownego użycia jego dokument PCB można umieścić w docelowym dokumencie PCB za pomocą procesu ECO. W edytorze schematów wybierz polecenie Design » Update PCB Document z menu głównego, a następnie zweryfikuj i wykonaj zmiany w oknie dialogowym Engineering Change Order. Dokument PCB zostanie umieszczony w docelowym dokumencie PCB jako zgrupowanie (union), którym można zarządzać w trybie Unions panelu PCB.
Gdy wybrany komponent schematu lub PCB jest częścią bloku do ponownego użycia umieszczonego w projekcie, możesz sprawdzić właściwości tego bloku, klikając łącze Reuse Block w panelu Properties . W panelu zostaną wyświetlone właściwości nadrzędnego bloku do ponownego użycia, do którego należy komponent. Aby wrócić do właściwości pierwotnie wybranego komponentu, użyj łącza Component.

Otwórz właściwości bloku do ponownego użycia z poziomu komponentu należącego do tego bloku. Powyższe obrazy przedstawiają dostęp do właściwości z poziomu komponentu schematu. Najedź kursorem na obraz, aby zobaczyć dostęp z poziomu komponentu PCB.
Edytowanie bloków do ponownego użycia i fragmentów
Aby edytować blok do ponownego użycia lub fragment przechowywany w obszarze roboczym, kliknij przycisk
na jego kafelku (lub kliknij prawym przyciskiem myszy w dowolnym miejscu kafelka) i wybierz z menu polecenie Edit.

Otwórz do edycji blok do ponownego użycia lub fragment przechowywany w obszarze roboczym, korzystając z polecenia Edit dostępnego na jego kafelku w panelu.
Zostanie otwarty tymczasowy edytor, a w nim do edycji dokument zawierający źródłowy blok do ponownego użycia lub fragment, pochodzący z najnowszej rewizji elementu w obszarze roboczym. Wprowadź wymagane zmiany, a następnie zapisz dokument jako kolejną rewizję bloku do ponownego użycia lub fragmentu, korzystając z polecenia File » Save to Server w menu głównym albo polecenia Save to Server w menu kontekstowym wpisu bloku do ponownego użycia lub fragmentu w panelu Projects.
Właściwości lokalnego fragmentu (nazwę, opis i ścieżkę) można edytować w oknie dialogowym Snippet Properties, otwieranym przez kliknięcie przycisku
na kafelku lokalnego fragmentu (lub kliknięcie prawym przyciskiem myszy w dowolnym miejscu kafelka) i wybranie z menu polecenia Edit Properties.

Edytuj właściwości lokalnego fragmentu w oknie dialogowym Snippet Properties, otwieranym z panelu Design Reuse.
Usuwanie bloków do ponownego użycia i fragmentów
Aby usunąć blok do ponownego użycia lub fragment, kliknij przycisk
na jego kafelku (lub kliknij prawym przyciskiem myszy w dowolnym miejscu kafelka) i wybierz z menu polecenie Delete.
-
W przypadku bloku do ponownego użycia lub fragmentu przechowywanego w obszarze roboczym pojawi się okno dialogowe Delete Items, w którym należy potwierdzić usunięcie. W rzeczywistości jest to „usunięcie nietrwałe”, w wyniku którego blok do ponownego użycia lub fragment zostanie przeniesiony do obszaru Trash w obszarze roboczym. Obszar Trash pełni funkcję kosza, do którego można przenieść dowolną zawartość obszaru roboczego w ramach usunięcia nietrwałego. Jest on odizolowany od pozostałej części obszaru roboczego. W przypadku bloku do ponownego użycia można również usunąć powiązaną z nim zawartość (np. fragmenty schematu i PCB).

Usuń nietrwale blok do ponownego użycia lub fragment, korzystając z polecenia Delete dostępnego na jego kafelku w panelu. -
W przypadku lokalnego fragmentu pojawi się okno dialogowe Confirm z prośbą o potwierdzenie usunięcia. Ta operacja usunie pliki fragmentu z dysku twardego.


