Praca z zarządzanymi arkuszami schematów

W skrócie

W tym artykule wyjaśniamy, jak zarządzane arkusze schematów w połączonym obszarze roboczym Altium Designer sprawiają, że ponowne wykorzystanie projektów jest bardziej niezawodne, spójne i łatwiejsze do prześledzenia niż zwykłe kopiowanie i wklejanie. Dowiesz się, czym jest zarządzany arkusz schematu, czym różni się od arkuszy urządzeń, jak jest przechowywany i wersjonowany w obszarze roboczym oraz jakie są główne sposoby jego tworzenia i zapisywania do wykorzystania w przyszłości. Zobaczysz również, jak typ folderu, typ zawartości, nazewnictwo, cykl życia i bezpośrednia edycja wpisują się w proces tworzenia schematów wielokrotnego użytku, na których Twój zespół może polegać. Czytaj dalej, aby dowiedzieć się, jak arkusze zarządzane w obszarze roboczym pomagają z większą pewnością ponownie wykorzystywać sprawdzone bloki projektowe.

- Dowiedz się, czym są zarządzane arkusze schematów, jak wspierają ponowne wykorzystanie projektów i dlaczego przechowywanie ich w obszarze roboczym zapewnia kontrolę wersji, identyfikowalność i integralność zawartości.
- Poznaj różne sposoby tworzenia i zapisywania zarządzanych arkuszy schematów, w tym bezpośrednią edycję, zapisywanie bieżącego arkusza i przesyłanie dokumentu schematu do określonej rewizji.
- Zobacz, jak szczegóły konfiguracji, takie jak typ folderu, typ zawartości, schematy nazewnictwa i ustawienia cyklu życia, pomagają porządkować schematy wielokrotnego użytku i nimi zarządzać.
Zagłęb się w temat dzięki AI:

Możliwość ponownego wykorzystania zawartości projektowej to coś, do czego dążą wszystkie firmy zajmujące się rozwojem produktów i co może przynieść im znaczne korzyści. Ponowne wykorzystanie nie tylko oszczędza czas — możliwość łatwego użycia fragmentu wcześniejszego projektu oznacza również, że cała kwalifikacja i wszystkie testy tej części projektu zostały już przeprowadzone. Ponowne wykorzystanie projektu to jednak znacznie więcej niż kopiowanie i wklejanie. Wymaga ono zablokowania zawartości, aby mieć pewność, że jest ona taka sama jak wcześniej. Nie ma tu miejsca na szybkie zmiany koloru komponentu czy drobne korekty wartości rezystora. Praca z zawartością wielokrotnego użytku musi przypominać pracę z gotowymi komponentami: umieszczasz zawartość, podłączasz ją i działa ona dokładnie tak samo jak poprzednio.

Altium Designer w połączeniu z podłączonym obszarem roboczym umożliwia tworzenie w tym obszarze zarządzanych arkuszy schematu (elementów typu Managed Schematic Sheet). Takie arkusze można tworzyć:

  • Poprzez bezpośrednią edycję.

  • Poprzez zapisanie bieżącego arkusza schematu w obszarze roboczym.

  • Poprzez przesłanie odpowiedniego dokumentu schematu (*.SchDoc) do rewizji docelowego zarządzanego arkusza schematu.

Po utworzeniu zarządzanego arkusza schematu (i zapisaniu danych w jego rewizji) można go ponownie wykorzystać w przyszłych projektach płytek.

Czym właściwie jest zarządzany arkusz schematu?

Zarządzany arkusz schematu to standardowy arkusz schematu Altium Designer zawierający komponenty i połączenia, zapisany w obszarze roboczym w celu ponownego wykorzystania w innych projektach. Edytuje się go tak samo jak każdy inny arkusz schematu. Koncepcja zarządzanego arkusza schematu nie ogranicza się przy tym do pojedynczego arkusza — w projekcie można umieścić zarządzany arkusz schematu, który znajduje się na szczycie hierarchii innych zarządzanych arkuszy schematu.

Zarządzane arkusze schematu różnią się od arkuszy urządzeń tym, że są przechowywane w obszarze roboczym, podczas gdy arkusze urządzeń są przechowywane w folderze na dysku twardym. Dzięki temu zarządzane arkusze korzystają z zalet zawartości obszaru roboczego, takich jak uproszczone przechowywanie, wymuszona kontrola wersji oraz, oczywiście, zapewniona integralność.

► Zobacz informacje o lokalnie zarządzanych arkuszach urządzeń.

Decyzja o przejściu z arkuszy urządzeń na zarządzane arkusze schematu pojawia się wtedy, gdy chcemy przejść od zawartości wielokrotnego użytku do Workspace zawartości wielokrotnego użytku — czyli wtedy, gdy pojawia się chęć lub potrzeba kontrolowania wydań tej zawartości projektowej i zapewnienia całemu zespołowi jednego źródła tej zawartości.

Przechowywanie arkusza w obszarze roboczym daje pewność, że rewizję zarządzanego arkusza schematu używaną w projekcie można w razie potrzeby łatwo zidentyfikować i prześledzić jej pochodzenie. Ponieważ jest to zawartość obszaru roboczego, można w razie potrzeby tworzyć jej nowe rewizje i ją aktualizować, a także śledzić wszystkie zależności związane z jej wykorzystaniem — zarówno w dół, do komponentów na danym arkuszu, jak i w górę, do projektów korzystających z tego arkusza. Zapewnia to wszystkie informacje niezbędne do podjęcia decyzji, czy zaktualizowany arkusz należy wprowadzić do istniejących projektów, czy też dany projekt musi nadal korzystać z poprzedniej rewizji.

Typ folderu

Podczas tworzenia folderu do przechowywania zarządzanych arkuszy schematu można określić jego typ. Nie ma to wpływu na zawartość folderu — zapisanie arkusza schematu zawsze spowoduje utworzenie odpowiadającego mu elementu typu Managed Schematic Sheet. Typ stanowi jedynie wizualną wskazówkę dotyczącą zawartości folderu i może być przydatny podczas przeglądania obszaru roboczego w poszukiwaniu określonej zawartości. Aby wskazać, że folder służy do przechowywania zarządzanych arkuszy schematu, podczas definiowania jego właściwości w oknie dialogowym Edit Folder ustaw Folder Type na Managed Schematic Sheets.

Określenie typu folderu — jego przeznaczenia — pozwala wizualnie rozpoznać jego zawartość podczas przeglądania obszaru roboczego.
Określenie typu folderu — jego przeznaczenia — pozwala wizualnie rozpoznać jego zawartość podczas przeglądania obszaru roboczego.

Typ zawartości

Podczas tworzenia docelowego elementu typu Managed Schematic Sheet, w którym ma być przechowywany arkusz schematu, upewnij się, że w oknie dialogowym Create New Item jego Content Type ma wartość Managed Schematic Sheet. Jeśli tworzysz element w folderze typu Managed Schematic Sheets, ten typ zawartości będzie dostępny w menu kontekstowym wywoływanym prawym przyciskiem myszy podczas tworzenia elementu.

Tworzenie zarządzanego arkusza schematu w folderze Managed Schematic Sheets — odpowiedni Content Type jest dostępny w menu kontekstowym.
Tworzenie zarządzanego arkusza schematu w folderze Managed Schematic Sheets — odpowiedni Content Type jest dostępny w menu kontekstowym.

Zapisywanie arkusza schematu

Related page: Tworzenie i edytowanie zawartości

Do tej pory omówiliśmy obsługę zarządzanych arkuszy schematu w przestrzeni roboczej w kontekście powiązanych typów folderów i zawartości. Zapisanie zdefiniowanego arkusza schematu w rewizji elementu typu Managed Schematic Sheet można przeprowadzić na kilka sposobów, opisanych w poniższych sekcjach.

Aby ułatwić ponowne wykorzystywanie zarządzanych arkuszy w projektach, zdecydowanie zaleca się ręczne nadanie oznaczeń na arkuszu schematu (Tools » Annotation » Annotate Schematics) przed zapisaniem go jako arkusza zarządzanego. Po ukończeniu projektu wykorzystującego zarządzane arkusze można ponownie ponumerować wszystkie arkusze i komponenty w całym projekcie.

► Więcej informacji zawiera sekcja Nadawanie oznaczeń komponentom i arkuszom poniżej.

Edycja bezpośrednia

Dzięki obsłudze edycji bezpośredniej w przestrzeni roboczej arkusz schematu można edytować i zapisać w początkowej rewizji nowo utworzonego elementu typu Managed Schematic Sheet. Edycja bezpośrednia eliminuje konieczność korzystania z oddzielnych danych źródłowych objętych kontrolą wersji. Obsługiwany typ zawartości można po prostu edytować w tymczasowym edytorze, do którego wczytywane są najnowsze dane źródłowe bezpośrednio z przestrzeni roboczej. Po zakończeniu edycji obiekt jest zapisywany (lub zapisywany ponownie) w kolejnej zaplanowanej rewizji jego elementu nadrzędnego, a tymczasowy edytor zostaje zamknięty. Nie ma plików na dysku twardym, wątpliwości, czy pracujesz na właściwych lub najnowszych danych źródłowych, ani konieczności utrzymywania oddzielnego oprogramowania do kontroli wersji. Przestrzeń robocza obsługuje to wszystko, zapewniając spójność danych i znacznie przyspieszając wprowadzanie w nich zmian.

Podczas tworzenia elementu typu Managed Schematic Sheet możesz wybrać opcję edycji i zapisania arkusza schematu w jego początkowej rewizji po utworzeniu elementu. W tym celu włącz opcję Open for editing after creation u dołu okna dialogowego Create New Item (jest ona domyślnie włączona). Element zostanie utworzony i otworzy się tymczasowy edytor schematów, w którym dokument .SchDoc będzie aktywnym dokumentem w głównym oknie projektowym. Nazwa tego dokumentu będzie odpowiadać elementowi i jego rewizji, w formacie: <Item><Revision>.SchDoc (np. SCH-0007-1.SchDoc).

Jeśli w przestrzeni roboczej zapisano co najmniej jeden szablon schematu, pojawi się okno dialogowe Select configuration item (Schematic Templates). Wybierz w nim szablon, który ma zostać zastosowany do dokumentu schematu.

Przykład edycji początkowej rewizji zarządzanego arkusza schematu bezpośrednio z przestrzeni roboczej — tymczasowy edytor schematów udostępnia dokument służący do zdefiniowania arkusza schematu.
Przykład edycji początkowej rewizji zarządzanego arkusza schematu bezpośrednio z przestrzeni roboczej — tymczasowy edytor schematów udostępnia dokument służący do zdefiniowania arkusza schematu.

Użyj tego dokumentu, aby zdefiniować arkusz schematu zgodnie z wymaganiami. Ponieważ zarządzane arkusze schematu są przechowywane w przestrzeni roboczej, umieszczone na nich komponenty również powinny być w niej przechowywane. Pozwala to w pełni wykorzystać możliwości systemu zarządzania zawartością oferowanego przez przestrzeń roboczą, w tym identyfikować i odnajdywać wszystkie komponenty użyte w zarządzanym arkuszu schematu (elementy podrzędne), a także projekty, w których ten arkusz został użyty (miejsca użycia). Więcej informacji zawiera sekcja Tworzenie i utrzymywanie komponentów oraz bibliotek.

Możliwość wykorzystywania komponentów z przestrzeni roboczej do tworzenia większych bloków projektowych pozwala coraz bardziej usprawniać proces projektowania i pracować na wyższym poziomie abstrakcji. Projektant, niczym podczas wybierania części z półki, ponownie wykorzystuje te zarządzane arkusze schematu realizujące określone funkcje jako elementy składowe większego projektu. Im więcej zarządzanych arkuszy schematu z takimi układami zostanie utworzonych i zapisanych w przestrzeni roboczej, tym więcej funkcji będzie dostępnych dla projektanta, co z kolei zwiększy wydajność pracy przy kolejnych projektach.

Podczas edycji bezpośredniej dostępne są trzy istotne przyciski, które można znaleźć w Quick Access Bar (w lewym górnym rogu głównego okna aplikacji) lub na pasku narzędzi Schematic Standard:

  • – Save Active Document. Użyj tego przycisku, aby lokalnie zapisać wszelkie zmiany wprowadzone w dokumencie. Pozwala to zapisać bieżące zmiany, jeśli chcesz wrócić do edycji później i wprowadzić kolejne zmiany przed ostatecznym zapisaniem w Workspace.
  • / – Save to Workspace. Użyj tego przycisku, aby zapisać zdefiniowany arkusz schematu w Workspace, w początkowej (planowanej) rewizji docelowego elementu zarządzanego arkusza schematu. Pojawi się okno dialogowe Edit Revision, w którym można zmienić nazwę i opis oraz w razie potrzeby dodać informacje o wydaniu. Po zapisaniu dokument i edytor zostaną zamknięte. Dokument zawierający źródłowy arkusz schematu (*.SchDoc) zostanie zapisany w rewizji elementu.

    Przycisk Save to Server jest również dostępny po prawej stronie wpisu arkusza schematu bezpośrednio w panelu Projects.
  • / – Discard Local Changes. Użyj tego przycisku, jeśli chcesz anulować edycję i odrzucić wszystkie wprowadzone zmiany. Dokument i edytor zostaną zamknięte, a żadne zmiany nie zostaną zapisane w docelowym elemencie zarządzanego arkusza schematu.

Te funkcje są również dostępne jako polecenia — Save (skrót: Ctrl+S), Save to Server (skrót: Ctrl+Alt+S) oraz Discard Local Changes — w menu głównym File oraz w menu kontekstowym wpisu arkusza schematu w panelu Projects.

Dane zapisane w Workspace obejmują źródłowy arkusz schematu zdefiniowany w pliku dokumentu schematu (<Item><Revision>.SchDoc) oraz wszelkie powiązane pliki definicji wiązek (*.Harness). W panelu Explorer przejdź na kartę widoku Preview, aby zobaczyć graficzną reprezentację arkusza wraz z listą jego komponentów (oraz szablonem zarządzanego arkusza schematu, jeśli ma zastosowanie).

Kliknij hiperłącze podrzędnej rewizji elementu komponentu, aby przejść do niej w panelu Explorer. Obszar elementów podrzędnych udostępnia również menu kontekstowe z poleceniami do pracy z podrzędną rewizją elementu komponentu.

Przeglądaj zapisaną rewizję zarządzanego arkusza schematu po powrocie do panelu Explorer. Przejdź na kartę widoku Preview, aby zobaczyć reprezentację graficzną oraz listę rewizji komponentów podrzędnych.
Przeglądaj zapisaną rewizję zarządzanego arkusza schematu po powrocie do panelu Explorer. Przejdź na kartę widoku Preview, aby zobaczyć reprezentację graficzną oraz listę rewizji komponentów podrzędnych.

Komponenty podrzędne użyte w arkuszu można również przeglądać na karcie widoku Children. Kliknij dwukrotnie wpis, aby przejść do danego komponentu, lub kliknij go prawym przyciskiem myszy, aby uzyskać dostęp do zestawu poleceń związanych z komponentem.

Przeglądaj komponenty wchodzące w skład zarządzanego arkusza schematu w widoku Children.
Przeglądaj komponenty wchodzące w skład zarządzanego arkusza schematu w widoku Children.

Zapisywanie istniejącego arkusza w Workspace

Chociaż edycja bezpośrednia jest preferowanym sposobem pracy z większością danych projektowych, które można przechowywać w Workspace, istniejące arkusze schematu (a także arkusze urządzeń) można również zapisywać bezpośrednio w Workspace. Wymaga to planowanej rewizji istniejącego elementu zarządzanego arkusza schematu, w której arkusz zostanie zapisany. Procedura wygląda następująco:

  1. Utwórz nowy element zarządzanego arkusza schematu i jego początkową planowaną rewizję lub, zależnie od potrzeb, przygotuj planowaną rewizję innego istniejącego elementu.

  2. Otwórz arkusz schematu lub arkusz urządzenia w Altium Designer.

  3. Wybierz polecenie File » Save as Managed Sheet to Server z menu głównego.

  4. Pojawi się okno dialogowe Choose Planned Item Revision. Wybierz w nim docelową rewizję odpowiedniego elementu zarządzanego arkusza schematu (musi ona mieć stan Planned), a następnie kliknij OK.

    Jeśli docelowy element zarządzanego arkusza schematu nie istnieje, możesz go utworzyć na bieżąco w oknie dialogowym Choose Planned Item Revision. W takim przypadku pamiętaj o wyłączeniu opcji Open for editing after creation (w oknie dialogowym Create New Item), w przeciwnym razie przejdziesz do trybu edycji bezpośredniej.
  5. Pojawi się okno dialogowe Edit Revision, w którym można zmienić nazwę i opis oraz w razie potrzeby dodać informacje o wydaniu.

  6. Po kliknięciu OK arkusz zostanie zapisany w rewizji elementu.

Przykład przesyłania istniejącego arkusza urządzenia do aktualnie połączonego Workspace. Arkusz musi zostać zapisany w istniejącej rewizji zarządzanego arkusza schematu, a rewizja ta musi mieć stan Planned.
Przykład przesyłania istniejącego arkusza urządzenia do aktualnie połączonego Workspace. Arkusz musi zostać zapisany w istniejącej rewizji zarządzanego arkusza schematu, a rewizja ta musi mieć stan Planned.

Wyszukiwanie i umieszczanie zarządzanego arkusza schematu

Opisany poniżej panel Design Reuse jest dostępny w wersji Open Beta po włączeniu opcji UI.ModernDesignReusePanel w oknie dialogowym Advanced Settings. Gdy ta opcja jest wyłączona, zarządzany arkusz schematu można umieścić z poziomu panelu Explorer. W tym celu znajdź zarządzany arkusz schematu, który chcesz umieścić, przeglądając zasoby lub korzystając z wyszukiwania, kliknij prawym przyciskiem myszy wymaganą rewizję arkusza (zazwyczaj najnowszą — w takim przypadku wystarczy kliknąć prawym przyciskiem myszy bezpośrednio wpis elementu najwyższego poziomu), a następnie wybierz polecenie Place.

Zarządzane arkusze schematu przechowywane w połączonym Workspace można przeglądać i wykorzystywać z poziomu panelu Design Reuse, gdy jest on ustawiony na wyświetlanie zasobów Workspace ().

Możesz przeglądać foldery Workspace, aby znaleźć wymagany zarządzany arkusz schematu. Możesz też użyć pola Search u góry panelu Design Reuse, aby wyszukać zarządzany arkusz schematu według nazwy lub opisu.

  • W panelu Design Reuse wyświetlana jest tylko najnowsza rewizja każdego zarządzanego arkusza schematu.

  • Jeśli najnowsza rewizja zarządzanego arkusza schematu znajduje się w stanie cyklu życia, w którym opcja Visible in Vault panels jest wyłączona (dowiedz się więcej), arkusz ten domyślnie nie będzie wyświetlany w panelu. Aby wyświetlić zarządzane arkusze schematu, które są obecnie niewidoczne, kliknij przycisk  w prawym górnym rogu panelu, a następnie włącz opcję Show Hidden Revisions w wyświetlonym menu.

Kliknij element sterujący Details u dołu panelu, aby rozwinąć sekcję Details, która wyświetla szczegóły wybranych zarządzanych arkuszy schematu, w tym:

  • Nazwę zarządzanego arkusza schematu.

  • Ikonę stanu cyklu życia i rewizję (kliknij łącze, aby otworzyć szczegółowy widok historii elementu zarządzanego arkusza schematu z zaznaczoną najnowszą rewizją).

  • Opis zarządzanego arkusza schematu.

  • Ogólne informacje o zarządzanym arkuszu schematu.

Dzięki kontrolowanemu dostępowi do zawartości Workspace w połączeniu z odpowiednim schematem cyklu życia upoważniony personel (bibliotekarze, starsza kadra zarządzająca projektami) może zatwierdzać i udostępniać wyłącznie te zarządzane arkusze schematu, które mają być używane w projektach. Pozwala to projektantowi pracować ze świadomością, że korzysta wyłącznie z zatwierdzonych arkuszy zawierających układy przeznaczone do ponownego wykorzystania.

Prior to Placement

Przed umieszczeniem zarządzanego arkusza schematu w projekcie należy pamiętać o kilku kwestiach:

  • Symbolu zarządzanego arkusza schematu nie można umieścić na schemacie niezależnym od projektu — arkusz docelowy musi być częścią projektu.

  • Upewnij się, że arkusz schematu, na którym ma zostać umieszczony powiązany symbol arkusza, jest otwarty w Altium Designer i jest aktywnym dokumentem. Jeśli dokumenty są otwarte w wielu oknach, upewnij się również, że okno zawierające aktywny dokument schematu jest aktywne.

Aby umieścić zarządzany arkusz schematu w projekcie, najedź kursorem na jego wpis w panelu Design Reuse, kliknij przycisk  (lub kliknij wpis prawym przyciskiem myszy) i wybierz z menu polecenie Place. Symbol arkusza odwołujący się do tego arkusza zostanie dołączony do kursora — kliknij w wybranym miejscu na arkuszu schematu, aby go umieścić.

Podczas umieszczania symbolu arkusza Altium Designer kopiuje reprezentowany przez niego zarządzany arkusz z Workspace do folderu projektu, do podfolderu o nazwie \Managed\Sheets. Przechowywana jest tu kopia każdego zarządzanego arkusza, każda we własnym podfolderze oznaczonym unikatowym identyfikatorem (GUID) wygenerowanym przez system.

Podfolderu o nazwie odpowiadającej identyfikatorowi GUID, do którego pobierana jest i w którym przechowywana jest instancja zarządzanego arkusza schematu, nie wolno w żaden sposób modyfikować ani zmieniać jego nazwy.

Numerowanie komponentów i arkuszy

Aby zagwarantować integralność układu użytego w zarządzanym arkuszu schematu, arkusza tego nie można edytować podczas normalnej pracy nad projektem. Oznacza to, że nie można na nim zmieniać numeru arkusza ani przypisanych oznaczeń komponentów. Jak zatem ponumerować wszystkie arkusze w projekcie i nadać oznaczenia wszystkim komponentom?

Do tych zadań służą dwa polecenia: arkusze numeruje się za pomocą polecenia Tools » Annotation » Annotate Compiled Sheets, a oznaczenia komponentów nadaje się za pomocą polecenia Tools » Annotation » Board Level Annotate. Przypisane numery arkuszy i oznaczenia komponentów są przechowywane w osobnym pliku — <ProjectName>*.annotation. 

Narzędzia do numerowania komponentów muszą znać kolejność przetwarzania arkuszy schematu. Dlatego najlepiej ponumerować arkusze przed ponumerowaniem komponentów.

Zasady numerowania komponentów i arkuszy są takie same jak w przypadku korzystania z lokalnych arkuszy urządzeń. Więcej informacji na temat numerowania w projektach zawierających zarządzane arkusze schematu można znaleźć w następujących sekcjach na stronie poświęconej arkuszom urządzeń:

Edytowanie zarządzanego arkusza schematu

Aby edytować zarządzany arkusz schematu, najedź kursorem na jego wpis w panelu Design Reuse i kliknij przycisk  (lub kliknij wpis prawym przyciskiem myszy), a następnie wybierz z menu polecenie Edit. Otworzy się edytor tymczasowy z arkuszem schematu zawartym w najnowszej rewizji elementu zarządzanego arkusza schematu, gotowym do edycji. Wprowadź wymagane zmiany, a następnie zapisz dokument jako kolejną rewizję elementu (File » Save to Server).​​​

Jeśli chcesz zmienić arkusz schematu przechowywany w elemencie zarządzanego arkusza schematu i masz już zaktualizowany arkusz, możesz przesłać go do tego elementu za pomocą panelu Explorer — nowy arkusz zostanie zapisany w kolejnej rewizji tego elementu. Więcej informacji można znaleźć na stronie Tworzenie i edytowanie zawartości.

Inne operacje na zarządzanych arkuszach schematu

Menu przycisku  (oraz menu kontekstowe otwierane prawym przyciskiem myszy) we wpisie zarządzanego arkusza schematu w panelu Design Reuse zapewnia również dostęp do następujących poleceń:

  • Move – służy do zmiany lokalizacji elementu zarządzanego arkusza schematu w strukturze folderów Workspace. Uruchomienie polecenia otwiera okno dialogowe Move Item, w którym można wybrać folder docelowy, w którym ma zostać umieszczony element. 

  • Share – służy do definiowania uprawnień udostępniania zarządzanego arkusza schematu. Po wybraniu polecenia otworzy się okno dialogowe Share For Item, w którym można odpowiednio skonfigurować udostępnianie. Dowiedz się więcej o udostępnianiu na poziomie elementu.

  • Operations – zapewnia dostęp do menu rozwijanego z dodatkowymi funkcjami dotyczącymi zarządzanych arkuszy schematu, opisanymi poniżej.

    • Make a Copy – służy do kopiowania zarządzanego arkusza schematu. Otworzy się tymczasowy edytor zarządzanego arkusza schematu z taką samą zawartością jak w oryginalnym zarządzanym arkuszu schematu. Wprowadź wymagane zmiany i zapisz zarządzany arkusz schematu w Workspace. 

    • Change Revision State – służy do zmiany stanu najnowszej rewizji zarządzanego arkusza schematu. Po wybraniu polecenia otworzy się okno dialogowe zbiorczej zmiany stanu, które umożliwia zmianę stanu rewizji zarządzanego arkusza schematu.

    • Download – służy do pobierania danych przechowywanych w zarządzanym arkuszu schematu. Powiązane dane zostaną pobrane do podfolderu w wybranym katalogu, którego nazwa odpowiada identyfikatorowi rewizji elementu zarządzanego arkusza schematu. Plik można znaleźć w znajdujących się w nim folderach Released.

  • Delete – służy do usuwania zarządzanego arkusza schematu z połączonego Workspace. Po wybraniu polecenia pojawi się okno dialogowe Delete Items, w którym należy potwierdzić usunięcie. 

    W rzeczywistości jest to „usunięcie nietrwałe”, w wyniku którego zarządzany arkusz schematu zostaje przeniesiony do obszaru Trash w Workspace. Dowiedz się więcej o usuwaniu nietrwałym.

  • History – zapewnia dostęp do szczegółowego widoku zarządzanego arkusza schematu, otwieranego jako nowa karta w Altium Designer.

AI-LocalizedTłumaczenie SI
Jeśli znajdziesz błąd, zaznacz tekst/obraz i naciśnij Ctrl + Enter aby wysłać nam wiadomość.
Nav
Contents
Dostępność funkcji

Dostępne funkcje zależą od tego, z którego rozwiązania Altium korzystasz – Altium Develop, Altium Agile Teams, Altium Agile Enterprise lub Altium Designer (w ramach aktywnej subskrypcji terminowej).

Jeśli opisana funkcja nie jest widoczna w Twoim oprogramowaniu, skontaktuj się z działem sprzedaży Altium, aby dowiedzieć się więcej.

Starsza dokumentacja

Dokumentacja Altium Designer nie jest już wersjonowana. Jeśli potrzebujesz dostępu do dokumentacji dla starszych wersji Altium Designer, odwiedź sekcję Starsza dokumentacja na stronie Inne instalatory.

Contents