Praca z blokami wielokrotnego użytku

W skrócie

Ten artykuł wyjaśnia, jak za pomocą panelu Design Reuse w Altium Designer tworzyć, wyszukiwać, umieszczać, edytować i porządkować formalne bloki wielokrotnego użytku przechowywane w połączonym obszarze roboczym oraz nimi zarządzać. Opisuje, jak bloki te mogą zawierać zarówno dane schematu, jak i PCB, oraz jak elementy PCB są przenoszone do projektu płytki w ramach procesu ECO. Omawia również najważniejsze działania dostępne w panelu, takie jak przeglądanie zasobów obszaru roboczego, wyświetlanie szczegółów, wybór opcji umieszczania, zapisywanie rewizji oraz wykonywanie zadań administracyjnych: zmiana nazwy, przenoszenie, udostępnianie, pobieranie i usuwanie. Jeśli szukasz bardziej przejrzystego i wydajnego sposobu na ponowne wykorzystywanie sprawdzonych fragmentów projektów, czytaj dalej — dowiesz się, od czego zacząć i jak sprawnie korzystać z dostępnych narzędzi.

- Dowiedz się, jak tworzyć formalne bloki wielokrotnego użytku, zapisywać je w obszarze roboczym i wykorzystywać ponownie w projektach schematów i PCB za pomocą panelu Design Reuse.
- Zobacz, jak wyszukiwać, przeglądać i umieszczać bloki wielokrotnego użytku, korzystając z opcji umieszczania bezpośredniego, umieszczania symbolu arkusza oraz obsługi wielu dokumentów PCB.
- Poznaj najważniejsze działania związane z zarządzaniem blokami wielokrotnego użytku, w tym edycję, aktualizowanie rewizji, udostępnianie, przenoszenie, pobieranie i usuwanie nietrwałe.
Zagłęb się w temat dzięki AI:

Panel Design Reuse służący do zarządzania blokami do ponownego wykorzystania i opisany na tej stronie jest dostępny w otwartej wersji beta, gdy opcja UI.ModernDesignReusePanel jest włączona w oknie dialogowym Advanced Settings. Gdy ta opcja jest wyłączona, używana jest poprzednia wersja panelu, opisana na stronie Praca z blokami do ponownego wykorzystania i fragmentami.

Jeśli Twoje projekty często zawierają powtarzające się „sekcje” obwodów na schemacie i PCB, Altium Designer oferuje proste i wygodne sposoby zapisywania tych sekcji oraz ich ponownego wykorzystywania, eliminując konieczność tworzenia ich za każdym razem od podstaw.

Po połączeniu z przestrzenią roboczą możesz utworzyć reuse block zawierający zarówno obwód na schemacie, jak i jego fizyczną reprezentację na PCB. Po umieszczeniu takiego bloku do ponownego wykorzystania na arkuszu schematu jego fizyczna reprezentacja zostanie automatycznie umieszczona w dokumencie PCB podczas procesu ECO.

Panel Design Reuse zapewnia szybki dostęp do wszystkich elementów sterujących potrzebnych do pracy z blokami do ponownego wykorzystania i zarządzania nimi.

  • Panel umożliwia również dostęp do zarządzanych arkuszy schematów i fragmentów.

  • Oprócz standardowych metod otwierania panelu (menu przycisku  i podmenu View » Panels w menu głównym) panel Design Reuse można otworzyć, wybierając polecenie Place » Reuse Block z menu głównego w edytorze schematów lub PCB.

Aby pracować z blokami do ponownego wykorzystania za pośrednictwem panelu Design Reuse, upewnij się, że panel jest skonfigurowany do przeglądania zasobów przestrzeni roboczej. W tym celu kliknij ikonę znajdującą się najbardziej po lewej stronie paska adresu u góry panelu i wybierz pozycję odpowiadającą połączonej przestrzeni roboczej. Ikona przyjmie postać .

Tworzenie bloku do ponownego wykorzystania

Nowy blok do ponownego wykorzystania można utworzyć w sposób opisany poniżej.

  1. Kliknij przycisk  w prawym górnym rogu panelu Design Reuse. Możesz też wybrać polecenie File » New » Reuse Block z menu głównego.

  2. W panelu Projects (pod pozycją odpowiadającą połączonej przestrzeni roboczej) zostanie otwarta tymczasowa, edytowalna struktura bloku do ponownego wykorzystania, przypominająca strukturę projektu PCB. Otworzy się również tymczasowy edytor schematów, gotowy do zdefiniowania dokumentu schematu bloku. Użyj standardowych poleceń i technik umieszczania obiektów, aby zdefiniować dokument schematu bloku do ponownego wykorzystania.

    Jeśli chcesz utworzyć blok do ponownego wykorzystania zawierający tylko schemat lub tylko PCB, możesz usunąć dokument PCB lub schematu ze struktury fragmentu, klikając prawym przyciskiem myszy odpowiednio dokument PCB lub schematu w panelu Projects i wybierając polecenie Remove from Project.

  3. Użyj polecenia Design » Update PCB Document i procesu ECO, aby przenieść utworzony schemat do dokumentu PCB bloku do ponownego wykorzystania, a następnie wprowadź w tym dokumencie niezbędne zmiany (rozmieszczenie komponentów, trasowanie ścieżek itp.).

    Do definiowanego bloku do ponownego wykorzystania można dodać wiele dokumentów PCB. W tym celu użyj polecenia Add New to Project » PCB z menu kontekstowego pozycji bloku do ponownego wykorzystania w panelu Projects.

    Użyj polecenia Rename z menu kontekstowego pozycji dodanego dokumentu PCB w panelu Projects, aby nadać mu opisową nazwę. Użyj polecenia Design » Update z menu głównego edytora schematów, aby zaktualizować odpowiedni dokument PCB.

  4. Po zdefiniowaniu dokumentów schematu i PCB bloku do ponownego wykorzystania zapisz blok w przestrzeni roboczej, używając polecenia Save to Server z menu kontekstowego pozycji bloku w panelu Projects lub elementu sterującego Save to Server po prawej stronie tej pozycji.

    Ponieważ bloki do ponownego wykorzystania są przechowywane w połączonej przestrzeni roboczej, zaleca się używanie w nich komponentów z tej przestrzeni. Pozwala to w pełni wykorzystać możliwości systemu zarządzania zawartością oferowanego przez przestrzeń roboczą.

    • Aby można było zapisać blok do ponownego wykorzystania w przestrzeni roboczej, zarówno jego dokument schematu, jak i dokument PCB muszą zawierać co najmniej jeden komponent.

    • Jeśli dokumenty schematu i PCB bloku do ponownego wykorzystania nie są zsynchronizowane (zostaną wykryte różnice między nimi), podczas próby zapisania bloku w przestrzeni roboczej pojawi się okno dialogowe z ostrzeżeniem. Możesz anulować zapisywanie, aby wrócić do bloku i usunąć różnice, albo kontynuować zapisywanie.

  5. Pojawi się okno dialogowe Create New Reuse Block, w którym możesz określić Name, Description oraz Folder w przestrzeni roboczej, w którym zostanie zapisany nowy blok do ponownego wykorzystania.

  6. Po kliknięciu OK w oknie dialogowym Create New Reuse Block blok do ponownego wykorzystania zostanie zapisany w przestrzeni roboczej, a jego tymczasowa struktura zostanie zamknięta.

Wyszukiwanie i umieszczanie bloku do ponownego wykorzystania

Bloki do ponownego wykorzystania przechowywane w połączonej przestrzeni roboczej można przeglądać i wykorzystywać za pomocą panelu Design Reuse, gdy jest on ustawiony na wyświetlanie zasobów przestrzeni roboczej (). W tym trybie panel przedstawia strukturę folderów przestrzeni roboczej, umożliwiając przeglądanie folderów, w których przechowywane są bloki do ponownego wykorzystania. Każdy folder i blok są wyświetlane na liście u góry panelu wraz z nazwą i opisem.

Aby znaleźć potrzebny blok do ponownego wykorzystania, możesz przeglądać foldery lub użyć pola Search u góry panelu Design Reuse, aby wyszukać blok według nazwy lub opisu ().

  • W panelu Design Reuse wyświetlana jest tylko najnowsza rewizja każdego bloku do ponownego wykorzystania.

  • Jeśli najnowsza rewizja bloku do ponownego wykorzystania znajduje się w stanie cyklu życia, dla którego opcja Visible in Vault panels jest wyłączona (dowiedz się więcej), blok ten domyślnie nie będzie wyświetlany w panelu. Aby wyświetlić obecnie niewidoczne bloki do ponownego wykorzystania, kliknij przycisk  w prawym górnym rogu panelu, a następnie włącz opcję Show Hidden Revisions w wyświetlonym menu.

Kliknij element sterujący Details u dołu panelu, aby rozwinąć sekcję Details, która wyświetla szczegóły wybranego bloku do ponownego wykorzystania, w tym:

  • Nazwę bloku do ponownego wykorzystania.

  • Ikonę stanu cyklu życia i rewizję (kliknij łącze, aby otworzyć szczegółowy widok historii elementu bloku do ponownego wykorzystania z wybraną najnowszą rewizją).

  • Opis bloku do ponownego wykorzystania.

  • Ogólne informacje o bloku do ponownego wykorzystania i jego parametry.

  • Podglądy dokumentów schematu i PCB bloku do ponownego wykorzystania.

  • Listę projektów () i wydań projektów (), w których używany jest blok do ponownego wykorzystania (obszar Where Used).

Korzystając z kontrolowanego dostępu do zawartości przestrzeni roboczej w połączeniu z odpowiednim schematem cyklu życia, upoważnione osoby (bibliotekarze, kierownictwo działu projektowego) mogą zatwierdzać i udostępniać wyłącznie te bloki do ponownego wykorzystania, które mają być używane w projektach. Dzięki temu projektant może swobodnie pracować, mając pewność, że korzysta wyłącznie z bloków dopuszczonych do użytku.

Aby umieścić blok do ponownego wykorzystania w projekcie, najedź kursorem na jego wpis w panelu Design Reuse, kliknij przycisk  (lub kliknij wpis prawym przyciskiem myszy) i wybierz z menu jedno z następujących poleceń:

  • Place – wybierz, aby umieścić blok do ponownego wykorzystania bezpośrednio w aktywnym dokumencie schematu lub PCB. W zależności od typu dokumentu aktywnego w momencie uruchomienia polecenia zostanie umieszczony dokument schematu lub PCB tego bloku.

     
  • Place as Sheet Symbol – gdy aktywny jest dokument schematu, wybierz, aby umieścić blok do ponownego wykorzystania jako symbol arkusza na arkuszu schematu. Umieszczony symbol arkusza będzie zawierał wejścia arkusza odpowiadające portom w bloku. Zawartość bloku zostanie umieszczona na automatycznie utworzonym podrzędnym arkuszu schematu, do którego odwołuje się symbol arkusza. Symbol arkusza umieszczonego bloku będzie miał charakterystyczną ikonę.

Jeśli blok do ponownego wykorzystania zawiera więcej niż jeden dokument PCB, przed umieszczeniem bloku wybierz odpowiedni dokument PCB, klikając jego kartę pod podglądem dokumentu PCB w obszarze Preview panelu Details (). Po umieszczeniu bloku na schemacie wybrany dokument PCB zostanie z nim powiązany i umieszczony na PCB podczas aktualizacji w ramach procesu ECO.

Po umieszczeniu dokumentu schematu bloku do ponownego wykorzystania jego dokument PCB można umieścić w dokumencie PCB w ramach procesu ECO. W edytorze schematów wybierz polecenie Design » Update PCB Document z menu głównego, a następnie zweryfikuj i zastosuj zmiany w oknie dialogowym Engineering Change Order.

Edycja bloku do ponownego wykorzystania

Aby edytować blok do ponownego wykorzystania, najedź kursorem na jego wpis w panelu Design Reuse i kliknij przycisk  (lub kliknij wpis prawym przyciskiem myszy), a następnie wybierz z menu polecenie Edit.

Do edycji zostanie otwarta tymczasowa struktura projektu bloku do ponownego wykorzystania, zawierająca najnowszą rewizję elementu tego bloku. Wprowadź wymagane zmiany, a następnie zapisz blok jako jego kolejną rewizję (File » Save to Server).

Inne operacje na blokach do ponownego wykorzystania

Menu przycisku  (oraz menu kontekstowe otwierane prawym przyciskiem myszy) wpisu bloku do ponownego wykorzystania w panelu Design Reuse zapewnia również dostęp do następujących poleceń:

  • Rename – służy do zmiany nazwy bloku do ponownego wykorzystania. Po wybraniu polecenia wprowadź nową nazwę w wyświetlonym oknie dialogowym Rename Reuse Block, a następnie kliknij OK.

  • Move – służy do zmiany położenia elementu bloku do ponownego wykorzystania w strukturze folderów przestrzeni roboczej. Uruchomienie polecenia otwiera okno dialogowe Move Item, w którym można wybrać folder docelowy dla tego elementu.

  • Share – służy do określania uprawnień udostępniania bloku do ponownego wykorzystania. Po wybraniu polecenia otworzy się okno dialogowe Share For Item, w którym można odpowiednio skonfigurować udostępnianie. Dowiedz się więcej o udostępnianiu na poziomie elementu.

  • Operations – zapewnia dostęp do menu rozwijanego z dodatkowymi funkcjami dotyczącymi bloków do ponownego wykorzystania, opisanymi poniżej.

    • Make a Copy – służy do kopiowania bloku do ponownego wykorzystania. Otworzy się tymczasowa struktura projektu bloku, zawierająca tę samą zawartość co blok oryginalny. Wprowadź wymagane zmiany i zapisz blok w przestrzeni roboczej. 

    • Change Revision State – służy do zmiany stanu najnowszej rewizji bloku do ponownego wykorzystania. Po wybraniu polecenia otwiera się okno dialogowe zbiorczej zmiany stanu, które umożliwia zmianę stanu rewizji bloku.

    • Download – służy do pobierania danych zapisanych w bloku do ponownego wykorzystania (jego dokumentów schematu i/lub PCB). Powiązane dane zostaną pobrane do podfolderu w wybranym katalogu, którego nazwa będzie odpowiadać identyfikatorowi rewizji elementu bloku. Pliki znajdują się w zawartych w nim folderach Released.

  • Delete – służy do usuwania bloku do ponownego wykorzystania z połączonej przestrzeni roboczej. Po wybraniu polecenia pojawi się okno dialogowe Delete Items, w którym należy potwierdzić usunięcie. Można również zdecydować o usunięciu zawartości powiązanej z blokiem (tj. fragmentów schematu i PCB).

    Operacja ta jest w rzeczywistości „usuwaniem nietrwałym”, w wyniku którego blok do ponownego wykorzystania zostanie przeniesiony do obszaru Trash przestrzeni roboczej. Dowiedz się więcej o usuwaniu nietrwałym.

  • History – zapewnia dostęp do widoku szczegółowego bloku do ponownego wykorzystania, otwieranego na nowej karcie w Altium Designer.

AI-LocalizedTłumaczenie SI
Jeśli znajdziesz błąd, zaznacz tekst/obraz i naciśnij Ctrl + Enter aby wysłać nam wiadomość.
Nav
Contents
Dostępność funkcji

Dostępne funkcje zależą od tego, z którego rozwiązania Altium korzystasz – Altium Develop, Altium Agile Teams, Altium Agile Enterprise lub Altium Designer (w ramach aktywnej subskrypcji terminowej).

Jeśli opisana funkcja nie jest widoczna w Twoim oprogramowaniu, skontaktuj się z działem sprzedaży Altium, aby dowiedzieć się więcej.

Starsza dokumentacja

Dokumentacja Altium Designer nie jest już wersjonowana. Jeśli potrzebujesz dostępu do dokumentacji dla starszych wersji Altium Designer, odwiedź sekcję Starsza dokumentacja na stronie Inne instalatory.

Contents