Trabalhando com Diretivas em um Esquemático
Altium Essentials: Schematic Updating
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
Num relance
- Saiba o que são diretivas de projeto e como elas são usadas na captura e na validação de esquemáticos.
- Entenda quando usar No ERC ou uma máscara de compilação para suprimir mensagens de validação indesejadas.
- Veja como as máscaras de compilação são posicionadas, ativadas ou desativadas e editadas no editor de esquemáticos.
As Diretivas de Projeto são objetos posicionados no esquemático durante a captura do projeto, oferecendo uma forma de especificar instruções a serem transmitidas a outras partes do software. Diversas Diretivas de Projeto estão disponíveis para uso das duas formas a seguir:
- Diretivas associadas à compilação automática dos documentos esquemáticos de origem.
- Diretivas usadas para transmitir à PCB informações definidas em uma folha de esquemático.
As seções a seguir examinam mais detalhadamente essas áreas e as diretivas associadas.
Diretivas relacionadas à compilação
Os projetos evoluem ao longo do tempo e são capturados em etapas. À medida que cada etapa se consolida, é comum querer verificá-la isoladamente do restante do projeto. A compilação de um documento esquemático individual (ou do projeto inteiro) em etapas intermediárias do processo de captura frequentemente gera várias mensagens de erro causadas por circuitos que ainda não foram capturados ou por conexões de interface entre trechos de circuito que ainda estão incompletas. Essas mensagens não têm valor real, pois apenas geram ruído em torno das informações relevantes. A maneira mais rápida e fácil de suprimir esses erros de compilação é posicionar diretivas No ERC ou Máscara de Compilação.
Diretiva No ERC
A diretiva No ERC é posicionada em um nó do circuito para suprimir todos os avisos e/ou condições de violação de erro da Verificação de Regras Elétricas detectados quando o projeto esquemático é validado. Consulte a página Validação do seu projeto para saber mais.
Diretiva Máscara de Compilação
As diretivas No ERC são excelentes para suprimir um pequeno número de pinos, portas, entradas de folha ou redes com violações em um projeto. Porém, em alguns casos, pode ser desejável excluir uma seção inteira do projeto, incluindo componentes. Use uma diretiva Máscara de Compilação (comando Place » Directives » Compile Mask) ou clique no botão Máscara de Compilação no menu suspenso de diretivas em Active Bar para ocultar efetivamente do Compilador a área do projeto contida nela, permitindo impedir manualmente a verificação de erros em circuitos que talvez ainda não estejam completos e que você sabe que gerarão erros de compilação. Isso pode ser muito útil quando você precisa compilar o documento ativo ou o projeto para verificar a integridade do projeto em outras áreas específicas, mas não deseja o “ruído” das mensagens geradas pelo compilador relacionadas às partes inacabadas do projeto.
Como o nome sugere, essa diretiva instrui o Compilador a ignorar quaisquer objetos que estejam completely dentro dos limites da máscara definida. Posicione a máscara exatamente como faria com uma nota ou um objeto retangular.
Considere o circuito esquemático de exemplo na imagem a seguir, em que as conexões ao dispositivo LCD1 ainda não estão completas. Compilar apenas esse esquemático (Project » Validate PCB Project) resultará em várias mensagens de violação (mostradas abaixo), cada uma delas causada pelo circuito incompleto. Passe o cursor sobre a imagem para ver o efeito de posicionar uma diretiva Máscara de Compilação ao redor do circuito incompleto. Essas violações serão ignoradas pelo Compilador, enquanto o restante do circuito no esquemático — cujas conexões estão completas — será verificado. Observe que os objetos efetivamente mascarados — aqueles totalmente contidos no retângulo delimitador da máscara — aparecerão acinzentados.

Passe o cursor sobre a imagem para mostrar o efeito do uso de uma diretiva Máscara de Compilação para ocultar violações do compilador causadas por circuitos incompletos.
Máscara de Compilação
Uma Máscara de Compilação posicionada, mostrada no lado esquerdo do esquemático acima.
Resumo
Uma Máscara de Compilação é uma diretiva de projeto usada para ocultar efetivamente do Compilador a área do projeto contida nela durante a validação realizada com o comando Project » Validate Project . Ela oferece uma forma de impedir manualmente a verificação de erros em circuitos que talvez ainda não estejam completos e que gerarão erros de validação. A Máscara de Compilação é útil em situações em que o projeto atual precisa ser validado para verificar sua integridade em outras áreas específicas, mas não se deseja o excesso de mensagens geradas pelo compilador relacionadas às partes inacabadas do projeto.
Disponibilidade
As Máscaras de Compilação estão disponíveis para posicionamento apenas no Editor de Esquemáticos. Para posicionar uma Máscara de Compilação:
- Clique no comando Place » Directives » Compile Mask nos menus principais.
- Clique no botão Máscara de Compilação no menu suspenso de diretivas em Active Bar , localizado na parte superior da área de projeto. Clique e mantenha pressionado um botão Active Bar para acessar outros comandos relacionados. Depois que um comando for usado, ele se tornará o primeiro item dessa seção de Active Bar.
- Clique com o botão direito no editor de esquemáticos e depois clique em Place » Directives » Compile Mask.
Posicionamento
Após iniciar o comando, o cursor mudará para uma cruz indicando o modo de posicionamento de Máscara de Compilação. O posicionamento é realizado por meio da seguinte sequência de ações:
- Posicione o cursor e clique ou pressione Enter para fixar o primeiro canto da máscara.
- Mova o cursor para ajustar o tamanho da máscara de modo que ela envolva completamente a área do projeto que precisa ser ocultada do Compilador; em seguida, clique ou pressione Enter para fixar o canto diagonalmente oposto e concluir o posicionamento da máscara. Os objetos do projeto totalmente contidos nos limites da máscara ficarão acinzentados.
- Continue posicionando outras máscaras de compilação ou clique com o botão direito ou pressione Esc para sair do modo de posicionamento.
Edição gráfica
Esse método de edição permite selecionar um objeto de máscara de compilação posicionado diretamente na área de projeto e alterar graficamente seu tamanho, forma ou localização.
Uma máscara de compilação pode ser exibida no modo ativo (quadro completo) ou recolhido (triângulo dentro de uma caixa), que correspondem à máscara habilitada e desabilitada, respectivamente. Alterne o modo de exibição clicando no ícone ▲ ou ▼ no canto superior esquerdo de uma máscara de compilação posicionada.
Clique no triângulo no canto superior esquerdo para recolher (e desabilitar) uma máscara de compilação.
Quando um objeto de máscara de compilação ativo (expandido) é selecionado, as seguintes alças de edição ficam disponíveis:
Uma Máscara de Compilação selecionada (quando ativa).
- Clique e arraste A para redimensionar a máscara de compilação nas direções vertical e horizontal simultaneamente.
- Clique e arraste B para redimensionar a máscara de compilação nas direções vertical e horizontal separadamente.
- Clique em qualquer ponto da máscara de compilação – longe das alças de edição – e arraste para reposicioná-la. Durante o arraste, a máscara de compilação pode ser girada (Spacebar/Shift+Spacebar) ou espelhada (teclas X ou Y para espelhar ao longo do eixo X ou Y, respectivamente).
Edição não gráfica
Os seguintes métodos de edição não gráfica estão disponíveis.
Edição pela caixa de diálogo Compile Mask ou pelo painel Properties
Panel page: Propriedades da máscara de compilação
Este método de edição utiliza a caixa de diálogo Compile Mask associada e o modo do painel Properties para modificar as propriedades de um objeto de máscara de compilação.
Após o posicionamento, a caixa de diálogo Compile Mask pode ser acessada das seguintes formas:
- Clicando duas vezes no objeto de máscara de compilação posicionado.
- Selecionando o objeto de máscara de compilação, clicando com o botão direito e escolhendo Properties no menu de contexto.
Durante o posicionamento, o modo Compile Mask do painel Properties pode ser acessado pressionando a tecla Tab. Assim que a máscara de compilação for posicionada, todas as opções serão exibidas.
Após o posicionamento, o modo Compile Mask do painel Properties pode ser acessado de uma das seguintes formas:
- Se o painel Properties já estiver ativo, selecionando o objeto de máscara de compilação.
- Após selecionar o objeto de máscara de compilação, selecione o painel Properties pelo botão Panels na seção inferior direita do espaço de projeto ou selecionando View » Panels » Properties no menu principal.
Edição de múltiplos objetos
O painel Properties permite editar múltiplos objetos, possibilitando modificar as configurações de propriedades que são idênticas em todos os objetos selecionados. Quando vários objetos do mesmo tipo são selecionados manualmente, pela caixa de diálogo Find Similar Objects ou por um painel Filter ou List, um campo do painel Properties cujo valor não seja exibido como um asterisco (*) pode ser editado para todos os objetos selecionados.
Edição por um painel List
Panel pages: Painéis List, SCH Filter
Um painel List exibe tipos de objetos de projeto de um ou mais documentos em formato de tabela, permitindo inspecionar e modificar rapidamente os atributos dos objetos. Usado em conjunto com a filtragem apropriada – selecionando tipos de objetos (pelas opções Include do painel) ou usando o painel Filter correspondente ou a caixa de diálogo Find Similar Objects – permite exibir apenas os objetos abrangidos pelo filtro ativo. As propriedades dos objetos listados podem então ser editadas diretamente no painel List.
Propriedades da máscara de compilação
As propriedades dos objetos do Editor de Esquemáticos são opções configuráveis que especificam o estilo visual, o conteúdo e o comportamento do objeto posicionado. As configurações de propriedades de cada tipo de objeto são definidas da seguinte forma:
- Post-placement settings – todas as propriedades do objeto máscara de compilação estão disponíveis para edição na caixa de diálogo Compile Mask e no painel Properties quando uma máscara de compilação posicionada é selecionada no espaço de projeto.
Localização
-
(X/Y)
- X (primeiro campo) - a coordenada X (horizontal) atual do ponto de referência do objeto, relativa à origem atual do espaço de projeto. Edite para alterar a posição X do objeto. O valor pode ser inserido no sistema métrico ou imperial; inclua as unidades ao inserir um valor cujas unidades não sejam as padrão atuais.
- Y (segundo campo) - a coordenada Y (vertical) atual do ponto de referência do objeto, relativa à origem atual. Edite para alterar a posição Y do objeto. O valor pode ser inserido no sistema métrico ou imperial; inclua as unidades ao inserir um valor cujas unidades não sejam as padrão atuais.
Propriedades
- Width - insira a largura do objeto.
- Height - insira a altura do objeto.
- Border - use a lista suspensa para selecionar a borda desejada.
- Fill Color - clique na caixa de cor para selecionar a cor desejada para o objeto.
- Collapsed and Disabled - marque a caixa para recolher e desabilitar o objeto.
Diretivas relacionadas à PCB
Como um ambiente de projeto unificado, o Altium Designer permite definir os requisitos da PCB antes de realizar o layout da placa. Isso é feito adicionando e especificando parâmetros para os objetos posicionados nas folhas de esquemático.
Para determinados objetos de projeto de esquemático – como componentes, símbolos de folha, portas etc. – isso envolve adicionar os parâmetros relevantes como parte das propriedades do objeto. Para objetos de rede, como fios e barramentos, os parâmetros não podem ser adicionados diretamente como uma propriedade do fio ou barramento. Em vez disso, os parâmetros necessários para armazenar as informações são especificados usando diretivas de projeto específicas.
As seguintes informações podem ser especificadas por meio de diretivas e serão transferidas para as definições correspondentes na PCB durante a sincronização do projeto:
- Restrições de layout da PCB
- Pares diferenciais
- Classes de redes
Ao incluir diretivas de projeto no esquemático, os engenheiros podem especificar restrições de projeto explícitas e garantir que o esquemático continue sendo o registro principal do projeto. Quaisquer alterações no projeto seriam realizadas apenas no esquemático e transferidas para a PCB. Isso pode ser especialmente importante quando várias pessoas trabalham no projeto, principalmente se estiverem em locais geograficamente distantes. Em vez de tentar se comunicar por meio de longas trocas de e-mails ou telefonemas, a pessoa responsável pela captura do projeto pode garantir que determinadas restrições sejam efetivamente utilizadas durante a etapa de layout.
No centro dessa funcionalidade está a diretiva de conjunto de parâmetros.
Essas diretivas são essencialmente objetos de conjunto de parâmetros definidos pelo usuário, que podem ser associados a um objeto de rede em um projeto esquemático. Posicione uma diretiva de layout de PCB em um fio, barramento ou chicote de sinais para definir uma ou mais restrições de projeto destinadas às redes associadas. Quando uma PCB é criada a partir do esquemático, as informações da diretiva de layout de PCB são usadas para criar as regras de projeto de PCB correspondentes. As informações especificadas por uma diretiva de layout de PCB são aplicadas apenas à rede (ou ao conjunto de redes) à qual a diretiva está conectada.

Uma diretiva de conjunto de parâmetros.
Ela funciona como um contêiner para qualquer quantidade de parâmetros destinados à rede à qual a diretiva de conjunto de parâmetros está conectada. É possível posicionar uma diretiva de conjunto de parâmetros padrão sem parâmetros (Place » Directives » Parameter Set) e adicionar os parâmetros relevantes posteriormente. As seções a seguir examinam mais detalhadamente o uso dessas diretivas baseadas em parâmetros. Estão disponíveis tanto diretivas de conjunto de parâmetros definidas pelo usuário (Conjunto de parâmetros) quanto predefinidas (Par diferencial). A única diferença entre um conjunto de parâmetros vazio e um predefinido é que os conjuntos predefinidos incluem um parâmetro, conforme descrito abaixo.
Conjunto de parâmetros
Resumo
Um conjunto de parâmetros é uma diretiva de projeto que permite associar especificações de projeto a um objeto do tipo rede em um projeto esquemático. Por exemplo, use um conjunto de parâmetros para declarar que duas redes são membros de um par diferencial. O software usa a presença de parâmetros com nomes específicos no conjunto de parâmetros para determinar qual diretiva de projeto você está posicionando.
Disponibilidade
Os conjuntos de parâmetros só podem ser posicionados no editor de esquemático. Estão disponíveis tanto diretivas de conjunto de parâmetros padrão (vazias) quanto predefinidas (Par diferencial). A única diferença entre um conjunto de parâmetros vazio e um predefinido é que os conjuntos predefinidos incluem um parâmetro, conforme descrito abaixo.
Acesse os comandos correspondentes no menu principal Place da seguinte forma:
| • | Place » Directives » Parameter Set | |
| • | Place » Directives » Differential Pair | |
Posicionamento
Um conjunto de parâmetros pode ser usado para associar parâmetros a:
- Fio
- Barramento
- Chicote de sinais
- Símbolo de folha
Após iniciar o comando, o cursor mudará para uma cruz e você entrará no modo de posicionamento de diretivas de projeto. O posicionamento é realizado por meio das seguintes ações:
- Posicione o cursor sobre um fio ou outro objeto de rede e clique ou pressione Enter para posicionar.
- Continue posicionando outras diretivas ou clique com o botão direito do mouse ou pressione Esc para sair do modo de posicionamento.
Outras ações que podem ser realizadas durante o posicionamento – enquanto o conjunto de parâmetros ainda acompanha o cursor – são:
-
Pressione a tecla Tab para pausar o posicionamento e acessar o modo Conjunto de parâmetros do painel Properties, no qual suas propriedades podem ser alteradas durante o posicionamento. Clique no botão de pausa sobreposto ao espaço de projeto para retomar o posicionamento.
-
Pressione a tecla Alt para restringir a direção do movimento ao eixo horizontal ou vertical, dependendo da direção inicial do movimento.
-
Pressione Spacebar para girar o arco no sentido anti-horário ou Shift+Spacebar para girá-lo no sentido horário. Essa ação também pode ser realizada enquanto o objeto é arrastado. A rotação ocorre em incrementos de 90°.
-
Pressione as teclas X ou Y no modo de posicionamento para espelhar o conjunto de parâmetros em relação ao eixo X ou Y.
Edição gráfica
Esse método de edição permite selecionar uma diretiva de conjunto de parâmetros já posicionada diretamente no espaço de projeto e alterar graficamente sua localização ou orientação.
Quando uma diretiva de conjunto de parâmetros é selecionada no espaço de projeto, uma caixa tracejada aparece ao redor dela. A caixa delimita apenas a área ocupada pela diretiva. Para cada parâmetro do conjunto com a visibilidade habilitada, uma linha tracejada ficará visível, conectando o campo de texto do parâmetro ao corpo da diretiva, o que confirma a associação:
Clique em qualquer lugar dentro da caixa tracejada e arraste para reposicionar o conjunto de parâmetros conforme necessário. Durante o arraste, o conjunto de parâmetros pode ser girado (Spacebar/Shift+Spacebar) ou espelhado (teclas X ou Y para espelhar em relação ao eixo X ou Y).
O tamanho dos campos de texto do conjunto de parâmetros (que podem ser editados graficamente de forma independente da diretiva à qual pertencem) só pode ser ajustado alterando a opção Style na página Esquemático – Padrões da caixa de diálogo Preferences. Por isso, as alças de edição não ficam disponíveis quando qualquer um desses objetos é selecionado.
Clique em qualquer lugar dentro da caixa tracejada e arraste para reposicionar o objeto de texto conforme necessário. Durante o arraste, o objeto de texto pode ser girado (Spacebar/Shift+Spacebar) ou espelhado (teclas X ou Y para espelhar em relação ao eixo X ou Y).
Se a opção Enable In-Place Editing estiver habilitada na página Esquemático – Geral da caixa de diálogo Preferences, você poderá editar o valor de um parâmetro diretamente na área de projeto (com exceção dos parâmetros adicionados como regras). Selecione o objeto de texto e clique uma vez para ativar o recurso. Digite o novo valor conforme necessário e clique fora do objeto de texto ou pressione Enter para aplicar a alteração.
Edição não gráfica
Os seguintes métodos de edição não gráfica estão disponíveis.
Edição pela caixa de diálogo Conjunto de parâmetros ou pelo painel Propriedades
Panel page: Propriedades do conjunto de parâmetros
Este método de edição utiliza a caixa de diálogo Parameter Set associada e o modo Properties do painel para modificar as propriedades de um objeto de conjunto de parâmetros.

A caixa de diálogo Parameter Set na primeira imagem e o modo Parameter Set do painel Propriedades na segunda imagem
Após o posicionamento, a caixa de diálogo Parameter Set pode ser acessada das seguintes formas:
- Clicando duas vezes no objeto de conjunto de parâmetros posicionado.
- Posicionando o cursor sobre o objeto de conjunto de parâmetros, clicando com o botão direito e escolhendo Properties no menu de contexto.
Durante o posicionamento, o modo Parameter Set do painel Properties pode ser acessado pressionando a tecla Tab. Depois que o conjunto de parâmetros é posicionado, todas as opções são exibidas.
Após o posicionamento, o modo Parameter Set do painel Properties pode ser acessado de uma das seguintes formas:
- Se o painel Properties já estiver ativo, selecionando o objeto de conjunto de parâmetros.
- Após selecionar o objeto de conjunto de parâmetros, selecione o painel Properties pelo botão Panels no canto inferior direito da área de projeto ou selecione View » Panels » Properties no menu principal.
Edição de múltiplos objetos
O painel Properties permite editar múltiplos objetos, possibilitando modificar as configurações de propriedades que são idênticas em todos os objetos selecionados no momento. Quando vários objetos do mesmo tipo são selecionados manualmente, pela caixa de diálogo Localizar objetos semelhantes ou por um painel de Filtro ou de Lista, um valor de campo do painel Properties que não seja exibido como um asterisco (*) pode ser editado para todos os objetos selecionados.
Edição por um painel de Lista
Panel pages: Painéis de Lista, Filtro SCH
Um painel List permite exibir objetos de projeto de um ou mais documentos em formato tabular, possibilitando a inspeção e a modificação rápidas dos atributos dos objetos. Quando usado em conjunto com a filtragem adequada — por meio do painel Filter aplicável ou da caixa de diálogo Localizar objetos semelhantes —, ele permite exibir apenas os objetos abrangidos pelo filtro ativo, possibilitando selecionar e editar múltiplos objetos de projeto com maior precisão e eficiência.
Notas
- Ao posicionar uma diretiva de conjunto de parâmetros padrão, não haverá parâmetros existentes. Após posicioná-la, adicione os parâmetros relevantes pela seção Parameters do painel Properties .
- Uma diretiva de conjunto de parâmetros permite atribuir informações de layout de PCB a uma rede no esquemático. Quando uma PCB é criada a partir do esquemático, as informações do conjunto de parâmetros são usadas para criar as regras de projeto de PCB relevantes. As informações especificadas por uma diretiva de conjunto de parâmetros são aplicadas apenas às redes às quais ela está conectada.
- Quando uma diretiva de conjunto de parâmetros é adicionada a uma rede, os campos Power Net e High Speed ficam disponíveis no painel Properties da rede. Ao atualizar o documento de PCB a partir dos esquemáticos, é sugerida a adição da regra de projeto Redes de alimentação a cada rede com o parâmetro Power Net habilitado.
- As diretivas de classe de redes permitem criar classes de redes definidas pelo usuário no esquemático. Quando uma PCB é criada a partir do esquemático, as informações de uma diretiva de classe de redes são usadas para criar a classe de redes correspondente na PCB. Para tornar uma rede membro de uma classe de redes, conecte uma diretiva de conjunto de parâmetros ao fio ou barramento relevante e adicione uma classe cujo nome corresponda ao da classe desejada. A opção Generate Net Classes (para classes definidas pelo usuário) deve estar habilitada na aba Class Generation da caixa de diálogo Opções do projeto para usar esse recurso.
- Se uma diretiva de classe de nets tiver sido definida para uma net, todas as regras de projeto de PCB também criadas por esse objeto de conjunto de parâmetros terão como escopo a classe de nets quando o projeto for transferido para o editor de PCB.
- Uma diretiva de classe de nets pode ser criada a partir da diretiva de conjunto de parâmetros posicionada, adicionando uma classe cujo valor deve ser definido como a classe de nets de PCB desejada.
-
Um Blanket, em conjunto com uma diretiva de conjunto de parâmetros, também pode ser usado para aplicar classes de componentes e parâmetros a componentes que estejam totalmente dentro da área definida pelo Blanket. Para isso, use as opções Component Class e Parameter do menu suspenso do botão Add nas propriedades da diretiva de conjunto de parâmetros vinculada ao Blanket. As informações sobre a classe de componentes e o parâmetro serão transferidas para o documento de PCB do projeto durante o processo de ECO ao atualizar a PCB.
Propriedades do conjunto de parâmetros
As propriedades dos objetos do editor de esquemáticos são opções configuráveis que especificam o estilo visual, o conteúdo e o comportamento do objeto posicionado.
As configurações de propriedades de cada tipo de objeto são definidas de duas maneiras diferentes:
-
Pre-placement settings – a maioria das propriedades do objeto Conjunto de parâmetros, ou aquelas que podem ser logicamente predefinidas, estão disponíveis como configurações padrão editáveis na página Esquemático – Padrões da caixa de diálogo Preferences (acessada pelo botão
no canto superior direito da área de projeto). Selecione o objeto em Primitive List para exibir suas opções à direita.
-
Post-placement settings – todas as propriedades do objeto Conjunto de parâmetros estão disponíveis para edição nas caixas de diálogo Parameter Set e no painel Properties quando um conjunto de parâmetros é selecionado na área de projeto.
Localização
-
(X/Y)
- X (primeiro campo) – a coordenada X (horizontal) atual do ponto de referência do objeto, em relação à origem atual da área de projeto. Edite para alterar a posição X do objeto. O valor pode ser inserido em unidades métricas ou imperiais; inclua as unidades ao inserir um valor cujas unidades não sejam as unidades padrão atuais.
- Y (segundo campo) – a coordenada Y (vertical) atual do ponto de referência do objeto, em relação à origem atual. Edite para alterar a posição Y do objeto. O valor pode ser inserido em unidades métricas ou imperiais; inclua as unidades ao inserir um valor cujas unidades não sejam as unidades padrão atuais.
- Rotation – use o menu suspenso para selecionar a rotação.
Propriedades
- Label – o rótulo do conjunto de parâmetros. Edite, se desejar.
- Style – use o menu suspenso para selecionar o estilo. Clique na caixa de cor para acessar um menu suspenso no qual você pode selecionar a cor padrão.
Parâmetros
- Grid – lista o Name e o Value dos parâmetros associados ao parâmetro atualmente selecionado. Após a adição, os campos Name e Value podem ser editados. O Value pode ser nomeado clicando no campo e inserindo o texto desejado. O campo Name só pode ser alterado no modo Properties do painel do objeto Conjunto de parâmetros usando Ctrl+Click. Esse método abre o modo Parameter do painel Properties, no qual você pode inserir o nome desejado no campo Name. Use o ícone de cadeado para bloquear/desbloquear um parâmetro listado. Use o ícone de olho para mostrar/ocultar o parâmetro. Todos os parâmetros, parâmetros individuais ou nenhum parâmetro podem ser exibidos nessa região alternando o botão All e os botões de parâmetros individuais. Os parâmetros ficam desativados quando seus respectivos botões estão cinza e ativados quando seus respectivos botões estão azuis.
-
Add – use o menu suspenso para adicionar um tipo de classe:
-
Net Class – selecione para adicionar uma nova classe de nets.
- Component Class – selecione para adicionar uma nova classe de componentes. Essa opção está disponível somente na variante Conjunto de parâmetros da caixa de diálogo Parameter Set ou do painel Properties.
-
Diff. Pair Net Class – selecione para adicionar uma nova classe de nets de pares diferenciais. Essa opção está disponível somente na variante Par diferencial da caixa de diálogo Parameter Set ou do painel Properties.
-
Parameter – selecione para adicionar um novo parâmetro.
-
Rule – clique para abrir a caixa de diálogo Select Design Rule Type, na qual você pode selecionar o tipo de uma nova regra Após escolher um tipo de regra e clicar em
, a caixa de diálogo Edit PCB Rule (From Schematic) será aberta para que você possa editar a nova regra, se desejar.
-
Clique no ícone de lápis para abrir a caixa de diálogo Edit PCB Rule (From Schematic) e editar o item selecionado. Clique em
para excluir o item selecionado.
- Font Settings – clique na fonte exibida para alterar o estilo da fonte. Essa opção só está disponível após a adição de uma classe de nets, classe de nets de pares diferenciais, parâmetro ou regra.
-
Other – se uma classe de nets, classe de nets de pares diferenciais, parâmetro ou regra tiver sido adicionada, clique para abrir um menu suspenso e alterar opções adicionais:
- Show Parameter Name – habilite para mostrar o nome do parâmetro.
- Allow Synchronization with Database – habilite para sincronizar com o banco de dados.
- X/Y – insira as coordenadas X e Y.
- Rotation – use a lista suspensa para selecionar a rotação.
- Autoposition – marque para habilitar o posicionamento automático.
Posicionamento de diretivas de conjunto de parâmetros
Posicione uma diretiva desse tipo escolhendo o comando Place » Directives » Parameter Set no menu principal ou clicando com o botão direito na área de projeto. Ao posicionar uma diretiva padrão de conjunto de parâmetros, não haverá parâmetros existentes. Um conjunto de parâmetros é uma diretiva de projeto que permite associar especificações de projeto a um objeto do tipo net em um projeto esquemático. Por exemplo, use um conjunto de parâmetros para declarar duas nets como integrantes de um par diferencial. O software usa a presença de parâmetros com nomes específicos no conjunto de parâmetros para determinar qual diretiva de projeto você está posicionando.
Além das diretivas de parâmetros definidas pelo usuário, uma diretiva de parâmetros baseada em regras é definida na caixa de diálogo Choose Design Rule Type, acessível pelo modo do painel Properties associado ao parâmetro. Para acessá-la, siga estas etapas:
-
Pressione
Tabantes de posicionar o conjunto de parâmetros ou clique duas vezes em uma diretiva de conjunto de parâmetros já posicionada para exibir suas propriedades no painel Properties. -
Em seguida, clique no botão
na região Parameters do painel Properties e escolha Rule na lista suspensa para selecionar uma regra na caixa de diálogo Select Design Rule Type.
Use a caixa de diálogo Select Design Rule Type para selecionar o tipo de regra que deseja adicionar à diretiva como um parâmetro de regra. Ao clicar duas vezes em um tipo de regra, você terá acesso à caixa de diálogo Edit PCB Rule (From Schematic) correspondente, na qual poderá definir as restrições da regra.

Especificação das restrições de uma regra selecionada.
A entrada da região Parameters será o tipo de regra escolhido, juntamente com as restrições especificadas. A imagem a seguir ilustra os parâmetros definidos da regra de restrição de largura para uma diretiva Parameter Set. Para exibir a regra na área de projeto, clique no ícone de visibilidade na região Rules.

Múltiplas restrições de regras definidas para uma determinada net por meio de uma diretiva de conjunto de parâmetros.
Quando o projeto for transferido para a PCB por meio do processo de sincronização, as regras de projeto correspondentes serão criadas com base nas informações contidas em uma diretiva. A palavra Schematic é usada no nome de cada regra gerada para distinguir a origem dessa regra.

Regras de projeto geradas na PCB.
Posicionamento de diretivas de classe de nets
Uma diretiva de classe de nets permite criar classes de nets definidas pelo usuário no esquemático. Uma diretiva de classe de nets pode ser posicionada escolhendo o comando Place » Directives » Parameter Set nos menus principais e, em seguida, definindo o conjunto de parâmetros como uma diretiva de classe de nets, conforme especificado na Dica nº 2 da página do comando. Quando uma PCB é criada a partir do esquemático, as informações de uma diretiva de classe de nets são usadas para criar a classe de nets correspondente na PCB. Para tornar uma net integrante de uma classe de nets, anexe uma diretiva de classe de nets ao fio, barramento ou chicote de sinais correspondente e, em seguida, defina o parâmetro ClassName da diretiva com o nome da classe desejada. A opção Generate Net Classes (para classes definidas pelo usuário) deve estar habilitada na aba Geração de classes da caixa de diálogo Opções do projeto para usar esse recurso.
Se uma diretiva de classe de nets tiver sido definida para uma net, todas as regras de projeto de PCB também criadas por esse objeto de conjunto de parâmetros terão como escopo a classe de nets quando o projeto for transferido para o editor de PCB. Uma diretiva de classe de nets pode ser criada a partir de uma diretiva de conjunto de parâmetros já posicionada, adicionando uma classe cujo valor deve ser definido como a classe de nets de PCB desejada.
Requisitos importantes das opções do projeto
Para garantir que os conjuntos de parâmetros definidos no esquemático sejam propagados para a PCB, as seguintes opções devem ser configuradas na caixa de diálogo Options for PCB Project:
- Habilite a opção Generate Net Classes, localizada na região User-Defined Classes da aba Geração de classes da caixa de diálogo.
-
Na aba Comparador da caixa de diálogo, defina o modo de verificação Differences Associated with Nets » Extra Net Classes como
Find Differences.

Para propagar as diretivas de conjunto de parâmetros para a PCB, duas opções do projeto precisam ser configuradas. Primeiro, habilite a opção Generate Net Classes na aba Class Generation. Passe o cursor sobre a imagem para mostrar a aba Comparator, na qual você precisará definir a opção Extra Net Classes como Find Differences.
Quando o projeto for transferido para a PCB por meio do processo de sincronização, as classes de nets correspondentes serão criadas com base nas informações contidas em uma diretiva.
Posicionamento de diretivas Blanket
As diretivas de Conjunto de Parâmetros só podem ser aplicadas à rede específica à qual estão conectadas, mas, quando combinadas com uma diretiva de Área de Abrangência, seu escopo pode ser ampliado para incluir todas as redes dentro dessa área.
Insira uma diretiva desse tipo selecionando o comando Place » Directives » Blanket nos menus principais. Ao inserir uma área de abrangência, você pode definir uma forma retangular simples ou uma forma poligonal. Esta última oferece um controle mais preciso sobre a cobertura dos objetos de rede desejados em uma folha.
A área de abrangência identifica as redes de interesse – insira uma diretiva de Parameter Set em qualquer ponto da borda da área para aplicar os requisitos de projeto a essas redes. Para aplicar a diretiva do perímetro a uma rede sob uma diretiva de Área de Abrangência, um objeto associado a essa rede – um pino, uma porta, um rótulo de rede, uma porta de alimentação ou um segmento de fio/barramento/chicote (incluindo ambas as extremidades) – deve estar dentro dos limites da área. Observe que, para identificadores de rede, como rótulos de rede, o ponto de conexão deve estar dentro da área de abrangência. Se as redes integrantes não forem transferidas para o Conjunto de Parâmetros da PCB conforme esperado, tente ajustar a área de abrangência.

Um exemplo de uso de uma diretiva de Área de Abrangência para aplicar uma diretiva de Conjunto de Parâmetros às redes dentro da área.
Exemplos de uso de uma diretiva de área de abrangência incluem:
- Conectar uma diretiva de Conjunto de Parâmetros a um objeto de área de abrangência para que seus parâmetros de regras sejam aplicados a cada rede individual coberta por essa área.
- Conectar uma diretiva de Conjunto de Parâmetros a um objeto de área de abrangência para criar um Conjunto de Parâmetros cujos membros sejam as redes individuais cobertas por essa área.
- Conectar uma diretiva de Par Diferencial a um objeto de área de abrangência para criar objetos de par diferencial com base nas redes diferenciais dentro dos limites dessa área.
Uma Área de Abrangência, em conjunto com uma diretiva de Conjunto de Parâmetros, também pode ser usada para aplicar classes de componentes e parâmetros aos componentes que estejam completamente dentro da área definida. Para isso, use as opções Component Class e Parameter do menu suspenso do botão Add nas propriedades da diretiva de Conjunto de Parâmetros conectada à Área de Abrangência. As informações sobre a classe de componentes e o parâmetro serão transferidas para o documento da PCB do projeto durante o processo de ECO ao atualizar a PCB.
Área de Abrangência
Uma Área de Abrangência retangular e uma Área de Abrangência poligonal – cada uma com uma diretiva conectada
Resumo
Uma Área de Abrangência é um objeto de diretiva de grupo, de forma retangular ou poligonal, inserido sobre um conjunto de redes e/ou componentes. Uma diretiva (objeto de Conjunto de Parâmetros) aplicada à Área de Abrangência será então aplicada a todas as redes e componentes cobertos por ela. Ao inserir uma área de abrangência, você pode definir uma forma retangular simples ou uma forma poligonal. Esta última oferece um controle mais preciso sobre a cobertura dos objetos de rede desejados em uma folha.
A Área de Abrangência se aplica a todas as redes que:
- estejam completamente dentro da área definida pela Área de Abrangência, ou
- tenham pelo menos um vértice de extremidade conectado do fio / barramento / chicote sob a Área de Abrangência, ou
- tenham um rótulo de rede conectado ao fio / barramento / chicote, e esse rótulo de rede esteja sob a Área de Abrangência.
Para componentes, a Área de Abrangência se aplica a todos os componentes dentro da área definida por ela.
Uma diretiva aplicada ao perímetro da Área de Abrangência (Place » Directive), como Sem ERC, Par Diferencial ou um Conjunto de Parâmetros de Regra/Classe específico, será aplicada a todas as redes e componentes identificados pelo objeto de Área de Abrangência. As Áreas de Abrangência podem ser desativadas e ocultadas.
Disponibilidade
As Áreas de Abrangência estão disponíveis para inserção apenas no editor de esquemáticos. Para inserir uma Área de Abrangência:
- Clique em Place » Directives » Blanket nos menus principais.
- Clique no botão Área de Abrangência no menu suspenso de diretivas da Active Bar localizada na parte superior do espaço de projeto. Clique e mantenha pressionado um botão Active Bar para acessar outros comandos relacionados. Depois que um comando for usado, ele se tornará o primeiro item nessa seção da Active Bar.
- Clique com o botão direito no editor de esquemáticos e clique em Place » Directives » Blanket.
Inserção
Para inserir uma Área de Abrangência retangular:
- Inicie o comando conforme descrito acima.
- Posicione o cursor e clique ou pressione Enter para definir o canto superior esquerdo.
- Posicione o cursor e clique ou pressione Enter para definir o canto inferior direito.
- Clique com o botão direito ou pressione Enter para concluir a inserção.
- Continue inserindo outras Áreas de Abrangência ou clique com o botão direito ou pressione Esc para sair do modo de inserção.
Para inserir uma Área de Abrangência poligonal:
- Inicie o comando de inserção.
- Posicione o cursor e clique ou pressione Enter para fixar o ponto inicial da Área de Abrangência.
- Posicione o cursor e clique ou pressione Enter para fixar uma série de segmentos que definem a forma da Área de Abrangência.
- Após inserir o segmento final, clique com o botão direito ou pressione Esc para concluir a inserção. Não é necessário 'fechar' o polígono, pois o software completará automaticamente a forma adicionando os segmentos necessários para conectar o ponto inicial ao último segmento inserido.
- Continue inserindo outras Áreas de Abrangência ou clique com o botão direito ou pressione Esc para sair do modo de inserção.
As ações adicionais que podem ser executadas enquanto os segmentos da Área de Abrangência estão sendo inseridos são:
- Pressione a tecla Tab para pausar a inserção e acessar o modo Blanket do painel Propriedades , onde suas propriedades de linha podem ser alteradas durante a operação. Clique no botão de pausa sobreposto ao espaço de projeto para retomar a inserção.
- Pressione Spacebar para alterar a direção do canto de um segmento ainda não confirmado.
- Pressione Backspace para excluir o segmento definido anteriormente ao definir uma forma poligonal para o Blanket. O uso sucessivo de Backspace excluirá os segmentos anteriores em ordem.
Edição gráfica
Este método de edição permite selecionar um objeto Blanket já posicionado diretamente na área de projeto e alterar graficamente seu tamanho, forma ou localização. Quando um objeto Blanket é selecionado, as seguintes alças de edição ficam disponíveis:
Blankets retangulares e poligonais selecionados, mostrando suas alças de edição gráfica.
Clique e arraste uma alça de edição no centro de um segmento para mover essa borda do Blanket.
Para um Blanket retangular, clique e arraste uma alça de edição de canto para redimensioná-lo simultaneamente nos planos vertical e horizontal.
Clique em qualquer ponto do contorno do Blanket longe das alças de edição e arraste para reposicioná-lo. O Blanket pode ser girado ou espelhado enquanto é arrastado:
- Pressione Spacebar para girar o Blanket no sentido anti-horário em torno da posição do cursor. Shift+Spacebar gira o Blanket no sentido horário em torno do cursor. A rotação ocorre em incrementos de 90°.
- Pressione as teclas X ou Y para espelhar o Blanket ao longo do eixo X ou Y, em relação à posição do cursor.
Edição não gráfica
Os seguintes métodos de edição não gráfica estão disponíveis.
Edição pela caixa de diálogo Blanket ou pelo painel Properties
Panel page: Propriedades do Blanket
Este método de edição usa o modo de caixa de diálogo Blanket e o modo de painel Properties associados para modificar as propriedades de um objeto Blanket.
A caixa de diálogo Blanket , à esquerda, e o modo Blanket do painel Properties, à direita
Após o posicionamento, a caixa de diálogo Blanket pode ser acessada das seguintes maneiras:
- Clicando duas vezes no objeto Blanket posicionado.
- Posicionando o cursor sobre o objeto Blanket, clicando com o botão direito e escolhendo Properties no menu de contexto.
Durante o posicionamento, o modo Blanket do painel Properties pode ser acessado pressionando a tecla Tab. Assim que o Blanket for posicionado, todas as opções serão exibidas.
Após o posicionamento, o modo Blanket do painel Properties pode ser acessado de uma das seguintes maneiras:
- Se o painel Properties já estiver ativo, selecionando o objeto Blanket.
- Após selecionar o objeto Blanket, selecione o painel Properties pelo botão Panels na seção inferior direita da área de projeto ou selecione View » Panels » Properties no menu principal.
Edição de vários objetos
O painel Properties permite editar vários objetos, modificando as configurações de propriedades que são idênticas em todos os objetos selecionados no momento. Quando vários objetos do mesmo tipo são selecionados manualmente, pela caixa de diálogo Localizar objetos semelhantes ou por um painel Filter ou List, um campo do painel Properties que não seja exibido como um asterisco (*) pode ser editado para todos os objetos selecionados.
Edição por um painel List
Panel pages: Painéis List, SCH Filter
Um painel List exibe tipos de objetos de projeto de um ou mais documentos em formato de tabela, permitindo inspecionar e modificar rapidamente os atributos dos objetos. Usado em conjunto com a filtragem apropriada — selecionando tipos de objetos (usando as opções Include do painel), ou usando o painel Filter aplicável ou a caixa de diálogo Localizar objetos semelhantes —, ele permite exibir apenas os objetos abrangidos pelo filtro ativo. As propriedades dos objetos listados podem então ser editadas diretamente no painel List.
Suporte à filtragem
Duas palavras-chave particularmente úteis estão disponíveis para selecionar objetos Blanket usando expressões de consulta lógica. Elas complementam as demais palavras-chave usadas para selecionar um Blanket com base em suas propriedades.
-
Collapsed– o objeto está recolhido (também útil ao selecionar máscaras de compilação). Essa palavra-chave pode ser encontrada na categoria SCH Functions - Fields ao usar o Assistente de consultas. -
IsBlanket– verifica se o objeto é um Blanket. Essa palavra-chave pode ser encontrada na categoria SCH Functions - Object Type Checks ao usar o Assistente de consultas.
Crie expressões lógicas de consulta para selecionar e retornar Blankets no seu projeto conforme necessário. Alguns exemplos de expressões de consulta lógica para selecionar Blankets são:
IsBlanket And Collapsed – seleciona todos os objetos Blanket que estão recolhidos no momento.
IsBlanket And Not Collapsed – seleciona todos os objetos Blanket que não estão recolhidos no momento.
Desabilitar um Blanket
Após o posicionamento, os Blankets podem ser desabilitados temporariamente clicando no pequeno triângulo no canto superior esquerdo Clique uma vez para desabilitar e ocultar o Blanket; clique novamente para reabilitá-lo. Isso oferece uma maneira prática de controlar o impacto do Blanket sem precisar removê-lo completamente do projeto.
Propriedades da Blanket
As propriedades dos objetos do Editor de Esquemáticos são opções configuráveis que especificam o estilo visual, o conteúdo e o comportamento do objeto posicionado. As configurações de propriedades de cada tipo de objeto são definidas de duas maneiras diferentes:
-
Pre-placement settings – a maioria das propriedades do objeto Blanket, ou aquelas que podem ser logicamente predefinidas, estão disponíveis como configurações padrão editáveis na página Esquemático - Padrões da caixa de diálogo Preferences (acesse pelo botão
no canto superior direito da área de projeto). Selecione o objeto em Primitive List para exibir suas opções à direita.
- Post-placement settings – todas as propriedades do objeto Blanket estão disponíveis para edição na caixa de diálogo Blanket e no painel Properties quando uma Blanket posicionada é selecionada na área de projeto.
Propriedades
- Border Width - use a lista suspensa para selecionar a largura desejada da borda.
- Estilo de Linha - use a lista suspensa para selecionar o estilo de linha desejado.
- Border Color - clique na caixa de cor para selecionar a cor desejada para a borda.
- Fill Color - clique na caixa de cor para selecionar a cor desejada para o preenchimento.
- Collapsed and Disabled - marque para recolher e desabilitar as blankets.
Diretivas indiretas (baseadas em parâmetros)
As diretivas de Conjunto de Parâmetros são necessárias ao direcionar objetos de projeto no esquemático que não podem conter parâmetros. Porém, para os objetos que podem, as diretivas de projeto podem ser aplicadas indiretamente, adicionando-as (e definindo-as) como parâmetros do objeto esquemático correspondente. Em essência, elas são parameter-based directives.
Exemplos de uso de diretivas baseadas em parâmetros incluem limitar a altura de um componente específico ou adicionar uma restrição de espaçamento que se aplique a todos os objetos do projeto. O parâmetro necessário que define a restrição é adicionado ao objeto como uma regra.
Quando sincronizadas com a PCB, as diretivas baseadas em parâmetros adicionadas aos objetos no esquemático tornam-se regras de projeto da PCB. O escopo da regra de projeto correspondente na PCB será determinado pela natureza do objeto ao qual o parâmetro foi inicialmente atribuído. A tabela a seguir resume as opções compatíveis de escopo de regras da PCB derivadas de parâmetros do esquemático.
| Adicione um parâmetro (como regra) a um(a)... | A partir de... | Para um escopo de regra da PCB de... |
|---|---|---|
| Pino | a aba Parameters do modo Pino do painel Propriedades. | Pad |
| Porta | a aba Parameters do modo Porta do painel Propriedades. | Rede |
| Componente | a região Parameters do modo Componentes do painel Propriedades. | Componente |
| Símbolo de Folha | a aba Parameters do modo Símbolo de Folha do painel Propriedades, quando Local está selecionado na região Origem. | Classe de Componentes |
| Símbolo de Folha de Dispositivo | a aba Parameters do modo Símbolo de Folha do painel Propriedades, quando Dispositivo está selecionado na região Origem. | Classe de Componentes |
| Símbolo de Folha Gerenciada | a região Parameters do modo Símbolo de Folha do painel Propriedades, quando Gerenciada está selecionado na região Origem. | Classe de Componentes |
| Folha | a aba Parameters do modo Opções do Documento do painel Propriedades. | Todos os Objetos |
Em cada caso, o método para adicionar um parâmetro baseado em regra é o mesmo. Na aba ou caixa de diálogo correspondente, faça o seguinte:
- Adicione um parâmetro como regra.
- Selecione o tipo de regra a ser usado.
- Configure as restrições para o tipo de regra escolhido.
Especificação de classes de componentes
De maneira semelhante, as classes de componentes podem ser definidas no esquemático adicionando um parâmetro ClassName aos componentes desejados e definindo seu valor como o nome da classe desejada. Quando o projeto for transferido para a PCB, as classes de componentes definidas serão criadas.
Para garantir que as classes de componentes definidas no esquemático sejam propagadas para a PCB, as seguintes opções devem ser configuradas na caixa de diálogo Project Options:
- Habilite a opção Generate Component Classes localizada na região User-Defined Classes da aba Geração de Classes da caixa de diálogo.
-
Na aba Comparador da caixa de diálogo, defina a configuração Differences Associated with Components » Extra Component Classes Mode como
Find Differences.
A opção da aba Class Generation mencionada acima é exibida na imagem abaixo. Passe o cursor sobre a imagem para visualizar a configuração da opção da aba Comparator .

Para propagar as classes de componentes para a PCB, habilite a opção Generate Component Classes na aba Class Generation. Passe o cursor sobre a imagem para mostrar a aba Comparator, na qual você deverá definir a configuração Extra Component Classes Mode como Find Differences.
Depois de definidas, as classes podem ser bloqueadas na região Properties do painel Properties das propriedades do respectivo componente.
Controle da impressão de diretivas
Por padrão, todas as diretivas de projeto são incluídas na impressão das folhas do esquemático. Isso, porém, pode ser alterado:
- Na caixa de diálogo Propriedades de Impressão do Esquemático, ao imprimir diretamente do esquemático ou como parte de uma saída configurada em um arquivo de Configuração de Tarefas de Saída.
- Na região Schematics include, na página Additional PDF Settings do Assistente de PDF Inteligente.

Controle a impressão das diretivas conforme necessário. Para as diretivas No ERC, você pode optar por imprimir determinados estilos de símbolo e excluir outros.



).

).