Preparando dados de fabricação
Num relance
- Saiba como gerar saídas de fabricação por meio de um arquivo de tarefa de saída (Output Job) ou diretamente no editor de PCB.
- Entenda os dados adicionais de fabricação do Gerber X2 e sua compatibilidade com versões anteriores do Gerber RS-274X.
- Explore as opções de configuração das saídas Gerber RS-274X, Gerber X2, ODB++, IPC-2581, arquivos de furação NC, relatório de empilhamento da placa e relatório de pontos de teste de fabricação.
Uma ampla variedade de formatos de arquivo de fabricação de PCBs está disponível tanto para geração individual quanto por meio de arquivos de tarefas de saída, incluindo:
-
Gerber RS-274X e Gerber X2
-
ODB++
-
IPC-2581
-
Furação NC
-
Relatório de empilhamento da placa
-
Saídas para impressão: desenhos compostos de furação, desenhos/guias de furação, impressões da arte-final, impressões dos planos de alimentação, impressões das máscaras de solda/pasta.
-
Relatório de pontos de teste de fabricação
As saídas de fabricação podem ser adicionadas ao arquivo de tarefas de saída ativo a partir do menu do controle [Add New Fabrication Output] na região Fabrication Outputs do arquivo ou dos submenus Edit » Add Fabrication Outputs dos menus principais.
Geração de dados de fabricação Gerber
Cada arquivo do formato Gerber RS274X (também conhecido como Extended Gerber ou GerberX) corresponde a uma camada da placa física — a serigrafia de componentes, a camada de sinal superior, a camada de sinal inferior, as camadas de máscara de solda etc. Esse formato de arquivo inclui definições de aberturas, posições em coordenadas XY para comandos de traçado e flash, além de outras informações necessárias para a fabricação de PCBs.
O Gerber X2 é uma evolução direta e muito mais avançada do padrão Gerber RS-274X e acrescenta uma ampla variedade de dados adicionais para a fabricação e montagem de PCBs. Em comparação com o padrão RS-274X, o formato Gerber X2 inclui informações essenciais, como definições do empilhamento de camadas e atributos de pads e vias. Uma das principais vantagens do formato Gerber X2 é a compatibilidade com o antigo padrão Gerber RS-274X. Por ser um padrão de múltiplos arquivos, uma empresa de fabricação/montagem que ainda não tenha adotado o novo padrão pode extrair os elementos tradicionais dos arquivos Gerber conforme necessário. Isso pode ser uma vantagem significativa para quem não deseja realizar uma grande mudança nos formatos de arquivos de fabricação ou para fabricantes com equipamentos e softwares pouco flexíveis.
O benefício geral de adotar o formato Gerber X2 para transferir dados de projeto de placas para empresas de fabricação e montagem é o rico conjunto de dados de manufatura incluído no conjunto de arquivos e a compatibilidade com o padrão anterior, permitindo uma atualização de baixo risco. Com uma implementação completa em ambas as extremidades da cadeia CAD-CAM, os riscos associados à interpretação incorreta de dados, a erros nos arquivos e a variações na interpretação dos dados podem ser amplamente eliminados. Em resumo, os formatos Gerber X2 e IPC-2581 representam uma nova geração de transferência de dados do projeto de placas para a fabricação.
Com um arquivo de PCB do projeto como documento ativo, o conjunto de arquivos Gerber pode ser gerado selecionando File » Fabrication Outputs » Gerber Files ou File » Fabrication Outputs » Gerber X2 Files nos menus principais. Isso abre a caixa de diálogo correspondente, Gerber Setup ou Gerber X2 Setup, na qual você pode definir as camadas a serem plotadas e a configuração geral aplicada durante o processo de exportação. Consulte as seções expansíveis abaixo para obter informações detalhadas sobre as opções e os controles disponíveis nessas caixas de diálogo.

Gerber Setup e Gerber X2 Setup caixas de diálogo
A saída é gerada no local definido no campo Output Path da aba Opções da caixa de diálogo Project Options. Os nomes dos arquivos gerados incluirão o nome do documento PCB.
A saída Gerber gerada também é aberta como um documento CAM composto que pode ser editado e/ou salvo no projeto atual e gerenciado pelo painel CAMtastic.
Opções e controles da caixa de diálogo Configuração de Gerber

A caixa de diálogo Gerber Setup. Passe o mouse sobre a imagem para alternar entre as abas Layers to plot e Advanced.
Unidades
Use esta região para escolher as unidades usadas no arquivo gerado:
-
Inches – habilite esta opção para usar unidades imperiais, nas quais todo o trabalho é feito em mils (1 mil = 1/1000 de polegada).
-
Millimeters – habilite esta opção para usar unidades métricas, nas quais todo o trabalho é feito em milímetros.
Decimal
Use a lista suspensa nesta região para especificar a precisão numérica das coordenadas de plotagem no arquivo Gerber.
Saídas: NomeDoArquivo.Extensão
Use esta região para escolher a opção de nomenclatura dos arquivos Gerber a serem gerados:
-
*.gbr – habilite esta opção para gerar camadas com nomes de arquivo exclusivos, mas com a mesma extensão (.gbr).
-
filename.* (gtl, gbl, gto,...) – habilite esta opção para gerar camadas com o mesmo nome de arquivo, mas com extensões diferentes (.gtl, .gbl, .gto,...).
Outros
-
Include unconnected mid-layer pads – habilite esta opção para permitir pads não conectados na camada intermediária nas plotagens Gerber.
-
Generate Reports – habilite esta opção para gerar os seguintes arquivos:
.REP,.EXTREP,.apre.APR_LIB. -
Merge regions and pads inside Footprint – habilite esta opção para mesclar regiões e pads dentro de um footprint durante a geração de saídas Gerber.
Aba Camadas a plotar
Esta aba permite configurar quais camadas serão plotadas na saída Gerber do documento PCB atual.
-
Layers List – uma lista das camadas da PCB atual disponíveis para exportação em Gerber. As camadas são agrupadas por tipo (camadas de cobre, serigrafia, máscara de solda, máscara de pasta, camadas mecânicas etc.). Cada camada é apresentada com as seguintes informações:
-
File Name – o nome de cada arquivo de saída Gerber. A nomenclatura é baseada no nome do projeto, na camada e na função, e usa um sublinhado como separador descritivo. Clique no nome de uma camada para digitar um novo nome, se necessário.
-
Layer Name – o nome da camada que se aplica ao arquivo de saída conforme definido pelo empilhamento de camadas da placa.
-
Plot – habilite esta opção para incluir uma plotagem Gerber dessa camada ou grupo de camadas na saída gerada. Desabilite-a para impedir a geração da plotagem dessa camada.
-
Mirror – habilite esta opção para uma camada ou grupo de camadas se desejar criar um arquivo Gerber espelhado.
-
-
Plot Layers – use a lista suspensa para acessar um menu de comandos que permitem habilitar ou desabilitar o campo Plot de todas as camadas na região Layers to plot:
- Select All – selecione para marcar todas as caixas na coluna Plot (serão criados dados Gerber para todas as camadas marcadas).
- Deselect All – selecione para desmarcar todas as caixas na coluna Plot (nenhum dado Gerber será criado).
- Select Used – selecione para marcar todas as caixas na coluna Plot das camadas listadas que são usadas no projeto.
-
Edit Group – clique para abrir a caixa de diálogo Add Mechanical Layers, na qual você pode selecionar as camadas mecânicas adicionadas a todas as camadas de plotagem do grupo de camadas selecionado. Você também pode clicar no botão
associado a um grupo de camadas para acessar a caixa de diálogo Add Mechanical Layers.
-
Mirror Layers – use a lista suspensa para acessar um menu de comandos que permitem habilitar ou desabilitar o campo Mirror de todas as camadas na região Layers to plot:
- Select All – selecione para marcar todas as caixas na coluna Mirror (serão criados dados Gerber para todas as camadas marcadas).
- Deselect All – selecione para desmarcar todas as caixas na coluna Mirror (nenhum dado Gerber será criado).
- Select Used – selecione para marcar todas as caixas na coluna Mirror das camadas listadas que são usadas no projeto.
Aba Avançado
Tolerâncias de correspondência de aberturas
- Plus – use este campo para definir a tolerância positiva de correspondência de aberturas.
- Minus – use este campo para definir a tolerância negativa de correspondência de aberturas.
Zeros à esquerda/à direita
- Keep leading and trailing zeroes – se esta opção estiver habilitada, todos os zeros à esquerda e à direita aparecerão no arquivo Gerber gerado.
- Suppress leading zeroes – se esta opção estiver habilitada, nenhum zero à esquerda aparecerá no arquivo Gerber gerado.
- Suppress trailing zeroes – se esta opção estiver habilitada, nenhum zero à direita aparecerá no arquivo Gerber gerado.
Tipo de plotter
- Unsorted (raster) – selecione para usar uma máquina raster (padrão).
- Sorted (vector) – selecione para usar uma máquina vetorial.
Outros
- Optimize change location commands – quando esta opção está habilitada, os dados de localização X ou Y não são incluídos se não mudarem de um objeto para o próximo.
- G54 on aperture change – marque esta opção para girar a roda de aberturas do plotter após cada troca de abertura.
- Use software arcs – marque esta opção para usar arcos gerados por software.
- Use polygons for octagonal pads – marque esta opção para usar polígonos em todos os pads octogonais.
-
Generate DRC Rules export file (.RUL) – marque esta opção para gerar um arquivo de exportação de regras DRC (
.RUL). O relatório desse arquivo detalha as regras de projeto do documento PCB de origem a partir do qual os dados Gerber são gerados.
Aba Legado

A aba Legacy da caixa de diálogo Gerber Setup
Tamanho do filme
- X(horizontal) – insira um valor para o comprimento do filme.
- Y(vertical) – insira um valor para a largura do filme.
- Border size – insira um valor para o tamanho da borda do filme.
Posição no filme
Use as opções a seguir para escolher a posição no filme:
- Reference to absolute origin
- Reference to relative origin
- Center on film
Modo em lote
- Separate file per layer – selecione esta opção se quiser que cada camada gere um arquivo Gerber separado.
- Panelize layers – selecione esta opção se quiser que apenas um arquivo Gerber seja gerado no formato de painelização.
Aberturas
- Embedded apertures (RS274X) – quando esta opção está habilitada, as aberturas são incorporadas aos arquivos Gerber de acordo com o padrão RS274X, e todas as informações de cada camada ficam contidas em um único arquivo. Habilitar esta opção garante que a lista atual de aberturas inclua todas as aberturas necessárias. Se esta opção estiver desabilitada, controles adicionais nesta região ficarão disponíveis.
- Maximum aperture size – insira o tamanho máximo das aberturas para o projeto.
- Generate relief shapes – marque esta opção para criar aberturas do tipo alívio.
- Flash pad shapes – marque esta opção para expor as formas dos pads por flash.
- Flash all fills – marque esta opção para expor todos os preenchimentos por flash.
- Apertures List – lista todos os dados atuais das aberturas.
-
New – use a lista suspensa para acessar um menu de comandos que permitem adicionar uma nova abertura e salvar ou carregar a lista de aberturas em/de um arquivo de aberturas:
- Add Aperture – selecione para abrir a caixa de diálogo Editar abertura, na qual você pode especificar as propriedades da nova abertura.
- Load – selecione para abrir uma caixa de diálogo na qual você pode selecionar o local do arquivo de aberturas a ser carregado.
- Save – selecione para salvar as aberturas atuais da lista de aberturas.
-
Edit – use a lista suspensa para acessar um menu de comandos que permitem editar uma abertura selecionada ou a lista de aberturas:
- Edit Aperture – selecione para editar as propriedades da abertura selecionada na caixa de diálogo Editar abertura.
- Rename Aperture – selecione para editar as propriedades da abertura selecionada na caixa de diálogo Edit Aperture.
- Clear All – selecione para remover todas as aberturas da lista de aberturas.
- Create List from PCB – selecione para criar a lista de aberturas a partir do projeto de PCB atual.
-
– selecione para excluir a abertura selecionada.
Notes about Apertures
A menos que o fabricante da sua PCB não ofereça suporte a aberturas incorporadas, é altamente recomendável usar a opção Embedded apertures (RS274X). A maioria dos fotoplotters modernos são plotters raster que aceitam aberturas de qualquer tamanho. Em geral, eles também aceitam arquivos Gerber com aberturas incorporadas.
Se o seu fabricante não usar aberturas incorporadas, um arquivo de aberturas separado (*.apt) deverá ser incluído com os arquivos Gerber. Se você usar um arquivo de aberturas existente em vez de um gerado, o Editor de PCB verificará as primitivas (trilhas, pads etc.) no documento PCB e as associará às descrições de aberturas no arquivo *.apt carregado. Se não houver uma correspondência exata entre a abertura e a primitiva, o Editor de PCB irá automaticamente paint a primitiva com uma abertura menor adequada. Se não houver uma abertura adequada para pintar, será gerado um arquivo *.MAT (correspondência) listando as aberturas ausentes, e a geração dos arquivos Gerber será interrompida.
Opções e controles da caixa de diálogo Configuração Gerber X2

A caixa de diálogo Gerber X2 Setup. Passe o mouse sobre a imagem para alternar entre as abas Layers to plot e Advanced.
Unidades
Use esta região para escolher as unidades usadas no arquivo gerado:
- Inches – habilite esta opção para usar unidades imperiais, nas quais todo o trabalho é feito em mils (1 mil = 1/1000 de polegada).
- Millimeters – habilite esta opção para usar unidades métricas, nas quais todo o trabalho é feito em milímetros.
Decimal
Use a lista suspensa nesta região para especificar a precisão numérica das coordenadas de plotagem no arquivo Gerber.
Saídas: NomeDoArquivo.Extensão
Use esta região para escolher a opção de nomenclatura dos arquivos Gerber a serem gerados:
- *.gbr – habilite esta opção para gerar camadas com nomes de arquivo exclusivos, mas com a mesma extensão (.gbr).
- filename.* (gtl, gbl, gto,...) – habilite esta opção para gerar camadas com o mesmo nome de arquivo, mas com extensões diferentes (.gtl, .gbl, .gto,...).
Outros
- Include unconnected mid-layer pads – habilite esta opção para permitir pads não conectados na camada intermediária nas plotagens Gerber.
-
Generate Reports – habilite esta opção para gerar os seguintes arquivos:
.REP,.EXTREP,.apre.APR_LIB. - Merge regions and pads inside Footprint – habilite esta opção para mesclar regiões e pads dentro de um footprint durante a geração das saídas Gerber.
Aba Camadas a plotar
Esta aba permite configurar quais camadas serão plotadas na saída Gerber X2 do documento PCB atual.
-
Layers List – uma lista das camadas da PCB atual disponíveis para saída em Gerber. As camadas são agrupadas por tipo (Contorno da placa, Camadas de cobre, Serigrafia, Máscara de solda, Máscara de pasta, Camadas mecânicas, Furações etc.). Cada camada é apresentada com as seguintes informações:
- File Name – o nome do arquivo de saída Gerber individual. A nomenclatura é baseada no nome do projeto, na camada e na função, e usa um caractere de sublinhado como separador descritivo. Clique no nome de uma camada para digitar um novo nome, se necessário.
- Layer Name – o nome da camada que se aplica ao arquivo de saída conforme definido no empilhamento de camadas da placa.
- Plot – habilite esta opção para incluir uma plotagem Gerber dessa camada ou grupo de camadas na saída gerada. Desabilite-a para impedir a geração da plotagem dessa camada.
-
Plot Layers – use a lista suspensa para acessar um menu de comandos que permitem habilitar ou desabilitar o campo Plot para todas as camadas na região Layers to Plot:
- Select All – selecione para marcar todas as caixas na coluna Plot (os dados Gerber serão criados para todas as camadas marcadas).
- Deselect All – selecione para desmarcar todas as caixas marcadas na coluna Plot (nenhum dado Gerber será criado).
- Select Used – selecione para marcar todas as caixas na coluna Plot das camadas listadas que são usadas no projeto.
-
Edit Group – clique para abrir a caixa de diálogo Add Mechanical Layers, na qual você pode selecionar as camadas mecânicas que serão adicionadas a todas as camadas de plotagem do grupo de camadas selecionado. Você também pode clicar no botão
associado a um grupo de camadas para acessar a caixa de diálogo Add Mechanical Layers.
Aba Avançado
Tolerâncias de abertura
Use as opções desta região para definir a faixa de tolerância usada na correspondência de aberturas para cada item nas plotagens.
- Plus – use para definir a tolerância positiva para a correspondência de aberturas.
- Minus – use para definir a tolerância negativa para a correspondência de aberturas.
Tipo de plotadora
Use esta região para especificar o tipo de fotoplotadora de destino:
- Unsorted (raster) – selecione para usar uma máquina raster (padrão).
- Sorted (vector) – selecione para usar uma máquina vetorial.
Específico do Gerber X2
-
File Subject – use este campo para selecionar o tipo de arquivo, que é incluído como um atributo
Partnas saídas Gerber X2. A lista suspensa oferece as seguintes opções:-
None -
Autodetect– atribui automaticamente um atributo da lista abaixo com base no tipo de arquivo da placa. Por exemplo, a um documento de PCB que contenha o projeto de uma única placa será atribuído o atributo de peçaSingle. -
Single– uma única PCB. -
CustomerPanel– um conjunto de placas ou painel de expedição. -
ProductionPanel– um painel de trabalho ou painel de fabricação. -
Coupon– um cupom (placa de teste de desempenho associada ao projeto de uma placa principal). -
Other– nenhuma das opções acima. No arquivo, uma string acrescentada ao atributo indica informalmente a peça.
-
- File Comment – insira um comentário que será incluído como atributo nas saídas geradas.
Outros
- Optimize change location commands – quando esta opção está habilitada, os dados de localização X ou Y não são incluídos se não mudarem de um objeto para o seguinte.
- Generate DRC Rules export file (.RUL) – habilite esta opção para gerar um arquivo de exportação de regras DRC. O relatório detalha as regras de projeto definidas para o documento de PCB de origem a partir do qual os dados Gerber estão sendo gerados.
Geração de dados de fabricação ODB++
ODB++ é um formato de intercâmbio de dados de CAD para CAM utilizado no projeto e na fabricação de placas de circuito impresso. O formato foi originalmente desenvolvido pela Valor Computerized Systems, Ltd., como um banco de dados aberto capaz de proporcionar um intercâmbio de dados mais rico em informações entre o software de projeto de PCBs e o software CAD-CAM da Valor utilizado pelos fabricantes de PCBs.
A caixa de diálogo ODB++ Setup fornece controles para configurar completamente as opções de saída de arquivos ODB++. A caixa de diálogo pode ser acessada de uma das seguintes maneiras:
-
Usando um gerador de saída ODB em um arquivo de configuração OutputJob (
*.OutJob). A saída é gerada quando o gerador de saída configurado é executado. - Em um documento de PCB ativo, clique em File » Fabrication Outputs » ODB++ Files. A saída será gerada imediatamente ao clicar em OK na caixa de diálogo.
Opções e controles da caixa de diálogo de configuração do ODB++
Versão do ODB++
Selecione a versão do ODB++ na qual as saídas geradas devem ser formatadas: v. 8.1 ou a versão legada v. 7.0.
Unidades
Quando a opção v. 8.1 estiver selecionada como ODB++ Version, selecione Millimeters ou Inches como sua unidade de medida preferida. Quando a opção v. 7.0 estiver selecionada como ODB++ Version, Inches serão selecionadas por padrão e não poderão ser alteradas.
Opções de arquivo
Marque a caixa ao lado do tipo de arquivo que deseja utilizar para gerar os arquivos de saída. As opções incluem arquivos não compactados, .zip e .tar/.tgz.
Dados incluídos
-
Include Net List – quando habilitada, as saídas geradas incluirão a netlist.
-
Neutralize Net Names – quando habilitada, os nomes das redes são substituídos por
Net_[1-…]nas saídas geradas. -
Merge Net-Tie Nets – quando habilitada, se um projeto contiver redes conectadas por componentes Net-Tie, essas redes serão apresentadas como redes individuais distintas na netlist. Observe que esta opção fica desabilitada quando a opção Generate shortf: List of Intentional Shorts (Net-Ties) está habilitada.
-
Generate shortf: List of Intentional Shorts (Net-Ties) – ao gerar saídas no formato ODB++ versão 8.1 (a opção v. 8.1 está selecionada como ODB++ Version), habilite para gerar um arquivo
shortfque contém uma lista de redes e primitivas de cobre que podem ser intencionalmente curto-circuitadas ('Net-Ties'). O arquivo gerado pode ser encontrado na subpastaedada saída da etapa. Observe que esta opção fica desabilitada quando a opção Merge Net-Tie Nets está habilitada.
-
-
Include Components – quando habilitada, as saídas geradas incluirão componentes.
-
Remove Component Properties – quando habilitada, as propriedades (parâmetros) dos componentes serão removidas das saídas geradas.
-
Distinguish different footprints with the same name – quando habilitada, se um dos footprints com o mesmo nome tiver sido modificado, apenas o footprint modificado será alterado na saída. Quando a opção não está habilitada, todos os footprints com o mesmo nome serão apresentados como modificados na saída.
-
Include Variants Data – ao gerar saídas no formato ODB++ versão 8.1 (a opção v. 8.1 está selecionada como ODB++ Version), habilite para incluir informações sobre todos variantes de projeto (incluindo
[No Variations]). As seguintes informações são incluídas nos arquivos de saída quando esta opção está habilitada:-
Estado de cada componente em qualquer variante exportada (montado / não montado).
-
Informações sobre peças alternativas no nível do componente para qualquer variante exportada.
-
Parâmetros de cada componente de acordo com a variante.
-
Parâmetros personalizados aplicados a cada variante/componente.
Quando esta opção está desabilitada, a saída é gerada para a variante selecionada no arquivo Outjob ou, quando a saída é gerada diretamente do editor de PCB (File » Fabrication Outputs » ODB++), para a variante atualmente ativa selecionada no painel Projects.
-
-
Outros
-
Include unconnected mid-layer pads – marque para permitir pads não conectados nas camadas intermediárias nas plotagens ODB++.
-
Generate DRC Rules export file (.RUL) – marque para gerar um arquivo
.RULque contenha todas as regras de projeto definidas para o documento de origem a partir do qual os dados ODB++ estão sendo gerados. -
Export only the objects inside the board outline – marque para especificar a origem a ser usada para criar a camada de perfil ODB++. A camada de perfil contém o contorno externo da placa. Por padrão, este campo é definido como Board Outline (também chamado de formato da placa, é uma forma poligonal fechada que define o contorno, ou os limites, da PCB). Criado com cada nova PCB, esse formato talvez seja a melhor origem para a criação da camada de perfil. Se o seu projeto não tiver um formato de placa associado, você poderá escolher qual camada da PCB de origem foi usada para definir o polígono fechado que representa o contorno da placa (por exemplo, a camada KeepOut ou uma camada mecânica específica). Esta opção só está disponível quando o documento de origem contém um objeto de painel de placas incorporado e permite controlar a extensão dos objetos exportados. Observe que, se um objeto (por exemplo, um texto) estiver fora do contorno da placa, mas em contato com ele, e esta opção estiver habilitada, esse objeto ainda será exportado.
-
Generate Additional Tools by Drill Symbols – habilite para gerar ferramentas de furação adicionais com base nos agrupamentos de símbolos de furação definidos. Os dados de colunas adicionais serão incluídos quando existirem no agrupamento de símbolos de furação. As colunas de dados existentes não serão removidas dos dados de furação gerados.
Camadas a plotar
Marque a caixa ao lado de cada camada específica que deseja plotar como parte da saída gerada.
Plotar camadas
Use o menu suspenso ou clique com o botão direito na seção Layers to Plot para selecionar facilmente um grupo de camadas a plotar.
-
All On - clique para marcar todas as caixas na coluna Plot (os dados ODB++ serão criados para todas as camadas marcadas).
-
All Off - clique para desmarcar todas as caixas marcadas na coluna Plot (nenhum dado ODB++ será criado).
-
Used On - clique para marcar todas as caixas na coluna Plot das camadas usadas no projeto.
-
Edit Group - clique para abrir a caixa de diálogo Add Mechanical Layers, na qual você pode selecionar as camadas mecânicas que serão adicionadas à plotagem selecionada. Você também pode clicar em
associado a um grupo de camadas ou clicar com o botão direito em um grupo de camadas e selecionar Edit Group para acessar a caixa de diálogo Add Mechanical Layers.
Opções adicionais
Clicar com o botão direito na seção Custom Layers exibirá:
-
Add Layer - clique para adicionar uma camada.
-
Edit Layer - clique para editar a camada.
-
Delete Layer - clique para excluir a camada.
Clique na célula da lista de camadas de uma camada personalizada na seção Custom Layers para abrir a caixa de diálogo Select Layer, na qual você pode selecionar as camadas que serão adicionadas à camada personalizada selecionada.
Geração a partir de um painel de placas incorporado
Ao gerar uma saída ODB++ a partir de um projeto de PCB que contém um painel de placas incorporado, aplicam-se as seguintes condições:
- O projeto é analisado automaticamente em busca de violações do empilhamento de camadas.
- Placas incorporadas que estiverem invertidas exibirão seus empilhamentos de camadas invertidos.
- Camadas de sinal intermediárias e planos internos diferentes ainda podem aparecer no mesmo painel de camada intermediária.
- Camadas de sinal intermediárias e planos internos podem ser invertidos entre si.
Ao gerar a saída ODB++ a partir do projeto da PCB, todos os objetos em todas as camadas habilitadas para plotagem serão exportados. Se quiser exportar apenas os objetos do projeto localizados dentro do contorno da placa, certifique-se de que todas as camadas adicionais que contenham objetos fora desse limite estejam desabilitadas para plotagem.
Localização dos arquivos ODB++ gerados
O caminho de saída dos arquivos gerados depende de como a saída foi gerada:
- A partir de um arquivo OutputJob - os arquivos gerados são armazenados em uma pasta dentro da pasta do projeto. A nomenclatura e a estrutura de pastas são definidas no Output Container ao qual a saída ODB++ se destina.
-
Diretamente da PCB - o caminho de saída é especificado na caixa de diálogo Opções do projeto - Opções. Por padrão, o caminho de saída é definido como uma subpasta dentro da pasta que contém o arquivo do projeto, com o nome
Project Outputs for <ProjectName>. O caminho de saída pode ser alterado conforme necessário. Se a opção de usar uma pasta separada para cada tipo de saída tiver sido habilitada na guia Options, os arquivos ODB++ serão gravados em uma subpasta adicional chamadaODB++ Output.
Abertura automática da saída ODB++ gerada
Ao gerar a saída ODB++, você pode especificar que ela seja aberta automaticamente em um novo documento CAM. A maneira de fazer isso depende de como você está gerando a saída:
- A partir de um arquivo OutputJob - habilite a opção de carregamento automático ODB++ Output na caixa de diálogo Output Job Options (Tools » Output Job Options no Editor de OutputJob).
- Diretamente da PCB - certifique-se de que a opção Open outputs after compile esteja habilitada na guia Options da caixa de diálogo Project Options (Project » Project Options).
Geração de dados de fabricação IPC-2581
Relacionado ao formato ODB++ existente, o IPC-2581 é um padrão de código aberto desenvolvido pelo Institute for Printed Circuits Consórcio IPC-2581 em 2004, que desde então foi aprimorado até as versões mais recentes das Revisões A e B (IPC-2581A/B).
O padrão tem ganhado aceitação cada vez maior como alternativa aos dados de saída de fabricação tradicionais, normalmente compostos por um conjunto de arquivos Gerber, de furação, de BOM e de texto, entre outros. A necessidade anterior de uma combinação complexa de arquivos de fabricação se deve às limitações inerentes ao formato Gerber RS-274x tradicional, que não possui definições para o empilhamento de camadas, informações de furação, dados de netlist (conectividade elétrica) e informações de BOM.
O padrão IPC-2581 tem o título oficial de ‘Generic Requirements for Printed Board Assembly Products Manufacturing Description Data and Transfer Methodology’ e oferece um formato de arquivo único baseado em XML que incorpora uma ampla variedade de dados de fabricação da placa — desde detalhes do empilhamento de camadas até informações completas de pads, roteamento e componentes, além da lista de materiais (BOM).
Um único arquivo XML IPC-2581 pode incluir:
- Informações de imagem de cobre para a corrosão das camadas da PCB.
- Informações do empilhamento de camadas da placa (incluindo seções rígidas e flexíveis).
- Netlist para testes da placa nua e testes em circuito.
- Lista de materiais de componentes para compra e montagem (pick-and-place).
- Notas e parâmetros de fabricação e montagem.
A vantagem potencial da adoção do formato IPC-2581 para transferir dados de projeto de placas para fabricantes e montadoras está no formato de arquivo único, detalhado e bem definido, que é plenamente compreendido em ambas as extremidades da cadeia. Com um sistema funcional de troca de dados CAD-CAM estabelecido, os riscos associados à interpretação incorreta dos dados, a erros nos arquivos e a variações na interpretação de Gerber são amplamente eliminados. Em resumo, tanto o formato IPC-2581 quanto o Gerber X2 representam uma nova geração de transferência de dados do projeto à fabricação de placas.
Com um arquivo PCB do projeto carregado como documento ativo, é possível gerar um arquivo IPC-2581 selecionando File » Fabrication Outputs » IPC-2581 no menu principal. Isso abre uma caixa de diálogo inicial IPC-2581 Configuration, na qual você pode especificar a revisão do padrão IPC-2581 a ser usada (A ou B), bem como as unidades de medida e a precisão dos números de ponto flutuante aplicadas durante o processo de exportação.

Defina as configurações de exportação na caixa de diálogo IPC-2581 Configuration.
Opções e controles da caixa de diálogo de configuração do IPC-2581
- IPC2581 version - use a lista suspensa para selecionar a versão correta do IPC-2581.
- Measurement System - use a lista suspensa para selecionar as unidades Metric ou Imperial .
- Floating Point Precision - digite o número desejado ou use as teclas de seta para selecionar a precisão de ponto flutuante desejada.
- OEMDesignNumberRef - use a lista suspensa para selecionar o parâmetro do componente a ser usado. DesignItemID é o padrão.
- Merge Net-Tie Nets - quando habilitada, se um projeto contiver redes conectadas por componentes Net-Tie, essas redes serão apresentadas como redes individuais distintas na netlist.
- Distinguish different footprints with the same name - quando habilitada, se um dos footprints com o mesmo nome tiver sido modificado, apenas o footprint modificado será alterado na saída. Quando a opção não estiver habilitada, todos os footprints com o mesmo nome serão exibidos como modificados na saída.
A configuração de precisão determina a exatidão de posição e dimensões dos dados no arquivo gerado em conformidade com o IPC-2581, conforme ilustrado na imagem abaixo.

A mesma seção de um arquivo IPC-2581 com a precisão definida como 2 (à esquerda) e 6 (à direita).
O arquivo IPC-2581 baseado em XML será exportado para o local definido no campo Output Path na guia Opções da caixa de diálogo Opções do projeto. Seu nome seguirá o formato <PCBDocumentName>.cvg.
Geração de dados de fabricação de furação NC
Os arquivos de furação são usados durante o processo de fabricação da placa para fazer furos na PCB. As opções de saída dos arquivos de furação NC são configuradas na caixa de diálogo NC Drill Setup.

A caixa de diálogo NC Drill Setup
A caixa de diálogo NC Drill Setup é acessada de uma das seguintes maneiras:
- Usando um gerador de saída NC Drill em um arquivo de configuração OutputJob (*.OutJob). A saída é gerada quando o gerador de saída configurado é executado.
- Em um documento PCB ativo, clique em File » Fabrication Outputs » NC Drill Files. A saída será gerada imediatamente ao clicar em OK na caixa de diálogo.
Opções e controles da caixa de diálogo NC Drill Setup
-
NC Drill Format – use esta região para especificar as unidades e o formato a serem usados nos arquivos de saída NC Drill.
-
Units
- Inches – habilite esta opção para usar unidades imperiais, nas quais todo o trabalho é feito em mils (1/1000 de polegada).
- Millimeters – habilite esta opção para usar unidades métricas, nas quais todo o trabalho é feito em milímetros.
-
Format
- 2:3/4:2 – fornece uma resolução de 1 mil/0,01 mm.
- 2:4/4:3 – fornece uma resolução de 0,1 mil/1 μm.
- 2:5/4:4 – fornece uma resolução de 0,01 mil/0,1 μm.
-
Units
-
Leading/Trailing Zeroes – a supressão de zeros é uma técnica que reduz o tamanho dos arquivos de dados gerados removendo todos os zeros do início (à esquerda) ou do final (à direita) dos números.
- Keep leading and trailing zeroes – se esta opção estiver habilitada, todos os zeros à esquerda e à direita aparecerão no arquivo NC Drill gerado.
- Suppress leading zeroes – se esta opção estiver habilitada, nenhum zero à esquerda aparecerá no arquivo NC Drill gerado.
- Suppress trailing zeroes – se esta opção estiver habilitada, nenhum zero à direita aparecerá no arquivo NC Drill gerado.
-
Coordinate Positions
- Reference to absolute origin – use a origem absoluta como ponto de referência.
- Reference to relative origin – use a origem relativa como ponto de referência.
-
Other
-
Optimize change location commands – marque esta opção para otimizar os comandos de mudança de localização.
-
Generate separate NC Drill files for plated & non-plated holes – marque esta opção para criar arquivos de furação separados para furos metalizados e não metalizados.
-
Generate separate NC Drill files for VIA features – marque esta opção para criar arquivos de furação separados para cada tipo de via IPC 4761.
-
Use drilled slot command (G85) – marque esta opção para usar vários furos para criar rasgos.
-
Generate Board Edge Rout Paths – marque esta opção para criar um arquivo NC Rout separado para definir o formato da placa, incluindo seus recortes.
-
Rout Tool Dia – especifique o tamanho da ferramenta usada para fresar o contorno da placa. Esta opção só está disponível quando Generate Board Edge Rout Paths está habilitada.
-
-
Generate EIA Binary Drill File (.DRL) – use esta opção para gerar um arquivo .DRL. DRL é um arquivo de furação em formato binário. Para uma PCB multicamadas que incorpore vias cegas e/ou enterradas, é criado um arquivo de furação separado para cada par de camadas, com uma extensão de arquivo exclusiva.
-
-
Generate Additional Tools by Drill Symbols - habilite esta opção para gerar ferramentas de furação adicionais com base nos agrupamentos de símbolos de furação definidos. Dados de colunas adicionais serão incluídos quando existirem no agrupamento de símbolos de furação. As colunas de dados existentes não serão removidas dos dados de furação gerados.
Arquivos NC Drill gerados
| Filename | Description |
| FileName.DRL | Arquivo de furação em formato binário. Para uma PCB multicamadas que incorpore vias cegas e/ou enterradas, é criado um arquivo de furação separado para cada par de camadas, com uma extensão de arquivo exclusiva. |
| FileName.DRR | Relatório de furação – detalha as atribuições de ferramentas, os tamanhos dos furos, a quantidade de furos e o percurso das ferramentas. |
| FileName.TXT | Arquivo de furação em formato ASCII. Para uma PCB multicamadas que incorpore vias cegas e/ou enterradas, é criado um arquivo de furação separado para cada par de camadas, com uma extensão de arquivo exclusiva. |
| FileName-Plated.TXT | Arquivo de furação em formato ASCII. Específico para furos metalizados em um projeto de PCB. Será criado um arquivo separado para cada tipo de furo – oblongo, quadrado ou redondo. |
| FileName-NonPlated.TXT | Arquivo de furação em formato ASCII. Específico para furos não metalizados em um projeto de PCB. Será criado um arquivo separado para cada tipo de furo – oblongo, quadrado ou redondo. |
| FileName-BoardEdgeRout.TXT | Arquivo de fresagem em formato ASCII. Específico para o contorno da placa, incluindo seus recortes. |
| FileName.LDP | Relatório de pares de camadas para furação em formato ASCII. Usado pelo Editor CAM para detectar vias cegas e enterradas. |
Após ser gerada, a saída será adicionada ao projeto e aparecerá no painel Projects, na pasta Generated, em uma subpasta com nome apropriado. Se você tiver usado uma pasta separada para cada tipo de saída, as pastas Generated correspondentes (separadas) serão adicionadas ao painel Projects (por exemplo, Generated (NC Drill Output)).
Localização dos arquivos NC Drill gerados
O caminho de saída dos arquivos gerados depende de como a saída foi gerada:
- A partir de um arquivo OutputJob – os arquivos gerados são armazenados em uma pasta dentro da pasta do projeto. A nomenclatura e a estrutura de pastas são definidas no Output Container ao qual a saída NC Drill File se destina.
- Diretamente da PCB – o caminho de saída é especificado na caixa de diálogo Project Options – Options. Por padrão, o caminho de saída é definido como uma subpasta da pasta que contém o arquivo do projeto, com o nome Project Outputs for <ProjectName>. O caminho de saída pode ser alterado conforme necessário. Se a opção de usar uma pasta separada para cada tipo de saída tiver sido habilitada na guia Options, os arquivos NC Drill serão gravados em uma subpasta adicional chamada NC Drill Output.
Abertura automática da saída NC Drill gerada
Ao gerar saídas NC Drill, você pode especificar que a saída seja aberta automaticamente em um novo documento CAM. A maneira de fazer isso depende de como você está gerando a saída:
- A partir de um arquivo OutputJob – habilite a opção de carregamento automático NC Drill Output na caixa de diálogo Output Job Options (Tools » Output Job Options a partir de OutputJob Editor).
- Diretamente da PCB – certifique-se de que a opção Open outputs after compile esteja habilitada na aba Options da caixa de diálogo Project Options (Project » Project Options).
Geração do relatório de empilhamento da placa
O Altium Designer permite gerar um Board Stack Report em formato Excel (<PCBDocumentName>.xls), resumindo os empilhamentos de camadas definidos e as camadas usadas no empilhamento (em termos de nome da camada, material, espessura e constante dielétrica). A altura de cada empilhamento também é resumida. As opções de saída do relatório de empilhamento da placa são configuradas na caixa de diálogo Layer Stack Report Setup, na qual você pode especificar a unidade de medida e as colunas que deseja exibir no relatório.

A caixa de diálogo Layer Stack Report Setup
Geração de dados de fabricação para impressão
As seguintes saídas são destinadas à impressão, com configurações predefinidas para as páginas e as camadas nelas contidas:
- Composite Drill Guide - produz um desenho composto de furação predefinido para o documento PCB de origem.
- Drill Drawings - produz um conjunto predefinido de desenhos e guias de furação para o documento PCB de origem.
- Final - produz um conjunto completo e predefinido de impressões da arte final para o documento PCB de origem.
- Mask Set - produz desenhos predefinidos das máscaras de solda/pasta para o documento PCB de origem.
- Power-Plane Set - produz desenhos predefinidos dos planos de alimentação para o documento PCB de origem.
Acesse a caixa de diálogo Print para examinar e ajustar a configuração da saída.
Consulte a página Configuração de impressões de PCB para saber mais.
Geração do relatório de pontos de teste de fabricação
O gerador de relatórios de pontos de teste de fabricação produz um relatório (nos formatos txt e/ou csv e/ou IPC-D-356A) de todos os pads e vias configurados para uso como pontos de teste de fabricação.
Consulte a página Atribuição de pontos de teste na placa para saber mais sobre a atribuição de pontos de teste em um projeto de PCB.
As opções de saída do relatório de pontos de teste de fabricação são configuradas na caixa de diálogo Fabrication Testpoint Setup.

A caixa de diálogo Fabrication Testpoint Setup
Opções e controles da caixa de diálogo de configuração de pontos de teste
Formatos de relatório
- Text - habilite para usar o formato de texto padrão no relatório.
- CSV - habilite para usar o formato padrão de valores separados por vírgulas, que pode ser importado para um aplicativo de planilhas, como o Excel, para processamento adicional.
- IPC-D-356A - habilite para gerar um arquivo de netlist IPC que contém informações sobre vias cegas e enterradas, além de diferenciar vias passantes de pads livres. Quando importado para um documento CAM junto com dados de imagem e furação, ele facilita a recuperação dos nomes originais das nets usadas no projeto de PCB, tornando a PCB mais fácil de entender e gerenciar no Editor CAM.
Camadas de pontos de teste
Estas seleções permitem especificar o escopo do relatório:
- Top layer - marque para incluir pontos de teste válidos atribuídos à face superior da placa.
- Bottom layer - marque para incluir pontos de teste válidos atribuídos à face inferior da placa.
Unidades
- Imperial- marque para gerar as coordenadas em polegadas.
- Metric - marque para gerar as coordenadas em milímetros.
Posições das coordenadas
- Reference to absolute origin - selecione para usar a origem absoluta como ponto de referência para as coordenadas dos pontos de teste.
- Reference to relative origin - selecione para usar a origem relativa como ponto de referência para as coordenadas dos pontos de teste.
Opções de IPC-D-356A
- Adjacency Information - marque para incluir uma lista de nets que possivelmente estejam em curto-circuito e, em seguida, insira os critérios de adjacência na caixa de texto.
- Board Outline - marque para permitir a descrição de contornos e outros dados do tipo segmento que não estejam conectados a uma net específica e, em seguida, use a lista suspensa para selecionar os dados desejados.
- Conductor Traces - Consulte a especificação IPC-D-356A para obter mais detalhes.
- Merge Net-Tie Nets - quando habilitada, se um projeto contiver nets conectadas por componentes Net-Tie, essas nets serão apresentadas como nets individuais distintas na netlist.
Arquivos de relatório de fabricação gerados
Todos os arquivos de pontos de teste gerados são nomeados primeiro pelo tipo (Fabricação ou Montagem) e, em seguida, pelo nome do arquivo. Por exemplo: Fabrication Testpoint Report for BoardFileName. As seguintes extensões de arquivo são usadas, dependendo de qual das opções de Report Formats está habilitada: .txt, .CSV, .IPC (observe que este é um arquivo ASCII).
Local dos arquivos de relatório de fabricação gerados
O caminho de saída dos arquivos gerados depende de como a saída foi gerada:
- A partir de um arquivo OutputJob - os arquivos gerados são armazenados em uma pasta dentro da pasta do projeto. A nomenclatura e a estrutura de pastas são definidas no Output Container ao qual a saída de pontos de teste se destina.
-
Diretamente da PCB - o caminho de saída é especificado na caixa de diálogo Opções do projeto - Opções. Por padrão, o caminho de saída é definido como uma subpasta da pasta que contém o arquivo do projeto, com o nome:
Project Outputs for ProjectName. O caminho de saída pode ser alterado conforme necessário. Se a opção de usar uma pasta separada para cada tipo de saída estiver habilitada na aba Options, os arquivos de pontos de teste serão gravados em uma subpasta adicional chamadaTestpoint Output.
Abertura automática da saída do relatório de fabricação gerado
Ao gerar a saída de pontos de teste, você pode especificar que ela seja aberta automaticamente em um novo documento CAM. A maneira de fazer isso depende de como você está gerando a saída:
- A partir de um arquivo OutputJob - habilite a opção de carregamento automático IPC-D-356A Output na caixa de diálogo Output Job Options (Tools » Output Job Options no Editor OutputJob).
- Diretamente da PCB - certifique-se de que a opção Open outputs after compile esteja habilitada na aba Options da caixa de diálogo Project Options (Project » Project Options).
Saída de arquivos de fabricação por meio de um arquivo Output Job
Para incluir a saída de arquivos de fabricação no arquivo de configuração de tarefas de saída de um projeto, clique em [Add New Fabrication Output] na seção Fabrication Outputs e selecione um tipo de saída no menu e a fonte de dados desejada no submenu correspondente.

Configure as saídas de fabricação como parte do Fabrication Outputs de um arquivo de tarefas de saída. Aqui é mostrado um exemplo de arquivos Gerber X2.
Quando o OutJob for executado — manualmente ou como parte do processo de liberação do projeto —, as saídas de fabricação serão geradas de acordo com as configurações definidas para o contêiner de saída aplicável.

Preparação das saídas de fabricação como parte de um OutJob configurado.




).
).
).
).