Trabalhando com Camadas Mecânicas
Altium Essentials: PCB Configuration
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
Num relance
- Saiba quando usar uma única camada mecânica ou um par de camadas de componentes, especialmente para informações que se aplicam a um lado ou a ambos os lados da placa.
- Veja como adicionar, configurar e gerenciar camadas mecânicas no painel Configuração de visualização, incluindo nomes, números, visibilidade e tipos de camada.
- Entenda como os tipos de camada predefinidos e as configurações das bibliotecas de PCB afetam a criação e o mapeamento automáticos de camadas no projeto da sua placa.
Mesmo a placa mais simples precisa de detalhes de projeto além das trilhas e dos pads que implementam o circuito. Podem ser as dimensões da placa ou os detalhes de fabricação, as áreas de contorno dos componentes ou os modelos 3D dos componentes. No Altium Designer, esse tipo de informação adicional é detalhado nas camadas mecânicas.
Camadas mecânicas e pares de camadas de componentes
Se as informações incluídas em uma camada mecânica não estiverem relacionadas a um lado específico da placa, por exemplo, notas de fabricação que detalham a ordem das camadas, será adicionado um individual mechanical layer.
Se as informações forem necessárias em ambos os lados da placa, por exemplo, as áreas de contorno dos componentes, serão atribuídas duas camadas mecânicas: uma camada contendo os detalhes da área de contorno quando o componente é colocado no lado superior da placa; e a outra camada mecânica contendo a imagem espelhada desses mesmos detalhes quando o componente é virado para o lado inferior da placa. Nessa situação, um par de camadas mecânicas é adicionado como um Component Layer Pair. Quando as camadas mecânicas são adicionadas como um par de camadas de componentes, elas são exibidas na seção Component Layer Pairs do painel View Configuration, conforme mostrado abaixo. Abaixo dessa seção estão as Mechanical Layers individuais.

Foram adicionados vários pares de camadas de componentes definidos pelo usuário.
| Display of Layer Pairs | No espaço de projeto, as duas camadas de um par de camadas de componentes são exibidas em abas de camada separadas, usando os nomes Top <LayerPairName> e Bottom <LayerPairName> |
| In the Library editor | No editor de bibliotecas de PCB, os objetos de projeto adicionais necessários no footprint de um componente são colocados na camada superior do par de camadas de componentes. Quando o componente é virado para o lado inferior da placa durante o layout da PCB (atalho L enquanto o componente está sendo movido), o conteúdo da camada superior do par é automaticamente espelhado na camada inferior do par. |
| Automatic layer creation | Se uma camada mecânica ou um par de camadas de componentes definido na biblioteca de PCB tiver um tipo de camada atribuído, essa camada mecânica ou esse par de camadas será criado automaticamente na PCB quando um componente que utiliza essas camadas for colocado. Se a PCB já tiver uma camada mecânica ou um par de camadas desse tipo, o conteúdo dessas camadas será mapeado de acordo. |
| Layers without a Layer Type |
Para camadas mecânicas ou pares de camadas definidos na biblioteca de PCB que não tenham um tipo de camada atribuído na biblioteca, serão criadas camadas mecânicas individuais na PCB. Nessa situação, defina previamente a camada mecânica ou o par de camadas na PCB usando os mesmos números de camada antes de colocar o componente, pois o software recorrerá à correspondência pelo número da camada se não conseguir encontrar uma correspondência pelo tipo de camada. |
Como adicionar camadas mecânicas ao projeto
As camadas mecânicas são adicionadas, editadas e removidas no painel Configuração de visualização, conforme mostrado abaixo. Sua visibilidade e cor também são configuradas no painel. Use o botão
no canto inferior direito do espaço de projeto e selecione View Configuration, ou pressione a tecla de atalho L para exibir o painel.
Clique com o botão direito em qualquer lugar da região Layers do painel para exibir o menu de contexto, que oferece comandos para Add Component Layer Pair (um par de camadas mecânicas) e Add Mechanical Layer (uma camada mecânica individual).
Camadas mecânicas individuais ou pares de camadas mecânicas são adicionados pelo menu acessado com o botão direito no painel View Configuration.
Como adicionar uma camada mecânica individual
Ao selecionar o comando Add Mechanical Layer no menu de contexto acessado com o botão direito no painel View Configuration para adicionar uma camada mecânica individual, a caixa de diálogo Edit Layer é aberta.
Configure a nova camada mecânica.
Caixa de diálogo Editar camada |
|
| Layer Name | Pode ser um nome de camada definido pelo usuário ou atribuído pelo sistema, caso um tipo predefinido seja escolhido na lista suspensa Layer Type. Se um tipo de camada predefinido for selecionado e, em seguida, um nome definido pelo usuário for inserido nesse campo, o tipo de camada atribuído aparecerá entre parênteses ao lado do nome definido pelo usuário no painel View Configuration. |
| Layer Number | O número da camada mecânica que está sendo configurada; o próximo número de camada disponível é sugerido. Se outro número for selecionado e já estiver em uso, um ícone de aviso aparecerá Será necessário atribuir um número de camada não utilizado para continuar. |
| Layer Type | O tipo de camada pode ficar sem atribuição (N/A), ou você pode selecionar um tipo na lista. Os tipos de camada disponíveis são descritos abaixo. |
Tipos de camadas mecânicas disponíveis
| Assembly Notes | Frequentemente usado para detalhar a ordem de colocação dos componentes e/ou instruções importantes de montagem. |
| Board | Use esta camada para instruções ou detalhes relacionados à placa. |
| Board Shape | Use esta camada para o contorno geral da placa (formato da placa). |
| Dimensions | Usado para definir os detalhes dimensionais necessários para a placa. |
| Fab Notes | Usado para detalhar notas importantes de fabricação. |
| Route Tool Path | Usado para indicar a camada que contém as informações de usinagem mecânica. Observe que não é permitido usar um nome definido pelo usuário com esse tipo de camada |
| Sheet | Use esta camada para definir a borda externa do modelo de desenho do documento. Consulte os detalhes na seção Representação e configurações da folha abaixo. |
| V Cut | Usado para definir os detalhes dos cortes em V. Os cortes em V são usados para separar placas de circuito, cortando uma ranhura em "V" nas faces superior e inferior da placa e deixando uma quantidade mínima de material para manter as placas do painel unidas. |
Adição de um par de camadas de componentes
Ao selecionar o comando Add Component Layer Pair no menu de contexto do painel View Configuration, acessado com o botão direito do mouse, a caixa de diálogo Edit Layers Pair é aberta.
Caixa de diálogo Editar par de camadas |
|
| Layer Name | Pode ser um nome de camada definido pelo usuário ou atribuído pelo sistema, caso um tipo predefinido seja escolhido na lista suspensa Layer Type. Se um tipo de camada predefinido for selecionado e, em seguida, um nome definido pelo usuário for inserido neste campo, o tipo de camada atribuído aparecerá entre parênteses ao lado do nome definido pelo usuário no painel View Configuration. |
| Layer Number | Os números das camadas mecânicas que estão sendo configuradas; são oferecidos os próximos números de camada disponíveis. Se outro número for selecionado e já estiver em uso, um ícone de aviso aparecerá Será necessário atribuir um número de camada não utilizado para continuar. |
| Layer Type | O tipo de camada pode permanecer sem atribuição (N/A), ou você pode selecionar um tipo na lista. Os tipos de camada disponíveis são descritos abaixo. |
Tipos de pares de camadas de componentes disponíveis
| Assembly | Usado para desenhar/detalhar os dados de montagem do componente. Esta camada pode ser incluída em uma vista de montagem da placa no Draftsman e, em seguida, selecionada como Geometry Source para os componentes na caixa de diálogo Component Display Properties do Draftsman. Saiba mais sobre o Draftsman. |
| Coating | Usado para definir áreas do componente que exigem um revestimento protetor. |
| Component Center | Usado para indicar o centroide do componente, fornecendo, na documentação de montagem, uma referência visual da posição usada pela máquina de posicionamento de componentes. |
| Component Outline | Usado para definir o contorno do corpo do componente, representando a área que ele ocupa na placa. |
| Courtyard | Usado para definir o espaço de posicionamento necessário para um componente. Normalmente, o Courtyard delimita o componente e os pads, com uma margem de folga adequada o contorno verde é o Courtyard). Saiba mais sobre a criação de footprints personalizados. A forma definida na camada Courtyard também é usada para a seleção de componentes, para definir a área do componente e para a detecção de colisões quando o componente não inclui um corpo 3D. |
| Designator | Use esta camada para posicionar a string especial .Designator. Esse par de camadas pode então ser incluído em desenhos de montagem que exigem a exibição do designador do componente. Saiba mais sobre strings especiais. |
| Dimensions | Usado para definir os detalhes dimensionais necessários para os componentes. |
| Glue Points | Usado para definir os pontos de cola dos componentes. |
| Gold Plating | Usado para definir os requisitos de douração seletiva dos componentes. |
| Value | Use esta camada para posicionar a string especial .Comment. Esse par de camadas pode então ser incluído em desenhos de montagem que exigem a exibição do valor do componente. Saiba mais sobre strings especiais. |
| 3D Body | Use esta camada para o modelo mecânico 3D do componente. Saiba mais sobre o posicionamento de corpos 3D. |
| Die | Use esta camada para os pads e corpos 3D do die ao criar um componente Chip-on-Board. Saiba mais sobre ligação por fios. |
| Wire Bonding | Use esta camada para os fios de ligação ao criar um componente Chip-on-Board ou diretamente em um documento PCB. Saiba mais sobre ligação por fios. |
A vantagem de atribuir um tipo de camada
Uma abordagem comum para gerenciar o uso de camadas mecânicas é atribuir um número de camada exclusivo para cada função de camada mecânica necessária. Essa abordagem exige que todos os projetistas sigam o mesmo esquema de atribuição e numeração de camadas. Ela também pode gerar dificuldades quando os componentes são obtidos de outras fontes que não seguem o mesmo esquema de atribuição e numeração. Se um esquema diferente tiver sido usado, os objetos do projeto deverão ser movidos de sua camada mecânica atual para a camada mecânica atribuída àquela função.
Esse problema é resolvido atribuindo uma propriedade Layer Type. Quando um componente é inserido de uma biblioteca no editor de PCB, copiado de uma biblioteca para outra ou criado pelo IPC Footprint Wizard, as atribuições existentes de tipo de camada são automaticamente correspondidas, independentemente dos números de camada mecânica atribuídos a esses tipos de camada. Os objetos são realocados para as camadas corretas de acordo com seu tipo de camada. Se o software não conseguir fazer a correspondência pelo tipo de camada, ele recorrerá à correspondência pelo número da camada.
Tanto para camadas mecânicas individuais quanto para pares de camadas de componentes, você pode selecionar um tipo de camada em uma lista de tipos predefinidos. As imagens abaixo mostram a lista de tipos de camada disponíveis. Você pode acessar as caixas de diálogo mostradas abaixo clicando com o botão direito do mouse em uma camada individual e selecionando o comando Edit Layer ou Add Component Layer no menu.

Selecione o tipo de camada na lista de tipos predefinidos; as camadas mecânicas individuais são mostradas à esquerda e os pares de camadas de componentes, à direita.
Nomeação de camadas com um tipo de camada atribuído
Quando um tipo de camada é atribuído, a propriedade Nome da camada é automaticamente alterada para corresponder ao tipo de camada. Isso pode ser substituído, se necessário, digitando um nome definido pelo usuário. Quando uma camada tem um nome definido pelo usuário e um tipo de camada atribuído, ambos são exibidos, com o tipo de camada entre parênteses, como mostrado abaixo para o par de camadas GP (Gold Plating).
O tipo de camada é usado para nomear a camada; isso pode ser substituído, se necessário.
O tipo de camada Caminho da ferramenta de fresagem
Há uma exceção ao comportamento de nomeação descrito acima quando um tipo de camada é atribuído: um nome definido pelo usuário não é permitido quando Layer Type está definido como Route Tool Path. Isso ocorre porque as versões anteriores do software usam o nome da camada Caminho da ferramenta de fresagem para identificar a camada que contém as informações de fresagem (também chamadas de informações de rout). Fixar o nome dessa camada garante que o projeto continue funcionando corretamente em uma versão anterior.
O tipo de camada Caminho da ferramenta de fresagem é usado para indicar a camada que contém as informações de fresagem mecânica. Uma abordagem típica para usar essa camada é posicionar trilhas e arcos ao redor da borda externa do contorno da placa para definir o caminho e a largura de usinagem. Seções sólidas são deixadas para manter a placa presa ao painel; em seguida, uma série de pequenos furos é posicionada ao longo de cada seção sólida para criar perfurações (frequentemente chamadas de mouse-bites), permitindo que a placa seja destacada do painel após a conclusão do processo de montagem.
Quando a placa é exibida no modo 3D, os objetos detectados na camada de trajetória da ferramenta de fresagem são exibidos como um rasgo fresado na placa, conforme mostrado abaixo.

Os objetos detectados na camada de trajetória da ferramenta de fresagem são usados para visualizar a placa fresada no modo de exibição 3D.
Use a caixa de diálogo Primitivas de linha/arco a partir do contorno da placa para traçar o exterior do contorno da placa com trilhas e arcos (mostrado abaixo). Habilite a opção Route Tool Outline na caixa de diálogo para que os objetos sejam posicionados fora do contorno da placa em vez de ficarem centralizados ao longo de sua borda. Alguns projetistas preferem adicionar as informações de fabricação ao usar o recurso de matriz de placas incorporada para criar um painel de montagem, em vez de incluir esses detalhes no arquivo da placa.
Saiba mais sobre Panelização de placas usando uma matriz de placas incorporada
Definição do tipo de camada no editor de bibliotecas PCB
Se uma camada mecânica ou um par de camadas de componente definido na biblioteca PCB tiver um tipo de camada atribuído, essa camada mecânica ou esse par de camadas será criado automaticamente na PCB quando um componente que utiliza essas camadas for posicionado. Se a PCB já tiver uma camada mecânica ou um par de camadas desse tipo, o conteúdo dessas camadas será mapeado adequadamente.
Sempre que possível, recomenda-se editar a biblioteca de origem e atribuir tipos de camada. Quando um footprint de componente é inserido (ou copiado) de uma biblioteca, as camadas mecânicas e os pares de camadas de componente desses tipos são criados automaticamente na placa (ou biblioteca) de destino, caso ainda não existam. Se esses tipos de camada já existirem na placa (ou biblioteca) de destino, o conteúdo das camadas será mapeado automaticamente para a camada correta.
Saiba mais sobre Como lidar com requisitos especiais específicos de camada no editor de bibliotecas PCB
Trabalhando com camadas mecânicas
As camadas mecânicas são adicionadas, editadas, excluídas e exibidas por meio do painel View Configuration no editor de PCB. Elas não são exibidas nem editadas no Layer Stack Manager.
Exibição
Configure a visibilidade das camadas no painel View Configuration e salve grupos de camadas usados com frequência como um conjunto de camadas definido pelo usuário.
| Controlling layer visibility | Clique no ícone de visibilidade ao lado do nome da camada para ativar ou desativar a exibição dessa camada mecânica. Como alternativa, clique para selecionar o nome da camada e pressione Spacebar (isso alterna a exibição de ambas as camadas de um par de camadas de componente). |
| Include in Single Layer Mode | As camadas mecânicas têm um recurso adicional de exibição: elas podem ser configuradas para permanecer visíveis quando a exibição estiver no modo de camada única. Mantenha |
| Include in 3D View Mode | As camadas mecânicas também podem ser incluídas na exibição 3D quando as configurações 3D habilitam a opção Colors - By Layer. Habilite a opção na guia View Options do painel View Configuration quando a placa estiver sendo exibida no modo de visualização 3D. As camadas mecânicas atualmente configuradas como visíveis serão incluídas |
Edição e exclusão
Para editar as configurações de um par de camadas de componente ou de uma camada mecânica existente, clique duas vezes diretamente em sua entrada no painel View Configuration (ou clique com o botão direito na entrada desejada e escolha Edit Layer no menu de contexto). Faça as alterações necessárias na caixa de diálogo Edit Layers Pair / Edit Layer. A visibilidade e a cor das camadas mecânicas são configuradas diretamente no painel View Configuration.
Para excluir uma camada, clique com o botão direito na camada desejada e selecione Delete Layer. Dependendo de como a camada está sendo usada, haverá três resultados possíveis:
| Nothing on the layer | Se não houver primitivas posicionadas na camada, ela será excluída imediatamente ao selecionar Delete Layer (sem confirmação). |
| Contains unlocked primitives | Se houver primitivas desbloqueadas na camada, será exibida uma janela solicitando a confirmação da exclusão. |
| Contains locked primitives | Se houver primitivas bloqueadas na camada, por exemplo, primitivas que pertencem a um componente, será exibida uma janela de erro informando que a ação não pode ser concluída. |
Exportação e importação
A estrutura de camadas mecânicas e pares de camadas de componente adicionados a uma PCB pode ser duplicada em outra PCB exportando esse conjunto para um arquivo a partir do documento PCB de origem e, em seguida, importando o arquivo para o documento PCB de destino.
Exportar / importar as camadas
-
No documento PCB de origem em que a estrutura necessária de camadas mecânicas e pares de camadas de componente foi adicionada, use o comando Tools » Export Mechanical Layers nos menus principais. Use a caixa de diálogo Export Mechanical Layers que será aberta para definir o nome e o diretório do arquivo
*.stackupque conterá os dados sobre a estrutura de camadas mecânicas. -
No documento PCB de destino, use o comando Tools » Import Mechanical Layers nos menus principais e use a caixa de diálogo Import Mechanical Layers que será aberta para selecionar o arquivo
*.stackupsalvo. A estrutura de camadas mecânicas e pares de camadas de componente adicionada pode ser vista no painel View Configuration.
Copiar / colar o conteúdo das camadas
Observe que os comandos de importação/exportação transferem a estrutura de camadas mecânicas e pares de camadas de componente, mas não transferem o conteúdo dessas camadas.
Para copiar o conteúdo de:
-
Uma única camada mecânica, use o comando Edit » Select » All on Layer quando a camada desejada for a camada ativa na PCB de origem e, em seguida, use o processo padrão de copiar/colar para replicar esses dados na PCB de destino.
-
Várias camadas mecânicas: configure a visibilidade das camadas no painel View Configuration para exibir apenas as camadas mecânicas necessárias e, em seguida, arraste um retângulo de seleção por contato (da direita para a esquerda) ao redor de todas as primitivas necessárias na PCB de origem. Depois, use o processo padrão de copiar/colar para replicar esses dados na PCB de destino.
Configurações de apresentação e saída
As camadas mecânicas costumam ser usadas para detalhar informações que precisam ser incluídas em impressões ou nas saídas de fabricação geradas. Isso pode incluir modelos de desenho, instruções de fabricação, instruções de montagem e assim por diante. Se necessário, isso pode ser feito diretamente no editor de PCB.
As informações da documentação de produção da placa podem ser incluídas nas camadas mecânicas, se necessário.
Como alternativa, essas tarefas de documentação podem ser realizadas no Draftsman, um ambiente avançado e flexível de edição gráfica para criar documentos de produção de projetos de placas. Com um conjunto dedicado de ferramentas de desenho, o sistema de desenho do Draftsman oferece uma abordagem interativa para reunir desenhos de fabricação e montagem com modelos personalizados, anotações, cotas, chamadas e notas.
Saiba mais sobre o Draftsman
Apresentação e configurações da folha
A imagem acima mostra um fundo branco que se ajusta exatamente aos objetos de desenho posicionados para representar o modelo da folha. Ele é criado adicionando uma camada mecânica com o Layer Type definido como Sheet, que é então usada para definir a borda externa do modelo de desenho do documento.
O tamanho desse fundo branco é definido pelo Sheet Settings, que pode ser personalizado no painel Properties quando não há nada selecionado na área de edição. Os valores de X/Y do canto inferior esquerdo da folha, bem como Width e Height, podem ser configurados manualmente. Como alternativa, quando a opção Get Size From Sheet Layer está habilitada, o fundo da folha é calculado automaticamente a partir do retângulo delimitador do conjunto de objetos posicionados na camada mecânica do tipo Sheet.
O fundo da folha pode ser dimensionado automaticamente a partir dos objetos posicionados na camada do tipo Folha.
A cor e a visibilidade do fundo da folha são configuradas na seção System Colors do painel View Configuration. Clique no botão de cor para alterar a cor de Sheet Line e Area Color. Alterne entre
/
para mostrar/ocultar a folha.
Inclusão de camadas mecânicas nas saídas
As camadas mecânicas são usadas para uma ampla variedade de tarefas, detalhando informações utilizadas durante o projeto, a fabricação e a montagem da placa, bem como na documentação do produto. Para atender a todos esses requisitos, as camadas mecânicas podem ser excluídas ou incluídas em todas as formas de geração de saídas baseadas em camadas, incluindo impressão e geração de arquivos de saída.
Saída impressa
Qualquer uma das camadas presentes no projeto pode ser incluída na especificação de uma impressão de PCB, incluindo as camadas mecânicas. As impressões são configuradas adicionando as camadas necessárias e definindo sua ordem na caixa de diálogo Print.

Desenhos de fabricação e montagem altamente detalhados podem ser criados posicionando objetos nas camadas mecânicas.
Saiba mais sobre Preparação de saídas de PCB 2D para impressão
Saídas geradas
Todas as saídas de fabricação, como Gerber e ODB++, permitem incluir camadas mecânicas como um Layer to Plot de saída, ou adicioná-las como detalhes a cada camada que está sendo plotada. A saída é gerada quando o gerador de saída configurado é executado, por exemplo, ao usar um gerador de saída ODB em um arquivo de configuração OutputJob (*.OutJob).

As camadas mecânicas podem ser plotadas ou adicionadas a todas as plotagens, se necessário.
Saiba mais sobre Preparação do seu projeto para fabricação
).
).



).