Atribuição de pontos de teste na placa

Num relance

Este artigo explica por que os pontos de teste são importantes na fabricação de PCBs e como o Altium Designer ajuda você a defini-los tanto para testes de fabricação de placas nuas quanto para testes de placas montadas. Ele apresenta as diferenças práticas entre as estratégias de teste de fabricação e de montagem, as restrições de posicionamento que influenciam onde os pontos de teste devem ficar e como designar pads e vias como pontos de teste, manualmente ou com o Testpoint Manager. Se você deseja criar uma placa mais fácil de testar e entender melhor como o Altium Designer apoia esse processo, este artigo oferece uma base clara. Continue lendo para tornar seu planejamento de pontos de teste mais eficaz.

- Entenda a diferença entre os testes de fabricação e de montagem e como cada um afeta o posicionamento dos pontos de teste.
- Conheça as principais considerações e restrições que orientam uma boa estratégia de pontos de teste, incluindo acesso aos lados da placa, espaçamentos, requisitos de grade e acessibilidade das pontas de prova.
- Veja como o Altium Designer permite a definição manual e automatizada de pontos de teste usando os recursos de pads, vias e do Testpoint Manager.
Aprofunde-se com a IA:

Os testes são uma parte importante do processo de fabricação de placas. Após a fabricação, a placa normalmente é testada para garantir que não haja curtos-circuitos nem circuitos abertos. Depois de montada com todos os seus componentes, a placa costuma ser testada novamente para verificar a integridade dos sinais e o funcionamento dos dispositivos. Para auxiliar nesse processo, é fundamental contar com um conjunto de pontos na placa - Testpoints - que os equipamentos de teste possam acessar com suas pontas de prova para realizar os testes necessários.

A localização dos pontos de teste em uma placa dependerá de fatores como a modalidade de teste (incluindo testes de fabricação da placa nua, testes em circuito da placa montada etc.) e o método de teste (incluindo testes automatizados com pontas de prova móveis e dispositivos de teste do tipo cama de pregos, testes manuais etc.). Por exemplo, ao realizar testes de fabricação da placa nua, a placa ainda não tem componentes montados e, portanto, todos os pads e vias estão disponíveis para a atribuição de pontos de teste. No entanto, os locais usados como pontos de teste nos testes em circuito da placa montada quase sempre serão diferentes. Com os componentes montados, talvez as pontas de prova já não consigam acessar os pads dos componentes, e certamente não terão acesso aos pads e vias sob um componente!

O Altium Designer oferece um sistema poderoso para atender às suas necessidades de pontos de teste e melhorar a testabilidade das suas placas, permitindo atribuir separadamente pontos de teste para testes de fabricação da placa nua e/ou testes em circuito da placa montada, conforme necessário. Os pontos de teste podem ser atribuídos manualmente ou de forma mais ágil e automatizada, usando a caixa de diálogo Gerenciador de pontos de teste.

Planejando sua estratégia de pontos de teste

Antes de começar a atribuir pads e vias como locais de pontos de teste, é uma boa ideia dar um passo atrás e pensar no que é necessário. A seguir, apresentamos algumas orientações a considerar ao definir uma estratégia para incorporar pontos de teste a um projeto:

  • Ao escolher o lado da placa em que os pontos de teste serão permitidos, considere os processos de teste e os dispositivos associados que serão utilizados. Por exemplo, a placa será acessada pelas pontas de prova apenas pelo lado inferior, apenas pelo lado superior ou por ambos os lados?
  • Um ponto de teste sob um componente (no mesmo lado da placa que o componente) geralmente é usado na etapa de teste da placa nua. Isso deve ser levado em consideração ao planejar os locais dos pontos de teste para os testes da placa montada.
  • É aconselhável posicionar todos os pontos de teste em apenas um lado da placa, usando vias para isso, se necessário. O motivo é que um dispositivo de teste de cabeçote duplo tem um custo maior do que um dispositivo de teste de cabeçote único.
  • Quanto mais fora do padrão e complexo for o arranjo dos pontos de teste, maior será o custo para configurar um dispositivo de teste para a placa. A melhor abordagem é desenvolver uma metodologia que proporcione uma testabilidade abrangente. Uma política de pontos de teste bem definida e adaptável permitirá testar diferentes projetos de forma eficiente e econômica.
  • Os requisitos do projeto para a cobertura de vias com máscara de solda devem ser cuidadosamente considerados. Cobrir uma via designada como ponto de teste impedirá o contato da ponta de prova. Mesmo uma cobertura parcial com máscara de solda líquida fotoimageável (LPI) causará problemas de contato, pois a máscara líquida tenderá a escoar pelo furo da via. Uma máscara de solda removível pode ser usada para cobrir temporariamente essas vias, mas essa solução muitas vezes pode ter um custo bastante elevado.
  • Consulte os fabricantes e montadores das suas placas para garantir que todos os parâmetros específicos do projeto sejam considerados ao especificar os pontos de teste. Esses parâmetros podem incluir espaçamentos entre pontos de teste e entre pontos de teste e componentes que sejam mais rigorosos do que os espaçamentos normais de posicionamento e roteamento.

As seções a seguir examinam mais detalhadamente os testes de fabricação e de montagem, incluindo as restrições específicas dos pontos de teste e as considerações associadas a cada um.

Testes de fabricação

Os testes de fabricação correspondem aos testes de uma placa de circuito impresso na fase de pré-montagem da fabricação, antes que qualquer componente seja colocado na placa. Por isso, costumam ser chamados de testes de placa nua. Esse método de teste normalmente pode envolver o uso de um equipamento com pontas de prova móveis para testar cada rede individualmente. Essencialmente, duas pontas de prova são programadas para operar em conjunto: uma para enviar um pulso de sinal por uma rede e a outra para detectar a presença (ou ausência) desse sinal.

Dois cenários comuns de teste na fabricação de placas nuas são:

  1. Testar para garantir que o cobre projetado para ser contínuo de ponta a ponta conduza um sinal limpo (abaixo de um limite máximo de impedância permitido), sem circuitos abertos.
  2. Testar para garantir que não haja curtos-circuitos entre as redes.

Testes de montagem

Os testes de montagem correspondem aos testes de uma placa de circuito impresso na fase de pós-montagem da fabricação, depois que todos os componentes especificados na lista de materiais (BOM) associada foram montados na placa. Por isso, costumam ser chamados de testes em circuito ou testes elétricos. Esse método de teste normalmente envolve (mas de forma alguma se limita a isso!) o uso de um dispositivo de teste do tipo cama de pregos configurado manualmente. Dependendo do tipo de teste realizado com o dispositivo, a placa pode ou não estar energizada.

Dois cenários comuns de testes em circuito da placa montada são:

  1. Acessar simultaneamente, com pontas de prova, um ponto de teste dedicado para cada rede (ou rede de interesse). Isso é feito enviando um pulso de sinal por cada ponta de prova individualmente e detectando os resultados da recepção do sinal em todas as outras pontas de prova.
  2. Teste componentes/barramentos específicos para garantir que o dispositivo em si esteja funcionando corretamente. Esses são testes especializados que podem ser realizados usando diversos métodos de teste. No caso mais simples, um dispositivo de teste do tipo cama de pregos pode ser usado para testar os pads dos componentes.

Suporte a pontos de teste em pads e vias

O Altium Designer oferece suporte completo a pontos de teste, permitindo especificar pads (de furo passante ou SMD) e/ou vias para uso como pontos de teste nos testes de fabricação e/ou montagem. Um pad ou uma via é designado para uso como ponto de teste por meio da configuração das propriedades de ponto de teste correspondentes e da resposta a duas perguntas fundamentais:

  • O pad/via deve ser usado como ponto de teste de fabricação e/ou montagem?
  • Em qual lado da placa o pad/via deve ser usado como ponto de teste — superior, inferior ou ambos?

Essas propriedades podem ser encontradas no painel Properties, quando um objeto pad (consulte Propriedades do pad) ou via (consulte Propriedades da via) é selecionado no espaço de projeto, respectivamente.

Um pad ou uma via selecionado é especificado para uso como ponto de teste por meio das opções correspondentes disponíveis no painel Properties.Um pad ou uma via selecionado é especificado para uso como ponto de teste por meio das opções correspondentes disponíveis no painel Properties.

Para agilizar o processo e reduzir a necessidade de configurar manualmente as propriedades de ponto de teste dos pads/vias, o Altium Designer oferece um método para atribuir pontos de teste automaticamente com base nas regras de projeto definidas e usando o Gerenciador de pontos de teste. Essa atribuição automática configura as propriedades de ponto de teste correspondentes para o pad/via em cada caso. Você também tem a opção de especificar pontos de teste manualmente — essencialmente, configurando cada pad/via individualmente —, o que proporciona controle total sobre o esquema de pontos de teste empregado na placa.
Ao abrir projetos de PCB criados em uma versão do software anterior à versão Summer 09, todas as opções de ponto de teste habilitadas passarão a ser opções de ponto de teste Fabrication habilitadas.

Regras de projeto para pontos de teste

As restrições de um projeto de PCB devem ser planejadas e implementadas como um conjunto bem elaborado de regras de projeto. Para implementar um esquema de pontos de teste bem-sucedido — no qual todos os pontos de teste definidos possam ser acessados e usados como parte dos testes de placa nua e/ou em circuito —, é necessário estabelecer restrições que o orientem. Para isso, os seguintes tipos de regra podem ser definidos no sistema de regras de projeto do Editor de PCB:

Acesse e defina regras desses tipos na caixa de diálogo Editor de regras e restrições de PCB (Design » Rules).

Defina regras de projeto separadas para restringir quais pads e/ou vias do projeto podem ser usados como pontos de teste de fabricação e de montagem, e quais redes exigem pontos de teste.Defina regras de projeto separadas para restringir quais pads e/ou vias do projeto podem ser usados como pontos de teste de fabricação e de montagem, e quais redes exigem pontos de teste.

As regras de estilo e uso de pontos de teste são idênticas, em termos de restrições, nos dois modos de teste (fabricação e montagem). A regra de estilo especifica, essencialmente, as restrições que um pad ou uma via deve atender para ser considerado na seleção de um local de ponto de teste. A regra de uso especifica quais redes exigem um ponto de teste.

Restrições padrão das regras de uso de pontos de teste (acima) e de estilo de pontos de teste (abaixo).Restrições padrão das regras de uso de pontos de teste (acima) e de estilo de pontos de teste (abaixo).

Ao definir uma regra de estilo, o escopo da regra pode ser criado rapidamente para abranger exatamente os objetos pad e/ou via a serem considerados como pontos de teste, usando as opções disponíveis na região Rule Scope Helper.

As regras de projeto para pontos de teste são usadas pelo Gerenciador de pontos de teste, pelo roteador automático, pelos processos de DRC online e em lote e também durante a geração de saídas.

Existem regras padrão de estilo e uso de pontos de teste de fabricação e montagem. Você deve verificar se essas regras atendem aos requisitos da placa e fazer as alterações necessárias. Se forem necessárias várias regras do mesmo tipo, use a prioridade das regras de projeto para garantir que as regras com escopo mais específico sejam aplicadas primeiro (por exemplo, ao executar uma DRC).

Para que o Testpoint Manager atribua pontos de teste com êxito, deve always existir pelo menos uma regra de estilo de ponto de teste correspondente com escopo All.
Ao abrir projetos de PCB ou importar regras de projeto criadas em uma versão do software anterior à versão Summer 09, as regras de estilo de ponto de teste passarão a ser regras de estilo de ponto de teste de fabricação, e as regras de uso de ponto de teste passarão a ser regras de uso de ponto de teste de fabricação.

Gerenciamento de pontos de teste

A atribuição manual de pontos de teste pode ser uma tarefa minuciosa e trabalhosa, ainda mais em uma placa complexa, com centenas de componentes distribuídos em ambos os lados. Para simplificar o gerenciamento de pontos de teste nos seus projetos de placas, o Altium Designer equipa o Editor de PCB com um Testpoint Manager. O Testpoint Manager permite atribuir pontos de teste — para testes de fabricação da placa nua e/ou testes de montagem em circuito — de forma automatizada, com base nas regras de projeto definidas. Essa atribuição automatizada define as propriedades de ponto de teste relevantes para cada pad/via.

O acesso é feito selecionando o comando Tools » Testpoint Manager nos menus principais.

Gerencie seus requisitos de pontos de teste de fabricação e montagem com rapidez e eficiência usando o Testpoint Manager.Gerencie seus requisitos de pontos de teste de fabricação e montagem com rapidez e eficiência usando o Testpoint Manager.

Use a caixa de diálogo para atribuir e remover pontos de teste automaticamente em um único local. Uma lista de todas as redes do projeto é fornecida na região Testpoint Net Status , com um status que indica a cobertura de pontos de teste — Complete ou Incomplete — tanto para testes de fabricação da placa nua quanto para testes de montagem em circuito. Clique nos botões Fabrication Testpoints ou Assembly Testpoints, ou clique com o botão direito na grade, para acessar os comandos de atribuição ou remoção desse tipo de ponto de teste. Observe que você pode selecionar redes manualmente na região superior da caixa de diálogo para atribuir/remover pontos de teste de forma seletiva.

Ao atribuir pontos de teste a algumas ou a todas as redes de um projeto, o Testpoint Manager segue as regras de estilo e uso definidas para pontos de teste de fabricação e montagem. Para ver a ordem em que os objetos válidos são pesquisados, clique no botão Search Order.

Para alterar a ordem, clique com o botão direito em uma entrada da lista de ordem de pesquisa e use os comandos do menu de contexto ou os atalhos Shift+Up Arrow e Shift+Down Arrow para movê-la para cima ou para baixo na lista.
Se uma rede tiver um ponto de teste atribuído que viole uma regra de projeto de pontos de teste aplicável, isso será indicado Illegal na região Testpoint Net Status da caixa de diálogo Testpoint Manager. Use a funcionalidade de verificação de regras de projeto do Editor de PCB para verificar a validade dos pontos de teste atribuídos.

A região Status Summaries fornece um resumo completo do status dos pontos de teste da placa para ambos os modos de teste. Essa região é atualizada a cada ação de atribuição ou remoção realizada. Para obter informações mais detalhadas, use a região Assignment Results. Ela fornecerá detalhes, por exemplo, sobre o número de pads/vias dos lados superior e inferior envolvidos em uma atribuição/remoção, além de indicar falhas.

Verificação da validade dos pontos de teste

As regras definidas para pontos de teste de fabricação e montagem são seguidas como parte do recurso de verificação de regras de projeto (DRC) do Editor de PCB. A verificação DRC on-line e/ou em lote pode ser habilitada para os vários tipos de regra na caixa de diálogo Design Rule Checker (Tools » Design Rule Check).

Inclua regras de projeto de pontos de teste nos processos de DRC on-line ou em lote.Inclua regras de projeto de pontos de teste nos processos de DRC on-line ou em lote.

Campos de consulta relacionados a pontos de teste

Para dar suporte aos vários pontos de teste de fabricação e montagem que podem ser atribuídos em um projeto, as seguintes palavras-chave estão disponíveis para selecionar pontos de teste usando expressões lógicas de consulta. Cada uma delas pode ser encontrada na categoria Funções de PCB - Campos ao usar o Assistente de consultas:

  • IsAssyTestpoint - é um ponto de teste de montagem.
  • IsFabTestpoint - é um ponto de teste de fabricação.
  • IsTestpoint - é um ponto de teste do lado superior ou inferior.
  • Testpoint - é um ponto de teste do lado superior ou inferior?
  • TestpointAssy - é um ponto de teste de montagem?
  • TestpointAssyBottom - é um ponto de teste de montagem do lado inferior?
  • TestpointAssyTop - é um ponto de teste de montagem do lado superior?
  • TestpointBottom - é um ponto de teste do lado inferior?
  • TestpointFab - é um ponto de teste de fabricação?
  • TestpointFabBottom - é um ponto de teste de fabricação do lado inferior?
  • TestpointFabTop - é um ponto de teste de fabricação do lado superior?
  • TestpointTop - é um ponto de teste do lado superior?

Crie expressões lógicas de consulta para selecionar e retornar pontos de teste no seu projeto conforme necessário. Alguns exemplos de expressões lógicas de consulta voltadas a pontos de teste de fabricação e montagem são:

  1. (ObjectKind = 'Pad') And (TestpointAssy = 'True')
    Seleciona todos os pads que são pontos de teste de montagem.
  2. IsPad And (TestpointAssyTop = 'True')
    Seleciona todos os pads que são pontos de teste de montagem do lado superior.
  3. (ObjectKind = 'Pad') And (TestpointFab = 'True')
    Seleciona todos os pads que são pontos de teste de fabricação.
  4. ((IsPad Or IsVia)) And (TestpointAssy = 'True')
    Seleciona todos os pads e vias que são pontos de teste de montagem.
  5. ((IsPad Or IsVia)) And IsFabTestpoint
    Seleciona todos os pads e vias que são pontos de teste de fabricação.

Geração de relatórios de pontos de teste

O Altium Designer inclui geradores de relatórios dedicados à geração de relatórios de pontos de teste de fabricação e montagem, respectivamente. Esses dois geradores de relatórios utilizam as propriedades de ponto de teste relevantes das primitivas de pad e via em um projeto.

Um relatório de pontos de teste de fabricação usará apenas as configurações de pontos de teste Fabrication dos pads e vias. Um relatório de pontos de teste de montagem usará apenas as configurações de pontos de teste Assembly .

Os relatórios podem ser gerados de duas maneiras:

  • Diretamente no documento de PCB, usando os comandos File » Fabrication Outputs » Test Point Report e File » Assembly Outputs » Test Point Report.
  • Usando saídas devidamente configuradas em um arquivo de configuração de tarefas de saída (*.OutJob).
Para obter mais informações sobre arquivos de configuração de tarefas de saída, consulte Preparação de dados de fabricação com tarefas de saída.

Inclua e configure saídas de relatórios de pontos de teste de fabricação e montagem em um arquivo de configuração de tarefas de saída independente e versátil. Depois de defini-las, obtenha seus relatórios com o toque de um botão!Inclua e configure saídas de relatórios de pontos de teste de fabricação e montagem em um arquivo de configuração de tarefas de saída independente e versátil. Depois de defini-las, obtenha seus relatórios com o toque de um botão!

Independentemente do método usado para gerar um relatório, as opções do relatório são definidas na mesma caixa de diálogo. Para um relatório de pontos de teste de fabricação, utiliza-se a caixa de diálogo Fabrication Testpoint Setup. Para um relatório de pontos de teste de montagem, utiliza-se a caixa de diálogo Assembly Testpoint Setup. As opções de relatório são idênticas nessas caixas de diálogo.

Defina as opções do relatório, incluindo o formato do arquivo gerado, usando a caixa de diálogo de configuração de relatório correspondente. 
Defina as opções do relatório, incluindo o formato do arquivo gerado, usando a caixa de diálogo de configuração de relatório correspondente.

As configurações definidas em uma caixa de diálogo Testpoint Setup ao gerar uma saída diretamente da PCB são distintas e independentes daquelas definidas para o mesmo tipo de saída em um arquivo de configuração de tarefas de saída. No primeiro caso, as configurações são armazenadas no arquivo do projeto; no segundo, são armazenadas no arquivo de tarefas de saída.
As opções na região Coordinate Positions de uma caixa de diálogo permitem exportar as posições dos pontos de teste, em todos os formatos de relatório, em relação à origem absoluta da placa ou à origem atual da placa.
Todos os tipos de relatório de pontos de teste oferecem suporte a painéis de placas incorporados. Vários arquivos de netlist IPC-D-356A são produzidos ao exportar de um documento de PCB que contém vários painéis de placas incorporados.

Função do arquivo de netlist IPC-D-356A

Um dos três formatos de saída de relatório de pontos de teste é o arquivo de netlist IPC-D-356A. Esse arquivo normalmente é usado para o modo de teste de fabricação da placa nua. O arquivo IPC é pós-processado para gerar comandos que controlam um equipamento de teste com sondas móveis.

Independentemente dos elementos especificamente identificados como posições de pontos de teste em um arquivo IPC-D-356A, os fabricantes de placas geralmente podem usar os dados do arquivo para realizar qualquer tipo de teste desejado, embora, dependendo das circunstâncias e do conteúdo do arquivo, isso possa exigir alguma intervenção manual.

AI-LocalizedLocalizado por IA
Caso encontre um problema, selecione o texto/imagem e primaCtrl + Enterpara nos enviar o seu feedback.
Nav
Contents
Disponibilidade de Recursos

Os recursos disponíveis para você dependem de qual solução Altium você possui – Altium Develop, Altium Agile Teams, Altium Agile Enterprise ou Altium Designer (com assinatura ativa).

Se você não vir um recurso documentado no software que está usando no momento, entre em contato com a equipe de vendas da Altium para saber mais.

Documentação Legada

A documentação do Altium Designer já não é versionada. Se precisar de aceder à documentação de versões anteriores do Altium Designer, visite a secção Documentação Legada da página de Outros Instaladores.

Contents