Изменение символов и посадочных мест

Краткий обзор

Обслуживание символов и посадочных мест, связанных с базой данных, в Altium Designer выполняется по-разному для стандартных библиотек DbLib и библиотек SVNDbLib с контролем версий. В этой статье объясняется, как открывать и редактировать символы и посадочные места по умолчанию, на которые ссылаются записи базы данных, настраивать локальные рабочие папки для SVN-библиотек и использовать панель Storage Manager для управления изменениями в репозитории и сравнения ревизий. Читайте дальше, чтобы уверенно приступить к следующему обновлению библиотеки.

- Узнайте, как открывать, редактировать и сохранять символы и посадочные места по умолчанию, на которые ссылаются записи базы данных.
- Разберитесь в рабочем процессе SVN: от получения рабочей копии библиотек до обновления статуса, обновления файлов и фиксации изменений.
- Узнайте, как визуально сравнивать ревизии библиотек и просматривать обнаруженные различия.
Узнайте больше с ИИ:

Помимо поддержки содержимого самой базы данных, при необходимости нужно также поддерживать в актуальном состоянии связанные условные обозначения и модели. Это предполагает внесение изменений в условные обозначения на схеме и модели посадочных мест. А для стандартной библиотеки базы данных (DbLib) — также в определения в файлах моделей для моделирования.

Оба типа библиотек баз данных — стандартные и с контролем версий — позволяют открывать связанные условные обозначения и модели посадочных мест для редактирования непосредственно из основного представления документа DbLib/SVNDbLib, когда он активен. В следующих разделах рассмотрено, как это сделать. При использовании SVNDbLib этот процесс несколько сложнее, но предоставляет больше возможностей.

Обратите внимание: через соответствующий активный файл библиотеки базы данных для редактирования доступны только условное обозначение и посадочное место по умолчанию для записи компонента. Напомним, что модель посадочного места по умолчанию — это модель, указанная в Database Field Name, которое сопоставлено с Design Parameter [Footprint Ref].

При использовании DbLib

Чтобы открыть для редактирования файл библиотеки, содержащий связанное условное обозначение или модель посадочного места компонента, щелкните правой кнопкой мыши запись компонента в Table Browser, затем выберите в контекстном меню соответствующую команду — Open Symbol или Open Footprint. Откроется соответствующий файл библиотеки, а условное обозначение или посадочное место станет активным объектом в рабочей области, готовым к редактированию.

Будет открыта библиотека, в которой найдено связанное условное обозначение или посадочное место: либо указанная явно, если информация о библиотеке присутствует в базе данных, либо найденная по путям, заданным на вкладке Symbol and Model Search Paths диалогового окна Database Library Options (также убедитесь, что нужная библиотека действительно находится по указанному пути). См. раздел Указание расположения библиотек условных обозначений и моделей для библиотеки базы данных.

После внесения необходимых изменений сохраните файл библиотеки.

Пример открытия связанного условного обозначения компонента базы данных непосредственно из DbLib. Пример открытия связанного условного обозначения компонента базы данных непосредственно из DbLib.

Исходный файл библиотеки можно открыть и вне файла DbLib. Для этого воспользуйтесь командой File » Open редактора библиотек, чтобы найти и открыть нужную библиотеку, либо перетащите файл библиотеки из Проводника Windows непосредственно в Altium Designer.

При использовании SVNDbLib

Как уже упоминалось, открытие и редактирование условных обозначений и моделей, на которые ссылаются компоненты базы данных и которые доступны через файл SVNDbLib, несколько сложнее, но предоставляет больше возможностей. Изменения вносятся в локальные рабочие копии библиотек, хранящихся в репозитории SVN.

Указание локальной рабочей папки

Чтобы изменять условные обозначения компонентов и модели посадочных мест, необходимо извлечь файлы из репозитория в локальную рабочую папку. Укажите нужную папку на странице Data Management - SVN Libraries диалогового окна Preferences. По умолчанию задано следующее расположение рабочей папки: \Users\<ProfileName>\Documents\My Designs\SVNDBlib Working Folder. При необходимости измените его, нажав кнопку Button used to browse and select the repository working folder для выбора существующей папки или введя путь к папке напрямую.

Папку, назначенную локальной рабочей папкой, следует использовать только для хранения копии файлов, находящихся под контролем версий. Другие файлы, такие как *.SVNDbLib, *.mdb и *.xls, следует размещать в другой папке, поскольку они не находятся под контролем версий.

Указание локальной рабочей папки.Указание локальной рабочей папки.

Рабочая папка, расположение которой задано по умолчанию, изначально физически не существует. Она будет создана при извлечении файлов из репозитория. То же самое произойдет, если вы укажете еще не существующую папку, введя путь напрямую.

Чтобы быстро извлечь все библиотеки условных обозначений и моделей посадочных мест из репозитория в назначенную локальную рабочую папку, выполните команду Check Out All Working Folders из главного меню Tools редактора SVNDatabaseLib. Будут извлечены папки, указанные в области Models Location на вкладке SVN Repository диалогового окна Database Library Options.

Пример условных обозначений и посадочных мест, хранящихся в репозитории SVN и указанных в составе Database Library Options, после извлечения в локальную рабочую папку.Пример условных обозначений и посадочных мест, хранящихся в репозитории SVN и указанных в составе Database Library Options, после извлечения в локальную рабочую папку.

Внесение изменений

После извлечения библиотек условных обозначений и моделей посадочных мест в назначенную локальную рабочую папку вы сможете вносить необходимые изменения. Для этого нужно изменить локальные копии условных обозначений на схеме и моделей посадочных мест, а затем зафиксировать эти изменения в репозитории SVN.

Как и в случае с DbLib, открыть условное обозначение или модель для редактирования можно следующими способами:

  • В документе SVNDbLib щелкните правой кнопкой мыши запись компонента в Table Browser, затем выберите в контекстном меню соответствующую команду — Open Symbol или Open Footprint.
Будет открыта локальная библиотека, в которой найдено связанное условное обозначение или посадочное место: либо указанная явно, если информация о библиотеке присутствует в базе данных, либо найденная по расположениям моделей, заданным на вкладке SVN Repository диалогового окна Database Library Options. См. раздел Указание расположения библиотек условных обозначений и моделей для библиотеки базы данных.
  • Если SVNDbLib добавлена в список Available File-based Libraries, команды редактирования доступны непосредственно на панели Components. Выберите нужную запись компонента, затем воспользуйтесь командой Edit Symbol (в контекстном меню области Components ) или командой Edit Footprint (в контекстном меню области Models ) соответственно.
  • Воспользуйтесь командой File » Open редактора библиотек, чтобы найти и открыть нужную библиотеку в локальной рабочей папке.
  • Перетащите файл библиотеки из локальной рабочей папки в Проводнике Windows непосредственно в Altium Designer.

В любом случае после внесения необходимых изменений сохраните файл библиотеки.

Однако основным средством взаимодействия между папками и файлами, извлеченными в локальную рабочую папку, и самим репозиторием служит панель Storage Manager. Когда файл SVNDbLib является активным документом, на панели Storage Manager отображаются папки условных обозначений и моделей, извлеченные в локальную рабочую папку. В списке будут представлены именно те папки, которые указаны в области Model Locations на вкладке SVN Repository диалогового окна Database Library Options.

Панель Storage Manager отображает содержимое локальной рабочей папки, если файл SVNDbLib является активным документом в Altium Designer. Панель Storage Manager отображает содержимое локальной рабочей папки, если файл SVNDbLib является активным документом в Altium Designer.

Чтобы открыть файл библиотеки для редактирования, щелкните правой кнопкой мыши его запись в области All Files панели и выберите Open в появившемся контекстном меню. Внесите необходимые изменения и сохраните файл обычным способом, используя стандартную команду Save соответствующего редактора.

Фиксация изменений в репозитории

Panel page: Storage Manager

Хотя открыть библиотеку для редактирования можно разными способами, зафиксировать внесенные изменения из within Altium Designer можно только через панель Storage Manager.

В Altium Designer средства отправки изменений в репозиторий и обновления из него доступны только на панели Storage Manager. Разумеется, отправлять изменения, выполнять обновление и проверять наличие изменений можно и вне Altium Designer, используя возможности внешнего SVN-клиента.

При работе с панелью Storage Manager особенно важно не забывать обновлять состояние связи между локальными рабочими папками и файлами, отображаемыми на панели, и соответствующими папками и файлами в репозитории системы управления версиями. Для отдельной выбранной библиотеки это можно сделать с помощью команды Refresh, доступной в контекстном меню области All Files панели. Чтобы быстро обновить состояние всей папки, используйте сочетание клавиш Ctrl+F5.

Обновление состояния исходных библиотек становится еще важнее, если с ними работают несколько библиотекарей, отвечающих за ведение репозитория исходных файлов символов и моделей.

При работе с локальными библиотеками символов и моделей используются следующие состояния:

Значок Состояние Описание
SVN icon - Normal No modification Локальная копия библиотеки идентична копии в репозитории. Можно открыть файл и внести изменения.
SVN icon - Out of Date Out of date Локальная копия файла в рабочей папке старее соответствующего файла в репозитории и поэтому устарела. Прежде чем вносить и отправлять собственные изменения, необходимо получить последнюю версию файла из репозитория, обновив локальную рабочую копию. Чтобы получить последнюю версию файла из репозитория, используйте команду Update в контекстном меню.
SVN icon - Modified Modified Локальная копия файла была изменена в Altium Designer и сохранена в рабочей папке. Чтобы отправить локальные изменения в репозиторий, щелкните правой кнопкой мыши запись файла и выберите в контекстном меню команду Commit. После отправки в репозиторий состояние снова изменится на No modification.
SVN icon - Conflict Conflict Другой пользователь Altium Designer отправил файл в репозиторий до того, как вы отправили собственную отредактированную и сохраненную версию этого файла. Используйте команду Update или Resolve , чтобы определить, какая версия файла станет последней ревизией в репозитории.
SVN icon - Locked Locked Файл заблокирован вами или другим пользователем. Другой пользователь не сможет обновить заблокированный файл до новой ревизии в репозитории, если блокировка не будет принудительно снята. Это состояние может отображаться вместе с другими значками, например Modified SVN icon - Locked and Modified или No Modification SVN icon - Locked not Modified, если соответствующие состояния также применимы.
Дополнительные сведения о работе с системой управления версиями см. в разделе Использование внешней системы управления версиями.

Физическое сравнение ревизий

Физическое сравнение можно выполнить между любыми двумя ревизиями одной и той же библиотеки символов или моделей. Это позволяет наглядно увидеть изменения между последовательными или непоследовательными ревизиями файла.

На панели Storage Manager сравнение выполняется из области VCS Revisions в нижней части панели.

На панели Storage Manager история выбранного файла представлена в двух отдельных областях: VCS Revisions и Local History. На панели Storage Manager история выбранного файла представлена в двух отдельных областях: VCS Revisions и Local History.

Сравнивать можно любые две ревизии. Используя стандартный для Windows способ выделения Ctrl+click, выберите две ревизии библиотеки, которые требуется сравнить, в области VCS Revisions панели, щелкните правой кнопкой мыши и выберите Compare.

После вызова команды Compare две выбранные ревизии документа откроются рядом в рабочей области, будет выполнено графическое сравнение, а все обнаруженные различия будут перечислены на панели Differences.

Графическое сравнение непосредственно в рабочей области редактора библиотек.Графическое сравнение непосредственно в рабочей области редактора библиотек.

AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Contents