Создание и определение библиотеки баз данных

Краткий обзор

Узнайте, как создавать и настраивать стандартные библиотеки баз данных и библиотеки баз данных с управлением версиями в Altium Designer. В этой статье рассматриваются подключение к внешней базе данных, привязка SVNDbLib к репозиторию Subversion, выбор таблиц базы данных для включения в библиотеку и задание критериев сопоставления, связывающих размещенные компоненты с исходными записями. Продолжайте чтение, чтобы перейти к следующему этапу настройки библиотеки базы данных.

- Узнайте о назначении файлов DbLib и SVNDbLib и о том, где их создавать.
- Изучите варианты подключения к базе данных, включая упрощенное подключение к Access и Excel, строки подключения и файлы Microsoft Data Link.
- Узнайте, как просматривать и редактировать подключенные таблицы, управлять их включением в библиотеку и задавать критерии сопоставления компонентов отдельно для каждой таблицы.
Узнайте больше с ИИ:

Основой механизма библиотек баз данных является файл библиотеки базы данных. Он бывает двух типов в зависимости от того, используете ли вы обычную библиотеку базы данных или библиотеку базы данных с контролем версий:

  • Standard Database Library — файл Database Library. Этот файл создается и редактируется в редакторе DatabaseLib системы Altium Designer. Этот редактор становится доступен, когда активным документом в главном окне проектирования является файл *.DbLib.
  • Version-Controlled Database Library — файл SVN Database Library. Этот файл создается и редактируется в редакторе SVNDatabaseLib системы Altium Designer. Этот редактор становится доступен, когда активным документом в главном окне проектирования является файл *.SVNDbLib.

Пример файла DbLib, открытого в редакторе DatabaseLib. Наведите указатель на изображение, чтобы увидеть пример файла SVNDbLib, открытого в редакторе SVNDatabaseLib.Пример файла DbLib, открытого в редакторе DatabaseLib. Наведите указатель на изображение, чтобы увидеть пример файла SVNDbLib, открытого в редакторе SVNDatabaseLib.

Чтобы создать новый файл одного из этих типов, выберите команду File » New » Library в главном меню, а затем выберите вариант Database Library или SVN Database Library в области Database открывшегося диалогового окна New Library.

Подключение к внешней базе данных

Таблицы и данные сопоставления появятся в главном окне редактора только после успешного подключения активного файла Database Library/SVN Database Library к требуемой внешней базе данных. Подключение настраивается с помощью элементов управления в области Source of Connection.

Настройка подключения к внешней базе данных через файл DbLib. Наведите указатель на изображение, чтобы увидеть подключение через файл SVNDbLib.Настройка подключения к внешней базе данных через файл DbLib. Наведите указатель на изображение, чтобы увидеть подключение через файл SVNDbLib.

Можно подключиться к любой базе данных, поддерживающей OLE DB. Каждый из вариантов в этой области использует строку подключения OLE DB для подключения к целевой базе данных. Некоторые базы данных могут не поддерживать OLE DB. Однако практически все используемые сегодня системы управления базами данных доступны через интерфейс Open Database Connectivity (ODBC). Механизм связи с базой данных использует поставщик ODBC от Microsoft, который позволяет объекту ADO (ActiveX Data Object) подключаться к любому источнику данных ODBC. Таким образом, можно подключиться к любой базе данных ODBC. Поставщик OLE DB для базы данных ODBC указывается в строке подключения.

Подключение также можно настроить на вкладке Connection диалогового окна Database Connection, которое открывается командой Tools » Database Connection в главном меню или нажатием кнопки Advanced (справа от кнопки Connect в нижней части области).

Быстрое подключение к базам данных Access и Excel

Вариант Select Database Type позволяет быстро создать строку подключения, если целевая база данных создана в Microsoft Access или Microsoft Excel. Выбрав этот вариант, укажите тип базы данных, затем найдите и выберите нужный файл базы данных. Соответствующая строка подключения будет автоматически сформирована и введена в поле варианта Use Connection String.

Можно указать полный путь или сохранить путь относительно файла Database Library/SVN Database Library.

Формирование строки подключения

Если база данных вашей компании не основана на Access или Excel и вы хотите явно сформировать строку подключения, выберите вариант Use Connection String, а затем нажмите соответствующую кнопку Build справа. Откроется диалоговое окно Data Link Properties.

Формирование строки подключения в диалоговом окне Data Link Properties.Формирование строки подключения в диалоговом окне Data Link Properties.

Диалоговое окно открывается на вкладке Connection . На вкладке Provider по умолчанию выбран поставщик OLE DB Microsoft Office <Version> Access Database Engine OLE DB Provider. Это поставщик по умолчанию для новых файлов Database Library/SVN Database Library; он также используется для подключения к файлам баз данных Access (*.mdb). При необходимости измените поставщика.

На вкладке Connection введите имя базы данных, к которой требуется подключиться, включая путь.

Если для доступа к базе данных требуется авторизация, введите необходимые учетные данные, а также задайте другие дополнительные параметры, доступные на вкладке Advanced диалогового окна. На вкладке All отображается сводный список заданных параметров связи, а также расширенные параметры выбранного поставщика OLE DB. На этой вкладке можно изменить параметры при необходимости.

После настройки параметров связи можно проверить подключение, нажав кнопку Test Connection (на вкладке Connection ). При успешном подключении появится диалоговое окно с соответствующим подтверждением.

Диалоговое окно Data Link Properties является диалоговым окном Microsoft, поэтому при нажатии F1 или доступной кнопки Help открывается файл Microsoft Data Link Help. Этот файл не входит в комплект документации Altium Designer.

Указание файла связи с данными

Если источник данных, к которому требуется подключиться, описан в файле Microsoft Data Link (*.udl), выберите третий вариант подключения — Use Data Link File — и нажмите соответствующую кнопку Browse , чтобы найти нужный файл. Файл связи с данными, по сути, служит для хранения строки подключения.

Выполнение подключения

После настройки подключения к внешней базе данных текст на кнопке Connect станет полужирным, указывая на то, что можно установить соединение. Если параметры подключения указаны верно, сведения о таблицах и сопоставлениях целевой базы данных будут загружены в файл Database Library/SVN Database Library. Текст на кнопке Connect изменится на Connected, а сама кнопка станет неактивной.

Если в параметрах подключения есть ошибка, например неверно сформирована строка подключения или неправильно указан путь, установить соединение не удастся, и появится соответствующее сообщение. Проверьте настройки подключения и снова нажмите кнопку Connect .

Примеры сообщений об ошибке подключения в библиотеке базы данных. Примеры сообщений об ошибке подключения в библиотеке базы данных.

Если изменить настройки подключения при установленном соединении с базой данных, текущее соединение будет разорвано, а текст на кнопке Connect изменится на Reconnect. Нажмите ее, чтобы восстановить соединение.

После первого успешного подключения и сохранения файла Database Library/SVN Database Library соединение будет устанавливаться автоматически при каждом открытии файла, если расположение и имя файла целевой базы данных не изменятся.

Указание ссылки на репозиторий системы управления версиями (только для SVNDbLib)

В случае DbLib библиотеки символов и моделей хранятся на жестком диске или другом локальном либо сетевом носителе. Помните, что в случае SVNDbLib эти библиотеки хранятся под управлением системы контроля версий в репозитории Subversion. В файле SVNDbLib необходимо указать ссылку на этот репозиторий. Подключение к репозиторию SVN настраивается на вкладке SVN Repository диалогового окна Database Library Options (Tools » Options). Это диалоговое окно также можно открыть, нажав кнопку Options в области Field Settings окна документа.

Пример подключения к файловому репозиторию SVN.Пример подключения к файловому репозиторию SVN.

Список таблиц базы данных

После успешного подключения к внешней базе данных будут загружены сведения о таблицах и сопоставлениях. В левой части документа DbLib/SVNDbLib отображается список всех таблиц подключенной базы данных.

В базе данных на основе Excel таблица фактически представляет собой лист связанной электронной таблицы. К имени таблицы добавляется суффикс $.

Таблицы подключенной базы данных.Таблицы подключенной базы данных.

Флажок Enable рядом с каждой записью таблицы позволяет указать, должна ли эта таблица входить в состав формируемой библиотеки базы данных. Когда библиотека базы данных добавляется в список доступных файловых библиотек для просмотра на панели Components, каждая таблица отображается как отдельная библиотека. Таким образом, хотя фактически добавляется только одна библиотека базы данных, на панели Components это выглядит так, как будто добавлено несколько отдельных библиотек. Подробнее см. в разделе Поиск компонентов в файловых библиотеках и библиотеках баз данных.

При выборе таблицы в списке ее значок меняется с Database table icon, inactive table на Database table icon, active table, показывая, что эта таблица сейчас активна. Таблица со всеми своими данными отображается на вкладке Table Browser документа. В этом представлении таблицу можно редактировать: вы можете быстро просматривать ее содержимое и при необходимости вносить изменения, не открывая саму внешнюю базу данных.

Просмотр исходной таблицы подключенной базы данных.Просмотр исходной таблицы подключенной базы данных.

Чтобы увеличить область просмотра таблицы (как показано на иллюстрации выше), сверните всю расположенную над ней область настроек подключения и полей, нажав элемент управления Collapse icon - collapse a region of the database library document в правом верхнем углу окна документа. Нажмите Expand icon - expand a region of the database library document, чтобы развернуть ее. Таблица также поддерживает привычные функции группировки, сортировки и фильтрации.

Задание критериев сопоставления

После размещения компонента из внешней базы данных необходимо сохранить связь между размещенным компонентом и записью базы данных, сведения из которой использовались для его создания. По сути, их необходимо сопоставить.

При размещении компонента его параметры создаются на лету на основе соответствующих полей записи базы данных. Связь между размещенным компонентом схемы и записью базы данных устанавливается с помощью одного или нескольких таких параметров. В области Field Settings документа можно задать критерии сопоставления: простой поиск по одному ключу или более сложное сопоставление с использованием условия WHERE.

Критерии сопоставления задаются отдельно для каждой таблицы.

Настройка критериев сопоставления после размещения.Настройка критериев сопоставления после размещения.

Поиск по одному ключу

Если выбран параметр Single key lookup (по умолчанию), становятся доступны поля Database field и Part parameter. В первом из них перечислены все доступные имена полей (заголовки столбцов) активной таблицы базы данных. Поскольку параметры компонента схемы добавляются при его размещении, поле Part parameter будет соответствовать выбранному полю базы данных.

Обычно в качестве ключевого поля поиска используется поле, однозначно идентифицирующее каждый компонент во внешней базе данных, например Part Number. Выбранное поле поиска отмечается на вкладке Field Mappings документа неактивной записью Design Parameter.

Сопоставление по одному ключу — Part Number.Сопоставление по одному ключу — Part Number.

При использовании функции Update Parameters From Database после размещения из выбранного ключевого параметра размещенных компонентов схемы считывается значение, которое затем ищется в выбранном ключевом поле базы данных во всех включенных таблицах. Если совпадение найдено, данные из других ячеек этой записи исходной таблицы можно перенести в сопоставленные параметры компонента схемы.

Расширенное сопоставление — условие WHERE

Параметр Single key lookup хорошо подходит для сопоставления по уникальному номеру или идентификатору компонента, но не столь эффективен при сопоставлении по неуникальному параметру, например емкости или сопротивлению. В этом случае следует использовать более гибкое условие WHERE, позволяющее задать сопоставление по нескольким ключам для связи компонента схемы с исходной записью базы данных.

В простейшем виде условие WHERE, записанное с использованием синтаксиса SQL, отражает выбранные значения, определяющие поиск по одному ключу. Например, если для Database field выбрано значение Part Number (по умолчанию), в поле Part parameter также автоматически будет установлено значение Part Number, а условие WHERE будет выглядеть следующим образом:

[Part Number] = '{Part Number}'

Квадратные скобки вокруг поля базы данных (столбца таблицы) — это символы кавычек, заданные на вкладке Advanced диалогового окна Database Connection. Чтобы открыть это окно, нажмите кнопку Advanced в области Source of Connection документа или воспользуйтесь главным меню Tools .

Mapping between the component parameters and the database, using a Where clause На вкладке Advanced диалогового окна Database Connection доступны дополнительные параметры SQL для заключения имен
таблиц в кавычки или использования имен схем таблиц в формируемом условии WHERE.

При заключении имен таблиц в кавычки используемые символы зависят от базы данных. Например, квадратные скобки [ ] можно использовать только в базах данных Microsoft, таких как Access, Excel через ADO или MSSQL (более поздних версий). В MYSQL для этого используется символ ` (обратная кавычка). В любой базе данных имена столбцов требуется заключать в кавычки только в том случае, если они содержат пробелы или являются зарезервированными словами для этой базы данных. Сведения о том, какие символы используются для заключения имен в кавычки (если используются вообще), см. в документации к вашей СУБД.

Фигурные скобки указывают, что указанная запись является параметром проекта. Одинарные кавычки указывают, что параметр проекта следует обрабатывать как строку, а не как число (без кавычек). Соответствие типов очень важно, поскольку SQL учитывает типы данных. Тип параметра проекта должен совпадать с типом столбца в базе данных.

Используя стандартный синтаксис SQL, условие Where можно расширить для поиска совпадений по нескольким записям Database field/Part parameter, например:

[Capacitance] = '{Capacitance}' AND [Tolerance] = {Tolerance} AND [Manufacturer] = '{Manufacturer}'

В этом случае связь с одной записью в соответствующей таблице базы данных устанавливается с помощью трех разных параметров проекта. Обратите внимание, что запись для параметра проекта Tolerance не заключена в кавычки. Это означает, что тип столбца в связанной таблице базы данных — Number, а не String.

Используя стандартный синтаксис SQL, можно сделать условие Where настолько простым или сложным, насколько это необходимо.

Сопоставление полей базы данных с параметрами проекта

Параметры проекта для компонента, размещаемого из библиотеки базы данных, создаются и добавляются в момент размещения. То, какие параметры будут созданы и как будет обновляться их информация после размещения с помощью команды Tools » Update Parameters From Database, определяется настройками сопоставления и обновления в файле Database Library/SVN Database Library. Эти настройки задаются на вкладке Field Mappings в основном представлении документа.

Параметры сопоставления и обновления задаются отдельно для каждой таблицы.

Задайте параметры сопоставления и обновления на вкладке Field Mappings документа DbLib/SVNDbLib.Задайте параметры сопоставления и обновления на вкладке Field Mappings документа DbLib/SVNDbLib.

Сопоставление моделей и параметров

Первые два столбца слева на вкладке Field Mappings определяют, какие данные из базы данных будут сопоставлены с атрибутами, моделями и параметрами компонента.

  • Database Field Name — в этом столбце перечислены имена всех полей (столбцов) текущей активной таблицы базы данных.
  • Design Parameter — этот столбец определяет, как будет использоваться каждое соответствующее поле базы данных: в качестве источника условного графического обозначения или модели посадочного места компонента (в этом случае имя заключается в квадратные скобки) либо в качестве параметра компонента (без скобок).
При открытии документа DbLib/SVNDbLib, подключенного к базе данных, можно заметить, что некоторые параметры проекта заключены в квадратные скобки, а другие — нет. Квадратные скобки обозначают зарезервированное имя, например [Library Ref]. Эти данные используются для заполнения атрибутов и моделей компонента. Параметры проекта без квадратных скобок становятся параметрами компонента.

Первоначальное сопоставление выполняется автоматически при подключении к базе данных; при этом сопоставляются все поля базы данных.

Обратите внимание: при автоматическом сопоставлении предполагается, что имена полей базы данных совпадают с зарезервированными именами, используемыми в Altium Designer. Если это не так, сопоставление необходимо настроить вручную.

Атрибуты и модели

Если имя поля базы данных совпадает с одним из следующих зарезервированных имен, соответствующее сопоставление атрибута или модели будет автоматически задано в поле Design Parameter:

  • Description → [Description]
  • Footprint Ref → [Footprint Ref]
  • Footprint Path → [Footprint Path]
  • Footprint Ref n → [Footprint Ref n]
  • Footprint Path n → [Footprint Path n]
В таблице базы данных можно указать неограниченное количество ссылок на модели посадочных мест (и путей к ним) и настроить их сопоставление в файле DbLib/SVNDbLib. В зарезервированных именах n обозначает положительное целое число, начиная с 2.
  • Library Ref → [Library Ref]
  • Library Path → [Library Path]
  • Orcad Footprint → [Orcad Footprint]
  • Orcad Library → [Orcad Library]
Эти ссылки используются при импорте файла конфигурации и библиотек OrCAD CIS и создании стандартной библиотеки базы данных (DbLib).
  • PCB3D Ref → [PCB3D Ref]
  • PCB3D Path → [PCB3D Path]

    • Ссылки на PCB3D относятся к устаревшему средству 3D-просмотра; их не следует использовать в новых проектах. Встроенный 3D-движок редактора печатных плат позволяет отображать тела компонентов и импортированные файлы 3D-моделей, связанные с посадочными местами компонентов.
    • Сопоставления моделей PCB3D можно задать в файле SVNDbLib, однако хранение библиотек моделей PCB3D в репозитории Subversion не поддерживается.
  • Sim Description → [Sim Description]
  • Sim Excluded Parts → [Sim Excluded Parts]
  • Sim File → [Sim File]
  • Sim Kind → [Sim Kind]
  • Sim Model Name → [Sim Model Name]
  • Sim Netlist → [Sim Netlist]
  • Sim Parameters → [Sim Parameters]
  • Sim Port Map → [Sim Port Map]
  • Sim Spice Prefix → [Sim Spice Prefix]
  • Sim SubKind → [Sim SubKind]

    Подробнее о полях, связанных с моделями для моделирования, см. ниже в разделе Сопоставление моделей для моделирования.
    Для компонента во внешней базе данных можно задать только одну ссылку на модель для моделирования. Как правило, с компонентом связывается только одна такая модель. Если необходимо настроить несколько ссылок на модели для моделирования, остальные ссылки нужно задать и сохранить вместе с этим компонентом в исходном файле библиотеки схемных компонентов.
    Связанные модели для моделирования поддерживаются в библиотеке базы данных с контролем версий (SVNDbLib), однако хранение файлов этих моделей в репозитории Subversion не поддерживается.

Эти сопоставления определяют сведения об атрибутах и моделях компонента. При размещении компонента условное графическое обозначение, указанное в поле [Library Ref] соответствующей записи базы данных, извлекается из указанной библиотеки схемных компонентов. Аналогичным образом сведения о посадочном месте и модели для моделирования, хранящиеся в записи, добавляются к компоненту в виде связанных моделей посадочного места и моделирования соответственно.

Чтобы компонент из Database Library/SVN Database Library можно было разместить на схеме, запись [Library Ref] должна присутствовать в столбце Design Parameter и быть сопоставлена с Database Field Name, задающим условное графическое обозначение. Если в таблице базы данных ссылка на обозначение хранится под другим именем Database Field Name, например SCH Symbol, необходимо вручную установить для соответствующей записи Design Parameter этого поля значение [Library Ref], выбрав его из раскрывающегося списка в этой ячейке.

Аналогичным образом, если сведения о ссылках на модели внесены в базу данных под другими именами полей, необходимо вручную выполнить сопоставление, поочередно выбирая для каждого поля соответствующую запись Design Parameter ([Footprint Ref], [Footprint Ref n], [PCB3D Ref], [Sim Model Name] и т. д.) из раскрывающегося списка.

Mapping the symbol and footprint models from the database to the design componentДля определения условного графического обозначения и моделей компонента при размещении ключевыми объектами
сопоставления являются поля ссылок на обозначение и модели в базе данных. Убедитесь, что в настроенном сопоставлении присутствуют ссылка на обозначение и хотя бы одна ссылка на посадочное место.

Как уже упоминалось, можно сопоставить несколько моделей печатной платы. Database Field Name, сопоставленное с Design Parameter [Footprint Ref], будет посадочным местом по умолчанию при размещении компонента на схеме. Именно это посадочное место будет размещено при переносе проекта на печатную плату.
При сопоставлении обозначений и моделей в файле DbLib/SVNDbLib указывать пути во внешней базе данных необязательно. Подробнее см. в разделе Указание расположения библиотек обозначений и моделей.

Сопоставление моделей для моделирования

В этом разделе рассматриваются поля, которые можно добавить в таблицу внешней базы данных для определения связи с моделью моделирования, создаваемой при размещении компонента.

  • Sim Model Name — имя модели, которую вы хотите использовать. После размещения компонента эта информация появится в поле Model Name диалогового окна Sim Model.

    При сопоставлении полей базы данных с параметрами проекта в файле DBLib поле Sim Model Name аналогично полям Footprint Ref, Library Ref и т. д.
  • Sim Description — описание связанной модели. Эта информация необязательна и не влияет на работу связи с моделью моделирования.
  • Sim File — конкретный файл модели, в котором следует искать модель моделирования, указанную в поле Sim Model Name. Это поле можно использовать несколькими способами:

    • Можно ввести абсолютный путь к файлу модели (например, C:\DbLibs\Switching Diodes\Libraries\JAS33.mdl). В этом файле будет выполнен поиск модели, указанной в поле Sim Model Name, и, если она будет найдена, она будет использована.
    • Можно ввести относительный путь к файлу модели (относительно файла DbLib), например Libraries\JAS33.mdl. В этом файле будет выполнен поиск модели, указанной в поле Sim Model Name, и, если она будет найдена, она будет использована.
    • Можно ввести только имя файла модели (например, JAS33.mdl)). Пути поиска, заданные в файле DbLib, будут использоваться для нахождения первого файла модели, имя которого совпадает с указанным и который содержит модель, указанную в поле Sim Model Name.
    • Можно оставить поле пустым. Пути поиска, заданные в файле DbLib, будут использоваться для нахождения первого файла модели, содержащего модель, указанную в поле Sim Model Name.
    Пути поиска для файла DbLib задаются на вкладке Symbol & Model Search Paths диалогового окна Database Library Options (Tools » Options).
  • Sim Kind — родительская категория связываемой модели.
  • Sim SubKind — тип связываемой модели.
  • Sim Netlist — данные шаблона списка соединений в соответствии с типом связываемой модели. Это поле особенно важно, если вы задаёте собственный шаблон списка соединений и устанавливаете для поля Sim SubKind значение Generic Editor, что позволяет точнее управлять информацией, включаемой в список соединений.

    Это поле обязательно должно быть заполнено. В противном случае запись для модели не будет добавлена в список соединений для моделирования, и моделирование компонента, размещённого из библиотеки базы данных, выполняться не будет.
  • Sim Spice Prefix – префикс SPICE для типа модели, с которой устанавливается связь.
  • Sim Port Map – сопоставление выводов компонента на схеме с выводами связанной модели. После размещения компонента эта информация появится в области Pin Mapping диалогового окна Sim Model.

    Каждую пару выводов необходимо вводить в следующем формате:

    (SchematicPinNumber:ModelPinNumber),

    разделяя пары сопоставленных выводов запятыми.

    Например, при сопоставлении выводов модели диода для моделирования, когда вывод 1 на схеме (анод) должен соответствовать выводу 1 модели (анод), а вывод 3 на схеме (катод) — выводу 2 модели (катод), в поле базы данных следует ввести:

    (1:1),(3:2)

  • Sim Excluded Parts – создайте это поле в базе данных, если хотите исключить из моделирования определённые части многосекционного компонента. Эта информация соответствует параметру Exclude part from simulation в области Pin Mapping диалогового окна Sim Model.

    По умолчанию в моделирование включаются все части многосекционного компонента, поэтому необходимо указать только номера частей, которые требуется исключить. Разделяйте номера в списке исключений запятыми. Например, если компонент состоит из четырёх частей и вы не хотите, чтобы части 2 и 4 участвовали в моделировании, в поле базы данных следует ввести:

    2,4

  • Sim Parameters – создайте это поле в базе данных, если хотите задать значения параметров моделирования для модели. Это параметры, которые можно определить на уровне компонента, в отличие от более сложных параметров, которые могут быть включены в файл модели.

    Параметр необходимо вводить в следующем формате:

    ParameterName=Value,

    Несколько параметров необходимо разделять символом вертикальной черты (|).

    Как вы, возможно, помните, параметр моделирования уровня компонента также можно задать как параметр компонента — он будет отображаться в области Parameters соответствующего диалогового окна Component Properties, и его можно будет вывести на лист схемы. По умолчанию запись параметра в поле Sim Parameters автоматически добавляется как параметр компонента. Если вы не хотите добавлять параметр моделирования как параметр компонента, просто поставьте восклицательный знак перед его именем (например, !Initial Voltage=100mV).

    Рассмотрим модель диода со следующими четырьмя параметрами уровня компонента:

    • Коэффициент площади
    • Начальное состояние
    • Начальное напряжение
    • Температура.

    Теперь предположим, что в базу данных нужно добавить значения коэффициента площади (например, 2) и температуры (например, 22°C). При этом оба параметра не должны добавляться как параметры компонента. Запись в поле Sim Parameters будет следующей:

    !Area Factor=2|!Temperature=22

После размещения компонента из библиотеки базы данных можно проверить, что информация о связи с моделью для моделирования соответствует требованиям. Выделив размещённый компонент в рабочей области проекта, выберите запись модели для моделирования в области Parameters панели Properties и нажмите кнопку , чтобы открыть диалоговое окно Sim Model, в котором можно проверить следующее:

  • Файл модели найден там, где ожидалось. Если файл найден, на вкладке Model File диалогового окна будет отображаться его содержимое.
  • Остальная информация для моделирования из базы данных добавлена в диалоговое окно корректно.

При запуске моделирования для компонента, размещённого из библиотеки базы данных, будут использоваться значения, хранящиеся в полях базы данных. Однако обратите внимание: если открыть диалоговое окно Sim Model модели для моделирования компонента, размещённого из библиотеки базы данных, и нажать OK, поля Sim Netlist и Sim Spice Prefix для этого компонента будут заданы автоматически на основе текста выбранной модели.

Параметры

Все остальные имена полей базы данных будут автоматически сопоставлены с одноимёнными параметрами проекта. Например, если поле в базе данных называется Tolerance, с ним будет сопоставлен параметр проекта с именем Tolerance. Имя параметра проекта можно изменить, щёлкнув его ячейку и введя новое имя. Именно эти имена параметров проекта будут отображаться в области Parameters соответствующего диалогового окна свойств компонента после его размещения на листе схемы.

С компонентом в базе данных может быть связано множество полей данных, и не все из них вы захотите или даже сочтете необходимым добавлять к компоненту в качестве параметров проекта при его размещении на листе схемы. Большая часть этой информации может требоваться только при формировании спецификации (BOM). Диалоговое окно Report Manager позволяет добавлять в BOM сведения о параметрах непосредственно из связанной базы данных, сокращая объем информации, которая «переносится» вместе с исходными документами схемы. Дополнительные сведения см. в разделе Подготовка BOM в Report Manager.

Для полей, которые вы явно не хотите сопоставлять с данными из базы, установите для Design Parameter значение [None]. Несопоставленные поля базы данных отмечаются на вкладке значком красного крестика (Cross icon, indicating that a database field is not mapped to a component parameter). Сопоставленные поля базы данных отмечаются значком зеленой галочки (Tick icon, indicating that a database field is mapped to a component parameter).

Настройте сопоставление параметров нужным образом. Установите значение [None], чтобы параметр из базы данных не сопоставлялся с размещенным компонентом. При необходимости несопоставленные параметры можно включить непосредственно в BOM.Настройте сопоставление параметров нужным образом. Установите значение [None], чтобы параметр из базы данных не сопоставлялся с размещенным компонентом. При необходимости несопоставленные параметры можно включить непосредственно в BOM.

Чтобы быстро восстановить сопоставление поля, щелкните в строке этого поля и используйте сочетание клавиш Ctrl+D. Обратите внимание: для сопоставления моделей необходимо вручную выбрать значение в соответствующем раскрывающемся списке Design Parameter.

Параметры обновления

Остальные столбцы на вкладке Field Mappings позволяют задать действия с параметрами при первом размещении компонента из библиотеки базы данных или при обновлении уже размещенного компонента с помощью команды Tools » Update Parameters From Database.

Предусмотрены следующие четыре столбца:

  • Update Values — ячейка в этом столбце определяет действие, которое следует выполнить, если параметр существует и на листе схемы, и в базе данных, но его значения различаются. Можно обновить параметр размещенного компонента значением из базы данных (Update) или не обновлять его (Do not update). Эта настройка учитывается при использовании команды Update Parameters From Database после размещения компонента.
  • Add To Design — ячейка в этом столбце определяет действие, которое следует выполнить, если параметр найден в базе данных, но отсутствует у размещенного компонента. Можно добавить параметр (Add), не добавлять его (Do not add) или добавлять его только в том случае, если в базе данных ему присвоено значение (Add only if not blank in database). Эта настройка учитывается как при первоначальном размещении компонента из библиотеки базы данных, так и при использовании команды Update Parameters From Database после его размещения.
  • Visible On Add — флажок в этом столбце определяет, будет ли новый параметр, добавленный при первоначальном размещении или последующем обновлении, видимым для компонента на листе схемы: установленный флажок включает видимость, снятый — отключает.
  • Remove From Design — ячейка в этом столбце определяет действие, которое следует выполнить, если параметр существует у размещенного компонента, но отсутствует в базе данных либо присутствует в ней, но не имеет значения. Можно не удалять параметр (Do not remove) или удалять его только в том случае, если в базе данных ему не присвоено значение (Remove only if blank in database). Эта настройка учитывается при использовании команды Update Parameters From Database после размещения компонента.

Изначально для полей Update Values, Add To Design и Remove From Design каждого сопоставленного поля базы данных устанавливается значение Default, а настройка Visible On Add отключена, как показано на следующем изображении.

Исходные настройки обновления параметров (по умолчанию).Исходные настройки обновления параметров (по умолчанию).

На изображении можно отметить четыре важных момента, касающихся настроек обновления:

  1. Для несопоставленных полей базы данных настройки обновления отсутствуют.
  2. Для сопоставлений атрибутов и моделей (записей в квадратных скобках в столбце Design Parameter) настройки обновления отсутствуют, поскольку это не параметры проекта.
  3. Для ключевого поля (например, Part Number на изображении) настройки обновления отсутствуют. Это поле используется исключительно для сопоставления параметров.
  4. Значение Default предписывает использовать для настройки обновления соответствующее значение по умолчанию, заданное на вкладке Default Actions диалогового окна Database Library Options (Tools » Options в главном меню или Options в контекстном меню вкладки Table Browser). Это диалоговое окно также можно открыть, нажав кнопку Options в области Field Settings представления документа.

Задайте настройки обновления параметров по умолчанию централизованно для DbLib. Наведите указатель на изображение, чтобы увидеть аналогичные настройки для SVNDbLib.Задайте настройки обновления параметров по умолчанию централизованно для DbLib. Наведите указатель на изображение, чтобы увидеть аналогичные настройки для SVNDbLib.

Четвертый пункт полезен тем, что позволяет задавать настройки обновления централизованно, а затем ссылаться на них при определении настроек обновления для каждого сопоставленного поля. Именно поэтому значение Default автоматически подставляется в соответствующие поля настроек обновления при сопоставлении поля базы данных с параметром проекта.

Чтобы переопределить настройку обновления по умолчанию, щелкните в соответствующем поле на вкладке Field Mappings, а затем щелкните еще раз, чтобы открыть раскрывающийся список доступных вариантов обновления.

При необходимости настройки обновления параметров можно переопределить вручную.При необходимости настройки обновления параметров можно переопределить вручную.

Таким образом, вы полностью контролируете обновление параметров проекта. Можно установить для всех полей значение Default и принимать необходимые решения об обновлении в диалоговом окне Database Library Options, настроить каждое поле обновления отдельно или использовать оба подхода — выбор полностью за вами. Для размещенных компонентов обновление выполняется через диалоговое окно Engineering Change Order. Если на этом этапе вы решите отказаться от каких-либо обновлений, соответствующие изменения можно исключить — окончательное решение о том, какие параметры проекта будут обновлены, остается за вами.

Указание расположения библиотек символов и моделей

При размещении компонента из библиотеки базы данных его символ, заданный сопоставлением [Library Ref], извлекается из указанной библиотеки схемных символов (*.SchLib). Аналогично, модели (посадочного места, PCB3D, моделирования), ссылки на которые заданы в базе данных, находятся в соответствующих файлах библиотеки посадочных мест (*.PcbLib), библиотеки PCB3D (*.PCB3DLib) и моделей для моделирования (*.mdl, *.ckt). Пути к этим файлам можно явно задать в базе данных следующими способами:

  • Указать абсолютный путь к файлу.
  • Указать относительный путь к файлу.

Если в базе данных определены поля для хранения путей, эти поля необходимо сопоставить с соответствующими параметрами проекта — [Library Path], [Footprint Path], [PCB3D Path], [Sim File] и т. д. (см. раздел Сопоставление моделей и параметров).

Указание путей, даже относительных, в таблице базы данных может несколько ограничивать гибкость. При изменении расположения библиотеки или файла модели потребуется соответствующим образом обновить таблицу базы данных. Для большей свободы действий сведения для поиска библиотек можно задать непосредственно в файле DbLib/SVNDbLib. Это позволяет указывать в базе данных только имя исходного файла библиотеки или модели либо вообще не указывать его.

Using Search Paths with a large number of symbol/model files - хотя пути поиска обеспечивают большую гибкость и простоту настройки поиска символов и моделей, этот подход не рекомендуется, если в папке поиска находится большое количество файлов символов или моделей. В зависимости от используемой схемы именования файлов при использовании путей поиска может потребоваться просмотр каждого файла библиотеки или модели по указанному пути всякий раз, когда нужен символ или модель, например при просмотре компонентов или переносе проекта со схемы на печатную плату.

Для библиотеки базы данных

Для DbLib пути поиска библиотек задаются на вкладке Symbol and Model Search Paths диалогового окна Database Library Options (Tools » Options). Это окно также можно открыть, нажав кнопку Options в области Field Settings представления документа.

Задание путей поиска библиотек символов и моделей.Задание путей поиска библиотек символов и моделей.

Чтобы добавить путь в список:

  1. Введите путь непосредственно в поле под областью Library Search Paths или нажмите кнопку Browse for a folder button, чтобы открыть диалоговое окно Browse for Folder, в котором можно выбрать папку с нужными файлами библиотек или моделей.
  2. Можно добавить как полный, так и относительный путь (относительно расположения файла DbLib). Это определяется параметром Add/Update As Relative Path.
  3. Указав нужный путь, добавьте его в список путей поиска, нажав кнопку Add .
  4. При необходимости добавьте другие пути поиска.
Если при непосредственном вводе указан неверный путь (например, к несуществующей папке), его всё равно можно добавить, но в списке он будет отображаться серым цветом, указывающим на недопустимый путь поиска. Если вы обнаружили, что ввели путь по ошибке, выберите его в списке и нажмите кнопку Remove либо измените путь и нажмите кнопку Update .

Пути поиска библиотек определяют, где искать файлы библиотек и моделей при размещении компонентов из библиотеки базы данных и при поиске модели после размещения. Выбор конкретной модели зависит от настройки путей поиска библиотек и от того, добавлены ли в базу данных сведения о конкретной библиотеке. Поиск выполняется в следующем порядке:

  1. Если в сопоставленном поле пути для символа или модели указан полный путь, используется соответствующий файл библиотеки или модели, из которого извлекается символ или модель, указанные в соответствующем поле ссылки.
  2. Если в сопоставленном поле пути для символа или модели указан относительный путь, используется соответствующий файл библиотеки или модели, из которого извлекается символ или модель, указанные в соответствующем поле ссылки.
  3. Если в сопоставленном поле пути для символа или модели указано только имя файла библиотеки или модели, по путям поиска находится первый файл с указанным именем, содержащий символ или модель, указанные в соответствующем поле ссылки.
  4. Если в базе данных отсутствуют сведения о файле библиотеки или модели, по путям поиска находится первый файл библиотеки или модели, содержащий символ или модель, указанные в соответствующем поле ссылки.

Для библиотеки базы данных SVN

Для SVNDbLib базовые каталоги в репозитории Subversion, в которых находятся символы и модели посадочных мест, задаются на вкладке SVN Repository диалогового окна Database Library Options (Tools » Options). Это окно также можно открыть, нажав кнопку Options в области Field Settings представления документа.

Задание базовых каталогов репозитория для символов и посадочных мест.Задание базовых каталогов репозитория для символов и посадочных мест.

Используйте поля в области Models Location, чтобы указать базовые каталоги для символов и посадочных мест. Нажмите кнопку Click the ellipsis button to select the repository folder for the symbols and footprints справа от поля, чтобы открыть диалоговое окно Browse for directory, в котором отображается содержимое подключённого репозитория. Выберите в этом окне нужную папку.

Выбор нужного каталога в подключённом репозитории SVN.Выбор нужного каталога в подключённом репозитории SVN.

Важно подчеркнуть, что символы и посадочные места должны находиться в указанных базовых каталогах репозитория. Разумеется, они могут располагаться во вложенных папках этих каталогов, а пути для символов и посадочных мест могут указывать на один и тот же каталог репозитория.

Расположения моделей определяют, где искать файлы библиотек и моделей при размещении компонентов из библиотеки базы данных с контролем версий и при поиске модели после размещения. Выбор конкретного символа схемы и моделей посадочных мест зависит от настройки этих расположений и от того, добавлены ли в базу данных сведения о конкретной библиотеке. Поиск выполняется в следующем порядке:

  1. Если в сопоставленном поле пути для символа или модели посадочного места указан полный путь (например, http://MyServer/svn/MyCompany/ParentDirectory/SchematicSymbols/Capacitor_NonPolarized.SchLib), используется соответствующий файл библиотеки, из которого извлекается символ или посадочное место, указанные в соответствующем поле ссылки.
  2. Если в сопоставленном поле пути для символа или модели посадочного места указан относительный путь (относительно корня репозитория) (например, /ParentDirectory/SchematicSymbols/Capacitor_NonPolarized.SchLib), используется соответствующий файл библиотеки, из которого извлекается символ или посадочное место, указанные в соответствующем поле ссылки. Для получения абсолютного адреса к началу введённого пути добавляется URL репозитория, указанный в области Repository Server Connection диалогового окна.
  3. Если в сопоставленном поле пути для символа или модели посадочного места указано только имя файла библиотеки (например, Capacitor_NonPolarized.SchLib), в заданных расположениях моделей в репозитории находится первый файл библиотеки с указанным именем, содержащий символ или модель посадочного места, указанные в соответствующем поле ссылки.
При поиске соответствующего символа или модели пути ко всем папкам в базовом каталоге символов или посадочных мест сводятся в единый список, сортируются и просматриваются в алфавитном порядке. Если используется мастер разделения библиотек, всегда будет существовать соответствующая библиотека с именем самого символа или посадочного места.
  1. Если в базе данных отсутствуют сведения о файле библиотеки, в заданных расположениях моделей находится первый файл библиотеки, содержащий символ или модель посадочного места, указанные в соответствующем поле ссылки.
При поиске символа или посадочного места система сначала ищет первую библиотеку с тем же именем, что и сам символ или посадочное место. Например, если логическое имя символа в базе данных (заданное сопоставлением [Library Ref]) — Capacitor_NonPolarized, система найдёт первый файл с именем Capacitor_NonPolarized.SchLib и попытается найти символ в этом файле. Если таким способом найти символ или посадочное место не удастся, система будет искать совпадение во всех библиотеках.
AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Contents