Инструменты миграции библиотек баз данных

Краткий обзор

Ознакомьтесь с инструментами миграции библиотек баз данных в Altium Designer и пошаговыми инструкциями по преобразованию интегрированных библиотек в стандартные библиотеки баз данных (DbLib) или библиотеки баз данных с контролем версий SVN (SVNDbLib). В статье объясняется, как мастера преобразования обрабатывают данные компонентов, условные графические обозначения и посадочные места, а также рассматриваются ограничения баз данных и требования к настройке. Читайте далее, чтобы выбрать подходящий способ преобразования и подготовить библиотеки к миграции.

- Узнайте, когда следует использовать DbLib, а когда — SVNDbLib.
- Изучите настройку мастеров преобразования, выбор исходных библиотек и указание целевых баз данных и репозиториев.
- Ознакомьтесь с важными требованиями и ограничениями, включая поддержку преобразования только для Access, подготовку репозитория SVN и обработку ссылок на модели.
Узнайте больше с ИИ:

Программное обеспечение Altium для проектирования позволяет размещать компоненты непосредственно из корпоративной базы данных, создав и используя библиотеку базы данных. Тип используемой библиотеки базы данных зависит от того, как вы хотите организовать хранение исходных библиотек символов и моделей. Если библиотеки будут храниться на жестком диске или сетевом диске, достаточно использовать библиотеку базы данных (DbLib). Если же вы хотите хранить библиотеки под управлением системы контроля версий в репозитории Subversion, следует использовать библиотеку базы данных SVN (SVNDbLib).

Независимо от типа используемой библиотеки базы данных основной принцип работы остается неизменным: возможность размещать компоненты непосредственно из связанной внешней базы данных. Чтобы максимально упростить использование этой мощной функции, предусмотрены инструменты для быстрого переноса существующих библиотек в структуру библиотеки базы данных. Эти инструменты позволяют выполнять следующие преобразования:

  • Из интегрированной библиотеки в библиотеку базы данных (DbLib или SVNDbLib).
  • Из библиотеки базы данных (DbLib или SVNDbLib) в интегрированную библиотеку.
  • Из исходных библиотек символов схем и посадочных мест печатных плат в библиотеку базы данных SVN.
  • Из библиотеки базы данных в библиотеку базы данных SVN.
  • Из системы OrCAD Component Information System (CIS) в библиотеку базы данных (DbLib).

В следующих разделах подробнее рассматривается выполнение этих преобразований в программном обеспечении.

Создание библиотеки базы данных из интегрированной библиотеки

Интегрированные библиотеки по своей природе надежно защищены. Кроме того, они идеально подходят для передачи проектов за пределы компании благодаря своей переносимости. Если проект должен оставаться внутри компании и/или вы хотите тесно связать компоненты Altium с корпоративной базой данных, библиотеки баз данных — идеальный выбор. Программное обеспечение позволяет быстро преобразовать корпоративные интегрированные библиотеки в структуру библиотеки базы данных (DbLib) или библиотеки базы данных SVN (SVNDbLib). В преобразование можно включить несколько интегрированных библиотек; каждая из них будет добавлена в целевую базу данных в виде отдельной таблицы.

Преобразование в DbLib

Создание стандартной библиотеки базы данных (DbLib) из интегрированной библиотеки (IntLib) выполняется с помощью Integrated Library to Database Library Translator Wizard. Мастер фактически декомпилирует указанные интегрированные библиотеки, используя каждую из них для создания отдельной таблицы в выбранной целевой базе данных, включая сведения о параметрах и моделях, извлеченные из компонентов. Затем для подключения к этой базе данных используется указанный файл библиотеки базы данных.

Мастер также можно использовать для импорта или добавления компонентов в существующую базу данных, подключенную через существующий файл DbLib.
Преобразование поддерживает только базы данных типа Access.

Перенос одной или нескольких исходных интегрированных библиотек в структуру библиотеки базы данных — простой процесс, выполняемый с помощью Integrated Library to Database Library Translator Wizard.Перенос одной или нескольких исходных интегрированных библиотек в структуру библиотеки базы данных — простой процесс, выполняемый с помощью Integrated Library to Database Library Translator Wizard.

Процесс включает следующие шаги:

  1. Создайте новый или откройте существующий файл библиотеки базы данных (*.DbLib). Как правило, существующий файл DbLib используется при преобразовании одной или нескольких интегрированных библиотек в существующую базу данных Access, к которой этот файл DbLib уже подключен.
  2. Когда файл библиотеки базы данных (*.DbLib) открыт как активный документ, выберите команду Tools » Import From Integrated Libraries в главном меню, чтобы открыть Integrated Library to Database Library Translator Wizard.
  3. На начальной странице мастера Specify your Database details укажите целевую базу данных — новую или существующую базу данных Access. При создании новой базы данных нажмите значок папки справа от поля Database Location, чтобы открыть стандартное диалоговое окно Open . В этом окне укажите расположение и имя создаваемой базы данных. Выбранные имя и путь будут внесены в поле Database Location.

    Если мастер запущен из существующего файла DbLib, по умолчанию будет выбран вариант Existing Access Database , а в поле Database Location будет указана база данных, к которой подключен этот файл DbLib.
  4. На следующей странице мастера Specify your Target Database Library укажите целевой файл библиотеки базы данных. Задайте путь и имя нового файла DbLib либо найдите и откройте существующий файл. Как правило, существующий файл DbLib используется при преобразовании одной или нескольких интегрированных библиотек в существующую базу данных Access, к которой этот файл DbLib уже подключен. По умолчанию в поле будет указан активный файл DbLib.

    Если используется существующий файл DbLib и целевая база данных изменена, после завершения работы мастера файл DbLib будет подключен к новой целевой базе данных.
  5. На следующей странице мастера Locate the Integrated Libraries to Import укажите интегрированные библиотеки, которые требуется преобразовать. Нажмите кнопку Add, чтобы открыть диалоговое окно Select Source Integrated Libraries, в котором можно найти и выбрать нужные библиотеки. Входящие в их состав библиотеки символов схем и моделей (при наличии) будут извлечены и сохранены в расположении, указанном в поле Destination Folder. Используйте кнопки Remove и Clear , чтобы убрать выбранную библиотеку из списка или удалить ее.

    По умолчанию Destination Folder указывает на вложенную папку Libraries в папке, содержащей файл DbLib (указанный на предыдущей странице мастера).
  6. После выбора исходных интегрированных библиотек нажмите Next, чтобы начать преобразование. Отобразится индикатор выполнения и информация о библиотеке, преобразуемой в данный момент. После завершения преобразования нажмите Finish на последней странице мастера, чтобы сделать указанный файл DbLib активным в главном окне проектирования (если он еще не активен).

    Для каждой интегрированной библиотеки, участвующей в преобразовании, в базе данных будет создана отдельная таблица с именем этой библиотеки. Если в существующей базе данных уже есть таблица с таким именем, сведения из библиотеки будут добавлены в эту таблицу.

Полученный файл DbLib после завершения преобразования.
Полученный файл DbLib после завершения преобразования.

После завершения преобразования можно открыть исходные библиотеки символов схем и удалить из символов все сведения о параметрах и моделях. Затем при необходимости можно уточнить настройки сопоставления полей в документе DbLib, чтобы они ссылались на соответствующие столбцы базы данных. Подробнее см. раздел Сопоставление полей базы данных с параметрами проекта на странице Создание и настройка библиотеки базы данных.

Для моделей посадочных мест мастер извлекает только ссылку на модель и путь к заданным моделям. Для моделей моделирования сведения о связях потребуется вручную внести во внешнюю базу данных.
Убедитесь, что компоненты библиотек символов схем в составе IntLib не содержат параметр Part Number. Сведения о номере компонента, вносимые в базу данных для идентификации каждой записи компонента, берутся из поля Design Item ID компонента схемы в разделе Properties на вкладке General панели Свойства при просмотре свойств выбранного компонента библиотеки. Если также задать эти сведения в виде параметра, преобразование завершится ошибкой из-за дублирующихся значений.

Преобразование в SVNDbLib

Создание библиотеки базы данных с контролем версий (SVNDbLib) из интегрированной библиотеки (IntLib) выполняется с помощью SVN Database Library Conversion Wizard. Мастер фактически декомпилирует выбранные интегрированные библиотеки и для каждой библиотеки создает отдельную таблицу в новой целевой базе данных с информацией о параметрах и моделях, извлеченной из содержащихся в ней компонентов. Затем создается указанный файл библиотеки базы данных SVN, который обеспечивает подключение к этой базе данных. Входящие в состав интегрированной библиотеки библиотеки схемных символов и посадочных мест разделяются и фиксируются в указанных каталогах выбранного репозитория системы контроля версий SVN; ссылки на эти каталоги сохраняются в файле SVNDbLib.

Преобразование поддерживает только базы данных Access.

Перенос одной или нескольких исходных интегрированных библиотек в структуру библиотеки базы данных SVN — это простой процесс, выполняемый с помощью SVN Database Library Conversion Wizard.Перенос одной или нескольких исходных интегрированных библиотек в структуру библиотеки базы данных SVN — это простой процесс, выполняемый с помощью SVN Database Library Conversion Wizard.

Процесс включает следующие шаги:

  1. Откройте SVN Database Library Conversion Wizard. Для этого:
  • Выберите команду Tools » SVN Database Library Maker в главном меню редактора библиотек схемных символов, редактора библиотек посадочных мест или редактора библиотек баз данных.
  • На панели Projects щелкните правой кнопкой мыши запись библиотеки проекта (SchLib, PcbLib или IntLib), затем выберите команду SVN Database Library Maker в контекстном меню.
  1. На странице Libraries to Convert укажите интегрированные библиотеки, которые требуется преобразовать. Изначально список будет содержать одну или несколько библиотек (активную библиотеку или все библиотеки, добавленные в проект, в зависимости от способа открытия мастера). Удалите их из списка, прежде чем выбирать интегрированные библиотеки для преобразования. Нажмите кнопку Add, чтобы открыть диалоговое окно Library Files, в котором можно найти и выбрать нужные интегрированные библиотеки.
  2. На странице Options задайте параметры преобразования: способ разделения исходных библиотек, репозиторий и каталоги для их хранения, а также выходной каталог для файла SVNDbLib. Для библиотеки схемных символов также доступны два параметра, позволяющие удалить информацию о параметрах и/или моделях из каждого компонента, оставив только символ.

    Репозиторий SVN и структура его папок должны быть созданы заранее. Вы лишь указываете репозиторий и папки в его структуре, в которых будут храниться файлы разделенных библиотек. Репозиторий и папки не создаются автоматически в процессе преобразования.
  3. Выбрав исходные интегрированные библиотеки и настроив необходимые параметры преобразования, нажмите Next , чтобы начать преобразование. Отобразится индикатор выполнения и информация о библиотеке, которая преобразуется в данный момент. Процесс преобразования включает:
    1. Извлечение исходных библиотек из выбранных интегрированных библиотек.
    2. Разделение библиотек схемных символов и посадочных мест на файлы библиотек, содержащие по одному символу или посадочному месту.
    3. Фиксацию разделенных библиотек символов и посадочных мест в репозитории в указанных базовых каталогах.
    4. Мастер извлекает только сведения о ссылках на модели посадочных мест. Связанные модели моделирования поддерживаются библиотеками баз данных с контролем версий (SVNDbLib), однако хранение файлов моделей моделирования в репозитории Subversion не поддерживается. Если такие ссылки существуют, они будут добавлены как параметры.
    5. Создание отдельной таблицы в формируемой базе данных Access (с тем же именем, которое указано для SVNDbLib) для каждой преобразуемой интегрированной библиотеки, включая информацию о параметрах и моделях, извлеченную из ее компонентов. Имя каждой таблицы формируется из имени интегрированной библиотеки с суффиксом _IntLib (например, Capacitor - Ceramic_IntLib).
    6. Создание указанного файла SVNDbLib с подключением к базе данных и репозиторию.
  4. После завершения преобразования нажмите Finish , чтобы закрыть мастер и сделать файл SVNDbLib активным документом.

Итоговый файл SVNDbLib после завершения преобразования.Итоговый файл SVNDbLib после завершения преобразования.

Убедитесь, что компоненты библиотеки схемных символов в IntLib не содержат параметр Part Number. Информация Part Number, записываемая в базу данных (для идентификации каждой записи компонента), берется из поля Design Item ID схемного компонента в разделе Properties на вкладке General панели Properties при просмотре свойств выбранного библиотечного компонента. Если добавить ее еще и в качестве параметра, преобразование завершится ошибкой из-за дублирующихся значений.

Создание интегрированной библиотеки из библиотеки базы данных

Библиотеки баз данных — идеальный выбор, если требуется тесно связать компоненты Altium Design с базой данных вашей компании. Если проект необходимо передать за пределы компании или вы предпочитаете, чтобы разработчики работали с защищенными интегрированными библиотеками, это легко организовать. Программное обеспечение позволяет скомпилировать интегрированную библиотеку непосредственно из библиотеки базы данных — как стандартной (DbLib), так и библиотеки базы данных SVN с контролем версий (SVNDbLib). Таким образом, специалисты по ведению библиотек САПР могут по-прежнему использовать библиотеки баз данных, а разработчики — регулярно обновляемые интегрированные библиотеки, работая, по сути, в автономном режиме.

Преобразование выполняется с помощью Offline Integrated Library Maker. Процесс выполняется отдельно для каждой таблицы базы данных, при этом можно полностью контролировать, какие таблицы будут обрабатываться. В преобразование включаются схемные компоненты, модели PCB, PCB3D и модели моделирования. Для каждой включенной таблицы создается отдельная интегрированная библиотека. Эти таблицы преобразуются в отдельные интегрированные библиотеки, которые затем добавляются в Installed Libraries.

Преобразуйте библиотеки баз данных (DbLib или SVNDbLib) в автономные интегрированные библиотеки с помощью Offline Integrated Library Maker.
Преобразуйте библиотеки баз данных (DbLib или SVNDbLib) в автономные интегрированные библиотеки с помощью Offline Integrated Library Maker.

Процесс включает следующие шаги:

  1. Откройте файл библиотеки базы данных (*.DbLib) или файл библиотеки базы данных SVN (*.SVNDbLib), который требуется преобразовать, и сделайте его активным документом. Затем выберите команду Tools » Offline Integrated Library Maker в главном меню, чтобы открыть Offline Integrated Library Maker.
  2. На странице Library to Convert укажите DbLib или SVNDbLib для обработки. По умолчанию для преобразования выбирается активная библиотека, из которой был открыт Offline Integrated Library Maker . При необходимости можно найти и выбрать другую библиотеку базы данных.

  3. На странице Options укажите, какие таблицы связанной базы данных следует включить в преобразование. По умолчанию включены все таблицы базы данных. Чтобы исключить таблицу, отключите соответствующий параметр Convert . На этой странице также можно указать выходной каталог, в котором будут сохранены созданные интегрированные библиотеки. Введите путь к этому базовому каталогу непосредственно в поле или нажмите значок Browse icon справа от поля, чтобы открыть диалоговое окно, в котором можно найти и выбрать нужный каталог. Результат преобразования (интегрированная библиотека) для каждой включенной таблицы базы данных будет сохранен в отдельной подпапке указанного выходного каталога; имя подпапки соответствует имени таблицы.

  4. Выбрав библиотеку базы данных и настроив необходимые параметры преобразования, нажмите Next , чтобы начать преобразование. Отобразится индикатор выполнения с информацией о текущей преобразуемой таблице базы данных. Помните, что преобразование выполняется для каждой выбранной таблицы базы данных. Ниже приведены основные этапы этого процесса:
    1. Создается пакет интегрированной библиотеки (*.LibPkg), который открывается на панели Projects. Пакету присваивается имя таблицы. Например, для таблицы с именем Capacitor - Ceramic пакет будет называться Capacitor - Ceramic.LibPkg.
    2. Создается документ библиотеки схемных символов и добавляется в LibPkg. Ему также присваивается имя таблицы (например, Capacitor - Ceramic.SchLib).
    3. Затем обрабатывается каждая запись таблицы и создается соответствующий компонент Altium Design. Для этого схемный символ, на который ссылается запись, извлекается из соответствующей исходной библиотеки и добавляется в новый документ библиотеки схемных символов в качестве компонента. Затем к этому компоненту добавляются параметры и сведения о связях с моделями, заданные в записи.
    4. Модели посадочных мест, на которые ссылается запись, извлекаются и добавляются в документ библиотеки посадочных мест. Этому документу также присваивается имя таблицы (например, Capacitor - Ceramic.PcbLib). Затем документ библиотеки посадочных мест добавляется в LibPkg.
    5. Если исходная библиотека имеет формат DbLib и в записи базы данных заданы связи с моделями моделирования, файлы этих моделей также добавляются в LibPkg. Расположение таких моделей остается неизменным. Полный путь к модели указывается в соответствующей связи с моделью.
    6. Затем LibPkg компилируется для получения интегрированной библиотеки (например, Capacitor - Ceramic.IntLib), которая впоследствии добавляется в список установленных библиотек программы.

Список установленных библиотек можно просмотреть на вкладке Installed диалогового окна Available File-based Libraries. Чтобы открыть его, нажмите кнопку Open Libraries dialogs in Components Panel в правом верхнем углу панели Components и выберите File-based Libraries Preferences.

Результаты преобразования — проекты пакетов библиотек с входящими в них документами символов и моделей посадочных мест, а также скомпилированные библиотеки IntLib, которые добавляются в список установленных библиотек и становятся доступны во всех проектах печатных плат.
Результаты преобразования — проекты пакетов библиотек с входящими в них документами символов и моделей посадочных мест, а также скомпилированные библиотеки IntLib, которые добавляются в список установленных библиотек и становятся доступны во всех проектах печатных плат.

Создание SVNDbLib из исходных библиотек (SCHLib/PCBLib)

Мастер SVN Database Library Conversion Wizard помогает преобразовать библиотеки схемных символов, посадочных мест, базы данных и интегрированные библиотеки в библиотеки базы данных SVN. Этот мастер упрощает переход от различных способов управления компонентами к библиотеке базы данных SVN (*.SVNDBLib). Библиотека базы данных SVN расширяет возможности размещения компонентов непосредственно из базы данных, позволяя использовать библиотеки под управлением системы контроля версий: схемные символы и модели посадочных мест хранятся в репозитории Subversion. Связь с репозиторием и внешней базой данных задается в файле библиотеки базы данных SVN (*.SVNDBLib), который является расширением файла библиотеки базы данных (*.DBLib) и часто называется Version-Controlled Database Library.

С помощью мастера задайте параметры преобразования, в том числе способ разделения исходных библиотек, каталоги и репозиторий для их хранения, а также выходной каталог для файла SVNDBLib. 

Необходимо выбрать библиотеки базы данных, схемных символов (*.SchLib), посадочных мест (*.PcbLib) или интегрированные библиотеки (*.IntLib), которые нужно преобразовать и затем поместить в репозиторий SVN. Также будет создана единая библиотека базы данных SVN. 

В этом мастере можно настроить подключение к репозиторию SVN, базовый каталог для символов и моделей, а также путь к документу библиотеки базы данных SVN. По умолчанию в качестве выходного каталога используется каталог, в котором хранится исходная библиотека.

Если вы хотите, чтобы созданный файл SVNDBLib и база данных находились в одном каталоге, есть два основных варианта. Первый — указать в качестве выходного каталога для SVNDBLib тот каталог, в котором сейчас находится база данных. Второй — создать SVNDBLib в другом каталоге, а затем переместить туда базу данных. В этом случае не забудьте изменить настройки подключения в файле SVNDBLib, указав новое расположение базы данных, и подключиться заново.

  • Поскольку файлы разделенных библиотек будут добавлены в репозиторий SVN, необходимо заранее, вне мастера, создать на локальном жестком диске нужную структуру папок для файлов символов и моделей. Управление структурой папок в репозитории выполняется с помощью SVN-клиента, например TortoiseSVN.
  • Вам необходимы репозиторий SVN и система контроля версий SVN, установленные на вашем компьютере или доступные по сети. Также убедитесь, что для параметра Provider на странице Data Management - Version Control диалогового окна Preferences задано значение SVN - Subversion.
  • Преобразование поддерживает только базы данных типа Access.

SVN Database Library Conversion WizardС помощью SVN Database Library
Conversion
Wizard можно легко включить одну или несколько исходных библиотек схемных символов и посадочных мест в структуру библиотеки базы данных SVN.

Процесс включает следующие шаги:

  1. Откройте SVN Database Library Conversion Wizard одним из следующих способов:

    • Выберите Tools » SVN Database Library Maker в файле библиотеки схемных символов (*.SchLib), библиотеки посадочных мест (*.PcbLib), интегрированной библиотеки (*.IntLib) или библиотеки базы данных (*.DbLib). Однако, если при запуске мастера из библиотеки схемных символов вы хотите включить в преобразование связанные модели посадочных мест, необходимо найти и добавить соответствующие библиотеки посадочных мест. Кроме того, преобразование только библиотек посадочных мест не является типовым сценарием, поэтому потребуется найти и добавить соответствующие библиотеки схемных компонентов.
    • На панели Projects щелкните правой кнопкой мыши запись нужной библиотеки (*.SchLib, *.PcbLib или *.IntLib) и выберите SVN Database Library Maker. Мастер автоматически загрузит все библиотеки проекта. Это самый простой способ, но для него исходные библиотеки схемных символов и посадочных мест должны быть добавлены в проект. Такая ситуация встречается довольно часто, если интегрированные библиотеки не используются.
    Мастер предварительно заполняет список библиотек в зависимости от того, откуда он запущен. Поэтому для экономии времени запускайте мастер из соответствующего редактора, как описано ниже.

  2. На странице Libraries to Convert выберите библиотеки для преобразования. Можно выбрать библиотеки базы данных либо библиотеки схемных символов, посадочных мест и интегрированные библиотеки. Выбранные библиотеки будут разделены на отдельные библиотеки компонентов и затем помещены в репозиторий SVN. Будет создана единая база данных SVN.

    • Converting a Database Library

      При преобразовании Database Libraries выполняются следующие действия:

      1. Разделение библиотек символов и посадочных мест на отдельные файлы библиотек с одним символом или посадочным местом. Исходные библиотеки указаны в записях компонентов связанной базы данных.
      2. Фиксация полученных библиотек символов и посадочных мест в репозитории, в указанных базовых каталогах.
      3. Создание указанного файла SVNDBLib и его подключение к базе данных и репозиторию.
    • Converting Schematic, PCB, and Integrated Libraries

      Нажмите кнопку Add, чтобы открыть стандартное диалоговое окно для поиска и выбора добавляемого файла. Нажмите кнопку Remove , чтобы удалить выбранную библиотеку.

      При преобразовании библиотек символов, посадочных мест и интегрированных библиотек выполняются следующие действия:

      1. Извлечение исходных библиотек из всех предоставленных интегрированных библиотек.
      2. Разделение библиотек символов и посадочных мест на отдельные файлы библиотек с одним символом или посадочным местом.
      3. Фиксация полученных библиотек символов и посадочных мест в репозитории в указанных базовых каталогах.
      4. Мастер извлекает только сведения о ссылках на модели посадочных мест. Связанные модели PCB3D и модели моделирования не поддерживаются в SVNDBLib. Если такие ссылки существуют, они будут добавлены в виде параметров.
      5. Создание отдельной таблицы в формируемой базе данных Access для каждой преобразуемой библиотеки символов и/или интегрированной библиотеки со всеми сведениями о параметрах и моделях, извлечёнными из компонентов. Каждая таблица получает имя библиотеки символов с суффиксом _SchLib (например, Mixer_SchLib) и/или имя интегрированной библиотеки с суффиксом _IntLib (например, AD Differential Amplifier_IntLib).
      6. Создание указанного файла SVNDBLib и его подключение к базе данных и репозиторию.
  3. На странице Options задайте параметры преобразования, включая способ разделения исходных библиотек, репозиторий и каталоги для их хранения, а также выходной каталог для файла SVNDbLib. Для библиотеки символов также предусмотрены две опции, позволяющие удалить сведения о параметрах и/или моделях из каждого компонента, оставив только сам символ.

    Репозиторий SVN и его структура папок должны быть созданы заранее. Вы лишь указываете репозиторий и папки в его структуре, в которых будут храниться файлы разделённых библиотек. Репозиторий и папки не создаются в процессе преобразования.

    SVN Options

    В этой области задайте параметры подключения к репозиторию SVN. 

    В раскрывающемся списке Method выберите способ подключения: file (файловый репозиторий), http (облачный репозиторий), https (защищённый облачный репозиторий), svn или svn+ssh. 

    Область Location  (доступна, только если для Method выбрано file) используется для указания пути к репозиторию. Нажмите значок выбора папки, чтобы найти и выбрать нужное расположение. 

    Область Server (доступна, только если для Method выбрано file not) используется для указания нужного сервера.

    Задайте для Server Port значение Default или Non-Default. Если выбрано Non-Default, введите порт сервера в текстовом поле. Также потребуется ввести имя Repository folder в текстовом поле.

    Server Port и Repository folder доступны, только если для Method выбрано not file. 

    Укажите базовые каталоги репозитория для Symbols и Footprints, нажав ..., чтобы найти и выбрать нужную папку для каждого из них.

    SVN DB Library Options

    В области SVN DB Library Options можно указать путь к документу библиотеки базы данных SVN. Если связанная база данных Access ещё не существует, она будет создана в той же папке. Нажмите значок выбора папки, чтобы найти и выбрать путь.

    Если вы хотите разместить создаваемый файл SVNDBLib и базу данных в одной папке, есть два основных варианта. Первый — указать в качестве выходного пути для SVNDBLib каталог, в котором уже находится база данных. Второй — создать SVNDBLib в другом каталоге, а затем переместить в него базу данных. В этом случае не забудьте изменить параметры подключения в файле SVNDBLib, указав новое расположение базы данных, и подключиться повторно.

    Library Splitting Options

    В раскрывающемся списке выберите для файлов Overwrite Existing Files или Append Incrementing Number To File Names (чтобы при разделении библиотек создавались новые файлы с суффиксом в имени). Если выбрано Overwrite Existing Files, все существующие файлы в репозиториях будут перезаписаны при разделении библиотек. Если выбрано Append Incrementing Number To File Names, все файлы в указанных репозиториях будут защищены от перезаписи, а к именам новых библиотек компонентов, совпадающим с существующими, будет добавлен суффикс «_#IncrementNumber».

    Для библиотеки символов также предусмотрены две опции, позволяющие удалить сведения о параметрах и/или моделях из компонентов после разделения, оставив только сами символы. Выберите Remove All Parameters и/или Remove All Models. Поскольку внешняя база данных уже существует и связана с исходным файлом DBLib, новая база данных создаваться не будет. База данных останется в текущем расположении.

  4. Выбрав исходные библиотеки символов и посадочных мест и настроив необходимые параметры преобразования, нажмите Next , чтобы начать преобразование. Появится индикатор выполнения и информация о преобразуемой в данный момент библиотеке. Процесс преобразования включает следующие действия:
    1. Разделение библиотек символов и посадочных мест на отдельные файлы библиотек с одним символом или посадочным местом.
    2. Фиксация полученных библиотек символов и посадочных мест в репозитории, в указанных базовых каталогах.
    3. Мастер извлекает только сведения о ссылках на модели посадочных мест. Связанные модели моделирования поддерживаются в библиотеке базы данных с контролем версий (SVNDbLib), однако хранение файлов моделей моделирования в репозитории Subversion не поддерживается. Если такие ссылки существуют, они будут добавлены в виде параметров.
    4. Создание отдельной таблицы в формируемой базе данных Access (с тем же именем, которое указано для SVNDbLib) для каждой преобразуемой библиотеки символов со всеми сведениями о параметрах и моделях, извлечёнными из её компонентов. Каждая таблица получает имя библиотеки символов с суффиксом _SchLib (например, Capacitor - Ceramic_SchLib).
    5. Создание указанного файла SVNDbLib и его подключение к базе данных и репозиторию.
  5. После завершения преобразования нажмите Finish , чтобы закрыть мастер и сделать файл SVNDbLib активным документом.

Полученный файл SVNDbLib после завершения преобразования.Полученный файл SVNDbLib после завершения преобразования.

Убедитесь, что компоненты вашей библиотеки схем не содержат параметра Part Number. Данные Part Number, вводимые в базу данных для идентификации каждой записи компонента, берутся из поля Design Item ID компонента схемы в разделе Properties на вкладке General панели Properties при просмотре свойств выбранного библиотечного компонента. Если также добавить эти данные в виде параметра, преобразование завершится с ошибкой из-за дублирования значений. Хотя процесс будет завершен, компоненты схемы, содержащие этот параметр, не будут созданы в базе данных и, следовательно, не появятся в списке компонентов базы данных на вкладке Table Browser документа SVNDbLib.

Преобразование DbLib в SVNDbLib

Возможно, вы уже используете возможности библиотек баз данных, преобразовав существующие интегрированные библиотеки в структуру DbLib или создав DbLib с нуля. Следующим шагом может стать перенос исходных библиотек символов и посадочных мест в защищенный репозиторий системы управления версиями. Программное обеспечение предоставляет средства для такого перехода от существующей стандартной библиотеки базы данных (DbLib) к библиотеке базы данных с управлением версиями (SVNDbLib).

Преобразование выполняется с помощью SVN Database Library Conversion Wizard практически так же, как и при преобразовании интегрированной библиотеки.

SVN Database Library Conversion WizardПреобразование существующей стандартной библиотеки базы данных (DbLib) в библиотеку базы данных с управлением версиями (SVNDbLib) — это простой процесс, выполняемый с помощью SVN Database
Library Conversion Wizard
.

Процесс включает следующие шаги:

  1. Откройте существующую библиотеку DbLib, которую требуется преобразовать, затем выберите Tools » SVN Database Library Maker в главном меню. Откроется SVN Database Library Conversion Wizard.
  2. На странице Libraries to Convert укажите исходную библиотеку базы данных, которую требуется преобразовать. Параметр Database Libraries уже будет включен, а в соответствующем поле будет указан путь к активной библиотеке. Если требуется преобразовать другую библиотеку DbLib, нажмите кнопку Browse icon и выберите ее в открывшемся диалоговом окне.
  3. После нажатия Next выбранный файл DbLib будет проанализирован, и появится диалоговое окно подтверждения с уведомлением о том, что связанная база данных может быть изменена. Нажмите Yes , чтобы продолжить.
  4. На странице Options задайте параметры преобразования, в том числе способ разделения исходных библиотек, каталоги и репозиторий для их хранения, а также выходной каталог для файла SVNDbLib. Для библиотеки схем также предусмотрены два параметра, позволяющие удалить сведения о параметрах и/или моделях из каждого входящего в нее компонента, оставив только символ.
Репозиторий SVN и его структура папок должны быть созданы заранее. Вы лишь указываете репозиторий и папки в его структуре, в которых будут храниться файлы разделенных библиотек. Репозиторий и папки не создаются в процессе преобразования.
Поскольку внешняя база данных уже существует и связана с исходным файлом DbLib, новая база данных создаваться не будет. База данных останется в текущем расположении. Если требуется разместить созданный файл SVNDbLib и базу данных в одном месте, есть два основных варианта. Первый — указать в качестве выходного каталога для SVNDbLib тот же каталог, в котором сейчас находится база данных. Второй — создать SVNDbLib в другом каталоге, а затем переместить в него базу данных. В этом случае не забудьте изменить настройки подключения в файле SVNDbLib, указав новое расположение базы данных, и повторно подключиться к ней.
  1. Выбрав исходный файл DbLib и задав необходимые параметры преобразования, нажмите Next , чтобы начать преобразование. Появится индикатор выполнения и информация о преобразуемой библиотеке. Процесс преобразования включает следующие операции:
    1. Разделение библиотек схем и печатных плат, на которые ссылаются записи компонентов в связанной базе данных, на библиотечные файлы, содержащие по одному символу или посадочному месту.
    2. Добавление разделенных библиотек символов и посадочных мест в репозиторий в указанные базовые каталоги.
    3. Создание указанного файла SVNDbLib и подключение к базе данных и репозиторию.
  2. После завершения преобразования нажмите Finish , чтобы закрыть мастер и сделать файл SVNDbLib активным документом.

Итоговый файл SVNDbLib после завершения преобразования.Итоговый файл SVNDbLib после завершения преобразования.

О сопоставлении полей

В созданной библиотеке SVNDbLib сопоставления полей базы данных с параметрами проекта, заданные на вкладке Field Mappings, остаются такими же, какими они были в исходной библиотеке DbLib.

Сопоставления полей в исходной библиотеке DbLib и созданной библиотеке SVNDbLib остаются одинаковыми.Сопоставления полей в исходной библиотеке DbLib и созданной библиотеке SVNDbLib остаются одинаковыми.

Однако следует обратить внимание на два важных момента:

  • Все заданные сопоставления путей к символам и моделям посадочных мест игнорируются. Для поиска нужного символа и посадочного места в библиотеках, добавленных в репозиторий, SVNDbLib использует только сопоставленные поля ссылок — [Library Ref] и [Footprint Ref]. Сведения о путях, заданные в базе данных, игнорируются, поскольку они указывают на библиотеки, расположенные на жестком диске или другом локальном либо сетевом носителе.
Если вы все же хотите хранить сведения о путях в базе данных, измените их так, чтобы они указывали на библиотеки в репозитории. Стоит помнить, что отсутствие сведений о путях к библиотекам в базе данных делает ее значительно устойчивее к изменениям. Расположение репозитория и/или его внутренняя структура папок могут измениться, и при этом обновлять базу данных не потребуется.
  • Все заданные сопоставления моделей моделирования также сохранятся в файле SVNDbLib. Однако хранение файлов моделей моделирования в репозитории Subversion не поддерживается. Хотя ссылки на модели будут добавлены в экземпляр компонента при его размещении, сами модели найдены не будут.

Прямая поддержка OrCAD® CIS

Программное обеспечение, основанное на системе библиотек баз данных, обеспечивает полную поддержку подключения к существующим системам информации о компонентах OrCAD (CIS) и их использования. По сути, структура CIS преобразуется в структуру стандартной библиотеки базы данных Altium Designer (DbLib).

Из OrCAD в Altium Designer — необходимые преобразования

Для обеспечения возможности размещать компоненты непосредственно из внешней базы данных (*.mdb, *.xls) необходимо преобразовать следующие файлы:

  • Файл конфигурации OrCAD CIS (*.dbc), который обеспечивает связь с внешней базой данных и содержит сведения о сопоставлении полей базы данных с параметрами проекта, необходимо преобразовать в файл библиотеки базы данных Altium Designer (*.DbLib).
В настоящее время Altium Designer поддерживает только файлы .dbc OrCAD CIS в двоичном формате.
  • Соответствующие файлы библиотек OrCAD необходимо преобразовать в файлы библиотек Altium Designer:
    • Библиотека OrCAD Capture (*.olb) ---> Библиотека схем (*.SchLib).
    • Файл библиотеки OrCAD Max (*.llb) ---> Библиотека печатных плат (*.PcbLib).

Автоматическое создание библиотеки базы данных

Самый простой и эффективный способ создать файл DbLib и исходные библиотеки Altium Designer — использовать мастер импорта (File » Import Wizard). На второй странице мастера убедитесь, что в качестве типа импортируемых файлов выбран пункт OrCAD CIS Configuration Files and Libraries.

Используйте Import Wizard, чтобы быстро преобразовать файл конфигурации CIS и связанные библиотеки OrCAD в файл DbLib и файлы исходных библиотек (SchLib и PcbLib) Altium Designer.
Используйте Import Wizard, чтобы быстро преобразовать файл конфигурации CIS и связанные библиотеки OrCAD в файл DbLib и файлы исходных библиотек (SchLib и PcbLib) Altium Designer.

Используйте Import Wizard, чтобы быстро преобразовать файл конфигурации CIS и связанные библиотеки OrCAD в файл DbLib и файлы исходных библиотек (SchLib и PcbLib) Altium NEXUS.
Используйте Import Wizard, чтобы быстро преобразовать файл конфигурации CIS и связанные библиотеки OrCAD в файл DbLib и файлы исходных библиотек (SchLib и PcbLib) Altium NEXUS.

На последующих страницах мастера необходимо указать:

  • Расположение внешней базы данных.
  • Расположение файла конфигурации CIS (*.dbc) — помните, что он должен быть в двоичном формате, а не в формате XML.
  • Расположение и имя, под которым будет создан целевой файл DbLib.
  • Библиотеки символов схем и/или посадочных мест OrCAD, на которые ссылается внешняя база данных.
При указании исходных библиотек OrCAD можно также выбрать место сохранения полученных библиотек Altium Designer. По умолчанию эти библиотеки сохраняются во вложенную папку \Libraries, расположенную в том же каталоге, что и целевой файл DbLib.

На страницах мастера укажите базу данных, файл конфигурации CIS, исходные библиотеки OrCAD и целевой файл DbLib.
На страницах мастера укажите базу данных, файл конфигурации CIS, исходные библиотеки OrCAD и целевой файл DbLib.

На страницах мастера укажите базу данных, файл конфигурации CIS, исходные библиотеки OrCAD и целевой файл DbLib.
На страницах мастера укажите базу данных, файл конфигурации CIS, исходные библиотеки OrCAD и целевой файл DbLib.

Указав необходимые исходные и целевые файлы и каталоги, нажмите Next, чтобы начать импорт. После завершения импорта нажмите Finish , чтобы закрыть мастер и сделать файл DbLib активным документом.

Полученный файл DbLib после завершения импорта.
Полученный файл DbLib после завершения импорта.

Полученный файл DbLib после завершения импорта.
Полученный файл DbLib после завершения импорта.

Следует учитывать:

  • На вкладке Symbol & Model Search Paths диалогового окна «Параметры библиотеки базы данных» в файл DbLib автоматически добавляется путь поиска библиотек, указывающий на каталог с преобразованными файлами библиотек.
  • Информация о сопоставлении параметров, включая заданный ключ поиска, берётся непосредственно из файла конфигурации OrCAD CIS.
  • Автоматически задаются две записи сопоставления моделей. Примеры имён полей базы данных для этих записей и назначенных им значений Design Parameter:
    • Footprint Name ---> [Orcad Footprint]
    • Symbol Name ---> [Orcad Library]

Эти записи обеспечивают связь с исходным символом схемы для конкретной записи компонента во внешней базе данных и с соответствующей моделью посадочного места на плате, связанной с этим компонентом.

Создание библиотеки базы данных вручную

  1. Создание файла DbLib с помощью Import Wizard — самый быстрый, но не единственный способ. Файл DbLib можно также создать вручную. Для этого:
  2. Создайте новый файл DbLib, подключите его к внешней базе данных и задайте необходимые настройки сопоставления и обновления параметров.
  3. Затем необходимо импортировать библиотеки OrCAD. Для этого можно использовать Import Wizard, чтобы преобразовать файлы библиотек OrCAD (*.olb, *.llb) в библиотеки Altium Designer (*.SchLib, *.PcbLib).
    1. При выборе типов файлов для импорта выберите пункт OrCAD Designs and Libraries Files.

    2. Пропустите страницу Importing OrCAD Designs и перейдите к странице Importing OrCAD Libraries. Добавьте все исходные библиотеки OrCAD, на которые ссылается база данных.

    3. Пропустите последующие страницы, относящиеся к импорту файлов проекта.

    4. На странице Output Library Options оставьте включённым параметр по умолчанию Output Libraries as PCB Project.

    5. На странице Output Libraries укажите выходной каталог для создаваемых файлов библиотек.

Импорт исходных библиотек OrCAD, содержащих символы и посадочные места, на которые ссылается база данных.
Импорт исходных библиотек OrCAD, содержащих символы и посадочные места, на которые ссылается база данных.

Импорт исходных библиотек OrCAD, содержащих символы и посадочные места, на которые ссылается база данных.
Импорт исходных библиотек OrCAD, содержащих символы и посадочные места, на которые ссылается база данных.

  1. После завершения импорта в указанном каталоге будет создана папка с именем Imported OrCAD Libraries.PrjPcb. При необходимости созданные библиотеки Altium Designer можно переместить в другое место. Например, можно переместить библиотеки в папку с именем Libraries, созданную в каталоге, содержащем файл DbLib.
  2. После получения библиотек символов и посадочных мест вернитесь к файлу DbLib и настройте пути поиска библиотек (на вкладке Symbol & Model Search Paths диалогового окна «Параметры библиотеки базы данных»), указав папку, в которой хранятся эти библиотеки.
AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Contents