Настройка связи с данными от поставщиков

Краткий обзор

Получайте актуальную информацию от поставщиков при проектировании с использованием библиотек компонентов на основе баз данных и файлов в Altium Designer. В этой статье рассматривается доступ к данным поставщиков при работе с SchLib, DbLib и SVNDbLib, объясняется, как настроить предпочтения поставщиков, и описывается панель Manufacturer Part Search для поиска компонентов и просмотра информации о ценах, складских запасах и жизненном цикле. Читайте дальше, чтобы принимать более обоснованные решения о закупке компонентов в процессе проектирования.

- Настройте предпочтительных поставщиков, географические регионы и валюты для поиска компонентов.
- Используйте ключевые слова, категории и параметрические фильтры для поиска подходящих компонентов производителей.
- Просматривайте цены поставщиков, сведения о наличии и характеристики компонентов, чтобы обоснованно выбирать и закупать их.
Узнайте больше с ИИ:

Altium Designer позволяет связывать компоненты проекта с реальными изделиями, обеспечивая доступ к актуальным данным поставщиков в процессе проектирования. Благодаря прямому подключению к веб-сервисам Altium с данными о компонентах вы можете искать изделия производителей и выбирать поддерживаемых поставщиков, предлагающих эти изделия. Затем эти актуальные данные поставщиков можно использовать в процессе проектирования — при разработке библиотек, в ходе работы над проектом и при его выпуске. Иными словами, эта функция позволяет обращаться к базам данных поставщиков непосредственно из Altium Designer, выполняя поиск и выбор компонентов производителей.

Связанные данные об изделии и поставщике также включаются или могут быть добавлены в спецификацию при выпуске проекта — это особенно полезно для расчета стоимости проекта и организации закупок.

Для связывания с данными поставщиков not требуется вход в учетную запись Altium. Поиск изделий производителей и поставщиков выполняется через веб-сервисы Altium. Однако при отображении цен в других валютах курсы пересчета обновляются ежедневно при условии, что вы are вошли в свою учетную запись.

В этом документе рассматривается связывание с данными поставщиков при использовании методов управления компонентами, в которых основой хранения компонентов служат SchLib, DbLib или SVNDbLib. Если вы используете подключенное рабочее пространство и компоненты рабочего пространства, аналогичная, но принципиально иная и более мощная связь между компонентом проекта и цепочкой поставок реализуется с помощью вариантов выбора изделий (Part Choices). Если в Altium Designer включена функция Custom Parts Provider Synchronization (подробнее об изменении установленного базового функционала см. на Installing & Managingстранице (Altium Designer Develop, Altium Designer Agile, Altium Designer)), подключенное рабочее пространство предоставляет интерфейс к любому подключению к базе данных изделий, настроенному в этом рабочем пространстве, например к внутренней базе данных изделий компании (напрямую либо через интерфейс ODBC или OLE-DB). Для доступа к этим данным о компонентах необходимо подключиться к рабочему пространству. Таким образом, этот функционал недоступен при использовании файловых методов управления компонентами и не связан с возможностью привязки к данным поставщиков в рамках таких методов.

Подробнее о централизованной настройке поставщиков в составе установленного Altium On-Prem Enterprise Server, включая настройку интерфейса к базе данных изделий, см. в разделе Настройка источников изделий.

Настройки поставщиков

Страница Data Management – Parts Providers диалогового окна Preferences служит основным центром настройки поставщиков, доступных при поиске данных об изделиях, а также других параметров связывания с данными поставщиков.

Настройте параметры функции связывания с данными поставщиков в настройках Altium Designer.
Настройте параметры функции связывания с данными поставщиков в настройках Altium Designer.

Используйте раздел Altium Parts Options этой страницы, чтобы настроить сервис в соответствии со своими потребностями.

Доступны следующие параметры:

  • Location — выберите географические регионы, из которых сервис будет собирать данные об изделиях. Хотя многие поставщики работают в нескольких регионах, изделие, доступное только в определенном регионе, будет отображаться лишь в том случае, если этот регион включен. Перетаскивайте записи регионов в списке, чтобы задать порядок их приоритета.

  • Currency — выберите валюты, которые будут доступны при поиске изделий и просмотре результатов. Перетаскивайте значки валют в списке, чтобы задать порядок их приоритета.

  • Supplier — выберите поставщиков, которых следует учитывать при поиске данных поставщиков. В результаты будут включены только изделия этих поставщиков. Добавляя больше поставщиков для использования с этой функцией, вы сможете сравнивать предложения и выбирать наиболее выгодные условия для компонентов, необходимых в вашем проекте. Символ в столбце Verified для поставщика означает, что Altium Parts Provider получает данные непосредственно от этого поставщика.

Обратите внимание: если вы вошли на сервер, область Altium Parts Options становится доступной только для чтения и использует настройки, заданные на сервере. На это указывает значок рядом с названием страницы в дереве навигации.

Поиск данных поставщиков компонентов

Основной интерфейс для доступа к доступным изделиям производителей и связанным с ними актуальным данным поставщиков — панель Manufacturer Part Search. Эта панель предоставляет развитые средства поиска и подбора изделий по категориям и параметрам, а также служит прямым порталом к реальным изделиям, предлагаемым различными поставщиками, которых вы включили для использования с этой функцией. Чтобы открыть панель, выберите View » Panels » Manufacturer Part Search в главном меню или пункт Manufacturer Part Search в меню кнопки в правом нижнем углу главного окна.

Ищите реальные изделия поставщиков с помощью панели Manufacturer Part Search.Ищите реальные изделия поставщиков с помощью панели Manufacturer Part Search.

Как показано на иллюстрации, панель разделена на три основных функциональных раздела:

  • Component Search, Type and Filtering:
    • В верхнем поле Search введите одно или несколько ключевых слов, относящихся к нужному компоненту. Результаты поиска содержат ссылки на поставщиков для каждого найденного изделия производителя.
    • Используйте раскрывающийся список Categories (), чтобы ограничить результаты выбранным типом компонентов.
    • Отметьте нужные значения параметров в области Filters слева (она включается значком ), чтобы отфильтровать результаты и оставить только компоненты, соответствующие этим значениям.
Все перечисленные функции можно использовать совместно, чтобы быстро и точно найти нужные компоненты и связанные с ними актуальные данные поставщиков.
  • Search Results:
    • В этой центральной области панели отображаются все изделия производителей, соответствующие текущим критериям поиска, категории и фильтрам. Столбец Supply Info содержит сводные данные о поставках для каждой записи: цену за единицу, минимальное количество заказа (MOQ) и доступный складской остаток у наиболее подходящего поставщика. Цветная полоска рядом с каждым изделием производителя позволяет быстро оценить стадию его жизненного цикла: например, зеленый цвет указывает, что изделие подходит для серийного производства, а красная полоска обозначает устаревшее изделие.
    • В выбранной записи изделия в столбце Manufacturer Part отображается ссылка на данные поставщиков (например, 9 SPNs), которая открывает горизонтальный список плиток с вариантами поставки этого изделия производителя. Каждая плитка в этом списке относится к определенному поставщику и содержит краткие актуальные сведения о складском остатке, ценах и артикуле изделия у поставщика. О том, как эти данные применяются к компонентам проекта, см. ниже в разделе Связывание с изделием поставщика.
    • Настройки панели, доступные через  кнопки в правом верхнем углу панели настройте отображение данных результатов поиска:
      • Currency меню — валюта, используемая для отображения цен на панели, определяется приоритетом валют, заданным на странице Управление данными — Поставщики компонентов. Чтобы быстро изменить текущую настройку панели, выберите другую валюту в этом раскрывающемся меню.

      • Exclude Invalid SPNs параметр — включите этот параметр, чтобы удалить ссылку на данные поставщика в столбце Manufacturer Part для записей, в которых данные поставщика для данного компонента непригодны для использования (недействительны), например если сведения о цене или наличии на складе отсутствуют.

      • Настройки поставщиков компонентов ссылка — предоставляет прямой доступ к странице Управление данными — Поставщики компонентов Preferences. В список поставщиков/продавцов компонента производителя включаются только те поставщики, которые включены на странице настроек.

  • Component Details:
    • Область Details панели (открывается кнопкой в правом верхнем углу) отображает все доступные данные выбранного компонента, включая его параметры, модели, техническую документацию и ссылки на информацию поставщиков в интернете.
    • В этой области также доступны варианты загрузки для просмотра/сохранения технических характеристик компонента производителя () или локального сохранения самого компонента () одним из следующих способов:
      • Сохранение компонента в подключенное в данный момент рабочее пространство Altium Workspace или
      • Загрузка компонента в виде файловой библиотеки в ZIP-архиве или 
      • Размещение компонента на активном листе схемы.

► Подробную информацию о возможностях и использовании см. на странице Поиск компонентов производителей.

Просмотр и редактирование связей с поставщиками

Связи с поставщиками, заданные для библиотечного компонента или компонента, размещенного на листе схемы, можно просматривать и редактировать в диалоговом окне Supplier Links for. Чтобы открыть это окно:

  • For a schematic library component — щелкните правой кнопкой мыши в любом месте рабочей области и выберите команду Supplier Links в контекстном меню.
  • For a Database library / SVN Database Library component — щелкните правой кнопкой мыши запись компонента на вкладке Table Browser соответствующего файла DbLib/SVNDbLib и выберите команду Edit Supplier Links в контекстном меню.
  • For a placed component on a schematic sheet — щелкните правой кнопкой мыши компонент и выберите команду Supplier Links в контекстном меню.

После запуска команды откроется диалоговое окно Supplier Links for. В нем перечислены все связи, заданные для компонента. Если доступны несколько компонентов производителей, то есть имеется несколько вариантов, они автоматически ранжируются от наиболее до наименее предпочтительного с учетом наличия, цены и статуса жизненного цикла компонента у производителя. Компонент производителя отображается слева, а сведения о выбранном доступном поставщике — справа.

Диалоговое окно Supplier Links for
Диалоговое окно Supplier Links for

Все связи с поставщиками, заданные для компонента библиотеки схемных символов, также можно просматривать и редактировать непосредственно на панели Properties выбранного компонента. Заданные связи с поставщиками для выбранного компонента отображаются в области Part Choices этой панели. Подробные данные о выбранной связи с поставщиком доступны по ссылке в карточке поставщика (как показано ниже) или при поиске по значению параметра Supplier Part Number 1 этого компонента на панели Manufacturer Part Search.

Чтобы добавить еще одну связь с поставщиком, нажмите кнопку в нижней части области Part Choices. Откроется диалоговое окно Supplier Links for; нажмите кнопку  , чтобы открыть диалоговое окно Add Supplier Links, в котором можно найти и добавить дополнительные связи с нужной позицией. Используйте кнопку в диалоговом окне Add Supplier Links, чтобы удалить выбранную связь с поставщиком из библиотечного компонента.

Диалоговое окно Add Supplier Links предоставляет возможность поиска по категориям и параметрической фильтрации, аналогичную панели Manufacturer Part Search . Дополнительные сведения см. на странице с описанием этой панели.

Многие поставщики предлагают скидки на оптовые заказы. Нажмите ссылку Show more на плитке SPN, чтобы просмотреть цены за единицу в зависимости от количества, заказываемого у поставщика. (Затем можно нажать ссылку Show less, чтобы свернуть список оптовых цен.)

Настройка процесса поиска — предлагаемые ключевые слова

При использовании диалогового окна Добавление ссылок на поставщиков для поиска и выбора подходящих данных поставщиков компонентов программа автоматически выполняет поиск компонента производителя на основе параметров, извлеченных из целевого компонента. Поисковый запрос, используемый программой, задается в области Suggested Keywords на странице Управление данными — поставщики данных о компонентах диалогового окна Preferences, что позволяет настроить выражение поиска в соответствии со структурой вашей библиотеки компонентов. Вы можете полностью контролировать, какие параметры компонентов используются в качестве ключевых слов поиска и в каком порядке.

Предлагаемые ключевые слова по умолчанию, используемые при автоматическом поиске компонентов в базах данных поставщиков.Предлагаемые ключевые слова по умолчанию, используемые при автоматическом поиске компонентов в базах данных поставщиков.

В области Suggested Keywords диалогового окна приоритеты по умолчанию (наивысший приоритет — вверху списка) заданы так, что сначала в качестве критерия поиска используется значение Comment. Если у исходного компонента не указан комментарий, следующая попытка поиска выполняется по значению Description. Если и оно пустое, используется Name компонента.

При необходимости можно добавить собственные параметры для ключевых слов, нажав кнопку Add . В конец списка будет добавлен новый параметр (с именем по умолчанию Parameter Name), которому, соответственно, будет назначен самый низкий приоритет. При этом поле имени нового параметра автоматически станет активным и будет готово к переименованию. Чтобы изменить имя существующего параметра, щелкните его поле имени один раз для активации, затем введите нужное имя. Также можно выбрать параметр, щелкнув соответствующее поле приоритета, а затем нажать кнопку Edit .

Чтобы применить изменение имени, щелкните в любом месте столбца Priority . Также можно нажать Enter, но учтите, что при этом изменение будет сохранено, а диалоговое окно Preferences закроется.

Используйте кнопки Move Up и Move Down, чтобы переместить выбранный параметр вверх или вниз по списку соответственно, повышая или понижая назначенный ему Priority .

Пример пользовательского параметра предлагаемого ключевого слова, добавленного в список и получившего наивысший приоритет.Пример пользовательского параметра предлагаемого ключевого слова, добавленного в список и получившего наивысший приоритет.

Хотя параметры по умолчанию можно изменять и даже удалять, их можно восстановить с помощью раскрывающегося списка в строке параметра.

Количество и цены

Как правило, поставщики устанавливают разные цены в зависимости от приобретаемого количества товара. Количества, необходимые для получения все более низкой цены за единицу, различаются не только у разных поставщиков, но и для разных товаров у одного поставщика. При выборе данных поставщика для компонента производителя на панели Поиск компонентов производителей сводную информацию можно просмотреть на плитке поставщика компонента, нажав ссылку Show more. Это позволяет принять обоснованное решение по цене и наличию при выборе ссылки на поставщика на основе актуальных данных.

Цены поставщиков и складские остатки меняются. Помните, что информация от поставщиков поступает в базу данных сервиса-агрегатора, предоставляемого Altium Parts Provider, с некоторой задержкой. Наведите указатель мыши на значок на плитке поставщика, чтобы узнать время последнего обновления информации.

Ссылки на поставщиков, добавленные к библиотечному компоненту, также предоставляют подробные сведения о зависимости цены от количества в области Part Choices панели Properties для выбранного библиотечного компонента. 

Пример отображения Unit Price на основе заданного Order Quantity: при заказе 100 штук цена снижается с 0,1 до 0,018 доллара США за конденсатор. Пример отображения Unit Price на основе заданного Order Quantity: при заказе 100 штук цена снижается с 0,1 до 0,018 доллара США за конденсатор.

Пересчет валют

Поставщики работают в разных регионах мира, нередко сразу в нескольких, поэтому цены на продукцию часто указываются в разных валютах. Altium Designer позволяет отображать такую ценовую информацию с пересчетом в одну из поддерживаемых валют.

Чтобы быстро отобразить все цены в одной валюте на панели Поиск компонентов производителей, выберите нужную валюту в раскрывающемся меню Currency, доступном при нажатии кнопки на панели. Чтобы цены отображались в валюте, используемой поставщиком по умолчанию, выберите пункт меню None.

Конвертация валют выполняется по действующим обменным курсам. Эти курсы обновляются ежедневно (каждые 24 часа), однако для применения актуальных курсов необходимо войти в свою учетную запись Altium.

Чтобы настроить использование валют в Altium Designer, включите или отключите нужные валюты и задайте их приоритет на странице Data Management – Parts Providers диалогового окна Preferences.

► Дополнительную информацию см. выше в разделе Настройки поставщиков.

Импорт отдельных параметров

Выбранные параметры производителя или поставщика можно импортировать из панели Manufacturer Part Search в библиотечный или размещенный компонент с помощью команды Add Parameter(s) To, доступной в области Details панели, которая открывается кнопкой .

Для этого выберите компонент производителя или одну из вложенных записей поставщиков в списке результатов поиска панели, а затем нужные параметры в области Details. Щелкните правой кнопкой мыши по выбранному (выделенному) параметру и выберите команду Add Parameter(s) To, чтобы перенести параметры в целевой компонент.

  • Для библиотечного компонента целевым объектом является запись, выбранная на панели SCH Library, или (для библиотеки базы данных) Table Browser DBLib.

  • Для размещенного компонента целевой объект выбирается в редакторе схем с помощью курсора-перекрестия.

При переносе пар «параметр — значение» следует учитывать следующее:

  • Если параметр уже существует в целевом компоненте, его значение будет обновлено — см. Voltage Rating на приведенных выше иллюстрациях.

  • Если параметр еще не существует, импортируемая пара «параметр — значение» будет добавлена в целевой компонент — Tolerance и Material на иллюстрации выше.

  • При этом учитываются настройки в области Parameter Import Options на странице Data Management – Parts Providers диалогового окна Preferences. Например, если Capacitance сопоставлен с Value, то последний параметр будет добавлен в целевой компонент в качестве значения емкости — Value 1nF.

  • Параметры поставщика, такие как Stock и Pricing, доступны в области Details панели Manufacturer Part Search только в том случае, если в качестве источника выбрана плитка поставщика, а не компонент производителя.

  • Как и для других параметров, добавляемые данные поставщика будут update существующие параметры поставщика в целевом компоненте. Суффикс данных поставщика остается равным 1, и при последующих добавлениях его значение не увеличивается.

Включение данных поставщиков в спецификацию

Связи с данными поставщиков, добавленные к компонентам проекта, а также связи, уже имеющиеся у компонента, размещенного из библиотеки, сохраняются вместе с проектом и доступны для включения в Bill of Materials (BOM).

Отчет по спецификации

В простейшем случае связи компонентов с поставщиками доступны в отчете по спецификации, сформированном на основе исходных документов проекта. Выберите Reports » Bill of Materials, чтобы открыть диалоговое окно Bill of Materials for Project, в котором можно настроить отчет под свои задачи и сформировать его в различных форматах (Excel, PDF, HTML и т. д.). Отчет по спецификации также можно включить в задание на формирование выходных данных проекта в качестве выходного отчета.

► Подробную информацию см. в разделе Настройка спецификации в Report Manager.

В простом отчете по спецификации отображаются параметры данных поставщиков для компонентов, содержащих связи с поставщиками.В простом отчете по спецификации отображаются параметры данных поставщиков для компонентов, содержащих связи с поставщиками.

Если в проекте есть документ ActiveBOM (см. ниже), отчет по спецификации извлекает данные связей с поставщиками из него, а не из проектных документов.

Документ ActiveBOM

Значительно более совершенный и рекомендуемый подход к управлению связями с производителями и поставщиками в спецификации проекта — добавление в проект документа ActiveBOM — File » New » ActiveBOM Document. Обратите внимание: все преимущества этого подхода раскрываются при использовании компонентов библиотеки рабочего пространства.

► Подробную информацию см. в разделе Управление спецификацией с помощью ActiveBOM.

ActiveBOM использует данные компонентов Solutions для добавления полного набора актуальной информации о компонентах, включая сведения о компонентах производителя (в том числе статус жизненного цикла), цены поставщиков и складские остатки.

Существующие связи компонентов с поставщиками, ранее добавленные на уровне библиотеки или документа схемы, автоматически преобразуются в решения ActiveBOM. Обратите внимание: в них по-прежнему будет отображаться только один поставщик, добавленный при создании связи с поставщиком, даже если компонент этого производителя доступен у нескольких поставщиков.

Следующий шаг по сравнению с решениями спецификации, полученными из существующих связей с поставщиками, добавленных к компонентам в библиотеке или на схеме, — добавление новых решений для компонентов в интерфейсе ActiveBOM.

Встроенные решения ActiveBOM, ориентированные на производителей, обеспечивают расширенное сопоставление данных между компонентом проекта и компонентом производителя, а также all of the approved Suppliers этого компонента. Актуальные данные решения доступны на протяжении всего процесса проектирования и служат источником для всех выходных документов типа спецификации.

С компонентом проекта (решением) можно связать не только нескольких поставщиков определенного компонента производителя, но и несколько компонентов производителей. Если связь DesignPart - ManufacturerPart хранится в составе компонента проекта в рабочем пространстве, этот подход называется Part Choices; если связь хранится в документе ActiveBOM (BomDoc), он называется Manufacturer Links.

Благодаря этому эффективному подходу в компоненте проекта не требуется хранить какие-либо сведения о поставщиках или артикулах компонентов у поставщиков. 

► Подробнее см. в разделе Добавление информации о цепочке поставок к компоненту в Altium Designer.

Если в проекте не используются компоненты рабочего пространства, выберите опцию Create/Edit Manufacturer Links в меню кнопки , чтобы добавить решение ActiveBOM к выбранной записи компонента. Нажмите кнопку в открывшемся диалоговом окне Edit Manufacturer Links, а затем выберите подходящую запись компонента производителя в диалоговом окне Add Part Choices. После подтверждения (OK) эта связь с компонентом добавляется как новая запись в диалоговом окне Edit Manufacturer Links.

После подтверждения добавления в диалоговом окне () решение ActiveBOM добавляется к записи компонента в спецификации. Обратите внимание: в этом случае решение включает полный список вариантов поставщиков, а выбранный вариант (выделенный зеленым) назначается «лучшим» решением поставщика для компонента производителя.

Используйте связанную панель Properties для настройки функций ActiveBOM, таких как используемая валюта, источник данных связей с производителями, видимые столбцы данных, группировка позиций спецификации, предупреждения при проверке спецификации и т. д.

► Дополнительную информацию см. в разделе Управление спецификацией с помощью ActiveBOM.

AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Contents