Горячие клавиши редактора CAM

Краткий обзор

В этом справочнике приведены сочетания клавиш и действия мышью для редактора CAMtastic в Altium Designer, охватывающие повседневное редактирование, выделение, просмотр документов, работу с сетками и слоями, манипулирование объектами и анализ. Также описаны сочетания клавиш, доступные при выполнении интерактивных команд, и клавиши для вызова всплывающих меню непосредственно из рабочей области проекта. Читайте дальше, чтобы найти сочетания клавиш для повседневных задач редактирования CAM-данных.

- Найдите сочетания клавиш для выделения и изменения объектов, управления слоями и навигации по CAM-документам.
- Узнайте, как получать сведения об объектах и цепях, измерять расстояния и управлять режимами отображения.
- Разберитесь в обозначениях сочетаний клавиш, управлении интерактивными командами и быстром доступе к всплывающим меню.
Узнайте больше с ИИ:

В следующих разделах приведены сочетания клавиш, предназначенные специально для редактора CAMtastic. Общие сведения о сочетаниях клавиш, включая их просмотр и редактирование, общие сочетания клавиш среды Altium и клавиши быстрого доступа, см. в разделе Сочетания клавиш Altium Designer.

При просмотре списков сочетаний клавиш учитывайте следующее:

  • В обозначениях сочетаний клавиш знак плюс (+) означает, что несколько клавиш следует удерживать нажатыми в указанной последовательности. Например, Shift+F1 означает, что нужно удерживать клавишу Shift, а затем нажать клавишу F1. Аналогично, Shift+Ctrl+PgUp означает, что нужно удерживать клавишу Shift , затем одновременно с ней удерживать клавишу Ctrl  и нажать клавишу PgUp.
  • При использовании стандартных кнопок мыши Click означает один щелчок левой кнопкой мыши, Double-Click — двойной щелчок левой кнопкой мыши, а Right-Click — один щелчок правой кнопкой мыши.

Стандартные сочетания клавиш

Следующие сочетания клавиш являются стандартными для редактора CAMtastic. Они доступны в обычном режиме работы и не требуют запуска интерактивного процесса.

General Editing

Right-Click Открыть контекстное меню рабочей области проекта. Если выполняется интерактивная команда, прервать текущую операцию.
Ctrl+C Скопировать выбранные объекты из текущего документа во внутренний буфер обмена редактора CAMtastic.
Ctrl+X Удалить выбранные объекты из текущего документа и скопировать их во внутренний буфер обмена редактора CAMtastic.
Ctrl+V Вставить содержимое внутреннего буфера обмена редактора CAMtastic в текущий документ.
Ctrl+Z Отменить действие.
Ctrl+Y Повторить действие.

Selecting

Alt+C Выбрать объекты проекта в заданной пользователем области. Объекты не обязательно должны полностью находиться в границах этой области.
Alt+P Повторно выбрать объекты, входившие в предыдущее выделение.
Alt+O Выбирать объекты в рабочей области по одному.
Ctrl+F Включить или выключить режим выбора объектов Flash/Point.
Ctrl+T Включить или выключить режим выбора объектов Draws.

Viewing the CAM Document

Home Показать все объекты на всех включённых слоях текущего документа.
Shift+P Изменить область отображения относительно указанной точки в текущем документе.
PgUp Увеличить масштаб относительно текущего положения курсора.
Ctrl+Mouse Wheel Up Увеличить масштаб относительно центра главного окна отображения. Использование клавиши Ctrl задано по умолчанию; эту настройку можно изменить на странице System - Mouse Wheel Configuration диалогового окна Preferences.
PgDn Уменьшить масштаб относительно текущего положения курсора.
Ctrl+Mouse Wheel Down Уменьшить масштаб относительно центра главного окна отображения. Использование клавиши Ctrl задано по умолчанию; эту настройку можно изменить на странице System - Mouse Wheel Configuration диалогового окна Preferences.
Mouse Wheel Прокрутить рабочую область проекта по вертикали. Это настройка по умолчанию, которую можно изменить на странице System - Mouse Wheel Configuration диалогового окна Preferences.
Shift+Mouse Wheel Прокрутить рабочую область проекта по горизонтали. Это настройка по умолчанию, которую можно изменить на странице System - Mouse Wheel Configuration диалогового окна Preferences.
Right-Click, Hold&Drag Переместить вид в главном окне проекта.
Shift+V Вернуться к предыдущему виду экрана после использования команд увеличения (PgUp) или уменьшения (PgDn) масштаба.
End Обновить рабочую область проекта, перерисовав текущий документ для устранения нежелательных артефактов отображения.
D Перейти в режим динамического панорамирования, в котором можно перемещать документ, удерживая нажатой левую кнопку мыши.
Alt+Home Показать и подсветить все объекты, построенные с использованием текущего D-кода.
Ctrl+Home Изменить вид в главном окне проекта так, чтобы отображались текущая рамка фотошаблона и её содержимое.
Shift+E Включить или выключить отображение габаритной рамки. Эта рамка показывает границы чертежа в главной рабочей области проекта.
Shift+F Переключить отображение документа между режимом заливки и контурным режимом.
Shift+H Включить или выключить подсветку объектов, соответствующих текущему D-коду. Это позволяет точно определить, с какими объектами связан конкретный D-код.
N Переключить отображение документа между негативным и стандартным видами.
Shift+T Включить или выключить полупрозрачный режим отображения. В этом режиме объекты документа отображаются с эффектом прозрачности, что позволяет видеть объекты, частично или полностью перекрытые другими объектами.
Shift+B Включить или выключить отображение текущей рамки фотошаблона.

Working with Grids

Ctrl+G Одновременно задать одинаковое выбранное значение шага сетки привязки по осям X (горизонталь) и Y (вертикаль) с помощью диалогового окна Enter Grid.
Shift+S Переключиться между режимом привязки Off и ранее выбранным режимом привязки (кроме Off).

Closed Polyline Conversion Tools

Shift+Y Преобразовать замкнутую полилинию в сплошной полигон.
Shift+Z Преобразовать замкнутую полилинию в полигон-вырез.
Shift+X Преобразовать замкнутую полилинию в сплошную полигональную область.

Working with Layers

Ctrl+L Совместить слои по выбранным объектам на слоях (убедитесь, что включены только те слои, с которыми вы хотите работать).
L Создать новый слой путём объединения существующих слоёв. Откроется диалоговое окно Select Layer for Merging, в котором можно выбрать слои для объединения.
K Открыть диалоговое окно Set Layers OFF, в котором можно указать слои, которые нужно выключить.
Alt+K Открыть диалоговое окно Set Layers ON, в котором можно указать слои, которые нужно включить.
+ (на цифровой клавиатуре) Сделать текущим следующий слой в списке Layers.
- (на цифровой клавиатуре) Сделать текущим предыдущий слой в списке Layers.
* (на цифровой клавиатуре) Сделать текущим следующий сигнальный слой в списке Layers.

Working with Objects

Ctrl+A Скопировать выбранные объекты и разместить их в документе в виде заданного массива.
Ctrl+D Изменить форму и/или слой выбранных объектов документа.
Ctrl+I Задать новое начало координат документа.
Ctrl+U Масштабировать выбранные объекты документа относительно указанной базовой точки с заданным коэффициентом масштабирования.
Ctrl+M Зеркально отразить выбранные объекты относительно заданной линии отражения в документе.
Ctrl+R Повернуть выбранные объекты относительно указанной базовой точки поворота в документе.
Ctrl+E Удалить выбранные объекты из документа.

Анализ

Q Получить сведения об одном выбранном объекте документа.
Shift+N Получить сведения об одной выбранной цепи документа.
Shift+M Измерить и отобразить расстояние между любыми двумя точками документа.

Miscellaneous

Shift+G Открыть страницу CAM Editor - Drawing Modes диалогового окна Preferences.
Shift+A Открыть диалоговое окно Edit Apertures, в котором можно создавать новые формы апертур, а также редактировать или удалять существующие.
Shift+Ctrl+R Повторить предыдущую команду размещения или редактирования.

Сочетания клавиш для интерактивных операций

Следующие сочетания клавиш становятся доступны после запуска интерактивного процесса, например размещения нового объекта проекта или перемещения существующего. Обратите внимание: доступные сочетания клавиш зависят от интерактивной команды и конкретного объекта проекта, с которым она выполняется.

PgUp Увеличить масштаб.
PgDn Уменьшить масштаб.
Right-Click Прервать текущую команду
Esc Выход из текущей команды. Если на каком-либо этапе выполнения текущей команды используется диалоговое окно, эта функция закроет только это окно. Чтобы полностью отменить выполнение команды, потребуется воспользоваться функцией еще раз.

Сочетания клавиш для всплывающих меню

Следующие сочетания клавиш позволяют открывать определенные всплывающие меню команд непосредственно в рабочей области проектирования. Некоторые из них вам уже знакомы: это подменю, входящие в основные меню редактора. Для каждого основного меню также назначена клавиша быстрого вызова из рабочей области проектирования. Подробнее см. в разделе Клавиши быстрого доступа.

B Подменю Toolbars  (из основного меню View).
C Подменю Circle  (из основного меню Edit).
G Всплывающее меню с командами настройки сетки привязки
I Подменю Import (из основного меню File).
O Подменю Objects  (из основного меню Edit).
S Подменю Selection  (из основного меню Edit).
X Подменю Export  (из основного меню File).
Z Всплывающее меню с командами масштабирования.

 

AI-LocalizedЛокализовано с помощью ИИ
Если вы обнаружили проблему, выделите текст/изображение и нажмитеCtrl + Enter, чтобы отправить нам свой отзыв.
Меню
Contents
Доступность функций

Доступные вам функции зависят от того, какое решение Altium вы используете: Altium Develop, Altium Agile Teams, Altium Agile Enterprise или Altium Designer (при активной подписке).

Если вы не видите описанную функцию в используемом вами программном обеспечении, свяжитесь с отделом продаж Altium, чтобы узнать больше.

Устаревшая документация

Документация Altium Designer больше не разделена по версиям ПО. Если вам необходим доступ к документации по старым версиям Altium Designer, посетите раздел Устаревшая документация на странице Прочие установщики.

Contents