3D-MID Design
Sơ lược
- Hiểu 3D-MID là gì, cách công nghệ này sử dụng quy trình sản xuất LDS và cách đưa thiết kế mạch 3D vào Altium Designer.
- Tìm hiểu cách tạo tài liệu 3D-MID, nhập hoặc thay đổi đế nền và làm việc với các tệp STEP hoặc IGES được hỗ trợ.
- Làm quen với những thao tác cơ bản trong trình chỉnh sửa 3D, bao gồm điều khiển camera, tùy chọn hiển thị, cấu hình màu sắc và công cụ căn chỉnh.
Công cụ 3D-MID của chúng tôi lần đầu tiên mang khả năng thiết kế mạch 3D thực sự đến Altium Designer, cho phép bạn kết hợp chức năng điện và cơ khí trong một chi tiết duy nhất.
Tài liệu 3D-MID được tích hợp vào dự án Altium Designer giống như PCB tiêu chuẩn — các linh kiện và kết nối của nó được xác định bởi thiết kế sơ đồ nguyên lý, đồng thời sử dụng các footprint SMT tiêu chuẩn từ thư viện linh kiện quen thuộc của bạn.
3D-MID là gì?
3D-MID là viết tắt của Three-Dimensional Mechatronic Integrated Devices (Thiết bị tích hợp cơ điện tử ba chiều).
Quy trình sản xuất 3D-MID sử dụng tia laser để khắc mẫu mạch trực tiếp lên bề mặt của đế nền 3D, sau đó thực hiện xử lý kim loại hóa tiêu chuẩn để biến mẫu mạch đó thành các đường dẫn điện. Quy trình này, được gọi là tạo cấu trúc trực tiếp bằng laser (Laser Direct Structuring — LDS), cho phép tích hợp mạch vào kết cấu của sản phẩm cuối cùng.
Thiết kế đường dẫn mạch trên bề mặt của một cấu trúc 3D đặt ra những thách thức riêng. Không gian biên tập phải hỗ trợ bố trí linh kiện và các kết nối giữa chúng để tạo nên mạch cụ thể. Trình biên tập này cũng phải có khả năng nhập đế nền 3D mà trên đó mạch điện tử sẽ được tạo ra — đây phải là một trình biên tập thiết kế điện tử ba chiều thực sự.
Người thiết kế phải có khả năng đặt linh kiện lên bất kỳ bề mặt nào của đế nền 3D đã nhập. Sau đó, họ phải có khả năng xác định các đường dẫn kết nối giữa các chân linh kiện, một quy trình thường được gọi là đi dây kết nối. Các đường đi dây này cũng phải có khả năng chạy trên bề mặt đế nền, bất kể hướng của bề mặt đế nền tại bất kỳ điểm nào dọc theo đường đi dây.
Cuối cùng, người thiết kế phải có khả năng tạo dữ liệu sản xuất theo định dạng mà quy trình tạo cấu trúc trực tiếp bằng laser (LDS) yêu cầu.
Công cụ thiết kế 3D-MID mới lần đầu tiên mang chức năng này đến Altium Designer.
Tạo tài liệu 3D-MID
Tương tự tài liệu PCB tiêu chuẩn (PcbDoc), tài liệu 3D-MID (PcbDoc3D) có thể được tạo trong một dự án hoặc dưới dạng tài liệu độc lập.
-
Để tạo tài liệu 3D-MID mới trong một dự án, nhấp chuột phải vào tên dự án trong bảng Projects, rồi chọn Add New to Project » PCB3D.
-
Để tạo tài liệu 3D-MID dưới dạng tài liệu độc lập, chọn File » New » PCB3D từ các menu.
-
Trong quá trình tạo, một hộp thoại sẽ xuất hiện, nhắc bạn chọn tệp để tạo đế nền cho tài liệu 3D-MID. Tệp được chọn phải có định dạng STEP hoặc IGES. Ưu điểm của định dạng IGES là có thể chứa các bản phác thảo nhúng.
Sau khi được chọn, tệp đế nền sẽ được hiển thị trong cửa sổ biên tập 3D-MID. Nếu bạn hủy cửa sổ chọn đế nền, đế nền mặc định sẽ được hiển thị như bên dưới.
Đế nền 3D mặc định được tạo nếu bạn chọn không mở đế nền riêng.
Thay đổi đế nền
Nếu cần, có thể thay đổi đế nền 3D bằng cách chọn lệnh File » Change Substrate từ các menu chính.
Nếu thiết kế đế nền đã thay đổi, bạn có thể cập nhật đế nền.
Cách xử lý các đối tượng hiện có khi thay đổi đế nền
|
Khi chọn một đế nền mới, phần mềm sẽ so sánh đế nền mới với đế nền hiện có. Phần mềm thực hiện việc này bằng cách so sánh vị trí của từng bề mặt hiện có với vị trí của bề mặt đó trên đế nền mới. Dựa trên một ngưỡng khoảng cách, nếu bề mặt mới nằm trong khoảng cách quy định so với một bề mặt hiện có, bề mặt đó được xem là cùng một bề mặt ở vị trí mới và mọi đối tượng bố trí hiện có sẽ được chuyển sang bề mặt đó. Nếu vượt quá khoảng cách này, bề mặt mới được xem là một bề mặt khác và các đối tượng bố trí sẽ bị xóa. Giá trị ngưỡng được xác định bằng Tùy chọn nâng cao |
Làm việc trong trình chỉnh sửa tài liệu 3D-MID
Các thao tác điều khiển góc nhìn như sau:
- Để dịch chuyển góc nhìn, nhấn giữ nút chuột phải và kéo
- Để phóng to hoặc thu nhỏ, sử dụng con lăn chuột
- Để xoay, giữ phím Shift, đồng thời nhấn giữ nút chuột phải và kéo. Tâm xoay được xác định bởi vị trí con trỏ chuột khi bắt đầu lệnh.
Thay đổi góc nhìn đế nền
Ở góc dưới bên trái của không gian thiết kế có một ký hiệu trục màu đỏ/xanh lá/xanh dương, được gọi là Gizmo định hướng góc nhìn.
Nhấp vào một mặt phẳng hoặc trục có màu trong Gizmo để chuyển góc nhìn đế nền theo mặt phẳng/trục đó.
Gizmo
Gizmo được dùng để thay đổi hướng nhìn đế nền. Mỗi trục trong không gian làm việc và mặt phẳng tương ứng được gán một màu. Khi bạn di chuột lên một phần tử có màu của Gizmo, phần tử đó sẽ phóng lớn để cho biết nó đang hoạt động. Khi bạn nhấp vào phần tử có màu đó, góc nhìn sẽ được định hướng lại để bạn nhìn down trục đó vào đế nền. Nhấp lần thứ hai sẽ lật góc nhìn, cho phép nhìn dọc theo cùng trục đó từ hướng ngược lại.
- Blue - Trục Z, nhìn vào mặt phẳng X-Y.
- Red - Trục X, nhìn vào mặt phẳng Y-Z.
- Green - Trục Y, nhìn vào mặt phẳng X-Z.
Điều khiển góc nhìn 3D
Bạn cũng có thể điều khiển góc nhìn đế nền thông qua menu con 3D View Control.
- Sử dụng nhóm lệnh phía trên để xem đế nền dọc theo trục được chỉ định.
- Sử dụng nhóm lệnh phía dưới để Rotate hoặc Roll đế nền theo hướng đã chọn. Bạn cũng có thể truy cập từng lệnh này bằng phím tắt được trình bày trong hình bên dưới. Khi chọn lệnh Rotate hoặc Roll, phần mềm cũng sẽ điều chỉnh mức thu phóng để đưa đế nền vào giữa màn hình.
Thay đổi kiểu hiển thị
Bạn có thể thay đổi kiểu hiển thị bằng cách bật/tắt lệnh View » Switch Perspective/Orthographic view. Chế độ xem phối cảnh cho phép bạn quan sát 3D-MID ở dạng 3D chân thực hơn. Chế độ xem trực giao loại bỏ các hiệu ứng biến dạng do phối cảnh và bảo đảm các chi tiết song song được hiển thị đúng là song song.
Cấu hình màu sắc
Bạn có thể cấu hình màu bề mặt và màu đường viền của đế nền, cũng như màu của đối tượng hiện đang được chọn và màu đồng trong bảng View Configuration, như minh họa bên dưới. Mở bảng bằng nút Panels ở góc dưới bên phải phần mềm.
|
Bạn có thể cấu hình màu bề mặt đế nền, màu đường viền và màu của đối tượng hiện đang được chọn trong mục System Colors của bảng. Bạn có thể cấu hình màu đồng trong mục Layers của bảng. Cửa sổ đồ họa sẽ không hiển thị màu đồng mới cho đến khi bạn bật/tắt chế độ hiển thị linh kiện bằng các phím tắt 2 và 3. |
Công cụ căn chỉnh
Có hai công cụ giúp định vị các đối tượng trên bề mặt đế nền. Bạn có thể nhập bản phác thảo từ MCAD hoặc sử dụng tính năng tạo lưới căn chỉnh trong trình chỉnh sửa 3D-MID. Sau khi được hiển thị, các đối tượng trong bản phác thảo có thể hỗ trợ việc bố trí linh kiện, đường mạch đồng và vùng đồng.
- Khi kéo một linh kiện, con trỏ chuột sẽ bắt dính vào tâm của footprint. Sau đó, con trỏ chuột (và do đó cả tâm linh kiện) sẽ bắt dính vào các phần tử của bản phác thảo.
- Khi được chọn, linh kiện cũng sẽ hiển thị một tay nắm xoay. Nhấp và kéo tay nắm để xoay linh kiện. Tay nắm sẽ bắt dính vào các phần tử của bản phác thảo. Tìm hiểu thêm về xoay linh kiện tương tác.
- Khi đi dây, điểm đầu và điểm cuối của đường mạch đồng sẽ bắt dính vào các giao điểm được tạo bởi các phần tử của bản phác thảo. Nếu con trỏ chuột không ở gần giao điểm nào, nó sẽ bắt dính vào các đường phác thảo. Trong khi đi dây, nếu con trỏ chuột di chuyển dọc theo một đường phác thảo (kể cả đường cong), đường mạch sẽ đi theo đường đó.
- Các đỉnh và cạnh của một vùng cũng có thể được căn chỉnh theo lưới hoặc các bản phác thảo đã nhập.
- Hai công cụ được mô tả bên dưới có thể hoạt động độc lập, đồng thời trên cùng một đế nền.
Nhập bản phác thảo
- Khi thiết kế đế nền trong MCAD, bạn có thể đặt các đường cong 3D lên bề mặt chi tiết và đưa chúng vào tệp IGES được xuất.
- Ví dụ, trong Solidworks, lệnh Project Curve cho phép bạn đặt một bản phác thảo 2D lên bề mặt 3D.
- Sau đó, bạn có thể đưa các “đường cong” này vào tệp IGES xuất ra bằng tùy chọn Export 3D Curve features.
- Khi tệp IGES được nhập vào Altium Designer để tạo đế nền cho 3D-MID, bạn có thể hiển thị các phần tử này bằng cách chọn lệnh View » Show Sketches.
Các bản phác thảo được xác định trong MCAD được hiển thị bằng màu đỏ.
- Sau đó, bạn có thể sử dụng các chi tiết trong bản phác thảo làm đường dẫn hướng khi bố trí linh kiện và vùng đồng, cũng như trong quá trình đi dây.
Lưới căn chỉnh
- Trong tài liệu 3D-MID, bạn có thể tạo lưới trên một trong ba mặt phẳng chuẩn bằng mục Alignment Grid của bảng Properties khi không có đối tượng nào được chọn trong không gian thiết kế 3D. Sau đó, lưới này được chiếu từ mặt phẳng đã chỉ định lên các bề mặt của chi tiết. Lưu ý rằng lưới này độc lập với các bản phác thảo được nhập cùng với đế nền.
-
Người dùng có thể điều chỉnh các thuộc tính của lưới. Lưu ý rằng gốc tọa độ của đế nền được kế thừa từ mô hình STEP/IGES đã nhập.
- Enable Grid - chỉ bắt dính vào lưới khi lưới hiển thị.
-
Plane Kind - mặt phẳng XY, XZ, YZ dùng để chiếu lưới căn chỉnh. Được kế thừa từ mô hình STEP/IGES được nhập để tạo đế nền.
Ngoài ra, bạn có thể chọn kiểu mặt phẳng UV để tạo lưới dựa trên các bề mặt của đế nền, mang lại các đường lưới tự nhiên hơn, uốn theo độ cong của đế nền (xem hình ảnh). Kiểu mặt phẳng UV cho phép đi dây theo các đường 'tự nhiên' hơn trên bề mặt đế nền 3D. - Horizontal/Vertical Size - bước lưới.
- Horizontal/Vertical Offset - độ lệch của lưới so với gốc tọa độ của đế nền.
- Rotation - góc xoay của lưới, song song với mặt phẳng đó (chỉ áp dụng cho các kiểu mặt phẳng XY, XZ, YZ).
Bắt dính con trỏ
Trình chỉnh sửa tài liệu 3D-MID cho phép bạn thay đổi thứ tự ưu tiên bắt dính. Các tùy chọn điều khiển thứ tự ưu tiên bắt dính được truy cập bằng nút Objects for snapping trên Active Bar.
Có hai cấp độ bắt dính con trỏ: lưới và đối tượng. Khi được bật, bắt dính vào đối tượng được ưu tiên hơn bắt dính vào lưới. Ví dụ, điều này cho phép bắt dính vào lưới thay vì đường tâm của đường mạch khi đi dây đến/từ một đường mạch hiện có, bằng cách bật bắt dính vào Grids nhưng tắt bắt dính vào Track Lines (với điều kiện bản thân lưới được bật trong bảng Properties), như minh họa trong video bên dưới.
Làm việc với linh kiện
- Nếu tài liệu 3D-MID thuộc một dự án, bạn có thể đồng bộ linh kiện từ các trang sơ đồ nguyên lý sang tài liệu này bằng các lệnh tiêu chuẩn - Design » Update PCB nếu đang làm việc trong trình chỉnh sửa sơ đồ nguyên lý, hoặc Design » Import Changes from xxx.PrjPcb nếu đang làm việc trong trình chỉnh sửa tài liệu 3D-MID. Trong trường hợp này, các thông tin gán net cho chân linh kiện trên sơ đồ nguyên lý cũng sẽ được chuyển sang các pad của linh kiện 3D-MID. Lưu ý rằng các quy tắc thiết kế mặc định sẽ được tạo trong quá trình này; hãy tham khảo phần Tùy chọn dự án và quy tắc thiết kế mặc định trên trang này để tìm hiểu thêm.
- Sau khi được đồng bộ sang tài liệu 3D-MID, ban đầu các linh kiện sẽ xuất hiện lơ lửng trong không gian 3D bên cạnh khối đế nền và có thể được kéo từng linh kiện lên bề mặt đế nền. Theo mặc định, khi bạn kéo một linh kiện lên đế nền, hướng ban đầu của linh kiện trên bề mặt đế nền sẽ phụ thuộc vào đường di chuyển của chuột khi kéo.
|
Sau khi đồng bộ các linh kiện và net từ sơ đồ nguyên lý, các linh kiện xuất hiện bên cạnh đế nền, lơ lửng trên mặt phẳng X-Y của đế nền. Lưu ý rằng pad 1 có các góc bo tròn. Hướng của linh kiện được di chuyển sau khi tiếp cận đế nền từ phía trước. Hướng của linh kiện được di chuyển sau khi tiếp cận đế nền từ bên cạnh. |
-
Ngoài ra, có thể kéo linh kiện trực tiếp lên đế nền từ bảng Components. Khi bạn đặt một linh kiện từ bảng Components , linh kiện đó có ký hiệu định danh mặc định và tất cả các pad của linh kiện đều được gán là
No Net. - Khi bạn kéo một linh kiện, con trỏ chuột (được biểu thị bằng dấu cộng màu xanh lá) sẽ bắt dính vào tâm của footprint. Sau đó, con trỏ (cùng với tâm footprint đi kèm) sẽ bắt dính vào lưới căn chỉnh đang hiển thị. Tìm hiểu thêm về Lưới căn chỉnh và các công cụ căn chỉnh.
- Bạn cũng có thể kéo linh kiện khi các khối 3D bị ẩn. Để chọn linh kiện, hãy nhấp và giữ một trong các pad của linh kiện. Ngay khi chuột di chuyển, tâm linh kiện sẽ bắt dính vào con trỏ.
-
Khi kéo một linh kiện trong tài liệu 3D-MID và các khối linh kiện đang bị ẩn (View » Component Bodies » Hide; phím tắt: 2), hình đồ họa giản lược (các hình chóp màu xanh lá) sẽ được hiển thị nếu số chân của linh kiện vượt quá giới hạn được xác định bởi thiết lập nâng cao
3DLayout.ComponentDrag.DrawShapesPinsLimit(mặc định là 15). Cơ chế này được áp dụng để cải thiện hiệu suất. Bạn có thể điều chỉnh giá trị của thiết lập cho phù hợp với cấu hình máy tính. - Khi đang kéo một linh kiện, Spacebar sẽ xoay linh kiện theo từng bước với góc Rotation Step được xác định trên trang PCB Editor - General của hộp thoại Preferences (xem hình ảnh). Bước xoay mặc định là 90 độ.
-
Cách định hướng linh kiện khi được kéo qua các bề mặt khác nhau của đế nền được điều khiển bằng thiết lập nâng cao
3DLayout.ComponentDrag.KeepOrientation.
|
Nếu giá trị là Nếu giá trị của thiết lập nâng cao |
|
Nhấp một lần để chọn linh kiện. Một khung sẽ xuất hiện bao quanh linh kiện và tay nắm sẽ hiển thị. Bạn có thể dùng tay nắm này để điều chỉnh hướng linh kiện một cách tương tác. Nhấp và giữ tay nắm này, rồi kéo đến vị trí mong muốn. Tay nắm sẽ bắt dính vào lưới căn chỉnh. |
- Bạn cũng có thể kéo nhiều linh kiện cùng lúc. Chọn nhiều linh kiện (bằng phím tắt Shift+Click hoặc các phương pháp chọn khác), sau đó dùng Click, Hold&Drag trên vùng chọn để di chuyển tất cả linh kiện đã chọn cùng lúc. Tương tự như khi kéo một linh kiện, chuyển động bị ràng buộc bởi các tùy chọn bắt dính hiện tại.
- Các pad, vùng đổ đồng và vùng đặc trong footprint của linh kiện là những đối tượng đồng được hỗ trợ đặt trong tài liệu 3D-MID. Điều này cho phép bạn đặt các linh kiện có footprint hình dạng phức tạp lên đế nền, bao gồm cả các hình dạng RF (ví dụ: ăng-ten).
- Khi một linh kiện được kéo trên bề mặt đế nền, hình dạng các pad của linh kiện được tạo bằng cách ánh xạ hình dạng của chúng từ mặt phẳng footprint 2D lên bề mặt đế nền. Nếu bề mặt này không phẳng, hình dạng pad tạo ra sẽ bị biến dạng. Mức độ biến dạng cho phép có giới hạn. Khi đạt đến giới hạn này, pad sẽ không được tạo.
- Để truy cập thuộc tính của một linh kiện, hãy nhấp chuột trái vào phần thân linh kiện. Một khung dạng dây sẽ xuất hiện bao quanh linh kiện. Sau đó, bạn có thể truy cập các thuộc tính của linh kiện qua bảng Properties.
- Khi đã chọn một linh kiện, bạn có thể chọn pad bằng cách nhấp chuột trái thêm một lần trực tiếp lên pad đó. Sau đó, có thể chỉnh sửa các thuộc tính của pad qua bảng Properties.
- Nếu không thể chỉnh sửa các thuộc tính của pad, điều đó có nghĩa là tùy chọn toàn cục Protect Locked Primitives in Component đang được bật trên trang PCB Editor - General của hộp thoại Preferences (xem hình). Để ghi đè thiết lập này cho riêng linh kiện hiện tại và chỉnh sửa pad của linh kiện, hãy chọn linh kiện thay vì pad (khung dây bao quanh sẽ xuất hiện), rồi nhấp vào nút khóa Primitives (xem hình) để mở khóa các đối tượng nguyên thủy của linh kiện đó. Hãy nhớ khóa lại các đối tượng nguyên thủy của linh kiện sau khi chỉnh sửa xong các thuộc tính của pad.
Đi dây
Đi dây là quá trình xác định các đường dẫn đồng giữa các chân linh kiện được kết nối. Bạn đi dây cho thiết kế bằng cách thay thế từng đường kết nối net bằng các đối tượng đường mạch trên một lớp đồng.
Hiển thị các đường kết nối
Để hỗ trợ đi dây, bạn có thể hiển thị các đường kết nối net (View » Connections » Show All). Các đường kết nối được hiển thị giữa các đường mạch/pad chưa được nối với nhau thuộc cùng một net, phản ánh thông tin kết nối được xác định trong các tài liệu sơ đồ nguyên lý của dự án. Với mỗi net, theo mặc định, thuật toán sẽ tính toán cách bố trí các đường sao cho tổng chiều dài của chúng là nhỏ nhất.
Phân biệt các đường kết nối bằng màu sắc
- Tập hợp các đường kết nối tạo nên mỗi net có thể được gán màu để phân biệt, như minh họa bên dưới:
|
Để gán màu cho một net cụ thể, trước tiên... hãy chọn một pad thuộc net đó (nhấp một lần để chọn linh kiện, đợi một chút, rồi nhấp lần thứ hai để chọn pad), sau đó nhấp vào siêu liên kết Net trong bảng Properties. Nhấp vào biểu tượng màu và chọn màu mới cho các đường kết nối của net đó trong bảng màu xuất hiện. Ngoài ra, bạn có thể sử dụng bảng PCB ở chế độ Nets, tìm net trong danh sách rồi nhấp chuột phải vào tên để hiển thị menu ngữ cảnh. Chọn lệnh Change Net Color để mở hộp thoại Choose Color và chọn màu mới. |
Ghi đè màu net – Hiển thị màu net trên các net đã đi dây
Bạn cũng có thể sử dụng màu net cho các net đã đi dây bằng cách bật tính năng Net Override Color. Tính năng này cho phép bạn kiểm soát cách tô nổi bật các net đã đi dây trong tài liệu 3D-MID bằng bảng màu ghi đè do bạn tự chọn. Thay vì chỉ tô màu đối tượng net theo màu của lớp, bạn có thể chỉ định sử dụng một màu thay thế cụ thể.
Để sử dụng tính năng Net Override Color:
- Apply the required color to the net(s) – sử dụng các phương pháp được mô tả trong phần Phân biệt các đường kết nối bằng màu sắc ở trên.
-
Enable Color Override for the net(s) – tính năng ghi đè màu được bật cho từng net bằng hộp kiểm bên cạnh tên net trong bảng PCB (ở chế độ Nets), như minh họa cho net
NetR2_1trong hình bên dưới. Bạn có thể bật/tắt các hộp kiểm cho nhiều net được chọn bằng các lệnh Right-click » Display Override » Selected On/Off.
Chuẩn bị đi dây
- Khi đã đi dây kết nối giữa hai pad thuộc cùng một net, đường kết nối tương ứng sẽ biến mất. Nhờ đó, bạn có thể dùng các đường kết nối để kiểm tra trực quan, bảo đảm tất cả các net đều đã được đi dây đầy đủ — với một thiết kế đã đi dây hoàn chỉnh, sẽ không còn đường kết nối nào (ngoại trừ giữa một cặp pad của via). Nếu cần, bạn có thể ẩn các đường kết nối bằng lệnh View » Connections » Hide All.
- Chỉ hỗ trợ đi dây tương tác thủ công (hiện chưa hỗ trợ đi dây tự động).
-
Có hai chế độ đi dây tương tác:
- Ignore Obstacles - bạn phải tự tránh kết nối với phần đồng thuộc net khác. Có thể xảy ra ngắn mạch. Trong chế độ này, phần mềm hoạt động nhanh và phản hồi tức thì.
-
Walkaround Obstacles - thuật toán đi dây ngăn ngừa ngắn mạch bằng cách duy trì khoảng hở giữa đường đi dây và các đối tượng đồng thuộc net khác. Quá trình này đòi hỏi tính toán nhiều, vì vậy có thể có độ trễ trước khi phần mềm phát hiện va chạm và điều chỉnh đường đi dây vòng tránh chướng ngại vật. Thuật toán yêu cầu con trỏ phải nằm ngoài đối tượng thuộc net khác.
Thiết lập khoảng hở giữa các đối tượng và độ rộng đường mạch
Trình biên tập 3D-MID sử dụng các quy tắc thiết kế để xác định độ rộng đường mạch và khoảng hở tối thiểu cho phép giữa các đối tượng thuộc các net khác nhau.
- Để thiết lập yêu cầu về khoảng hở và độ rộng đường mạch, hãy mở PCB Rules and Constraints Editor (Design » Rules).
Cấu hình ràng buộc khoảng hở
- Trong cây ở bên trái hộp thoại quy tắc thiết kế, hãy mở rộng cây và chọn quy tắc Clearance mặc định.
- Chỉ ba giá trị được đánh dấu trong hình bên dưới ảnh hưởng đến thuật toán:
- Lưu ý rằng các pad TH (xuyên lỗ) được nhận diện đúng là pad xuyên lỗ trong tài liệu 3D-MID, nhưng bản thân lỗ sẽ không được đưa vào.
Cấu hình độ rộng đường mạch
- Độ rộng của các đường mạch mới được đặt được xác định bởi quy tắc thiết kế đi dây Width áp dụng cho chúng. Bộ đi dây 3D chỉ hỗ trợ giá trị Preferred Width cho lớp trên cùng (Top Layer). Bạn có thể cấu hình giá trị này trong trường Preferred Width tổng thể (được đánh dấu trong hình bên dưới) hoặc trong trường độ rộng dành riêng cho từng lớp.
Các tùy chọn dự án và quy tắc thiết kế mặc định
Mỗi dự án mới đều có các thiết lập tạo quy tắc mặc định, và mỗi tài liệu PcbDoc3D mới đều có các quy tắc mặc định. Ví dụ, các thiết lập dự án mặc định sẽ tạo một hoặc nhiều quy tắc thiết kế Placement khi thiết kế được đồng bộ từ trình biên tập sơ đồ nguyên lý sang trình biên tập PCB3D. Do quy tắc Placement mặc định này, tính năng DRC trực tuyến sẽ phát hiện các linh kiện không nằm trong vùng room, vì vậy chúng sẽ được tô nổi bật (màu xanh lá) để chỉ báo vi phạm.
- Có thể xóa quy tắc thiết kế Placement mặc định; nhấp chuột phải vào quy tắc trong PCB Rules and Constraints Editor để hiển thị menu ngữ cảnh rồi xóa quy tắc đó, như minh họa bên dưới. Tìm hiểu thêm về Quy tắc thiết kế.
- Để ngăn phần mềm tạo quy tắc Placement cho từng trang sơ đồ nguyên lý trong dự án khi đồng bộ thiết kế giữa trình biên tập sơ đồ nguyên lý và 3DPCB, hãy mở hộp thoại Options for PCB Project (Project » Project Options), chuyển sang tab Class Generation và tắt tùy chọn Generate Rooms, như minh họa bên dưới. Tìm hiểu thêm về Tùy chọn dự án.
Đi dây bằng lưới căn chỉnh và các bản phác thảo
Vì bạn đang đi dây trên các bề mặt không đều của vật thể 3D nên lưới mặt phẳng XY truyền thống dùng trong thiết kế PCB không còn phù hợp. Thay vào đó, trình biên tập 3D-MID hỗ trợ hai loại đối tượng phác thảo: Lưới căn chỉnh và Các bản phác thảo được nhập.
-
Trong trình biên tập 3D-MID, Alignment Grid được bật và cấu hình trong bảng Properties khi không có đối tượng nào được chọn trong không gian thiết kế. Cấu hình các thuộc tính của Lưới căn chỉnh cho phù hợp với bước đi dây cần thiết, bao gồm:
- Plane Kind (mặt phẳng dùng để chiếu lưới căn chỉnh);
- Size (bước lưới) và
- Rotation (góc xoay song song với mặt phẳng đó). Trong khi đi dây, khi con trỏ chuột đến gần lưới căn chỉnh, nó sẽ bắt dính vào đường lưới gần nhất.
- Nếu đế nền được nhập từ tệp IGES, mọi đối tượng phác thảo (đường thẳng và cung tròn) được nhúng trong tệp IGES đó cũng có thể được dùng để dẫn hướng khi đi dây. Trong khi đi dây, nếu con trỏ chuột được di chuyển về phía giao điểm của các đường phác thảo, nó sẽ bắt dính vào giao điểm đó. Nếu không, nó sẽ bắt dính vào một đường phác thảo gần đó. Lưu ý rằng chỉ có thể dùng các bản phác thảo để hỗ trợ bố trí khi chúng đang hiển thị. Để bật/tắt khả năng hiển thị của chúng, hãy chọn View » Show Sketches (lưu ý rằng lệnh này không áp dụng cho việc hiển thị Alignment Grid; thiết lập này được cấu hình trong bảng Properties).
Bật Lưới căn chỉnh để các đường mạch bắt dính vào lưới.
Đi dây cho một kết nối
Để bắt đầu đi dây, hãy chọn lệnh menu Route » Interactive Routing, nhấp vào nút tắt trong Active Bar như minh họa bên dưới hoặc nhấn tổ hợp phím tắt Ctrl+W.
Đi dây là quá trình xác định các đường dẫn bằng đồng giữa các chân linh kiện được kết nối.
Mẹo đi dây
-
Khởi chạy lệnh Interactive Routing. Con trỏ sẽ chuyển thành dấu chữ thập màu xanh lá để cho biết lệnh đi dây tương tác đang hoạt động. Lưu ý rằng có thể có một khoảng trễ ngắn từ lúc chọn lệnh đến khi có thể bắt đầu đi dây trong lần đầu khởi chạy lệnh ở một phiên chỉnh sửa.
-
Nhấp vào bất kỳ vị trí nào trên pad (hoặc đường mạch hiện có) mong muốn để bắt đầu đi dây. Một đoạn mạch sẽ xuất hiện, đầu cố định sẽ tự động gắn vào tâm pad (hoặc đầu mút đường mạch hiện có), còn đầu kia sẽ gắn với con trỏ đang di chuyển. Các đoạn mạch bạn đặt sau mỗi lần nhấp chuột sẽ tự động được gán vào net của pad hoặc đường mạch hiện có đó.
-
Đầu đang di chuyển của đường mạch sẽ được gắn với một đường kết nối tương tác màu xanh lá. Phần mềm sẽ tự động nối đầu còn lại của đường kết nối đó với đối tượng gần nhất thuộc cùng net. Bạn có thể đi dây đến bất kỳ đối tượng nào trong net đó mà không cần đi theo hình dạng của các đường kết nối. Phần mềm sẽ tự động cập nhật các đường kết nối ngay khi bạn thoát chế độ đi dây tương tác. Hình bên dưới hiển thị đường kết nối gốc màu nhạt và đường kết nối tương tác màu xanh lá khi đường mạch tiến đến pad đích. Di con trỏ lên hình để xem kết nối đã hoàn tất.
-
Nhấp chuột trái để đặt đoạn mạch và xác định một điểm cố định trên đường đi dây. Sau đó, tiếp tục di chuyển con trỏ và nhấp để đặt các đoạn mạch tiếp theo.
-
Khi bạn tiến đến đối tượng đích, ngay khi con trỏ nằm trong đường biên của đối tượng, nó sẽ bắt dính vào tâm pad hoặc đường tâm của đoạn mạch hiện có (hoặc đầu mút đoạn mạch nếu gần hơn).
-
Trong khi đi dây cho một kết nối, bạn có thể truy cập bảng Properties, bật/tắt lưới và điều chỉnh các thiết lập của lưới nếu cần. Video ở đầu phần này minh họa thao tác đó.
-
Khi đã đi dây xong cho kết nối đó, right-click (hoặc nhấn Esc trên bàn phím) để thoát chế độ Đi dây tương tác. Lưu ý rằng thao tác này sẽ đưa bạn ra khỏi chế độ đi dây tương tác; bạn phải khởi chạy lại lệnh để tiếp tục đi dây.
-
Bạn có thể để đường mạch chưa hoàn tất và quay lại tiếp tục sau. Right-click chuột để dừng đi dây.
-
Bạn cũng có thể bắt đầu đi dây tại bất kỳ vị trí nào trên bề mặt đế nền. Trong trường hợp này, đường mạch sẽ có Net được gán là
No Net, vì vậy nếu sau đó bạn đi dây đến một pad đã được gán net, bạn sẽ tạo ra vi phạm khoảng cách cách điện. Vì lý do này, bạn nên bắt đầu đi dây từ một đối tượng đã thuộc net. -
Nếu cần, bạn có thể dùng bảng Properties để thay đổi net được gán cho một hoặc nhiều đoạn mạch đã đặt.
-
Nếu bạn đang đi dây ở chế độ Đi vòng chướng ngại vật, có thể có một khoảng trễ trước khi các đoạn mạch xuất hiện khi bạn tiến đến một đối tượng hiện có thuộc net khác. Lưu ý rằng thuật toán Đi vòng yêu cầu con trỏ phải nằm ngoài các đối tượng thuộc net khác để có thể tính toán đường đi. Cũng có thể có một khoảng trễ từ lúc nhấp chuột đến khi đoạn mạch xuất hiện.
-
Nếu công cụ đi dây tương tác có vẻ bị treo, hãy ngừng di chuyển chuột và chờ phần mềm hoàn tất việc tính toán các vị trí đối tượng cần thiết. Điều này đặc biệt quan trọng khi chuyển từ bề mặt này sang bề mặt khác của đế nền.
-
Bạn có thể chỉnh sửa đường mạch bằng cách nhấp và kéo.
- Nhấp và kéo một đường mạch để thêm đỉnh mới.
- Nhấp và kéo một đỉnh để di chuyển đỉnh đó.
-
Để thay đổi độ rộng của một đoạn mạch đã đặt, hãy chọn đoạn mạch đó và chỉnh sửa thiết lập Width trong bảng Properties.
-
Để thay đổi độ rộng của nhiều đoạn mạch, hãy giữ phím Shift, rồi nhấp để chọn từng đoạn. Sau đó, bạn có thể chỉnh sửa độ rộng của tất cả các đoạn đã chọn trong bảng Properties.
-
Để chọn tất cả các đoạn mạch, vùng và pad trong một net, hãy chọn một đối tượng rồi nhấn phím Tab.
-
Chọn một hoặc nhiều đoạn mạch rồi nhấn phím Delete trên bàn phím để xóa các đường mạch đã đặt.
-
Để xóa toàn bộ đường mạch của một net, hãy mở bảng PCB, đặt bảng ở chế độ Nets, bật hộp kiểm Select, rồi chọn net (hoặc các net) mong muốn trong phần Nets của bảng. Khi bảng đang là thành phần hoạt động trong phần mềm, hãy nhấp một lần vào tab tài liệu PcbDoc3D ở phía trên không gian thiết kế đồ họa để chuyển trạng thái hoạt động sang tài liệu đó, rồi nhấn phím Delete. Các pad đã chọn sẽ không bị xóa vì chúng là đối tượng con của các linh kiện chứa chúng, do đó chỉ có thể xóa chúng cùng với các linh kiện đó.
Đặt một vùng đặc
Có hỗ trợ đặt Vùng đặc (Solid Region). Đối tượng vùng có thể được dùng để tạo hình dạng đồng bất kỳ, đi qua các cạnh trong cấu trúc nếu cần. Video minh họa quy trình đặt một Vùng đặc lên cấu trúc 3D.
Lưu ý khi đặt Vùng đặc:
- Sử dụng các phím tắt 2 (ẩn linh kiện) và 3 (hiện linh kiện) để bật/tắt hiển thị linh kiện.
- Con trỏ sẽ bắt dính vào cả lưới căn chỉnh lẫn bản phác thảo được nhập cùng đế nền. Bật và cấu hình Alignment Grid (bảng Properties) và/hoặc các bản phác thảo (View » Show Sketches).
- Nhấp vào nút Place Solid Region trên Active Bar để bắt đầu đặt Vùng đặc.
- Phần mềm sẽ nhận diện hình đặc là phần diện tích nhỏ hơn được bao quanh bởi các đỉnh xác định qua những lần nhấp chuột. Nếu vùng bạn đang xác định đi qua nhiều bề mặt của đế nền 3D, phần mềm có thể không suy luận chính xác được phần diện tích bên trong và bên ngoài của vùng. Nếu cần, bạn có thể chuyển đổi vùng giữa inside và outside và phần diện tích bạn đã xác định bằng cách nhấn Spacebar trong khi đặt.
- Khi đã sẵn sàng, nhấp chuột phải để thoát chế độ đặt vùng. Phần mềm sẽ tự động xác định cạnh cuối cùng nối vị trí nhấp cuối cùng với vị trí nhấp đầu tiên.
- Sau khi đặt, hình dạng của vùng không thể được chỉnh sửa tương tác.
-
Nhấp một lần vào vùng đã đặt để chọn vùng đó. Sau khi chọn:
- Bạn có thể xác định tên net trong bảng Properties nếu muốn vùng kết nối với một net.
- Nhấn phím Delete để xóa các vùng đã chọn.
- Có thể tạo các vùng cong bằng cách vẽ theo một bản phác thảo cong đã nhập, như minh họa trong video bên dưới. Tìm hiểu thêm về nhập bản phác thảo.
- Trong quá trình xuất, nhiều vùng chồng lấn thuộc cùng một net sẽ được hợp nhất thành một vùng duy nhất. Thao tác này tạo ra các vùng có phần khoét, như minh họa trong video bên dưới.
Via trong thiết kế 3D-MID
Có thể tạo via trong quá trình sản xuất 3D-MID, nhưng phải tuân theo một số ràng buộc. Bạn nên trao đổi trực tiếp với nhà sản xuất để xác định khả năng sản xuất về mặt này. Công cụ 3D-MID chưa triển khai hỗ trợ đầy đủ cho via, nhưng bạn vẫn có thể đưa chúng vào thiết kế bằng quy trình sau.
- Khác với PCB tiêu chuẩn, mỗi pad via phải được xem là một linh kiện. Cần tạo một linh kiện pad via, bao gồm một chân duy nhất trong ký hiệu nguyên lý và một pad duy nhất tương ứng trong footprint.
- Việc đưa via vào thiết kế bao gồm các bước đặt thủ công, gán tên net và đi dây. Trình chiếu sau minh họa quy trình này.
|
Trong ví dụ này, giả sử chúng ta muốn kết nối hai pad linh kiện như được biểu thị bằng đường kết nối màu vàng, nhưng sử dụng ba đường mạch và hai via như được biểu thị bằng màu xanh lam. Khác với PCB tiêu chuẩn, mỗi pad via cần được xem là một linh kiện. Cần tạo một linh kiện pad via, bao gồm một chân duy nhất trong ký hiệu nguyên lý và một pad duy nhất tương ứng trong footprint. Kéo hai linh kiện pad via từ bảng Components lên một bề mặt của đế nền. Kéo thêm hai linh kiện pad via lên mặt đối diện của đế nền, sử dụng lưới để căn chúng thẳng hàng với hai linh kiện đầu tiên. Chọn một trong các pad linh kiện để xác định tên net liên quan; trong ví dụ này là Sử dụng chế độ Components trong bảng PCB, nhấp đúp để chỉnh sửa và gán một Designator duy nhất cho mỗi via,
Để đặt thuộc tính Net cho tất cả các pad 3dVia này trong một lần chỉnh sửa, trước tiên hãy chọn chúng trong phần Linh kiện của PCB bảng điều khiển (lưu ý rằng hộp kiểm Select được bật), sau đó chọn bốn pad trong phần Component Primitives của bảng điều khiển. Bây giờ hãy chuyển sang bảng điều khiển Properties, nơi bạn có thể gán tên net cho bốn pad đó (lưu ý phần dưới cùng của bảng điều khiển cho biết có bao nhiêu đối tượng được chọn để chỉnh sửa). Các đường kết nối sẽ cập nhật để cho biết các pad via hiện có cùng net với các pad linh kiện. Đi dây các kết nối trên bề mặt đang hiển thị của đế. Lật đế lại và đi dây kết nối trên bề mặt còn lại của đế. Lúc này, các đường kết nối duy nhất còn lại là những đường biểu thị chính các via. Không thể hoàn tất các kết nối này trong công cụ thiết kế. Người thiết kế cần cho nhà sản xuất biết những pad nào cần được khoan xuyên và mạ để tạo thành via. Nếu thông tin kết nối trong tài liệu 3D-MID được xác định bởi tài liệu sơ đồ nguyên lý, để duy trì tính nhất quán giữa hai tài liệu, các linh kiện pad via cũng phải được thêm vào sơ đồ nguyên lý và nối vào cùng net như trong bố trí mạch. Thay vì kéo linh kiện từ bảng điều khiển, hãy nhấp chuột phải và chọn Place từ menu ngữ cảnh, nhưng chưa đặt gì cả. Trong khi linh kiện đang đi theo con trỏ, nhấn phím Tab trên bàn phím để chỉnh sửa ký hiệu định danh before của linh kiện đang đặt. Nếu thực hiện thao tác này, khi bạn tiếp tục nhấp để đặt ba linh kiện còn lại, ký hiệu định danh của chúng sẽ tự động tăng dần. Nối dây cho các linh kiện via theo yêu cầu. Để đồng bộ sơ đồ nguyên lý và bố trí mạch, chọn Design » Update PCB 3D Document từ các menu của trình biên tập sơ đồ nguyên lý. Khi đó, hộp thoại Component Links sẽ xuất hiện; hãy dùng nút này để tự động liên kết từng linh kiện mới trên sơ đồ nguyên lý với linh kiện 3D-MID tương ứng. Sau khi bạn nhấp vào OK để chấp nhận các cập nhật liên kết, hộp thoại ECO sẽ xuất hiện, liệt kê chi tiết tất cả các thay đổi cần thực hiện để đồng bộ tài liệu sơ đồ nguyên lý và bố trí mạch. Nhấp vào Execute để áp dụng các thay đổi này. Để xác nhận quá trình đồng bộ đã thành công, chọn Design » Import Changes từ các menu của trình biên tập 3D-MID. |
Kiểm tra quy tắc thiết kế (DRC) cho thiết kế 3D-MID
Trình biên tập tài liệu 3D-MID cho phép thực hiện kiểm tra quy tắc thiết kế (DRC) hàng loạt để phát hiện các vi phạm đối với đường mạch đã đi trên đế 3D của bạn theo các quy tắc sau:
Việc cấu hình kiểm tra quy tắc thiết kế được thực hiện trong hộp thoại Design Rule Checker, truy cập qua lệnh Tools » Design Rule Check từ các menu chính.
Để biết thêm thông tin về cách thiết lập và chạy DRC, hãy tham khảo trang Thiết lập & chạy DRC.
Xuất PCB 3D
Sau khi hoàn tất thiết kế, bạn có thể xuất thiết kế 3D-MID bằng lệnh File » Export » 3D-MID. Dữ liệu xuất sẽ được lưu vào thư mục dự án cục bộ.
|
Thiết kế hoàn chỉnh trong trình biên tập Altium 3D-MID; dữ liệu đã xuất được mở trong MCAD; và sản phẩm được kết xuất trong MCAD. Lưu ý rằng các linh kiện không được xuất kèm khi dùng lệnh Export » 3D-MID. |
Các thiết lập xuất mặc định (liệt kê bên dưới) thường phù hợp với quy trình tạo cấu trúc trực tiếp bằng laser (Laser Direct Structuring), nhưng bạn có thể cấu hình các tùy chọn khác bằng các thiết lập Advanced Settings tương ứng nếu cần.
| Tùy chọn | Đầu ra mặc định | Các tùy chọn Advanced Settings |
|---|---|---|
| Định dạng | STEP IGES Parasolid |
Chọn định dạng cần dùng trong hộp thoại Export File |
| Nội dung | Đế và mẫu dẫn điện
|
Chỉ mẫu dẫn điện
|
| Cấu trúc | Đế và mẫu dẫn điện dưới dạng các chi tiết riêng biệt trong một cụm lắp ráp
|
Đế và mẫu dẫn điện dưới dạng các đặc trưng/khối riêng biệt trong một chi tiết
|
| Độ dày mẫu dẫn điện | 0
|
Giá trị bất kỳ được đùn vào trong và/hoặc ra ngoài đế
|
Bạn cũng có thể kiểm soát cách xử lý các vùng chuyển tiếp giữa các bề mặt dẫn điện (vùng hợp nhất) trong tệp xuất bằng cách thay đổi giá trị của hai tùy chọn Advanced Settings. Tìm merge trong hộp thoại Advanced Settings để nhanh chóng xác định các thiết lập, như minh họa trong hình bên dưới.
Ảnh hưởng của các thiết lập này đến dữ liệu xuất được trình bày trong bảng sau:
| TrackToTrackMergeMode=0 | TrackToTrackMergeMode=1 | TrackToTrackMergeMode=2 | |
|---|---|---|---|
| PadToTrackMergeMode=0 | ![]() |
![]() |
![]() |
| PadToTrackMergeMode=1 | ![]() |
![]() |
![]() |
| PadToTrackMergeMode=2 | ![]() |
![]() |
![]() |
Dữ liệu đầu ra khác của dự án
-
Các đầu ra dự án lấy dữ liệu từ tài liệu sơ đồ nguyên lý, chẳng hạn như bảng kê vật liệu (BOM), vẫn khả dụng như bình thường.
-
Các đầu ra dự án phụ thuộc vào tài liệu PCB, chẳng hạn như bản vẽ lắp ráp Draftsman, hiện chưa khả dụng cho tài liệu 3D-MID.
-
Khi xuất thiết kế 3D-MID (File » Export » 3D-MID), một tệp
txtgắp và đặt được tạo trong cùng thư mục với tệp 3D-MID đã xuất (STEP, IGES hoặc Parasolid). Tệp này chứa thông tin về vị trí của từng linh kiện trong thiết kế: tọa độ X, Y và Z của tâm linh kiện cùng các vectơ xoay của linh kiện. Các vectơ xoay phụ thuộc vào tay nắm xoay của linh kiện (hiển thị khi linh kiện được chọn):- Vectơ xoay 1 là vectơ ngược hướng với tay nắm xoay.
- Vectơ xoay 2 là vectơ pháp tuyến của bề mặt tại điểm đặt linh kiện.
- Vectơ xoay 3 hướng sang bên phải so với Vectơ xoay 1 khi nhìn từ trên xuống (ngược hướng với Vectơ xoay 2).













































