Bố trí PCB của bạn
Altium Essentials: PCB Introduction
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
Sơ lược
- Cách thiết lập trình biên tập PCB và tài liệu PCB, bao gồm các tùy chọn, lưới và đơn vị đo.
- Cách xác định và chỉnh sửa hình dạng bo mạch, thiết lập gốc tọa độ và quản lý việc hiển thị các lớp khi làm việc trong trình biên tập PCB.
- Cách Altium Designer tổ chức các lớp phục vụ chế tạo và các lớp phi điện, cũng như vị trí cấu hình cấu trúc lớp và các loại via.
Bên trong mỗi sản phẩm điện tử đều có một bảng mạch in, hay PCB. Ngày nay, linh kiện đã thu nhỏ đến mức kích thước được đo bằng các phần của milimét thay vì centimét, và chiều rộng đường mạch cũng đã giảm từ những đường rộng 10 mil, cách nhau khá xa, thành những đường mảnh như sợi tóc, chỉ rộng 2 hoặc 3 mil và nằm sát nhau. Tốc độ tín hiệu ngày càng tăng cũng khiến các kết nối trên PCB chuyển từ những đường dẫn đồng đơn giản truyền năng lượng điện sang hoạt động như các đường truyền tốc độ cao, đòi hỏi các kỹ thuật thiết kế phù hợp. Các yêu cầu cơ khí cũng trở nên phức tạp hơn. Những sản phẩm điện tử hiện đại nhỏ gọn, có hình dạng khác thường đòi hỏi các bảng mạch in cũng nhỏ gọn và có hình dạng khác thường, thường được triển khai dưới dạng cấu trúc cứng–mềm kết hợp. Những bảng mạch này có thể có cạnh cong và các phần khoét, đòi hỏi linh kiện phải được bố trí cẩn thận.
Những thách thức này có thể được giải quyết bằng các công nghệ thiết kế PCB của Altium. Trình biên tập PCB của Altium Designer cho phép bạn tạo, chỉnh sửa và kiểm tra các thiết kế PCB.
Thiết lập trình biên tập PCB
Danh mục PCB Editor trong hộp thoại Preferences (truy cập bằng cách nhấp vào biểu tượng
ở góc trên bên phải của không gian thiết kế) cho phép truy cập các trang tùy chọn ảnh hưởng đến cách hoạt động của trình biên tập PCB. Bạn có thể truy cập các tùy chọn này bất cứ lúc nào để cấu hình thiết lập theo nhu cầu.

Sử dụng danh mục PCB Editor trong Preferences của Altium Designer để thiết lập trình biên tập PCB.
Tìm hiểu thêm về các tùy chọn PCB: Tùy chọn trình biên tập PCB.
Thiết lập tài liệu PCB
Để bắt đầu bố trí PCB, hãy thêm một tài liệu PCB mới vào dự án PCB. Để thực hiện, nhấp chuột phải vào mục của dự án trong bảng Projects và chọn lệnh Add New to Project » PCB từ menu ngữ cảnh. Tài liệu PCB mặc định sẽ xuất hiện trong không gian thiết kế.

Tài liệu PCB mới tạo sẽ là tài liệu đang hoạt động trong không gian thiết kế.
Các tùy chọn của tài liệu PCB được cấu hình trong bảng Properties khi không có đối tượng nào được chọn trong không gian thiết kế. Các tùy chọn chính được cấu hình trên tab General của bảng:
-
Thiết lập lưới (vùng Grid Manager) – cấu hình các tùy chọn của lưới toàn cục mặc định hoặc thêm các lưới khác (Đề-các và cực) theo nhu cầu. Lưới đảm bảo việc di chuyển và đặt đối tượng chính xác.
- Đơn vị (vùng Other) – chọn đơn vị đo mong muốn (mm hoặc mils) cho tài liệu.

Cấu hình các tùy chọn của tài liệu PCB trong bảng Properties.
Tìm hiểu thêm về cách cấu hình tài liệu PCB: Thiết lập môi trường PCB.
Xác định hình dạng bảng mạch và gốc tọa độ
Hình dạng bảng mạch, còn gọi là đường bao bảng mạch, xác định phạm vi tổng thể của bảng mạch. Theo mặc định, bảng mạch là một hình chữ nhật có kích thước 6000 x 4000 mil (152,4 x 101,6 mm). Trình biên tập PCB cung cấp nhiều công cụ để xác định hình dạng bảng mạch theo nhu cầu.
Bạn có thể xác định tương tác một hình dạng bảng mạch mới theo quy trình sau:
-
Vào chế độ lập kế hoạch bảng mạch của trình biên tập bằng cách chọn lệnh View » Board Planning Mode từ các menu chính.
-
Chọn lệnh Design » Redefine Board Shape từ các menu chính.
-
Định vị con trỏ và nhấp để cố định đỉnh bắt đầu của hình dạng bảng mạch.
-
Di chuyển con trỏ đến vị trí đặt đỉnh thứ hai rồi nhấp để đặt đỉnh.
-
Tiếp tục di chuyển chuột và nhấp để đặt các đỉnh tiếp theo.
-
Sau khi đặt đỉnh cuối cùng, nhấp chuột phải để khép kín và hoàn tất việc xác định hình dạng bảng mạch. Không cần khép kín hình dạng bảng mạch theo cách thủ công vì trình biên tập PCB sẽ tự động hoàn tất hình dạng bằng cách nối điểm bắt đầu với điểm cuối cùng đã đặt.
Bạn cũng có thể chỉnh sửa hình dạng hiện có thay vì xác định lại theo quy trình sau:
- Vào chế độ lập kế hoạch bảng mạch của trình biên tập bằng cách chọn lệnh View » Board Planning Mode từ các menu chính.
- Chọn lệnh Design » Edit Board Shape từ các menu chính.
-
Nhấp, giữ và kéo một cạnh hoặc đỉnh của hình dạng bảng mạch để di chuyển.
- Thoát chế độ chỉnh sửa bằng cách nhấp vào bất kỳ vị trí nào trong không gian thiết kế (trên hoặc ngoài hình dạng bảng mạch).
Sử dụng lệnh View » 2D Layout Mode từ các menu chính để trở về chế độ bố trí 2D của trình biên tập.
Tìm hiểu thêm về các kỹ thuật xác định hình dạng bảng mạch hiện có: Xác định hình dạng bảng mạch.
Cấu hình cách hiển thị các lớp
Ngoài các lớp dùng để chế tạo bảng mạch, bao gồm lớp tín hiệu, lớp mặt phẳng nguồn, lớp mặt nạ và lớp in lụa, trình biên tập PCB còn hỗ trợ nhiều lớp không mang chức năng điện khác. Các lớp thường được nhóm như sau:
-
Electrical Layers – bao gồm 128 lớp tín hiệu và 16 lớp mặt phẳng nguồn bên trong.
-
Component Layers – các lớp dùng trong thiết kế linh kiện, bao gồm các lớp Overlay (in lụa), Solder (mặt nạ hàn) và Paste (kem hàn). Nếu một đối tượng được đặt trong mẫu chân linh kiện trên một trong các lớp này trong trình biên tập thư viện, khi linh kiện được lật từ mặt trên sang mặt dưới của bảng mạch, tất cả đối tượng được nhận diện trên một lớp linh kiện sẽ được lật sang lớp linh kiện tương ứng trong cặp. Điều này bao gồm cả các đối tượng trên các cặp lớp linh kiện do người dùng xác định (các lớp cơ khí được ghép cặp).
-
Mechanical Layers – phần mềm hỗ trợ số lượng không giới hạn các lớp cơ khí đa dụng, được dùng cho các tác vụ thiết kế như ghi kích thước, chi tiết chế tạo, hướng dẫn lắp ráp, v.v. Có thể chọn đưa các lớp này vào bản in và đầu ra Gerber nếu cần. Các lớp cơ khí cũng có thể được ghép cặp; khi được ghép cặp, chúng hoạt động như các lớp linh kiện. Các lớp linh kiện được ghép cặp được dùng cho những tác vụ như đặt thân 3D, bố trí điểm keo và mạ vàng chọn lọc trên các đầu nối cạnh.
-
Other Layers – bao gồm lớp Keep-Out (dùng để xác định các vùng cấm áp dụng cho tất cả các lớp đồng), lớp multi-layer (dùng cho các đối tượng có mặt trên tất cả các lớp tín hiệu, chẳng hạn như pad và via), lớp Drill Drawing (dùng để đặt thông tin khoan, chẳng hạn như bảng khoan) và lớp Drill Guide (dùng để hiển thị các dấu chỉ vị trí và kích thước lỗ khoan).
Các lớp đồng được thêm vào và xóa khỏi thiết kế trong Layer Stack Manager, sẽ được trình bày trong phần tiếp theo. Tất cả các lớp khác được bật và cấu hình trong bảng View Configuration.

Hai tab của bảng View Configuration
Ngoài trạng thái hiển thị lớp và thiết lập màu sắc, bảng View Configuration còn cho phép truy cập các thiết lập hiển thị khác bao gồm:
-
Màu sắc và trạng thái hiển thị của System Colors, chẳng hạn như màu lựa chọn hoặc việc có hiển thị các đường kết nối hay không.
-
Cách hiển thị từng loại đối tượng (đặc hoặc phác thảo) và độ trong suốt của đối tượng (phần Object Visibility).
-
Các tùy chọn chế độ xem khác nhau, chẳng hạn như có hiển thị Origin Marker, tên Pad Net và Pad Numbers hay không (phần Additional Options).
-
Mức độ làm mờ hiển thị khi các đối tượng được làm mờ hoặc che khuất (phần Mask and Dim Settings).
-
Tạo các bộ lớp, giúp chuyển đổi nhanh những lớp đang hiển thị bằng điều khiển
(phần Layers).
-
Tạo và chọn các cấu hình chế độ xem, dùng để cấu hình trước tất cả thuộc tính của lớp, chẳng hạn như màu sắc, trạng thái hiển thị, độ trong suốt của đối tượng, v.v. (phần General Settings).
Một số lưu ý về các lớp:
-
Các lớp hiện được bật hiển thị dưới dạng một dãy tab ở phía dưới không gian thiết kế PCB, như trong hình bên dưới. Nhấp chuột phải vào một tab để truy cập các lệnh hiển thị lớp thường dùng.
-
Khi đặt đối tượng lên PCB, bạn cần xem xét đối tượng sẽ được đặt trên lớp nào. Các đối tượng được đặt trên lớp hiện tại, được thể hiện bằng tab lớp đang hoạt động ở phía dưới không gian thiết kế. Trong hình trên, Top Layer là lớp đang hoạt động.
-
Để chuyển lớp đang hoạt động:
-
Nhấp vào tab lớp ở phía dưới không gian thiết kế, hoặc
-
Nhấn phím số + hoặc - để chuyển lần lượt qua tất cả các lớp, hoặc
-
Nhấn phím số * để chuyển lần lượt qua các lớp tín hiệu, hoặc
-
Sử dụng các phím tắt Ctrl+Shift+Mouse Wheel.
-
-
Trong một thiết kế dày đặc, việc chỉ hiển thị lớp đang làm việc có thể hữu ích; chế độ này được gọi là Single Layer Mode. Để bật/tắt chế độ hiển thị một lớp, nhấn phím tắt Shift+S. Các Available Single Layer Modes được cấu hình trên trang Trình biên tập PCB – Hiển thị Board Insight của hộp thoại Preferences. Mỗi lần nhấn Shift+S sẽ chuyển sang chế độ một lớp được bật tiếp theo.
Tìm hiểu thêm về cách cấu hình chế độ xem PCB: Chế độ xem PCB của bạn.
Xác định cấu trúc xếp lớp
PCB được thiết kế và cấu thành từ một chồng lớp được xác định trong Layer Stack Manager (Design » Layer Stack Manager). Layer Stack Manager mở trong một trình biên tập tài liệu tương tự như trang sơ đồ nguyên lý, PCB và các loại tài liệu khác. Các chức năng được phân chia theo các tab hiển thị ở phía dưới Layer Stack Manager. Các thao tác cấu hình chính được thực hiện trên các tab Stackup và Via Types.
Tab Stackup trình bày chi tiết các lớp chế tạo. Các lớp được thêm, xóa và cấu hình trong tab này.
|
Để thêm một lớp, hãy chọn một lớp trong vùng bảng mà lớp mới cần được thêm ở phía trên hoặc phía dưới, rồi nhấp vào nút Add ở phía trên Layer Stack Manager và sử dụng cửa sổ bật lên xuất hiện. Để xóa một lớp, hãy chọn lớp đó trong vùng bảng và nhấp vào nút Delete. Để chọn vật liệu lớp từ thư viện vật liệu, hãy chọn lớp cần thiết trong vùng bảng và nhấp vào nút Modify. Các thuộc tính được xác định cho vật liệu đã chọn sẽ được áp dụng cho lớp. Các thuộc tính của lớp đang được chọn cũng có thể được chỉnh sửa trực tiếp trong vùng bảng hoặc bảng Properties. |
Tab Via Types được dùng để xác định các yêu cầu cho phép về phạm vi xuyên lớp theo trục Z của các via được sử dụng trong thiết kế.
|
Loại via xuyên lỗ mặc định luôn có trong thiết kế PCB. Để thêm một loại via khác (via mù, via chôn hoặc microvia), hãy nhấp vào nút Add ở phía trên Layer Stack Manager rồi chọn các lớp mà loại via này đi qua trong các danh sách thả xuống First layer và Last layer trên bảng Properties khi loại via đó được chọn trong vùng bảng. Để xóa một loại via đã thêm, hãy chọn loại via đó trong vùng bảng và nhấp vào nút Delete. |
Sử dụng lệnh File » Save to PCB trong Layer Stack Manager để cập nhật các thay đổi vào PCB.
Tìm hiểu thêm về Layer Stack Manager: Xác định cấu trúc xếp lớp, Xác định via mù, via chôn & microvia.
Cấu hình các quy tắc thiết kế
Các quy tắc thiết kế giám sát và kiểm tra thiết kế theo những yêu cầu khác nhau, chẳng hạn như khoảng cách giữa các đối tượng đồng, độ rộng đường mạch, chiều dài các net, v.v. Các quy tắc thiết kế kết hợp lại thành một bộ hướng dẫn để trình biên tập PCB tuân theo.
Các quy tắc thiết kế được xác định và quản lý trong hộp thoại PCB Rules and Constraints Editor, được truy cập bằng cách chọn lệnh Design » Rules từ các menu chính.
Hộp thoại PCB Rules and Constraints Editor có hai phần:
- Bên trái hộp thoại hiển thị cây liệt kê các nhóm quy tắc có sẵn, các loại quy tắc trong từng nhóm, và các quy tắc riêng lẻ thuộc từng loại hiện đã được xác định.
- Bên phải hộp thoại hiển thị thông tin liên quan đến mục đang được chọn trong cây. Ví dụ, chọn một quy tắc riêng lẻ để hiển thị các thiết lập cho quy tắc đó.
Quy tắc thiết kế có ba nhóm thiết lập được mô tả bên dưới và minh họa trong các hình tiếp theo:
- Các thuộc tính chính của quy tắc – tại đây, bạn có thể đặt tên có ý nghĩa cho quy tắc và thêm chú thích nếu muốn.
- Phạm vi quy tắc – xác định các đối tượng cụ thể trong thiết kế mà quy tắc áp dụng. Tùy theo loại quy tắc, cần xác định một phạm vi (đối với quy tắc đơn đối tượng, xác định hành vi yêu cầu của một đối tượng) hoặc hai phạm vi (đối với quy tắc hai đối tượng, xác định sự tương tác giữa hai đối tượng).
- Các ràng buộc của quy tắc – những ràng buộc cụ thể cho quy tắc.
|
Các quy tắc thuộc loại Width là quy tắc đơn đối tượng. Cần xác định một phạm vi (Where the Object Matches) cho quy tắc đơn đối tượng. Các quy tắc thuộc loại Clearance là quy tắc hai đối tượng. Cần xác định hai phạm vi (Where the First Object Matches và Where the Second Object Matches) cho quy tắc hai đối tượng. |
Để tạo quy tắc mới, nhấp chuột phải vào loại quy tắc cần thiết trong cây của hộp thoại và chọn lệnh New Rule từ menu ngữ cảnh. Quy tắc mới sẽ được thêm vào cây bên dưới nhóm đã chọn. Chọn mục của quy tắc trong cây để chỉnh sửa.
Khi có nhiều quy tắc cùng loại áp dụng cho cùng một hoặc nhiều đối tượng, trình biên tập PCB sử dụng mức ưu tiên của quy tắc để bảo đảm quy tắc phù hợp có mức ưu tiên cao nhất được áp dụng. Nhấp vào nút Priorities ở cuối hộp thoại PCB Rules and Constraints Editor để mở hộp thoại Edit Rule Priorities và thay đổi mức ưu tiên theo yêu cầu. 1 là mức ưu tiên cao nhất. Khi thêm một quy tắc mới (bằng lệnh New Rule), quy tắc đó sẽ được gán mức ưu tiên cao nhất.
Tìm hiểu thêm về cách làm việc với quy tắc thiết kế PCB và các loại quy tắc cụ thể: Xác định, thiết lập phạm vi & quản lý quy tắc thiết kế PCB, Các loại quy tắc thiết kế PCB.
Bố trí linh kiện
Khi dữ liệu thiết kế được chuyển từ các sơ đồ nguyên lý của dự án PCB sang tài liệu PCB (bằng lệnh Design » Update PCB Document trong các menu chính của trình biên tập sơ đồ nguyên lý và quy trình thực thi ECO tiếp theo), các footprint mặc định của linh kiện dùng trong sơ đồ nguyên lý sẽ được đặt tại các vị trí bất kỳ trong tài liệu PCB. Các pad linh kiện sẽ được nối bằng các đường kết nối, theo các net (các chân linh kiện được kết nối) đã xác định trong sơ đồ nguyên lý.

PCB sau khi cập nhật từ sơ đồ nguyên lý.
Các thao tác cơ bản để xác định vị trí của một linh kiện trên PCB gồm:
- Để di chuyển linh kiện đến vị trí cần thiết, Click, Hold&Drag sau đó thả nút chuột để đặt linh kiện.
- Để xoay linh kiện, nhấn Spacebar trong khi kéo linh kiện.
- Để lật linh kiện sang mặt bên kia của bo mạch, nhấn L trong khi kéo linh kiện.
Các đường kết nối được tự động tối ưu lại khi bạn di chuyển linh kiện. Sử dụng chúng để hỗ trợ định hướng và bố trí linh kiện nhằm giảm số điểm giao nhau giữa các đường kết nối.
Tìm hiểu thêm về kết nối trên PCB và bố trí linh kiện: Tìm hiểu về kết nối trên PCB của bạn, Bố trí linh kiện.
Đi dây bo mạch
Đi dây là quá trình đặt các đường mạch, cung tròn và via trên bo mạch để kết nối các pad linh kiện. Trình biên tập PCB cung cấp các công cụ, bao gồm công cụ đi dây tương tác, để hỗ trợ đi dây các kết nối trên bo mạch.
Vì các công cụ đi dây hoạt động dựa trên quy tắc, việc cấu hình quy tắc thiết kế trước khi bắt đầu đi dây là rất quan trọng. Các quy tắc thiết kế chính được sử dụng trong quá trình đi dây tương tác gồm:
- Quy tắc Clearance (nhóm Electrical) – xác định khoảng cách tối thiểu cho phép giữa các đường dây của net đang được đi dây và những đối tượng khác trên bo mạch.
- Quy tắc Width (nhóm Routing) – xác định độ rộng đường dây của net đang được đi dây.
- Quy tắc Routing Via Style (nhóm Routing) – xác định đường kính và kích thước lỗ của via được đặt khi chuyển lớp trong quá trình đi dây.
Bạn cũng nên thiết lập lưới bắt điểm phù hợp cho việc đi dây.
Để đi dây một kết nối, hãy sử dụng công cụ Interactive Routing. Quy trình như sau:
-
Chọn lệnh Route » Interactive Routing từ các menu chính.
-
Nhấp vào pad linh kiện mà bạn muốn bắt đầu đi dây.
-
Định vị con trỏ, sau đó nhấp trong vùng thiết kế để đặt đường dây đến vị trí con trỏ. Tiếp tục xác định lộ trình đường dây.
-
Nhấp vào pad đích để hoàn tất đi dây cho kết nối. Kết nối sẽ được tự động nhả, và bạn vẫn ở chế độ đi dây tương tác, sẵn sàng đi dây cho kết nối tiếp theo.
-
Nhấp chuột phải để thoát chế độ đi dây tương tác.
Lưu ý về đi dây tương tác:
-
Khi bạn di chuyển con trỏ đến gần một pad trong lúc đi dây tương tác, con trỏ sẽ tự động bắt dính vào tâm pad. Đây là tính năng điểm bắt dính của đối tượng, kéo con trỏ đến điểm bắt dính của đối tượng điện gần nhất.
Tìm hiểu thêm về Làm việc với hệ thống bắt dính con trỏ.
-
Trong khi đi dây tương tác, bạn có thể sử dụng các phím tắt sau:
-
Tab để tạm dừng đi dây và mở bảng Properties nhằm cấu hình các tùy chọn đi dây tương tác. Khi hoàn tất, nhấp vào nút
trong không gian thiết kế để quay lại chế độ đi dây tương tác.
-
Shift+Spacebar để chuyển lần lượt qua các kiểu góc: Đường mạch 45°, Đường 45°/90° có cung tròn, Góc bất kỳ, v.v.
-
Spacebar để đổi hướng góc.
-
Shift+R để chuyển lần lượt qua các chế độ xử lý xung đột đi dây có sẵn: Đi vòng chướng ngại vật, Đẩy chướng ngại vật, Bỏ qua chướng ngại vật, v.v.
-
Ctrl+Shift+Wheel Scroll để chuyển sang lớp tín hiệu khả dụng tiếp theo và chèn một via.
-
Shift+F1 để hiển thị danh sách phím tắt đi dây tương tác.
-
-
Trong khi đi dây, các đoạn đường mạch được hiển thị theo những cách khác nhau (như trong các hình bên dưới):
-
Solid – đoạn đã được đặt.
-
Hatched – các đoạn có nét gạch chéo là những đoạn được đề xuất nhưng chưa được xác nhận; chúng sẽ được đặt khi bạn nhấp chuột.
-
Hollow – đây được gọi là đoạn dự kiến, giúp bạn xác định vị trí kết thúc của đoạn được đề xuất cuối cùng. Đoạn này not được đặt khi bạn nhấp chuột, trừ khi lần nhấp tiếp theo sẽ hoàn tất tuyến đi dây. Trong trường hợp đó, tùy chọn Automatically Terminate Routing sẽ được kích hoạt và ghi đè hành vi mặc định của đoạn dự kiến. Bạn có thể bật/tắt chế độ đoạn dự kiến bằng phím tắt
1trong khi đi dây.

Các đoạn đặc đã được đặt, các đoạn có nét gạch chéo được đề xuất nhưng chưa được xác nhận, còn đoạn rỗng là đoạn dự kiến. -
-
Một tính năng rất hữu ích để hình dung không gian còn trống cho việc đi dây là khả năng hiển thị ranh giới khoảng cách an toàn quanh tất cả các đối tượng thuộc net khác Sử dụng phím tắt
Ctrl+Wđể bật và tắt các ranh giới khoảng cách an toàn. Khi tính năng này được bật và một net đang được đi dây, tất cả các đối tượng thuộc net khác sẽ hiển thị ranh giới khoảng cách an toàn được xác định bởi ràng buộc khoảng cách điện áp dụng. Bạn không thể vượt qua ranh giới này trong khi đi dây. -
Trong khi đi dây, nhiều thông tin hữu ích, bao gồm tên net và thiết lập độ rộng hiện tại, được cung cấp trên màn hình Heads-Up và thanh trạng thái
-
Thay vì đi dây toàn bộ đến pad đích, bạn cũng có thể nhấn
Ctrl+Clickđể sử dụng chức năng Auto-Complete và yêu cầu bộ máy đi dây thử đi dây toàn bộ kết nối. Chức năng tự động hoàn tất hoạt động như sau:-
Chức năng này chọn đường đi ngắn nhất, nhưng đó có thể không phải là đường đi tốt nhất vì bạn luôn cần cân nhắc đường đi cho các kết nối khác chưa được đi dây. Nếu bạn đang ở chế độ Đẩy, chức năng tự động hoàn tất có thể đẩy các đường mạch hiện có để tới đích.
-
Với các kết nối dài hơn, đường đi tự động hoàn tất có thể không phải lúc nào cũng khả dụng vì đường đi được xác định theo từng phần, và có thể không xác định được đường đi hoàn chỉnh giữa pad nguồn và pad đích.
-
Bạn cũng có thể thực hiện Tự động hoàn tất (
Ctrl+Click) trực tiếp trên một pad hoặc đường kết nối.
-
Không có một giải pháp duy nhất cho việc đi dây trên bo mạch, vì vậy việc bạn muốn thay đổi cách đi dây là điều khó tránh khỏi. Trình biên tập PCB có các tính năng và công cụ hỗ trợ việc này. Có hai cách tiếp cận: đi dây lại hoặc sắp xếp lại.
-
Reroute – chọn lệnh Route » Interactive Routing và bắt đầu đi dây tại bất kỳ điểm nào trên một tuyến đi dây hiện có để xác định lại đường đi của kết nối. Tính năng Loại bỏ vòng lặp sẽ tự động xóa mọi đoạn đường mạch (và via) dư thừa ngay khi bạn khép kín vòng lặp và nhấp chuột phải để cho biết đã hoàn tất.
-
Rearrange –
Click, Hold&Dragđể trượt hoặc kéo các đoạn đường mạch trên bo mạch theo cách tương tác.
Tìm hiểu thêm về đi dây PCB: Đi dây PCB.
Đặt vùng đổ đồng đa giác
Để phủ một lớp tín hiệu của PCB bằng một vùng đồng lớn, bạn có thể sử dụng vùng đổ đồng đa giác. Vùng đổ đồng đa giác tự động đổ đồng quanh các đối tượng hiện có và chỉ kết nối với những đối tượng thuộc cùng net với vùng đổ đồng. Khoảng cách an toàn và các thuộc tính kết nối được kiểm soát bởi các quy tắc thiết kế Khoảng cách an toàn và Kiểu kết nối đa giác áp dụng.
Để đặt vùng đổ đồng đa giác:
- Chọn lệnh Place » Polygon Pour từ các menu chính.
-
Trong khi đặt, bạn có thể nhấn phím Tab để mở bảng Properties và cấu hình các thuộc tính của đa giác đang đặt: net, lớp, chế độ tô, v.v. Khi hoàn tất, nhấp vào nút
trong không gian thiết kế để quay lại chế độ đặt.
- Định vị con trỏ và nhấp chuột để cố định đỉnh bắt đầu của vùng đổ đồng đa giác.
-
Di chuyển con trỏ đến vị trí đặt đỉnh thứ hai và nhấp chuột để đặt đỉnh đó.
- Tiếp tục di chuyển chuột và nhấp để đặt các đỉnh tiếp theo.
- Sau khi đặt đỉnh cuối cùng, nhấp chuột phải để khép kín và hoàn tất việc đặt vùng đổ đồng đa giác. Bạn không cần khép kín hình đa giác theo cách thủ công vì trình biên tập PCB sẽ tự động hoàn thiện hình bằng cách nối điểm bắt đầu với điểm cuối cùng đã đặt.
- Tiếp tục đặt các vùng đổ đồng đa giác khác hoặc nhấp chuột phải để thoát chế độ đặt.
Khi một vùng đổ đồng đa giác được chỉnh sửa (ví dụ: hình dạng hoặc thuộc tính của nó đã thay đổi), vùng đó phải được đổ lại để phản ánh các thay đổi. Để đổ lại một đa giác, hãy chọn đa giác đó rồi nhấp vào nút Repour ở đầu bảng Properties.
Tìm hiểu thêm về vùng đổ đồng đa giác: Đa giác trên các lớp tín hiệu.
Thực hiện kiểm tra quy tắc thiết kế
Trình biên tập PCB cung cấp các chức năng Kiểm tra Quy tắc Thiết kế (DRC) để kiểm tra xem thiết kế của bạn có tuân thủ các quy tắc thiết kế đang được bật hay không.
Việc cấu hình kiểm tra quy tắc thiết kế được thực hiện trong hộp thoại Design Rule Checker, truy cập qua lệnh Tools » Design Rule Check từ các menu chính.
-
Nhấp vào mục Report Options trong cây ở bên trái hộp thoại để cấu hình các tùy chọn bổ sung có sẵn khi chạy DRC hàng loạt.
-
Nhấp vào mục Rules to Check hoặc một mục thuộc nhóm quy tắc cụ thể để hiển thị danh sách các loại quy tắc trong hộp thoại và bật từng loại quy tắc cho DRC trực tuyến và/hoặc DRC hàng loạt theo nhu cầu:
-
DRC trực tuyến – việc kiểm tra sẽ được thực hiện theo thời gian thực trong quá trình bạn thiết kế.
-
DRC hàng loạt – việc kiểm tra sẽ được thực hiện theo quy trình hàng loạt bằng cách nhấp vào nút Run Design Rule Check trong hộp thoại, với kết quả được liệt kê trong bảng Messages và có thể tạo thêm báo cáo.
-
Khi chạy DRC trực tuyến hoặc hàng loạt, các vi phạm quy tắc được phát hiện sẽ được hiển thị trong không gian thiết kế (bằng đồ họa đánh dấu vi phạm tùy chỉnh và/hoặc lớp phủ vi phạm). Dưới đây là một số ví dụ về vi phạm trong không gian thiết kế:

Các đường mạch vi phạm quy tắc Độ rộng. Vi phạm được hiển thị bằng cả đồ họa đánh dấu vi phạm tùy chỉnh và lớp phủ vi phạm.

Một đường mạch vi phạm quy tắc Nhánh cụt trên net. Vi phạm được hiển thị bằng đồ họa đánh dấu vi phạm tùy chỉnh.
Bạn có thể cấu hình cách hiển thị vi phạm của các loại quy tắc khác nhau trong không gian thiết kế bằng trang Trình biên tập PCB – Hiển thị vi phạm DRC trong hộp thoại Preferences.
Dựa trên thông tin về mức độ vi phạm, bạn có thể quyết định cách khắc phục phù hợp nhất. Ví dụ, nếu ràng buộc về độ rộng tối thiểu của dải solder mask được đặt là 0,25 mm và độ rộng thực tế là 0,24 mm, thì tình trạng này không quá nghiêm trọng và bạn có thể điều chỉnh ràng buộc để chấp nhận giá trị đó. Nhưng nếu độ rộng thực tế là 0,02 mm, thì có lẽ không thể khắc phục tình trạng này bằng cách điều chỉnh ràng buộc.
-
Thông tin chi tiết được đưa vào bảng Messages. Giá trị thực tế được nêu chi tiết cùng với giá trị đã quy định (ví dụ: 0.017mm < 0.254mm).
-
Bạn cũng có thể nhấp chuột phải vào một vi phạm và mở menu con Violations để xem ràng buộc nào đang bị vi phạm và các điều kiện gây vi phạm
-
Trình biên tập PCB cũng có các công cụ đo tiện dụng, cho phép bạn đo khoảng cách giữa hai điểm, đo các đối tượng được chọn (chiều dài của đường mạch và cung tròn được chọn), cũng như đo khoảng cách giữa hai đối tượng cơ bản. Tham khảo trang Đo khoảng cách trên PCB để tìm hiểu thêm.
Bảng PCB Rules And Violations là một tính năng rất hữu ích để xác định vị trí và tìm hiểu các điều kiện gây vi phạm. Theo mặc định, bảng sẽ hiển thị [All Rules] trong danh sách Rule Classes. Khi đã xác định loại quy tắc cần quan tâm, hãy chọn nhóm quy tắc cụ thể đó để chỉ các vi phạm tương ứng được hiển thị ở cuối bảng. Bảng cung cấp chi tiết về loại vi phạm, giá trị đo được, ràng buộc và các đối tượng vi phạm. Các vi phạm quy tắc được phát hiện thuộc nhóm quy tắc hoặc quy tắc cụ thể đã chọn cũng được liệt kê trong vùng Violations của bảng. Nhấp vào một mục vi phạm để làm nổi bật vi phạm trong không gian thiết kế, theo thiết lập ở đầu bảng: Mask/Dim/Normal, Select, Zoom. Nhấp đúp vào một vi phạm để mở hộp thoại Violation Details.
Bạn cũng có thể chạy DRC cho tất cả quy tắc, các quy tắc thuộc một loại cụ thể hoặc một quy tắc cụ thể bằng cách nhấp chuột phải vào mục tương ứng trong bảng PCB Rules And Violations và chọn lệnh Run DRC.

Chạy DRC ngay từ bảng PCB Rules And Violations. Ví dụ ở đây minh họa việc chạy DRC cho tất cả các quy tắc Khoảng cách đã được định nghĩa.
Tìm hiểu thêm về DRC: Kiểm tra Quy tắc Thiết kế (DRC).















).
).


).