访问、定义和管理项目选项
Altium Essentials: Schematic Electrical Rules Validation
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

Project Options 对话框的 General、Error Reporting 和 Options 选项卡
概述
现有项目或新建项目都关联着一系列特定于该项目的选项设置。这些设置存储在项目文件(例如 *.PrjPcb)中,并因项目类型而异。选项设置在 Project Options 对话框中配置。
访问方式
可通过以下任一方式访问 Project Options 对话框:
- 在 Projects 面板中右键单击项目条目,然后从右键菜单中单击 Project Options。
-
当所需项目在 Projects 面板中处于焦点状态时,单击该面板中的
图标。
- 在任意编辑器中,从主菜单中选择 Project » Project Options。
对话框选项卡
常规

Project Options 对话框的 General 选项卡
Project Options 对话框的 General 选项卡可用于控制工作区项目的在线可用性和同步。
选项/控件
如果在已断开与项目所属工作区的连接时访问此选项卡,则唯一可用的选项是 Turn Off Synchronization 按钮。
对于非工作区项目,Project Options 对话框的 General 选项卡将仅显示 Make Project Available Online 按钮。单击此按钮可打开 使项目在线可用对话框,完成必要步骤后,即可将项目添加到工作区。完成后,此对话框选项卡中的所有选项均可用。
常规
- Description - 使用此字段为项目提供可选描述。在工作区浏览器界面中浏览项目时,该描述将显示在描述字段中。
在线可用性和同步
-
Version Control - 此复选框的选中状态反映当前的在线可用方式。启用此选项,可将此项目存储在工作区的 Versioned Storage Git 设计存储库中并纳入版本控制系统 (VCS) 管理;禁用此选项,则使用简单同步。启用正式版本控制后,多位用户便可协同处理该项目,这意味着项目将与连接到您工作区的所有其他参与者共享。
-
Migrate to Altium 365 Versioned Storage - 启用此选项,可将使用外部 VCS 系统的项目迁移到 Altium 365 工作区原生 VCS。转换后的设计项目将保留之前的 VCS 提交历史记录,并可使用工作区中由原生 VCS 支持的功能,例如基于事件的历史时间线。此选项仅适用于镜像项目。
-
Server Folder - 项目所在的工作区文件夹。
-
Enable Conflict Prevention Notifications - 启用此选项以管理文件编辑访问权限。当团队成员正在编辑工作区项目中的同一文档时,您会收到提醒,从而避免潜在的数据冲突。
-
Turn Off Synchronization - 单击此按钮可关闭同步,确保本地项目副本不再链接到工作区中的项目。工作区中的项目将保持不变。
需求
-
Link Requirements – 如果 Requirements Portal 的模块尚未链接到设计项目,单击此按钮可打开 Link Requirements 对话框,从中选择要链接到项目的模块。
-
Linked Requirements – 如果 Requirements Portal 的模块已链接到设计项目,此条目将显示已链接的模块 。单击链接可更改当前的项目与模块映射关系。单击 Unlink 按钮可移除此链接。
请参阅设计中的需求页面以了解更多信息。
错误报告

Project Options 对话框的 Error Reporting 选项卡(适用于 PCB 项目)
Project Options 对话框的 Error Reporting 选项卡可用于定义验证项目时,源原理图文档中可能存在的各类电气违规和绘图违规的报告级别。验证项目时,这些违规设置将与连接矩阵选项卡上的设置结合使用,以检查源文档中的连接违规。
选项/控件
违规列表
此列表显示项目源文档中可能存在的所有电气违规和绘图违规。违规分为以下类别:
PCB Design:
Multi-board Design:
Harness Design:
每种具体违规类型均包含以下字段:
- Violation Type Description - 违规类型的简短描述。
-
Report Mode - 使用此字段指定未通过该项检查时的严重性级别。使用下拉列表从以下报告级别中进行选择:
-
右键菜单
右键菜单中提供以下命令:
- All Off - 将所有违规类型的 Report Mode 设置为 No Report。
- All Warning - 将所有违规类型的 Report Mode 设置为 Warning。
- All Error - 将所有违规类型的 Report Mode 设置为 Error。
- All Fatal - 将所有违规类型的 Report Mode 设置为 Fatal Error。
- Selected Off - 将所有选定违规类型的 Report Mode 设置为 No Report。
- Selected To Warning - 将所有选定违规类型的 Report Mode 设置为 Warning。
- Selected To Error - 将所有选定违规类型的 Report Mode 设置为 Error。
- Selected To Fatal - 将所有选定违规类型的 Report Mode 设置为 Fatal Error。
- Default - 将所有违规类型的 Report Mode 恢复为默认设置。
- Report Suppressed Violations in Messages Panel - 启用此选项后,即使违规已通过此选项卡被抑制,仍会显示在 Messages 面板中。
附加选项
- Set To Installation Defaults - 单击可将此选项卡中的选项恢复为安装时的默认设置。
连接矩阵

Project Options 对话框的 Connection Matrix 选项卡
Project Options 对话框的 Connection Matrix 选项卡提供了一个矩阵,用于建立元件引脚与端口、图纸入口等网络标识符之间的连接规则。它定义了应报告为警告或错误的逻辑或电气条件。例如,一个输出引脚连接到另一个输出引脚通常被视为错误,而两个无源引脚相连则不会。在验证项目时,将使用这些违规设置(结合 错误报告选项卡中定义的设置)检查源文档中的违规情况。
选项/控件
连接矩阵
此矩阵列出了引脚、端口和图纸入口各种组合之间所有可能的接线连接检查 ,同时也检查未连接的对象。矩阵按行和列交叉读取,行列交点处矩阵元素的颜色指定了编译器在检查该特定条件时的处理方式。
要更改矩阵中某项违规检查的报告模式,请单击两个对象所在行和列交点处的彩色方块。每单击一次,模式就会切换到下一个报告级别。支持以下级别:
- No Report
- Warning
- Error
- Fatal Error
右键菜单
右键快捷菜单中提供以下命令:
- All Off - 将矩阵中的所有条目设置为 No Report。
- All Warning - 将矩阵中的所有条目设置为 Warning。
- All Error - 将矩阵中的所有条目设置为 Error。
- All Fatal - 将矩阵中的所有条目设置为 Fatal Error。
- Default - 将所有条目恢复为默认设置。
附加选项
- Set To Installation Defaults - 单击可将此选项卡中的选项恢复为安装时的默认设置。
类生成

Project Options 对话框的 Class Generation 选项卡
Project Options 对话框的 Class Generation 选项卡用于配置和控制类的生成。类是某一特定类型设计对象的逻辑集合。例如,可以将一组相关元件归入一个独立的元件类,然后以该类为基础创建有针对性的规则。此选项卡提供的控件可用于确定,在将源原理图文档与 PCB 设计文档同步时,自动生成哪些类 以及生成哪些用户定义的类。
选项/控件
自动生成的类
-
Generate Net Classes for Buses - 勾选此选项,可为设计中的每条总线自动生成一个网络类。类的成员为相应总线(用于生成该类的总线)所包含的各个网络。
-
Generate Net Classes for Components - 勾选此选项,可为设计中的每个元件自动生成一个网络类。类的成员为相应元件(用于生成该类的元件)引脚所连接的网络。
-
Generate Separate Net Classes for Bus Sections - 勾选此选项,可为每个总线分段自动生成一个独立的网络类。通过指定一条实际属于较大总线一部分的总线来创建总线分段,例如,总线
D[15..0]中的D[15..8]。 -
Generate Net Classes for Named Signal Harnesses - 启用此选项,可为设计中的每个已命名信号线束自动生成一个网络类。类的成员为相应已命名信号线束(用于生成该类的信号线束)所汇集信号对应的网络。
-
Sheet-Level Class Generation Grid - 此区域允许您在单张原理图层级控制元件类和/或网络类的自动生成。此处列出了项目的所有源原理图 ,并显示每张原理图的以下信息:
- Sheet Name - 原理图文档的名称。
- Full Path - 文档所在文件夹的绝对路径。
-
Component Classes - 勾选此选项可为该图纸生成元件类。
- Generate Rooms - 勾选此选项可为元件类生成一个 Room。
-
Net Classes Scope - 使用此字段确定是否为该图纸生成网络类,以及生成的范围。此字段的下拉列表提供以下选项:
- None - 不为此图纸生成网络类。
- Local Nets Only - 为此图纸生成网络类,但仅包含该图纸的本地成员网络。
- All Nets - 为此图纸生成网络类,其中包含与该图纸关联的所有成员网络(包括本地网络以及连接到其他位置的网络)。
-
Structure Classes Generate Structure - 勾选此选项可为该图纸生成结构类。
结构类是一种特殊的类,可以将任意类型的类(网络类、元件类等)作为其成员。在将设计传输到 PCB 时,为工程中包含元件和/或网络的每张原理图图纸自动生成结构类,即可在 PCB 端忠实地呈现工程结构。结构类不仅可以在 PCB 中重现原理图文档结构,以实现高级导航,还可以用于逻辑查询,例如限定设计规则的作用范围或进行筛选。
用户定义类
- Generate Component Classes - 勾选此选项可在将设计传输到 PCB 时生成用户定义的元件类。您可以在原理图中为目标元件添加 ClassName 参数,并将其值设置为所需的类名,从而手动定义元件类。
- Generate Rooms for Component Class - 勾选此选项可根据用户定义的元件类生成 Room。这些元件需要具有参数名为“ClassName”的元件参数。
- Generate Net Classes - 勾选此选项可在将设计传输到 PCB 时生成用户定义的网络类。网络类通过使用网络类指令在原理图中手动定义。要将某个网络设为网络类的成员,请将网络类指令附加到相关导线或总线(或 Blanket)上,并将其 ClassName 参数的值设置为所需的类名。
► 了解如何创建用户定义的网络类
► 了解如何创建用户定义的元件类
附加选项
- Set To Installation Defaults - 单击可将此选项卡中的选项恢复为安装时的默认设置。
注意事项
-
要在将设计传输到 PCB 时生成类(自动生成和/或用户定义),必须确保在 Project Options 对话框的 比较器选项卡上,将相应的比较器设置设为 Find Differences,具体如下:
- 网络类 - 将比较类型 Extra Net Classes(位于 Differences Associated with Nets 类别中)设为 Find Differences。
- 元件类 - 将比较类型 Extra Component Classes(位于 Differences Associated with Components 类别中)设为 Find Differences。
-
此外,必须确保在 Project Options 对话框的 ECO 生成选项卡上,将相应的 ECO 设置设为 Generate Change Orders。
- 网络类 - 将修改类型 Add Net Classes(位于 Modifications Associated with Nets 类别中)设为 Generate Change Orders。
- 元件类 - 将修改类型 Add Component Classes(位于 Modifications Associated with Components 类别中)设为 Generate Change Orders。
比较器

Project Options 对话框的 Comparator 选项卡
Project Options 对话框的 Comparator 选项卡可用于定义比较文档时要查找和忽略的差异类型。对于每种可用的比较,您都可以使用 Mode 列中相应的下拉列表,选择查找或忽略差异。您可以根据需要,设置查找元件、网络、参数和物理对象的差异。
选项/控件
此对话框分为两个主要区域:
- 上方区域的标题为 Comparison Type Description/Mode,列出了每种可用比较类型的描述和比较模式。
- 下方区域的标题为 Object Matching Criteria,用于定义 Net、Net Class、Component Class、Differential Pair 和 Structure Class的匹配条件。
比较类型描述/模式
- Comparison Type Description - 此区域列出了工程中每种可用比较类型的描述。使用最右侧的滚动条滚动到 Differences Associated with Components、Differences Associated with Nets、Differences Associated with Parameters、Differences Associated with Physical 和 Differences Associated with Structure Classes,以查看/更改各区域的比较模式。
-
Mode - 单击某个条目,即可使用下拉列表更改比较模式:
-
Find Differences- 选择此选项可查找该比较类型的差异。 -
Ignore Differences- 选择此选项可忽略该比较类型的所有差异(不会执行该类型的比较)。
-
对象匹配条件
- Object Type - 对象类型列表,例如 Net、Net Class、Component Class、Differential Pair 和 Structure Class.
- Min Match % - 输入所需的最低匹配百分比,或单击该列右侧,然后使用上、下箭头键增大或减小数值。
- Min Matched Members - 输入所需的最少匹配成员数,或单击该列右侧,然后使用上、下箭头键增大或减小数值。
- Use Name Matching - 单击条目或使用下拉列表选择 After member matching 或 Never。
- Show Manual Matching Dialog - 单击条目或使用下拉列表选择 For unmatched objects 或 Never。
附加选项
- Ignore Rules Defined in PCB Only - 勾选此选项可忽略设计项目中仅在 PCB 中定义的规则。例如,执行工程变更单时,可以将原理图中的更改应用到 PCB;如果启用此选项,则会忽略仅在 PCB 中存在的规则。如果同一项目的原理图图纸中没有相应的规则,比较器将不会尝试添加新规则。
- Set To Installation Defaults - 单击可将此选项卡的选项恢复为安装时的默认设置。
ECO 生成

Project Options 对话框的 ECO Generation 选项卡
Project Options 对话框的 ECO Generation 选项卡可用于配置:根据比较器发现的差异生成工程变更单 (ECO) 时,可以包含哪些修改类型。
选项/控件
修改类型列表
此列表列出了将源原理图文档与 PCB 设计文档同步时,可通过工程变更单执行的所有修改。列表条目包括与 Components、Nets、Parameters、Structure Classes 等相关的修改类型类别。
每种具体的修改类型都包含以下字段:
- Modification Type Description – 简要描述修改类型(即同步器将执行的操作)。
-
Mode – 使用此字段可控制是否在生成的 ECO 中包含该修改类型。使用下拉列表从以下选项中选择:
- Generate Change Orders - 在生成的 ECO 中包含该修改类型。
- Ignore Differences - 从生成的 ECO 中排除该修改类型。
右键菜单
右键上下文菜单中提供以下命令:
- Report – 使用此命令可生成一份报告,列出当前配置的修改模式。随后将显示 Report Preview 对话框,并已加载该报告。使用此对话框中的各种页面/缩放控件检查报告,然后将其导出到文件或打印。
附加选项
- Push Component Designator Changes to Annotation File (if any) – 勾选可在标注文件中包含元件位号更改。
- Set To Installation Defaults – 单击可将此选项卡的选项恢复为安装时的默认设置。
选项

Project Options 对话框的 Options 选项卡
Project Options 对话框的 Options 选项卡可用于指定项目生成输出的输出路径及相关选项。您还可以指定各种网表选项以及网络标识符作用域。
选项/控件
-
Output Path – 从当前设计项目 (
*.PrjPcb) 生成输出文件时使用的默认输出路径。 - ECO Log Path – ECO 日志文件的默认输出路径。
-
Schematic Template Location – 使用此字段可指定用于查找项目原理图模板文件(
*.SchDot、*.SchDoc)的目录。
输出选项
- Open outputs after compile – 启用后,将打开编译设计项目后生成的文件。对于集成库包项目,启用此选项可在编译包项目后安装集成库。
-
Timestamp folder – 启用后,将为生成的输出(例如 BOM 报告 (Reports » Bill of Materials))创建带时间戳的文件夹。文件夹名称的格式为
<FolderName> Date Time,其中<FolderName>在 Output Path 字段中指定,Date和Time的格式与系统设置一致。 - Archive project document – 启用后,将归档项目文档。例如,从 PCB 设计生成制造输出(File » Fabrication Outputs 和 File » Assembly Outputs)时,目标输出文件夹中将包含相关 PCB 文档的副本。
- Use separate folder for each output type – 启用后,将为设计项目生成的每种输出类型创建单独的文件夹。此文件夹结构也会显示在 Projects 面板中。
网表选项
- Allow Ports to Name Nets – 启用后,将使用已连线端口的 Name 属性来命名网络,而不是使用系统生成的默认网络名称。
- Allow Sheet Entries to Name Nets – 启用后,将使用图纸入口名称来命名网络,而不是使用系统生成的默认网络名称。
- Allow Single Pin Nets – 启用后,允许存在仅包含单个引脚的网络。
-
Append Sheet Numbers to Local Net – 启用后,将原理图文档的 Sheet Number 参数(文档级参数)值附加到该图纸的局部网络名称中。局部网络是指不延伸到图纸之外的网络。对于延伸到图纸之外的网络(即非局部网络),此选项不适用。
- Higher Level Names Take Priority – 启用后,将使用层次结构中上层图纸上的网络标签来命名下层图纸上的网络。
-
Power Port Names Take Priority – 软件可通过将电源端口连接到普通端口,使全局电源网络局部化。这会强制将该图纸上连接到该电源端口的所有引脚划入一个独立的网络。启用此选项后,将强制使用分配给电源端口的网络名称来命名网络。
网络标识符作用域
多图纸设计在电气(或连接)层面上由网络标识符定义。网络标识符(网络标签、端口、图纸入口、电源端口和隐藏引脚)在同一网络中的各个点之间建立逻辑连接。这些连接可以位于同一张图纸内,也可以跨越多张图纸。当一个对象通过导线直接连接到另一个电气对象时,即存在物理连接。当两个相同类型的网络标识符(例如两个网络标签)具有相同的 Net 属性时,即建立逻辑连接。
创建设计的连接模型时,必须定义网络标识符之间的连接方式,这称为设置 Net Identifier Scope。多图纸设计中的图纸连接基本上有两种方式:水平连接,即从一张图纸直接连接到另一张图纸,再连接到下一张图纸,依此类推;垂直连接,即从子图纸连接到父图纸上代表该子图纸的图纸符号。在水平连接中,连接建立在端口与端口之间(也可以在网络标签与网络标签之间建立)。在垂直连接中,连接建立在图纸入口与端口之间。
使用下拉列表从以下作用范围中进行选择:
-
Automatic (Based on project contents) – 此模式根据以下条件自动选择要使用的网络标识符模式:如果顶层图纸上存在图纸入口,则使用 Hierarchical;如果没有图纸入口,但存在端口,则使用 Flat;如果既没有图纸入口,也没有端口,则使用 Global。
- Flat (Only ports global) – 端口在整个设计的所有图纸之间全局连接。使用此选项时,网络标签仅在各自图纸内有效,即不会跨图纸连接。所有图纸上名称相同的端口都会连接在一起。此选项可用于扁平式多图纸设计。不建议将其用于大型设计,因为可能难以跨图纸追踪网络。
- Hierarchical (Sheet entry <-> port connections, power ports global) – 在端口与匹配的图纸入口之间建立垂直连接。此选项仅通过图纸符号入口和匹配的子图纸端口建立图纸间连接。它使用图纸上的端口,将网络或总线向上连接到父图纸上相应图纸符号的图纸入口。没有匹配图纸入口的端口不会建立连接,即使另一张图纸上存在同名端口也是如此。网络标签仅在各自图纸内有效,即不会跨图纸连接。但是,电源端口是全局的——整个设计中名称相同的所有电源端口都会连接在一起。此选项可用于创建任意深度或层次结构的设计,并允许在打印出的原理图上追踪贯穿整个设计的网络。
- Strict Hierarchical (Sheet entry <-> port connections, power ports local) – 此连接模式的行为与 Hierarchical 模式相同,区别在于电源端口仅在各自图纸内有效,即不会跨图纸连接到同名电源端口。
- Global (Netlabels and ports global) – 端口和网络标签在整个设计的所有图纸之间连接。使用此选项时,所有图纸上具有相同网络标签的所有网络都会连接在一起。此外,所有图纸上名称相同的所有端口也都会连接在一起。如果连接到端口的网络同时具有网络标签,则其网络名称将采用网络标签的名称。此选项也可用于扁平式多图纸设计,但由于在原理图上目视查找网络名称并不总是很容易,因此难以从一张图纸追踪到另一张图纸。
允许使用以下方法进行引脚交换
在 PCB 编辑器中,引脚、差分对和部件交换通过交换元件焊盘上的网络及其对应的铜箔来完成。将这些更改合并到原理图时,有两种处理引脚交换的方式:
-
Adding / Removing Net-Labels – 启用此选项可允许交换元件符号上的引脚。只有通过网络标签建立连接时,即引脚之间没有通过导线直接连接时,才能通过交换网络标签在原理图上完成交换。
-
Changing Schematic Pins – 启用此选项可允许交换连接到元件引脚的导线上的网络标签。当网络已通过导线直接连接到元件时,交换引脚将是唯一可用的选项。此方法可用于简单元件(例如电阻阵列),或由于原理图设计结构的限制而没有其他选择的情况。
常规
- Automatic Sheet Numbering – 启用此选项可自动为此项目中的原理图图纸编号。这样可以控制图纸标识,并将其作为参数存储在相应的原理图文档中。
-
Automatic Cross References – 启用此选项可自动向当前项目中的所有源原理图文档添加端口、图外连接器和图纸入口的交叉引用信息。此功能有助于在非层次化设计中追踪网络连接。
- New Indexing of Sheet Symbols – 启用此选项可使用任意数字 作为重复图纸符号的起始或结束索引,包括 0。不允许使用负数。结束索引必须始终大于起始索引。
交叉引用
-
Sheet Style – 选择以下图纸样式之一,用于项目中一张或多张原理图图纸上端口的交叉引用。
-
None– 不在任何端口的交叉引用字符串中添加图纸样式。 -
Name– 在交叉引用字符串中添加端口所链接的图纸名称。 -
Number– 在交叉引用字符串中添加端口所链接的图纸编号。
-
-
Location Style – 选择以下位置样式之一,用于项目中一张或多张原理图图纸上端口的交叉引用。
-
None– 不在任何端口的交叉引用字符串中添加位置样式。 -
Zone– 在所有与父级对象关联的端口的交叉引用字符串中添加参考分区编号(图纸边框带有分区),例如图纸符号所在位置的分区编号。 -
Location X,Y– 在所有与父级对象关联的端口的交叉引用字符串中,以括号形式显示端口的位置,例如图纸符号所在的位置。
-
- Follow Cross References settings in Preferences – 启用此选项后,Sheet Style 和 Location Style 选项的值将继承自 Preferences 对话框中 原理图 – 常规页面 的 Port Cross References 区域中的选项。
-
Display Cross References for:
-
Ports – 使用下拉列表选择端口交叉引用的显示模式。
-
Disabled– 不为端口添加交叉引用。 -
Only Related Sheet Entry– 显示指向父级原理图图纸上关联图纸入口的交叉引用。 -
Only Related Ports– 显示指向关联端口的交叉引用。 -
Sheet Entry & Ports– 显示指向图纸入口和端口的交叉引用。
-
- Off-sheet Connectors – 启用此选项可显示图外连接器对象的交叉引用。
- Sheet Entries – 启用此选项可显示图纸入口对象的交叉引用。
-
Ports – 使用下拉列表选择端口交叉引用的显示模式。
差分对
-
Custom Diff Pair Suffix Grid – 列出默认差分对后缀(
_P/_N)及所有已定义的自定义差分对后缀,包括:- Positive Suffix – 差分对正端网络的后缀。
- Negative Suffix – 差分对负端网络的后缀。
- Add – 单击可向列表中添加一组新的后缀对。
- Remove – 单击可从列表中删除选定的后缀对。
xNets 创建
- Sources/Destinations – 定义以逗号分隔的元件位号前缀列表,这些元件可用作 xNets 中的源元件或目标元件。
- Discretes – 定义以逗号分隔的元件位号前缀列表,这些元件可用作 xNets 中的串联元件。
多通道

Project Options 对话框的 Multi-Channel 选项卡
Project Options 对话框的 Multi-Channel 选项卡用于定义多通道设计所使用的 Room 命名规则和元件位号格式。多通道设计是指在项目中多次引用同一张子图纸。您可以放置多个引用同一张子图纸的图纸符号,也可以在图纸符号的位号中包含 Repeat 关键字,使其实例化多次。
Altium Designer 提供真正的多通道设计功能,这意味着您可以在项目中重复引用单张图纸。任何必要的更改都只需在一处进行,重新编译项目后,这些更改便会传播到每个实例。Altium Designer 不仅支持多通道,还允许通道嵌套。
原理图上的单个逻辑元件到 PCB 上多个物理实例的映射,由此选项卡中定义的多通道位号规则控制。
选项/控件
Room 命名
-
Room Naming Style - 使用此字段指定 Room 的命名样式。当您从列表中选择一种样式时,下方的图像会随之更新,以展示设计中将采用的命名规则。编译设计时,会为设计中的每张图纸创建一个 Room,包括每个通道组和每个下层通道。共有五种可用样式:两种扁平样式和三种层次样式(包含路径的样式):
- Flat Numeric With Names
- Flat Alpha With Names
- Numeric Name Path
- Alpha Name Path
- Mixed Name Path
-
Level Separator for Paths - 使用层次命名样式(包含路径的样式)时,在此字段中指定用于分隔路径信息的字符/符号。默认使用下划线字符(_)。
- Preview - 当您更改 Room Naming Style 和/或 Designator Format 时,此区域中的图像会动态更新,以展示设计中将采用的命名规则。该图像给出了一个 2 x 2 嵌套通道设计的示例。较大的交叉阴影区域表示两个上层通道(或通道组),其中的阴影区域表示下层通道(每个通道中显示两个示例元件)。
元件命名
-
Designator Format - 使用此字段指定为设计元件分配位号时所用的格式。此字段的下拉列表提供以下八种预定义格式:五种平面格式,以及三种可用于层次化设计的格式(包含通道命名):
- $Component_$RoomName
- $RoomName_$Component
- $Component$ChannelAlpha
- $Component_$ChannelPrefix$ChannelAlpha
- $Component_$ChannelIndex
- $Component_$ChannelPrefix$ChannelIndex
- $ComponentPrefix_$ChannelIndex_$ComponentIndex
- $ComponentPrefix_$RoomName_$ComponentIndex
定义自定义位号格式
您也可以直接在 Designator Format 字段中输入内容,以定义自己的元件位号格式。构建格式字符串时可使用以下关键字:
- $RoomName - 关联通道的名称,由 Room Naming Style 字段中所选的样式决定。
- $Component- 元件的逻辑位号。
- $ComponentPrefix - 元件逻辑位号的前缀(例如,U1 中的 U)。
- $ComponentIndex - 元件逻辑位号的索引(例如,U1 中的 1)。
- $ChannelPrefix - 逻辑图纸符号的位号。
- $ChannelIndex - 通道索引。
- $ChannelAlpha - 以字符表示的通道索引。
注意事项
- 只有当设计中的通道总数少于 26 个,或者所使用的位号格式本身为层次化格式时,通道的字母索引才真正有用。
- 对于多通道设计,设计窗口中原理图图纸的底部会显示选项卡,每个通道(或通道组)对应一个选项卡。选项卡名称由图纸符号名称加上通道编号组成,例如 BANKA。这些是设计的编译视图(物理视图),而逻辑设计仍与之前一样保留在 Editor 选项卡上。
默认打印

Project Options 对话框的 Default Prints 选项卡
Project Options 对话框的 Default Prints 选项卡可用于设置 Altium Designer 各种编辑器的默认打印输出。从编辑器主菜单运行以下打印命令时,将使用这些指定的默认设置:
- File » Print
- File » Print Preview » Print
也可以在原理图编辑器和 PCB 编辑器中,从主菜单选择 File » Default Prints 命令,访问 Project Options 对话框的 Default Prints 选项卡。
选项/控件
此选项卡的主区域列出了可从原理图和 PCB 编辑器生成的所有受支持的打印输出。输出类型分为以下类别:
-
Assembly Outputs -
Documentation Outputs -
Fabrication Outputs -
Other Outputs -
Report Outputs -
Validation Outputs
每个条目显示以下信息:
- Output Description – 使用此打印输出类型输出的内容。
- Supports – 支持此打印输出类型的编辑器。
-
Default Print – 指示是否将此打印输出类型用作默认打印类型(启用或禁用)。
其他选项
-
Configure – 单击此按钮可打开相关对话框,以配置当前选中的打印输出。涉及的对话框包括:
- 打印对话框 – 用于配置装配图、复合图、PCB 打印、PCBLIB 打印、原理图打印、复合钻孔图、钻孔图/导引图、最终底图打印、电源平面打印以及阻焊层/焊膏层打印。
- PCB 3D 打印设置对话框 – 用于配置 PCB 3D 打印。
- PCB 3D 视频对话框 – 用于配置 PCB 3D 视频输出。
- PDF3D 对话框 – 用于配置 PDF3D 和 PDF3D MBA 输出。
- 高级文本打印属性对话框 – 用于配置报告打印和文本打印。定义打印输出的选项(例如页眉以及页码/行号)。您还可以指定使用特定字体。
- Wave Print Properties Form 对话框 – 用于配置 SimView 打印。
- 层叠报告设置对话框 – 用于配置板层叠报告输出。
- 报告管理器对话框 – 用于配置物料清单和 BOM 比较报告。
- 评论导出配置对话框 – 用于配置导出评论报告。
- 差异设置对话框 – 用于配置差异报告。
- 电气规则检查设置对话框 – 用于配置电气规则检查验证报告。
- Page Setup – 单击可打开当前所选打印输出的页面设置对话框。在此对话框中,您可以针对所选打印机配置打印输出的纸张、缩放和颜色设置。您还可以打开相关配置对话框和打印机设置对话框,预览打印输出,最后通过所选打印机打印输出。
搜索路径

Project Options 对话框的 Search Paths 选项卡
Project Options 对话框的 Search Paths 选项卡可用于指定工程的库文件和模型文件搜索路径。
选项/控件
搜索路径有序列表
此表格按顺序显示库文件和模型文件(例如 PCB 封装库、仿真模型和信号完整性模型)的搜索路径列表。您可以为每条路径指定筛选条件和递归设置。
- Path - 搜索路径的位置。
- Filter - 搜索筛选器。默认情况下,筛选器会搜索所有文件。
- Recursive - 勾选此项可 搜索搜索路径目录下的所有子目录。双击某个搜索路径可对其进行编辑。
支持以下文件类型:封装库(*.PcbLib)、仿真模型文件(*.mdl)、仿真子电路文件(*.ckt)、IBIS 模型文件(*.ibs)。
- Delete - 用于移除选定的搜索路径。
- Properties - 用于打开 Edit Search Path 对话框 以编辑选定搜索路径的属性。
- Move Up - 用于将选定的搜索路径上移一行。
- Move Down - 用于将选定的搜索路径下移一行。
在所有搜索路径中找到的文件
此表格 显示从 Ordered List of Search Paths 列表中找到的库文件和模型文件。使用 Refresh List 按钮可查看更新后的列表。
参数

Project Options 对话框的 Parameters 选项卡
Project Options 对话框的 Parameters 选项卡用于管理为工程定义的参数,这些参数通常称为 project-level parameters。通过使用特殊字符串,工程级定义的参数可用于工程中的所有原理图图纸和 PCB 文档:在原理图上使用 =<ProjectParameterName>(例如 =Project),在 PCB 上使用 .<ProjectParameterName>(例如 .Project)。参数可用于提供额外的设计信息。例如,工程级参数可作为全局数据源,为添加到原理图图纸和/或 PCB 文档中的特殊字符串提供参数数据,而 PCB 文档不支持局部参数。
工作区端的工程参数随工程一起保存在工作区中,并且只能通过工作区的浏览器界面进行编辑(有关 Editing a Project 的更多信息,请参阅 Altium 356 工作区 或 本地部署企业工作区 中的相关内容)。相比之下,设计端的工程参数保存在工程文件(*.PrjPcb)中,可以在 Altium Designer 中编辑。在 Project Options 对话框的 Parameter 选项卡中,工作区端的工程参数显示为蓝色图标(
),而设计端的工程参数显示为橙色图标(
)。
选项/控件
-
Parameters Grid – 主区域列出了当前为工程定义的所有参数,包括以下属性:
- Name – 参数的名称。
- Value – 参数的值。
-
Add – 单击可打开 Parameter Properties 对话框,在其中添加参数。使用 Name 和 Value 字段,分别为参数指定能够反映其用途的有意义的名称及其值。 这两个字段最多都允许输入 255 个字符。
- Remove – 单击可从参数列表中删除选定的参数。此选项不适用于工作区端的工程参数,因为这些参数只能在工作区中移除或编辑。
- Edit – 单击可打开 Parameter Properties 对话框,在其中修改当前选定参数的内容。此选项不适用于工作区端的工程参数,因为这些参数只能在工作区中移除或编辑。
- Refresh – 对于设计端的工程参数,单击可撤销上次所做的更改。对于工作区端的工程参数,单击可确保获取参数的最新版本。在工作区中对工作区端工程参数所做的更改,只有使用此选项后才会反映在此对话框中。
右键菜单
右键菜单中提供以下命令:
-
Edit – 用于在 Parameter Properties 对话框中修改当前选定的参数。 此命令不适用于工作区端的工程参数,因为这些参数只能在工作区中移除或编辑。
-
Add – 用于在 Parameter Properties 对话框中向列表添加新的设计端参数。
-
Remove – 用于从列表中删除所选参数。 此命令不适用于 Workspace 端的项目参数,因为这些参数只能在 Workspace 中删除或编辑。
-
Copy – 用于将所选参数复制到 Windows 剪贴板。
-
Paste – 用于将 Windows 剪贴板中的参数粘贴到参数列表中。 此命令不适用于 Workspace 端的项目参数,因为这些参数只能在 Workspace 中删除或编辑。
器件图纸

Project Options 对话框的 Device Sheets 选项卡
Project Options 对话框的 Device Sheets 选项卡用于指定器件图纸所在的文件夹及其顺序。
选项/控件
- Main region - 列出当前项目的 Device Sheet Folders 路径。 勾选 Include Sub-folders 可包含所列父文件夹的子文件夹。
- Move Up - 用于将所选器件图纸文件夹每次向上移动一级。
- Move Down - 用于将所选器件图纸文件夹每次向下移动一级。
- Add - 用于打开对话框,以查找要添加的新文件夹。
- Remove - 用于移除所选器件图纸文件夹。
受管输出作业

Project Options 对话框的 Managed OutputJobs 选项卡
Project Options 对话框的 Managed OutputJobs 选项卡用于配置可供此项目使用的输出作业模板列表,这些模板来自您所连接的 Workspace。
选项/控件
- Outputjob List - 按 Item Revision、Revision State、Description 和 Name 列出所有 Workspace 输出作业。
- Add - 单击可打开 Select configuration item (Output Jobs) 对话框,以选择所需的输出作业。
- Remove - 单击可移除所选输出作业。
)

