修改符号和封装

概览

在 Altium Designer 中维护数据库关联的符号和封装时,标准 DbLib 库与采用版本控制的 SVNDbLib 库有着不同的工作流程。本文介绍如何打开和编辑所引用的符号及默认封装、为 SVN 库设置本地工作文件夹,以及使用 Storage Manager 面板管理存储库中的更改并比较修订版本。继续阅读,让您更有信心地完成下一次库更新。

- 了解如何访问、编辑和保存所引用的符号及默认封装。
- 掌握 SVN 工作流程,包括检出库、刷新状态、更新文件和提交更改。
- 了解如何直观地比较库的修订版本,并查看检测到的差异。
使用 AI 深入了解:

除了维护数据库本身的内容外,还需要在必要时维护所引用的符号和模型。这包括修改原理图符号和封装模型。对于标准数据库库(DbLib),还包括修改仿真模型文件中的定义。

两种类型的数据库库(标准库和版本控制库)都支持在 DbLib/SVNDbLib 文档作为活动文档打开时,直接从其主视图访问所引用的符号和封装模型并进行编辑。以下各节将介绍具体操作方法。使用 SVNDbLib 时,操作稍复杂一些,但功能也更强大。

请注意,通过相应的活动数据库库文件,只能访问并编辑元件记录的符号和默认封装。请记住,默认封装模型是输入到映射至 Design Parameter [Footprint Ref] 的 Database Field Name 中的模型。

使用 DbLib 时

要打开元件所引用的符号/封装模型库文件进行编辑,请在 Table Browser 中右键单击该元件条目,然后从右键菜单中选择相应的命令:Open Symbol 或 Open Footprint。系统将打开相应的库文件,并将该符号/封装作为设计空间中的活动对象显示,供您编辑。

打开的库将是包含所引用符号/封装的库。如果数据库中包含库信息,则根据该信息确定具体的库;如果没有,则使用数据库库选项对话框的 Symbol and Model Search Paths 选项卡上定义的路径来查找(同时请确保相关库确实位于所声明的路径中)。请参阅前文中的为数据库库指定符号和模型库位置一节。

完成所需更改后,保存库文件。

直接从 DbLib 中访问数据库元件所引用符号的示例。直接从 DbLib 中访问数据库元件所引用符号的示例。

也可以在 DbLib 文件之外访问源库文件。您可以使用库编辑器的 File » Open 命令浏览并打开所需的库,或将库文件从 Windows 资源管理器直接拖放到 Altium Designer 中。

使用 SVNDbLib 时

如前所述,通过 SVNDbLib 文件访问并编辑数据库元件所引用的符号和模型,操作稍复杂一些,但功能也更强大。修改是在 SVN 存储库中所存储库文件的本地工作副本上进行的。

指定本地工作区

要修改元件符号和封装模型,需要将文件从存储库签出到本地工作目录。在 Preferences 对话框的数据管理 - SVN 库页面上指定所需目录。系统定义了一个默认工作文件夹位置:\Users\<ProfileName>\Documents\My Designs\SVNDBlib Working Folder。您可以根据需要更改该位置,方法是单击 Button used to browse and select the repository working folder 按钮浏览并选择现有文件夹,或直接输入文件夹路径。

指定为本地工作目录的文件夹应仅用于存放受版本控制文件的副本。其他文件(例如 *.SVNDbLib、*.mdb 和 *.xls)应放在其他目录中,因为这些文件不受版本控制。

指定本地工作目录。指定本地工作目录。

默认工作文件夹位置在默认情况下并不实际存在。从存储库签出文件时,系统会创建该文件夹。如果您通过直接输入路径指定了一个当前不存在的文件夹,系统也会在签出时创建它。

要将所有符号库和封装模型库从存储库快速签出到指定的本地工作文件夹,请从 SVNDatabaseLib 编辑器的主 Tools 菜单中运行 Check Out All Working Folders 命令。签出的文件夹将是数据库库选项对话框中 SVN Repository 选项卡的 Models Location 区域所指定的文件夹。

将存储在 SVN 存储库中、并作为 Database Library Options 的一部分指定的符号和封装签出到本地工作文件夹的示例。将存储在 SVN 存储库中、并作为 Database Library Options 的一部分指定的符号和封装签出到本地工作文件夹的示例。

进行更改

将符号库和封装模型库签出到指定的本地工作文件夹后,即可根据需要进行修改。具体而言,需要修改原理图符号和封装模型的本地副本,然后将这些更改提交回 SVN 存储库。

与 DbLib 一样,可以通过以下方法访问符号/模型进行编辑:

  • 在 SVNDbLib 文档中,右键单击 Table Browser 中的元件条目,然后从右键菜单中选择相应的命令:Open Symbol 或 Open Footprint。
打开的本地库将是包含所引用符号/封装的库。如果数据库中包含库信息,则根据该信息确定具体的库;如果没有,则使用数据库库选项对话框中 SVN Repository 选项卡上定义的模型位置来查找。请参阅前文中的为数据库库指定符号和模型库位置一节。
  • 如果 SVNDbLib 已添加到可用文件型库列表中,则可以直接通过元件面板访问编辑命令。选择所需的元件条目,然后分别使用 Edit Symbol 命令(位于 Components 区域的右键菜单中)或 Edit Footprint 命令(位于 Models 区域的右键菜单中)。
  • 使用库编辑器的 File » Open 命令,浏览并打开所需的库(位于本地工作文件夹中)。
  • 将库文件(位于本地工作文件夹中)从 Windows 资源管理器直接拖放到 Altium Designer 中。

无论使用哪种方法,完成所需更改后,都应保存库文件。

不过,已签出到本地工作文件夹的文件夹和文件与存储库本身之间的主要交互界面是存储管理器面板。当 SVNDbLib 文件为活动文档时,Storage Manager 面板将显示已签出到本地工作文件夹中的符号和模型文件夹。列出的具体文件夹由 Database Library Options 对话框中 SVN Repository 选项卡的 Model Locations 区域指定。

当 SVNDbLib 文件是 Altium Designer 中的活动文档时,Storage Manager 面板会反映本地工作文件夹的内容。 当 SVNDbLib 文件是 Altium Designer 中的活动文档时,Storage Manager 面板会反映本地工作文件夹的内容。

要打开库文件进行编辑,请在面板的 All Files 区域中右键单击其条目,然后从弹出的右键菜单中选择 Open。根据需要进行更改,并使用相应编辑器的标准 Save 命令,按常规方式保存文件。

将更改提交到存储库

Panel page: 存储管理器

虽然可以通过不同方式打开库进行编辑,但从 within Altium Designer 提交所做的任何更改,只能通过存储管理器面板执行。

在 Altium Designer 中,用于向存储库提交以及从存储库更新的控件仅在 Storage Manager 面板中提供。当然,您也可以使用外部 SVN 客户端的功能,在 Altium Designer 之外执行提交、更新和检查修改操作。

使用 Storage Manager 面板时,最重要的注意事项之一是刷新本地工作文件夹/文件(显示在面板中)与源代码管理存储库中对应文件夹/文件之间的链接状态。对于单独选中的库,可以使用面板 All Files 区域右键菜单中的 Refresh 命令来刷新状态。要快速刷新整个文件夹的状态,请使用 Ctrl+F5 键盘快捷键。

在多名库管理员协作的环境中,可能有多人负责维护源符号和模型文件的存储库,因此刷新源库的状态尤为重要。

使用本地符号库和模型库时涉及的状态条目如下:

图标 状态 说明
SVN icon - Normal No modification 库的本地副本与存储库中的副本完全相同。您可以打开文件并进行修改。
SVN icon - Out of Date Out of date 文件的本地副本(位于工作文件夹中)比存储库中的对应文件更旧,因此已过时。您需要先从存储库获取文件的最新版本,更新本地工作副本,然后才能修改并提交自己的更改。使用右键上下文菜单中的 Update 命令,从存储库获取最新文件。
SVN icon - Modified Modified 文件的本地副本已在 Altium Designer 中修改并保存到工作文件夹。要将本地更改推送到存储库,请右键单击该文件的条目,然后从上下文菜单中选择 Commit 命令。签入存储库后,状态将恢复为 No modification。
SVN icon - Conflict Conflict 在您提交自己编辑并保存的文件版本之前,另一位 Altium Designer 用户已提交了该文件。使用 Update 或 Resolve 命令,确定哪个文件版本将成为存储库中的最新修订版。
SVN icon - Locked Locked 文件已被您或其他用户锁定。其他用户无法将锁定的文件更新为存储库中的新修订版(除非强制解锁)。当其他状态条件也适用时,此状态可以与其他图标同时显示,例如 Modified SVN icon - Locked and Modified 或 No Modification SVN icon - Locked not Modified 对应的图标。
有关使用版本控制的更多信息,请参阅使用外部版本控制。

修订版的物理比较

可以对同一符号(模型库)的任意两个修订版进行物理比较。这样,您就可以直观、清晰地查看文件在连续或不连续的修订版之间发生的更改。

在 Storage Manager 面板中,比较操作通过面板底部的 VCS Revisions 区域执行。

Storage Manager 面板提供所选文件历史记录的两种视图,分别在独立区域中显示 VCS 修订版和本地历史记录。Storage Manager 面板提供所选文件历史记录的两种视图,分别在独立区域中显示 VCS 修订版和本地历史记录。

可以对任意两个修订版进行比较。使用 Windows 的 Ctrl+click 选择方式,在面板的 VCS Revisions 区域中选择要比较的两个库修订版,右键单击,然后选择 Compare。

调用 Compare 命令后,所选的两个文档修订版将在工作区中并排打开,系统会执行图形比较,并将检测到的所有差异列在 Differences 面板中。

直接在库编辑器的设计空间中进行图形比较。直接在库编辑器的设计空间中进行图形比较。

AI-LocalizedAI 翻译
如您发现任何问题,请选中相关文本/图片,并按 Ctrl + Enter 键向我们提交反馈。
Contents
功能可用性

您可使用的功能取决于您所采用的 Altium 解决方案——Altium Develop、Altium Agile Teams、Altium Agile Enterprise,或 Altium Designer(在有效订阅期内)。

如果您在实际软件中未看到文档中介绍的某项功能, 请联系 Altium Sales 了解更多信息。

旧版文档

Altium Designer 文档不再提供版本区分。如果您需要访问 Altium Designer 旧版本的文档,请前往其他安装程序页面的旧版文档部分。

Contents