验证元器件

概览

在 Altium Designer 中将库元件保存到已连接的 Workspace 之前,请运行元件规则检查,验证其是否满足已配置的要求。本文介绍自动验证和手动验证、查看所报告违规的位置,以及如何配置用户自定义检查,并提供解决文件夹路径缺失、标识符重复和引脚映射无效等问题的指导。继续阅读,了解如何在保存到 Workspace 之前发现元件问题并解决验证失败的问题。

- 了解如何在元件编辑器的单元件编辑模式和批量元件编辑模式下运行元件规则检查,并在“消息”面板中查看结果。
- 了解哪些验证失败会阻止将元件保存到 Workspace。
- 了解在哪里配置用户自定义检查,以及如何解决常见的元件违规问题。
使用 AI 深入了解:

将在元件编辑器中以(单元件编辑或批量元件编辑模式)定义/编辑的工作区库元件保存到已连接的工作区 并使其可用于设计之前,必须确保该元件符合所配置设置的要求。 当您尝试将元件保存回工作区时,元件编辑器会执行一项验证,即元件规则检查。

  • 您也可以随时从主菜单中选择 Tools » Component Rule Check 命令,手动运行此功能。 执行前,请务必先将元件保存到本地(File » Save)。

  • 编辑器的主 File 菜单以及 Projects 面板中元件条目的右键菜单中也提供了 Component Rule Check 命令。

正如电路板工程具有用于检测违规的验证流程一样,元件编辑器也具有元件验证功能。检测到的所有违规都会列在 Messages 面板中。

 
 
 
 
 

在保存到工作区之前检测元件存在的问题。此处展示了在 Single Component Editing 模式下从元件编辑器运行 Component Rule Check 命令的操作。

在保存到工作区之前检测元件存在的问题。此处展示了在 Batch Component Editing 模式下从元件编辑器运行 Component Rule Check 命令的操作。

 

元件验证会检查元件及其已定义模型中可能存在的各种问题,包括内置检查,以及可由用户在全局级别定义的一系列违规类型。

以下内置验证检查的报告模式均为 :

用户可定义的检查在 Preferences 对话框的数据管理 – 元件规则检查页面上配置。

 
 
 
 
 

可在全局首选项中配置用户自定义的违规检查,用于验证元件。
可在全局首选项中配置用户自定义的违规检查,用于验证元件。

任何内置测试未通过,或任何级别为“致命错误”的用户自定义检查未通过,都将阻止元件保存到工作区。

用户自定义检查的默认设置可能不适用于您的元件,因此,熟悉这些选项以及如何根据设计需求进行配置非常重要。有关各项用户自定义错误检查的信息,请参见下文。

与元件相关的违规

与封装相关的违规项

与符号相关的违规项

AI-LocalizedAI 翻译
如您发现任何问题,请选中相关文本/图片,并按 Ctrl + Enter 键向我们提交反馈。
Contents
功能可用性

您可使用的功能取决于您所采用的 Altium 解决方案——Altium Develop、Altium Agile Teams、Altium Agile Enterprise,或 Altium Designer(在有效订阅期内)。

如果您在实际软件中未看到文档中介绍的某项功能, 请联系 Altium Sales 了解更多信息。

旧版文档

Altium Designer 文档不再提供版本区分。如果您需要访问 Altium Designer 旧版本的文档,请前往其他安装程序页面的旧版文档部分。

Contents