Importing Existing Libraries to Your Connected Workspace

Auf einen Blick

Übertragen Sie Ihre vorhandenen Bauteilbibliotheken mit dem Library Importer von Altium Designer in Ihren verbundenen Workspace. Dieser Artikel erläutert, wie der einfache Modus gängige Importvorgänge automatisiert und wie Ihnen der erweiterte Modus mehr Kontrolle über Bauteiltypen, Parameter und Importeinstellungen bietet. Außerdem erfahren Sie, welche Bibliotheksformate unterstützt und welche Daten übertragen werden und wie Validierungsprüfungen dabei helfen, Importprobleme zu erkennen. Lesen Sie weiter, um das passende Importverfahren für Ihre Bibliotheken zu finden und den nächsten Schritt hin zu einer zentralen Bauteilverwaltung zu machen.

- Erfahren Sie, wie Sie den Library Importer aufrufen und zwischen dem einfachen und dem erweiterten Modus wählen.
- Lernen Sie, welche Bibliotheken und Bauteildaten importiert werden können und welche wesentlichen Einschränkungen dabei gelten.
- Entdecken Sie Importvorschauen, Bauteilklassifizierung, Parametereinstellungen und Berichte, mit denen Sie Ihre Importe prüfen und optimieren können.
Mit KI tiefer einsteigen:

Altium Designer bietet in Verbindung mit Ihrem verbundenen Workspace einen optimierten und weitgehend automatisierten Prozess, mit dem Sie Ihre vorhandenen Bibliotheken schnell in diesen Workspace importieren können. Die Oberfläche für diesen Prozess – der Library Importer – bietet eine Ein-Klick-Lösung, die die ausgewählten Bibliotheken automatisch analysiert und in den Workspace importiert, mit dem Sie aktuell verbunden sind.

Der Library Importer unterstützt alle Bibliothekstypen älterer Methoden zur Komponentenverwaltung (SchLib, PcbLib, IntLib, DbLib, SVNDbLib) und ist eine speziell entwickelte Lösung zum schnellen Aufbau der Workspace-Komponentenbibliothek Ihres Unternehmens. So können Sie deren zahlreiche Vorteile nutzen: hohe Datenintegrität, zentrale Speicherung und Verwaltung, einfache Wiederverwendung von Designs und Lieferketteninformationen in Echtzeit.

Der Library Importer bietet einen minimalistischen Oberflächenmodus Simple, in dem die ausgewählten datenbank- und dateibasierten Komponentenbibliotheken in einem einzigen Schritt als Workspace-Komponenten importiert werden. Dabei übernimmt der Importer automatisch die Typklassifizierung, die Auswahl des Zielordners für Quelldaten, die Übernahme von Parametern und die Festlegung ihrer Werttypen sowie die Übertragung aller relevanten Daten. Die Oberfläche steht auch im Modus Advanced zur Verfügung, der eine vollständige Vorschau des geplanten Bibliotheksimports sowie Zugriff auf die zugehörigen Daten und Einstellungen bietet. Obwohl der Import standardmäßig mit einem einzigen Klick erfolgt, bietet der Importer über das Properties-Panel auch erweiterte Konfigurationsoptionen, mit denen Sie die genaue Durchführung des Imports gezielter steuern können.

Was wird importiert?

Alle Informationen aus einer ursprünglichen Quellbibliothek werden in die Workspace-Komponenten importiert, einschließlich aller referenzierten Domänenmodelle (Schaltplansymbole, PCB-Footprints, Simulationsmodelle), Parameterinformationen, zugewiesenen Bauteilauswahlen, Datenblattdateien usw. Bei Bedarf werden auch Komponentenvorlagen erstellt, die anschließend angepasst und für weitere Bibliotheksimporte verwendet werden können.

Wenn für Ihre ursprünglichen Komponenten mehrere PCB-Footprints definiert sind, übernimmt der Library Importer diese Modelle und behält den aktuellen Standard-Footprint bei. Wenn Sie ausschließlich mit PCB-Bibliotheken arbeiten – also nur das PCB-Layout für Sie relevant ist –, unterstützt der Library Importer den Import genau dieser Bibliotheken. Alternativ kann er in einen reinen Modellimportmodus umgeschaltet werden, in dem die angegebenen Modelltypen aus integrierten oder Datenbankbibliotheken importiert werden. Bibliotheken mit mehreren Komponententypen (monolithische Bibliotheken) werden ebenfalls automatisch erkannt und verarbeitet.

Obwohl der Bibliotheksimport datenbank- und dateibasierte Bibliotheksquellen mit unterschiedlichen Formatierungsstandards verarbeiten muss, erkennen seine automatischen Analyseprozesse die Komponententypen in der Quellbibliothek (Widerstand, Kondensator usw.) sowie die Parameternamen und deren Werttypen (Volt, Ohm usw.). Das System führt eine Reihe von Prüfungen durch, um beispielsweise sicherzustellen, dass die resultierenden Komponenten der Workspace-Bibliothek keine doppelten IDs aufweisen, keine doppelten Modelle oder Komponentenvorlagen erstellt werden und solche Elemente bei Bedarf für mehrere Komponenten wiederverwendet, also mit ihnen verknüpft werden. Sollten Probleme auftreten, kennzeichnet das System diese und schlägt Lösungen vor, damit der Import möglichst schnell und reibungslos fortgesetzt werden kann.

Folgende Bibliothekstypen können importiert werden:

  • Schaltplanbibliothek (*.SchLib).

  • PCB-Footprint-Bibliothek (*.PcbLib).

  • Integrierte Bibliothek (*.IntLib)

  • Datenbankbibliothek (*.DbLib).

  • SVN-Datenbankbibliothek (*.SVNDbLib).

Der Import von Pin-Zuordnungsinformationen (für Simulationsmodelle) wird derzeit nicht unterstützt.

Zugriff auf den Library Importer

Der Library Importer ist verfügbar, wenn Sie mit einem Workspace verbunden sind. So öffnen Sie den Importer im Modus Simple:

  • Wählen Sie im Components-Panel die Option Import Library aus dem Menü . Wenn aktuell eine datenbank- oder dateibasierte Bibliothek in der Spalte Categories des Panels (oder im oberen Dropdown-Menü, wenn sich das Panel im Kompaktmodus befindet) ausgewählt ist, wird der Library Importer für diese Bibliothek geöffnet. Wenn ein Komponententyp einer Workspace-Bibliothek ausgewählt ist, wird der Windows-Standarddialog Open geöffnet, in dem Sie eine zu importierende Bibliotheksdatei suchen und auswählen können.

    Die datenbank- und dateibasierten Bibliotheken, die der Software aktuell zur Verfügung stehen, können im Dialogfeld „Libraries Preferences“ angezeigt und verwaltet werden. Sie öffnen es über die Option Libraries Preferences im Menü der Schaltfläche  im Components-Panel.

    Sie können die aktuell installierten dateibasierten Bibliotheken auch auf der Seite „Data Management – File-based Libraries“ des Dialogfelds Preferences anzeigen und verwalten.

  • Klicken Sie im Projects-Panel mit der rechten Maustaste auf eine Bibliotheksdatei und wählen Sie im Kontextmenü Import Library.

  • Wählen Sie im Schaltplansymbol- oder PCB-Footprint-Editor bei geöffneter lokaler Bibliotheksdatei Tools » Import Library.

  • Wählen Sie im Datenbankbibliotheks-Editor File » Import Library oder Tools » Import Library .

  • Wählen Sie im Dialogfeld „Libraries Preferences“ auf der Registerkarte Installed einen Bibliothekseintrag aus und klicken Sie anschließend auf das Steuerelement Import.

  • Ziehen Sie eine Bibliotheksdatei aus einem Windows-Ordner auf das Explorer-Panel.

Der einfache Modus bietet Optionen, um die ausgewählte Bibliothek sofort zu importieren () oder den Library Importer mit seiner vollständigen grafischen Benutzeroberfläche zu öffnen ().

Der Library Importer im Ein-Klick-Importmodus Simple.
Der Library Importer im Ein-Klick-Importmodus Simple.

Um den Library Importer direkt im Oberflächenmodus Advanced zu öffnen, wählen Sie im Hauptmenü File » Library Importer.

Der Library Importer unterstützt auch in seinem vollständigen Oberflächenmodus Advanced einen Ein-Klick-Importprozess.
Der Library Importer unterstützt auch in seinem vollständigen Oberflächenmodus Advanced einen Ein-Klick-Importprozess.

Einfacher Modus

Im einfachen Modus legt der Library Importer anhand seiner Analyse der Quellbibliothek und des verbundenen Workspace alle Aspekte des Importprozesses vorab fest. Das Dialogfeld Library Importer zeigt anschließend eine Zusammenfassung der Importstruktur einschließlich der Gesamtanzahl für jeden Elementtyp an. Der Bibliotheksimport wird über den Befehl in einem einzigen Schritt ausgeführt.

Dieser einfache Oberflächenmodus eignet sich für die meisten gängigen Quellbibliotheksformate, die üblicherweise gängige Komponententypen (Widerstände, Kondensatoren, integrierte Schaltungen usw.) und standardisierte Parameterwerte enthalten. Während der anfänglichen Analyse ermittelt das System den Typ der Komponenten in der Bibliothek anhand von Bezeichner- oder Parameterschlüsselwörtern (LD?, LED usw.) und sucht anschließend im Ziel-Workspace nach einer entsprechenden Komponentenvorlage (LED). Diese Vorlage wird beim Import dieser Komponenten angewendet und legt damit Importeinstellungen wie den Zielordner (Components/LED), die Parameterzuordnung, die Einheiten der Parameterwerte usw. fest. Geeignete Vorlagen sind im Workspace verfügbar, wenn bei der Aktivierung eines Altium 365 Workspace oder der Installation von Altium On-Prem Enterprise Server die Option zum Einbeziehen von Beispieldaten ausgewählt wurde.

Die Ergebnisse des Bibliotheksimports sind als neu erstellte Workspace-Komponenten sowohl im Panel Explorer als auch im Panel Components zu sehen. Importierte Komponenten enthalten alle Modelle, die gemäß den angewendeten Komponentenvorlagen interpretierten Parameter, aus den Quelldaten der Lieferantenverknüpfungen abgeleitete Bauteiloptionen sowie alle Referenzlinks oder -dateien.

Alle vom Library Importer erstellten Komponentenvorlagen sind im Ordner Managed Content\Templates\Component Templates des Panels Explorer zugänglich.

Wenn Sie aus irgendeinem Grund – etwa wegen eines unbefriedigenden Importergebnisses – eine Gruppe von Komponenten löschen möchten, können Sie die im Components-Panel ausgewählten Komponenten über die Option Delete im Kontextmenü vollständig entfernen. Zusammen mit den ausgewählten Komponenten können auch die zugehörigen Modelle gelöscht werden, sofern diese nicht von anderen Komponenten verwendet werden.

Beim Bibliotheksimport sind folgende Punkte zu beachten:

  • Monolithische Bibliotheken (die mehrere Komponententypen enthalten) werden automatisch in Untergruppen aufgeteilt, wobei jede Gruppe einen in dieser Bibliothek enthaltenen Komponententyp repräsentiert. Die Gruppen werden als eigenständige Bibliotheken verarbeitet.

  • Eine Quellbibliothek mit einem nicht erkennbaren (nicht erkannten) Komponententyp wird ohne Interpretation mit nicht zugewiesenen Komponententypen in einen Workspace-Ordner Components/Uncategorized importiert. Vor dem Import können Sie dies beheben, indem Sie im Modus Advanced (vollständige Benutzeroberfläche) die Zuordnung von Referenzbezeichnern oder die Parametergruppierung anwenden. Alternativ können Sie den Import durchführen und die Einstellungen und den Ordner der Komponente später über das Explorer-Panel ändern.
  • Der Bibliotheksimport umfasst eine automatische Validierung der Komponenten. Komponenten, die einen Validierungsfehler auslösen, werden übersprungen.
  • Werden in der zu importierenden Quellbibliothek doppelte Modelle erkannt, wird nur eines dieser Modelle importiert und mit den daraus entstandenen Komponenten im Ziel-Workspace verknüpft. Oben im Dialogfeld Library Importer wird eine entsprechende Benachrichtigung angezeigt.
  • Alle während des Vorgangs aufgetretenen Fehler können Sie in Importing Report einsehen. Der Zugriff erfolgt über die Schaltfläche , sobald der Import abgeschlossen ist.

Erweiterter Modus

Die vollständige grafische Benutzeroberfläche des Library Importers wird im Modus Advanced angezeigt. Sie bietet detaillierte Steuerungsmöglichkeiten für die Verwaltung von Bibliotheken, Komponententypen und Komponentenparametern. In Kombination mit dem Properties-Panel lässt sich der Import von Komponentenbibliotheken in den Workspace an Ihre spezifischen Anforderungen anpassen. Beachten Sie, dass sich die Einstellungen des Importers durch Exportieren/Importieren von Konfigurationsdateien speichern und wiederherstellen lassen.

Der erweiterte Modus wird aktiviert, wenn Sie den Library Importer über den Befehl File » Library Importer öffnen oder im einfachen Modus die Schaltfläche auswählen. Bibliotheken werden dem Bereich SOURCE LIBRARIES des Importers (sofern dieser noch nicht gefüllt ist) hinzugefügt, indem Sie eine Bibliotheksdatei per Drag-and-drop in diesen Bereich ziehen, mit der rechten Maustaste auf <All Libraries> klicken und anschließend Add Library im Kontextmenü auswählen oder die Schaltfläche auswählen.

Der Bereich Import Preview listet die aus den Quellbibliotheken ermittelten Komponententypgruppen auf – als Types () oder als vorgeschlagene Folder Structure () – und enthält eine parameterbasierte Tabellenansicht dieser Komponenten (Components). Parameterwerte lassen sich direkt in der Tabelle bearbeiten, sodass die Quellbibliothek nicht geöffnet und bearbeitet werden muss. Der untere Bereich Details enthält zusätzliche Informationen zur aktuell ausgewählten Komponente – Bauteiloptionen, Modelle und Datenblätter.

Sie können den Komponententyp ändern, indem Sie in der Liste Types mit der rechten Maustaste auf einen Typ klicken und den Befehl Change Component Type auswählen.

Unabhängig von den detaillierten Optionen und Daten in der Benutzeroberfläche lässt sich die erweiterte Ansicht des Importers genauso wie die einfache Ansicht verwenden: Klicken Sie einfach auf die Schaltfläche , um den Importvorgang ohne weitere Eingriffe zu starten. Wie beim Vorgang in der einfachen Ansicht hat der Importer die Bibliothek analysiert, die darin enthaltenen Komponententypen ermittelt und die passende Komponentenvorlage angewendet. Die Vorlage wiederum bestimmt den Zielordner im Workspace, die angewendeten Benennungsschemata und Lebenszyklusdefinitionen sowie die Zuordnung und Interpretation der Parameter.

  • Verwenden Sie die Schaltfläche (oben links), um den Library Importer zu aktualisieren. Dadurch werden alle Quellbibliotheken und Workspace-Daten neu geladen, um alle seit dem Öffnen des Importers vorgenommenen Änderungen zu erfassen.
  • Verwenden Sie das Suchfeld (oben rechts), um die Komponenteneinträge anhand eines übereinstimmenden Parameterwerts zu filtern.

Monolithische Bibliotheken

Quellbibliotheken, die mehrere Komponententypen enthalten, werden von den Analyseroutinen des Importers erkannt und in Unterbibliotheksgruppen aufgeteilt, die als eigenständige typbezogene Bibliotheken verarbeitet werden können. Die Erkennung des Komponententyps basiert auf den Referenzbezeichnern der Quellkomponenten (R?, C? usw.) sowie auf Schlüsselwörtern (Resistor, Res usw.), die in den anderen Hauptparametern der Komponenten (Beschreibung, ID usw.) enthalten sind.

Im unten gezeigten Beispiel wurde die Quellbibliothek (ProjectABC.IntLib) anhand der erkannten Komponententypen (Kondensatoren, Widerstände usw.) automatisch „aufgeteilt“. Diese können in der Spalte Folder Structure (oder der Spalte Types) ausgewählt werden, um eine Vorschau der zugehörigen Komponenteneinträge in der Tabelle Components anzuzeigen.

Komponententypen, die derzeit noch nicht im Workspace vorhanden sind, aber während des Importvorgangs erstellt werden sollen, sind mit dem Symbol  gekennzeichnet.

Beachten Sie, dass sich die Darstellung der Liste Components auf verschiedene Weise ändern lässt:

  • Klicken Sie auf eine Spaltenüberschrift, um die Liste nach dieser Parameterspalte zu sortieren, und klicken Sie erneut, um die Reihenfolge umzukehren.

  • Über das Kontextmenü der Spaltenüberschrift:

    • Wählen Sie Clear Sorting, um die Sortierreihenfolge auf die Standardeinstellung zurückzusetzen (aufsteigend nach der Spalte Name).

    • Wählen Sie Best Fit, um die Breite einer bestimmten Spalte an deren Inhalt anzupassen.

    • Wählen Sie Select Best Fit All Columns, um die Breite aller verfügbaren Spalten an deren jeweiligen Inhalt anzupassen.

    • Wählen Sie Select Columns, um das Dialogfeld Select Columns zu öffnen, in dem Parameterspalten aktiviert, deaktiviert und in ihrer Reihenfolge geändert werden können.

  • Klicken Sie auf das Filtersymbol () in einer Spaltenüberschrift, um die Liste auf einen verfügbaren Wert der Parameterspalte, leere bzw. nicht leere Werte oder eine Filtereinstellung Custom einzuschränken. Der angewendete Filter wird am unteren Rand der Liste angezeigt. Dort kann er über das zugehörige Kontrollkästchen aktiviert/deaktiviert, in Filter Editor geändert oder gelöscht werden. Wenn Sie über das Filtersymbol in der Spaltenüberschrift () die Option All auswählen, wird der angewendete Filter ebenfalls entfernt.

Nicht kategorisierte Komponenten

Wenn ein Eintrag einer Bibliotheksuntergruppe den Namen Uncategorized trägt (und als Uncategorized unter Types oder Folder Structure aufgeführt sowie mit dem -Symbol) weist dies darauf hin, dass der Importer für diese Gruppe von Bauteilen keinen Typ erkennen und zuweisen konnte – der Bauteiltyp ist effektiv auf None gesetzt. In diesem Fall verwenden die nicht erkannten Bauteile (Inverter-Logik-ICs) ein unbekanntes Bezeichnerpräfix (U?), und ihre Parameter enthalten keine erkannten Schlüsselwörter wie IC, logic usw.

Wenn der Import ausgeführt wird, werden die Bauteile ohne Interpretation als nicht kategorisierter Typ importiert. Sind jedoch Schlüssel- bzw. Standardparameter enthalten (wie Resistance, Capacitance, Tolerance usw.), weist der Importer ihnen automatisch einen geeigneten Parametereinheitentyp zu (Ohm, Farad, Percent usw.).

Dieses Problem lässt sich beheben, indem Sie die für diese Bauteile verwendeten Bezeichner im Dialogfeld Library Splitting manuell dem gewünschten Bauteiltyp zuordnen. Das Dialogfeld wird über die Schaltfläche geöffnet, die verfügbar ist, wenn die Quellbibliothek (ProjectABC.IntLib) ausgewählt ist. Das Dialogfeld Library Splitting mit seinen Standardwerten bietet Steuerelemente zum Festlegen benutzerdefinierter Optionen für die Bibliotheksgruppierung nicht kategorisierter Bauteile. Diese basieren auf der Zuordnung von Bezeichnern zu Bauteiltypen und einer parameterbasierten Aufteilung.

Wählen Sie bei aktivierter Option Map Designators  im Dialogfeld den für die nicht kategorisierten Bauteile zutreffenden Bauteiltyp aus der Dropdown-Liste Component Type aus (sie enthält alle verfügbaren Bauteiltypen). Bestätigen Sie die fertige Zuordnung von Typ zu Bezeichner (Bauteiltyp Logic zu U?-Bezeichnern) mit der Schaltfläche .

Da der Bauteiltyp nun durch die angewendete Zuordnung festgelegt ist, verwendet der Importer die passende Bauteilvorlage (Logic), um den Bibliotheksimport gemäß den Vorlageneinstellungen (Ordner, Benennung usw.) zu konfigurieren.

  • Das Dialogfeld Library Splitting bietet auch die Möglichkeit, aufgeteilte Bauteile nach einem bestimmten Parameterwert zu gruppieren (beispielsweise aus einem Parameter Category oder Component_Type), sofern dieser in der Quellbibliothek definiert ist. Wählen Sie dazu die Option Parameter Grouping des Dialogfelds und anschließend einen geeigneten Parameter aus dem Dropdown-Menü aus.
  • Alternativ kann der Bauteiltyp einer Bibliothek im Bereich General des Properties-Panels manuell ausgewählt werden.
  • Um den Bauteiltyp eines einzelnen Eintrags in der Liste Components zu ändern, klicken Sie in dessen Zelle Component Type und wählen Sie einen anderen Typ aus dem Dropdown-Menü aus. Alternativ klicken Sie mit der rechten Maustaste auf den Bauteiltyp und wählen Change Component Type aus dem Kontextmenü.

Beachten Sie, dass dank der flexiblen Einstellungen des Library Importer ein neuer (nicht kategorisierter) Bauteilbibliothekstyp mit der gesamten Infrastruktur importiert werden kann, die für zukünftige Importe dieses Bibliothekstyps erforderlich ist. Wenn Sie eine geeignete Importkonfiguration wählen – neuer Bauteiltyp, Bauteilvorlage, Zielordner, Parameterzuordnung und Einheitentypen für Parameterwerte –, müssen Sie beim nächsten Import dieses Bibliothekstyps lediglich den zuvor definierten Bauteiltyp auswählen. Der ausgewählte Bauteiltyp bestimmt dann alle weiteren Aspekte des Imports.

Vom Import ausschließen

Sie können auch bestimmte Bauteiltypen vom Import ausschließen. Um einen Bauteiltyp auszuschließen, klicken Sie in der Liste Types mit der rechten Maustaste auf den auszuschließenden Bauteiltyp und wählen Sie Exclude from Importer aus dem Kontextmenü. Ändern Sie bei Bedarf die Spaltenanzeige von Folder Structure zu Types ().

Der ausgeschlossene Bauteiltyp wird in der Liste Types ausgegraut dargestellt. Um die ausgeschlossenen Bauteile in der Tabelle anzuzeigen, klicken Sie auf Show Excluded Component (n), wobei n die Anzahl der ausgeschlossenen Bauteile angibt.

In den Import einschließen

Wenn Sie einen Bauteiltyp mit dem oben beschriebenen Befehl Exclude from Importer vom Import ausgeschlossen haben und ihn doch wieder einschließen möchten, klicken Sie in der Liste Types (oder Folder Structure) mit der rechten Maustaste auf den ausgegrauten Bauteiltyp und wählen Sie Include to Importer aus dem Kontextmenü. Der Bauteiltyp wird wieder in der Liste Types angezeigt und ist somit nicht mehr ausgeschlossen.

Validierungsfehler und Warnungen

Bauteile, die nicht korrekt oder überhaupt nicht in den Workspace importiert werden, werden beim Ausführen des Library Importer () oder einer Importvalidierung () in der erweiterten Benutzeroberfläche mit Warn- oder Fehlermarkierungen gekennzeichnet. Die Validierung prüft außerdem auf leere Workspace-Ordnerpfade, widersprüchliche Systemparameter und doppelte Modelle. Ein schwerwiegender Fehler blockiert den Import.

Beim Versuch, den Import auszuführen, werden die erkannten Regelverstöße im Panel Messages aufgeführt. Ein Dialogfeld bietet die Möglichkeit, den Import abzubrechen oder mit der aktuellen Importkonfiguration fortzufahren. Im letzteren Fall werden ungültige Bauteile nicht importiert, oder der Importvorgang schlägt fehl.

Wenn ein Import abgebrochen oder die manuelle Validierung ausgeführt wird, werden alle Bauteile, die die Importprüfungen nicht bestehen, mit Fehler-/Warnsymbolen sowie weiteren Informationen im unteren Bereich Details versehen. Symbole in der Vorschau-Spalte Status kennzeichnen die einzelnen Bauteileinträge, die gegen die geprüften Importregeln verstoßen.

Die verfügbaren fest integrierten Validierungsprüfungen sind nachfolgend aufgeführt.

Benutzerdefinierte Prüfungen werden im Bereich Import Checks des Panels Properties konfiguriert. Verwenden Sie das Dropdown-Menü Report Mode, um eine andere Meldestufe für den zugehörigen Verstoßtyp auszuwählen. Diese Prüfungen sind nachfolgend aufgeführt.

Fehler und Warnungen beheben

Parameterfehler, wie im hier gezeigten Beispiel, bei dem der Wert Forward Voltage des Bauteils nicht als gültige Spannung interpretiert werden kann, lassen sich wie folgt beheben:

  • Den beanstandeten Parameterwert bearbeiten – suchen Sie die entsprechende Zelle und ändern Sie den Wert in ein gültiges Format.

  • Die zugeordnete Parametereinheit Type, die durch die angewendete Bauteilvorlage festgelegt wird, von Voltage auf „nicht interpretiert“ Text ändern – wählen Sie die Quellbibliothek in der Benutzeroberfläche des Importers aus und ändern Sie anschließend Forward Voltage Type in der Liste des Panels Properties Parameter Mapping (auf der Registerkarte General).

  • Das Bauteil vom Import ausschließen – klicken Sie mit der rechten Maustaste auf seinen Eintrag und wählen Sie die Option Exclude from Importer aus.

Ein Fehler aufgrund einer fehlenden Datei, wie beispielsweise der hier gezeigten, nicht auffindbaren Datenblattdatei, lässt sich wie folgt beheben:

  • Die naheliegende Lösung besteht darin, die fehlende Datei zu suchen und am erwarteten Speicherort wiederherzustellen.
  • Den Import von Datenblattdateien deaktivieren – ändern Sie die Option Migrate im Abschnitt des Panels Properties Datasheet (auf der Registerkarte Advanced).
  • Das Bauteil vom Bibliotheksimport ausschließen – wie oben beschrieben.

Verwenden Sie das Feld Search (oben rechts), um bestimmte Bauteileinträge zu suchen. Die Suche filtert die Eintragsliste anhand übereinstimmender Parameterwerte für den aktuell ausgewählten Bauteiltyp. Wählen Sie All unter Types (Folder Structure) aus, damit die Suche auf alle Bauteile in den verfügbaren Quellbibliotheken angewendet wird.

Import von Schaltplanbibliotheken

Wenn beim Versuch, eine Schaltplanbibliothek zu importieren, ein Fehler vom Typ „Modell nicht gefunden“ (z. B. Footprint <footprint name> not found in available libraries) auftritt, bedeutet dies, dass der Library Importer die Modelle nicht finden kann, die mit Bauteilen in der SCHLIB verknüpft sind.

Im einfachen Modus werden solche Fehler im HTML-basierten Importing Report angezeigt. Dieser lässt sich über die Schaltfläche aufrufen, die nach dem Ausführen des Imports verfügbar ist. Im erweiterten Modus werden die Fehler durch Statussymbole in der Hauptoberfläche () und als Einträge im Panel Messages angezeigt – dies geschieht beim Durchführen einer Validierungsprüfung () oder beim Versuch, die Bibliothek zu importieren ().

Fehlende Footprints werden bei der Validierung korrekt erkannt. Im Fehlerbericht steht außerdem die Option Choose a Library zur Verfügung (im Dropdown-Menü Details). Wenn bei mehreren Bauteilen fehlende Footprints erkannt wurden, bietet ein Dialog Apply PcbLib Selection die Möglichkeit, die angegebene PcbLib für diesen Fall oder für alle Bauteile mit fehlenden Footprints zu verwenden.

Eine weitere Möglichkeit, dieses Problem zu beheben oder zu vermeiden, besteht darin, sicherzustellen, dass die erforderlichen Modellbibliotheksdateien in Altium Designer verfügbar sind. Bibliotheken werden über die Seite Data Management – File-based Libraries des Dialogs Preferences installiert.

Wenn Sie nicht mehrere Modellbibliotheken installieren möchten, müssen Sie diese alternativ im Standardbibliothekspfad der Software ablegen (oder den Pfad bearbeiten) und prüfen, ob die Modellquellbibliothek für die Bauteile der Schaltplanbibliothek angegeben ist:

  • Die Modellbibliothek in den Standardsuchpfad der Software aufnehmen. Fügen Sie die Modellbibliothek, beispielsweise eine zugehörige PCB-Bibliothek, an dem Speicherort hinzu, der durch den Standardbibliothekspfad des Systems vorgegeben ist. Um diesen Speicherort zu überprüfen, sehen Sie sich den Eintrag Library Path auf der Seite System – Default Locations des Dialogs Preferences an. Wenn eine Bibliotheksdatei zu diesem Speicherort hinzugefügt oder dorthin kopiert wurde, müssen Sie Altium Designer möglicherweise neu starten, damit die Änderung erkannt wird.
  • Den Namen der Zielmodellbibliothek für Bauteile der Schaltplanbibliothek angeben. Damit der Library Importer die Modellbibliothek kennt, mit der ein Bauteil der Schaltplanbibliothek verknüpft ist, geben Sie ihren Namen im Dialog PCB Model der Bibliothek an.

Beachten Sie, dass es weder erforderlich noch empfehlenswert ist, eine PCB-Bibliothek zusammen mit der zugehörigen Schaltplanbibliothek zu importieren, da der Library Importer den erforderlichen Modellimport und die Verknüpfung selbst durchführt. Der Importprozess identifiziert, findet und überträgt die richtigen Modelle für jedes Bauteil, um ein vereinheitlichtes Bauteil im Ziel-Workspace zu erstellen.

Duplikaterkennung

Der Library Importer enthält außerdem Mechanismen, die verhindern, dass doppelte Bauteile im Ziel-Workspace erstellt werden. Dazu werden während der Validierung die Parameter zur Bauteilidentifikation und die Part Choices der Quellbibliothek mit denen der Bauteile im Ziel-Workspace und in den zu importierenden Quellbibliotheken verglichen. Mit den Standardeinstellungen des Importers wird im Validierungsschritt () eine Warning-Meldung ausgegeben, wenn derselbe Name- oder Part Choices-Eintrag eines Bauteils erkannt wird, der auf ein mögliches Bauteilduplikat hinweist. Die angezeigte Warn- oder Fehlermeldung enthält die Art des Duplikatverstoßes (Parameter oder Part Choice), den Namen des betroffenen Bibliotheksbauteils und das Bauteil (anhand seiner ID), mit dem der Konflikt besteht.

Zwei während der Validierung erkannte potenzielle Duplikate, bei denen Name (oberes Bild) bzw. Part Choice (unteres Bild) des Bauteils bereits in Workspace-Bauteilen vorhanden ist.
Zwei während der Validierung erkannte potenzielle Duplikate, bei denen Name (oberes Bild) bzw. Part Choice (unteres Bild) des Bauteils bereits in Workspace-Bauteilen vorhanden ist.

Das zur Erkennung von Duplikatverstößen verwendete Parameter-Name-Wert-Paar wird im Bereich Duplicates Detection des Panels Properties auf der Registerkarte Advanced festgelegt. Verwenden Sie das Dropdown-Menü Unique Field (standardmäßig auf Name eingestellt), um einen der in der Quellbibliothek verfügbaren Parameter auszuwählen. Diese Auswahl ist besonders nützlich für unternehmenseigene Bibliothekskonfigurationen, die ein proprietäres Identifikationsfeld zur Anbindung an das übergeordnete Unternehmenssystem verwenden.

Ein erkannter Duplikatverstoß, bei dem der Wert eines angegebenen Parameters (ERP-REF) für ein lokales Bibliotheksbauteil und ein Workspace-Bauteil identisch ist.
Ein erkannter Duplikatverstoß, bei dem der Wert eines angegebenen Parameters (ERP-REF) für ein lokales Bibliotheksbauteil und ein Workspace-Bauteil identisch ist.

Für Duplikatverstöße kann eine andere Statuskennzeichnung festgelegt werden, indem im Bereich Import Checks auf der Registerkarte General des Panels Properties eine andere Report Mode ausgewählt wird.

Auch bei Symbolmodellen von Bauteilen wird eine Duplikaterkennung durchgeführt. Wenn die zu importierenden Bauteile in den Quellbibliotheken Symbolmodelle mit identischer Geometrie aufweisen, wird nur eines dieser Modelle importiert.

Diese Funktion ist verfügbar, wenn die Option LibraryMigrator.DuplicatedModelCheck im Dialog „Advanced Settings“ aktiviert ist.

Bibliotheken mit einem einzigen Modell

Die automatische Duplikaterkennung wird auch zur Verarbeitung von Quellbibliotheken verwendet, die ein gemeinsames Symbolmodell für alle Bauteile nutzen. Solche Bibliotheken bestehen in der Regel aus einem einzigen Bauteiltyp mit unterschiedlichen Ausführungen und Werten, beispielsweise Widerständen eines bestimmten Gehäuseformats, für die jeweils eine standardisierte Modellgrafik als Symbol dient.

Der Library Importer erkennt, dass ein einziges gemeinsames Modell verwendet wird, und konfiguriert den Import so, dass ein Symbolmodell übertragen wird, das für alle importierten Bauteile gilt – anstelle eines entsprechenden, individuell benannten Symbols für jedes Bauteil. Das zu importierende Symbol übernimmt den Namen eines der zu importierenden Symbole; alle Bauteilparameter bleiben unverändert.

Das importierte Bibliothekssymbol, das einen generischen Namen und ein leeres Beschreibungsfeld hat, kann an Ihre Anforderungen angepasst werden. Verwenden Sie dazu im Panel „Components“ die Kontextmenüoption Edit. Wählen Sie während des Vorgangs im Dialog Create Revisions for Item die Option Update items related to <symbol ID>, um sicherzustellen, dass die importierten Bauteile die neue Symbolrevision verwenden.

Bauteiltypen zusammenführen

Die im System – bzw. in der Praxis im verbundenen Workspace – registrierten Bauteiltypen können auf der Seite „Data Management – Component Types“ des Dialogs Preferences angezeigt und verwaltet werden. Die Typen werden mit den zugehörigen Bauteil-Template und Workspace-Folder aufgelistet. Dazu gehören auch alle neuen Typen, die beim Import von Bibliotheksdateien in den Workspace durch den Library Importer erstellt wurden.

Mehrere neue Bauteiltypen entstehen typischerweise dann, wenn in einer Konfiguration des Library Importers die Parametergruppierung (anhand eines festgelegten Bauteilparameterwerts) verwendet wurde, um den Typ jedes importierten Bauteils zu bestimmen. Beispielsweise könnte der Parameter Categories für eine Gruppe importierter Bauteile den Wert Resistor-0608 und für eine andere den Wert Resistor-0402 haben usw. Für die zukünftige Verwendung wäre es hier am sinnvollsten, alle unter dem einzigen Bauteiltyp Resistors zusammenzufassen.

Anstatt in solchen Fällen alle Bauteiltypen manuell zu ändern, können auf der Seite „Component Types“ in Preferences ausgewählte Typeinträge zu einem festgelegten einzelnen Eintrag zusammengeführt werden. Weitere Informationen finden Sie im Abschnitt Bauteiltypen zusammenführen auf der Seite Bauteiltypen.

Eine solche Zusammenführung bewirkt, dass Resistors, wenn dieser im Library Importer als Typ für die importierten Bauteile gewählt wird, auch dann angewendet wird, wenn Sie alternativ eine der zusammengeführten Vorlagen (Resistor_0402 usw.) auswählen.

Nur Modelle importieren

Der Library Importer kann in einen speziellen Importmodus Models Only umgeschaltet werden, der die verfügbaren Bauteilmodelle in einer Quellbibliothek erkennt und verarbeitet.

Diese Funktion ist verfügbar, wenn die Option LibraryMigrator.ModelsOnlyMode im Dialog „Advanced Settings“ aktiviert ist.

Im Modus „Models Only“ erkennt der Analyseprozess des Importers alle in einer Quellbibliothek (IntLib, SchLib, PcbLib usw.) verfügbaren Symbol-, Footprint- und Simulationsmodelle und importiert diese anschließend mit den standardmäßigen Speicherorten, Benennungsschemata und Lebenszyklusdefinitionen des Systems in den Workspace.

Wenn der Library Importer in den erweiterten Modus umgeschaltet () oder im erweiterten Modus geöffnet wird (File » Library Importer), stehen vollständige Details zum vorgesehenen Modellimport zur Verfügung. Der Bereich Import Preview zeigt die Folder Structure, die im Ziel-Workspace verwendet werden. Diese können für jeden Modelltyp im Feld Folder des Panels Properties abweichend von den Standardeinstellungen festgelegt werden. Die angewendeten Benennungsschemata und die Lebenszyklusdefinition für jedes Modell können aus den verfügbaren Systemtypen ausgewählt werden (siehe Panel „Properties“ weiter unten).

Der Import von Bauteilmodellen in den Workspace kann bei Bedarf auf bestimmte Typen beschränkt werden, indem einzelne Modelltypen im Panel Properties über die zugehörigen Schaltflächen deaktiviert oder aktiviert werden.

Nachdem der Library Importer konfiguriert wurde, klicken Sie auf die Schaltfläche , um den Import der aufgelisteten Bauteilmodelle abzuschließen. Die Ergebnisse können in der Importprotokolldatei überprüft werden, die über den Fortschrittsdialog Library Importer () angeboten wird, oder durch Anzeigen der importierten Modelle im Panel „Components“.

Nur Bauteile importieren

Ähnlich wie beim oben beschriebenen Importmodus Models Only kann der Library Importer in einen speziellen Importmodus Components Only umgeschaltet werden, mit dem Sie die in einer Quellbibliothek verfügbaren Bauteile ohne ihre verknüpften Modelle importieren können.

Diese Funktion ist verfügbar, wenn die Option LibraryMigrator.ReleaseComponentsWithoutModels im Dialog „Advanced Settings“ aktiviert ist.

Im Modus „Components Only“ erkennt der Analyseprozess des Importers alle Bauteile, Parameter und Part Choices in einer Quellbibliothek und importiert diese Bauteile anschließend mit dem standardmäßigen Speicherort, Benennungsschema und der Lebenszyklusdefinition des Systems in den Workspace.

Wenn der Library Importer in den erweiterten Modus umgeschaltet () oder im erweiterten Modus geöffnet wird (File » Library Importer), stehen sämtliche Details zum geplanten Bauteilimport zur Verfügung. Der verwendete Ordner, die Benennungsschemata und die Lebenszyklusdefinition können aus den verfügbaren Systemtypen ausgewählt werden (siehe Properties-Panel weiter unten).

Sobald der Library Importer konfiguriert ist, klicken Sie auf die Schaltfläche , um den Import der aufgeführten Bauteile abzuschließen. Im Workspace werden nur Bauteil-Items erstellt, ohne verknüpfte Modelle. Die Ergebnisse können in der Importprotokolldatei überprüft werden, die über den Fortschrittsdialog Library Importer () angeboten wird, oder durch Anzeigen der importierten Bauteile im Components-Panel. 

Properties-Panel

Die Einstellungen des zum Library Importer gehörenden Panels Properties bieten erweiterte Steuerungsmöglichkeiten für die Importkonfiguration der ausgewählten Bibliothek (oder Unterbibliotheksgruppe). Das Panel lässt sich im erweiterten Modus des Library Importers öffnen, indem Sie die Option Properties im Menü der Schaltfläche  (unten rechts im Designbereich) auswählen, auf die Schaltfläche oben rechts in der Ansicht des Library Importers klicken oder die Schaltfläche neben <All Libraries> bzw. einem bestimmten Kategorieeintrag in der Liste Source Libraries anklicken.

Die Optionseinstellungen des Panels werden durch die Standardsystemeinstellungen oder die Vorgaben der verwendeten Bauteilvorlage bestimmt. Diese wiederum wird anhand des erkannten Bauteiltyps der Bibliothek festgelegt – im hier gezeigten Beispiel LED. Die Einstellungen können auch vom Benutzer bearbeitet werden, sodass Sie den Importprozess nach Bedarf anpassen können. Über den Link Reset to Default (oben rechts) lassen sie sich wiederherstellen.

Die Registerkarte General des Panels enthält folgende Abschnitte:

  • General:
    • Component Type – der vom Importer für die ausgewählte Bibliothek erkannte Bauteiltyp und damit auch die verwendete Vorlage (siehe Component Template weiter unten). Überschreiben Sie diese Einstellung, indem Sie das Feld bearbeiten, wodurch ein neuer Bauteiltyp erstellt wird, oder indem Sie über das Dropdown-Menü (oder die Schaltfläche ) einen anderen Typ auswählen – dies ist eine weitere Möglichkeit, ein Problem mit nicht kategorisierten Bauteilen zu beheben. Wählen Sie die Option [LibraryName], um den Namen der ausgewählten Bibliothek als Typ festzulegen.
    • Component Template – die Bauteilvorlage im Workspace, die auf die importierten Bauteile angewendet wird, und damit auch deren Bauteiltypeinstellung. Überschreiben Sie diese Einstellung, indem Sie über das Dropdown-Menü (oder die Schaltfläche ) eine andere Vorlage auswählen. Setzen Sie diese Option auf [Create new], um automatisch eine Vorlage aus den Parametern der Quellbibliothek und den aktuellen Einstellungen des Library Importers zu erstellen, oder wählen Sie [No Template], damit keine Vorlage angewendet oder erstellt wird.

      Beachten Sie, dass die Einstellungen Component Type und Component Template miteinander gekoppelt sind, wenn ein verfügbarer Typ bzw. eine verfügbare Vorlage ausgewählt ist. Wird beispielsweise eine der beiden Einstellungen auf Capacitors gesetzt, wird die andere automatisch auf Capacitors gesetzt. Wird in diesem Fall jedoch die Einstellung Component Template auf [Create New] geändert, wird eine weitere Vorlage Capacitors (mit einem entsprechenden Versions-/Revisionssuffix im Namen) erstellt, die den aktuellen Einstellungen entspricht. Vorhandene Bauteilvorlagen werden durch den Importprozess nicht verändert.
  • Parameter Mapping – die Zuordnung zwischen den Bibliotheksparametern und den Parametern der verwendeten Bauteilvorlage (bzw. den Standardeinstellungen, wenn keine Vorlage verfügbar ist) sowie der Wertetyp für jeden Parameter (Text oder ein einheitenbezogener Typ). Verwenden Sie die Dropdown-Menüoptionen in der Spalte Source Library Parameter, um die Zuordnung zu ändern, und die Menüoptionen in der Spalte Type, um die durch die Vorlage oder die Standardwerte vorgegebene Einstellung zu überschreiben. Wählen Sie die Option <Skip>, um einen Parameter nicht zu übernehmen. Jeder Parameter, der nicht automatisch einem Parameter der Quellbibliothek zugeordnet wurde (vom System auf <Skip> gesetzt), kann manuell einem geeigneten Vorlagenparameter zugeordnet werden. Beispielsweise könnte der Quellparameter ROHS ausgewählt werden, um ihn dem in der Workspace-Vorlage definierten Parameter RoHS Compliant zuzuordnen. Parameternamen können bearbeitet und Parametersätze hinzugefügt, bearbeitet und entfernt werden. Die Basisparameter der Bauteile (ID, Name, Description) können neu zugeordnet werden, sind ansonsten jedoch schreibgeschützt.

    Für den Workspace-Parameter ID ist der Quellbibliotheksparameter auf <Auto> gesetzt. Dadurch werden Bauteil-IDs automatisch anhand von Naming Template erstellt, das im Abschnitt Component auf der Registerkarte Advanced des Panels angegeben ist. Die ID-Zuordnung kann so geändert werden, dass ein beliebiger Parameter aus der Quellbibliothek verwendet wird, der für jeden Bauteileintrag eindeutig ist. Wählen Sie dazu im Dropdown-Menü für den Quellbibliotheksparameter einen anderen Eintrag aus. Beachten Sie, dass die Basisparameter der Bauteile (ID, Name, Description) neu zugeordnet werden können, ansonsten jedoch schreibgeschützt sind.
  • Part Choice Mapping – die Liste der vom Importer erkannten Herstellerteil- oder Lieferantenlink-Parameter, aus denen Part Choices-Einträge für importierte Bauteile abgeleitet werden. Über die Dropdown-Menüoptionen können Sie die Zuordnung neu festlegen oder Zuordnungssätze hinzufügen und löschen. Beachten Sie, dass Herstellerteil- und Lieferantenlink-Parameter standardmäßig beim Import nicht berücksichtigt (übersprungen) werden. Wenn ein Bibliotheksbauteil mehrere Lieferantenlinks enthält, wird die primäre Lieferantenreferenz (Supplier 1 / Supplier Part Number 1) für die Einträge im Feld „Part Choices“ verwendet.
  • Import Checks – hier können Sie die Fehler-/Warnungsreaktion des Importers auf Verstöße gegen die Importvalidierungsregeln anzeigen oder festlegen. Verwenden Sie das Dropdown-Menü Report Mode, um die Reaktion und das Symbol für einen Eintrag Violation Type zu ändern. Beachten Sie, dass bei ausgewähltem Meldemodus Fatal Error der Importprozess blockiert wird, sobald dieser Verstoß erkannt wird.

Die Registerkarte Advanced des Panels bietet Einstellungen für alle Datenobjekt-Items des Importers, die durch die Systemstandardwerte oder die verwendete Bauteilvorlage festgelegt werden. Dazu gehören Bauteilmodelle, Datenblattdateien und alle erstellten Bauteilvorlagen. Mit Ausnahme der Option Datasheet (einem Schalter zum Aktivieren/Deaktivieren) umfassen die Einstellungen für jedes Importobjekt Folgendes:

  • Folder – der Workspace-Zielordner für das importierte Objekt. Er kann manuell bearbeitet (beispielsweise zum Erstellen eines neuen Zielordners) oder über die Schaltfläche zum Durchsuchen () ausgewählt werden.
  • Naming Scheme – die Benennungsvorgabe für das Objekt im Workspace, wie sie durch die Bauteilvorlage definiert ist, oder, wenn keine Vorlage aktiv ist, das für den Zielordner festgelegte (oder manuell eingegebene) Schema. Wählen Sie über das Dropdown-Menü eines der verfügbaren Benennungsschemata aus. Beachten Sie, dass eine Änderung des Zielordnerpfads (Folder) auch eine Änderung des verwendeten Benennungsschemas nach sich ziehen kann, das durch den Ordner selbst oder durch eine verwendete bzw. zugeordnete Bauteilvorlage festgelegt wird.
  • Revision Naming Scheme – das Benennungsschema für die Workspace-Revisionen des Objekts, das durch die verwendete Vorlage festgelegt oder über das Dropdown-Menü des Eintrags ausgewählt wird. Es stehen nur die vom System aktivierten Schemata zur Auswahl.
  • Lifecycle Definition – das Lebenszyklussystem, das für das Objekt verwendet wird und durch die angewendete Vorlage festgelegt oder aus den Optionen im Dropdown-Menü des Eintrags ausgewählt wird. Nur die vom System aktivierten Definitionen stehen zur Auswahl.
Der Objektbereich Component enthält die Einstellung für Duplicates Detection, wie oben beschrieben.

Exportieren und Importieren der Konfiguration

Der Library Importer bietet die Möglichkeit, eine detaillierte textbasierte Datei zu exportieren, die die aktuelle Konfiguration erfasst. Diese umfasst alle konfigurierbaren Importeinstellungen, etwa Zielpfade, Parameterzuordnungen, Benennungsschemata, Lebenszyklusdefinitionen, Ziel-Bauteiltypen usw.

Die Konfigurationsdatei des Importers wird über den Befehl File » Export » Importer Config im Dateiformat *.lmcfg gespeichert und kann jederzeit über die Menüoption File » Import » Importer Config wiederhergestellt werden.

Die Möglichkeit, eine Konfiguration wiederherzustellen, ist besonders hilfreich, wenn die Quelldatenbank oder die dateibasierte Bibliothek aktualisiert wurde und diese Änderungen in den Workspace importiert werden müssen. Wurde die Konfiguration beim ersten Import der Bibliothek exportiert, stellt die wiederhergestellte (importierte) Konfiguration exakt die zuvor verwendeten Einstellungen wieder her. Dadurch wird ein einheitliches Datenübertragungsschema für diese Bibliothek (oder Bibliotheken) gewährleistet.

Beachten Sie, dass eine exportierte (gespeicherte) Konfigurationsdatei des Importers Verweise auf die Bibliotheksdateien enthält, die beim Export der Konfiguration als Quellbibliotheken geöffnet waren. Wenn diese Konfigurationsdatei des Importers später importiert (erneut geladen) wird, muss mindestens eine der in der Konfiguration referenzierten Bibliotheken verfügbar sein – sie muss also aktuell als Quellbibliothek im Library Importer verfügbar sein.
AI-LocalizedKI-lokalisiert
Wenn Sie ein Problem feststellen, wählen Sie den Text/das Bild aus und drücken SieCtrl + Enter, um uns Ihr Feedback zu senden.
Nav
Contents
Funktionsverfügbarkeit

Die Ihnen zur Verfügung stehenden Funktionen hängen davon ab, über welche Altium-Lösung Sie verfügen – Altium Develop, Altium Agile Teams, Altium Agile Enterprise oder Altium Designer (mit aktivem Laufzeitvertrag).

Wenn Sie eine dokumentierte Funktion in Ihrer tatsächlich verwendeten Software nicht sehen, wenden Sie sich an den Altium-Vertrieb, um mehr zu erfahren.

Legacy-Dokumentation

Die Dokumentation von Altium Designer wird nicht mehr versioniert. Wenn Sie auf Dokumentation für ältere Versionen von Altium Designer zugreifen müssen, besuchen Sie den Abschnitt Legacy-Dokumentation auf der Seite Andere Installer.

Contents