3D-MID Design
De un vistazo
- Comprende qué es 3D-MID, cómo utiliza la fabricación mediante LDS y cómo incorpora el diseño de circuitos 3D a Altium Designer.
- Aprende a crear un documento 3D-MID, importar o cambiar un sustrato y trabajar con archivos STEP o IGES compatibles.
- Familiarízate con los conceptos básicos del editor 3D, incluidos los controles de cámara, las opciones de visualización, la configuración de colores y las herramientas de alineación.
Nuestra herramienta 3D-MID incorpora por primera vez el diseño de circuitos en 3D real a Altium Designer, lo que permite combinar la funcionalidad eléctrica y mecánica en una sola pieza.
Un documento 3D-MID se integra en su proyecto de Altium Designer del mismo modo que una PCB estándar: sus componentes y su conectividad se definen a partir del diseño esquemático e incorpora huellas SMT estándar de su biblioteca de componentes habitual.
¿Qué es 3D-MID?
3D-MID significa dispositivos mecatrónicos integrados tridimensionales.
El proceso de fabricación 3D-MID utiliza un láser para grabar el patrón del circuito directamente sobre la superficie de un sustrato 3D, que después se somete a un tratamiento de metalización estándar para convertir ese patrón en pistas conductoras. Este proceso, conocido como estructuración directa por láser (LDS), permite integrar el circuito en la estructura del producto final.
Diseñar pistas de circuitos sobre la superficie de una estructura 3D plantea desafíos singulares. El espacio de edición debe permitir colocar los componentes y las conexiones entre ellos que definen el circuito específico. Este editor también debe poder importar el sustrato 3D sobre el que se creará el circuito electrónico: debe ser un verdadero editor de diseño electrónico tridimensional.
El diseñador debe poder colocar los componentes sobre cualquier superficie del sustrato 3D importado. A continuación, debe poder definir las pistas de conexión entre los pines de los componentes, un proceso que suele denominarse enrutamiento de las conexiones. A su vez, esas rutas deben poder recorrer la superficie del sustrato, independientemente de la orientación de dicha superficie en cualquier punto del recorrido.
Por último, el diseñador debe poder generar los datos de fabricación en el formato requerido por el proceso de estructuración directa por láser (LDS).
La nueva herramienta de diseño 3D-MID incorpora esta funcionalidad por primera vez a Altium Designer.
Creación de un documento 3D-MID
Al igual que un documento PCB estándar (PcbDoc), un documento 3D-MID (PcbDoc3D) puede crearse dentro de un proyecto o como documento independiente.
-
Para crear un nuevo documento 3D-MID dentro de un proyecto, haga clic con el botón derecho en el nombre del proyecto en el panel Projects y, a continuación, seleccione Add New to Project » PCB3D.
-
Para crear un documento 3D-MID como documento independiente, seleccione File » New » PCB3D en los menús.
-
Como parte del proceso de creación, aparecerá un cuadro de diálogo que le pedirá que seleccione un archivo para formar el sustrato del documento 3D-MID. El archivo seleccionado debe estar en formato STEP o IGES. La ventaja del formato IGES es que puede incluir croquis integrados.
Una vez seleccionado, el archivo del sustrato se mostrará en la ventana de edición 3D-MID. Si cancela la ventana de selección del sustrato, se mostrará el sustrato predeterminado, como se ilustra a continuación.
Se crea un sustrato 3D predeterminado si decide no abrir uno propio.
Cambio del sustrato
Si es necesario, puede cambiar el sustrato 3D seleccionando el comando File » Change Substrate en los menús principales.
Si el diseño del sustrato ha cambiado, puede actualizarse.
Cómo se gestionan los objetos existentes al cambiar el sustrato
|
Cuando se selecciona un nuevo sustrato, el software lo compara con el sustrato existente. Para ello, compara la ubicación de cada superficie existente con la ubicación de esa superficie en el nuevo sustrato. Mediante un umbral, si la nueva superficie se encuentra dentro de la distancia especificada respecto a una superficie existente, se considera que es la misma superficie en una nueva ubicación, y todos los objetos de diseño existentes se trasladan a ella. Si se supera esta distancia, la nueva superficie se considera una superficie diferente y los objetos de diseño se eliminan. El valor del umbral se define mediante la opción avanzada |
Trabajo en el editor de documentos 3D-MID
Los controles de la cámara son los siguientes:
- Para desplazar la vista, arrastre con el botón derecho del ratón
- Para ajustar el zoom, utilice la rueda de desplazamiento
- Para girar, mantenga pulsada la tecla Mayús y arrastre con el botón derecho del ratón. El centro de rotación se define según la ubicación del puntero del ratón al iniciar el comando.
Cambio de la vista del sustrato
En la parte inferior izquierda del espacio de diseño hay un marcador de ejes rojo/verde/azul, denominado orientación de la vista Gizmo.
Haga clic en un plano o eje de color del Gizmo para reorientar la vista del sustrato hacia ese plano o eje.
El Gizmo
El Gizmo se utiliza para cambiar la orientación de la vista del sustrato. Cada eje del espacio de trabajo y su plano correspondiente tienen asignado un color. Al pasar el ratón sobre un elemento de color del Gizmo, este aumenta de tamaño para indicar que está activo. Al hacer clic en ese elemento de color, la vista se reorienta para que mire down ese eje hacia el interior del sustrato. Un segundo clic invierte la vista, mirando a lo largo del mismo eje desde la dirección opuesta.
- Blue - Eje Z, mirando hacia el plano X-Y.
- Red - Eje X, mirando hacia el plano Y-Z.
- Green - Eje Y, mirando hacia el plano X-Z.
Controles de la vista 3D
La vista del sustrato también se puede controlar mediante el submenú 3D View Control.
- Utilice el grupo superior de comandos para ver el sustrato a lo largo del eje especificado.
- Utilice el grupo inferior de comandos para Rotate o Roll el sustrato en la dirección elegida. También se puede acceder a cada uno de estos comandos mediante el atajo indicado en la imagen siguiente. Al seleccionar un comando de rotación o de giro sobre el eje de visión, también se ajustará el zoom para centrar el sustrato en la pantalla.
Cambio del tipo de vista
Puede cambiar la vista alternando el comando View » Switch Perspective/Orthographic view. La vista en perspectiva permite obtener una representación 3D más realista del 3D-MID. La vista ortográfica elimina los efectos de distorsión debidos a la perspectiva y garantiza que los elementos paralelos se muestren como tales.
Configuración de los colores
El color de la superficie y del contorno del sustrato, así como el color del objeto seleccionado actualmente y del cobre, se pueden configurar en el panel View Configuration, como se muestra a continuación. Active el panel mediante el botón Panels situado en la parte inferior derecha del software.
|
El color de la superficie del sustrato, el del contorno y el del objeto seleccionado actualmente se pueden configurar en la sección System Colors del panel. El color del cobre se puede configurar en la sección Layers del panel. La ventana gráfica no mostrará el nuevo color del cobre hasta que se haya desactivado y vuelto a activar la visibilidad de los componentes mediante los atajos 2 y 3. |
Herramientas de alineación
Hay dos herramientas disponibles para ayudar a ubicar entidades en la superficie del sustrato. Puede importar un croquis desde MCAD o utilizar la función de generación de una cuadrícula de alineación del editor 3D-MID. Una vez mostradas, las entidades del croquis pueden servir de ayuda para colocar componentes, pistas de cobre y regiones.
- Al arrastrar un componente, el puntero del ratón se ajustará al centro de la huella. A continuación, el puntero del ratón (y, por tanto, el centro del componente) se ajustará a los elementos del croquis.
- Cuando se selecciona un componente, también se muestra un controlador de rotación. Haga clic en el controlador y arrástrelo para girar el componente. El controlador se ajustará a los elementos del croquis. Obtenga más información sobre la rotación interactiva de componentes.
- Durante el enrutado, los puntos inicial y final de la pista de cobre se ajustarán a las intersecciones formadas por los elementos del croquis. Si el puntero del ratón no está cerca de ninguna intersección, se ajustará a las líneas del croquis. Si, durante el enrutado, el puntero del ratón se desplaza a lo largo de una línea del croquis (incluidas las líneas curvas), la pista seguirá esa línea.
- Los vértices y los bordes de una región también se pueden alinear con la cuadrícula o con los croquis importados.
- Las dos herramientas descritas a continuación se pueden utilizar de forma independiente y simultánea en el mismo sustrato.
Importación de croquis
- Al diseñar el sustrato en MCAD, se pueden colocar curvas 3D sobre la superficie de la pieza e incluirlas en el archivo IGES exportado.
- En Solidworks, por ejemplo, el comando Project Curve permite colocar un croquis 2D sobre una superficie 3D.
- Estas «curvas» se pueden incluir después en la exportación IGES mediante la opción Export 3D Curve features.
- Cuando el archivo IGES se importa en Altium Designer para formar el sustrato de un 3D-MID, estos elementos se pueden mostrar seleccionando el comando View » Show Sketches.
Los croquis definidos en MCAD se muestran en rojo.
- Los elementos del croquis se pueden utilizar después como guía para colocar componentes y regiones, y durante el enrutado.
Cuadrícula de alineación
- Desde el documento 3D-MID, es posible generar una cuadrícula en uno de los tres planos de referencia mediante la sección Alignment Grid del panel Properties cuando no hay ningún objeto seleccionado en el espacio de diseño 3D. Esta cuadrícula se proyecta después desde el plano especificado sobre las superficies de la pieza. Tenga en cuenta que esta cuadrícula es independiente de los croquis importados como parte del sustrato.
-
El usuario puede controlar las propiedades de la cuadrícula. Tenga en cuenta que el origen del sustrato se hereda del modelo STEP/IGES importado.
- Enable Grid - el ajuste a la rejilla solo se produce cuando la rejilla está visible.
-
Plane Kind - el plano XY, XZ o YZ desde el que se proyecta la rejilla de alineación. Se hereda del modelo STEP/IGES importado para formar el sustrato.
Como alternativa, puede seleccionar el tipo de plano UV, que genera una rejilla basada en las superficies del sustrato y proporciona líneas de rejilla más naturales que siguen las curvas del sustrato (mostrar imagen). El tipo de plano UV permite enrutar a lo largo de líneas más «naturales» sobre la superficie del sustrato 3D. - Horizontal/Vertical Size - paso de la rejilla.
- Horizontal/Vertical Offset - desplazamiento de la rejilla con respecto al origen del sustrato.
- Rotation - ángulo de rotación de la rejilla, paralelo a ese plano (solo se aplica a los tipos de plano XY, XZ e YZ).
Ajuste del cursor
El editor de documentos 3D-MID permite modificar la prioridad de ajuste. Se accede a los controles de prioridad de ajuste mediante el botón Objects for snapping en Active Bar.
Hay dos niveles de ajuste del cursor disponibles: rejillas y objetos. Cuando está habilitado, el ajuste a objetos tiene prioridad sobre el ajuste a la rejilla. Esto, por ejemplo, permite ajustarse a la rejilla en lugar de a la línea central de una pista al enrutar hacia o desde una pista existente, habilitando el ajuste a Grids y deshabilitando el ajuste a Track Lines (siempre que la propia rejilla esté habilitada en el panel Properties), como se muestra en el siguiente vídeo.
Trabajo con componentes
- Si el documento 3D-MID forma parte de un proyecto, los componentes se pueden sincronizar con él desde las hojas de esquemático mediante los comandos estándar: Design » Update PCB si está trabajando en el editor de esquemáticos y Design » Import Changes from xxx.PrjPcb si está trabajando en el editor de documentos 3D-MID. En este caso, las asignaciones de redes de los pines del esquemático también se transferirán a los pads de los componentes 3D-MID. Tenga en cuenta que, como parte de este proceso, se crean reglas de diseño predeterminadas; consulte la sección Opciones de proyecto y reglas de diseño predeterminadas de esta página para obtener más información.
- Una vez sincronizados con el documento 3D-MID, los componentes aparecerán inicialmente flotando en el espacio 3D junto al cuerpo del sustrato y se podrán arrastrar uno a uno hasta su superficie. De forma predeterminada, al arrastrar un componente hasta el sustrato, su orientación inicial sobre la superficie dependerá de la trayectoria seguida con el ratón al arrastrarlo.
|
Tras sincronizar los componentes y las redes desde el esquemático, los componentes aparecen junto al sustrato, flotando en su plano X-Y. Observe que el pad 1 tiene las esquinas redondeadas. La orientación del componente desplazado después de acercarse al sustrato desde la parte frontal. La orientación del componente desplazado después de acercarse al sustrato desde un lateral. |
-
Como alternativa, los componentes se pueden arrastrar directamente hasta el sustrato desde el panel Components. Al colocar un componente desde el panel Components , este tiene un designador predeterminado y todos sus pads se designan como
No Net. - Al arrastrar un componente, el cursor del ratón (indicado por una cruz verde) se ajustará al punto central de la huella. A continuación, el cursor (junto con el punto central de la huella) se ajustará a una rejilla de alineación visible. Obtenga más información sobre las rejillas y las herramientas de alineación.
- Los componentes también se pueden arrastrar con los cuerpos 3D ocultos. Para elegir el componente, haga clic en uno de sus pads y mantenga pulsado el botón. En cuanto mueva el ratón, el punto central del componente se ajustará al cursor.
-
Al arrastrar un componente en un documento 3D-MID con los cuerpos de los componentes ocultos (View » Component Bodies » Hide; atajo: 2), se mostrarán gráficos simplificados (pirámides verdes) si su número de pines supera el límite definido por la configuración avanzada
3DLayout.ComponentDrag.DrawShapesPinsLimit(15 de forma predeterminada). Este comportamiento se implementa para mejorar el rendimiento. El valor de esta configuración se puede ajustar según las especificaciones de su PC. - Al arrastrar un componente, Spacebar lo gira en incrementos definidos por el ángulo Rotation Step especificado en la página PCB Editor - General del cuadro de diálogo Preferences (mostrar imagen). El incremento de rotación predeterminado es de 90 grados.
-
El comportamiento de la orientación de un componente al arrastrarlo sobre distintas superficies del sustrato se controla mediante la configuración avanzada
3DLayout.ComponentDrag.KeepOrientation.
|
Si el valor es Si el valor de la configuración avanzada |
|
Haga clic una vez para seleccionar el componente. Aparecerá un recuadro alrededor del componente y el tirador se hará visible. Este se puede utilizar para ajustar de forma interactiva la orientación del componente. Haga clic en este tirador, mantenga pulsado el botón y arrástrelo hasta la posición deseada. El tirador se ajustará a la rejilla de alineación. |
- También puede arrastrar más de un componente. Seleccione varios componentes (mediante el atajo Shift+Click u otros métodos de selección) y, a continuación, utilice Click, Hold&Drag sobre la selección para mover todos los componentes seleccionados a la vez. Al igual que al arrastrar un solo componente, el movimiento está limitado por las opciones de ajuste actuales.
- Los pads, los rellenos y las regiones sólidas de la huella de un componente son objetos de cobre que se pueden colocar en el documento 3D-MID. Esto permite colocar componentes con huellas de formas complejas sobre los sustratos, incluidas las formas de RF (por ejemplo, antenas).
- Al arrastrar un componente sobre la superficie del sustrato, la forma de sus pads se crea adaptando su geometría desde el plano de la huella 2D a la superficie del sustrato. Si esta superficie no es plana, la forma resultante de los pads se distorsionará. El grado de distorsión admisible tiene un límite. Una vez alcanzado este límite, el pad no se creará.
- Para acceder a las propiedades de un componente, haga clic con el botón izquierdo en su cuerpo. Aparecerá un recuadro de contorno alrededor del componente. A continuación, podrá acceder a sus propiedades desde el panel Properties.
- Una vez seleccionado un componente, puede seleccionar un pad con otro clic izquierdo directamente sobre él. A continuación, puede editar las propiedades del pad desde el panel Properties.
- Si las propiedades del pad no están disponibles para su edición, significa que la opción global Protect Locked Primitives in Component está activada en la página PCB Editor - General del cuadro de diálogo Preferences (mostrar imagen). Para anular esta opción localmente y editar el pad de este componente, seleccione el componente en lugar del pad (aparecerá el recuadro de contorno) y, a continuación, haga clic en el botón de bloqueo Primitives (mostrar imagen) para desbloquear las primitivas de ese componente. Recuerde volver a bloquear las primitivas del componente cuando termine de editar las propiedades del pad.
Enrutado
El enrutado es el proceso de definir las rutas de cobre entre los pines de los componentes conectados. Para enrutar el diseño, se sustituye cada línea de conexión de una red por objetos de pista en una capa de cobre.
Visualización de las líneas de conexión
Como ayuda para el enrutado, es posible mostrar las líneas de conexión de las redes (View » Connections » Show All). Las líneas de conexión se muestran entre pistas o pads de la misma red que aún no están conectados, y reflejan la conectividad definida en los documentos de esquemático del proyecto. Para cada red, el comportamiento predeterminado consiste en que el algoritmo calcule la configuración de líneas que minimice su longitud total.
Codificación por colores de las líneas de conexión
- El conjunto de líneas de conexión que componen cada red se puede codificar por colores, como se muestra a continuación:
|
Para aplicar un color a una red específica, primero... seleccione un pad perteneciente a esa red (haga clic una vez para seleccionar el componente, espere un momento y vuelva a hacer clic para seleccionar el pad), y, a continuación, haga clic en el hipervínculo Red del panel Properties. Haga clic en el icono de color y elija un nuevo color para las líneas de conexión de esa red en la paleta que aparece. Como alternativa, en el panel PCB configurado en el modo Nets, busque la red en la lista y haga clic con el botón derecho en su nombre para mostrar el menú contextual. Seleccione el comando Change Net Color para abrir el cuadro de diálogo Choose Color y seleccione un nuevo color. |
Anulación del color de red: visualización del color de red en redes enrutadas
También puede utilizar el color de red para las redes enrutadas activando la función de anulación del color de red. Esta función permite controlar el resaltado de las redes enrutadas en los documentos 3D-MID mediante un esquema de colores personalizado que sustituye al predeterminado. En lugar de que un objeto de red se muestre únicamente con el color de la capa, puede asignarle un color alternativo específico.
Para utilizar la función de anulación del color de red:
- Apply the required color to the net(s) – utilice las técnicas descritas en la sección Codificación por colores de las líneas de conexión anterior.
-
Enable Color Override for the net(s) – la anulación del color se activa para cada red mediante la casilla situada junto a su nombre en el panel PCB (en el modo Nets), como se muestra para la red
NetR2_1en la imagen siguiente. Las casillas de varias redes seleccionadas se pueden activar o desactivar mediante los comandos Right-click » Display Override » Selected On/Off.
Preparación para el enrutado
- Una vez enrutada una conexión entre dos pads de la misma red, la línea de conexión asociada desaparece. Esto permite utilizar las líneas de conexión como comprobación visual para asegurarse de que todas las redes estén completamente enrutadas: en un diseño completamente enrutado, no quedará ninguna línea de conexión (salvo entre un par de pads de vía). Si es necesario, las líneas de conexión se pueden ocultar mediante el comando View » Connections » Hide All.
- Solo se admite el enrutado interactivo manual (actualmente no se admite el enrutado automático).
-
Hay dos modos de enrutado interactivo disponibles:
- Ignore Obstacles - la conexión con el cobre de otra red debe evitarse manualmente. Es posible crear cortocircuitos. En este modo, el software funcionará con rapidez y responderá con agilidad.
-
Walkaround Obstacles - el algoritmo de enrutado evita los cortocircuitos manteniendo una separación entre el trazado y los objetos de cobre de otra red. Este proceso requiere muchos cálculos, por lo que puede haber un retardo antes de que el software detecte la colisión y desvíe el trazado alrededor del obstáculo. El algoritmo requiere que el cursor esté fuera del objeto perteneciente a la otra red.
Configuración de la separación entre objetos y del ancho de enrutado
El editor 3D-MID utiliza reglas de diseño para definir el ancho de enrutado y la separación mínima permitida entre objetos que pertenecen a redes distintas.
- Para establecer los requisitos de separación y ancho de enrutado, abra PCB Rules and Constraints Editor (Design » Rules).
Configuración de la restricción de separación
- En el árbol situado a la izquierda del cuadro de diálogo de reglas de diseño, expanda el árbol y seleccione la regla Clearance predeterminada.
- Solo los tres valores resaltados en la imagen siguiente afectan al algoritmo:
- Tenga en cuenta que los pads TH (de orificio pasante) se reconocen como tales en el documento 3D-MID, pero no se incluirá el orificio en sí.
Configuración del ancho de enrutado
- El ancho de las pistas recién colocadas se define mediante la regla de diseño de enrutado Width aplicable. El enrutador 3D solo admite el valor Preferred Width para la capa superior. Este valor puede configurarse en el campo general Preferred Width (resaltado en la imagen siguiente) o en el campo de ancho específico de la capa.
Opciones de proyecto y reglas de diseño predeterminadas
Cada proyecto nuevo tiene una configuración predeterminada para la creación de reglas, y cada documento PcbDoc3D nuevo tiene reglas predeterminadas. Por ejemplo, la configuración predeterminada del proyecto dará lugar a la creación de una o varias reglas de diseño Placement cuando el diseño se sincronice entre el editor de esquemáticos y el editor PCB3D. Como consecuencia de esta regla de colocación predeterminada, la comprobación de reglas de diseño (DRC) en línea detectará que los componentes no están contenidos dentro de la sala, por lo que se resaltarán (en verde) para indicar que incumplen la regla.
- La regla de diseño de colocación predeterminada se puede eliminar; haga clic con el botón derecho en la regla en PCB Rules and Constraints Editor para mostrar el menú contextual y eliminarla, como se muestra a continuación. Obtenga más información sobre las reglas de diseño.
- Para evitar que el software cree una regla de colocación para cada hoja de esquemático del proyecto al sincronizar un diseño entre los editores de esquemáticos y 3DPCB, abra el cuadro de diálogo Options for PCB Project (Project » Project Options), vaya a la pestaña Class Generation y desactive la opción Generate Rooms, como se muestra a continuación. Obtenga más información sobre las opciones del proyecto.
Enrutamiento con la cuadrícula de alineación y los bocetos
Dado que las conexiones se enrutan sobre las superficies irregulares de objetos 3D, la cuadrícula tradicional del plano XY utilizada en el diseño de PCB no resulta adecuada. En su lugar, el editor 3D-MID admite dos tipos de elementos de boceto: la cuadrícula de alineación y los bocetos importados.
-
La Alignment Grid del editor 3D-MID se activa y configura en el panel Properties cuando no hay objetos seleccionados en el espacio de diseño. Configure las propiedades de la cuadrícula de alineación para adaptarlas al paso de enrutamiento requerido, incluidos los siguientes parámetros:
- Plane Kind (el plano desde el que se proyecta la cuadrícula de alineación);
- Size (paso de la cuadrícula) y
- Rotation (ángulo de rotación paralelo a ese plano). Durante el enrutamiento, a medida que el puntero del ratón se acerque a la cuadrícula de alineación, se ajustará a la línea de cuadrícula más cercana.
- Si el sustrato se importa desde un archivo IGES, los elementos de boceto (líneas y arcos) incluidos en ese archivo IGES también se pueden utilizar como guía para colocar las pistas. Durante el enrutamiento, si el puntero del ratón se mueve hacia una intersección de líneas de boceto, se ajustará a esa intersección. De lo contrario, se ajustará a una línea de boceto cercana. Tenga en cuenta que los bocetos solo se pueden utilizar para la colocación si están visibles. Para alternar su visibilidad, seleccione View » Show Sketches (tenga en cuenta que este comando no se aplica a la visualización de Alignment Grid; esta se configura en el panel Properties).
Active la cuadrícula de alineación para ajustar las pistas a la cuadrícula.
Enrutamiento de una conexión
Para comenzar a enrutar, seleccione el comando de menú Route » Interactive Routing, haga clic en el botón de acceso directo en Active Bar, como se muestra a continuación, o pulse la combinación de teclas Ctrl+W.
El enrutamiento es el proceso de definir las rutas de cobre entre los pines de los componentes conectados.
Consejos para el enrutamiento
-
Ejecute el comando Interactive Routing. El cursor se convertirá en una cruz verde para indicar que el comando de enrutamiento interactivo está activo. Tenga en cuenta que puede producirse una breve demora entre la selección del comando y la posibilidad de comenzar a enrutar la primera vez que lo ejecute en una sesión de edición.
-
Haga clic en cualquier punto del pad (o de una pista existente) que le interese para comenzar a enrutar. Aparecerá un segmento de pista; el extremo fijo se unirá automáticamente al centro del pad (o al extremo de la pista existente), y el otro extremo quedará unido al cursor en movimiento. A los segmentos de pista que coloque con cada clic del ratón se les asignará automáticamente la red de ese pad o de la pista existente.
-
El extremo móvil de la pista tendrá unida una línea de conexión interactiva verde. El software conectará automáticamente el otro extremo de esa línea de conexión al objeto más cercano de la misma red. Puede enrutar la conexión hacia cualquier objeto de esa red; no es necesario seguir el patrón de las líneas de conexión. El software actualizará automáticamente las líneas de conexión en cuanto salga del modo de enrutamiento interactivo. La imagen siguiente muestra la línea de conexión original de color claro y la línea de conexión interactiva verde a medida que la pista se aproxima al pad de destino. Sitúe el cursor sobre la imagen para ver la conexión completada.
-
Haga clic con el botón izquierdo para colocar el segmento de pista y definir un punto fijo en el trazado. A continuación, siga moviendo el cursor y haciendo clic para colocar los siguientes segmentos de pista.
-
A medida que se acerque al objeto de destino, una vez que el cursor esté dentro de sus bordes, se ajustará al centro del pad o a la línea central del segmento de pista existente (o al extremo de la pista, si está más cerca).
-
Mientras enruta una conexión, puede acceder al panel Properties, activar o desactivar la cuadrícula y ajustar su configuración si es necesario. Esto se muestra en el vídeo al principio de esta sección.
-
Cuando termine de enrutar esa conexión, right-click (o pulse Esc en el teclado) para salir del modo de enrutamiento interactivo. Tenga en cuenta que esta acción lo saca del modo de enrutamiento interactivo; deberá volver a ejecutar el comando para continuar enrutando.
-
Puede dejar una pista incompleta y retomarla más adelante. Right-click con el ratón para detener el enrutamiento.
-
También puede comenzar a enrutar en cualquier punto de la superficie del sustrato. En este caso, el trazado tendrá una asignación de Net de
No Net, por lo que, si después lo enruta hasta un pad con una red asignada, se producirá una infracción de separación. Por este motivo, se recomienda comenzar a enrutar desde un objeto de red existente. -
Si es necesario, puede utilizar el panel Properties para cambiar la red asignada a uno o varios segmentos de pista ya colocados.
-
Si está enrutando en el modo de rodear obstáculos, puede producirse una demora antes de que aparezcan los segmentos de pista al acercarse a un objeto existente que pertenezca a una red diferente. Tenga en cuenta que el algoritmo para rodear obstáculos requiere que el cursor esté fuera de los objetos de otras redes para poder calcular una ruta. También puede producirse una demora entre un clic y la aparición de una pista.
-
Si el enrutador interactivo parece bloquearse, deje de mover el ratón y espere a que el software termine de calcular las ubicaciones necesarias de los objetos. Esto es especialmente importante al pasar de una superficie del sustrato a otra.
-
Puede editar una pista haciendo clic y arrastrando.
- Haga clic en una pista y arrástrela para añadir un nuevo vértice.
- Haga clic en un vértice y arrástrelo para moverlo.
-
Para cambiar el ancho de un segmento de pista ya colocado, selecciónelo y edite el ajuste Width en el panel Properties.
-
Para cambiar el ancho de varios segmentos, mantenga pulsada la tecla Shift y haga clic para seleccionar cada segmento. A continuación, podrá editar el ancho de todos los segmentos seleccionados en el panel Properties.
-
Para seleccionar todos los segmentos de pista, regiones y pads de una red, seleccione un objeto y pulse la tecla Tab.
-
Seleccione los segmentos de pista y pulse la tecla Delete del teclado para eliminar las pistas ya colocadas.
-
Para eliminar el enrutamiento de una red completa, abra el panel PCB, configúrelo en el modo Nets, active la casilla Select y, a continuación, seleccione la red o las redes deseadas en la sección Nets del panel. Cuando el panel sea el elemento activo del software, haga clic una vez en la pestaña del documento PcbDoc3D, en la parte superior del espacio de diseño del editor gráfico, para convertirlo en el elemento activo del software y, después, pulse la tecla Delete. Los pads seleccionados no se eliminarán, ya que son objetos secundarios de sus componentes principales, por lo que solo se pueden eliminar junto con dichos componentes.
Colocación de una región sólida
Se admite la colocación de una región sólida. El objeto de región se puede utilizar para crear cualquier forma de cobre, pasando por encima de las aristas de la estructura si es necesario. El vídeo muestra el proceso de colocación de una región sólida sobre una estructura 3D.
Notas sobre la colocación de una región sólida:
- Utilice los atajos 2 (ocultar componentes) y 3 (mostrar componentes) para alternar la visibilidad de los componentes.
- El cursor se ajustará tanto a la cuadrícula de alineación como a un boceto importado con el sustrato. Active y configure Alignment Grid (panel Properties) y/o los bocetos (View » Show Sketches).
- Haga clic en el botón Place Solid Region de Active Bar para comenzar a colocar una región sólida.
- El software reconocerá la forma sólida como el área más pequeña delimitada por los vértices que se definen con los clics del ratón. Si el área que está definiendo pasa por varias superficies del sustrato 3D, es posible que el software no pueda deducir correctamente las áreas interior y exterior de la región. Si es necesario, puede alternar la región entre inside y outside y el área definida pulsando Spacebar durante la colocación.
- Cuando haya terminado, haga clic con el botón derecho para salir de la colocación de regiones. El software definirá automáticamente la última arista entre las posiciones del último y del primer clic.
- Una vez colocada, la forma de una región no se puede editar de forma interactiva.
-
Haga clic una vez en una región colocada para seleccionarla. Una vez seleccionada:
- El nombre de la red se puede definir en el panel Properties si necesita que la región se conecte a una red.
- Pulse la tecla Delete para eliminar las regiones seleccionadas.
- Se pueden crear regiones curvas siguiendo el contorno de un boceto curvo importado, como se muestra en el vídeo siguiente. Obtenga más información sobre cómo importar un boceto.
- Durante el proceso de exportación, las regiones superpuestas que pertenezcan a la misma red se fusionarán en una sola región. Esto crea regiones que contienen recortes, como se muestra en el vídeo siguiente.
Vías en un diseño 3D-MID
Se pueden crear vías durante el proceso de fabricación 3D-MID, con ciertas limitaciones. Se recomienda consultar directamente con el fabricante para determinar las capacidades de fabricación en este ámbito. La compatibilidad completa con las vías aún no está implementada en la herramienta 3D-MID, pero es posible incluirlas en un diseño mediante el siguiente flujo de trabajo.
- A diferencia de una PCB estándar, cada pad de vía debe tratarse como un componente. Se debe crear un componente de pad de vía que incluya un único pin en el símbolo y su correspondiente pad único en la huella.
- La inclusión de vías consiste en colocarlas manualmente, asignarles los nombres de red y enrutarlas. La siguiente presentación muestra el proceso.
|
En este ejemplo, supongamos que queremos conectar los dos pads de los componentes como indica la línea de conexión amarilla, pero utilizando tres pistas y dos vías, tal como se muestra en azul. A diferencia de una PCB estándar, cada pad de vía debe tratarse como un componente. Es necesario crear un componente de pad de vía que incluya un único pin en el símbolo y su correspondiente pad único en la huella. Arrastre dos componentes de pad de vía desde el panel Components hasta una superficie del sustrato. Arrastre otros dos componentes de pad de vía al lado opuesto del sustrato, utilizando la cuadrícula para alinearlos con los dos primeros. Seleccione uno de los pads de los componentes para determinar el nombre de la red correspondiente; en este ejemplo, Utilizando el modo Components del panel PCB, haga doble clic para editar y asignar un Designator único a cada una de las vías,
Para establecer la propiedad Red de todos estos pads 3dVia en una sola edición, selecciónelos primero en la sección Componentes de PCB panel (tenga en cuenta que la casilla Select está activada), y, a continuación, seleccione los cuatro pads en la sección Primitivas del componente del panel. Ahora cambie al panel Properties, donde puede asignar el nombre de la red a esos cuatro pads (observe cómo la parte inferior del panel indica cuántos objetos están seleccionados para su edición). Las líneas de conexión se actualizarán para indicar que los pads de las vías ahora pertenecen a la misma red que los pads de los componentes. Enrute las conexiones en la superficie visible del sustrato. Dé la vuelta al sustrato y enrute la conexión en la otra superficie del sustrato. Las únicas líneas de conexión restantes son ahora las que representan las propias vías. No es posible completar estas conexiones en la herramienta de diseño. El diseñador debe indicar al fabricante qué pads deben taladrarse y metalizarse para formar las vías. Si la conectividad del documento 3D-MID está determinada por un documento esquemático, para mantener la coherencia entre ambos documentos, los componentes de pads de vía también deben añadirse al esquemático y conectarse a la misma red que en el diseño físico. En lugar de arrastrar el componente desde el panel, haga clic con el botón derecho y seleccione Place en el menú contextual, pero no coloque nada todavía. Mientras el componente esté flotando en el cursor, pulse la tecla Tab del teclado para editar la colocación del designador before. Si lo hace, a medida que siga haciendo clic para colocar los tres componentes restantes, sus designadores se incrementarán automáticamente. Conecte los componentes de vía según sea necesario. Para sincronizar el esquemático y el diseño físico, seleccione Design » Update PCB 3D Document en los menús del editor de esquemáticos. Al hacerlo, aparecerá el cuadro de diálogo Component Links; utilice el botón para vincular automáticamente cada nuevo componente del esquemático con su componente 3D-MID equivalente. Después de hacer clic en OK para aceptar las actualizaciones de los vínculos, aparecerá el cuadro de diálogo ECO, que detalla todos los cambios que deben realizarse para sincronizar los documentos del esquemático y del diseño físico. Haga clic en Execute para aplicar estos cambios. Para confirmar que la sincronización se ha realizado correctamente, seleccione Design » Import Changes en los menús del editor 3D-MID. |
Comprobación de reglas de diseño (DRC) de un diseño 3D-MID
El editor de documentos 3D-MID permite realizar una comprobación de reglas de diseño (DRC) por lotes para detectar infracciones de las siguientes reglas en las pistas enrutadas sobre el sustrato 3D:
La comprobación de reglas de diseño se configura en el cuadro de diálogo Design Rule Checker, al que se accede mediante el comando Tools » Design Rule Check de los menús principales.
Para obtener más información sobre cómo configurar y ejecutar una DRC, consulte la página Configuración y ejecución de una DRC.
Exportación de la PCB 3D
Una vez completado el diseño, el diseño 3D-MID puede exportarse mediante el comando File » Export » 3D-MID. Los datos exportados se guardarán en la carpeta local del proyecto.
|
El diseño completado en el editor 3D-MID de Altium; los datos exportados abiertos en MCAD; y el producto renderizado en MCAD. Tenga en cuenta que el comando Export » 3D-MID no incluye los componentes. |
Los ajustes de exportación predeterminados (enumerados a continuación) suelen ser adecuados para el proceso de estructuración directa por láser, pero se pueden configurar otras opciones mediante los ajustes avanzados correspondientes si es necesario.
| Opción | Salida predeterminada | Opciones de configuración avanzada |
|---|---|---|
| Formatos | STEP IGES Parasolid |
Seleccione el formato requerido en el cuadro de diálogo Export File |
| Contenido | Sustrato y patrón conductor
|
Solo el patrón conductor
|
| Estructura | Sustrato y patrón conductor como piezas separadas en un único ensamblaje
|
Sustrato y patrón conductor como operaciones/cuerpos separados en una única pieza
|
| Espesor del patrón conductor | 0
|
Cualquier valor de extrusión hacia el interior o el exterior del sustrato
|
También puede controlar cómo se gestionan las transiciones entre las superficies conductoras (uniones) en el archivo exportado cambiando los valores de dos opciones de configuración avanzada. Busque merge en el cuadro de diálogo Advanced Settings para localizar rápidamente los ajustes, como se muestra en la imagen siguiente.
El efecto de estos ajustes sobre los datos de exportación se muestra en la siguiente tabla:
| TrackToTrackMergeMode=0 | TrackToTrackMergeMode=1 | TrackToTrackMergeMode=2 | |
|---|---|---|---|
| PadToTrackMergeMode=0 | ![]() |
![]() |
![]() |
| PadToTrackMergeMode=1 | ![]() |
![]() |
![]() |
| PadToTrackMergeMode=2 | ![]() |
![]() |
![]() |
Otros datos de salida del proyecto
-
Las salidas del proyecto que obtienen datos de los documentos esquemáticos, por ejemplo, la lista de materiales, están disponibles de la forma habitual.
-
Las salidas del proyecto que dependen de un documento PCB, por ejemplo, un plano de ensamblaje de Draftsman, no están disponibles actualmente para un documento 3D-MID.
-
Al exportar un diseño 3D-MID (File » Export » 3D-MID), se genera un archivo de
txtcolocación de componentes en la misma carpeta que el archivo 3D-MID exportado (STEP, IGES o Parasolid). Este archivo contiene información sobre la posición de cada componente del diseño: las coordenadas X, Y y Z del centro del componente y los vectores de rotación del componente. Los vectores de rotación dependen del controlador de rotación del componente (visible cuando el componente está seleccionado):- El vector de rotación 1 es un vector opuesto al controlador de rotación.
- El vector de rotación 2 es un vector normal a la superficie en el punto de ubicación del componente.
- El vector de rotación 3 está dirigido hacia la derecha con respecto al vector de rotación 1 cuando se observa desde arriba (en dirección opuesta al vector de rotación 2).

Ejemplo de un archivo de colocación de componentes generado para una PCB 3D
Disposición de los vectores de rotación utilizados para el archivo de colocación de componentes











































