Sistema Board Insight

Altium Training

Altium Essentials: PCB Viewing and Navigation

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

De un vistazo

Este artículo explica cómo el sistema Board Insight de Altium Designer te ayuda a comprender los diseños de PCB densos y multicapa al ofrecerte mejores formas de visualizar, identificar y manipular los objetos en el espacio de diseño. Repasa sus funciones principales, como las herramientas de inspección emergentes, la lista de selección visual, el panel de información en pantalla, el resaltado dinámico de redes, el control de la capa activa, la visualización de nombres de redes, las opciones de detalle de pads y vías, los ajustes de visualización de objetos bloqueados y los modos de visualización 3D. Todas ellas están orientadas a mejorar la claridad y el control mientras trabajas. Si quieres moverte por placas complejas con más confianza y aprovechar mejor las herramientas de visualización de Altium Designer, esta guía te mostrará por dónde empezar. Sigue leyendo y haz que tu espacio de diseño sea más fácil de comprender.

- Descubre qué funciones de Board Insight te ayudan a inspeccionar con mayor claridad los objetos, las infracciones de las reglas de diseño y las zonas de alta densidad.
- Comprueba cómo las opciones de visualización, como el panel de información en pantalla, el resaltado dinámico, el control de la capa activa y la visibilidad de los nombres de redes, pueden facilitar la navegación diaria por la PCB.
- Comprende cómo los ajustes de visualización configurables, incluidos los de los objetos bloqueados y los modos de proyección 3D, pueden facilitar la interpretación de diseños de placas complejos.
Profundiza con IA:

Board Insight es un sistema de funciones configurable que te ofrece un control total sobre la visualización y el trabajo con tu diseño de PCB. Una placa multicapa compleja da lugar a un espacio de diseño visualmente denso y, a menudo, difícil de interpretar. El sistema Board Insight de Altium Designer facilita la visualización y la comprensión de los objetos de tu diseño. Consta de un conjunto integrado de funciones desarrolladas para satisfacer tus necesidades de gestión de la visualización.

Board Insight integra funciones mejoradas del modo de capa única y de visualización 3D. En el modo de capa única, puedes ver claramente qué hay en una capa determinada, pero también tener una perspectiva de lo que hay en otras capas. 

Para un observador ocasional, un diseño de PCB resulta bastante ininteligible y parece una maraña de líneas, círculos, arcos y cadenas de texto de distintos colores superpuestos entre sí. Incluso para un ojo muy entrenado, puede resultar difícil interpretar la enorme cantidad de detalles del diseño. Altium Designer incluye una serie de funciones que ayudan a buscar, identificar y gestionar la visualización del contenido del diseño. En conjunto, estas funciones se conocen como el sistema Board Insight.

Modo emergente de Board Insight

El modo emergente de Board Insight es una herramienta excelente para ver los objetos situados bajo el cursor. Pulsa Shift+X (Tools » Browse Objects) para ver información detallada sobre los componentes y las redes situados bajo el cursor, así como los objetos que pertenecen a ellos, por ejemplo, pads y pistas. Utiliza Shift+V (Tools » Browse Violations) para ver información sobre las infracciones (de las reglas de diseño definidas) situadas actualmente bajo el cursor. También se muestra una representación gráfica del objeto o de la infracción seleccionado en la ventana emergente. La lista es jerárquica, lo que te permite, por ejemplo, profundizar hasta obtener todos los detalles de los objetos primitivos asociados a una infracción concreta. Puedes ver información detallada sobre el objeto o la infracción, seleccionarlo o acercar la vista haciendo clic en él para abrir un menú emergente, o utilizando los iconos de la derecha. Las opciones disponibles son:

  • Properties o  - abre el panel Properties de ese objeto o el cuadro de diálogo Detalles de la infracción para la infracción.
  • Select o  - selecciona el objeto o la infracción en el espacio de diseño.
  • Zoom o  - acerca la vista al objeto o a la infracción.
Dado que la ventana emergente actúa sobre los objetos situados bajo el cursor, se recomienda acceder al comando mediante su atajo de teclado.

Lista visual de selección emergente

La lista visual de selección emergente facilita la elección del objeto correcto en un espacio de diseño saturado. Un diseño de PCB multicapa da lugar a un espacio de diseño denso y visualmente saturado, con muchos objetos superpuestos entre sí. La lista visual de selección emergente simplifica la selección de objetos. Haz doble clic cuando haya varios objetos bajo el cursor para mostrar la lista visual de selección emergente. A medida que desplaces el ratón por la lista, el objeto actual se mostrará en la ventana emergente, lo que facilitará su identificación. Los objetos de la lista visual de selección emergente están ordenados por capa.

El icono  situado a la derecha del nombre de una primitiva indica que esta forma parte de un componente de PCB y que las primitivas del componente de PCB al que pertenece están bloqueadas (la propiedad Primitives del componente está en el estado ).

Visualización de información en pantalla

La visualización de información en pantalla proporciona información en tiempo real sobre los objetos situados bajo el cursor en el espacio de diseño de PCB. Es configurable y puede incluir la posición del cursor, información delta (distancia desde el último clic del ratón), la capa actual y la rejilla de ajuste actual. Además del contenido informativo, también se pueden configurar la fuente y los colores de la visualización. La visualización de información en pantalla puede permanecer fija en cualquier lugar de la pantalla o seguir al cursor.

Si te detienes un momento mientras mueves el cursor, la visualización de información en pantalla cambiará a Hover mode. En este modo se muestra información adicional, que puede incluir un resumen, los atajos disponibles, las infracciones de reglas y detalles sobre redes, componentes y primitivas.

Puedes configurar la visualización de información en pantalla en la página Editor de PCB - Modos de Board Insight del cuadro de diálogo Preferences .

En la columna Heads Up de la tabla, activa las opciones de las propiedades que quieras mostrar en la visualización de información en pantalla. Los ajustes de Font de esas opciones también se pueden configurar en la tabla.

Los siguientes comandos del menú View » Board Insight (al que también se puede acceder pulsando F2 en el espacio de diseño) permiten configurar la visualización de información en pantalla: 

  • Toggle Heads Up Display (Shift+H) - activa o desactiva la visualización de información en pantalla. 
  • Toggle Heads Up Tracking (Shift+G) - alterna entre mantener la visualización de información en pantalla en una posición fija de la placa y permitir que se desplace con el cursor. La visualización HUD no saltará hasta el cursor, sino que se moverá con respecto a la posición en la que se encontraba el cursor cuando se activó el seguimiento. Se recomienda situar el cursor con respecto a la posición actual de la visualización HUD antes de utilizar este comando.
  • Resets Heads Up Delta Origin (Ins) - restablece el origen delta en las coordenadas actuales del ratón. La distancia horizontal y vertical que recorre el ratón desde el origen delta se puede mostrar en la visualización de información en pantalla. El origen delta también se puede restablecer con el botón izquierdo del ratón. Este ajuste se puede configurar en la página PCB Editor - Board Insight Modes del cuadro de diálogo Preferences .

    La disponibilidad y los controles utilizados para establecer el punto de origen delta se rigen por las opciones Insert Key Resets Heads Up Delta Origin y Mouse Click Resets Heads Up Delta Origin de la página Editor de PCB - Modos de Board Insight del cuadro de diálogo Preferences. Si ambas opciones están desactivadas, la función de origen delta queda desactivada y las coordenadas delta permanecerán en 0,0 mientras mueves el ratón.
  • Toggle Heads Up Delta Origin (Shift+D) - activa o desactiva la visualización de las coordenadas del origen delta. Las coordenadas delta muestran la distancia horizontal (dx) y vertical (dy) desde las coordenadas Delta Origin : un punto que el usuario puede definir dentro del espacio de diseño. Utiliza las coordenadas delta para medir la distancia con respecto a una posición de la placa.
Los cambios realizados en el sistema Board Insight afectan al espacio de diseño del dominio de PCB y, por tanto, a todos los documentos de PCB y de huellas de PCB con los que trabajes.

Resaltado en tiempo real

Interpretar un diseño de PCB complejo no es fácil cuando hay una alta densidad de componentes, un enrutado muy ajustado y varias capas de señal. Altium Designer incluye una serie de funciones de resaltado de redes que te ayudan a examinar el enrutado.

Utiliza la sección Live Highlighting de la página Editor de PCB - Visualización de Board Insight del Preferences cuadro de diálogo para configurar esta función. 

Utilice Ctrl+Click para resaltar cualquier red de la placa. Todos los elementos del diseño que no forman parte de esa red se atenúan, lo que permite que el trazado destaque en todas las capas de señal, como se muestra en la siguiente imagen. Para resaltar varias redes, mantenga pulsada la tecla Shift mientras hace Ctrl+Click en cada red. Ctrl+Click en cualquier espacio libre para restablecer la visualización.

El resaltado de redes también puede utilizarse de forma dinámica, de modo que una red se resalte al pasar el cursor sobre ella. Este método resalta el contorno, es configurable y no afecta a la visualización del resto de la PCB. La siguiente imagen muestra una red resaltada mediante el resaltado en tiempo real.

La siguiente imagen es un ejemplo de una red resaltada mediante Ctrl+Click. 

Control de la capa activa

El editor de PCB es un entorno multicapa en el que solo una capa está activa en cada momento. Hay varias formas de cambiar la capa activa. Tenga en cuenta que la selección de la capa actual solo se aplica al modo de visualización 2D.

  • Haga clic en la pestaña Layer en la parte inferior del espacio de diseño.
  • Utilice el menú desplegable Active Layer de la sección Layers en la pestaña Layers & Colors del panel View Configuration.
  • Desplácese entre las capas mediante los siguientes atajos.
    • Ctrl+Shift+Mouse wheel - capa siguiente/capa anterior
    • + (teclado numérico) - capa siguiente
    • - (teclado numérico) - capa anterior
    • * (teclado numérico) - capa de señal siguiente

Visualización del nombre de la red en las pistas

Otra función útil para trabajar con mayor eficiencia es la posibilidad de mostrar los nombres de las redes en las pistas (se configura en la pestaña View Options de la sección Additional Options del panel View Configuration ). Para utilizar esta función, active la opción Repeated Net Names on Tracks en la sección Additional Options. Independientemente de la zona de la placa en la que esté trabajando, podrá comprobar al instante si el trazado que está viendo corresponde a la red que le interesa. 

Mostrar los nombres de las redes en las pistas facilita la «lectura» del trazado.Mostrar los nombres de las redes en las pistas facilita la «lectura» del trazado.

Opciones de visualización de detalles de pads y vías

Puede controlar la visualización de los detalles de pads y vías mediante la sección Pad and Via Display Options de la página Editor de PCB - Visualización de Board Insight del cuadro de diálogo Preferences . Puede configurar el color, el fondo y la fuente de la información de pads y vías. Los textos se presentan automáticamente con una orientación que facilita su lectura y se alinean en la dirección que maximiza el área disponible para mostrarlos. La opción Use Smart Display Color selecciona automáticamente un color de fuente que ofrece un buen contraste para que el texto pueda leerse fácilmente.

Opciones de visualización de objetos bloqueados

Puede controlar cómo se muestran los objetos bloqueados en el espacio de diseño para facilitar su identificación visual. Utilice los controles de la sección Show Locked Texture on Objects en la página Editor de PCB - Visualización de Board Insight del cuadro de diálogo Preferences .

Ejemplo con la opción Only When Live Highlighting activada. Ejemplo con la opción Only When Live Highlighting activada.

Board Insight 3D

Board Insight 3D incluye modos de proyección que muestran la placa en proyección Perspective o Orthographic . Utilice la sección Projection en el modo de visualización 3D, en la pestaña View Options del panel de configuración de vista para seleccionar el modo de visualización deseado.

Seleccione Orthographic para ver la posición exacta de los objetos y el texto en la PCB sin que los objetos circundantes los oculten. Elija Perspective para ver una vista 3D más realista de la PCB.

AI-LocalizedLocalizado por IA
Si encuentra un problema, seleccione el texto/imagen y presioneCtrl + Enterpara enviarnos sus comentarios.
Nav
Contents
Disponibilidad de funciones

Las funciones disponibles para usted dependen de qué solución de Altium tenga: Altium Develop, Altium Agile Teams, Altium Agile Enterprise o Altium Designer (con suscripción activa).

Si no ve una función documentada en su software actual, contacte con Ventas de Altium para obtener más información.

Documentación heredada

La documentación de Altium Designer ya no está versionada. Si necesita acceder a la documentación de versiones anteriores de Altium Designer, visite la sección Documentación heredada de la página de Otros instaladores.

Contents