Búsqueda y colocación de componentes

Altium Training

Altium Essentials: Schematic Capture

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

De un vistazo

Este artículo explica cómo el panel Components de Altium Designer te ayuda a buscar, revisar, gestionar y colocar componentes de tu espacio de trabajo, así como de bibliotecas de bases de datos y de archivos. Destaca las distintas opciones de búsqueda disponibles, como la navegación por categorías, la búsqueda mediante consultas directas y el filtrado paramétrico de componentes del espacio de trabajo. También muestra cómo se conecta el panel con herramientas relacionadas, como el panel Manufacturer Part Search, el editor de componentes y el panel Explorer. Además, verás cómo abrir el panel desde documentos de esquemáticos y PCB, cómo se determinan las categorías de componentes y qué operaciones y controles de visualización están disponibles para agilizar tu flujo de trabajo. Si buscas una forma más sencilla de encontrar los componentes adecuados y colocarlos de manera eficiente en tus diseños, este artículo te ayudará a conseguirlo. Sigue leyendo.

- Aprende a buscar componentes en el panel Components mediante categorías, consultas de búsqueda y filtros basados en parámetros.
- Comprende de dónde proceden los componentes, incluidas las fuentes del espacio de trabajo, las bibliotecas de archivos, las bibliotecas de bases de datos y los resultados del panel Manufacturer Part Search.
- Descubre cómo colocar componentes y utilizar las funciones principales del panel para consultar detalles, editar componentes, gestionar bibliotecas y organizar la lista de componentes.
Profundiza con IA:

Los componentes son el núcleo de cualquier diseño electrónico. El componente que finalmente se suelda a la placa debe representarse, o modelarse, en cada dominio de diseño: como un símbolo en el esquema, como un modelo SPICE en el simulador, como una huella en la placa y como un modelo STEP 3D en el archivo que se entrega al diseñador mecánico.

Más información sobre Creación y mantenimiento de componentes y bibliotecas.

El panel Components de Altium Designer proporciona una potente interfaz que permite interactuar con todos los componentes, tanto los del espacio de trabajo como los externos a él. Puede buscar el componente necesario especificando la categoría y utilizando el modo de búsqueda simple, introduciendo una consulta (el nombre completo o parcial de un componente, un valor, etc.) en el campo de búsqueda. Además, el panel ofrece una función de búsqueda paramétrica (por facetas) basada en filtros para especificar los parámetros deseados de los componentes del espacio de trabajo. El panel también ofrece opciones para editar un componente del espacio de trabajo mediante el Editor de componentes en su modo de edición de un solo componente, ver el componente en su espacio de trabajo de origen y realizar funciones de gestión de componentes, como crear y clonar componentes o editar las opciones de piezas y el tipo del componente seleccionado. Se puede colocar un componente en el esquema arrastrándolo o utilizando el comando Place  del menú contextual del componente.

Y aunque, por supuesto, puede crear sus propios componentes, Altium Designer proporciona un potente panel Manufacturer Part Search que permite buscar piezas reales de fabricantes. Si dispone de un espacio de trabajo, puede guardar esas piezas en él y acceder después a ellas mediante el panel Components. Este proceso implica crear un nuevo componente del espacio de trabajo, utilizando el Editor de componentes en su modo de edición de un solo componente, y guardarlo en el espacio de trabajo.

El panel Components proporciona acceso directo a los componentes del espacio de trabajo y a los componentes de bibliotecas basadas en bases de datos y basadas en archivos disponibles en Altium Designer.

El panel obtiene los componentes de un espacio de trabajo conectado y de cualquier biblioteca abierta o instalada. El panel ofrece información detallada del componente seleccionado (parámetros, modelos, opciones de piezas, datos de proveedores, etc.), comparación de componentes y, para los componentes del espacio de trabajo, una función de búsqueda paramétrica basada en filtros que permite especificar los parámetros deseados.

El panel Components en su modo normal

El panel Components en su modo compacto

 

El panel Components utiliza las funciones básicas del motor de búsqueda y la vista que se emplean en el panel Manufacturer Part Search. Mientras que el panel Manufacturer Part Search aprovecha el servicio Altium Parts Provider y se centra en las búsquedas de datos de fabricantes y proveedores de componentes, el panel Components contiene componentes listos para colocar procedentes del espacio de trabajo conectado y de bibliotecas basadas en bases de datos y en archivos.

En el caso de los componentes del espacio de trabajo, el panel solo muestra la revisión más reciente de cada componente.
Aunque gran parte de las funciones para trabajar con componentes están disponibles a través del panel Components, también puede utilizar el panel Explorer: en esencia, el primero proporciona un subconjunto de las funciones disponibles en el segundo, centrado en la gestión de componentes. Algunas operaciones relacionadas con los propios componentes solo pueden realizarse desde el panel Explorer (añadir hojas de datos sin editar, cambiar estados, eliminar componentes y modelos de forma masiva, etc.), pero suelen corresponder a casos atípicos o excepcionales, o formar parte de actividades de administración o estructuración del espacio de trabajo. Recuerde que los componentes son solo un tipo de contenido: el panel Explorer despliega todo su potencial al trabajar con el conjunto completo de tipos de contenido compatibles con un espacio de trabajo. Por ejemplo, la creación y gestión de plantillas de componentes, un elemento especialmente relevante para los componentes, solo se puede realizar desde el panel Explorer (a menos que las plantillas se creen al importar bibliotecas mediante el Importador de bibliotecas).

Acceso al panel Components

Para abrir el panel Components, seleccione View » Panels » Components en los menús principales o la opción Components en el menú del botón , situado en la esquina inferior derecha de la pantalla principal. Gracias a su diseño adaptable, la disposición del panel se ajusta dinámicamente entre el modo normal a pantalla completa () y el modo compacto (), en el que las opciones de categorías y filtros se contraen en menús.

Desde un documento de esquema, utilice el atajo de teclado P, P para abrir el panel Components. También puede utilizar el comando Place » Part de los menús principales, el comando Place » Part del menú contextual del área de diseño del editor de esquemas o el botón Part () de la Active Bar.

Desde un documento de PCB, utilice el atajo de teclado P, C para abrir el panel Components. También puede utilizar el comando Place » Component de los menús principales, el comando Place » Component del menú contextual del área de diseño del editor de PCB o el comando Component () de la Active Bar.

Al abrir por primera vez el panel Components en la sesión actual de Altium Designer, estarán disponibles los siguientes controles si está conectado a un espacio de trabajo:

  • Use Existing Components – haga clic para explorar el tipo de componente seleccionado actualmente en la lista desplegable superior del panel.

  • Delete Existing Components – haga clic para abrir el cuadro de diálogo Delete Existing Components y, a continuación, la página Data Cleanup de Settings de su espacio de trabajo, donde podrá seleccionar los tipos de contenido que desea eliminar.

  • Import Library – haga clic para abrir el cuadro de diálogo estándar de Windows Open y seleccione una biblioteca basada en bases de datos o en archivos guardada en una carpeta local o de red. Tras abrir un archivo de biblioteca, se iniciará el Importador de bibliotecas en su modo simple con la biblioteca seleccionada cargada.

  • Create Component – haga clic para abrir el cuadro de diálogo Create New Component y, a continuación, el Editor de componentes en el modo de edición de un solo componente, listo para definir un nuevo componente.

El área Categories del panel (o el menú desplegable en el modo compacto) muestra todos los componentes disponibles del espacio de trabajo bajo la categoría All, así como las bibliotecas disponibles. Cuando el panel esté en modo normal, haga clic en el icono de lista Categories o en el icono « para contraer o expandir la columna, y utilice el botón (arriba a la derecha) para mostrar u ocultar el área Details del componente. Al explorar el área Categories, puede utilizar los atajos de teclado Up/Down y PgUp/PgDn para recorrer la lista. Los atajos de teclado Left/Right permiten abrir y cerrar las distintas ramas.

La agrupación Categories de los componentes del espacio de trabajo se deriva de los parámetros Component Type asociados a cada componente. Por ejemplo, si el Component Type de un componente se ha especificado como Resistor, dicho componente aparecerá en la categoría Resistor del panel Components (independientemente de la carpeta del espacio de trabajo en la que se encuentre).

Para especificar o cambiar el tipo de un componente sobre la marcha, haga clic con el botón derecho en su entrada y seleccione la opción Operations » Change Component Type del menú contextual para abrir el cuadro de diálogo Elegir tipo de componente.

El parámetro de tipo de un componente se establece:

Los tipos de componentes se gestionan (se crean, editan o eliminan) en la página Gestión de datos – Tipos de componentes del cuadro de diálogo Preferences. El botón Templates de este cuadro de diálogo abre el cuadro de diálogo Edit Templates, donde se puede especificar o cambiar la plantilla de componentes asociada a cada tipo de componente.

NOTE: La Category en la que aparece un componente se define mediante su parámetro de tipo de componente y no está relacionada con la carpeta del espacio de trabajo en la que se encuentra. Por lo tanto, si mueve un componente a otra carpeta a través del panel Explorer, ese cambio no se reflejará en el panel Components.

Menú de operaciones

Las opciones del menú de operaciones permiten configurar las preferencias de las bibliotecas basadas en archivos, realizar búsquedas y especificar si se muestra la colección de modelos de componentes. Para acceder a estas opciones, seleccione el botón del menú de operaciones en la parte superior derecha del panel.

  • Create Component – seleccione esta opción para abrir el cuadro de diálogo Create new component y, a continuación, el Editor de componentes en el modo de edición de componentes individuales, listo para definir un nuevo componente.
  • Import Library – seleccione esta opción para abrir el cuadro de diálogo estándar de Windows Open y seleccionar una biblioteca de base de datos o basada en archivos guardada en una carpeta local o de red. Tras abrir un archivo de biblioteca, se iniciará el Importador de bibliotecas en su modo simple con la biblioteca seleccionada cargada.
  • Clean-up Library – seleccione esta opción para abrir el cuadro de diálogo Delete Existing Components y, a continuación, la página Data Cleanup de Settings de su espacio de trabajo, donde puede seleccionar los tipos de contenido que desea eliminar.
  • Models – seleccione esta opción para incluir las entradas de las colecciones de modelos de bibliotecas en la lista Categories. Las entradas adicionales de este modo de exploración incluyen colecciones de modelos de símbolos, huellas y simulación procedentes del espacio de trabajo conectado, así como las bibliotecas de huellas de PCB instaladas (*.PcbLib).
  • File-based Libraries Preferences – seleccione esta opción para abrir el cuadro de diálogo Available File-based Libraries, donde encontrará controles para añadir bibliotecas de base de datos y basadas en archivos al proyecto actual o eliminarlas de él, instalar bibliotecas y especificar rutas de búsqueda de bibliotecas. Consulte la sección Gestión de las bibliotecas de base de datos y basadas en archivos disponibles de la página Búsqueda de componentes en bibliotecas basadas en archivos y de base de datos para obtener más información.
  • File-based Library Search – seleccione esta opción para abrir el cuadro de diálogo File-based Libraries Search, donde puede buscar un componente cuando no sepa qué biblioteca de base de datos o basada en archivos lo contiene, o si está disponible. Consulte la sección Búsqueda de componentes en bibliotecas de base de datos y basadas en archivos de la página Búsqueda de componentes en bibliotecas basadas en archivos y de base de datos para obtener más información.
  • Refresh – haga clic para actualizar rápidamente el panel. Se conservará la selección actual de componentes.

Lista de componentes

En la propia tabla de componentes, el contenido de la lista se gestiona mediante las siguientes acciones:

  • Establecer el orden de clasificación de la lista de componentes: haga clic en el encabezado de una columna para ordenar la lista de componentes según los datos de esa columna. Vuelva a hacer clic en el encabezado para invertir el orden.

  • Establecer el orden de las columnas mostradas: arrastre y suelte el encabezado de una columna en una nueva posición.

  • Especificar qué columnas de parámetros se muestran: haga clic con el botón derecho en el encabezado de una columna y elija Select Columns para abrir el cuadro de diálogo Select Columns, que permite controlar la visibilidad de una columna de parámetros y cambiar su posición.

    El cuadro de diálogo Select columns
    El cuadro de diálogo Select columns

    • El cuadro de diálogo enumera todas las columnas que se pueden mostrar en el panel Components. Cuando un elemento muestra , esa columna se mostrará en el panel Components . Cuando un elemento muestra , esa columna not se mostrará en el panel Components. Haga clic en los símbolos para alternar entre mostrar y ocultar.

    • También puede controlar la visualización de todas las columnas haciendo clic en el icono / de la barra de encabezados de las columnas. Cuando algunas columnas están visibles y otras ocultas, se muestra el icono .

    • Pase el cursor sobre la barra de encabezado de la segunda columna y haga clic en el icono  para abrir una lista desplegable en la que puede elegir la columna que desea mostrar.

    • Utilice los botones  /  para mover el elemento seleccionado hacia arriba o hacia abajo en la lista. Solo se pueden mover los elementos configurados como visibles (). Esto determina el orden en el que aparecerán las columnas en el panel Components.

  • Agrupar la lista por los datos de una columna: haga clic con el botón derecho en el encabezado de una columna, seleccione la opción Enable Columns Grouping y, a continuación, arrastre un encabezado de columna (p. ej., Footprint) al área de agrupación situada en la parte superior de la lista. Las entradas de la lista se agruparán según cada valor único del parámetro (p. ej., el tipo de huella) de la columna de agrupación especificada.

    Al utilizar Grouping para agrupar los componentes de la lista, se admite un máximo de 10 000 entradas.

  • Filtrar la lista por una entrada específica de una columna: seleccione en el encabezado de una columna para mostrar una lista de sus valores de parámetro únicos y, a continuación, seleccione una entrada para limitar los componentes de la lista a aquellos que incluyan el parámetro especificado (p. ej., un código de tipo de huella). Seleccione la opción All para restablecer el filtro. Seleccione (Custom) para abrir el cuadro de diálogo Filter Editor y refinar aún más el filtrado de la columna seleccionada.

Visualización de columnas

Existen varias formas de mostrar el contenido del panel Components. Al hacer clic con el botón derecho en los nombres de las columnas (Nombre, Descripción, Huella), puede seleccionar entre las siguientes opciones, según cómo desee mostrar los componentes:

  • Best Fit – ajusta el contenido de las columnas Name y Descriptions para que queden juntas, sin espacio sobrante entre ellas.

  • Best Fit All Columns – ajusta el contenido de todas las columnas para que queden juntas, sin espacio sobrante entre ellas.

  • Clear Sorting – permite deshacer la ordenación de las columnas.

  • Enable Columns Grouping – permite arrastrar los encabezados de columna por una columna específica, lo que permite cambiar el orden de las columnas Name, Description y Footprint.

  • Select Columns – abre el cuadro de diálogo Select Columns, que permite seleccionar otras columnas que desee mostrar en esta sección.

  • Apply Column Visibility to Child Categories – en los casos en que la categoría seleccionada tenga una categoría secundaria, utilice este comando para permitir la propagación de la configuración de visibilidad de las columnas desde las categorías principales a las secundarias. Este comando solo está disponible cuando existe una categoría secundaria.

Búsqueda de componentes y funciones

Búsqueda de componentes

Para buscar componentes disponibles en el panel Components, introduzca una frase en el campo Search y/o utilice las selecciones Categories y Filters del panel para limitar la lista de componentes a sus necesidades específicas. Los filtros solo se admiten para componentes del espacio de trabajo y, al igual que en el panel Manufacturer Part Search, el panel Components admite filtros de búsqueda que reconocen unidades (conversión de texto a número). La función de búsqueda prioriza los resultados según los criterios de búsqueda introducidos.

La función Search permite seleccionar y luego editar o ampliar una cadena Search activa.

Haga clic en la cadena de búsqueda «activa» para introducirla en el campo Search. Puede reutilizar o editar esa búsqueda desde el campo Search.

El campo Search también admite búsquedas con comodines, representados por un asterisco (*) en la cadena.

El cuadro de diálogo Find Similar Components, al que se accede haciendo clic con el botón derecho en un componente de la lista y seleccionando Find Similar Components, permite definir las preferencias de búsqueda a partir del componente seleccionado.

Los resultados finales de la búsqueda dependerán del tipo de componente seleccionado, ya sea un componente del espacio de trabajo o externo a este, y del estado de conexión al espacio de trabajo. Por ejemplo, los componentes del espacio de trabajo suelen mostrar más parámetros que los componentes externos. Para obtener específicamente componentes y parámetros que sean iguales o diferentes a los del componente seleccionado, puede utilizar los menús desplegables para seleccionar las opciones Same, Any o Different.

Colocación de componentes

Un componente seleccionado se coloca en un esquema arrastrándolo y soltándolo, seleccionando Place en su menú contextual, utilizando el botón en el panel Details, haciendo doble clic en la entrada del componente deseado o utilizando la tecla de acceso rápido Enter.

Para colocar un componente desde el panel, puede:

  • Hacer clic en el botón Place del panel Component Details: el cursor se desplaza automáticamente al interior de los límites de la hoja de esquema y el componente aparece flotando sobre el cursor; sitúelo y haga clic para colocarlo. Después de colocar un componente, aparecerá otra instancia del mismo componente sobre el cursor; haga clic con el botón derecho para salir del modo de colocación.

    Components panel, placing from component details pane

  • Hacer clic con el botón derecho en el componente y seleccionar Place en el menú contextual. El componente aparece flotando sobre el cursor; sitúelo y haga clic para colocarlo. Tenga en cuenta que, si el panel está flotando sobre el espacio de diseño, se atenuará para que pueda ver el esquema y colocar el componente. Después de colocar un componente, aparecerá otra instancia del mismo componente sobre el cursor; haga clic con el botón derecho para salir del modo de colocación.

  • Click, Hold&Drag – haga clic en el componente y arrástrelo desde la región de la tabla del panel hasta una hoja de esquema. Este modo requiere mantener pulsado el botón del ratón; el componente se coloca al soltarlo. Después de colocar el componente, puede seleccionar otro componente u otro comando.

    Arrastrar y soltar coloca una única instancia del componente. Si necesita colocar varias instancias, utilice el comando/botón Place o haga doble clic en la entrada del componente.

Colocar un componente es realmente sencillo. Pero antes de hacer nada, asegúrese de que la hoja de esquema (o el documento de PCB) que recibirá el componente esté abierta en Altium Designer y sea el documento activo. Si hay documentos abiertos en varias ventanas, asegúrese también de que la ventana que contiene ese documento de esquema activo tenga el foco.

Al trabajar con Altium Designer en varias ventanas, si el panel Components o el panel Explorer están acoplados en cualquier modo a una ventana que no contiene el esquema de destino, el comando Place permanecerá deshabilitado. Esto se debe a que, al hacer clic dentro de un panel acoplado, el foco pasa a la ventana a la que está vinculado ese panel. Sin embargo, con el panel flotante, se puede dar el foco a la ventana de Altium deseada (la que contiene el esquema de destino activo), y esa ventana conservará el foco al trabajar dentro del panel.

Colocación de un componente de varias partes

Si el componente que se va a colocar tiene varias partes, se colocará inicialmente la parte seleccionada debajo de la imagen de vista previa del símbolo en la región Models del panel.

Una vez colocada una parte de un componente de varias partes, puede cambiarse por otra parte de este componente mediante el menú desplegable Part del panel Properties cuando la parte esté seleccionada, o puede cambiarse a la siguiente parte disponible mediante el comando Edit » Increment Part Number de los menús principales o el comando Part Actions » Increment Part Number del menú contextual de la parte.

Altium Designer permite representar un componente de varias partes como un único símbolo (todas las subpartes) o como varios símbolos (uno por cada subparte individual) utilizando un solo componente mediante los modos de visualización Normal y Alternativo definidos (Mostrar ejemplo).

  • Si un componente de varias partes tiene subpartes vacías en su modo de visualización (normal o alternativo), estas se omiten durante la colocación (Mostrar ejemplo).

  • Si un componente de varias partes solo tiene primitivas definidas en una subparte, el sufijo del designador se oculta al colocar esa subparte en una hoja de esquemático (Mostrar ejemplo).

  • Cuando una subparte no tiene primitivas para el modo de visualización seleccionado actualmente o un modo de visualización no tiene primitivas para la subparte seleccionada actualmente, la entrada correspondiente en el menú desplegable Part de Mode del panel Properties del componente aparece atenuada (). Cuando se selecciona una entrada de este tipo en el menú desplegable, se muestran iconos de advertencia ().

  • Al ejecutar una validación del diseño, no se producirá una infracción de Subparte no utilizada en el componente si un componente tiene subpartes sin primitivas y estas no están colocadas en el esquemático.

Filtrado de componentes

Al visualizar los componentes del espacio de trabajo, el panel Filters se rellena con las opciones de filtrado seleccionadas en función de la búsqueda actual y los parámetros disponibles. El filtrado paramétrico de los componentes de la lista ofrece más opciones para localizar un componente o tipo de componente específico. Abra el panel Filters desde el botón situado encima del panel Categories. En el modo compacto del panel, haga clic en el botón para desplegar Filters como una extensión del panel.

Tenga en cuenta que los filtros solo son compatibles con los componentes del espacio de trabajo. Utilice el campo Filtro Search del panel para buscar un filtro de parámetro específico.

Javascript ID: Pnl_Components_Filter
  • La función de búsqueda paramétrica de Filters del panel depende de que el espacio de trabajo que aloja los componentes proporcione datos de parámetros de componentes adecuados. Por ello, la función de filtrado puede estar deshabilitada cuando el software está conectado a un producto de servidor de Altium antiguo. Para habilitar el filtro en versiones anteriores del servidor, habilite la opción ComponentSearch.LegacyAFS.Filters en el cuadro de diálogo Configuración avanzada.

  • Tenga en cuenta que, para que un parámetro aparezca en el panel Filters, los componentes de la categoría seleccionada deben utilizar al menos dos valores diferentes para ese parámetro. Además, solo se muestran en el panel Filters un máximo de 100 de los parámetros más utilizados (aquellos que utilizan más componentes en el espacio de trabajo conectado, entre todos los tipos de componentes). Los siguientes parámetros (o aquellos cuyos nombres comienzan por los siguientes) siempre se muestran en la parte superior del panel: Power, Value, Resistance, Res, Capacitance, Case, Package, Tolerance, RoHS, Lead.

Las opciones Filters del panel se pueden adaptar a sus necesidades seleccionando determinados tipos de parámetros como Favorites, que pasarán a la parte superior de la lista para la categoría de componentes actual. Sitúe el cursor a la derecha del nombre de un filtro de parámetro y haga clic en el icono para establecer el filtro como favorito. La configuración de los filtros favoritos se aplica y se guarda de forma individual para cada categoría de componentes.

Para los componentes del espacio de trabajo, el menú contextual ofrece opciones para editar el componente mediante el editor de componentes (Edit) y realizar funciones de gestión de componentes, como crear y clonar componentes, o editar las opciones de piezas y el tipo del componente seleccionado (Operations).

 
 
 
 
 

Las opciones de información adicional del panel Details del componente incluyen: ver una imagen del modelo, consultar hojas de datos en línea (References), consultar información de proveedores en tiempo real (Part Choices), ver dónde se ha utilizado la pieza en proyectos del espacio de trabajo, hojas gestionadas y bloques de reutilización (Where Used) y, mediante el menú contextual, copiar los datos de los parámetros del componente seleccionados o todos ellos (detalles técnicos) en un formato delimitado por tabulaciones, así como restablecer los parámetros marcados como favoritos a los cinco parámetros predeterminados.

Al explorar los componentes de un espacio de trabajo de Altium 365 conectado, si se detecta algún problema relacionado con el estado del componente seleccionado, se indicará mediante el icono (para errores) o (para errores graves) en la línea Component issues situada encima de la lista de parámetros del componente. El número a la derecha del icono indica la cantidad de problemas detectados. Haga clic en la flecha hacia abajo situada a la derecha del número para ver una breve descripción de los problemas.

Ejemplo de problemas detectados en el estado de la biblioteca.
Ejemplo de problemas detectados en el estado de la biblioteca.

Puede consultar con más detalle el estado de la biblioteca de su espacio de trabajo en la página del panel de estado de la biblioteca, accesible desde la interfaz web del espacio de trabajo de Altium 365. Consulte Panel de estado de la biblioteca para obtener más información.

Puede utilizar la función de filtrado personalizado para afinar aún más el filtrado en el panel Components. ​​​​​​

Para acceder a esta función:

  1. haga clic en el icono de filtro () del encabezado para mostrar el menú desplegable de filtros,

  2. que permite filtrar seleccionando un Filter Value (opción predeterminada) o configurando un Filter Rule definido por el usuario. Si selecciona un valor de la lista, se convertirá automáticamente en una expresión (que podrá editar después).

  3. Si selecciona Filter Rules para definir su propio filtro, elija un operador en el primer menú desplegable,

  4. y, a continuación, seleccione o introduzca un valor de filtro en el segundo menú desplegable.

  5. El filtro actual se muestra debajo de la lista de resultados; haga clic en el botón para abrir el cuadro de diálogo Filter Editor y editar el filtro.

Dónde se utiliza

Seleccione un componente del espacio de trabajo en el panel Components para ver información sobre dónde se utiliza actualmente su última revisión en la sección Where Used. Esta sección proporciona información de filtrado rápido para:

  • Projects – los proyectos del espacio de trabajo en los que se ha utilizado el componente. La información se presenta only una vez que el proyecto se ha guardado en el espacio de trabajo.

  • Managed Sheets – las hojas de esquemático gestionadas en las que se ha utilizado el componente. 

  • Reuse Blocks – los bloques de reutilización almacenados como parte de la biblioteca de un espacio de trabajo conectado.

Tenga en cuenta que las pestañas solo se mostrarán si existe una entidad en el espacio de trabajo que utilice el componente seleccionado.

Si un componente no se utiliza en todas las variantes de diseño de un proyecto del espacio de trabajo, la entrada del proyecto en la sección Where Used mostrará el número de variantes en las que se utiliza el componente y el número total de variantes del proyecto, así como la lista de variantes en las que se utiliza el componente ().

Almacenamiento en caché de datos de componentes

Al utilizar el panel Components, los datos de los componentes del espacio de trabajo se almacenan en la caché del equipo local desde el espacio de trabajo. Esto proporciona un modo de acceso sin conexión a los componentes del espacio de trabajo cuando Altium Designer no está conectado a él y, por tanto, permite explorar y colocar componentes de la forma habitual, entre otras acciones.

La primera vez que se abra el panel Components en la sesión actual de Altium Designer, si está en modo sin conexión, se mostrará una advertencia en el panel junto con controles para seguir utilizando los datos de componentes almacenados en caché o para borrar la caché.

Haga clic en Use Cached Data para utilizar los componentes almacenados en caché. Esta condición se indicará mediante el texto de advertencia Offline mode – cached data is being used en la barra inferior del área de la lista de componentes del panel. Tenga en cuenta que Filters no están habilitados en este modo.

La caché acumula datos de componentes con el tiempo y puede borrarse en cualquier momento (para todos los espacios de trabajo) mediante la opción Clear Cache, disponible en Known Servers en la página Gestión de datos – Servidores del cuadro de diálogo Preferences.

El sistema de caché solo mostrará los componentes almacenados en caché de los espacios de trabajo conectados actualmente, como un espacio de trabajo de Altium 365, lo que significa que algunos datos almacenados en caché pueden quedar deshabilitados. Este comportamiento puede gestionarse desde la página Data Management – Servers del cuadro de diálogo Preferences.

Lista de opciones de piezas

Edite la lista de opciones de piezas asociada a un componente del espacio de trabajo seleccionando la opción Operations » Create/Edit Part Choices en el menú contextual de la entrada.

Utilice el botón del cuadro de diálogo Edit Part Choices que aparece a continuación para abrir el cuadro de diálogo Add Part Choices, que buscará automáticamente fabricantes de piezas según el parámetro Name del componente seleccionado. Anule la selección del término de búsqueda predefinido para buscar alternativas manualmente. Desde el punto de vista funcional, este cuadro de diálogo es una versión modal del panel Búsqueda de piezas de fabricantes.

Puede asignar prioridades a la lista de opciones de piezas seleccionando el nivel adecuado del icono de estrella; la lista se reordenará automáticamente y situará en primer lugar la opción de fabricante con mayor prioridad.

Las opciones de piezas acompañan al componente dondequiera que se utilicen sus datos, como en un diseño de esquemático, un documento de lista de materiales (BOM), un informe de salida, etc.

Cuando se selecciona un componente en el panel Components, su lista de opciones de piezas puede verse en la sección Part Choices del área Details. La información básica (existencias, mediana del precio unitario y ciclo de vida del fabricante) de la opción de pieza relacionada también está disponible en la parte superior del área Details. La franja de color asociada indica la idoneidad básica de la pieza para su uso según su estado de ciclo de vida deducido; por ejemplo, un componente marcado como Obsolete (rojo) no se recomienda frente a uno clasificado como Volume Production (verde). Pase el cursor sobre una franja de color para ver su estado de ciclo de vida del fabricante.

Si utiliza la funcionalidad de integración con SiliconExpert o Z2Data, es posible que haya datos y controles adicionales disponibles en la parte superior del panel Details. Consulte las páginas Obtener datos de piezas de SiliconExpert y Obtener datos de piezas de Z2Data para obtener más información.

Si tiene habilitada la función Control de revisiones de opciones de piezas para su espacio de trabajo, al seleccionar la opción Operations » Create/Edit Part Choices se abrirá el Editor de componentes (en su modo de Edición de un solo componente o de Edición de componentes por lotes) en lugar del cuadro de diálogo Edit Part Choices. Aplique los cambios necesarios a las opciones de piezas y guarde los componentes de nuevo en el espacio de trabajo como las siguientes revisiones de los componentes.

Menú contextual del panel Componentes

El menú emergente que aparece al hacer clic con el botón derecho en el panel ofrece los siguientes comandos:

 
 
 
 
 
  • Place [ComponentName/FootprintName/SimulationModelName] – permite colocar el componente o modelo de simulación seleccionado en el documento esquemático activo, o la huella seleccionada en el documento de PCB activo.

  • Find Similar Components – permite abrir el cuadro de diálogo Buscar componentes similares para configurar los criterios de búsqueda y encontrar componentes similares al componente seleccionado.

  • Navigate to [ComponentName] – permite abrir el componente del espacio de trabajo elegido en el panel Explorador, donde puede acceder a información detallada del elemento y gestionar los ajustes de revisión y ciclo de vida de los elementos, así como consultar dónde se utilizan y los detalles de la cadena de suministro, entre otras opciones.

  • Edit – haga clic para editar los componentes del espacio de trabajo seleccionados mediante el Editor de componentes (en su modo de Edición de un solo componente o de Edición de componentes por lotes) o el modelo de dominio seleccionado (símbolo, huella o modelo de simulación) en su editor. Si el tipo de componente actual es diferente del de la plantilla que se está utilizando, se abrirá el cuadro de diálogo Change component type (). Utilice este cuadro de diálogo para cambiar el tipo de componente del componente seleccionado.

  • Create – haga clic para abrir el cuadro de diálogo Create new component y seleccionar el tipo de componente al añadir uno nuevo.

  • Delete – haga clic para eliminar los componentes seleccionados del espacio de trabajo al que está conectado.

  • Operations – permite acceder a un menú desplegable de funciones adicionales para los componentes del espacio de trabajo, como se describe a continuación.

    • Submit Request – permite acceder a las definiciones de proceso activas de solicitud de piezas. Si no hay definiciones de proceso activas disponibles para la categoría de procesos Solicitudes de piezas, el botón Submit Request aparecerá atenuado (no disponible). Es posible que tenga que cerrar la sesión del espacio de trabajo y volver a iniciarla, o reiniciar Altium Designer para actualizarlo.

    • Download – permite descargar los componentes seleccionados en una Biblioteca integrada compilada y comprimida en ZIP (*.IntLib), con su paquete de bibliotecas de origen (*.LibPkg) y sus archivos de biblioteca. Seleccione varias entradas de componentes para descargarlos en una sola sesión.

    • Make a copy – haga clic para copiar el componente seleccionado. El editor de componentes se abre en el modo Single Component Editor.

    • Change Component Type – permite abrir el cuadro de diálogo Choose component type (), desde el que puede cambiar el tipo del componente actual por otro de los tipos definidos existentes en la lista. El cuadro de diálogo muestra información sobre cualquier plantilla de componentes asociada a un tipo de componente y la carpeta del espacio de trabajo conectado en la que se pueden encontrar o guardar los componentes de ese tipo. Haga clic en el botón  para gestionar la lista de tipos de componentes disponibles en la página Gestión de datos – Tipos de componentes del cuadro de diálogo Preferences.

    • Change State – permite cambiar el estado de revisión de los componentes seleccionados. Tras utilizar el comando, se abre el cuadro de diálogo Cambio de estado por lotes, que permite cambiar el estado de revisión de los componentes.

    • Create/Edit Part Choices – permite acceder al cuadro de diálogo Edit Part Choices, donde puede crear o editar la lista de opciones de piezas asociada al componente del espacio de trabajo.

      Si tiene habilitada la función Control de revisiones de opciones de piezas para su espacio de trabajo, al seleccionar este comando se abrirá el Editor de componentes en su modo de Edición de un solo componente o de Edición de componentes por lotes.
    • Full Item History – permite acceder a una vista detallada del componente seleccionado, que se abre como una nueva pestaña en Altium Designer. La Vista de elemento ofrece una vista muy detallada del historial de revisiones y del ciclo de vida de un elemento específico, además de mostrar todos los elementos que lo componen. La vista también incluye una línea de tiempo. Utilice la línea de tiempo para consultar la fecha y hora exactas de cualquier cambio realizado en el nivel de revisión o en el estado del ciclo de vida de ese elemento y quién lo realizó.

  • Refresh – haga clic para actualizar rápidamente el panel. Se conservará la selección actual de componentes.

Función de comparación de componentes

La función Compare permite comparar los parámetros de dos componentes (piezas) seleccionados. Para acceder a esta función, seleccione dos componentes en el área de la tabla con el icono habilitado (azul). El área Selected Component Details se abrirá a la derecha del área de la tabla. El área superior (área 1 en la imagen siguiente) muestra, uno al lado del otro, una imagen, el nombre, la descripción y el precio de los componentes seleccionados. Haga clic en el botón Datasheet para abrir la hoja de datos del fabricante (si está disponible) del componente correspondiente. Haga clic en el botón Place para colocar el componente en el espacio de diseño. El componente aparecerá flotando en el espacio de diseño; haga clic para colocarlo en la ubicación deseada. Puede seguir colocando componentes adicionales, o hacer clic con el botón derecho o pulsar Esc para salir del modo de colocación y volver al panel Components.

El área inferior (área 2 en la imagen siguiente) muestra los parámetros de los componentes uno al lado del otro, con las diferencias resaltadas en rojo para facilitar la comparación.

La función Compare también está disponible cuando el panel Components está en modo compacto, aunque funciona de forma ligeramente distinta. Para acceder a esta función, seleccione dos componentes en el área de la tabla. El área Selected Component Details se abrirá debajo del área de la tabla. El área superior muestra el nombre, el precio y una vista de los parámetros de los componentes, con las diferencias resaltadas en rojo para facilitar la comparación. El área inferior muestra, uno al lado del otro, los Symbols y Models de los componentes.

La función Compare y sus funcionalidades también están disponibles en el panel Búsqueda de piezas de fabricantes.

Edición de símbolos y huellas de componentes

El símbolo y la huella de un componente determinado pueden ocultarse en la sección Models del panel Details, al que se accede haciendo clic en Info button en la parte superior derecha. Una vez ocultos, el símbolo y la huella se sustituirán por enlaces en los que se puede hacer clic para restaurar la vista original de los elementos ocultos. También es posible ajustar el tamaño de los modelos mostrados. Tanto para los símbolos como para las huellas, haga clic y arrastre el borde inferior del área del modelo para cambiar el tamaño de la imagen.

Tenga en cuenta que la posibilidad de ocultar y cambiar el tamaño de las vistas de los modelos también está disponible en el área Details del panel Búsqueda de piezas de fabricantes.

En el caso de un archivo de biblioteca de esquemáticos (*.SchLib) que se esté explorando en el panel Components, el símbolo y la huella del componente seleccionado pueden editarse mediante el botón situado en la esquina inferior derecha de la vista previa del modelo.

La posibilidad de editar una huella está disponible al acceder a Components, siempre que ya existan huellas válidas y vinculadas.

Cuadros de diálogo de selección de componentes

El motor de búsqueda y la vista utilizados en el panel Components también se emplean en otras aplicaciones de Altium Designer en las que se selecciona un componente. La funcionalidad de búsqueda de componentes se incluye en estos cuadros de diálogo (modales), junto con un botón de confirmación OK y pequeñas variaciones en los comandos de acción disponibles. El cuadro de diálogo suele denominarse Component Search.

Acceso y colocación de componentes genéricos

Esta función está en beta abierta y está disponible cuando la opción ComponentSearch.GenericComponents está habilitada en el cuadro de diálogo Configuración avanzada.

Para agilizar el proceso de desarrollo de las primeras etapas de un diseño, se ofrece el concepto de Generic Components estándar y básicos. Los componentes genéricos pueden colocarse rápidamente en un diseño sin necesidad de buscar y elegir una pieza de un fabricante específico entre las fuentes de componentes disponibles. Los componentes genéricos están pensados como marcadores de posición que pueden reemplazarse fácilmente por un componente adecuado más adelante en el proceso de diseño; también pueden considerarse componentes virtuales o paramétricos.

Para obtener más información sobre la creación de componentes genéricos, consulte la página Creación de componentes genéricos.

Cuando Altium Designer está conectado a un espacio de trabajo, se puede acceder a los componentes genéricos disponibles desde el panel, donde se muestran al seleccionar la opción All en el panel Categories, o desde el menú desplegable superior cuando el panel está en modo compacto. Haga clic en el botón de la ficha de un componente genérico para adjuntar el componente al cursor y colocarlo en el documento esquemático activo. Cuando el componente se coloca en un esquemático, las primitivas de pines, líneas y bordes del símbolo —es decir, su contorno— se muestran en rojo para indicar que se está utilizando un componente genérico. Al seleccionar la propia ficha en el panel Components, se abrirá la categoría de ese tipo de componente en el panel.

Colocación de un componente genérico desde el panel Components
Colocación de un componente genérico desde el panel Components

Dado que los componentes genéricos no deben utilizarse en un diseño final, provocarán una infracción de ERC —Componente genérico— cuando se coloquen en un esquemático. El nivel de esa infracción —Fatal Error de forma predeterminada— se determina en la sección Infracciones asociadas a componentes de la configuración de notificación de errores del cuadro de diálogo Project Options (Project » Project Options).

Seleccione un componente genérico colocado para acceder a sus propiedades en el panel Propiedades, que solo ofrece los ajustes y parámetros pertinentes para este tipo de componente. Los parámetros disponibles se determinan mediante la plantilla de componentes relacionada (Resistors en el ejemplo que se muestra aquí). Los valores de los parámetros pueden introducirse manualmente o seleccionarse en una lista desplegable que ofrece valores procedentes de todos los componentes disponibles de ese tipo.

Especificación de los parámetros de un componente genérico: selección de valores de parámetros en las listas desplegables.

Especificación de los parámetros de un componente genérico: el resultado.

 

Compatibilidad con componentes de puente

Los puentes, también denominados puentes de hilo, permiten reemplazar el trazado de pistas por un componente de puente, lo que a menudo resulta esencial para diseñar correctamente una placa de una sola cara. Altium Designer admite el uso de componentes de puente mediante un tipo de componente especial: Jumper.

Aunque puede comenzar colocando las huellas de los puentes directamente en la PCB, se recomienda un flujo de trabajo que comience en el esquemático. Para obtener más información, consulte la página Trabajo con componentes de puente.

AI-LocalizedLocalizado por IA
Si encuentra un problema, seleccione el texto/imagen y presioneCtrl + Enterpara enviarnos sus comentarios.
Nav
Contents
Disponibilidad de funciones

Las funciones disponibles para usted dependen de qué solución de Altium tenga: Altium Develop, Altium Agile Teams, Altium Agile Enterprise o Altium Designer (con suscripción activa).

Si no ve una función documentada en su software actual, contacte con Ventas de Altium para obtener más información.

Documentación heredada

La documentación de Altium Designer ya no está versionada. Si necesita acceder a la documentación de versiones anteriores de Altium Designer, visite la sección Documentación heredada de la página de Otros instaladores.

Contents