Création et définition de la bibliothèque de base de données

En un coup d'œil

Découvrez comment créer et configurer des bibliothèques de base de données standard et sous contrôle de version dans Altium Designer. Cet article explique comment se connecter à une base de données externe, lier un fichier SVNDbLib à un dépôt Subversion, choisir les tables de base de données à inclure et définir les critères de correspondance qui relient les composants placés à leurs enregistrements sources. Poursuivez votre lecture pour passer à l’étape suivante de la configuration de votre bibliothèque de base de données.

- Comprenez le rôle des fichiers DbLib et SVNDbLib et découvrez où les créer.
- Explorez les options de connexion aux bases de données, notamment les raccourcis pour Access et Excel, les chaînes de connexion et les fichiers Microsoft Data Link.
- Apprenez à parcourir et à modifier les tables connectées, à gérer leur inclusion dans la bibliothèque et à définir les critères de correspondance des composants pour chaque table.
Approfondissez avec l'IA :

Le fichier de bibliothèque de base de données constitue la clé de voûte de la fonctionnalité de bibliothèque de base de données. Il se présente sous deux formes, selon que vous utilisez une bibliothèque de base de données standard ou une bibliothèque de base de données sous contrôle de version :

  • Standard Database Library - le fichier Database Library. Ce fichier est créé et géré à l’aide de l’éditeur DatabaseLib d’Altium Designer. Cet éditeur est disponible lorsque le document actif dans la fenêtre de conception principale est un fichier *.DbLib.
  • Version-Controlled Database Library - le fichier SVN Database Library. Ce fichier est créé et géré à l’aide de l’éditeur SVNDatabaseLib d’Altium Designer. Cet éditeur est disponible lorsque le document actif dans la fenêtre de conception principale est un fichier *.SVNDbLib.

Exemple de fichier DbLib ouvert dans l’éditeur DatabaseLib. Survolez l’image pour voir un exemple de fichier SVNDbLib ouvert dans l’éditeur SVNDatabaseLib.Exemple de fichier DbLib ouvert dans l’éditeur DatabaseLib. Survolez l’image pour voir un exemple de fichier SVNDbLib ouvert dans l’éditeur SVNDatabaseLib.

Créez un nouveau fichier de l’un de ces types en choisissant la commande File » New » Library  dans les menus principaux, puis en sélectionnant l’option Database Library ou SVN Database Library dans la zone Database de la boîte de dialogue New Library qui s’ouvre.

Connexion à une base de données externe

Les données des tables et de correspondance n’apparaissent dans la fenêtre d’affichage principale de l’éditeur qu’une fois le fichier Database Library/SVN Database Library actif connecté à la base de données externe requise. La connexion est définie à l’aide des commandes de la zone Source of Connection.

Définition de la connexion à la base de données externe au moyen d’un fichier DbLib. Survolez l’image pour voir la connexion au moyen d’un fichier SVNDbLib.Définition de la connexion à la base de données externe au moyen d’un fichier DbLib. Survolez l’image pour voir la connexion au moyen d’un fichier SVNDbLib.

Il est possible de se connecter à toute base de données prenant en charge OLE DB. Les options proposées dans cette zone utilisent chacune une chaîne de connexion OLE DB pour se connecter à la base de données cible. Certaines bases de données ne prennent pas en charge OLE DB. Toutefois, la quasi-totalité des systèmes de gestion de bases de données utilisés aujourd’hui sont accessibles via l’interface Open Database Connectivity (ODBC). La fonctionnalité de liaison à une base de données utilise le fournisseur ODBC de Microsoft, qui permet à un objet ADO (ActiveX Data Object) de se connecter à n’importe quelle source de données ODBC. Il est donc possible de se connecter à n’importe quelle base de données ODBC. Le fournisseur OLE DB pour la base de données ODBC est spécifié dans la chaîne de connexion.

La connexion peut également être définie dans l’onglet Connection de la boîte de dialogue Database Connection, accessible en choisissant la commande Tools » Database Connection dans les menus principaux ou en cliquant sur le bouton Advanced (à droite du bouton Connect , en bas de la zone).

Connexion rapide aux bases de données Access et Excel

L’option Select Database Type permet de créer rapidement une chaîne de connexion lorsque la base de données cible a été créée à l’aide de Microsoft Access ou de Microsoft Excel. Avec cette option, sélectionnez le type de base de données, puis parcourez les fichiers pour sélectionner le fichier de base de données requis. La chaîne de connexion correspondante est automatiquement générée et saisie dans le champ de l’option Use Connection String.

Vous pouvez spécifier le chemin complet ou choisir d’enregistrer le chemin relatif au fichier Database Library/SVN Database Library.

Création d’une chaîne de connexion

Si la base de données de votre entreprise ne repose ni sur Access ni sur Excel et que vous souhaitez créer explicitement la chaîne de connexion, activez l’option Use Connection String, puis cliquez sur le bouton Build associé, à droite. La boîte de dialogue Data Link Properties s’affiche.

Création d’une chaîne de connexion dans la boîte de dialogue Data Link Properties.Création d’une chaîne de connexion dans la boîte de dialogue Data Link Properties.

La boîte de dialogue s’ouvre sur l’onglet Connection . Le fournisseur OLE DB Microsoft Office <Version> Access Database Engine OLE DB Provider est défini par défaut dans l’onglet Provider de la boîte de dialogue. Il s’agit du fournisseur par défaut pour les nouveaux fichiers Database Library/SVN Database Library ; il est également utilisé pour se connecter aux fichiers de base de données Access (*.mdb). Changez de fournisseur si nécessaire.

Dans l’onglet Connection , saisissez le nom (chemin compris) de la base de données à laquelle vous souhaitez vous connecter.

Si votre base de données nécessite une authentification, saisissez les informations requises, ainsi que tout autre paramètre avancé disponible dans l’onglet Advanced de la boîte de dialogue. L’onglet All présente un récapitulatif des options de liaison définies, ainsi que des options étendues relatives au fournisseur OLE DB choisi. Les options peuvent être modifiées selon les besoins dans cet onglet.

Une fois les options de liaison définies, vous pouvez vérifier que la connexion fonctionne en cliquant sur le bouton Test Connection (dans l’onglet Connection ). Si la connexion réussit, une boîte de dialogue de confirmation s’affiche.

La boîte de dialogue Data Link Properties est une boîte de dialogue Microsoft. Par conséquent, appuyer sur F1 ou utiliser le bouton Help disponible permet d’accéder au fichier Microsoft Data Link Help. Ce fichier ne fait pas partie de la documentation d’Altium Designer.

Spécification d’un fichier de liaison de données

Si la source de données à laquelle vous souhaitez vous connecter est décrite dans un fichier Microsoft Data Link (*.udl), activez la troisième option de connexion — Use Data Link File — et cliquez sur le bouton Browse associé pour localiser le fichier requis. Un fichier de liaison de données sert essentiellement à stocker une chaîne de connexion.

Établissement de la connexion

Après avoir défini la connexion à la base de données externe, le texte du bouton Connect s’affiche en gras, indiquant que vous pouvez établir la connexion. Si les informations de connexion sont correctes, les informations relatives aux tables et aux correspondances de la base de données cible sont chargées dans le fichier Database Library/SVN Database Library. Le texte du bouton Connect devient Connected et le bouton est grisé.

En cas de problème avec les informations de connexion, par exemple si une chaîne de connexion est mal construite ou si un chemin est erroné, la connexion échoue et un message vous en informe. Vérifiez vos paramètres de connexion et cliquez de nouveau sur le bouton Connect .

Exemples de signalement d’un échec de connexion dans une bibliothèque de base de données. Exemples de signalement d’un échec de connexion dans une bibliothèque de base de données.

Si vous modifiez les paramètres de connexion alors que vous êtes connecté à une base de données, la connexion active est interrompue et le texte du bouton Connect devient Reconnect. Cliquez dessus pour rétablir la connexion.

Une fois la connexion initiale établie et le fichier Database Library/SVN Database Library enregistré, la connexion s’établit automatiquement à chaque ouverture du fichier, à condition que l’emplacement et le nom de fichier de la base de données cible n’aient pas changé.

Définition du lien vers le dépôt de gestion des versions (SVNDbLib uniquement)

Avec une DbLib, les bibliothèques de symboles et de modèles sont stockées sur votre disque dur ou sur un autre support local ou réseau. Rappelez-vous que, pour une SVNDbLib, ces bibliothèques sont placées sous gestion des versions dans un dépôt Subversion. Dans le fichier SVNDbLib, vous devez définir le lien vers ce dépôt. La connexion au dépôt SVN est définie dans l’onglet SVN Repository de la boîte de dialogue Database Library Options (Tools » Options). Vous pouvez également accéder à cette boîte de dialogue en cliquant sur le bouton Options dans la zone Field Settings de la vue du document.

Exemple de connexion à un dépôt SVN basé sur des fichiers.Exemple de connexion à un dépôt SVN basé sur des fichiers.

Liste des tables de la base de données

Une fois la connexion à la base de données externe établie, les données des tables et des correspondances sont chargées. La partie gauche du document DbLib/SVNDbLib répertorie toutes les tables présentes dans la base de données connectée.

Dans une base de données Excel, une table correspond en réalité à une feuille du classeur lié. Le nom de la table porte le suffixe $.

Tables présentes dans la base de données connectée.Tables présentes dans la base de données connectée.

L’option Enable située à côté de chaque entrée de table vous permet de déterminer si cette table doit faire partie de la bibliothèque de base de données résultante. Lorsque la bibliothèque de base de données est ajoutée à la liste des bibliothèques basées sur des fichiers disponibles pour consultation dans le panneau Components, chaque table apparaît comme une bibliothèque distincte. Ainsi, bien qu’une seule bibliothèque de base de données soit réellement ajoutée, du point de vue du panneau Components , tout se passe comme si vous aviez ajouté plusieurs bibliothèques distinctes. Pour plus d’informations, consultez Recherche de composants dans les bibliothèques basées sur des fichiers et les bibliothèques de base de données.

Lorsque vous cliquez sur une entrée de table dans la liste, son icône passe de Database table icon, inactive table à Database table icon, active table pour indiquer qu’il s’agit de la table actuellement active. La table, avec toutes ses données, apparaît dans l’onglet Table Browser du document. Cette vue modifiable vous permet de consulter rapidement son contenu et de le modifier si nécessaire, sans avoir à ouvrir la base de données externe elle-même.

Consultation d’une table source dans la base de données connectée.Consultation d’une table source dans la base de données connectée.

Pour agrandir la zone de consultation des tables (comme illustré ci-dessus), réduisez toute la zone située au-dessus (paramètres de connexion et des champs) en cliquant sur la commande Collapse icon - collapse a region of the database library document, en haut à droite de la vue du document. Cliquez sur Expand icon - expand a region of the database library document pour la développer. La table propose également les fonctions habituelles de regroupement, de tri et de filtrage.

Définition des critères de correspondance

Après avoir placé un composant à partir de la base de données externe, il faut pouvoir conserver le lien entre ce composant et l’enregistrement de la base de données dont les informations ont servi à le créer. Il s’agit donc d’établir une correspondance entre les deux.

Lorsqu’un composant est placé, ses paramètres sont créés à la volée à partir des champs correspondants de l’enregistrement de la base de données. Le lien entre le composant du schéma et l’enregistrement de la base de données est établi après le placement à l’aide d’un ou de plusieurs de ces paramètres. La zone Field Settings du document vous permet de définir les critères de correspondance : une simple recherche par clé unique ou une correspondance plus avancée à l’aide d’une clause WHERE.

Les critères de correspondance sont définis individuellement pour chaque table.

Définition des critères de correspondance après placement.Définition des critères de correspondance après placement.

Recherche par clé unique

Si l’option Single key lookup est activée (par défaut), les champs Database field et Part parameter deviennent disponibles. Le premier répertorie tous les noms de champs (en-têtes de colonnes) disponibles dans la table active de la base de données. Comme les paramètres d’un composant du schéma sont ajoutés lors de son placement, le champ Part parameter reflète le champ de base de données sélectionné.

En général, le champ utilisé comme clé de recherche permet d’identifier de manière unique chaque composant dans la base de données externe, par exemple une référence de composant. Le champ de recherche choisi est signalé dans l’onglet Field Mappings du document par l’entrée Design Parameter, qui apparaît grisée.

Correspondance par clé unique à l’aide de la référence du composant.Correspondance par clé unique à l’aide de la référence du composant.

Lorsque vous utilisez la fonction Update Parameters From Database après le placement, les informations du paramètre clé choisi sont lues dans les composants placés sur le schéma, puis recherchées dans le champ (clé) choisi de la base de données, dans toutes les tables activées. Lorsqu’une correspondance est trouvée, les informations des autres cellules de cet enregistrement dans la table source peuvent alors être transférées vers les paramètres correspondants du composant du schéma.

Correspondance avancée : la clause WHERE

Si l’option Single key lookup fonctionne bien lorsqu’il existe une référence ou un identifiant unique sur lequel établir la correspondance, elle est moins efficace avec un paramètre non unique, comme la capacité ou la résistance. Dans ce cas, il convient d’utiliser la clause WHERE, plus avancée, qui permet de définir une correspondance sur plusieurs clés afin de relier le composant du schéma à son enregistrement source dans la base de données.

Dans sa forme la plus simple, la clause WHERE (écrite en syntaxe SQL) reflète les entrées sélectionnées pour définir la recherche par clé unique. Par exemple, si Database field est défini sur Part Number — la valeur par défaut —, le champ Part parameter est lui aussi automatiquement défini sur Part Number, et la clause WHERE est la suivante :

[Part Number] = '{Part Number}'

Les crochets entourant le champ de la base de données (colonne de table) sont des caractères de délimitation, tels que définis dans l’onglet Advanced de la boîte de dialogue Database Connection. Pour accéder à cette boîte de dialogue, cliquez sur le bouton Advanced dans la zone Source of Connection du document, ou passez par le menu principal Tools .

Mapping between the component parameters and the database, using a Where clause L’onglet Advanced de la boîte de dialogue Database Connection propose des options SQL supplémentaires pour délimiter les noms des
tables ou utiliser les noms de schéma des tables dans une clause WHERE construite.

Lorsque vous encadrez les noms de tables avec des caractères de délimitation, les caractères à utiliser dépendent de la base de données utilisée. Par exemple, les crochets [ ] ne peuvent être utilisés que dans les bases de données Microsoft telles qu’Access, Excel via ADO ou MSSQL (versions récentes). MYSQL utilise le caractère ` (accent grave) comme délimiteur. Dans toute base de données, il n’est réellement nécessaire de délimiter les noms de colonnes que s’ils contiennent des espaces ou correspondent à des mots réservés de cette base de données. Consultez la documentation de votre logiciel de base de données pour connaître les caractères de délimitation utilisés, le cas échéant.

Les accolades indiquent que l’entrée référencée est un paramètre de conception. Les apostrophes indiquent que le paramètre de conception doit être traité comme une chaîne de caractères, et non comme un nombre (sans apostrophes). La correspondance des types est très importante, car SQL est sensible aux types. Le paramètre de conception doit être du même type que la colonne de la base de données.

En utilisant la syntaxe SQL standard, la clause Where peut ensuite être étendue pour rechercher des correspondances à l’aide de plusieurs entrées Database field/Part parameter, par exemple :

[Capacitance] = '{Capacitance}' AND [Tolerance] = {Tolerance} AND [Manufacturer] = '{Manufacturer}'

Dans ce cas, un seul enregistrement de la table concernée de la base de données serait lié à l’aide de trois paramètres de conception différents. Notez que l’entrée du paramètre de conception Tolerance n’est pas encadrée d’apostrophes. Cela signifie que le type de colonne dans la table associée de la base de données est Number et non String.

La syntaxe SQL standard vous permet de rendre la clause Where aussi simple ou aussi complexe que vous le souhaitez.

Correspondance entre les champs de la base de données et les paramètres de conception

Les paramètres de conception d’un composant placé à partir d’une bibliothèque de base de données sont créés/ajoutés au moment du placement. Les paramètres effectivement créés et les options utilisées pour mettre à jour leurs informations après le placement, à l’aide de la commande Tools » Update Parameters From Database, sont déterminés par les informations de correspondance et de mise à jour spécifiées dans le fichier Database Library/SVN Database Library. Ces réglages s’effectuent dans l’onglet Field Mappings de la vue principale du document.

Les options de correspondance et de mise à jour sont spécifiées pour chaque table.

Spécifiez les options de correspondance et de mise à jour des paramètres dans l’onglet Field Mappings du document DbLib/SVNDbLib.Spécifiez les options de correspondance et de mise à jour des paramètres dans l’onglet Field Mappings du document DbLib/SVNDbLib.

Correspondance des modèles et des paramètres

Les deux premières colonnes (en partant de la gauche) de l’onglet Field Mappings permettent de déterminer quelles informations de la base de données doivent être associées aux attributs, modèles et paramètres du composant.

  • Database Field Name - cette colonne répertorie tous les noms de champs (colonnes) de la table actuellement active de la base de données.
  • Design Parameter - cette colonne définit la manière dont chaque champ correspondant de la base de données doit être utilisé. Il peut servir à fournir le symbole ou le modèle d’empreinte d’un composant (il sera alors encadré de crochets), ou être inclus comme paramètre de composant (sans crochets).
Lorsque vous ouvrez un document DbLib/SVNDbLib connecté à une base de données, vous remarquerez que certains paramètres de conception comportent des crochets et d’autres non. Les crochets indiquent un nom réservé, tel que [Library Ref]. Ces données servent à renseigner les attributs et les modèles du composant. Les paramètres de conception qui ne comportent pas de crochets deviennent des paramètres de composant.

La correspondance initiale est établie automatiquement lors de la connexion à la base de données, pour l’ensemble des champs de celle-ci.

Notez que la correspondance automatique suppose que les noms des champs de la base de données correspondent aux noms réservés utilisés dans Altium Designer. Si ce n’est pas le cas, la correspondance doit être configurée manuellement.

Attributs et modèles

Si le nom du champ de la base de données est l’un des noms réservés suivants, l’entrée de correspondance de l’attribut/du modèle sera automatiquement définie dans le champ Design Parameter :

  • Description → [Description]
  • Footprint Ref → [Footprint Ref]
  • Footprint Path → [Footprint Path]
  • Footprint Ref n → [Footprint Ref n]
  • Footprint Path n → [Footprint Path n]
Un nombre illimité de références de modèles d’empreinte (et de chemins d’accès) peut être spécifié dans une table de base de données et associé dans le fichier DbLib/SVNDbLib. Dans les noms réservés, n représente un entier positif commençant à 2.
  • Library Ref → [Library Ref]
  • Library Path → [Library Path]
  • Orcad Footprint → [Orcad Footprint]
  • Orcad Library → [Orcad Library]
Ces références sont utilisées lors de l’importation d’un fichier de configuration et de bibliothèques OrCAD CIS, ainsi que de la génération d’une bibliothèque de base de données standard (DbLib).
  • PCB3D Ref → [PCB3D Ref]
  • PCB3D Path → [PCB3D Path]

    • Les références à PCB3D concernent l’ancienne visionneuse 3D et ne doivent pas être utilisées pour les nouvelles conceptions. Le moteur 3D natif de l’éditeur de PCB peut afficher les corps des composants et les fichiers de modèles 3D importés associés aux empreintes des composants.
    • Des correspondances de modèles PCB3D peuvent être définies dans un fichier SVNDbLib, mais le stockage des bibliothèques de modèles PCB3D dans le dépôt Subversion n’est pas pris en charge.
  • Sim Description → [Sim Description]
  • Sim Excluded Parts → [Sim Excluded Parts]
  • Sim File → [Sim File]
  • Sim Kind → [Sim Kind]
  • Sim Model Name → [Sim Model Name]
  • Sim Netlist → [Sim Netlist]
  • Sim Parameters → [Sim Parameters]
  • Sim Port Map → [Sim Port Map]
  • Sim Spice Prefix → [Sim Spice Prefix]
  • Sim SubKind → [Sim SubKind]

    Reportez-vous à la section Correspondance des modèles de simulation ci-dessous pour en savoir plus sur les champs relatifs aux modèles de simulation.
    Un seul lien vers un modèle de simulation peut être défini pour un composant dans une base de données externe. En règle générale, un seul modèle de simulation est lié à un composant. Si vous souhaitez configurer plusieurs liens vers des modèles de simulation, les autres liens devront être définis et enregistrés avec ce composant dans le fichier de bibliothèque de schémas source.
    Les modèles de simulation liés sont pris en charge pour une bibliothèque de base de données sous gestion de versions (SVNDbLib), mais le stockage des fichiers de modèles de simulation dans le dépôt Subversion n’est pas pris en charge.

Ces correspondances définissent les informations relatives aux attributs et aux modèles du composant. Lors du placement du composant, le symbole schématique spécifié dans le champ [Library Ref] de l’enregistrement correspondant de la base de données est extrait de la bibliothèque de schémas spécifiée. De même, les informations d’empreinte PCB et de modèle de simulation stockées dans l’enregistrement sont ajoutées au composant sous forme de modèles liés, respectivement d’empreinte et de simulation.

L’entrée [Library Ref] doit exister dans la colonne Design Parameter et être associée au Database Field Name qui spécifie le symbole schématique pour pouvoir placer un composant de la bibliothèque Database Library/SVN Database Library sur un schéma. Si la table de la base de données contient la référence du symbole sous un autre Database Field Name, par exemple SCH Symbol, vous devrez définir manuellement l’entrée Design Parameter associée à ce champ sur [Library Ref], à l’aide de la liste déroulante disponible dans cette cellule.

De même, si les informations de référence des modèles sont saisies dans la base de données sous des noms de champs différents, vous devrez établir manuellement les correspondances en choisissant l’entrée Design Parameter appropriée ([Footprint Ref], [Footprint Ref n], [PCB3D Ref], [Sim Model Name], etc.) dans la liste déroulante, pour chaque champ.

Mapping the symbol and footprint models from the database to the design componentPour définir les informations de symbole et de modèle d’un composant lors de son placement, les champs de référence du symbole et des modèles dans la base de données constituent les éléments essentiels
de la correspondance : assurez-vous que la correspondance définie comprend une référence de symbole et au moins une référence d’empreinte PCB.

Comme indiqué précédemment, plusieurs modèles PCB peuvent être associés. Le Database Field Name associé à Design Parameter [Footprint Ref] sera l’empreinte par défaut lors du placement du composant sur le schéma. C’est cette empreinte qui sera placée lors du transfert de la conception vers le domaine PCB.
Lors de la définition des correspondances des symboles et des modèles pour un fichier DbLib/SVNDbLib, les informations de chemin d’accès dans la base de données externe sont facultatives. Pour plus d’informations, consultez Spécification des emplacements des bibliothèques de symboles et de modèles.

Correspondance des modèles de simulation

Cette section présente chacun des champs de base de données pouvant être ajoutés à une table de base de données externe afin de définir le lien vers le modèle de simulation, qui sera créé lors du placement du composant.

  • Sim Model Name – le nom du modèle que vous souhaitez utiliser. Une fois le composant placé, cette information apparaîtra dans le champ Model Name de la boîte de dialogue Sim Model.

    Lors de la mise en correspondance des champs de base de données avec les paramètres de conception dans le fichier DBLib, le champ Sim Model Name est analogue aux champs Footprint Ref, Library Ref, etc.
  • Sim Description – une description du modèle lié. Cette information est facultative et n'affecte pas le fonctionnement du lien vers le modèle de simulation.
  • Sim File – un fichier de modèle particulier dans lequel rechercher le modèle de simulation spécifié dans le champ Sim Model Name. Ce champ peut être utilisé de plusieurs façons :

    • Vous pouvez saisir un chemin absolu vers un fichier de modèle (par exemple, C:\DbLibs\Switching Diodes\Libraries\JAS33.mdl). Le modèle spécifié dans le champ Sim Model Name sera recherché dans ce fichier et utilisé s'il est trouvé.
    • Vous pouvez saisir un chemin relatif (par rapport au fichier DbLib) vers un fichier de modèle (par exemple, Libraries\JAS33.mdl). Le modèle spécifié dans le champ Sim Model Name sera recherché dans ce fichier et utilisé s'il est trouvé.
    • Vous pouvez saisir uniquement le nom du fichier de modèle (par exemple, JAS33.mdl)). Les chemins de recherche définis dans le fichier DbLib seront utilisés pour localiser le premier fichier de modèle dont le nom correspond au nom spécifié et qui contient le modèle spécifié dans le champ Sim Model Name.
    • Vous pouvez laisser ce champ vide. Les chemins de recherche définis dans le fichier DbLib seront utilisés pour localiser le premier fichier de modèle contenant le modèle spécifié dans le champ Sim Model Name.
    Les chemins de recherche du fichier DbLib sont définis dans l'onglet Symbol & Model Search Paths de la boîte de dialogue Database Library Options (Tools » Options).
  • Sim Kind – la catégorie parente du modèle auquel le lien renvoie.
  • Sim SubKind – le type de modèle auquel le lien renvoie.
  • Sim Netlist – les informations du gabarit de netlist, conformément au type de modèle auquel le lien renvoie. Ce champ devient particulièrement important si vous spécifiez votre propre gabarit de netlist et avez défini le champ Sim SubKind sur Generic Editor, ce qui vous permet de mieux contrôler les informations insérées dans la netlist.

    Ce champ doit être renseigné et ne doit pas rester vide. Sinon, aucune entrée correspondant au modèle ne sera créée dans la netlist de simulation et le composant ne pourra pas être simulé lorsqu'il sera placé depuis la bibliothèque de base de données.
  • Sim Spice Prefix – le préfixe SPICE du type de modèle auquel vous établissez une liaison.
  • Sim Port Map – la correspondance entre les broches du composant du schéma et celles du modèle lié. Une fois le composant placé, ces informations apparaîtront dans la zone Pin Mapping de la boîte de dialogue Sim Model.

    Chaque paire de broches doit être saisie au format suivant :

    (SchematicPinNumber:ModelPinNumber),

    chaque paire de correspondance étant séparée par une virgule.

    Par exemple, pour un modèle de simulation de diode dans lequel la broche 1 du schéma (anode) doit correspondre à la broche 1 du modèle (anode), et la broche 3 du schéma (cathode) à la broche 2 du modèle (cathode), la saisie dans le champ de la base de données serait la suivante :

    (1:1),(3:2)

  • Sim Excluded Parts – créez ce champ dans la base de données si vous souhaitez exclure de la simulation certaines parties d’un composant multipartie. Ces informations correspondent à l’option Exclude part from simulation dans la zone Pin Mapping de la boîte de dialogue Sim Model.

    Par défaut, toutes les parties d’un composant multipartie sont incluses dans la simulation ; vous devez donc uniquement indiquer, par leur numéro, les parties à exclure. Séparez les différentes parties de la liste d’exclusion par des virgules. Par exemple, si un composant comporte quatre parties et que vous ne souhaitez pas inclure les parties 2 et 4 dans les simulations, saisissez ce qui suit dans le champ de la base de données :

    2,4

  • Sim Parameters – créez ce champ dans la base de données si vous souhaitez attribuer des valeurs aux paramètres de simulation du modèle. Il s’agit de paramètres qui peuvent être définis au niveau du composant, contrairement aux paramètres plus avancés qui peuvent être inclus dans un fichier de modèle.

    Un paramètre doit être saisi au format suivant :

    ParameterName=Value,

    Les différents paramètres doivent être séparés par une barre verticale (|).

    Pour rappel, un paramètre de simulation au niveau du composant peut également être défini comme paramètre de composant : il apparaît alors dans la zone Parameters de la boîte de dialogue Component Properties associée et peut ensuite être affiché sur la feuille de schéma. Par défaut, un paramètre saisi dans le champ Sim Parameters sera automatiquement ajouté comme paramètre de composant. Si vous ne souhaitez pas qu’un paramètre de simulation soit ajouté comme paramètre de composant, faites simplement précéder son nom d’un point d’exclamation (par exemple, !Initial Voltage=100mV).

    Prenons un modèle de diode comportant les quatre paramètres suivants au niveau du composant :

    • Facteur de surface
    • Condition de démarrage
    • Tension initiale
    • Température.

    Supposons maintenant que vous ajoutiez dans la base de données des valeurs pour le facteur de surface (par exemple, 2) et la température (par exemple, 22 °C). De plus, aucun de ces deux paramètres ne doit être ajouté comme paramètre de composant. La saisie dans le champ Sim Parameters serait la suivante :

    !Area Factor=2|!Temperature=22

Une fois le composant placé depuis la bibliothèque de base de données, vous pouvez vérifier que les informations définies pour la liaison de simulation correspondent bien à vos attentes. Lorsque le composant placé est sélectionné dans l’espace de conception, sélectionnez l’entrée du modèle de simulation dans la zone Parameters du panneau Properties, puis cliquez sur le bouton  pour accéder à la boîte de dialogue Sim Model, dans laquelle vous pouvez vérifier que :

  • Le fichier de modèle a bien été localisé. Lorsqu’il est trouvé, l’onglet Model File de la boîte de dialogue affiche le contenu du fichier.
  • Les autres informations de simulation provenant de la base de données ont bien été ajoutées à la boîte de dialogue.

Les valeurs stockées dans les champs de la base de données seront utilisées lors de l’exécution d’une simulation pour le composant placé depuis la bibliothèque de base de données. Notez toutefois que si vous accédez à la boîte de dialogue Sim Model du modèle de simulation d’un composant placé depuis une bibliothèque de base de données et cliquez sur OK, les champs Sim Netlist et Sim Spice Prefix seront automatiquement définis pour ce composant en fonction du texte du modèle choisi.

Paramètres

Tous les autres noms de champs de la base de données seront automatiquement associés à des paramètres de conception portant les mêmes noms. Par exemple, si un champ de la base de données est nommé Tolerance, un paramètre de conception nommé Tolerance lui sera associé. Vous pouvez modifier le nom d’un paramètre de conception en cliquant dans sa cellule et en saisissant directement le nouveau nom. Ce sont ces noms de paramètres de conception qui apparaîtront dans la zone Parameters de la boîte de dialogue des propriétés associée au composant, une fois celui-ci placé sur une feuille de schéma.

Un grand nombre de champs de données peuvent être associés à un composant dans la base de données, sans que vous souhaitiez, ni même ayez besoin, de tous les ajouter au composant en tant que paramètres de conception lors de son placement sur une feuille de schéma. Une grande partie de ces informations peut n’être nécessaire que lors de la génération d’une nomenclature. La boîte de dialogue Report Manager vous permet d’ajouter des informations de paramètres à une nomenclature directement depuis une base de données liée, ce qui réduit la quantité d’informations « transportées » avec les documents sources du schéma. Pour plus d’informations, consultez la section Préparation d’une nomenclature dans Report Manager.

Pour les champs que vous ne souhaitez explicitement pas mapper depuis la base de données, définissez l’entrée Design Parameter sur [None]. Les champs de base de données non mappés sont signalés dans l’onglet par une icône en forme de croix rouge (Cross icon, indicating that a database field is not mapped to a component parameter). Les champs de base de données mappés sont signalés par une icône en forme de coche verte (Tick icon, indicating that a database field is mapped to a component parameter).

Configurez le mappage des paramètres selon vos besoins. Définissez la valeur sur [None] pour empêcher le mappage d’un paramètre de la base de données vers le composant placé. Les paramètres non mappés peuvent être inclus directement dans la nomenclature, si nécessaire.Configurez le mappage des paramètres selon vos besoins. Définissez la valeur sur [None] pour empêcher le mappage d’un paramètre de la base de données vers le composant placé. Les paramètres non mappés peuvent être inclus directement dans la nomenclature, si nécessaire.

Pour remapper rapidement un champ non mappé, cliquez dans la ligne correspondante et utilisez le raccourci clavier Ctrl+D. Notez que, pour les mappages de modèles, vous devrez effectuer une sélection manuelle dans la liste déroulante Design Parameter associée.

Options de mise à jour des paramètres

Les autres colonnes de l’onglet Field Mappings vous permettent de spécifier les actions à effectuer sur les paramètres lors du premier placement d’un composant depuis la bibliothèque de base de données, ou lors de la mise à jour d’un composant déjà placé à l’aide de la commande Tools » Update Parameters From Database.

Les quatre colonnes sont les suivantes :

  • Update Values - une cellule de cette colonne permet de déterminer l’action à effectuer si le paramètre existe à la fois sur une feuille de schéma et dans la base de données, mais que leurs valeurs diffèrent. Vous pouvez choisir de mettre à jour le paramètre du composant placé avec la valeur enregistrée dans la base de données (Update), ou de ne pas le mettre à jour (Do not update). Cette option est prise en compte lors de l’utilisation de la commande Update Parameters From Database, après le placement du composant.
  • Add To Design - une cellule de cette colonne permet de déterminer l’action à effectuer si le paramètre est présent dans la base de données, mais n’existe pas pour le composant placé. Vous pouvez choisir d’ajouter le paramètre (Add), de ne pas l’ajouter (Do not add), ou de l’ajouter uniquement si une valeur lui est attribuée dans la base de données (Add only if not blank in database). Cette option est prise en compte aussi bien lors du placement initial du composant depuis la bibliothèque de base de données que lors de l’utilisation de la commande Update Parameters From Database, après le placement du composant.
  • Visible On Add - une case à cocher de cette colonne permet de déterminer si un paramètre nouvellement ajouté, à la suite du placement initial ou d’une mise à jour après placement, est visible pour le composant sur la feuille de schéma (case cochée) ou non (case décochée).
  • Remove From Design - une cellule de cette colonne permet de déterminer l’action à effectuer si le paramètre existe pour le composant placé, mais qu’il est absent de la base de données ou qu’il y figure sans valeur. Vous pouvez choisir de ne pas supprimer le paramètre (Do not remove), ou de le supprimer uniquement si aucune valeur ne lui est attribuée dans la base de données (Remove only if blank in database). Cette option est prise en compte lors de l’utilisation de la commande Mettre à jour les paramètres depuis la base de données, après le placement du composant.

Initialement, les champs Update Values, Add To Design et Remove From Design de chaque champ de base de données mappé sont définis sur l’entrée Default, et l’option Visible On Add est désactivée, comme illustré dans l’image suivante.

Options initiales (par défaut) de mise à jour des paramètres.Options initiales (par défaut) de mise à jour des paramètres.

L’image met en évidence quatre points importants concernant les options de mise à jour :

  1. Les champs de base de données non mappés ne disposent d’aucune option de mise à jour associée.
  2. Les mappages basés sur des attributs et des modèles (entrées entre crochets dans la colonne Design Parameter) ne disposent d’aucune option de mise à jour associée, car il ne s’agit pas de paramètres de conception.
  3. Le champ clé (par exemple Part Number dans l’image) ne dispose d’aucune option de mise à jour associée. Ce champ sert uniquement à établir la correspondance entre les paramètres.
  4. Le réglage Default indique qu’une option de mise à jour doit suivre sa définition par défaut correspondante, spécifiée dans l’onglet Default Actions de la boîte de dialogue Database Library Options (Tools » Options depuis les menus principaux ou Options depuis le menu contextuel de l’onglet Table Browser). Cette boîte de dialogue est également accessible en cliquant sur le bouton Options dans la zone Field Settings de la vue du document.

Définissez les options de mise à jour des paramètres par défaut de manière centralisée pour une bibliothèque DbLib. Survolez l’image pour voir l’équivalent pour une bibliothèque SVNDbLib.Définissez les options de mise à jour des paramètres par défaut de manière centralisée pour une bibliothèque DbLib. Survolez l’image pour voir l’équivalent pour une bibliothèque SVNDbLib.

Le quatrième point présente l’avantage de vous permettre de spécifier les options de mise à jour de manière centralisée, puis de faire référence à cet emplacement lors de la définition des options de mise à jour de chaque champ mappé. C’est pourquoi l’entrée Default est automatiquement renseignée dans les champs de mise à jour concernés lors du mappage d’un champ de base de données vers un paramètre de conception.

Si vous souhaitez remplacer le réglage par défaut d’une option de mise à jour, cliquez dans le champ de mise à jour concerné, dans l’onglet Field Mappings, puis cliquez de nouveau pour accéder à une liste déroulante proposant les choix de mise à jour applicables.

Les options de mise à jour des paramètres peuvent être remplacées manuellement, si nécessaire.Les options de mise à jour des paramètres peuvent être remplacées manuellement, si nécessaire.

Vous disposez ainsi d’un contrôle total sur la manière dont les paramètres de la conception sont mis à jour. Vous pouvez définir tous les champs sur Default et prendre les décisions de mise à jour nécessaires dans la boîte de dialogue Database Library Options, configurer chaque champ de mise à jour individuellement ou combiner les deux approches : le choix vous appartient entièrement. Pour les composants placés, la mise à jour s’effectue au moyen d’une boîte de dialogue Engineering Change Order. Si, à ce stade, vous préférez ne pas effectuer certaines mises à jour, vous pouvez choisir de ne pas inclure les modifications correspondantes : vous gardez ainsi le dernier mot sur les paramètres de conception à mettre à jour.

Spécification des emplacements des bibliothèques de symboles et de modèles

Lorsque vous placez un composant depuis une bibliothèque de base de données, son symbole, spécifié par le mappage [Library Ref], est extrait de la bibliothèque de schémas indiquée (*.SchLib). De même, les modèles référencés dans la base de données (empreinte, PCB3D, simulation) sont stockés dans les fichiers sous-jacents de bibliothèque PCB (*.PcbLib), de bibliothèque PCB3D (*.PCB3DLib) et de modèles de simulation (*.mdl, *.ckt). Les chemins d’accès à ces fichiers peuvent être spécifiés explicitement dans la base de données en :

  • Saisissant un chemin absolu vers le fichier.
  • Saisissant un chemin relatif vers le fichier.

Si vous avez défini des champs dans votre base de données pour les informations de chemin d’accès, ces champs doivent être mappés vers les paramètres de conception appropriés : [Library Path], [Footprint Path], [PCB3D Path], [Sim File], etc. (reportez-vous à la section Mappage des modèles et des paramètres).

La saisie de chemins d’accès, même relatifs, dans une table de base de données peut s’avérer quelque peu contraignante. Si vous déplacez une bibliothèque ou un fichier de modèle, vous devez mettre à jour la table de base de données en conséquence. Pour plus de souplesse, vous pouvez spécifier les informations de recherche des bibliothèques directement dans le fichier DbLib/SVNDbLib. Cela vous permet de spécifier le nom de la bibliothèque source ou du fichier de modèle dans la base de données, ou de ne pas le définir du tout.

Using Search Paths with a large number of symbol/model files - bien que les chemins de recherche offrent davantage de flexibilité et de simplicité pour configurer la localisation des symboles et des modèles, cette approche n’est pas recommandée lorsqu’un grand nombre de fichiers de symboles ou de modèles sont présents dans l’emplacement de recherche. Selon la convention de nommage des fichiers utilisée, les chemins de recherche peuvent nécessiter de parcourir chaque fichier de bibliothèque ou de modèle présent dans le chemin chaque fois qu’un symbole ou un modèle est requis, par exemple lors de la consultation des composants ou du transfert de la conception du schéma vers le PCB.

Pour une bibliothèque de base de données

Pour une DbLib, les chemins de recherche des bibliothèques sont définis dans l’onglet Symbol and Model Search Paths de la boîte de dialogue Database Library Options (Tools » Options). Cette boîte de dialogue est également accessible en cliquant sur le bouton Options dans la zone Field Settings de la vue du document.

Définition des chemins de recherche des bibliothèques de symboles et de modèles.Définition des chemins de recherche des bibliothèques de symboles et de modèles.

Pour ajouter un chemin à la liste :

  1. Saisissez le chemin directement dans le champ situé sous la zone Library Search Paths, ou cliquez sur le bouton Browse for a folder button pour accéder à la boîte de dialogue Browse for Folder, dans laquelle vous pouvez localiser le répertoire contenant les fichiers de bibliothèque ou de modèle requis.
  2. Vous pouvez ajouter un chemin absolu ou un chemin relatif (par rapport à l’emplacement du fichier DbLib). Utilisez l’option Add/Update As Relative Path pour choisir le type de chemin.
  3. Après avoir spécifié le chemin requis, ajoutez-le à la liste des chemins de recherche en cliquant sur le bouton Add .
  4. Continuez à ajouter d’autres chemins de recherche selon vos besoins.
En cas de saisie directe, si vous indiquez un chemin incorrect (par exemple, vers un dossier qui n’existe pas), l’entrée peut tout de même être ajoutée, mais elle apparaîtra grisée dans la liste pour indiquer qu’il s’agit d’un chemin de recherche non valide. Si vous constatez que vous avez saisi un chemin par erreur, vous pouvez le sélectionner dans la liste et cliquer sur le bouton Remove , ou modifier sa définition et cliquer sur le bouton Update .

Les chemins de recherche des bibliothèques déterminent où trouver les fichiers de bibliothèque et de modèle lors du placement à partir de la bibliothèque de base de données et lors de la recherche d’un modèle après le placement. Le modèle utilisé dépend de la configuration de vos chemins de recherche des bibliothèques et de l’ajout éventuel d’informations spécifiques sur les bibliothèques dans votre base de données. La recherche s’effectue dans l’ordre suivant :

  1. Si un chemin absolu figure dans le champ de chemin mappé pour le symbole ou le modèle, utiliser ce fichier de bibliothèque ou de modèle et en extraire le symbole ou le modèle spécifié dans le champ de référence correspondant.
  2. Si un chemin relatif figure dans le champ de chemin mappé pour le symbole ou le modèle, utiliser ce fichier de bibliothèque ou de modèle et en extraire le symbole ou le modèle spécifié dans le champ de référence correspondant.
  3. Si seul un nom de fichier de bibliothèque ou de modèle figure dans le champ de chemin mappé pour le symbole ou le modèle, utiliser les chemins de recherche pour localiser le premier fichier de bibliothèque ou de modèle qui correspond au nom spécifié et qui contient le symbole ou le modèle spécifié dans le champ de référence correspondant.
  4. Si aucune information sur le fichier de bibliothèque ou de modèle ne figure dans la base de données, utiliser les chemins de recherche pour localiser le premier fichier de bibliothèque ou de modèle contenant le symbole ou le modèle spécifié dans le champ de référence correspondant.

Pour une bibliothèque de base de données SVN

Pour une SVNDbLib, les répertoires de base du dépôt Subversion dans lesquels résident les symboles et les modèles d’empreinte sont spécifiés dans l’onglet SVN Repository de la boîte de dialogue Database Library Options (Tools » Options). Cette boîte de dialogue est également accessible en cliquant sur le bouton Options dans la zone Field Settings de la vue du document.

Définition des répertoires de base du dépôt pour les symboles et les empreintes.Définition des répertoires de base du dépôt pour les symboles et les empreintes.

Utilisez les champs disponibles dans la zone Models Location pour spécifier le répertoire de base des symboles et des empreintes. Cliquez sur le bouton Click the ellipsis button to select the repository folder for the symbols and footprints à droite d’un champ pour accéder à la boîte de dialogue Browse for directory, qui permet de parcourir le dépôt lié. Utilisez cette boîte de dialogue pour sélectionner le dossier requis.

Recherche du répertoire approprié dans le dépôt SVN lié.Recherche du répertoire approprié dans le dépôt SVN lié.

Il est important de souligner que les symboles et les empreintes doivent résider dans les répertoires de base du dépôt spécifiés. Ils peuvent bien sûr se trouver dans des sous-dossiers de ces répertoires, et les chemins spécifiés pour les symboles et les empreintes peuvent pointer vers le même répertoire du dépôt.

Les emplacements des modèles déterminent où trouver les fichiers de bibliothèque et de modèle lors du placement à partir de la bibliothèque de base de données sous contrôle de version et lors de la recherche d’un modèle après le placement. Le symbole schématique et les modèles d’empreinte utilisés dépendent de la configuration de ces emplacements et de l’ajout éventuel d’informations spécifiques sur les bibliothèques dans votre base de données. La recherche s’effectue dans l’ordre suivant :

  1. Si un chemin absolu figure dans le champ de chemin mappé pour le symbole ou le modèle d’empreinte (par exemple, http://MyServer/svn/MyCompany/ParentDirectory/SchematicSymbols/Capacitor_NonPolarized.SchLib), utiliser ce fichier de bibliothèque et en extraire le symbole ou l’empreinte spécifié dans le champ de référence correspondant.
  2. Si un chemin relatif (par rapport à la racine du dépôt) figure dans le champ de chemin mappé pour le symbole ou le modèle d’empreinte (par exemple, /ParentDirectory/SchematicSymbols/Capacitor_NonPolarized.SchLib), utiliser ce fichier de bibliothèque et en extraire le symbole ou l’empreinte spécifié dans le champ de référence correspondant. L’URL du dépôt, spécifiée dans la zone Repository Server Connection de la boîte de dialogue, sera ajoutée devant le chemin saisi pour obtenir l’adresse absolue.
  3. Si seul un nom de fichier de bibliothèque figure dans le champ de chemin mappé pour le symbole ou le modèle d’empreinte (par exemple, Capacitor_NonPolarized.SchLib), utiliser les emplacements des modèles spécifiés dans le dépôt pour localiser le premier fichier de bibliothèque qui correspond au nom spécifié et qui contient le symbole ou le modèle d’empreinte spécifié dans le champ de référence correspondant.
Lors de la recherche d’un symbole ou d’un modèle correspondant, les chemins des dossiers du répertoire de base des symboles ou des empreintes sont mis à plat, puis triés et parcourus par ordre alphabétique. Si l’assistant de fractionnement de bibliothèque est utilisé, il existera toujours une bibliothèque correspondante portant le nom du symbole ou de l’empreinte.
  1. Si aucune information sur le fichier de bibliothèque ne figure dans la base de données, utiliser les emplacements des modèles spécifiés pour localiser le premier fichier de bibliothèque contenant le symbole ou le modèle d’empreinte spécifié dans le champ de référence correspondant.
Lors de la localisation du symbole ou de l’empreinte, le système recherche d’abord la première bibliothèque portant le même nom que le symbole ou l’empreinte. Par exemple, si le nom logique du symbole dans la base de données (spécifié par le mappage [Library Ref]) est Capacitor_NonPolarized, le système recherche le premier fichier nommé Capacitor_NonPolarized.SchLib, puis recherche le symbole dans ce fichier. Si le symbole ou l’empreinte ne peut pas être trouvé de cette manière, le système recherche une correspondance dans toutes les bibliothèques.
AI-LocalizedLocalisé par IA
Si vous trouvez un problème, sélectionnez le texte/l’image et appuyez surCtrl + Enterpour nous envoyer vos commentaires.
Nav
Contents
Disponibilité des fonctionnalités

Les fonctionnalités auxquelles vous avez accès dépendent de la solution Altium dont vous disposez – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, ou Altium Designer (avec un abonnement actif).

Si vous ne voyez pas une fonctionnalité documentée dans votre logiciel actuel, contactez le service commercial d’Altium pour en savoir plus.

Documentation héritée

La documentation d’Altium Designer n’est plus versionnée. Si vous devez accéder à la documentation des versions antérieures d’Altium Designer, consultez la section Documentation héritée de la page Other Installers.

Contents