Liaison de composants existants à une base de données d’entreprise à l’aide d’un fichier de lien de base de données

En un coup d'œil

Reliez les composants existants de vos schémas ou bibliothèques à la base de données centrale de composants de votre entreprise à l’aide d’un fichier Database Link dans Altium Designer. Cet article explique en quoi DbLink diffère des approches reposant sur des bibliothèques de base de données, comment créer un fichier DbLink et comment configurer une connexion à une base de données externe. Il aborde également la synchronisation des paramètres de composants associés avec les enregistrements de la base de données, afin que ces informations puissent être incluses dans votre nomenclature. Poursuivez votre lecture pour franchir une nouvelle étape vers la synchronisation de vos données de composants.

- Comprenez dans quels cas utiliser DbLink plutôt que DbLib ou SVNDbLib.
- Découvrez comment créer un fichier Database Link et configurer les connexions à Access, Excel et aux autres bases de données prises en charge.
- Identifiez les exigences de liaison par champs clés et les points à prendre en compte concernant les moteurs de base de données 64 bits.
Approfondissez avec l'IA :

Pour de nombreuses organisations, il est courant de devoir relier les composants de CAO électronique à la base de données centrale de composants de l’entreprise. Altium Designer répond à ce besoin en permettant de lier des composants existants aux enregistrements de la base de données de l’entreprise, grâce à la création et à l’utilisation d’un fichier Database Link. Le fichier Database Link est ajouté à votre projet de conception ou à votre package de bibliothèques, ce qui vous permet de lier, respectivement, des composants déjà placés sur des feuilles de schéma ou, plus généralement, des composants définis dans une bibliothèque de schémas source.

Une fois la liaison établie, vous pouvez transférer les informations paramétriques mises en correspondance depuis les enregistrements de la base de données vers les paramètres de conception des composants à l’aide de la commande Tools » Update Parameters From Database. Ces informations peuvent ensuite être incluses dans la nomenclature finale (BOM), en vue de l’approvisionnement en composants.

The Move from 32-bit to 64-bit Software

Avec la sortie d’Altium Designer version 18.0 et d’Altium NEXUS version 1.0, le logiciel de conception est passé à une architecture 64 bits. Pour lier des composants de conception à une base de données dans une version 64 bits du logiciel Altium, le moteur de base de données sous-jacent doit également être en 64 bits. Si vous utilisez Microsoft Access ou Excel pour gérer les données sous-jacentes et qu’une version 32 bits d’Office est installée, il est possible d’installer également le moteur de base de données Microsoft Access 64 bits. Pour savoir précisément comment procéder, suivez les instructions de la page Utilisation de bibliothèques de bases de données avec les versions 32 bits et 64 bits d’Altium Designer sur un même ordinateur.

Si vous tentez de vous connecter via le moteur de base de données Microsoft Access 32 bits, le message d’erreur suivant s’affiche.

Error dialog, reporting that a 64-bit version of the Microsoft Access Database engine is required for database linking

Notez que certaines erreurs de connexion, telles qu’une syntaxe incorrecte dans les informations Provider du Connection String, peuvent entraîner l’appel du mauvais moteur de base de données et l’affichage de la boîte de dialogue d’erreur ci-dessus, même après l’installation du moteur de base de données 64 bits.

Quelques mots sur les options de liaison…

Altium Designer propose trois méthodes pour lier un composant à une base de données : à l’aide d’un fichier Database Link (*.DbLink), d’un fichier Database Library (*.DbLib) ou d’un fichier SVN Database Library (*.SVNDbLib). L’approche DbLink constitue un moyen efficace de lier les composants utilisés dans votre conception (ou vos bibliothèques) aux données saisies dans la base de données et de les maintenir synchronisés avec celles-ci. L’approche DbLib/SVNDbLib reprend cette efficacité de liaison éprouvée et y ajoute la possibilité de placer un composant directement depuis la base de données. Le composant est ainsi créé dynamiquement à partir des informations stockées dans l’enregistrement correspondant de la base de données.

Avant d’explorer plus en détail la fonctionnalité de liaison à une base de données, il convient d’examiner les différences entre ces deux approches du point de vue de leur utilisation.

Liaison à l’aide d’un fichier Database Link

  • Avec cette méthode, le fichier Database Link définit la liaison entre le composant de schéma et un enregistrement correspondant dans une base de données. La correspondance avec l’enregistrement est établie au moyen de champs clés : il peut s’agir d’un seul champ clé (par exemple, une référence de pièce) ou de plusieurs champs clés (en définissant une clause Where).
  • Avec cette méthode de liaison, les informations relatives aux modèles et aux paramètres du composant doivent être prédéfinies dans le composant de bibliothèque Altium Designer. La définition du composant de bibliothèque doit également inclure les informations nécessaires sur les champs clés. Une fois ces éléments définis, ajoutez un fichier Database Link à votre package de bibliothèques ou à votre projet de conception. Vous pouvez alors synchroniser les informations du composant (paramètres) avec le contenu des champs de la base de données.
  • Bien que chaque composant physique défini par un enregistrement de la base de données ne doive pas nécessairement correspondre à un composant de bibliothèque Altium Designer unique — plusieurs composants de la base de données peuvent partager le même symbole —, cette méthode de liaison est généralement utilisée selon le principe « un enregistrement de base de données pour un composant Altium Designer ». Le composant Altium Designer unique peut être une instance placée sur une feuille de schéma ou un composant unique dans une bibliothèque de composants.
  • Avec une liaison à une base de données de type DbLink, vous incluez le fichier Database Link dans le package de bibliothèques ou le projet de conception.

La liaison entre des composants de bibliothèque et une base de données externe n’est possible que si la bibliothèque fait partie d’un package de bibliothèque intégrée (*.LibPkg). Choisissez la commande File » New » Library » Integrated Library pour créer un nouveau package de bibliothèques, puis ajoutez-y les bibliothèques de schémas sources.

► En savoir plus sur les bibliothèques intégrées.

Liaison à l’aide d’un fichier Database Library

Related page: Bibliothèques de bases de données

  • Avec cette méthode, le fichier Database Library définit lui aussi la liaison entre le composant de schéma et un enregistrement correspondant dans une base de données. Là encore, la correspondance avec l’enregistrement est établie au moyen de champs clés : il peut s’agir d’un seul champ clé (par exemple, une référence de pièce) ou de plusieurs champs clés (en définissant une clause Where).
  • Avec cette méthode de liaison, les informations relatives au symbole, aux modèles et aux paramètres d’un composant sont stockées dans la définition de l’enregistrement de ce composant dans la base de données externe. Le composant de schéma référencé (stocké dans une bibliothèque de composants sous-jacente (*.SchLib)) ne contient que le symbole ; aucun modèle ne lui est lié et aucun paramètre de conception n’y est défini.
  • Lors du placement du composant, ses informations de paramètres et de modèles sont créées à la volée, à partir des champs correspondants de l’enregistrement associé dans la base de données et conformément à la mise en correspondance définie. Un ou plusieurs de ces paramètres servent ensuite à maintenir une liaison avec la base de données, selon les critères de correspondance définis, afin de permettre une synchronisation ultérieure après le placement.
  • Grâce à la création dynamique des composants au moment du placement, cette méthode de liaison se prête particulièrement bien à une utilisation selon le principe « plusieurs enregistrements de base de données pour un composant Altium Designer ». Par exemple, votre base de données peut inclure la série de résistances E96, chaque enregistrement faisant référence au même symbole de résistance de schéma et à la même empreinte de PCB.
  • Contrairement à la liaison à une base de données de type DbLink, pour laquelle le fichier DbLink doit être inclus dans le package de bibliothèques (ou le projet de conception), le fichier DbLib/SvnDbLib n’a pas besoin d’être ajouté au projet. La bibliothèque de base de données (DbLib) figure parmi les bibliothèques disponibles, accessibles depuis le panneau Components. Pour rappel, les bibliothèques disponibles peuvent comprendre les bibliothèques du projet, les bibliothèques installées ou les bibliothèques trouvées dans les chemins de recherche spécifiés.
  • En règle générale, vous configurez les fichiers DbLib/SVNDbLib en les organisant par bibliothèque. Vous pouvez, par exemple, en avoir un pour toutes les résistances répertoriées dans la base de données de votre entreprise, un autre pour les condensateurs, etc.
Une bibliothèque de base de données SVN (*.SVNDbLib) est une extension du modèle de liaison DbLib. Ce type de fichier s’utilise exactement comme un fichier DbLib, mais le symbole de schéma et les modèles associés sont stockés dans des bibliothèques placées sous gestion de versions (Subversion).

Création du fichier Database Link

Comme indiqué précédemment, le fichier Database Link constitue la base de la fonctionnalité de liaison à une base de données. Ce fichier est créé et géré à l’aide de l’éditeur DatabaseLink d’Altium Designer. Cet éditeur devient disponible lorsque le document actif dans la fenêtre principale de conception est un fichier *.DbLink.

Exemple de fichier DbLink ouvert dans l’éditeur DatabaseLink.Exemple de fichier DbLink ouvert dans l’éditeur DatabaseLink.

Pour créer un fichier de ce type :

  • Choisissez la commande File » New » Library » Database Link File dans les menus principaux.
  • Faites un clic droit sur l’entrée du projet souhaité dans le panneau Projects, puis choisissez la commande Add New to Project » Database Link File dans le menu contextuel.

Lorsqu’ils sont ajoutés à un projet, les fichiers Database Link apparaissent dans le panneau Projects , sous le sous-dossier Settings\Database Link Files.

The DbLink file appears in the Settings folder in the Projects panel

Si un document par défaut a été spécifié sur la page System - New Document Defaults de la boîte de dialogue Preferences, le fichier Database Link sera créé en utilisant ce document par défaut comme modèle. Un document par défaut différent peut être défini pour un fichier Database Link créé dans le cadre d’un projet PCB, d’un package de bibliothèque intégrée ou en tant que document libre.

Connexion à une base de données externe

Les données des tables et de correspondance n’apparaissent dans la fenêtre d’affichage principale de l’éditeur qu’une fois le fichier Database Link actif connecté à la base de données externe souhaitée. La connexion est définie à l’aide des commandes disponibles dans la zone Source of Connection.

Définition de la connexion à la base de données externe.Définition de la connexion à la base de données externe.

Il est possible de se connecter à toute base de données prenant en charge OLE DB. Les options proposées dans cette zone utilisent chacune une chaîne de connexion OLE DB pour se connecter à la base de données cible. Certaines bases de données ne prennent pas en charge OLE DB. Toutefois, la quasi-totalité des systèmes de gestion de bases de données utilisés aujourd’hui sont accessibles via l’interface Open Database Connectivity (ODBC). La fonctionnalité de liaison à une base de données utilise le fournisseur ODBC de Microsoft, qui permet à un objet ADO (ActiveX Data Object) de se connecter à n’importe quelle source de données ODBC. Il est donc possible de se connecter à toute base de données ODBC. Le fournisseur OLE DB de la base de données ODBC est spécifié dans la chaîne de connexion.

La connexion peut également être définie dans l’onglet Connection de la boîte de dialogue Database Connection, accessible depuis le menu principal Tools ou en cliquant sur le bouton Advanced (à droite du bouton Connect , au bas de la zone).

Connexion rapide aux bases de données Access et Excel

L’option Select Database Type permet de créer rapidement une chaîne de connexion lorsque la base de données cible a été créée avec Microsoft Access ou Microsoft Excel. Avec cette option, sélectionnez le type de base de données, puis recherchez et sélectionnez le fichier de base de données souhaité. La chaîne de connexion correspondante est automatiquement générée et saisie dans le champ de l’option Use Connection String.

Vous pouvez spécifier le chemin complet ou choisir de stocker le chemin relatif au fichier Database Link.

Création d’une chaîne de connexion

Si la base de données de votre entreprise ne repose ni sur Access ni sur Excel et que vous souhaitez créer explicitement la chaîne de connexion, activez l’option Use Connection String, puis cliquez sur le bouton Build associé, à droite. La boîte de dialogue Data Link Properties s’affiche.

Création d’une chaîne de connexion à l’aide de la boîte de dialogue Data Link Properties. Création d’une chaîne de connexion à l’aide de la boîte de dialogue Data Link Properties.

La boîte de dialogue s’ouvre sur l’onglet Connection . Le fournisseur OLE DB Microsoft Office <Version> Access Database Engine OLE DB Provider est défini par défaut dans l’onglet Provider de la boîte de dialogue. Il s’agit du fournisseur par défaut pour les nouveaux fichiers Database Link ; il est également utilisé pour se connecter aux fichiers de base de données Access (*.mdb). Modifiez le fournisseur si nécessaire.

Dans l’onglet Connection , saisissez le nom (chemin compris) de la base de données à laquelle vous souhaitez vous connecter.

Si votre base de données nécessite des informations d’authentification, saisissez-les, ainsi que tout autre paramètre avancé disponible dans l’onglet Advanced de la boîte de dialogue. L’onglet All présente un récapitulatif des options de liaison définies, ainsi que des options étendues relatives au fournisseur OLE DB choisi. Vous pouvez également modifier les options dans cet onglet, selon vos besoins.

Une fois les options de liaison définies, vous pouvez vérifier que la connexion fonctionne en cliquant sur le bouton Test Connection (dans l’onglet Connection ). Si la connexion réussit, une boîte de dialogue de confirmation s’affiche.

La boîte de dialogue Data Link Properties étant une boîte de dialogue Microsoft, appuyer sur F1 ou utiliser le bouton Help permet d’accéder au fichier Microsoft Data Link Help. Ce fichier ne fait pas partie de la documentation d’Altium.

Spécification d’un fichier Data Link

Si la source de données à laquelle vous souhaitez vous connecter est décrite dans un fichier Microsoft Data Link (*.udl), activez la troisième option de connexion, Use Data Link File, puis cliquez sur le bouton Browse associé pour localiser le fichier souhaité. Un fichier Data Link sert essentiellement à stocker une chaîne de connexion.

Établissement de la connexion

Une fois la connexion à la base de données externe définie, le texte du bouton Connect s’affiche en gras, indiquant que vous pouvez établir la connexion. Si les informations de connexion sont correctes, les informations sur les tables et les correspondances de la base de données cible sont chargées dans le fichier Database Link. Le texte du bouton Connect devient Connected et le bouton est grisé.

Si les informations de connexion présentent un problème, par exemple une chaîne de connexion mal construite ou un chemin erroné, la connexion échoue et un message vous en avertit. Vérifiez vos paramètres de connexion et cliquez de nouveau sur le bouton Connect .

Exemples de signalement d’un échec de connexion.Exemples de signalement d’un échec de connexion.

Si vous modifiez les paramètres de connexion alors que vous êtes connecté à une base de données, la connexion active est perdue et le texte du bouton Connect devient Reconnect. Cliquez dessus pour rétablir la connexion.

Une fois la première connexion établie et le fichier Database Link enregistré, la connexion s’effectue automatiquement à chaque ouverture du fichier, à condition que l’emplacement et le nom du fichier de la base de données cible restent inchangés.

Liste des tables de la base de données

Une fois la connexion à la base de données externe établie, les données des tables et de correspondance sont chargées. La partie gauche du document DbLink répertorie toutes les tables présentes dans la base de données connectée.

Tables présentes dans la base de données connectée.Tables présentes dans la base de données connectée.

L’option Enable située à côté de chaque table permet de déterminer si cette table doit être utilisée lors de la mise à jour des paramètres à partir de la base de données.

Lorsque vous cliquez sur une table dans la liste, son icône passe de Database table icon, inactive table à Database table icon, active table pour indiquer qu’il s’agit de la table active. La table, avec toutes ses données, apparaît dans l’onglet Table Browser du document. Il s’agit d’une copie non modifiable de la table, qui vous permet de consulter rapidement son contenu sans avoir à ouvrir la base de données externe elle-même.

Consultation d’une table source dans la base de données connectée.Consultation d’une table source dans la base de données connectée.

Pour agrandir la zone de consultation des tables (comme dans l’illustration ci-dessus), réduisez toute la zone située au-dessus (paramètres de connexion et des champs) en cliquant sur la commande Collapse icon - collapse a region of the DbLink document, en haut à droite de la vue du document DbLink. Cliquez sur Expand icon - expand a region of the DbLink document pour la développer à nouveau.

Définition des critères de correspondance

Pour mettre à jour les paramètres des composants à partir des informations stockées dans les champs de la base de données externe, chaque composant de la conception doit d’abord être associé à une ligne d’une table de la base de données. La zone Field Settings du document permet de définir les critères de correspondance : soit une recherche simple à clé unique, soit une correspondance plus avancée à l’aide d’une clause Where.

Les critères de correspondance sont définis séparément pour chaque table.

Définition des critères de correspondance.Définition des critères de correspondance.

Recherche à clé unique

Si l’option Single key lookup est activée (par défaut), les champs Database field et Part parameter deviennent disponibles. Le champ Database field répertorie tous les noms de champs (en-têtes de colonnes) disponibles dans la table active de la base de données. Le champ Part parameter répertorie tous les paramètres présents dans l’ensemble des composants de la conception, qu’il s’agisse de paramètres système ou de paramètres définis par l’utilisateur.

Utilisez ces champs pour définir la correspondance entre un champ de la table et un paramètre d’un composant (commun à tous les composants). En général, le champ de correspondance est, dans les deux cas, un élément qui identifie de manière unique chaque composant dans la base de données externe, comme une référence fabricant. Le champ de recherche choisi se distingue dans l’onglet Field Mappings du document par l’entrée Design Parameter grisée.

Correspondance à clé unique par référence fabricantCorrespondance à clé unique par référence fabricant

Lorsque vous utilisez la fonctionnalité Tools » Update Parameters From Database, les informations sont lues dans le paramètre clé choisi des composants placés sur le schéma, puis recherchées dans le champ (clé) choisi de la base de données, dans toutes les tables activées. Lorsqu’une correspondance est trouvée, les informations des autres cellules de cet enregistrement de la table parente peuvent alors être transférées vers les paramètres correspondants du composant du schéma.

Correspondance avancée : la clause WHERE

Si l’option Single key lookup fonctionne bien lorsqu’une référence ou un identifiant de composant unique permet d’établir la correspondance, elle est moins efficace lorsque celle-ci repose sur un paramètre non unique, comme la capacité ou la résistance. Dans ce cas, il convient d’utiliser la clause WHERE, plus avancée, qui permet de définir une correspondance à plusieurs clés afin de lier le composant du schéma à la ligne requise dans la table concernée de la base de données.

Dans sa forme la plus simple, la clause WHERE (écrite en syntaxe SQL) reflète les entrées choisies pour définir la recherche à clé unique. Par exemple, si Database field a été défini sur Part Number et que le paramètre unique Part parameter (présent pour tous les composants de la conception) a été défini sur Part Number, la clause WHERE serait la suivante :

[Part Number] = '{Part Number}'

Les crochets entourant le champ de la base de données (colonne de la table) sont des caractères de délimitation, tels que définis dans l’onglet Advanced de la boîte de dialogue Database Connection. Pour accéder à cette boîte de dialogue, cliquez sur le bouton Advanced dans la zone Source of Connection du document ou passez par le menu principal Tools .

L’onglet Advanced  de la boîte de dialogue Database Connection propose des options SQL supplémentaires pour délimiter les noms de tables ou utiliser des noms de schémas de tables dans une clause WHERE construite. L’onglet Advanced de la boîte de dialogue Database Connection propose des options SQL supplémentaires pour délimiter les noms de tables ou utiliser des noms de schémas de tables dans une clause WHERE construite.

Lorsque vous délimitez les noms de tables, les caractères de délimitation à utiliser dépendent de la base de données employée. Par exemple, les crochets [ ] ne sont utilisables que dans les bases de données Microsoft telles qu’Access, Excel via ADO ou MSSQL (versions récentes). MYSQL utilise le caractère ' comme délimiteur. Dans toute base de données, il n’est réellement nécessaire de délimiter les noms de colonnes que s’ils contiennent des espaces ou s’il s’agit de mots réservés (pour cette base de données). Consultez la documentation de votre logiciel de base de données pour connaître les caractères de délimitation utilisés, le cas échéant.

Les accolades indiquent que l’entrée référencée est un paramètre de conception. Les apostrophes indiquent que le paramètre de conception doit être traité comme une chaîne de caractères, et non comme un nombre (sans apostrophes). La correspondance des types est très importante, car SQL est sensible aux types. Le paramètre de conception doit être du même type que la colonne de la base de données.

La syntaxe SQL standard permet ensuite d’étendre la clause WHERE pour établir une correspondance à partir de plusieurs entrées Database field/Part parameter, par exemple :

[Capacitance] = '{Capacitance}' AND [Tolerance] = {Tolerance} AND [Manufacturer] = '{Manufacturer}'

Dans ce cas, un seul enregistrement de la table concernée de la base de données serait lié à l’aide de trois paramètres de conception différents. Notez que l’entrée du paramètre de conception Tolerance n’est pas entourée d’apostrophes. Cela signifie que le type de colonne dans la table associée de la base de données est Number et non String.

La syntaxe SQL standard vous permet de rendre la clause WHERE aussi simple ou aussi complexe que vous le souhaitez. Voici un exemple de clause plus complexe :

[Tolerance] BETWEEN {Min Tolerance} AND {Max Tolerance} AND [Price] <= {Max Price} AND [Manufacturer] IN ('{Preferred Manufacturer 1}', '{Preferred Manufacturer 2}')

Dans ce cas, la table serait interrogée pour rechercher des composants correspondants selon trois champs de la base de données : Tolerance, Price et Manufacturer. La tolérance doit se situer dans la plage définie par les paramètres de conception Min Tolerance et Max Tolerance. Le prix doit être inférieur ou égal à celui spécifié dans le paramètre de conception Max Price, et le fabricant peut être l’un des deux candidats spécifiés par les paramètres de conception Preferred Manufacturer 1 et Preferred Manufacturer 2.

Création d’un paramètre de composant

Si vos composants Altium Designer ne possèdent aucun paramètre adapté à une utilisation comme Part parameter pour établir la correspondance dans le fichier DbLink, vous devrez en créer un. Vous pouvez ajouter rapidement ce paramètre « de base » à l’aide de la commande Tools » Parameter Manager ou du panneau Properties de l’éditeur concerné.

Ajout d’un paramètre à l’aide de la fonctionnalité de gestion des paramètres

Pour ajouter un nouveau paramètre à l’aide de la fonctionnalité de gestion des paramètres :

  1. Depuis un document schématique (ou un document de bibliothèque schématique), choisissez Tools » Parameter Manager dans les menus principaux. La boîte de dialogue Parameter Editor Options s’affiche. Pour ajouter le nouveau paramètre à tous les composants, assurez-vous que l’option Parts est activée dans la zone Include Parameters Owned By et que All Objects est défini comme critère dans la zone That Meet the Following Criteria.

Configuration des options de gestion des paramètres.Configuration des options de gestion des paramètres.

  1. Cliquez sur OK pour ouvrir la boîte de dialogue Parameter Table Editor, qui affiche tous les paramètres actuellement associés à tous les objets composants des documents schématiques sources du projet actif (ou aux composants schématiques de la bibliothèque schématique active). Cliquez sur le bouton Add Column et utilisez la boîte de dialogue Add Parameter qui s’affiche pour définir le nom du paramètre. Assurez-vous que l’option Add to all objects est activée afin que le nouveau paramètre soit ajouté à tous les composants.

Lors du premier passage, laissez Value du paramètre non renseigné : ajoutez simplement le paramètre à chaque composant. Vous pouvez ouvrir une seconde fois Parameter Table Editor pour définir la valeur de chaque paramètre. La boîte de dialogue prend en charge les raccourcis d’édition Windows standard, notamment : les touches fléchées pour passer d’une cellule à l’autre ; F2 pour modifier la valeur de la cellule active ; et le copier-coller de blocs depuis un éditeur de texte ou une feuille de calcul vers la cellule sélectionnée et le nombre requis de cellules situées en dessous dans la boîte de dialogue.

Exemple d’utilisation de la fonctionnalité de gestion des paramètres pour ajouter un nouveau paramètre à tous les composants, dans tous les schémas sources d’un projet de conception.Exemple d’utilisation de la fonctionnalité de gestion des paramètres pour ajouter un nouveau paramètre à tous les composants, dans tous les schémas sources d’un projet de conception.

  1. Une fois la nouvelle colonne ajoutée, cliquez sur le bouton Accept Changes (Create ECO). Utilisez la boîte de dialogue Engineering Change Order qui s’affiche pour Validate, puis Execute les modifications, afin d’ajouter le paramètre à chacun des composants concernés.

Application des modifications de paramètres (ajout du nouveau paramètre à tous les composants) au moyen d’un ordre de modification technique (ECO).Application des modifications de paramètres (ajout du nouveau paramètre à tous les composants) au moyen d’un ordre de modification technique (ECO).

Ajout d’un paramètre à l’aide du panneau Properties

Vous pouvez ajouter un nouveau paramètre à tous les composants sélectionnés à l’aide du panneau Properties. La procédure suivante décrit le cas où vous souhaitez ajouter le même paramètre à tous les composants du document de bibliothèque schématique actif, à l’aide des panneaux SCHLIB Filter et Properties.

La procédure est similaire pour ajouter un paramètre aux composants placés dans les documents schématiques sources. Dans ce cas, les panneaux SCH Filter et Properties de l’éditeur de schémas sont utilisés.
  1. Commencez par sélectionner tous les composants de la bibliothèque à l’aide du panneau SCH Filter et de la requête IsPart. Assurez-vous que l’option Whole Library est activée, sinon seul le composant actif de la bibliothèque sera pris en compte.

Configurez un filtre pour sélectionner tous les composants du document de bibliothèque schématique actif.Configurez un filtre pour sélectionner tous les composants du document de bibliothèque schématique actif.

  1. Dans le panneau Properties de l’éditeur de bibliothèque, vérifiez, à l’aide du texte situé en bas du panneau, que tous les composants de la bibliothèque sont actuellement sélectionnés. Si le panneau Properties n’est pas visible, cliquez sur le bouton  Panels button, click to display a menu of available panels en bas à droite de l’espace de travail pour l’afficher.

Vérifiez que tous les composants sont sélectionnés. Vérifiez que tous les composants sont sélectionnés.

  1. Ajoutez le paramètre requis à l’aide de l’onglet Parameters du panneau. Cliquez sur le bouton Add pour ajouter un nouveau paramètre par défaut, puis modifiez son nom selon vos besoins. Notez que le paramètre a déjà été ajouté à tous les composants sélectionnés : si vous cliquez à nouveau sur le bouton Add, un deuxième nouveau paramètre sera ajouté.

Ajoutez le nouveau paramètre requis à tous les composants sélectionnés. Ajoutez le nouveau paramètre requis à tous les composants sélectionnés.

Correspondance entre les champs de la base de données et les paramètres de conception

Les paramètres de conception des composants existants, qu’il s’agisse de composants placés sur les feuilles de schéma sources d’un projet de conception ou définis dans une bibliothèque de composants schématiques ajoutée à un paquet de bibliothèques, sont mis à jour à partir d’informations stockées dans une base de données externe de l’entreprise à l’aide de la commande Update Parameters From Database, accessible depuis le menu principal Tools lorsque le document schématique ou le document de bibliothèque schématique est actif.

Lorsqu’une correspondance est établie entre un composant de la conception et un enregistrement d’une table de la base de données liée, la suite des opérations est déterminée par les informations de correspondance et de mise à jour spécifiées dans le fichier Database Link. Ces réglages sont configurés dans l’onglet Field Mappings de la vue principale du document.

Les options de correspondance et de mise à jour sont spécifiées pour chaque table.

Spécifiez les options de correspondance et de mise à jour des paramètres dans l’onglet Field Mappings du document DbLink.Spécifiez les options de correspondance et de mise à jour des paramètres dans l’onglet Field Mappings du document DbLink.

Correspondance des paramètres

Les deux premières colonnes (en partant de la gauche) de l’onglet Field Mappings vous permettent de contrôler quelles informations de la base de données doivent être associées aux paramètres d’un composant.

La colonne Database Field Name répertorie tous les noms de champs (colonnes) de la table actuellement active de la base de données. La colonne Design Parameter vous permet de spécifier le paramètre de conception à associer au champ correspondant dans la base de données. La correspondance initiale est établie automatiquement lors de la connexion à la base de données : tous les champs de la base de données sont associés à des paramètres de conception portant les mêmes noms. Par exemple, si un champ de la base de données s’appelle Tolerance, un paramètre de conception nommé Tolerance lui sera associé.

Vous pouvez modifier l’entrée d’un paramètre de conception :

  • En cliquant dans sa cellule et en saisissant directement le nom d’un autre paramètre.
  • En utilisant la liste déroulante associée à la cellule pour choisir un paramètre de conception existant.

Un composant peut être associé à un grand nombre de champs de données dans la base de données, sans que vous souhaitiez, ni même ayez besoin, de tous les ajouter comme paramètres de conception au composant existant. Une grande partie de ces informations peut n’être nécessaire que lors de la génération d’une nomenclature. La boîte de dialogue Report Manager comprend une option permettant d’ajouter des informations de paramètres à une nomenclature directement depuis une base de données liée, ce qui réduit la quantité d’informations « embarquées » dans les documents schématiques sources. Pour plus d’informations, consultez la section Ajout d’informations de base de données directement à une nomenclature.

Pour les champs de la base de données que vous ne souhaitez explicitement pas associer, définissez l’entrée Design Parameter sur [None]. Les champs de base de données non associés sont signalés dans l’onglet par une icône en forme de croix rouge (Cross icon, indicating that a database field is not mapped to a component parameter). Les champs associés sont signalés par une icône en forme de coche verte (Tick icon, indicating that a database field is mapped to a component parameter).

Définissez les correspondances des paramètres selon vos besoins. Définissez les correspondances des paramètres selon vos besoins.

Pour rétablir rapidement la correspondance d’un champ non associé, cliquez dans la ligne de ce champ et utilisez le raccourci clavier Ctrl+D. Le nom du paramètre de conception sera identique à celui du Database Field Name correspondant.

Options de mise à jour des paramètres

Les autres colonnes de l’onglet Field Mappings vous permettent de spécifier les actions à effectuer sur les paramètres lors de la mise à jour d’un composant à l’aide de la commande Tools » Update Parameters From Database. Dans les descriptions suivantes, le terme Altium component désigne un composant placé sur une feuille de schéma ou un composant défini dans une bibliothèque de composants schématiques (faisant partie d’un paquet de bibliothèques).

Les quatre colonnes sont les suivantes :

  • Update Values - une cellule de cette colonne permet de déterminer l’action à effectuer si le paramètre existe pour le composant Altium et dans la base de données, mais que leurs valeurs diffèrent actuellement. Vous pouvez choisir de mettre à jour le paramètre du composant Altium avec la valeur stockée dans la base de données (Update) ou de ne pas le mettre à jour (Do not update).
  • Add To Design - une cellule de cette colonne permet de déterminer l’action à effectuer si le paramètre est présent dans la base de données, mais n’existe pas pour le composant Altium Designer. Vous pouvez choisir d’ajouter le paramètre (Add), de ne pas l’ajouter (Do not add) ou de l’ajouter uniquement si une valeur lui est attribuée dans la base de données (Add only if not blank in database).
  • Visible On Add - une case à cocher de cette colonne permet de déterminer si un paramètre nouvellement ajouté est visible pour le composant Altium (case cochée) ou non (case décochée).
  • Remove From Design - une cellule de cette colonne permet de déterminer l’action à effectuer si le paramètre existe pour le composant Altium Designer, mais qu’il est absent de la base de données ou qu’il y est présent sans valeur. Vous pouvez choisir de ne jamais supprimer le paramètre (Do not remove) ou de le supprimer uniquement si aucune valeur ne lui est attribuée dans la base de données (Remove only if blank in database).

Initialement, les champs Update Values, Add To Design et Remove From Design de chaque champ de base de données associé sont définis sur l’entrée Default, et l’option Visible On Add est désactivée, comme illustré dans l’image suivante.

Options initiales (par défaut) de mise à jour des paramètres.Options initiales (par défaut) de mise à jour des paramètres.

L’image met en évidence trois points importants concernant les options de mise à jour :

  1. Les champs de base de données non associés ne disposent d’aucune option de mise à jour.
  2. Le champ clé (par exemple, Part Number dans l’image) ne dispose d’aucune option de mise à jour. Ce champ sert uniquement à établir la correspondance des paramètres.
  3. Le réglage Default indique qu’une option de mise à jour suit la définition par défaut correspondante, telle qu’elle est spécifiée dans l’onglet Default Actions de la boîte de dialogue Database Link Options (Tools » Options). Cette boîte de dialogue est également accessible en cliquant sur le bouton Options dans la zone Field Settings de la vue du document.

Définissez les options de mise à jour des paramètres par défaut de manière centralisée.Définissez les options de mise à jour des paramètres par défaut de manière centralisée.

Le troisième point présente l’avantage de vous permettre de spécifier les options de mise à jour de manière centralisée, puis de faire référence à ces réglages lors de la définition des options de mise à jour de chaque champ associé. C’est pourquoi l’entrée Default est automatiquement chargée dans les champs de mise à jour concernés lorsqu’un champ de base de données est associé à un paramètre de conception.

Si vous souhaitez remplacer le réglage par défaut d’une option de mise à jour, cliquez dans le champ de mise à jour concerné, dans l’onglet Field Mappings, puis cliquez à nouveau pour accéder à une liste déroulante proposant les choix de mise à jour applicables.

Les options de mise à jour des paramètres peuvent être remplacées manuellement si nécessaire.Les options de mise à jour des paramètres peuvent être remplacées manuellement si nécessaire.

Vous gardez ainsi le contrôle total sur la manière dont les paramètres de la conception sont mis à jour. Vous pouvez définir tous les champs sur Default et prendre les décisions de mise à jour nécessaires dans la boîte de dialogue Database Link Options, configurer chaque champ de mise à jour individuellement ou combiner les deux approches : le choix vous appartient entièrement. La mise à jour s’effectue au moyen d’une boîte de dialogue Engineering Change Order. Si, à ce stade, vous préférez ne pas effectuer certaines mises à jour, vous pouvez choisir d’exclure les modifications concernées : vous avez ainsi le dernier mot sur les paramètres de conception à mettre à jour.

Garantir la synchronisation

Une fois les options de correspondance et de mise à jour définies selon vos besoins dans le fichier Database Link, et le fichier enregistré, vous pouvez transférer les informations de la base de données vers les paramètres correspondants des composants Altium Designer. N’oubliez pas que le paramètre choisi comme champ clé permet de maintenir le lien entre un composant Altium Designer et son enregistrement correspondant dans la base de données externe. Ainsi, toute modification ultérieure des informations de paramètres dans la base de données peut être facilement répercutée sur le composant Altium Designer, afin de synchroniser les deux. Les mises à jour s’effectuent à l’aide de la commande Update Parameters From Database, disponible dans le menu principal Tools de l’éditeur de schémas ou de bibliothèques de schémas.

Double synchronisation : DbLib/SVNDbLib et DBLink

Il se peut que vous disposiez d’un projet de conception existant dans lequel la majorité des composants placés sont liés à une base de données externe au moyen d’un fichier DbLink. Les modifications de conception peuvent nécessiter l’ajout de circuits dont les composants sont placés à l’aide de la fonctionnalité Bibliothèque de base de données. Le fichier DbLib/SVNDbLib associé peut tout à fait pointer vers une autre base de données externe.

Lors de l’utilisation de la commande Update Parameters From Database, tous les paramètres liés des composants placés sont interrogés, dans l’ensemble des bases de données liées et quelle que soit la méthode de liaison utilisée. Les différences détectées pour ces paramètres sont affichées dans la boîte de dialogue Select Parameter Changes.

Si le même champ de base de données a été utilisé pour établir les correspondances dans les fichiers DbLink et DbLib/SVNDbLib, une correspondance sera d’abord recherchée dans la base de données liée par le fichier DbLink, puis dans celle liée par le fichier DbLib/SVNDbLib. Si le composant est présent dans les deux bases de données, vous risquez d’établir une correspondance avec le mauvais enregistrement externe et d’effectuer la mise à jour à partir de celui-ci.

Ajouter des informations de base de données directement à une nomenclature

Related page: Configuration de la nomenclature dans le gestionnaire de rapports

Auparavant, les informations sources d’une nomenclature (BOM) provenaient des paramètres des composants placés dans la conception. Toutefois, cela peut conduire à associer au schéma de nombreuses informations utilisées uniquement pour la nomenclature. Si vos composants Altium Designer placés sont liés à une base de données externe au moyen d’un fichier DbLink, le générateur de nomenclature peut extraire toutes les autres informations des enregistrements qui n’ont pas été ajoutées aux composants en tant que paramètres de conception.

Les paramètres d’une base de données externe peuvent être inclus, quelle que soit la méthode utilisée pour établir le lien avec cette base de données : DbLink, DbLib ou SVNDbLib.

Lorsque vous configurez le rapport de nomenclature dans la boîte de dialogue Report Manager, cliquez sur le bouton Database Parameters (  Database Parameters source button, click to make linked database parameters available in the Report Manager ) dans l’onglet Columns de la boîte de dialogue pour les inclure comme source de la nomenclature, comme illustré ci-dessous. Cette option n’est disponible que si un ou plusieurs composants de votre conception sont liés à une base de données externe.

Dans la liste Columns, l’icône Database icon, indicates that this parameter comes from the database permet de distinguer un paramètre présent pour un ou plusieurs composants placés dans une base de données externe liée. Cliquez sur l’icône de visibilité pour qu’elle prenne la forme d’un œil ( Visibility icon ), afin d’inclure cette colonne (ce paramètre) dans votre nomenclature.

Incluez des informations supplémentaires sur les composants qui existent uniquement dans une base de données externe.Incluez des informations supplémentaires sur les composants qui existent uniquement dans une base de données externe.

Pour une conception comprenant des variantes, les paramètres utilisés pour interroger la base de données sont modifiés dans la boîte de dialogue Variant Management. Comme les valeurs de ces paramètres n’existent que dans la boîte de dialogue Variant Management, elles ne sont utilisées pour interroger la base de données et rechercher les enregistrements correspondants que lors de la configuration d’une nomenclature à générer. Pour cela, assurez-vous que la sous-option Include DB Parameters in Variations est activée dans l’onglet General des propriétés de Report Manager.

Altium Designer comprend également un puissant éditeur de nomenclature appelé ActiveBOM. ActiveBOM offre un ensemble complet de fonctionnalités de gestion des nomenclatures, notamment la possibilité d’ajouter des éléments supplémentaires à la nomenclature, ainsi qu’une intégration étroite avec la chaîne d’approvisionnement en composants.

► En savoir plus sur ActiveBOM

AI-LocalizedLocalisé par IA
Si vous trouvez un problème, sélectionnez le texte/l’image et appuyez surCtrl + Enterpour nous envoyer vos commentaires.
Nav
Contents
Disponibilité des fonctionnalités

Les fonctionnalités auxquelles vous avez accès dépendent de la solution Altium dont vous disposez – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, ou Altium Designer (avec un abonnement actif).

Si vous ne voyez pas une fonctionnalité documentée dans votre logiciel actuel, contactez le service commercial d’Altium pour en savoir plus.

Documentation héritée

La documentation d’Altium Designer n’est plus versionnée. Si vous devez accéder à la documentation des versions antérieures d’Altium Designer, consultez la section Documentation héritée de la page Other Installers.

Contents