Modèles de composants
En un coup d'œil
- Découvrez comment configurer les dossiers de l’espace de travail et les éléments de modèle de composant avec des schémas de nommage, de révision et de cycle de vie adaptés.
- Comprenez comment les modèles régissent les paramètres des composants, notamment les valeurs obligatoires et les valeurs par défaut en lecture seule.
- Découvrez comment modifier directement les modèles et les enregistrer dans votre espace de travail sous forme de nouvelles révisions.
Pour simplifier la création de vos composants, Altium Designer, associé à votre espace de travail connecté, permet de créer et de définir des Component Templates (éléments de modèle de composant) dans cet espace de travail. De même qu'un modèle de schéma peut servir à prédéfinir des informations sur les feuilles de schéma qui y font référence, un modèle de composant est référencé par un composant de bibliothèque de l'espace de travail et fournit des paramètres prédéfinis pour la définition de ce composant.
Les modèles de composants ont notamment été développés en accordant une attention particulière aux informations paramétriques. Ils permettent de définir, à un seul endroit, un ensemble de paramètres qui seront mis à la disposition du composant faisant référence au modèle. Le modèle vous permet de choisir les paramètres à rendre visibles, de renseigner des valeurs par défaut et même de désigner certains paramètres comme obligatoires. Des contrôles de validation sont effectués lors de l'enregistrement du composant afin de garantir sa conformité.
Ces modèles de composants sont créés directement dans l'espace de travail. Une fois un modèle de composant créé (et ses données enregistrées dans une révision), il peut être réutilisé pour créer un ou plusieurs composants.
Type de dossier
Lors de la création du dossier destiné à stocker les modèles de composants, vous pouvez spécifier son type. Cela n'a aucune incidence sur le contenu du dossier : la publication d'un modèle de composant génère toujours un élément de modèle de composant correspondant. Il s'agit simplement d'un repère visuel indiquant ce que contient un dossier, ce qui peut être utile lorsque vous parcourez un espace de travail à la recherche d'un contenu particulier. Pour indiquer qu'un dossier est destiné à contenir des modèles de composants, définissez son Folder Type sur Component Templates lors de la configuration des propriétés du dossier dans la boîte de dialogue Edit Folder.

La spécification du type de dossier, c'est-à-dire de son usage prévu, fournit une indication visuelle de son contenu lorsque vous parcourez l'espace de travail.
Schéma de nommage des éléments
Un autre aspect important du dossier parent est le Item Naming Scheme qui lui est appliqué. Celui-ci définit le format de l'identifiant unique de chaque élément créé dans ce dossier. Plusieurs exemples de schémas par défaut sont disponibles. Ils utilisent le code abrégé correspondant au type de dossier (CTC – Collection de modèles de composants) ou au type de contenu (CMPT – Modèle de composant) :
-
$CONTENT_TYPE_CODE-001-{0000}– par exemple,CMPT-001-0001. -
$CONTENT_TYPE_CODE-001-{A00}– par exemple,CMPT-001-A01. -
$FOLDER_TYPE_CODE-001-{0000}– par exemple,CTC-001-0001. -
$FOLDER_TYPE_CODE-001-{A000}– par exemple,CTC-001-A001.
Si vous utilisez un schéma de nommage par défaut, le logiciel attribue automatiquement le prochain identifiant unique disponible selon ce schéma, après avoir analysé l'ensemble de l'espace de travail et les identifiants du contenu existant. Cela peut représenter un gain de temps considérable lors de la création manuelle de modèles de composants.
Vous pouvez également définir un schéma personnalisé pour un dossier en le saisissant simplement dans le champ, en veillant à placer la partie variable entre accolades (par exemple, CMP-TMP-{0000}).

Le schéma de nommage des éléments du dossier parent est appliqué à l'identifiant unique de chaque élément créé dans ce dossier.
Type de contenu
Lors de la création d'un élément de modèle de composant cible destiné à stocker votre modèle de composant, assurez-vous que son Content Type est défini sur Component Template dans la boîte de dialogue Create New Item. Si vous créez l'élément dans un dossier de type Component Templates, ce type de contenu sera disponible dans le menu contextuel accessible par clic droit lors de la création de l'élément.

Création d'un modèle de composant dans un dossier Component Templates : le Content Type approprié est disponible dans le menu contextuel.
Définition du cycle de vie et nommage des révisions des éléments
Related pages: Définition des schémas de nommage des révisions pour un espace de travail, Définition des cycles de vie pour un espace de travail
Lors de la définition d'un modèle de composant, veillez à spécifier le type de gestion du cycle de vie à utiliser pour ce modèle, ainsi que le schéma de nommage de ses révisions.
Les types de contenu autorisés à utiliser une définition de cycle de vie ou un schéma de nommage des révisions donné peuvent être définis et activés globalement dans la boîte de dialogue Content Types lors de la définition de chaque schéma. Les schémas attribués par défaut à un modèle de composant sont respectivement : Generic Lifecycle et 1-Level Revision Scheme.
Spécifiez les schémas requis dans la boîte de dialogue Create New Item, à l'aide des champs Lifecycle Definition et Revision Naming Scheme, respectivement.

Sélection des schémas de définition du cycle de vie et de nommage des révisions pour un modèle de composant créé manuellement.
Enregistrement d'un modèle de composant
Related page: Création et modification de contenu
Jusqu'à présent, nous avons abordé la prise en charge des modèles de composants dans l'espace de travail sous l'angle des types de dossiers et de contenu associés. L'enregistrement d'un modèle de composant défini dans une révision d'un tel élément de modèle de composant peut être effectué de manière simplifiée.
Un modèle de composant peut être modifié et enregistré dans la révision initiale d'un élément de modèle de composant nouvellement créé, grâce à la prise en charge de la modification directe par l'espace de travail. La modification directe vous libère des contraintes liées à la gestion séparée de données sources sous contrôle de version. Vous pouvez simplement modifier un type de contenu pris en charge à l'aide d'un éditeur temporaire dans lequel la dernière version des données sources est chargée directement depuis l'espace de travail. Une fois la modification terminée, l'entité est enregistrée (ou réenregistrée) dans une révision ultérieure planifiée de son élément parent, puis l'éditeur temporaire se ferme. Aucun fichier n'est stocké sur votre disque dur, vous n'avez pas à vous demander si vous travaillez avec les bonnes données sources ou leur dernière version, et vous n'avez pas à maintenir un logiciel de contrôle de version distinct. L'espace de travail gère l'ensemble de ces opérations avec un haut niveau d'intégrité, tout en accélérant considérablement les modifications de vos données.
Lorsque vous créez un élément de modèle de composant, vous avez la possibilité de modifier et d’enregistrer un modèle de composant dans la révision initiale de cet élément, après sa création. Pour ce faire, activez l’option Open for editing after creation, au bas de la boîte de dialogue Create New Item (cette option est activée par défaut). L’élément est créé et l’éditeur temporaire de modèles de composants s’ouvre, avec un document .CMPT comme document actif dans la fenêtre de conception principale. Ce document est nommé d’après l’élément et sa révision, au format suivant : <Item><Revision>.CMPT (par exemple, CMPT-0001-1.CMPT).
Utilisez le document pour définir le modèle de composant selon vos besoins. Pour plus d’informations sur cette opération, consultez Définition du modèle.
Trois commandes utiles lors de la modification directe sont facilement accessibles depuis Quick Access Bar (en haut à gauche de la fenêtre principale de l’application) ou depuis la barre d’outils Component Template Standard :
-
– Save Active Document. Utilisez ce bouton pour enregistrer localement les modifications apportées au document. Cela vous permet d’enregistrer les modifications en cours si vous souhaitez revenir ultérieurement pour apporter d’autres modifications avant l’enregistrement final dans l’espace de travail.
-
/
– Save to Server. Utilisez ce bouton pour enregistrer le modèle de composant défini dans l’espace de travail, en le stockant dans la révision initiale (planifiée) de l’élément de modèle de composant cible. La boîte de dialogue Edit Revision s’affiche. Vous pouvez y modifier le nom et la description, et ajouter des notes de publication selon vos besoins. Le document et l’éditeur se ferment après l’enregistrement. Le document contenant le modèle de composant source, *.CMPT, est stocké dans la révision de l’élément. -
/
– Discard Local Changes. Utilisez ce bouton pour annuler la modification et abandonner toutes les modifications apportées. Le document et l’éditeur se ferment, et rien n’est publié dans l’élément de modèle de composant cible.
Ces commandes sont également accessibles sous forme d’options de menu — Save (raccourci : Ctrl+S), Save to Server (raccourci : Ctrl+Alt+S) et Discard Local Changes — depuis le menu principal File et le menu contextuel de l’entrée du modèle de composant dans le panneau Projects.
Les données enregistrées dans l’espace de travail se composent du modèle de composant source, défini dans le fichier de modèle de composant (<Item><Revision>.CMPT).
Héritage d’un modèle de composant
Vous pouvez utiliser un modèle de composant provenant du type de composant racine si aucun modèle de composant n’est associé au sous-type. Lors de la création d’une hiérarchie de types de composants, les sous-types de composants héritent du modèle de composant attribué au type de composant racine ou parent.
L’éditeur CMPT (modèle de composant)
Définition du modèle
L’éditeur de modèles de composants est essentiellement divisé en deux zones principales, illustrées dans l’image suivante et décrites ci-après.
- Upper Region – permet de définir les options au niveau du composant (cycle de vie, nommage et options de dossier) pour un composant faisant référence au modèle.
- Lower Region – permet de définir les paramètres à utiliser pour un composant faisant référence au modèle.
Spécification des options du composant
La moitié supérieure de l’éditeur est consacrée à la définition des valeurs par défaut des propriétés de composant suivantes :
-
Lifecycle Definition – choisissez la définition de cycle de vie à appliquer à un composant créé à l’aide du modèle. La liste déroulante répertorie toutes les définitions configurées pour l’espace de travail et dont l’utilisation est autorisée pour un composant.
-
Revision Naming – choisissez le schéma de nommage des révisions à appliquer à un composant créé à l’aide du modèle. La liste déroulante répertorie tous les schémas configurés pour l’espace de travail et dont l’utilisation est autorisée pour un composant.
-
Component Naming – utilisez ce champ pour définir un schéma de dénomination des éléments par défaut pour un composant créé à partir du modèle, afin de garantir un identifiant unique au composant obtenu dans l’espace de travail. La valeur saisie ici servira de modèle pour nommer automatiquement le composant (dans le champ Id associé (lorsque l’éditeur de composants est utilisé en mode Single Component Editing), ou dans le champ Item ID (lorsque l’éditeur de composants est utilisé en mode Batch Component Editing)). Le logiciel attribuera automatiquement le prochain identifiant unique disponible selon ce schéma, après avoir analysé l’ensemble de l’espace de travail et les identifiants du contenu existant. Un schéma de dénomination des éléments par défaut –
CMP-{00000}– est fourni, mais vous pouvez bien entendu créer votre propre schéma en le saisissant dans le champ, en veillant à placer la partie variable entre accolades (par exemple,CMP-001-{0000}). -
Default Folder – permet de spécifier un dossier par défaut dans l’espace de travail cible où stocker un composant enregistré. Pour ce faire, cliquez sur le bouton Choose pour accéder à la boîte de dialogue Choose Folder (une variante du panneau Explorer), dans laquelle vous pouvez parcourir l’espace de travail et choisir un dossier existant, ou en créer un à la volée.
Lorsque le modèle est référencé, les valeurs spécifiées dans cette zone servent à préremplir les champs correspondants dans l’éditeur de composants (lorsqu’ils sont disponibles) :
- Single Component Editing mode – les champs Id et Folder, dans la zone Advanced Settings de la section Component.
- Batch Component Editing mode – dans l’onglet Document Options de la boîte de dialogue Document Options et, par conséquent, les champs Item ID et FolderPath, dans la zone Component de la section des définitions de composants.

Lorsque le modèle est référencé, les valeurs servent à préremplir les champs correspondants lors de la modification d’un composant dans l’éditeur de composants en mode Single Component Editing (à gauche) et en mode Batch Component Editing (à droite).
Définition des paramètres
La moitié inférieure de l’éditeur est consacrée à la définition et à la gestion des paramètres qui seront mis à la disposition d’un composant référençant le modèle.
Paramètres système par défaut
Divers paramètres système sont inclus par défaut lors de la création d’un modèle de composant, comme illustré dans l’image suivante et détaillé ci-après.
-
ComponentType– ce paramètre permet de spécifier le type de composant. Il facilite les recherches ciblées grâce à la puissante fonction de recherche de l’espace de travail, qui permet non seulement d’effectuer des recherches par type de composant, mais aussi de rechercher plus intelligemment grâce à la prise en charge des paramètres de composants tenant compte des unités. Lorsque vous parcourez les composants de votre espace de travail à l’aide du panneau Components, le regroupement Categories des composants est établi à partir des paramètresComponentTypeassociés à chaque composant. Cliquez sur le champ Default Value associé, puis sur le bouton
pour accéder à la boîte de dialogue Choose component type. Utilisez-la pour sélectionner le type de composant souhaité, puis cliquez sur OK : le type choisi sera inséré comme valeur du paramètre ComponentType dans la grille principale des paramètres.

Exemple de modèle de composant, avec le paramètre système ComponentType défini surDiodes. -
SCHLIBetPCBLIB– ces deux paramètres permettent de spécifier respectivement les modèles de symbole et d’empreinte par défaut. Cliquez sur le champ Default Value associé à chaque paramètre, puis sur le bouton
pour accéder à une boîte de dialogue permettant de choisir le modèle souhaité.

Spécifiez des modèles de symbole et d’empreinte dans votre modèle de composant. -
NameetDescription– ces deux paramètres permettent de définir respectivement le nom et la description du composant. Saisissez les chaînes de caractères souhaitées dans le champ Default Value associé à chaque paramètre.
Spécifiez les paramètresNameetDescriptiondans votre modèle de composant.
Ajout d’un nouveau paramètre utilisateur
Pour ajouter un nouveau paramètre utilisateur à la liste, cliquez sur le bouton
(ou utilisez la commande Add du menu contextuel accessible par clic droit) : le paramètre est ajouté à la fin de la liste actuelle.

Exemple d’ajout d’un nouveau paramètre utilisateur au modèle.
Chaque paramètre est présenté dans la grille avec les informations suivantes :
-
Name – utilisez ce champ pour nommer le paramètre, généralement avec un nom explicite indiquant sa fonction. Lors de leur ajout, les paramètres reçoivent des noms par défaut (
Parameter,Parameter 1,Parameter 2, etc.). -
Type – le type de paramètre. Cette entrée est initialement définie sur
Textpar défaut, mais plusieurs types de données prenant en charge les unités sont disponibles, ainsi que le typePCBLIB, qui facilite la définition de plusieurs empreintes, et le typeHarnessWiring, qui facilite la définition d’un composant de câblage de faisceau. Les types de paramètres définis par les dictionnaires disponibles sont également pris en charge – en savoir plus. -
Visible – activez cette option (activée par défaut pour tout nouveau paramètre) pour que l’option Show correspondante du paramètre soit activée lors de la modification d’un ou de plusieurs composants dans l’éditeur de composants (configuré en mode Batch Component Editing). Cela contrôle l’affichage de la colonne correspondante pour ce paramètre dans la partie inférieure de l’éditeur de composants, où sont définis les composants eux-mêmes. Cette propriété n’a aucun effet lors de la définition d’un composant en mode Single Component Editing de l’éditeur.
-
Read Only – activez cette option pour rendre le paramètre accessible en lecture seule. Lors de la modification d’un composant faisant référence au modèle, la valeur du paramètre ne pourra pas être modifiée.
-
Required – activez cette option pour rendre le paramètre obligatoire. Lors de la modification d’un composant faisant référence au modèle, une valeur doit être définie pour ce paramètre, sans quoi l’enregistrement du composant sera impossible. Dans l’éditeur de composants, lorsqu’aucune valeur n’a été saisie, un tel paramètre se distingue par une cellule de valeur entourée d’une bordure rouge (en mode Batch Component Editing) ou contenant l’icône
(en mode Single Component Editing).
-
Default Value – utilisez ce champ pour saisir une valeur par défaut pour le paramètre.
-
Description – ajoutez une description du paramètre, par exemple une brève note sur sa fonction. Si une description est définie pour un paramètre dans le modèle, la colonne Description sera affichée en conséquence dans la zone Parameters de l’éditeur de composants dans son Single Component Editing.
La liste des paramètres prend également en charge les opérations simples de copier-coller, ce qui vous permet de dupliquer un ou plusieurs paramètres utilisateur existants. Les paramètres collés seront ajoutés en bas de la liste.
Ordre et dimensionnement des colonnes
L’ordre des colonnes est personnalisable. Cliquez sur l’en-tête d’une colonne et faites-le glisser horizontalement jusqu’à la nouvelle position souhaitée. Les positions valides sont indiquées par des flèches verticales.
Tri
Les paramètres peuvent être triés selon une colonne spécifique en cliquant sur son en-tête. Cliquez une fois pour effectuer un tri croissant (selon le contenu de cette colonne). Cliquez à nouveau pour effectuer un tri décroissant.
Vous pouvez effectuer un tri sur plusieurs colonnes. Lorsque les paramètres sont déjà triés selon une colonne spécifique, Shift+Click sur une autre colonne pour effectuer un tri secondaire selon le contenu de cette dernière.
Types de données des paramètres de composants prenant en charge les unités
L’éditeur de modèles de composants permet de définir des types de données explicites pour les paramètres de composants définis dans un modèle de composant (*.CMPT). De plus, ces types de données prennent en charge les unités ainsi que plusieurs préfixes d’unités courants. Vous pouvez ainsi saisir la valeur d’un paramètre dans différents formats, tels que 2.2k, 2k2, 4M ou 2.5GHz, l’espace de travail étant doté de l’intelligence nécessaire pour reconnaître la valeur numérique correspondant à ces saisies.
Cette fonctionnalité des modèles de composants facilite les recherches ciblées à l’aide de la fonction de recherche avancée du serveur. Celle-ci permet non seulement de rechercher par type de composant, mais aussi d’effectuer des recherches plus intelligentes par plage de valeurs. Grâce aux paramètres de composants prenant en charge les unités, vous pouvez rapidement définir une recherche, par exemple pour trouver tous les condensateurs dont la capacité est comprise entre 47uF et 220uF.
Consultez les sections dépliables suivantes pour en savoir plus sur les paramètres prenant en charge les unités.
Unités prises en charge
Les types de données suivants, prenant en charge les unités, sont disponibles lors de la définition d’un paramètre utilisateur dans un modèle de composant :
-
Entier
-
Décimal
-
Ampère (A)
-
Surface (mm2)
-
Bit
-
Candela (cd)
-
Celsius (C)
-
Décibel (dB)
-
Farad (F)
-
Gramme (g)
-
Henry (H)
-
Hertz (Hz)
-
Joule (J)
-
Lumen (lm)
-
Mètre (m)
-
Millimètre (mm)
-
Ohm
-
Pourcentage (%)
-
Pascal (Pa)
-
Bar (bar)
-
Livres par pouce carré (psi)
-
Tours par minute (tr/min)
-
Seconde (s)
-
Siemens (S)
-
Coefficient de température (ppm/°C)
-
Tesla (T)
-
Volt (V)
-
Watts (W)
Préfixes d’unités pris en charge
Le tableau suivant répertorie les préfixes d’unités pris en charge lors de la saisie d’une valeur pour un type de paramètre prenant en compte les unités.
| Préfixe | Terme | Valeur (notation scientifique) | Valeur (notation normale) |
|---|---|---|---|
| T | Téra | 1 x 1012 | 1 000 000 000 000 |
| G | Giga | 1 x 109 | 1 000 000 000 |
| M | Méga | 1 x 106 | 1 000 000 |
| k | kilo | 1 x 103 | 1 000 |
| m | milli | 1 x 10-3 | 1 / 1 000 |
| u | micro | 1 x 10-6 | 1 / 1 000 000 |
| n | nano | 1 x 10-9 | 1 / 1 000 000 000 |
| p | pico | 1 x 10-12 | 1 / 1 000 000 000 000 |
| f | femto | 1 x 10-15 | 1 / 1 000 000 000 000 000 |
Ajout d’un paramètre de composant prenant en compte les unités
Lors de l’ajout d’un paramètre au modèle (cliquez sur
dans la zone Parameters), utilisez le champ Type associé pour choisir le type de données prenant en compte les unités souhaité dans la liste déroulante.

Sélection d’un type de données prenant en compte les unités pris en charge pour un paramètre utilisateur dans un modèle de composant. Dans cet exemple, Ampere est le type de paramètre.
Lors de la saisie d’une valeur pour un paramètre de composant utilisant un type de données prenant en compte les unités — que ce soit comme Default Value dans un modèle de composant ou comme valeur requise dans une définition de composant — les points suivants sont à prendre en compte :
-
Vous pouvez saisir la valeur dans différents formats :
-
Valeur numérique uniquement (p. ex.
10). Notez que si le type de données possède une unité, celle-ci sera appliquée automatiquement. Pour les types possédant une unité, celle-ci figure entre parenthèses après leur nom. -
Valeur numérique en notation scientifique (p. ex.
1e10,1E6). -
Valeur numérique et unités (p. ex.
10F). -
Valeur numérique avec préfixe (p. ex.
10k). L’unité appropriée sera automatiquement ajoutée (le cas échéant). -
Valeur numérique avec préfixe et unités (p. ex.
10kF). -
Valeur numérique avec préfixe au format usuel en ingénierie (p. ex. pour une résistance :
2k2,2K2,10r2,10R2). La valeur sera automatiquement normalisée en conséquence (p. ex.2K2deviendra2.2k).
-
Valeur numérique uniquement (p. ex.
-
Vous pouvez saisir le préfixe et/ou les unités avec ou sans espace après la valeur numérique (p. ex.
10uFou10 uF). L’espace sera automatiquement supprimé.
Validation des données
Lorsqu’un type de données prenant en compte les unités est utilisé pour un paramètre de composant, la valeur saisie est validée par rapport au type de données spécifié. Cela garantit l’utilisation de l’unité de mesure appropriée pour ce type de données. Par exemple, un paramètre de type Celsius ne peut pas avoir une valeur de 10V !
La validation est effectuée chaque fois qu’un paramètre de composant avec un type de données prenant en compte les unités est utilisé et qu’une valeur est fournie pour ce paramètre :
- Lors de la définition d’une valeur par défaut pour un paramètre dans un modèle de composant.
- Lors de la définition d’une valeur pour un paramètre dans le cadre de la définition d’un composant dans l’éditeur de composants.
- Lors de la configuration d’une recherche par plage, basée sur la valeur du paramètre, dans le cadre d’un schéma de recherche enregistré.

Exemple de validation des données dans l’éditeur de modèles de composants.
Types de données de paramètres définis par dictionnaire
Les dictionnaires sont des types de paramètres personnalisés comportant plusieurs valeurs définies. Ils sont gérés par les administrateurs de l’espace de travail sur la page Settings – Vault – Dictionaries de l’interface Web de l’espace de travail, accessible depuis l’éditeur de modèles de composants en choisissant l’option Add New Dictionary dans la liste déroulante Type ou en cliquant sur la commande Manage Dictionaries en haut à droite de la zone Parameters.

Accédez à la page de gestion des dictionnaires dans l’interface Web de l’espace de travail depuis l’éditeur de modèles de composants.
Les dictionnaires définis sont disponibles en tant que types de paramètres dans la liste déroulante Type.

Sélectionnez un type de paramètre défini par dictionnaire dans la liste déroulante Type.
Les valeurs définies pour le type sélectionné défini par un dictionnaire sont disponibles dans la liste déroulante Default Value. Sélectionnez la valeur souhaitée à utiliser comme valeur par défaut du paramètre, ou sélectionnez <None>.

Sélectionnez une valeur par défaut parmi celles définies pour le type sélectionné défini par un dictionnaire.
Définition de plusieurs empreintes
L’éditeur de modèles de composants permet également de définir plusieurs empreintes de PCB dans un modèle de composant. Vous pouvez spécifier autant de liens vers des modèles d’empreinte que vous le souhaitez. Cette fonctionnalité sera particulièrement utile pour créer des composants faisant référence à trois empreintes, afin de satisfaire aux exigences IPC relatives aux différents niveaux de densité : L (quantité de cuivre minimale), M (quantité de cuivre maximale) et N (quantité de cuivre nominale ou médiane).
Pour ajouter une définition de modèle d’empreinte supplémentaire au modèle, cliquez sur
pour ajouter un nouveau paramètre, puis choisissez l’entrée PCBLIB dans le menu déroulant associé au champ Type.

Transformez un paramètre nouvellement ajouté en définition de modèle d’empreinte en réglant son Type sur PCBLIB.

Exemple de composant défini dans l’éditeur de composants (mode Single Component Editing) à l’aide d’un modèle de composant référencé. Le modèle comporte trois modèles d’empreinte, qui sont intégrés à la définition du composant. Notez que l’entrée de modèle PCBLIB du modèle de composant est utilisée comme modèle d’empreinte par défaut (identifié par une icône en haut à gauche) lors de la définition du composant. Survolez l’image pour voir le même composant défini dans l’éditeur de composants en mode Batch Component Editing. Dans ce cas, l’empreinte par défaut est désignée par PCBLIB (default).
Importation et exportation de modèles de composants
Un fichier de modèle de composant existant (*.CMPT) ou un fichier de bibliothèque de composants (*.CMPLIB) peut être importé dans l’éditeur de modèles de composants, et le modèle de composant en cours de modification peut être exporté vers un fichier de modèle de composant (*.CMPT). Utilisez les commandes File » Import » Component Template, File » Import » Component Library et File » Export du menu principal de l’éditeur de composants pour sélectionner l’action souhaitée, puis la boîte de dialogue Windows standard qui s’ouvre pour accéder à l’emplacement souhaité et sélectionner un fichier à importer ou définir le nom du fichier à exporter.
Réutilisation d’un modèle de composant
L’utilisation d’une révision d’un modèle de composant — ou, plus précisément, son référencement depuis la révision du composant en cours de modification — peut s’effectuer des manières suivantes.
Lors de la création d’un nouveau composant
Lorsque vous créez un nouveau composant à l’aide de la commande File » New » Component des menus principaux, vous pouvez choisir le modèle dans la boîte de dialogue Create new component.

Association rapide d’un modèle de composant à partir de la liste de tous les modèles disponibles, lors de la création d’un nouveau composant.
Manuellement depuis l’éditeur de composants
La réutilisation d’une révision d’un modèle de composant depuis l’éditeur de composants dépend du mode de fonctionnement de l’éditeur.
En mode de modification d’un seul composant
Lorsque vous modifiez un seul composant dans ce mode de l’éditeur de composants, choisissez le modèle de composant souhaité dans le menu déroulant associé au champ Template, qui fait partie du groupe Advanced Settings, dans la zone Component de l’éditeur. Tous les modèles de composants actuellement disponibles dans l’espace de travail où réside le composant sont répertoriés par nom, avec leurs dernières révisions indiquées entre parenthèses. Choisissez le modèle souhaité pour l’appliquer.

Association rapide d’un modèle de composant à partir d’un menu contenant tous les modèles disponibles, lors de la modification de la révision d’un composant dans l’éditeur de composants en mode Single Component Editing.
En mode de modification des composants par lots
Il existe deux façons d’associer une révision d’un modèle de composant à la révision du composant en cours de modification :
-
Depuis l’onglet Template de la boîte de dialogue Options du document (Edit » Document Options). Cliquez sur le bouton Choose à droite du champ Item Revision. Cela ouvre la boîte de dialogue Choose Item (une variante du panneau Explorer). Utilisez cette boîte de dialogue pour rechercher et sélectionner la révision du modèle de composant souhaité. Après avoir cliqué sur OK, un lien est créé entre la révision du composant et la révision cible du modèle de composant. Ce lien est ensuite visible dans l’onglet Template de la boîte de dialogue Document Options.

Association manuelle d’un composant à une révision d’un modèle de composant dans l’espace de travail cible. -
Depuis le menu Add associé à la zone Required Models/Parameters de l’éditeur de composants. Le sous-menu Templates répertorie par nom tous les modèles de composants actuellement disponibles dans le même espace de travail que le composant lui-même, avec leurs dernières révisions indiquées entre parenthèses. Cliquez sur une entrée pour créer un lien vers la dernière révision de ce modèle de composant. Là encore, vous pouvez vérifier le lien dans l’onglet Templates de la boîte de dialogue Document Options.

Liaison rapide d’un modèle de composant depuis un menu regroupant tous les modèles disponibles.
Héritage depuis le dossier de composants de l’espace de travail
Vous pouvez spécifier un modèle de composant à utiliser automatiquement pour tous les composants (et leurs révisions) stockés dans un dossier de composants de l’espace de travail.
Spécifiez le modèle souhaité à l’aide du champ Component Template, lors de la définition des propriétés du dossier dans la boîte de dialogue Edit Folder. La liste déroulante associée à ce champ répertorie par nom tous les modèles de composants actuellement disponibles dans le même espace de travail que le dossier de composants lui-même, avec leurs dernières révisions indiquées entre parenthèses. Sélectionnez une entrée pour créer un lien vers la dernière révision de ce modèle de composant pour chaque composant créé ultérieurement dans ce dossier.

Définissez un modèle de composant par défaut à appliquer à tous les composants créés dans le dossier de composants parent.
Si un modèle de composant est sélectionné au niveau du dossier, ce même modèle sera utilisé par défaut lors de la création de composants dans les sous-dossiers enfants. Cela permet de transmettre rapidement le modèle à tous les composants des dossiers enfants.
Incidence de l’utilisation d’un modèle de composant sur les modèles et les paramètres du composant
Lors de la modification d’une révision d’un composant, lorsqu’une révision d’un modèle de composant est liée ou référencée, les opérations suivantes sont effectuées dans l’éditeur de composants concernant les modèles et les paramètres :
- Les modèles définis dans le modèle de composant référencé sont ajoutés à la zone Models (mode Single Component Editing) et à la zone Model Links (mode Batch Component Editing).
- Un modèle référencé existant est conservé et le composant continue de l’utiliser, sauf modification manuelle délibérée.
-
Les paramètres définis dans le modèle de composant référencé sont ajoutés à la zone Parameters (mode Single Component Editing) et à la zone Required Models/Parameters (mode Batch Component Editing).

Exemple de paramètres après la liaison à une révision d’un modèle de composant, lors de l’utilisation de l’éditeur de composants en mode Single Component Editing (à gauche) et en mode Batch Component Editing (à droite). -
En mode Batch Component Editing uniquement, les paramètres issus du modèle dont l’affichage est activé sont regroupés dans la zone de définition des composants de l’éditeur, sous l’en-tête
Template Parameters.
Exemple d’affichage de paramètres issus du modèle dans la zone où sont définis les composants eux-mêmes, lors de l’utilisation de l’éditeur de composants en mode Batch Component Editing. -
Les champs de valeur des paramètres issus du modèle qui ont été marqués comme étant en lecture seule ne sont pas modifiables. Pour tous les autres paramètres issus du modèle qui ne sont pas en lecture seule, vous pouvez modifier les valeurs selon vos besoins.
-
Si un paramètre issu du modèle a été marqué comme obligatoire, mais qu’aucune valeur ne lui a été attribuée dans le modèle, son champ de valeur apparaît avec une bordure rouge (en mode Batch Component Editing) ou contient l’icône
(en mode Single Component Editing), pour vous signaler qu’une valeur est requise pour ce paramètre. Vous ne pourrez pas enregistrer un composant dans l’espace de travail tant que tous les paramètres obligatoires n’auront pas de valeur.
Nouvel enregistrement d’un modèle de composant
À tout moment, vous pouvez revenir à n’importe quelle révision d’un modèle de composant dans l’espace de travail et la modifier directement. Cliquez avec le bouton droit sur la révision et choisissez la commande Edit dans le menu contextuel. L’éditeur temporaire s’ouvre à nouveau et le modèle contenu dans cette révision est ouvert pour modification. Apportez les modifications souhaitées, puis enregistrez le modèle de composant dans la révision suivante de l’élément.

Accès à la commande permettant de lancer la modification directe d’une révision existante d’un modèle de composant.
Téléchargement des données enregistrées
Téléchargez les données stockées dans une révision d’un modèle de composant en cliquant avec le bouton droit sur cette révision (dans le panneau Explorer) et en choisissant la commande Operations » Download dans le menu contextuel. Le fichier du modèle de composant sera téléchargé dans un sous-dossier du répertoire choisi, nommé d’après l’identifiant de révision de l’élément. Le fichier se trouve dans le dossier Released qu’il contient.
Suppression réversible
Lorsque vous êtes connecté à un espace de travail, une fonctionnalité souple permet de supprimer un modèle de composant directement depuis Altium Designer, à partir du panneau Explorer. Cliquez avec le bouton droit sur l’entrée du modèle de composant dans le panneau et choisissez la commande Delete Item dans le menu contextuel. La boîte de dialogue Delete Items s’affiche pour vous permettre de confirmer la suppression. Il s’agit en réalité d’une « suppression réversible » : le modèle de composant est déplacé vers la zone Trash de l’espace de travail. La zone Trash est essentiellement une corbeille dans laquelle tout contenu de votre espace de travail peut être déplacé par une suppression réversible. Elle est isolée du reste de l’espace de travail.

Suppression réversible d’un modèle de composant. Le modèle sera déplacé vers la zone Trash de l’espace de travail.
Pour procéder à la suppression, cliquez sur le bouton
. L'élément sera supprimé et une boîte de dialogue Deletion Summary confirmera la suppression. Si un problème survient lors de la suppression, il vous sera signalé.
Tout le contenu supprimé de cette manière se trouve sur la page Trash de l'interface Web du Workspace. Notez que vous ne pouvez voir que le contenu que vous avez personnellement supprimé de manière réversible. Les administrateurs peuvent voir l'intégralité du contenu de la page Trash, c'est-à-dire tout le contenu ayant fait l'objet d'une suppression réversible.
Points à prendre en compte concernant un modèle de composant supprimé de manière réversible :
- Le modèle de composant ne sera plus accessible depuis votre logiciel de conception ni depuis l'interface Web.
- Partout où le modèle de composant était utilisé, sa suppression sera indiquée.
- Un modèle de composant peut être restauré ou supprimé définitivement depuis la page Trash, à condition que vous disposiez des droits de modification. La suppression définitive n'est possible que si le modèle n'est pas utilisé par un élément parent.







).