Modèles de composants

Pour simplifier la création de vos composants, Altium Designer, associé à votre espace de travail connecté, permet de créer et de définir des Component Templates (éléments de modèle de composant) dans cet espace de travail. Tout comme un modèle de schéma permet de prédéfinir des informations sur les feuilles de schéma qui y font référence, un modèle de composant est référencé par un composant de bibliothèque de l’espace de travail et fournit des paramètres prédéfinis à utiliser lors de la définition de ce composant.

Les modèles de composants ont notamment été conçus en accordant une attention particulière aux informations paramétriques. Ils vous permettent de définir, en un seul endroit, un ensemble de paramètres qui seront mis à la disposition du composant référençant le modèle. Grâce au modèle, vous pouvez contrôler lesquels de ces paramètres seront visibles, renseigner des valeurs par défaut et même rendre obligatoires les paramètres requis. Des contrôles de validation sont effectués lors de l’enregistrement du composant afin de garantir sa conformité.

Les valeurs par défaut spécifiées pour de nombreux paramètres du modèle peuvent être verrouillées en lecture seule ou autorisées, au cas par cas, à être remplacées par le concepteur lors de la définition d’un composant.

Un modèle de composant sert également de base à la création d’un composant générique. Pour en savoir plus, consultez la page Création de composants génériques.

L’accès aux modèles de composants dépend de la licence du logiciel. Pour plus d’informations, consultez l’encadré Note à droite de la page.

Ces modèles de composants sont créés directement dans l’espace de travail. Une fois un modèle de composant créé et ses données enregistrées dans une révision, il peut être réutilisé pour créer un ou plusieurs composants.

Type de dossier

Lors de la création du dossier destiné à stocker les modèles de composants, vous pouvez spécifier son type. Cela n’a aucune incidence sur le contenu du dossier : la publication d’un modèle de composant génère toujours un élément de modèle de composant correspondant. Le type fournit simplement un indice visuel sur le contenu du dossier et peut être utile lorsque vous parcourez un espace de travail à la recherche d’un contenu particulier. Pour indiquer qu’un dossier est destiné à contenir des modèles de composants, définissez son Folder Type sur Component Templates lors de la configuration de ses propriétés dans la boîte de dialogue Modifier le dossier.

La spécification du type de dossier, c’est-à-dire de son usage prévu, fournit une indication visuelle de son contenu lorsque vous parcourez l’espace de travail.
La spécification du type de dossier, c’est-à-dire de son usage prévu, fournit une indication visuelle de son contenu lorsque vous parcourez l’espace de travail.

Type de contenu

Lors de la création d’un élément de modèle de composant cible destiné à stocker votre modèle de composant, assurez-vous que son Content Type est défini sur Component Template dans la boîte de dialogue Créer un nouvel élément. Si vous créez l’élément dans un dossier de type Component Templates, ce type de contenu sera disponible dans le menu contextuel accessible par clic droit lors de la création de l’élément.

Création d’un modèle de composant dans un dossier Component Templates : le Content Type approprié est disponible dans le menu contextuel.
Création d’un modèle de composant dans un dossier Component Templates : le Content Type approprié est disponible dans le menu contextuel.

Enregistrement d’un modèle de composant

Related page: Création & modification de contenu

Jusqu’ici, nous avons abordé la prise en charge des modèles de composants dans l’espace de travail sous l’angle des types de dossiers et de contenu associés. L’enregistrement d’un modèle de composant défini dans une révision d’un tel élément de modèle de composant peut s’effectuer de manière simplifiée.

Un modèle de composant peut être modifié et enregistré dans la révision initiale d’un élément de modèle de composant nouvellement créé, grâce à la prise en charge de la modification directe par l’espace de travail. La modification directe vous libère des contraintes liées à la gestion de données sources distinctes sous contrôle de version. Vous pouvez simplement modifier un type de contenu pris en charge à l’aide d’un éditeur temporaire dans lequel la dernière version des données sources est chargée directement depuis l’espace de travail. Une fois les modifications terminées, l’entité est enregistrée, ou réenregistrée, dans une révision planifiée ultérieure de son élément parent, puis l’éditeur temporaire se ferme. Aucun fichier n’est stocké sur votre disque dur, vous n’avez pas à vous demander si vous travaillez avec les bonnes données sources ou leur dernière version, et vous n’avez pas à maintenir un logiciel de contrôle de version distinct. L’espace de travail gère l’ensemble du processus en garantissant l’intégrité des données et en accélérant considérablement leur modification.

Lorsque vous créez un élément de modèle de composant, vous pouvez modifier et enregistrer un modèle de composant dans la révision initiale de cet élément après sa création. Pour ce faire, activez l’option Open for editing after creation, en bas de la boîte de dialogue Create New Item (cette option est activée par défaut). L’élément est créé et l’éditeur temporaire de modèles de composants s’ouvre, avec un document .CMPT actif dans la fenêtre principale de conception. Ce document est nommé selon l’élément et sa révision, au format : <Item><Revision>.CMPT (par exemple, CMPT-0001-1.CMPT).

 
 
 
 
 

Exemple de modification de la révision initiale d’un modèle de composant directement depuis l’espace de travail : l’éditeur temporaire de modèles de composants fournit le document permettant de définir votre modèle de composant.
Exemple de modification de la révision initiale d’un modèle de composant directement depuis l’espace de travail : l’éditeur temporaire de modèles de composants fournit le document permettant de définir votre modèle de composant.

Utilisez le document pour définir le modèle de composant selon vos besoins. Pour plus d’informations sur cette procédure, consultez Définition du modèle.

Trois commandes utiles pour la modification directe sont accessibles depuis Quick Access Bar (en haut à gauche de la fenêtre principale de l’application) ou depuis la barre d’outils Component Template Standard :

  • – Save Active Document. Utilisez ce bouton pour enregistrer localement les modifications apportées au document. Cela vous permet d’enregistrer les modifications en cours si vous souhaitez y revenir ultérieurement pour effectuer d’autres modifications avant l’enregistrement définitif dans l’espace de travail.
  • / – Save to Server. Utilisez ce bouton pour enregistrer le modèle de composant défini dans l’espace de travail, dans la révision initiale (planifiée) de l’élément de modèle de composant cible. La boîte de dialogue Edit Revision s’affiche. Vous pouvez y modifier le nom et la description, et ajouter des notes de version selon vos besoins. Le document et l’éditeur se ferment après l’enregistrement. Le document contenant le modèle de composant source, *.CMPT, est stocké dans la révision de l’élément.

    Une commande Save to Server est également disponible à droite de l’entrée du modèle de composant, directement dans le panneau Projects .
  • / – Discard Local Changes. Utilisez ce bouton si vous souhaitez annuler la modification et abandonner toutes les modifications apportées. Le document et l’éditeur se ferment, et rien n’est publié dans l’élément de modèle de composant cible.

Ces commandes sont également disponibles – Save (raccourci : Ctrl+S), Save to Server (raccourci : Ctrl+Alt+S) et Discard Local Changes – dans le menu principal File et dans le menu contextuel de l’entrée du modèle de composant dans le panneau Projects.

Les données enregistrées dans l’espace de travail comprennent le modèle de composant source, défini dans le fichier de modèle de composant (<Item><Revision>.CMPT).

 
 
 
 
 

Exemple de modèle de composant défini, enregistré dans l’espace de travail.
Exemple de modèle de composant défini, enregistré dans l’espace de travail.

Héritage d’un modèle de composant

Cette fonctionnalité est disponible lorsque l’option UI.ComponentTemplateInheritance est activée dans la boîte de dialogue Advanced Settings.

Vous pouvez utiliser le modèle de composant du type de composant racine si aucun modèle de composant n’est lié au sous-type. Lors de la création d’une hiérarchie de types de composants, les sous-types de composants héritent du modèle de composant attribué au type de composant racine ou parent.

L’éditeur CMPT (modèle de composant)

Pour accéder à l’éditeur de modèles de composants dans Altium Designer, l’extension logicielle Component Template Editor doit être installée. Cette extension est installée par défaut avec Altium Designer. Elle peut être installée ou supprimée manuellement.

Pour plus d’informations sur la gestion des extensions, consultez la page Extending Your Installation (Altium Designer Develop, Altium Designer Agile, Altium Designer).

Définition du modèle

L’éditeur de modèles de composants est essentiellement divisé en deux zones principales, illustrées dans l’image suivante et décrites ci-après.

 
 
 
 
 

L’éditeur de modèles de composants peut être divisé en deux grandes zones.
L’éditeur de modèles de composants peut être divisé en deux grandes zones.

  1. Upper Region – pour définir les options au niveau du composant (cycle de vie, nommage et options de dossier) pour un composant faisant référence au modèle.
  2. Lower Region – pour définir les paramètres à utiliser pour un composant faisant référence au modèle.

Définition des options du composant

La moitié supérieure de l’éditeur est consacrée à la définition des valeurs par défaut des propriétés de composant suivantes :

  • Lifecycle Definition – choisissez la définition du cycle de vie à appliquer à un composant créé à l’aide du modèle. La liste déroulante présente toutes les définitions configurées pour l’espace de travail et dont l’utilisation est autorisée pour un composant.

  • Revision Naming – choisissez le schéma de nommage des révisions à appliquer à un composant créé à l’aide du modèle. La liste déroulante présente tous les schémas configurés pour l’espace de travail et dont l’utilisation est autorisée pour un composant.

    Si l’option permettant de contrôler l’utilisation des définitions de cycle de vie et des schémas de nommage des révisions par type de contenu est activée pour certaines définitions ou certains schémas, et que le type de contenu Composant n’est pas configuré pour utiliser une définition ou un schéma donné, cette définition ou ce schéma ne sera pas disponible dans la liste déroulante correspondante.

  • Component Naming – utilisez ce champ pour définir un schéma de nommage des éléments par défaut pour un composant créé à partir du modèle, afin de garantir un identifiant unique pour le composant obtenu dans l’espace de travail. La valeur saisie ici servira de modèle pour nommer automatiquement le composant (dans son champ Id associé lorsque l’éditeur de composants est utilisé en mode Single Component Editing, ou dans le champ Item ID lorsque l’éditeur de composants est utilisé en mode Batch Component Editing). Le logiciel attribuera automatiquement le prochain identifiant unique disponible selon ce schéma, après avoir analysé l’ensemble de l’espace de travail et les identifiants du contenu existant. Un schéma de nommage des éléments par défaut – CMP-{00000} – est fourni, mais vous pouvez bien sûr créer votre propre schéma en le saisissant dans le champ, en veillant à placer la partie variable entre accolades (par exemple, CMP-001-{0000}).

  • Default Folder – permet de spécifier un dossier par défaut dans l’espace de travail cible où stocker un composant enregistré. Pour ce faire, cliquez sur le bouton Choose afin d’ouvrir la boîte de dialogue Choose Folder (une version du panneau Explorer), depuis laquelle vous pouvez parcourir l’espace de travail et sélectionner un dossier existant, ou en créer un nouveau à la volée.

Aucun champ ne permet de définir l’espace de travail cible, car celui-ci est prédéfini pour correspondre à l’espace de travail dans lequel se trouve la révision du modèle de composant.

L’option Allow override de chaque propriété permet de contrôler indépendamment si l’utilisateur peut modifier cette propriété (option activée) ou non (option désactivée) lors de la définition d’un composant dans l’éditeur de composants.

Lorsque le modèle est utilisé, les valeurs spécifiées dans cette zone servent à préremplir les champs correspondants dans l’éditeur de composants (lorsqu’ils sont disponibles) :

  • Single Component Editing mode – les champs Id et Folder, dans la zone Advanced Settings de la section Component.
  • Batch Component Editing mode – dans l’onglet Document Options de la boîte de dialogue Document Options et, par conséquent, dans les champs Item ID et FolderPath de la zone Component de la section des définitions de composants.

Lorsque le modèle est utilisé, les valeurs servent à préremplir les champs correspondants lors de la modification d’un composant dans l’éditeur de composants en mode Single Component Editing (à gauche) et en mode Batch Component Editing (à droite).
Lorsque le modèle est utilisé, les valeurs servent à préremplir les champs correspondants lors de la modification d’un composant dans l’éditeur de composants en mode Single Component Editing (à gauche) et en mode Batch Component Editing (à droite).

Définition des paramètres

La moitié inférieure de l’éditeur est consacrée à la définition et à la gestion des paramètres qui seront mis à la disposition d’un composant utilisant le modèle.

 
 
 
 
 

Exemple de paramètres définis dans un modèle de composant.
Exemple de paramètres définis dans un modèle de composant.

Paramètres système par défaut

Divers paramètres système sont inclus par défaut lors de la création d’un nouveau modèle de composant, comme illustré dans l’image suivante et détaillé ci-après.

 
 
 
 
 

Paramètres système par défaut inclus dans un modèle de composant nouvellement créé.
Paramètres système par défaut inclus dans un modèle de composant nouvellement créé.

  • ComponentType – ce paramètre vous permet de spécifier le type de composant. Il facilite les recherches ciblées grâce à la puissante fonction de recherche de l’espace de travail, qui permet non seulement de rechercher par type de composant, mais aussi d’effectuer des recherches plus intelligentes grâce à la prise en charge des paramètres de composants tenant compte des unités. Lorsque vous parcourez les composants de votre espace de travail à l’aide du panneau Components, le regroupement Categories des composants est déterminé à partir des paramètres ComponentType associés à chaque composant. Cliquez sur le champ Default Value associé, puis sur le bouton pour ouvrir la boîte de dialogue Choose component type. Utilisez-la pour sélectionner le type de composant souhaité, puis cliquez sur OK : le type choisi sera inséré comme valeur du paramètre ComponentType dans la grille principale des paramètres.

    La boîte de dialogue Choose component type reflète l’ensemble des types de composants définis sur la page Data Management – Component Types de la boîte de dialogue Preferences. Cliquez sur le bouton en bas de la boîte de dialogue Choose component type pour accéder à cette page de préférences, depuis laquelle vous pouvez adapter cette liste à vos besoins, soit en ajoutant de nouveaux types et sous-types, soit en modifiant ou en supprimant des types existants.

    Exemple de modèle de composant, avec le paramètre système ComponentType défini sur Diodes.
    Exemple de modèle de composant, avec le paramètre système ComponentType défini sur Diodes.

     
     
     
     
     

    Le type de données de ce paramètre est défini sur ComponentType et ne peut pas être modifié. De plus, le paramètre ComponentType ne peut être ni copié ni supprimé. Sélectionnez la cellule et utilisez la touche Delete pour effacer la valeur.

  • SCHLIB et PCBLIB – ces deux paramètres permettent de spécifier respectivement les modèles de symbole et d’empreinte par défaut. Cliquez sur le champ Default Value associé à chaque paramètre, puis sur le bouton pour ouvrir une boîte de dialogue permettant de choisir le modèle souhaité.

    Notez que vous choisissez le modèle, et non une révision spécifique de celui-ci. Ainsi, un composant utilisant le modèle de composant utilisera toujours la dernière révision du modèle choisi.

    Spécifiez les modèles de symbole et d’empreinte dans votre modèle de composant.
    Spécifiez les modèles de symbole et d’empreinte dans votre modèle de composant.

     
     
     
     
     

    Les types de données de ces paramètres sont définis respectivement sur SCHLIB et PCBLIB et ne peuvent pas être modifiés. De plus, les paramètres de modèle ne peuvent être ni copiés ni supprimés. Sélectionnez la cellule et utilisez la touche Delete pour effacer la valeur.

  • Name et Description – ces deux paramètres permettent de définir respectivement le nom et la description du composant. Saisissez les chaînes souhaitées dans le champ Default Value associé à chaque paramètre.

    Spécifiez les paramètres Name et Description dans votre modèle de composant.
    Spécifiez les paramètres Name et Description dans votre modèle de composant.

     
     
     
     
     

    Le type de données de ces deux paramètres est défini sur Text et ne peut pas être modifié. De plus, ces paramètres ne peuvent être ni copiés ni supprimés.

Ajout d’un nouveau paramètre utilisateur

Pour ajouter un nouveau paramètre utilisateur à la liste, cliquez sur le bouton (ou utilisez la commande Add du menu contextuel accessible par clic droit) – le paramètre est ajouté à la fin de la liste actuelle.

 
 
 
 
 

Exemple d’ajout d’un nouveau paramètre utilisateur au modèle de composant.
Exemple d’ajout d’un nouveau paramètre utilisateur au modèle de composant.

Chaque paramètre est présenté dans le tableau avec les informations suivantes :

  • Name – utilisez ce champ pour nommer le paramètre, généralement avec un nom explicite qui indique sa fonction. Lors de leur ajout initial, les paramètres reçoivent des noms par défaut (Parameter, Parameter 1, Parameter 2, etc.).

  • Type – le type de paramètre. Cette entrée prend initialement la valeur Text par défaut, mais plusieurs types de données prenant en compte les unités sont pris en charge, ainsi que le type PCBLIB, qui facilite la définition de plusieurs empreintes, et HarnessWiring, qui facilite la définition d’un composant de câblage de faisceau. Les types de paramètres définis par les dictionnaires disponibles sont également pris en charge – en savoir plus.

  • Visible – activez cette option (activée par défaut pour un paramètre nouvellement ajouté) pour que l’option Show correspondante du paramètre soit activée lors de la modification d’un ou de plusieurs composants dans l’éditeur de composants (configuré en mode Batch Component Editing). Cela contrôle l’affichage de la colonne correspondant à ce paramètre dans la partie inférieure de l’éditeur de composants, où sont définis les composants eux-mêmes. Cette propriété n’a aucun effet lors de la définition d’un composant en mode Single Component Editing de l’éditeur.

  • Read Only – activez cette option pour rendre le paramètre accessible en lecture seule. Lors de la modification d’un composant qui fait référence au modèle, la valeur du paramètre ne pourra pas être modifiée.

  • Required – activez cette option pour rendre le paramètre obligatoire. Lors de la modification d’un composant qui fait référence au modèle, une valeur doit être définie pour ce paramètre, sinon le composant ne pourra pas être enregistré. Dans l’éditeur de composants, lorsqu’aucune valeur n’a été saisie, ce type de paramètre se distingue par une bordure rouge autour de la cellule de valeur (en mode Batch Component Editing) ou par l’icône dans cette cellule (en mode Single Component Editing).

  • Default Value – utilisez ce champ pour saisir une valeur par défaut pour le paramètre.

    • Si le paramètre est marqué comme obligatoire (option Required activée) et a également été défini en lecture seule (option Read Only activée), une valeur par défaut MUST être saisie. Sinon, lors de la modification d’un composant qui fait référence au modèle, le paramètre sera signalé comme n’ayant aucune valeur, mais ce problème ne pourra pas être résolu puisque le paramètre n’est pas modifiable, étant en lecture seule. Une nouvelle révision de ce modèle de composant ne pourra pas être enregistrée dans l’espace de travail tant que ce problème n’aura pas été résolu.

    • Lors de la modification d’une révision d’un composant, un paramètre existant défini par l’utilisateur qui porte le même nom qu’un paramètre du modèle de composant lié sera remplacé par la version du modèle. Toute valeur existante de ce paramètre sera conservée (et ne sera pas écrasée par la valeur par défaut du modèle).

  • Description – ajoutez une description du paramètre, par exemple une courte note sur son rôle. Si une description est définie pour un paramètre du modèle, la colonne Description sera affichée dans la zone Parameters de l’éditeur de composants dans son Single Component Editing, en conséquence.

La liste des paramètres prend également en charge les opérations simples de copier-coller, ce qui vous permet de dupliquer un ou plusieurs paramètres utilisateur existants. Les paramètres collés seront ajoutés à la fin de la liste.

Les raccourcis standard de copie (Ctrl+C) et de collage (Ctrl+V) sont pris en charge, et ces commandes sont également disponibles dans le menu contextuel accessible par clic droit. Plusieurs paramètres utilisateur peuvent être sélectionnés pour les opérations de copier-coller à l’aide des techniques standard Ctrl+Click et Shift+Click.
Pour supprimer un ou plusieurs paramètres utilisateur de la liste, sélectionnez chaque paramètre, puis cliquez sur le bouton ou utilisez la commande Remove du menu contextuel accessible par clic droit.

Types de données des paramètres de composants prenant en charge les unités

L’éditeur de modèles de composants permet de définir des types de données explicites pour les paramètres de composants définis dans un modèle de composant (*.CMPT). De plus, ces types de données prennent en charge les unités ainsi qu’un ensemble de préfixes d’unités courants. Vous pouvez ainsi saisir la valeur d’un paramètre dans différents formats, tels que 2.2k, 2k2, 4M ou 2.5GHz, l’espace de travail étant doté de la logique nécessaire pour reconnaître la valeur numérique correspondant à ces saisies.

Cette fonctionnalité des modèles de composants facilite les recherches ciblées à l’aide de la fonction de recherche avancée du serveur : celle-ci permet non seulement de rechercher par type de composant, mais aussi d’effectuer des recherches plus précises, par plages de valeurs. Grâce aux paramètres de composants prenant en charge les unités, vous pouvez rapidement définir une recherche, par exemple pour trouver tous les condensateurs dont la capacité est comprise entre 47uF et 220uF.

Les paramètres prenant en charge les unités sont également utilisés pour le filtrage intelligent lorsque vous recherchez vos propres composants à l’aide du panneau Components.

Consultez les sections dépliables suivantes pour en savoir plus sur les paramètres prenant en charge les unités.

Types de données de paramètres définis par un dictionnaire

Les dictionnaires sont des types de paramètres personnalisés comportant plusieurs valeurs définies. Ils sont gérés par les administrateurs de l’espace de travail sur la page Settings – Vault – Dictionaries de l’interface Web de l’espace de travail. Cette page est accessible depuis l’éditeur de modèles de composants en choisissant l’option Add New Dictionary dans la liste déroulante Type ou en cliquant sur la commande Manage Dictionaries en haut à droite de la zone Parameters.

  • La page Settings – Vault – Dictionaries est également accessible depuis la page Gestion des données – Dictionnaires de la boîte de dialogue Preferences, en cliquant sur la commande Manage Dictionaries, ainsi que depuis la page Gestion des données – Serveurs de la boîte de dialogue Preferences, en cliquant sur la commande Properties de l’espace de travail actif ou d’un espace de travail connu, puis en sélectionnant l’entrée Dictionaries dans le menu.

  • Lorsqu’un type défini par un dictionnaire est sélectionné pour un paramètre, la page Settings – Vault – Dictionaries est également accessible en cliquant dans la cellule du paramètre dans la colonne Type, puis sur le bouton  ().

Accédez à la page de gestion des dictionnaires dans l’interface Web de l’espace de travail depuis l’éditeur de modèles de composants.
Accédez à la page de gestion des dictionnaires dans l’interface Web de l’espace de travail depuis l’éditeur de modèles de composants.

En savoir plus sur la gestion des dictionnaires depuis l’interface Web de l’espace de travail (espace de travail Altium 365, espace de travail Enterprise Server).

Les dictionnaires définis sont disponibles en tant que types de paramètres dans la liste déroulante Type.

Sélectionnez un type de paramètre défini par un dictionnaire dans la liste déroulante Type.
Sélectionnez un type de paramètre défini par un dictionnaire dans la liste déroulante Type.

Les valeurs définies pour le type sélectionné sont disponibles dans la liste déroulante Default Value. Sélectionnez la valeur souhaitée comme valeur par défaut du paramètre ou sélectionnez <None>.

Sélectionnez une valeur par défaut parmi celles définies pour le type sélectionné.
Sélectionnez une valeur par défaut parmi celles définies pour le type sélectionné.

  • Les valeurs par défaut sont validées lors de l’enregistrement du modèle de composant dans l’espace de travail. Si la valeur par défaut devient incohérente avec le dictionnaire (p. ex. si elle a été supprimée du dictionnaire, puis que le modèle utilisant cette valeur a été ouvert pour modification), elle sera mise en évidence en rouge dans la colonne Valeur par défaut, et un message d’erreur s’affichera dans le panneau Messages lors de la tentative d’enregistrement du modèle dans l’espace de travail.

  • Si la valeur d’un paramètre de composant devient incohérente avec le dictionnaire (p. ex. si le type de ce paramètre est passé de Texte à un type défini par un dictionnaire dans le modèle de composant et que la valeur actuelle du composant ne correspond à aucune valeur du type sélectionné), ce paramètre sera mis en évidence lors de la modification du composant dans l’éditeur de composants : une icône en forme de point d’exclamation s’affichera à côté de la valeur incohérente du paramètre en mode de modification d’un seul composant, et la valeur du paramètre sera mise en évidence en rouge en mode de modification de composants par lots. Assurez-vous que tous les paramètres du composant sont cohérents avec les valeurs du modèle ; sinon, vous ne pourrez pas enregistrer le composant dans la révision suivante.

  • Si les dictionnaires ont été modifiés dans l’interface Web de l’espace de travail connecté, vous devez vous déconnecter de l’espace de travail, puis vous y reconnecter pour que ces modifications soient prises en compte dans Altium Designer. Consultez la page Accéder à votre espace de travail pour en savoir plus.

Définition de plusieurs empreintes

L’éditeur de modèles de composants permet également de définir plusieurs empreintes de PCB dans un modèle de composant. Vous pouvez spécifier autant de liens vers des modèles d’empreinte que nécessaire. Cette fonctionnalité sera particulièrement utile pour créer des composants faisant référence à 3 empreintes, afin de satisfaire aux exigences IPC pour différents niveaux de densité : L (faible, ou cuivre minimal), M (élevée, ou cuivre maximal) et N (nominale, ou cuivre médian).

Pour ajouter une définition de modèle d’empreinte supplémentaire au modèle de composant, cliquez sur pour ajouter un nouveau paramètre, puis choisissez l’entrée PCBLIB dans le menu déroulant associé au champ Type.

Transformez un paramètre nouvellement ajouté en définition de modèle d’empreinte en définissant son Type sur PCBLIB.
Transformez un paramètre nouvellement ajouté en définition de modèle d’empreinte en définissant son Type sur PCBLIB.

Le nom du paramètre passera de Parameter à PCBLIB n, où n est le prochain entier disponible permettant de distinguer les différents modèles d’empreinte (p. ex. PCBLIB 1, PCBLIB 2, etc.). Le modèle par défaut sera celui associé à l’entrée PCBLIB. Lorsque les empreintes sont importées dans l’éditeur de composants lors de la définition d’un composant, le modèle d’empreinte par défaut se distingue par l’icône en haut à gauche de la fenêtre d’aperçu du modèle (en mode Single Component Editing) et par l’entrée PCBLIB (default) dans la zone Required Models/Parameters (en mode Batch Component Editing).

Exemple de composant défini dans l’éditeur de composants (mode Single Component Editing), à partir d’un modèle de composant référencé. Le modèle contient trois modèles d’empreinte, qui sont intégrés à la définition du composant. Notez que l’entrée de modèle PCBLIB du modèle de composant est utilisée comme modèle d’empreinte par défaut (signalé par une icône en haut à gauche) lors de la définition du composant. Survolez l’image pour voir le même composant défini dans l’éditeur de composants en mode Batch Component Editing. Dans ce cas, l’empreinte par défaut est nommée PCBLIB (default).
Exemple de composant défini dans l’éditeur de composants (mode Single Component Editing), à partir d’un modèle de composant référencé. Le modèle contient trois modèles d’empreinte, qui sont intégrés à la définition du composant. Notez que l’entrée de modèle PCBLIB du modèle de composant est utilisée comme modèle d’empreinte par défaut (signalé par une icône en haut à gauche) lors de la définition du composant. Survolez l’image pour voir le même composant défini dans l’éditeur de composants en mode Batch Component Editing. Dans ce cas, l’empreinte par défaut est nommée PCBLIB (default).

Importation et exportation de modèles de composants

Un fichier de modèle de composant existant (*.CMPT) ou un fichier de bibliothèque de composants (*.CMPLIB) peut être importé dans l’éditeur de modèles de composants, et le modèle de composant en cours de modification peut être exporté vers un fichier de modèle de composant (*.CMPT). Utilisez les commandes File » Import » Component Template, File » Import » Component Library et File » Export du menu principal de l’éditeur de composants pour sélectionner l’action souhaitée, puis la boîte de dialogue Windows standard qui s’ouvre pour accéder à l’emplacement requis et sélectionner un fichier à importer ou définir le nom du fichier à exporter.

Réutilisation d’un modèle de composant

L’utilisation d’une révision d’un modèle de composant — ou, plus précisément, son référencement depuis la révision d’un composant en cours de modification — peut s’effectuer de différentes façons.

Un composant ne peut référencer qu’un seul modèle de composant à la fois.

Lors de la création d’un nouveau composant

Lors de la création d’un nouveau composant à l’aide de la commande File » New » Component des menus principaux, vous pouvez choisir le modèle dans la boîte de dialogue Create new component.

Association rapide d’un modèle de composant à partir de la liste de tous les modèles disponibles, lors de la création d’un nouveau composant.
Association rapide d’un modèle de composant à partir de la liste de tous les modèles disponibles, lors de la création d’un nouveau composant.

Manuellement depuis l’éditeur de composants

La réutilisation d’une révision d’un modèle de composant depuis l’éditeur de composants dépend du mode de fonctionnement de l’éditeur.

En mode de modification d’un seul composant

Lors de la modification d’un seul composant dans ce mode de l’éditeur de composants, choisissez le modèle de composant requis dans le menu déroulant associé au champ Template, qui fait partie du groupe Advanced Settings, dans la zone Component de l’éditeur. Tous les modèles de composants actuellement disponibles dans le même espace de travail que le composant sont répertoriés par nom, avec leurs dernières révisions indiquées entre parenthèses. Choisissez le modèle souhaité pour l’appliquer.

Association rapide d’un modèle de composant à partir d’un menu regroupant tous les modèles disponibles, lors de la modification de la révision d’un composant à l’aide de l’éditeur de composants en mode Single Component Editing.
Association rapide d’un modèle de composant à partir d’un menu regroupant tous les modèles disponibles, lors de la modification de la révision d’un composant à l’aide de l’éditeur de composants en mode Single Component Editing.

En mode de modification des composants par lots

Il existe deux façons d’associer une révision d’un modèle de composant à la révision du composant en cours de modification :

  • Depuis l’onglet Template de la boîte de dialogue Options du document (Edit » Document Options). Cliquez sur le bouton Choose à droite du champ Item Revision. Cela ouvre la boîte de dialogue Choose Item (une variante du panneau Explorer). Utilisez cette boîte de dialogue pour rechercher et sélectionner la révision du modèle de composant requis. Après avoir cliqué sur OK, un lien est créé entre la révision du composant et la révision cible du modèle de composant. Ce lien est visible dans l’onglet Template de la boîte de dialogue Document Options.

    Association manuelle d’un composant à une révision d’un modèle de composant dans l’espace de travail cible.
    Association manuelle d’un composant à une révision d’un modèle de composant dans l’espace de travail cible.

    Le modèle de composant utilisé peut être changé à tout moment : cliquez sur Choose et sélectionnez une révision d’un autre modèle de composant.
    L’état de la révision de l’élément de modèle de composant associé est indiqué dans l’onglet Template de la boîte de dialogue Document Options. Si une révision plus récente de l’élément associé est disponible, cliquez sur le bouton pour utiliser cette dernière révision.
  • Depuis le menu Add associé à la zone Required Models/Parameters de l’éditeur de composants. Le sous-menu Templates répertorie par nom tous les modèles de composants actuellement disponibles dans le même espace de travail que le composant, avec leurs dernières révisions indiquées entre parenthèses. Cliquez sur une entrée pour créer un lien vers la dernière révision de ce modèle de composant. Là encore, vous pouvez vérifier ce lien dans l’onglet Templates de la boîte de dialogue Document Options.

    Association rapide d’un modèle de composant à partir d’un menu regroupant tous les modèles disponibles.
    Association rapide d’un modèle de composant à partir d’un menu regroupant tous les modèles disponibles.

Héritage depuis le dossier de composants de l’espace de travail

Vous pouvez spécifier un modèle de composant à utiliser automatiquement pour tous les composants (et leurs révisions) stockés dans un dossier de composants de l’espace de travail.

Un modèle de composant par défaut ne peut être défini que pour un dossier de type Components.

Spécifiez le modèle requis à l’aide du champ Component Template lors de la définition des propriétés du dossier dans la boîte de dialogue Modifier le dossier. La liste déroulante associée au champ répertorie par nom tous les modèles de composants actuellement disponibles dans le même espace de travail que le dossier de composants, avec leurs dernières révisions indiquées entre parenthèses. Choisissez une entrée pour créer un lien vers la dernière révision de ce modèle de composant pour chaque composant créé ultérieurement dans ce dossier.

Spécifiez un modèle de composant par défaut à appliquer à tous les composants créés dans le dossier de composants parent.
Spécifiez un modèle de composant par défaut à appliquer à tous les composants créés dans le dossier de composants parent.

Pour ne pas utiliser cette fonctionnalité, laissez ou définissez le champ Component Template sur None.

Si un modèle de composant est choisi au niveau du dossier, ce même modèle sera utilisé par défaut lors de la création de composants dans les sous-dossiers enfants. Cela permet de transmettre rapidement le modèle à tous les composants des dossiers enfants.

Lorsqu’une révision d’un composant est enregistrée dans l’espace de travail, la révision spécifique du modèle de composant utilisé est figée : un lien fort est créé vers cette révision, sauf modification manuelle.

Impact de l’utilisation d’un modèle de composant sur les modèles et les paramètres du composant

Lors de la modification d’une révision d’un composant, si une révision d’un modèle de composant est associée ou référencée, les effets suivants se produisent dans l’éditeur de composants concernant les modèles et les paramètres :

  • Les modèles définis dans le modèle de composant référencé sont ajoutés à la zone Models (mode Single Component Editing) et à la zone Model Links (mode Batch Component Editing).
  • Un modèle référencé existant est conservé, et le composant continue à utiliser ce modèle, sauf s’il est volontairement changé manuellement.
  • Les paramètres définis dans le modèle de composant référencé sont ajoutés à la zone Parameters (mode Single Component Editing) et à la zone Required Models/Parameters (mode Batch Component Editing).

    Exemple de paramètres après association à une révision d’un modèle de composant, lors de l’utilisation de l’éditeur de composants en mode Single Component Editing (à gauche) et en mode Batch Component Editing (à droite).
    Exemple de paramètres après association à une révision d’un modèle de composant, lors de l’utilisation de l’éditeur de composants en mode Single Component Editing (à gauche) et en mode Batch Component Editing (à droite).

    Tous les paramètres provenant du modèle de composant référencé sont identifiés par l’icône (mode Single Component Editing) et l’icône (mode Batch Component Editing). De plus, uniquement en mode de modification des composants par lots, l’option Show de chaque paramètre issu du modèle suit l’état de l’option Visible correspondante dans le modèle.
    Les paramètres issus du modèle ne peuvent pas être supprimés.
    Vous pouvez ajouter des paramètres utilisateur supplémentaires selon vos besoins.
  • Uniquement en mode Batch Component Editing, les paramètres issus du modèle configurés pour être affichés sont regroupés dans la zone de définition des composants de l’éditeur, avec Template Parameters comme en-tête.

    Affichage d’exemples de paramètres issus d’un modèle dans la zone où sont définies les définitions des composants, lorsque l’éditeur de composants est utilisé en mode Batch Component Editing.
    Affichage d’exemples de paramètres issus d’un modèle dans la zone où sont définies les définitions des composants, lorsque l’éditeur de composants est utilisé en mode Batch Component Editing.

  • Les champs de valeur des paramètres issus d’un modèle qui ont été marqués comme étant en lecture seule ne sont pas modifiables. Pour tous les autres paramètres issus d’un modèle, qui n’ont pas été marqués comme étant en lecture seule, vous pouvez modifier les valeurs selon vos besoins.

    Lorsque l’éditeur de composants est en mode Single Component Editing, un paramètre de modèle en lecture seule est signalé dans la zone Parameters par l’icône .
  • Si un paramètre issu d’un modèle a été marqué comme obligatoire, mais qu’aucune valeur ne lui a été attribuée dans le modèle, son champ de valeur apparaît avec une bordure rouge (en mode Batch Component Editing) ou contient l’icône (en mode Single Component Editing), vous indiquant qu’une valeur est requise pour ce paramètre. Vous ne pourrez pas enregistrer un composant dans l’espace de travail tant que tous les paramètres obligatoires n’auront pas de valeur.

    Lorsque l’éditeur de composants est en mode Single Component Editing, un paramètre de modèle obligatoire est signalé dans la zone Parameters par l’icône .

Réenregistrement d’un modèle de composant

À tout moment, vous pouvez revenir à n’importe quelle révision d’un modèle de composant dans l’espace de travail et la modifier directement. Faites un clic droit sur la révision et choisissez la commande Edit dans le menu contextuel. L’éditeur temporaire s’ouvre à nouveau, avec le modèle contenu dans la révision prêt à être modifié. Effectuez les modifications nécessaires, puis enregistrez le modèle de composant dans la révision suivante de l’élément.

Un clic droit sur l’entrée de premier niveau du modèle de composant permet de modifier la dernière révision de ce modèle.

Accès à la commande permettant de lancer la modification directe d’une révision existante d’un modèle de composant.
Accès à la commande permettant de lancer la modification directe d’une révision existante d’un modèle de composant.

Téléchargement des données enregistrées

Téléchargez les données stockées dans une révision d’un modèle de composant en faisant un clic droit sur cette révision (dans le panneau Explorer) et en choisissant la commande Operations » Download dans le menu contextuel. Le fichier du modèle de composant est téléchargé dans un sous-dossier du répertoire choisi, nommé d’après l’identifiant de révision de l’élément. Le fichier se trouve dans le dossier Released qu’il contient.

Accédez à la commande Download depuis l’entrée de premier niveau du modèle de composant pour télécharger le fichier du modèle de composant stocké dans sa dernière révision.
Cliquez sur le bouton Explore dans la boîte de dialogue Download from Server pour accéder rapidement au dossier de téléchargement.

Suppression réversible

Lorsque vous êtes connecté à un espace de travail, une fonctionnalité souple permet de supprimer un modèle de composant directement depuis Altium Designer, à partir du panneau Explorer. Faites un clic droit sur l’entrée du modèle de composant dans le panneau et choisissez la commande Delete Item dans le menu contextuel. La boîte de dialogue Delete Items s’affiche pour vous permettre de confirmer la suppression. Il s’agit en réalité d’une « suppression réversible », qui déplace le modèle de composant vers la zone Trash de l’espace de travail. La zone Trash est essentiellement une corbeille dans laquelle tout contenu de votre espace de travail peut être déplacé (par une suppression réversible). Elle est isolée du reste de l’espace de travail.

La fonctionnalité de suppression réversible vous permet de supprimer un modèle de composant actuellement utilisé.
Plusieurs modèles de composants peuvent être supprimés en une seule opération. Sélectionnez tous les modèles de composants souhaités à l’aide des commandes de sélection multiple standard (Shift+Click, Ctrl+Click), puis faites un clic droit et choisissez la commande Delete Items dans le menu contextuel.

Suppression réversible d’un modèle de composant. Le modèle est déplacé vers la zone Trash de l’espace de travail.
Suppression réversible d’un modèle de composant. Le modèle est déplacé vers la zone Trash de l’espace de travail.

Pour procéder à la suppression, cliquez sur le bouton . L’élément est supprimé et une boîte de dialogue Deletion Summary confirme que la suppression a réussi. Si un problème survient lors de la suppression, il vous sera signalé.

Tout le contenu supprimé de cette manière se trouve sur la page Trash de l’interface Web de l’espace de travail. Notez que vous ne pouvez voir que le contenu que vous avez vous-même supprimé de manière réversible. Les administrateurs peuvent voir l’intégralité du contenu de la page Trash, c’est-à-dire tout le contenu ayant fait l’objet d’une suppression réversible.

Points à prendre en compte concernant un modèle de composant supprimé de manière réversible :

  • Le modèle de composant n’est plus disponible dans votre logiciel de conception ni dans l’interface Web.
  • Partout où le modèle de composant était utilisé, sa suppression est signalée.
  • Un modèle de composant peut être restauré ou supprimé définitivement depuis la page Trash, à condition que vous disposiez des droits de modification. La suppression définitive n’est possible que s’il n’est pas utilisé par un élément parent.
Notez que si vous avez supprimé de manière réversible un modèle de composant, en le déplaçant vers Trash, vous pouvez créer un nouveau modèle de composant portant le même nom. Si vous restaurez ensuite le modèle de composant d’origine et que son nom d’origine est déjà utilisé, un suffixe numérique entier lui sera ajouté afin que son nom reste unique dans l’espace de travail.
AI-LocalizedLocalisé par IA
Si vous trouvez un problème, sélectionnez le texte/l’image et appuyez surCtrl + Enterpour nous envoyer vos commentaires.
Nav
Contents
Disponibilité des fonctionnalités

Les fonctionnalités auxquelles vous avez accès dépendent de la solution Altium dont vous disposez – Altium Develop, Altium Agile Teams, Altium Agile Enterprise, ou Altium Designer (avec un abonnement actif).

Si vous ne voyez pas une fonctionnalité documentée dans votre logiciel actuel, contactez le service commercial d’Altium pour en savoir plus.

Documentation héritée

La documentation d’Altium Designer n’est plus versionnée. Si vous devez accéder à la documentation des versions antérieures d’Altium Designer, consultez la section Documentation héritée de la page Other Installers.

Contents