単一コンポーネント編集
Workspaceコンポーネントの定義や編集には、Component Editorを使用します。Component Editorには、Single Component EditingとBatch Component Editingの2つのモードがあります。前者は、単一のコンポーネントを定義・編集するためのシンプルなインターフェースを提供します。新しいコンポーネントを作成する場合や、既存のコンポーネントの単一リビジョンを編集する場合は、このモードがデフォルトとなります。後者は、複数のコンポーネントを定義・編集するためのインターフェースですが、必要に応じて単一のコンポーネントの定義・編集にも使用できます。
このドキュメントでは、Component EditorをSingle Component Editingモードで使用する方法について説明します。
インターフェースの概要
Single Component EditingモードのComponent Editorインターフェースは、基本的に4つの主要な領域に分かれています。次の画像に示し、その後に概要を説明します。

Single Component Editingモードで動作するComponent Editorは、4つの主要な領域に分けられます。
-
コンポーネント – コンポーネントの主要なプロパティを定義する領域です。Name、Description、Type、一意のId、 格納先のFolder、および必要に応じてコンポーネントテンプレートへの参照を定義します。
-
モデル – コンポーネントで使用する、保存済み(またはその場で作成した)のドメインモデルへのリンクを追加する領域です。
-
パラメーター – コンポーネントに適用するパラメトリックデータのセットを作成する領域です。参照先のコンポーネントテンプレートのパラメーターに加えて、ユーザー定義のパラメーターを含めることができます。ここには、WebサイトのURLへのリンクやデータシートも追加できます。
-
部品候補 – コンポーネントの部品候補を検索して追加する領域です。部品候補とは、基板の製造・実装時に設計コンポーネントとして使用したい、実際のメーカー部品です。
コンポーネント
この領域には、次のコンポーネント属性を定義するためのコントロールがあります。
-
Name – コンポーネントに付けられた、人が理解しやすい名前を表します。このシステムパラメーターは、Workspace内の検索で使用でき、インデックス化されます。Item IDを覚えていなくても、特定のコンポーネントを簡単に見つけられます。
名前の入力を開始すると(2文字以上)、Workspaceのローカル部品カタログから、利用可能なメーカー部品の一覧がポップアップ表示されます。エントリを選択すると、選択したデータ(パラメーター、モデル、データシート)を使用して、コンポーネントをすばやく定義できます。このメーカー部品検索による作成機能は、フィールドの右端にある
ボタンを押しても使用できます。詳細については、メーカー部品検索からのコンポーネントの作成を参照してください。
-
Description – コンポーネントに追加された説明を表します。このシステムパラメーターは、Workspace内の検索で使用でき、インデックス化されます。
-
Type – このフィールドではコンポーネントの種類を定義でき、目的に合ったコンポーネントの検索を容易にするための重要な属性として使用されます。Componentsパネルで自分のコンポーネントを参照する際、コンポーネントのCategoriesグループ分けは、各コンポーネントに定義されたコンポーネントの種類に基づきます。フィールドをクリックすると、現在定義されているコンポーネントの種類の一覧が表示され、そこから選択できます。種類はプリファレンスで定義されます。フィールド右側の
ボタンをクリックすると、PreferencesダイアログのData Management – Component Typesページにアクセスできます。ここでは、新しい種類やサブタイプを追加したり、既存の種類を編集・削除したりして、ニーズに合うように一覧を調整できます。
また、Advanced Settingsコントロールをクリックすると、次の項目にアクセスできます。
-
Id – このフィールドは、Workspaceに保存されるコンポーネントのIDを指定するために使用します。File » New » ComponentコマンドまたはComponentsパネルから作成した新しいコンポーネントの場合、このフィールドには、Create new componentダイアログで選択したコンポーネントの種類に対して定義されているコンポーネントテンプレートに従って値が入力されます。テンプレートが存在しない場合、またはダイアログで
<Undefined>項目を選択した場合は、デフォルトの命名規則が使用されます(CMP-{00000})。Explorerパネルから作成した新しいコンポーネントの場合、このフィールドには、そのコンポーネントの親フォルダーに指定されているデフォルトの命名規則に従って値が入力されます。親フォルダーにコンポーネントテンプレートが関連付けられている場合は、そのテンプレートで定義されたコンポーネントの命名規則が適用されます。ソフトウェアはWorkspace全体と既存コンテンツの識別子をスキャンし、その命名規則に基づいて、次に使用可能な一意のIDを自動的に割り当てます。 -
Folder – このフィールドを使用して、対象のWorkspace内の特定のフォルダーにコンポーネントを保存します。File » New » ComponentコマンドまたはComponentsパネルから作成した新しいコンポーネントの場合、このフィールドには、Create new componentダイアログで選択したコンポーネントの種類に対して定義されているコンポーネントテンプレートに従って値が入力されます。テンプレートが存在しない場合、またはダイアログで
<Undefined>項目を選択した場合、このフィールドは空欄になります。Explorerパネルから作成した新しいコンポーネントの場合、このフィールドには、そのコンポーネントの親フォルダーが入力されます。対象のWorkspace内のどこにコンポーネントを保存するかは、自由に指定できます。保存先フォルダーを手動で指定するには、
ボタンをクリックしてChoose Folderダイアログを開きます。既存のフォルダーを参照して選択するか、その場で新しいフォルダーを作成します。
-
Template – このフィールドでは、定義済みのコンポーネントテンプレートを参照できます。フィールドをクリックすると、接続中のWorkspaceで現在利用できるすべてのコンポーネントテンプレートの一覧が表示されます。項目をクリックすると、そのコンポーネントテンプレートの表示されている(最新の)リビジョンへのリンクが作成されます。テンプレート情報がコンポーネントエディターに取り込まれます(Name、Description、Idの命名形式、Folder、Type、Models、およびParameters)。詳細については、コンポーネントテンプレートの参照を参照してください。
モデル
エディターのこの領域では、コンポーネントで使用する、保存済み(またはその場で作成した)のドメインモデルへのリンクを追加します。
モデルの操作について詳しくは、以下の折りたたみ可能なセクションを参照してください。
モデルリンクの追加
コンポーネントに必要なモデルへのリンクは、さまざまな方法で定義できます。
-
既存のモデルを選択する。モデルの種類の下にあるボタンのドロップダウンアイコンをクリックし、表示されるメニューからExistingを選択します。続いて表示されるダイアログで、必要な種類のモデルを選択します。モデルのプレビューの下にあるRevision Stateフィールドには、選択したモデルのリビジョンの現在のライフサイクル状態と、それが最新リビジョンであるか(
Up to date)、そうでないか(Out of date)が表示されます。 -
Explorerパネルからモデルを直接ドラッグ&ドロップします。

Explorerパネルからドラッグ&ドロップして、1つまたは複数のモデルを追加します。 -
新しいモデルを手動で作成します。モデルタイプの下にあるボタンのドロップダウンアイコンをクリックし、表示されるメニューからNewを選択します。対応する一時エディター(シンボルの場合は回路図シンボルエディター、 フットプリントの場合はPCBフットプリントエディター、ハーネス配線モデルの場合はハーネス配線モデルエディター)、またはSim Modelダイアログ(シミュレーションモデルの場合)が開き、モデルを定義できる状態になります。必要に応じてモデル名を 変更します。定義が完了したら、 エディターを保存して閉じるか、 ダイアログでOKをクリックします。モデルはModels領域にリンクされた状態で表示されます。モデルのプレビューの下にあるRevision Stateフィールドには、
Not releasedが表示されます。コンポーネントを保存すると、新しく定義したモデルも自動的にWorkspaceに保存され、新しいアイテムの初期リビジョンとして登録されます。
コンポーネント用の新しいモデル(この例では回路図シンボル)を手動で作成する例です。シンボルには当初、親コンポーネントにちなんでDiode_Schottkyという名前が付けられていましたが、その後Diode_Schottky_Redに変更されました。親コンポーネントを保存するまで、モデルはWorkspaceに保存されません。 -
ウィザードを使用して新しいモデルを作成します(シンボルとフットプリントのみ)。モデルタイプの下にあるボタンのドロップダウンアイコンをクリックし、表示されるメニューからWizardを選択します。この2種類のモデルの作成手順はほぼ同じで、使用するウィザードだけが異なります。
-
シンボルの場合はシンボルウィザードが表示されます。フットプリントの場合はIPC準拠フットプリントウィザードが表示されます。それぞれのウィザードを使用して、必要に応じてモデルを定義します。
-
ウィザードでの作業を完了すると、そのモデルタイプに対応する一時エディターが開き、ウィザードで生成されたモデルが読み込まれます。生成されたシンボルには、現在定義中のコンポーネント名が初期名として付けられます。必要に応じて変更してください。生成されたフットプリントモデルには、ウィザードで定義した名前が付けられます。
-
必要に応じて追加の変更を行い、エディターを保存して閉じます。モデルはModels領域にリンクされた状態で表示されます。モデルのプレビューの下にあるRevision Stateフィールドには、
Not releasedが表示されます。 -
コンポーネントをWorkspaceに保存すると、新しく定義したモデルも自動的にWorkspaceに保存され、新しいアイテムの初期リビジョンとして登録されます。
-
-
テンプレートから。コンポーネントがコンポーネントテンプレートを参照している場合、そのテンプレートに専用パラメーターとして定義されているすべてのモデル(SCHLIB および PCBLIB のみ)が、Models 領域に取り込まれます。詳細については、コンポーネントテンプレートの参照を参照してください。
-
メーカー部品検索から。メーカー部品検索からコンポーネントを作成する場合、Use Component Data ダイアログでモデルのオプションが有効になっていれば、選択した部品に定義されているモデルのうち、選択されたモデルが取り込まれます。詳細については、メーカー部品検索からのコンポーネントの作成を参照してください。
新規作成モデルの保存
新規モデルの作成先となるデフォルトのフォルダーを定義できます。また、必要に応じてデフォルト設定を上書きし、別の作成先フォルダーを指定することもできます。これにより、モデルの作成方法や保存先を、より柔軟に制御できます。
Defining Default Target Folders
新規作成モデルのデフォルトのリリース先フォルダーは、Workspace のブラウザーインターフェースの Admin – Settings – Vault – Components ページで定義します(Altium 365 Workspace、Enterprise Server Workspace)。
デフォルトのフォルダーを変更するには、Select ボタンをクリックします。Explorer ウィンドウが表示され、そのモデルタイプの新しいデフォルトのリリース先フォルダーを選択できます。選択したら、OK をクリックしてウィンドウを閉じ、Components ページに戻ります。該当するフィールドが新しいフォルダーパスで更新されます。
デフォルトのリリース先フォルダーを変更した場合は、必ずページ右上の Save ボタンをクリックしてください。
Overriding the Default Target Folder
Component Editor の Single Component Editing モードでコンポーネントを作成する際、新規作成モデルは、前述のとおり、定義されたデフォルトのリリース先フォルダーに従って Workspace に保存されます。ただし、必要に応じて、作成したモデルの保存先として特定のフォルダーを指定し、デフォルト設定を上書きできます。これを行うには、モデルのプレビューの右上にある
コントロールをクリックし、メニューから Select Target Folder を選択します。Choose Folder ダイアログ(実質的には Explorer パネルの簡略版)が表示されます。このダイアログで目的の保存先フォルダーを選択し、OK をクリックします。

別のフォルダーを選択して、モデルタイプのデフォルトのリリース先フォルダーを上書きします。
コンポーネントが未リリースの間は、選択した保存先フォルダーがモデルのプレビューウィンドウの上にテキストで表示されます。新しいモデルの保存先を確認するのに便利です。
シミュレーションモデルのリンク
シミュレーションモデルとコンポーネントのリンクは、Sim Model ダイアログで定義します。 モデルの選択と、回路図シンボルのピンとモデルのピンのマッピングは、このダイアログで行います。

Sim Model ダイアログでシミュレーションモデルを選択し、そのピン定義を回路図シンボルのピンにマッピングします。
モデルのソースの選択
Browse ボタンをクリックしてモデルを選択する前に、クリックして必要な Source モードを設定します。有効にした Source ボタンによって、Browse ボタンをクリックしたときの動作が決まります。
-
Local – ローカルハードドライブまたはネットワークサーバーに保存されているモデルファイルを参照するには、このオプションを使用します。
-
Library – Available File-based Libraries ダイアログから利用可能になっているモデルを参照するには、このオプションを使用します。
-
Server – 接続されている Workspace 内のモデルを参照するには、このオプションを使用します。
-
Octopart – Manufacturer Part Search ダイアログで利用可能なコンポーネントモデルを参照するには、このオプションを使用します(このダイアログは Manufacturer Part Search パネルと同じです)。ダイアログの Filter セクション(
)を有効にしてから、Has Simulation フィルターを検索して有効にし、シミュレーションモデルを含むコンポーネントだけが表示されるようにします。次に、メインの検索フィールドで検索し、必要なコンポーネントモデルが利用可能かどうかを確認します(
)。Manufacturer Part Search パネルではコンポーネント全体が表示されますが、設計で使用されるのは、選択したコンポーネントのシミュレーションモデルだけです。
モデルの参照と選択
ソースを選択したら、Browse ボタンをクリックしてモデルファイルを選択します。表示されるダイアログとモデルの検索方法は、有効にした Source オプションによって異なります。以下のスライドは、4 つの Source モードそれぞれで開くダイアログを示しています。
スライドは、4 つの Source モードそれぞれで表示されるダイアログを示しています。
モデルファイルを選択した後、モデルファイルに含まれるテキスト、パラメーター、情報が表示されることが、モデルの互換性と動作可能性の目安となります。この情報は、Sim Model ダイアログの Model Description 領域に表示されます。Model File タブに切り替えて、モデルの内容を確認してください。
Model File タブでモデルの Format Type オプションが正しく設定されていることを確認することも重要です。ソフトウェアはこの設定の自動検出と割り当てを試みますが、正しいことを確認してください。
モデルのピンとコンポーネントシンボルのピンのマッピング
モデルを正しく動作させるには、コンポーネントのピンとモデルのピンの対応関係を確認する必要があります。両者が一対一で対応しているとは限らないためです。ほとんどのモデルファイルでは、以下の画像に示すように、ファイル内のテキストにモデルのピン番号の説明が含まれています。この説明を参考に、各モデルピンを正しいシンボルピンにマッピングしてください。

各コンポーネントピンを、対応するモデルピンにマッピングする必要があります。
コンポーネントレベルのシミュレーションパラメーターの追加
設計内のコンポーネントにシミュレーションモデルを使用する場合、そのモデル固有のパラメーターは、次の2つのレベルで指定できます。
- Model-level parameter – シミュレーションモデル定義自体の一部として(SimModelファイル内で)指定し、その定義とともに、リンクされたシミュレーションモデルのリビジョンに保存します。
- Component-level parameter – コンポーネント定義の一部として(ここではComponent Editorで)指定し、その定義とともに、リンクされたコンポーネントのリビジョンに保存します。
モデルレベルのパラメーターを確認し、コンポーネントレベルで追加できるパラメーターを把握するには、シミュレーションモデルのプレビューウィンドウ下部にあるView Parametersコントロールをクリックします。

シミュレーションモデルのモデルレベルのパラメーターを表示して、コンポーネントレベルで追加できるパラメーターを確認します。
これらのパラメーターをコンポーネントレベルで追加するには、コンポーネントのSim Modelダイアログを開き(モデルがすでに追加されている場合は、シミュレーションモデルのプレビューウィンドウ右上にある
コントロールをクリック)、ダイアログのParametersタブで、対象のシミュレーションモデルパラメーターのShow in Componentオプションを有効にします。OKをクリックすると、選択したパラメーターがComponent EditorのParameters領域のリストに追加されます。

シミュレーション関連のパラメーターをコンポーネントレベルで追加します。一部のパラメーター(Area Factor やTemperatureなど)は、参照されているコンポーネントテンプレートによって、すでに使用可能になっています。
ストレス解析モデルの設定
Sim ModelダイアログのStressタブには、ストレス解析用のシミュレーションモデルを設定するためのコントロールがあります。ここでは、必要なDevice Typeを選択してパラメーター値を定義できるほか、ストレスモデル(ピンはあらかじめ定義されています)とシミュレーションモデル間のピンマッピングも定義できます。

コンポーネントのストレス解析モデルは、Sim ModelダイアログのStressタブで設定できます。
各デバイスタイプで使用できるストレス解析パラメーターとその説明を以下に示します。
抵抗器
| パラメーター名 | 説明 |
|---|---|
| PDM | 抵抗器の最大許容損失 |
| RV | 定格電圧 |
| TMAX | 抵抗器が耐えられる最高温度(StressグラフではTBとして表示) |
| SLP | 温度に対する許容損失の傾き |
コンデンサー
| パラメーター名 | 説明 |
|---|---|
| CI | 最大リップル |
| CV | 定格電圧 |
| CVP | 最大正方向電圧 |
| CVN | 最大逆方向電圧 |
| PDML | 直列抵抗による最大電力損失 |
| TMAX | 最高温度(StressグラフではTJLとして表示) |
| SLP | 温度ディレーティングの傾き |
| TBRK | 折点温度 |
| ESR | 等価直列抵抗 |
| RTH | 熱抵抗 |
インダクター
| パラメーター名 | 説明 |
|---|---|
| LI | 定格電流 |
| LV | 絶縁耐力 |
| PDML | 直列抵抗による最大電力損失 |
| TMAX | 最高温度(StressグラフではTJLとして表示) |
| ESR | 等価直列抵抗 |
| RTH | 熱抵抗 |
ダイオード
| パラメーター名 | 説明 |
|---|---|
| IF | 最大順方向電流 |
| IFD | 最大順方向電流 |
| IFS | 最大順方向電流 |
| IRMX | 最大逆方向電流 |
| PDM | 最大許容損失 |
| VR | 最大逆方向電圧 |
| VD | 最大逆方向電圧 |
| TJ | 最高接合温度 |
| RJC | 接合部からケースまでの熱抵抗 |
| RCA | ケースから周囲までの熱抵抗 |
BJT
| パラメーター名 | 説明 |
|---|---|
| IB | 最大ベース電流 |
| IC | 最大コレクター電流 |
| PDM | 最大許容損失 |
| VCB | 最大コレクター・ベース間電圧 |
| VCE | 最大コレクター・エミッター間電圧 |
| VEB | 最大エミッター・ベース間電圧 |
| TJ | 最高接合温度 |
| RJC | 接合部からケースまでの熱抵抗 |
| RCA | ケースから周囲までの熱抵抗 |
JFET
| パラメーター名 | 説明 |
|---|---|
| ID | 最大ドレイン電流 |
| IG | 最大順方向ゲート電流 |
| PDM | 最大許容損失 |
| VDG | 最大ドレイン・ゲート間電圧 |
| VDS | 最大ドレイン・ソース間電圧 |
| VGS | 最大ゲート・ソース間電圧 |
| TJ | 最高接合温度 |
| RJC | 接合部からケースまでの熱抵抗 |
| RCA | ケースから周囲までの熱抵抗 |
MESFET
| パラメーター名 | 説明 |
|---|---|
| ID | 最大ドレイン電流 |
| IG | 最大順方向ゲート電流 |
| PDM | 最大許容損失 |
| VDG | 最大ドレイン・ゲート間電圧 |
| VDS | 最大ドレイン・ソース間電圧 |
| VGS | 最大ゲート・ソース間電圧 |
| TJ | 最大接合温度 |
| RJC | 接合部・ケース間熱抵抗 |
| RCA | ケース・周囲間熱抵抗 |
MOSFET
| パラメーター名 | 説明 |
|---|---|
| ID | 最大ドレイン電流 |
| IG | 最大順方向ゲート電流 |
| PDM | 最大許容損失 |
| VDG | 最大ドレイン・ゲート間電圧 |
| VDS | 最大ドレイン・ソース間電圧 |
| VGSF | 最大順方向ゲート・ソース間電圧 |
| VGSR | 最大逆方向ゲート・ソース間電圧 |
| TJ | 最大接合温度 |
| RJC | 接合部・ケース間熱抵抗 |
| RCA | ケース・周囲間熱抵抗 |
スイッチ
| パラメーター名 | 説明 |
|---|---|
| PDSW | スイッチの定格電力 |
| SI | スイッチの定格電流 |
| SV | スイッチ接点の定格電圧 |
IGBT
| パラメーター名 | 説明 |
|---|---|
| IC | 最大コレクター電流 |
| IG | 最大ゲート電流 |
| PDM | 最大許容損失 |
| VCE | 最大コレクター・エミッター間電圧 |
| VCG | 最大コレクター・ゲート間電圧 |
| VGEF | 最大順方向ゲート・エミッター間電圧 |
| VGER | 最大逆方向ゲート・エミッター間電圧 |
| TJ | 最大接合温度 |
| RJC | 接合部・ケース間熱抵抗 |
| RCA | ケース・周囲間熱抵抗 |
OpAmp3
| パラメーター名 | 説明 |
|---|---|
| IPLUS | 非反転入力電流 |
| IMINUS | 反転入力電流 |
| IOUT | 出力電流 |
| VDIFF | 差動入力電圧 |
OpAmp5
| パラメーター名 | 説明 |
|---|---|
| VSMAX | 最大電源電圧差 |
| VSMIN | 最小電源電圧差 |
| VPMAX | 入力電圧(非反転)と正電源電圧の最小差 |
| VPMIN | 入力電圧(非反転)と負電源電圧の最小差 |
| VMMAX | 入力電圧(反転)と正電源電圧の最小差 |
| VMMIN | 入力電圧(反転)と負電源電圧の最小差 |
| VEEMAX | 最大負電源電圧 |
| VCCMAX | 最大正電源電圧 |
| IPLUS | 非反転入力電流 |
| IMINUS | 反転入力電流 |
| IOUT | 出力電流 |
| VDIFF | 差動入力電圧 |
電流源
| パラメーター名 | 説明 |
|---|---|
| IV | 電流源が耐えられる最大電圧 |
電圧源
| パラメーター名 | 説明 |
|---|---|
| VI | 電圧源が耐えられる最大電流 |
ブリッジ
| パラメーター名 | 説明 |
|---|---|
| IF1 | ダイオード1の最大順方向電流 |
| IF2 | ダイオード2の最大順方向電流 |
| IF3 | ダイオード3の最大順方向電流 |
| IF4 | ダイオード4の最大順方向電流 |
| PDM | 最大許容損失 |
| VR1 | ダイオード1のピーク逆電圧 |
| VR2 | ダイオード2のピーク逆電圧 |
| VR3 | ダイオード3のピーク逆電圧 |
| VR4 | ダイオード4のピーク逆電圧 |
| TJ | 最大接合温度 |
| RJC | 接合部・ケース間熱抵抗 |
| RCA | ケース・周囲間熱抵抗 |
フォトカプラー
| パラメーター名 | 説明 |
|---|---|
| IC | 最大コレクター電流 |
| IFD | 最大順方向電流 |
| PDM | 最大許容損失 |
| VCEO | 最大コレクター・エミッター間電圧 |
| VD | 最大逆電圧 |
| VECO | 最大エミッター・コレクター間電圧 |
NPNフォトカプラー
| パラメーター名 | 説明 |
|---|---|
| IC | 最大コレクター電流 |
| IFD | 最大順方向電流 |
| PDM | 最大許容損失 |
| VCEO | 最大コレクター・エミッター間電圧 |
| VD | 最大逆電圧 |
| VECO | 最大エミッター・コレクター間電圧 |
| VCBO | 最大コレクター・ベース間電圧 |
| VEBO | 最大エミッター・ベース間電圧 |
バリスター
| パラメーター名 | 説明 |
|---|---|
| ITM | ピーク電流 |
| TJ | 最大接合温度 |
| RJC | 接合部・ケース間熱抵抗 |
| RCA | ケース・周囲間熱抵抗 |
サイリスター
| パラメーター名 | 説明 |
|---|---|
| IGM | 最大ゲート電流 |
| IT | 最大アノード電流 |
| VDRM | 最大アノード・カソード間電圧 |
| VRRM | 最大カソード・アノード間電圧 |
| TJ | 最大接合温度 |
| RJC | 接合部・ケース間熱抵抗 |
| RCA | ケース・周囲間熱抵抗 |
トランス
| パラメーター名 | 説明 |
|---|---|
| Primary_Current | 一次側電流 |
| Secondary_Current | 二次側電流 |
| Isolation_Voltage | 一次側・二次側間の絶縁電圧 |
二重トランス
| パラメーター名 | 説明 |
|---|---|
| Primary_Current | 一次側電流 |
| Isolation_Voltage1 | 一次側・二次側間の絶縁電圧 |
| Isolation_Voltage2 | 一次側・二次側間の絶縁電圧 |
| Secondary_one_Current | 第1二次側電流 |
| Secondary_two_Current | 第2二次側電流 |
リンクされたモデルの直接編集
コンポーネントで現在使用(参照)されているモデルを変更するには、プレビューの右上にある
コントロールをクリックします。対応する一時エディター(シンボルの場合は 回路図シンボルエディター、フットプリントの場合は PCBフットプリントエディター)、または Sim Modelダイアログ(シミュレーションモデルの場合)が開き、必要に応じてモデルを変更できます。変更が完了したら、保存してエディターを閉じるか、ダイアログで OK をクリックします。変更したモデルは、再び Models 領域にリンクされた状態で表示されます。コンポーネントをWorkspaceに保存すると、変更したモデルも自動的にWorkspaceに保存され、親Itemの次のリビジョンになります。
モデルのコピー
参照されている既存のドメインモデルをコピーするには、モデルのプレビューの右上にある
コントロールをクリックし、メニューから Make a copy を選択します。そのモデルタイプに対応する一時エディターが開き、コピーしたモデルに必要な変更を加えられます(区別できるように新しいモデルの名前を変更することもできます)。変更が完了したら、保存してエディターを閉じるだけです。コピーしたモデルは、再び Models 領域にリンクされた状態で表示されます。モデルのプレビューの下にある Revision State フィールドには、Not released と表示されます。コンポーネントをWorkspaceに保存すると、コピーしたモデルも自動的にWorkspaceに保存され、新しいItemの初期リビジョンになります。

既存のモデルをコピーする例。これにより、最初から作り直すことなく、その場で新しいモデルをすばやく作成し、コンポーネントで使用できます。
モデルの参照
Explorerパネルでモデルをすばやく参照するには、モデルのプレビューの右上にある
コントロールをクリックし、メニューから Show in Explorer を選択します。パネルが表示される(またはフォーカスが移る)と、そのモデルとリビジョンが表示されます。
最新ではないモデル
コンポーネントをWorkspaceに保存しようとすると、Component Editorは検証(Component Rule Check)を実行します。この検証で、リンクされたモデルが最新リビジョンではないと検出された場合、検証失敗ダイアログで通知され、問題の詳細が Messages パネルに表示されます。リビジョン状態の情報は、参照されているモデルリビジョンのグラフィカルプレビューの下に表示されます。モデルの新しいリビジョンが利用可能な場合、Revision State フィールドでは、現在のリビジョンのライフサイクル状態の右側に Out of date というテキストが表示されます。最新リビジョンが参照されている場合は、Up to date と表示されます。

Component Editorによる自動コンポーネント検証チェックで、モデルが最新ではないことを検出した例。
保存をキャンセルして問題を修正するか、違反を無視してそのまま保存するかを選択できます。モデルの最新リビジョンを使用するようにリンクを更新するには、モデルのプレビューの右上にある
コントロールをクリックし、メニューから Update to Latest を選択します。
複数のフットプリントモデルのサポート
コンポーネントが参照できるシンボルは1つですが、フットプリントモデルは任意の数を参照できます。これは、異なる密度レベルのIPC要件を満たす3つのフットプリント、すなわち L(最小銅箔)、M(最大銅箔)、N(標準または中間の銅箔)を参照するコンポーネントを作成したい場合に便利な機能です。このため、フットプリントモデルをリンクした後も、Add Footprint コントロールは引き続き使用できます。最初にリンクしたフットプリントがデフォルトになり、モデルの左上にある
アイコンで識別できます。

コンポーネントは複数のフットプリントモデルを参照できます。デフォルトのフットプリント(オレンジ色で強調表示)は、左上隅のアイコンで識別できます。
モデルのピンからパッドへのクロスプローブ
シンボルとフットプリントモデルの両方をコンポーネントに追加すると、シンボルのピンとフットプリントモデルの対応するパッドの間で、クロスプローブによる視覚的なハイライト表示が可能になります。フットプリントモデルは2Dで表示する必要があり、クロスプローブは一方向(ピンからパッドへのみ)です。

編集中のコンポーネントのシンボルピンと2Dフットプリントモデルのパッド間でのクロスプローブによるハイライト表示。
モデルの削除
モデルを削除するには、モデルのプレビューの右上にある
コントロールをクリックし、メニューから Remove を選択します。
モデルの名前変更
モデルの名前を変更するには、モデルのプレビューの右上にある
コントロールをクリックし、メニューから Rename を選択します。続いて表示される Rename ダイアログで、必要に応じて名前と説明を変更し、関連するリリースノートも追加します。
ピンマッピングの編集
コンポーネントのピンマッピング(参照先の回路図シンボルのピンと、参照先のフットプリントおよびシミュレーションモデルのパッド/ピンとの対応)を表示・編集するには、モデルのプレビューの右上にある
コントロールをクリックして、Pins パネルを開きます。 このパネルでは、デフォルトの1対1のピンとパッドの対応を、1つのピンを複数のフットプリントパッドに接続する対応や、ピン番号とパッド番号が一致しないその他の対応など、カスタムの対応関係に変更できます。このパネルでは、ピンとパッドのマッピングを定義・編集し、確認できます。

Pins パネルを開き、必要に応じて、コンポーネントの各設計領域間のピンマッピングを定義します。
デフォルトでは、シンボルの番号付きピンは、参照先のフットプリントおよびシミュレーションモデルの同じ番号のパッド/ピンにマッピングされます。モデルのセルをクリックし、必要な値を入力することで、マッピング先のパッド/ピンを直接変更できます。これによりカスタムのピンマッピングが可能になり、カスタムマッピングが設定されている場合は、その設計領域のモデルのプレビューの右上に
アイコンが表示されます。
フットプリントモデルでは、デフォルトの1対1のピンとパッドの対応を変更して、1つのピンを複数のフットプリントパッドに接続したり、ピン番号とパッド番号が一致しないその他の対応関係を設定したりできます。1つのピンを複数のパッドにマッピングする場合、マッピング項目はカンマ区切りの数値形式(1,2,3,4など)で入力します。

コンポーネントのシンボルの1つのピンを、参照先のフットプリントモデルの複数のパッドにマッピングする例。
ピンをマッピングする際の注意事項:
- 対象モデルのパッド/ピンのセルを空欄にすることはできません。必ずマッピングする必要があります。
- そのモデルに存在しないパッド/ピン番号は入力できません。
- モデルのパッド/ピンを複数のシンボルピンに割り当てることはできません。
これらのいずれかに該当すると、セルに
アイコンが表示されます。該当する問題を修正してください。
パラメーター
エディターのこの領域は、コンポーネントにパラメーターデータを追加するために使用します。ここでは、次の3種類のパラメーターを手動で追加できます:
-
Parameter – 標準のユーザー定義パラメーター。
-
Link – メーカーのWebサイトやオンラインデータシートなど、WebサイトのページへのURLリンク。
-
Datasheet – Workspaceにアップロードされ、コンポーネントから参照されるデータシート(任意の形式)へのリンク。

コンポーネントにパラメーターデータを追加するためのコントロールを備えた Parameters 領域。
これらの種類のパラメーターは、必要に応じていくつでも追加できます。追加するには、領域の下部にある
ボタンのドロップダウン部分をクリックし、メニューから該当する項目を選択します。新しいパラメーターは次のようにリストに追加されます:
-
Parameter – リスト内で現在選択されている項目の下に追加されます。名前はデフォルトの形式
Parameter nになります。必要に応じて、Name フィールドをクリックして変更してください。Value フィールドをクリックし、必要な値を入力します。 - Link – リストの末尾に追加されます。Name フィールドをクリックし、必要な名前を入力します。この名前は、回路図シートに配置されたコンポーネントのインスタンスを右クリックして References サブメニューを開いたときに表示されます。対象ページのURLを Value フィールドに入力(または貼り付け)します。このURLは、対象ページにアクセスするためのハイパーリンクになります。
- Datasheet – 標準のWindowsの Open ダイアログが表示され、必要なデータシートを参照して選択できます。このダイアログでは、複数のデータシートを同時に追加できます。各データシートはリストの末尾に追加されます。Name は最初はファイル自体の名前になり、Explorer パネルに表示されるほか、コンポーネントを回路図シートに配置した後は、そのコンポーネントの References サブメニューにも表示されます。必要に応じて、より適切な表示名に変更してください。Value には、ファイルの名前、形式、およびディスク上のサイズが表示されます。これは、データシートにすばやくアクセスするためのハイパーリンクになります。
ドラッグ&ドロップによるデータシートの添付
前のセクションで説明した Open ダイアログからの手動添付に加えて、次の方法で1つ以上のデータシートをコンポーネントに添付することもできます:
-
Windowsのファイルエクスプローラーから、Parameters領域内の任意の場所にドラッグ&ドロップします。

ローカルドライブからデータシートを添付し、メインのデータシートのローカルキャプションを編集する例。 -
外部WebブラウザーのWebページから、データシートのリンクをParameters領域内の任意の場所にドラッグ&ドロップします。

Webページからデータシートを添付する例。
テンプレートパラメーター
また、コンポーネントがコンポーネントテンプレートを参照している場合、そのテンプレートで定義されているパラメーターが取り込まれ、Parameters領域に追加されます。

参照先のコンポーネントテンプレートから取り込まれたパラメーターの例。
注意事項:
-
標準のテンプレートパラメーター(読み取り専用または必須に設定されていないもの)は、Parameters領域で
アイコンにより識別されます。
-
読み取り専用に設定されたテンプレートパラメーターは、Parameters領域で
アイコンにより識別されます。
-
必須に設定されたテンプレートパラメーターは、Parameters領域で
アイコンにより識別されます。
-
辞書で定義されたテンプレートパラメーターは、Parameters領域で
アイコンにより識別されます。
- リンクされたコンポーネントテンプレートのパラメーターと同じ名前を持つ既存のユーザー定義パラメーターは、テンプレートのパラメーターに置き換えられます。そのパラメーターの既存の値は保持されます(テンプレートの値で上書きされることはありません)。
- 読み取り専用に設定されたテンプレート由来のパラメーターは、値フィールドを編集できません。読み取り専用に設定されていないその他のテンプレート由来のパラメーターは、必要に応じて自由に値を変更できます。
-
テンプレート由来のパラメーターが必須に設定されているものの、テンプレート内で値が指定されていない場合、値フィールドに
アイコンが表示され、そのパラメーターに値が必要であることを知らせます。すべての必須パラメーターに値を設定するまで、コンポーネントをWorkspaceに保存することはできません。
-
テンプレート内のパラメーターに説明が定義されている場合、コンポーネントエディターのParameters領域にDescription列が表示されます。
単位を認識するコンポーネントパラメーターのデータ型のサポート
コンポーネントエディターは、参照先のコンポーネントテンプレートで定義された、単位を認識するコンポーネントパラメーターのデータ型をサポートしています。該当するフィールドに、2.2k、2k2、4M、2.5GHzなど、さまざまな形式でパラメーターの値を直接入力できます。Workspaceには、これらの入力が表す数値を認識する機能が備わっています。
コンポーネントテンプレートのこの機能により、Workspaceの検索機能を使用した絞り込み検索が容易になります。この検索機能では、コンポーネントの種類で検索できるだけでなく、範囲を指定した、より高度な検索も可能です。単位を認識するコンポーネントパラメーターを活用すると、たとえば静電容量が47uFから220uFの間にあるすべてのコンデンサーを検索する条件をすばやく設定できます。

参照先のコンポーネントテンプレートから取り込まれた、単位を認識するデータ型を持つコンポーネントパラメーター。
単位を認識するデータ型を使用するコンポーネントパラメーターに値を入力する際は、次の点に注意してください。
-
値はさまざまな形式で入力できます。
-
数値のみ(例:
10)。データ型に単位がある場合、その単位が自動的に適用されます。単位を持つデータ型では、名前の後ろに括弧付きで単位が表示されます。 -
科学表記の数値(例:
1e10、1E6)。 -
数値と単位(例:
10F))。 -
接頭辞付きの数値(例:
10k)。該当する場合、適切な単位が自動的に追加されます。 -
接頭辞と単位付きの数値(例:
10kF)。 -
一般的な工学表記による接頭辞付きの数値(抵抗の場合の例:
2k2、2K2、10r2、10R2)。値は適切な形式に自動的に正規化されます(例:2K2は2.2kになります)。
-
数値のみ(例:
-
接頭辞や単位は、数値の後ろにスペースを入れても、入れなくても入力できます(例:
10uF、または10 uF)。スペースは自動的に削除されます。
サポートされる単位
以下の単位を認識するデータ型がサポートされています。
- ボルト(V)
- アンペア(A)
- オーム
- ファラド(F)
- ヘンリー(H)
- ワット(W)
- ヘルツ(Hz)
- 摂氏(C)
- デシベル(dB)
- パーセント(%)
- メートル(m)
- グラム(g)
- 秒(s)
サポートされる接頭辞
以下の表は、単位を認識するパラメーター型に値を入力する際に使用できる接頭辞の一覧です。
| 接頭辞 | 名称 | 値(科学表記) | 値(通常表記) |
|---|---|---|---|
| T | テラ | 1 x 1012 | 1,000,000,000,000 |
| G | ギガ | 1 x 109 | 1,000,000,000 |
| M | メガ | 1 x 106 | 1,000,000 |
| k | キロ | 1 x 103 | 1,000 |
| m | ミリ | 1 x 10-3 | 1 / 1,000 |
| u | マイクロ | 1 x 10-6 | 1 / 1,000,000 |
| n | ナノ | 1 x 10-9 | 1 / 1,000,000,000 |
| p | ピコ | 1 x 10-12 | 1 / 1,000,000,000,000 |
| f | フェムト | 1 x 10-15 | 1 / 1,000,000,000,000,000 |
パラメーター値の検証
コンポーネントパラメーターに単位対応のデータ型を使用すると、入力した値が指定されたデータ型に照らして検証されます。これにより、単位を入力する場合に、そのデータ型に適した測定単位が使用されていることを確認できます。例えば、型が Celsius のパラメーターには、10V という値を設定できません。
コンポーネントエディターでパラメーターに無効な値を入力すると、入力値が有効ではないことを知らせるダイアログが表示されます。これは、セル間で値をコピーして貼り付けた場合も同様です。ダイアログで OK をクリックすると、値は以前の入力値に戻ります。

データ検証 – コンポーネントエディターは、単位対応パラメーターに入力された値とそのデータ型の不一致を検出し、警告します。
辞書定義のコンポーネントパラメーターデータ型のサポート
コンポーネントエディターは、参照先の コンポーネントテンプレート 内で設定された、辞書定義のコンポーネントパラメーターデータ型をサポートしています。Value 列をクリックし、ドロップダウンを使用すると、辞書で定義された選択肢からパラメーターの値を選択できます。Value 列をクリックして値を入力し始めると、ドロップダウンが開き、最も近い値がリスト内で強調表示されます。

参照先のコンポーネントテンプレートに含まれる、単位対応データ型を持つコンポーネントパラメーター。
Workspaceの管理者は、Value フィールドの右側にある
アイコンをクリックすると、Workspaceのブラウザーインターフェースの Settings – Vault – Dictionaries ページを開き、辞書を管理できます。
動的(アイテムレベル)パラメーター
Altium Designerは、接続されたWorkspaceと連携して、動的パラメーター(アイテムレベルパラメーター)という概念をサポートしています。これらのパラメーターは親コンポーネントアイテムに追加され、そのリリース済みのすべてのリビジョンで使用できます。パラメーターを反映するために、アイテムを新しいリビジョンとして再リリースする必要はありません。この機能により、コンポーネントの新しいリビジョンを作成せずにコンポーネントを更新できるため、そのコンポーネントを使用している関連設計に影響を与えずに済みます。例えば、コストパラメーターの変更を、その場で動的に適用できます。
動的パラメーターは、コンポーネントエディターの Single Component Editing モードでコンポーネントアイテムのリビジョンを編集するときに確認できます。このようなパラメーターには、エディターの Parameters 領域で区別できるように、異なるアイコン(
)が表示されます。アイコンにカーソルを合わせると、Dynamic というテキストが表示されます。

コンポーネントアイテムに追加され、そのリビジョンで使用できる動的パラメーターの例。
部品候補
エディターのこの領域では、コンポーネントに対して1つ以上のPart Choicesを指定します。これは、実装基板上でそのコンポーネントを実現するために使用できる「許可された」メーカー部品です。メーカー(および部品番号)、サプライヤー(および部品番号)、説明、価格、在庫状況からなる実際のサプライチェーン情報は、WorkspaceのローカルPart Catalogと該当する部品ソースから取得されます。

定義中のコンポーネントの部品候補リストの例。1つのメーカー部品が含まれています。
コンポーネントの部品候補リストにメーカー部品を追加するには、次の2つの方法があります。
- 手動で追加する。
- メーカー部品検索の実行時に自動で追加する。詳しくは、メーカー部品検索からのコンポーネント作成を参照してください。
部品候補を手動で追加するには、この領域の下部にある
ボタンをクリックします。Add Part Choicesダイアログが表示されます。このダイアログはManufacturer Part Searchパネルと同じように使用できます(UIの各要素の詳細は、このページを参照してください)。必要なメーカー部品を検索して選択し、OKボタンをクリックします。メーカー部品のSPNsエントリ(Supplier Part Numbers)をクリックすると、その部品を取り扱うサプライヤーを確認し、在庫状況や価格などに基づいて、適切な部品候補かどうかを判断できます。

部品候補の手動追加 – Add Part Choicesダイアログで必要なメーカー部品を検索し、そのエントリを選択してOKをクリックします。
部品候補を削除するには、リストで選択し、
ボタンをクリックします。
メーカー部品検索からのコンポーネント作成
コンポーネントの作成を効率化するため、Altium DesignerではManufacturer Part Search機能を使用して実在するメーカー部品を検索し、その部品(またはそのデータの一部)をコンポーネントエディターに追加できます。これにより、コンポーネントをゼロから作成することなく、Workspaceに追加する新しいコンポーネントをすばやく定義できます。部品の名前、説明、パラメーター、データシート、部品候補、定義済みモデルなど、すべてのデータを取り込めるため、いわば「車輪の再発明」をする必要はありません。
この機能には複数の方法でアクセスできます。折りたたみ可能なセクションをクリックすると、詳細を確認できます。
いずれの場合も、Use Component Dataダイアログが開き、現在作成/編集中のコンポーネントに適用するデータ(名前、説明、パラメーター、モデル、データシート)を選択できます。コンポーネントにまだデータが定義されていない場合は、その部品で利用可能なすべてのデータが、コンポーネントへの読み込み対象としてデフォルトで有効になります。コンポーネントの名前、説明、シンボルの一部がすでに定義されている場合は、該当するオプションがダイアログでデフォルトでは無効になりますが、選択した部品のデータで置き換えることもできます。

Use Component Dataダイアログを使用して、選択した部品からコンポーネントに追加するデータを選択します。
Use Component Dataダイアログのオプションとコントロール
-
Show only matching with template – このオプションを有効にすると、コンポーネントテンプレートに一致するデータのみが表示されます。無効にすると、選択した部品で利用可能なすべてのデータが表示されます。
-
Parameter Import Options – クリックすると、Preferencesダイアログのデータ管理 – 部品プロバイダーページが開き、パラメーターのインポートオプションを設定できます。
-
Parameters (nn)、Models (nn)、Datasheets (nn) – 各タブで対応するデータを確認し、コンポーネントに含める項目を選択します。
-
Model Info – クリックすると、部品に割り当てられたモデルの詳細情報を示す領域が展開されます。コントロールの右側にあるアイコンは、モデルの品質レベルを示します。
モデルデータの詳細については、メーカー部品の検索ページを参照してください。
Nameフィールドから
Nameフィールドからは、次の2つの方法でメーカー部品検索機能にアクセスできます。
-
Typing Directly – Nameフィールドに入力を開始すると(2文字以上)、一致するメーカー部品の一覧がポップアップ表示されます(右側にメーカー名が表示されます)。使用する部品を選択してください。

必要なメーカー部品の名前を入力し、ポップアップ一覧から該当する項目を選択します。画像は、その部品のすべてのデータがコンポーネントエディターに取り込まれた状態を示しています。 -
Using the Manufacturer Part Search dialog – フィールドの右端にある
ボタンをクリックすると、Manufacturer Part Searchダイアログが開きます。必要なメーカー部品を検索し、項目を選択してから、OKボタンをクリックします。

Manufacturer Part Searchダイアログで必要なメーカー部品を検索して選択し、OKをクリックします。画像は、その部品のすべてのデータがコンポーネントエディターに取り込まれた状態を示しています。
パラメーターとテンプレートの不一致の解消
Workspaceに保存するコンポーネントとWorkspace内のテンプレートとの間でパラメーター名の不一致が検出された場合、保存時にその場で修正し、その変更をグローバル環境設定に保存できます。Use Component DataダイアログでShow only matching with templateオプションを無効にすると、すべてのコンポーネントパラメーターが表示されます。不一致が検出されたパラメーターについては、Fixコントロールを使用してParameter Mapping Configurationダイアログを開き、必要な変更を適用します。

Parameter Mapping Configurationダイアログを使用して、コンポーネントパラメーターとコンポーネントテンプレートの不一致を解消します。
コンポーネントルールチェックの実行
コンポーネントエディターで定義または編集したWorkspaceライブラリコンポーネントを、接続先のWorkspaceに保存して設計で使用できるようにする前に、そのコンポーネントが設定済みの要件を満たしていることを確認する必要があります。コンポーネントエディターは、コンポーネントをWorkspaceに保存しようとしたとき、またはこの機能を手動で実行したときに、検証(Component Rule Check)を実行します。
。
。
)というComponent Namingオプションがあります。テンプレートでこのオプションが有効になっている場合、新しいコンポーネントを作成する際にIDを編集できます。
)というDefault Folderオプションがあります。テンプレートでこのオプションが有効になっている場合、新しいコンポーネントの作成時に、そのコンポーネントの保存先フォルダーを編集できます。










)。元のモデルとコピーの両方をコンポーネントにリンクしたままにするには、Yes を選択します。元のモデルへのリンクをコピーへのリンクに置き換えるには、No を選択します。



