単一コンポーネント編集
概略
- シングルコンポーネント編集モードへのアクセス方法と、エディターの主要な領域の操作方法を確認します。
- コンポーネントの名前、説明、タイプを定義する方法や、名前と説明にパラメーターを使用する方法を学びます。
- テンプレート、命名規則、フォルダー設定が、コンポーネントの作成と保存にどのように適用されるかを理解します。
Workspaceコンポーネントは、Component Editorを使用して定義・編集します。Component Editorには、Single Component EditingとBatch Component Editingの2つのモードがあります。前者は、単一のコンポーネントを定義・編集するためのシンプルなインターフェースです。新しいコンポーネントを作成する場合や、既存のコンポーネントの単一リビジョンを編集する場合のデフォルトモードです。後者は、複数のコンポーネントを定義・編集するためのインターフェースですが、必要に応じて単一のコンポーネントの定義・編集にも使用できます。
このドキュメントでは、Component EditorをSingle Component Editingモードで使用する方法について説明します。
インターフェースの概要
Single Component Editingモードでは、Component Editorのインターフェースは基本的に4つの主要領域に分かれています。次の図に各領域を示し、その後に概要を説明します。

Single Component Editingモードで動作するComponent Editorは、4つの主要領域に分かれています。
-
コンポーネント – コンポーネントの主要なプロパティを定義する領域です。これには、Name、Description、Type、一意のId、 格納先のFolder、および必要に応じてコンポーネントテンプレートへの参照が含まれます。
-
モデル – コンポーネントで使用する、保存済みの(またはその場で作成した)ドメインモデルへのリンクを追加する領域です。
-
パラメーター – コンポーネントに適用するパラメーターデータ一式を作成する領域です。参照するコンポーネントテンプレートのパラメーターや、追加のユーザー定義パラメーターを含めることができます。ここには、データシートに加えて、WebサイトのURLへのリンクも追加できます。
-
部品候補 – コンポーネントの部品候補を検索して追加する領域です。部品候補とは、基板の製造・実装時に、設計上のコンポーネントに対して使用する実際のメーカー部品です。
コンポーネント
この領域には、次のコンポーネント属性を定義するためのコントロールがあります。
-
Name – コンポーネントに付けられた、人が読みやすい名前を表します。このシステムパラメーターはWorkspace内の検索で使用でき、インデックスも作成されるため、Item IDを覚えていなくても特定のコンポーネントを簡単に見つけられます。
名前を入力し始めると(2文字以上)、Workspaceのローカル部品カタログにあるメーカー部品の一覧がポップアップ表示されます。エントリを選択すると、選択したデータ(パラメーター、モデル、データシート)を使用してコンポーネントをすばやく定義できます。このメーカー部品検索からの作成機能は、フィールドの右端にある
ボタンを押して使用することもできます。詳細については、メーカー部品検索からのコンポーネントの作成を参照してください。
-
Description – コンポーネントに追加された説明を表します。このシステムパラメーターはWorkspace内の検索で使用でき、インデックスも作成されます。
-
Type – このフィールドではコンポーネントの種類を定義できます。これは、目的に合ったコンポーネントの検索を容易にするための重要な属性です。Componentsパネルで自分のコンポーネントを参照する際、コンポーネントのCategoriesグループ分けは、各コンポーネントに定義されたコンポーネントタイプに基づきます。フィールドをクリックすると、現在定義されているコンポーネントタイプの一覧が表示され、そこから選択できます。タイプは環境設定で定義します。フィールドの右側にある
ボタンをクリックすると、PreferencesダイアログのData Management – Component Typesページにアクセスできます。このページで、新しいタイプやサブタイプの追加、既存のタイプの編集や削除を行い、ニーズに合った一覧を作成できます。
また、Advanced Settingsコントロールをクリックすると、以下の項目にアクセスできます。
-
Id – このフィールドは、Workspaceに保存されるコンポーネントのIDを指定するために使用します。File » New » ComponentコマンドまたはComponentsパネルから新しいコンポーネントを作成した場合、このフィールドには、Create new componentダイアログで選択したコンポーネントタイプに対して定義されているコンポーネントテンプレートに従って値が入力されます。テンプレートが存在しない場合、またはダイアログで
<Undefined>項目を選択した場合は、デフォルトの命名規則(CMP-{00000})が使用されます。Explorerパネルから新しいコンポーネントを作成した場合、このフィールドには、そのコンポーネントの親フォルダーに指定されているデフォルトの命名規則に従って値が入力されます。親フォルダーにコンポーネントテンプレートが関連付けられている場合は、そのテンプレートで定義されているコンポーネントの命名設定が取り込まれます。ソフトウェアはWorkspace全体と既存コンテンツの識別子をスキャンし、その命名規則に基づいて、次に使用可能な一意のIDを自動的に割り当てます。 -
Folder – このフィールドは、保存先のWorkspace内の特定のフォルダーにコンポーネントを保存するために使用します。File » New » ComponentコマンドまたはComponentsパネルから新しいコンポーネントを作成した場合、このフィールドには、Create new componentダイアログで選択したコンポーネントタイプに対して定義されているコンポーネントテンプレートに従って値が入力されます。テンプレートが存在しない場合、またはダイアログで
<Undefined>項目を選択した場合、このフィールドは空白になります。Explorerパネルから新しいコンポーネントを作成した場合、このフィールドには、そのコンポーネントの親フォルダーが入力されます。保存先のWorkspace内でコンポーネントをどこに保存するかは、自由に指定できます。保存先フォルダーを手動で指定するには、
ボタンをクリックしてChoose Folderダイアログにアクセスします。既存のフォルダーを参照して選択するか、その場で新しいフォルダーを作成してください。
-
Template – このフィールドでは、定義済みのコンポーネントテンプレートを参照できます。フィールドをクリックすると、接続中のWorkspaceで現在利用可能なすべてのコンポーネントテンプレートの一覧が表示されます。項目をクリックすると、そのコンポーネントテンプレートの表示されている(最新の)リビジョンへのリンクが作成されます。テンプレートの情報(Name、Description、Idの命名形式、Folder、Type、Models、Parameters)がコンポーネントエディターに取り込まれます。詳細については、コンポーネントテンプレートの参照を参照してください。
モデル
エディターのこの領域では、コンポーネントで使用する、保存済みの(またはその場で作成した)ドメインモデルへのリンクを追加します。
モデルの操作について詳しくは、以下の折りたたみ式セクションを参照してください。
モデルリンクの追加
コンポーネントに必要なモデルへのリンクは、さまざまな方法で定義できます。
-
既存のモデルを選択する。モデルタイプの下にあるボタンのドロップダウンアイコンをクリックし、表示されるメニューからExistingを選択します。続いて表示されるダイアログで、必要なタイプのモデルを選択します。モデルのプレビューの下にあるRevision Stateフィールドには、選択したモデルのリビジョンの現在のライフサイクル状態と、それが最新リビジョンであるか(
Up to date)、そうでないか(Out of date)が表示されます。 -
Explorer パネルからモデルを直接ドラッグ&ドロップします。

Explorer パネルからドラッグ&ドロップして、1 つまたは複数のモデルを追加します。 -
新しいモデルを手動で作成します。モデルタイプの下にあるボタンのドロップダウンアイコンをクリックし、表示されるメニューから New を選択します。対応する一時エディター(シンボルの場合は回路図シンボルエディター、フットプリントの場合はPCB フットプリントエディター、ハーネス配線モデルの場合はハーネス配線モデルエディター)、またはシミュレーションモデルの場合は Sim Model ダイアログが開き、モデルを定義できる状態になります。必要に応じてモデル名を変更します。定義が完了したら、エディターを保存して閉じるか、ダイアログで OK をクリックします。モデルは Models 領域にリンクされた状態で表示されます。モデルのプレビューの下にある Revision State フィールドには
Not releasedと表示されます。コンポーネントを保存すると、新しく定義したモデルも、新しいアイテムの初期リビジョンとして Workspace に自動的に保存されます。
コンポーネントの新しいモデル(この例では回路図シンボル)を手動で作成する例。シンボルには当初、親コンポーネントにちなんでDiode_Schottkyという名前が付けられていましたが、その後Diode_Schottky_Redに変更されました。親コンポーネントを保存するまで、モデルは Workspace に保存されません。 -
ウィザードを使用して新しいモデルを作成します(シンボルとフットプリントのみ)。モデルタイプの下にあるボタンのドロップダウンアイコンをクリックし、表示されるメニューから Wizard を選択します。この 2 種類のモデルの作成手順は、使用するウィザードが異なるだけで、ほぼ同じです。
-
シンボルの場合はシンボルウィザードが表示されます。フットプリントの場合は IPC 準拠フットプリントウィザードが表示されます。それぞれのウィザードを使用して、必要に応じたモデルを定義します。
-
ウィザードを完了すると、モデルタイプに対応する一時エディターが開き、ウィザードで生成されたモデルが読み込まれます。生成されたシンボルには、現在定義しているコンポーネントの名前が初期名として付けられます。必要に応じて変更してください。生成されたフットプリントモデルには、ウィザードで定義した名前が付けられます。
-
必要に応じて追加の変更を行い、エディターを保存して閉じます。モデルは Models 領域にリンクされた状態で表示されます。モデルのプレビューの下にある Revision State フィールドには
Not releasedと表示されます。 -
コンポーネントを Workspace に保存すると、新しく定義したモデルも、新しいアイテムの初期リビジョンとして Workspace に自動的に保存されます。
-
-
テンプレートから。コンポーネントがコンポーネントテンプレートを参照している場合、そのテンプレートで専用パラメーターとして定義されているすべてのモデル(SCHLIB および PCBLIB のみ)が、Models 領域に取り込まれます。詳細については、コンポーネントテンプレートの参照を参照してください。
-
メーカー部品検索から。メーカー部品検索からコンポーネントを作成し、Use Component Data ダイアログでモデルのオプションが有効になっている場合、選択した部品に定義されているモデルのうち、選択されたものが取り込まれます。詳細については、メーカー部品検索からのコンポーネントの作成を参照してください。
新規作成モデルの保存
新規モデルの作成先となるデフォルトのターゲットフォルダーを定義できます。また、必要に応じてデフォルト設定を上書きし、別のターゲットフォルダーを指定することもできます。これにより、モデルの作成方法と保存先を、より柔軟に管理できます。
Defining Default Target Folders
新規作成モデルのデフォルトのリリース先フォルダーは、Workspace のブラウザーインターフェースの Admin – Settings – Vault – Components ページで定義します(Altium 365 Workspace、Enterprise Server Workspace)。
デフォルトのフォルダーを変更するには、Select ボタンをクリックします。Explorer ウィンドウが表示され、そのモデルタイプの新しいデフォルトのリリース先フォルダーを選択できます。選択後、OK をクリックするとウィンドウが閉じ、Components ページに戻ります。該当するフィールドは、新しいフォルダーパスに更新されます。
デフォルトのリリース先フォルダーを変更した場合は、必ずページ右上の Save ボタンをクリックしてください。
Overriding the Default Target Folder
Component Editor の Single Component Editing モードでコンポーネントを作成する際、新規作成モデルは、前述のデフォルトのリリース先フォルダーの設定に従って Workspace に保存されます。ただし、必要に応じて、作成したモデルを保存する特定のフォルダーを指定し、デフォルト設定を上書きできます。これを行うには、モデルのプレビューの右上にある
コントロールをクリックし、メニューから Select Target Folder を選択します。Choose Folder ダイアログ(基本的には Explorer パネルを簡略化したもの)が表示されます。このダイアログで目的のターゲットフォルダーを選択し、OK をクリックします。

別のフォルダーを選択して、モデルタイプのデフォルトのリリース先フォルダーを上書きします。
コンポーネントが未リリースの間は、選択したターゲットフォルダーがモデルのプレビューウィンドウの上にテキストで表示されるため、新しいモデルの保存先を簡単に確認できます。
シミュレーションモデルのリンク
コンポーネントへのシミュレーションモデルのリンクは、Sim Model ダイアログで定義します。このダイアログでは、モデルの選択と、回路図シンボルのピンからモデルのピンへのマッピングを行います。

Sim Model ダイアログでシミュレーションモデルを選択し、そのピン定義を回路図シンボルのピンにマッピングします。
モデルのソースの選択
Browse ボタンをクリックしてモデルを選択する前に、クリックして必要な Source モードを設定します。有効にした Source ボタンによって、Browse ボタンをクリックしたときの動作が決まります。
-
Local – ローカルのハードドライブまたはネットワークサーバーに保存されているモデルファイルを参照する場合は、このオプションを使用します。
-
Library – Available File-based Libraries ダイアログを通じて利用可能になっているモデルを参照する場合は、このオプションを使用します。
-
Server – 接続されている Workspace 内のモデルを参照する場合は、このオプションを使用します。
-
Octopart – Manufacturer Part Search ダイアログで利用できるコンポーネントモデルを参照する場合は、このオプションを使用します(このダイアログは Manufacturer Part Search パネルと同じです)。ダイアログの Filter セクション(
)を有効にしてから、Has Simulation フィルターを探して有効にし、シミュレーションモデルを含むコンポーネントのみが検索結果に表示されるようにします。次に、メインの検索フィールドで検索し、必要なコンポーネントモデルが利用可能かどうかを確認します(
)。Manufacturer Part Search パネルではコンポーネント全体が検索結果として返されますが、設計で使用されるのは、選択したコンポーネントのシミュレーションモデルのみです。
モデルの参照と選択
ソースを選択したら、Browse ボタンをクリックしてモデルファイルを選択します。表示されるダイアログと、モデルを探す手順は、有効にした Source オプションによって異なります。以下のスライドは、4 つの Source モードそれぞれで開くダイアログを示しています。
スライドは、4 つの Source モードそれぞれで表示されるダイアログを示しています。
モデルファイルを選択した後、そのファイルに含まれるテキスト、パラメーター、情報が表示されれば、モデルに互換性があり動作可能であることの目安になります。この情報は、Sim Model ダイアログの Model Description 領域に表示されます。Model File タブに切り替えて、モデルの内容を確認します。
また、Model File タブでモデルの Format Type オプションが正しく設定されていることを確認することも重要です。ソフトウェアはこの設定を自動的に検出して割り当てようとしますが、正しいことを確認してください。
モデルのピンとコンポーネントシンボルのピンのマッピング
モデルを正しく動作させるには、コンポーネントのピンとモデルのピンの対応関係を確認する必要があります。両者が一対一に対応しているとは限らないためです。ほとんどのモデルファイルでは、以下の画像に示すように、ファイル内のテキストにモデルのピン番号の説明が含まれています。この情報を使用して、各モデルピンを正しいシンボルピンにマッピングしてください。

各コンポーネントピンは、対応するモデルピンにマッピングする必要があります。
コンポーネントレベルのシミュレーションパラメーターの追加
設計内のコンポーネントにシミュレーションモデルを使用する場合、そのモデル固有のパラメーターを次の2つのレベルで指定できます。
- Model-level parameter – シミュレーションモデル定義自体の一部として(SimModelファイル内で)指定し、その定義とともに、リンクされたシミュレーションモデルのリビジョンに保存します。
- Component-level parameter – コンポーネント定義の一部として(ここではComponent Editorで)指定し、その定義とともに、リンクされたコンポーネントのリビジョンに保存します。
モデルレベルのパラメーターを表示し、コンポーネントレベルで追加できるパラメーターを確認するには、シミュレーションモデルのプレビューウィンドウ下部にあるView Parametersコントロールをクリックします。

シミュレーションモデルのモデルレベルのパラメーターを表示して、コンポーネントレベルで追加できるパラメーターを確認します。
これらと同じパラメーターをコンポーネントレベルで追加するには、コンポーネントのSim Modelダイアログを開き(モデルをすでに追加している場合は、シミュレーションモデルのプレビューウィンドウ右上にある
コントロールをクリック)、ダイアログのParametersタブで、対象のシミュレーションモデルパラメーターのShow in Componentオプションを有効にします。OKをクリックすると、選択したパラメーターがComponent EditorのParameters領域のリストに追加されます。

シミュレーション関連のパラメーターをコンポーネントレベルで追加します。一部のパラメーター(Area Factor やTemperatureなど)は、参照されているコンポーネントテンプレートによって、すでに使用可能になっています。
ストレス解析モデルの設定
Sim ModelダイアログのStressタブには、ストレス解析用のシミュレーションモデルを設定するためのコントロールが用意されています。ここでは、必要なDevice Typeを選択してパラメーター値を定義できるほか、ストレスモデル(ピンは定義済み)とシミュレーションモデル間のピンマッピングを定義できます。

コンポーネントのストレス解析モデルは、Sim ModelダイアログのStressタブで設定できます。
各デバイスタイプで使用できるストレス解析パラメーターとその説明を以下に示します。
抵抗器
| パラメーター名 | 説明 |
|---|---|
| PDM | 抵抗器の最大許容損失 |
| RV | 定格電圧 |
| TMAX | 抵抗器の最高許容温度(StressグラフではTBとして表示) |
| SLP | 温度に対する許容損失の傾き |
コンデンサー
| パラメーター名 | 説明 |
|---|---|
| CI | 最大リップル |
| CV | 定格電圧 |
| CVP | 最大正方向電圧 |
| CVN | 最大逆方向電圧 |
| PDML | 直列抵抗による最大電力損失 |
| TMAX | 最高温度(StressグラフではTJLとして表示) |
| SLP | 温度ディレーティングの傾き |
| TBRK | 折れ点温度 |
| ESR | 等価直列抵抗 |
| RTH | 熱抵抗 |
インダクター
| パラメーター名 | 説明 |
|---|---|
| LI | 定格電流 |
| LV | 耐電圧 |
| PDML | 直列抵抗による最大電力損失 |
| TMAX | 最高温度(StressグラフではTJLとして表示) |
| ESR | 等価直列抵抗 |
| RTH | 熱抵抗 |
ダイオード
| パラメーター名 | 説明 |
|---|---|
| IF | 最大順方向電流 |
| IFD | 最大順方向電流 |
| IFS | 最大順方向電流 |
| IRMX | 最大逆方向電流 |
| PDM | 最大許容損失 |
| VR | 最大逆方向電圧 |
| VD | 最大逆方向電圧 |
| TJ | 最高接合温度 |
| RJC | 接合部-ケース間熱抵抗 |
| RCA | ケース-周囲間熱抵抗 |
BJT
| パラメーター名 | 説明 |
|---|---|
| IB | 最大ベース電流 |
| IC | 最大コレクター電流 |
| PDM | 最大許容損失 |
| VCB | 最大コレクター-ベース間電圧 |
| VCE | 最大コレクター-エミッター間電圧 |
| VEB | 最大エミッター-ベース間電圧 |
| TJ | 最高接合温度 |
| RJC | 接合部-ケース間熱抵抗 |
| RCA | ケース-周囲間熱抵抗 |
JFET
| パラメーター名 | 説明 |
|---|---|
| ID | 最大ドレイン電流 |
| IG | 最大順方向ゲート電流 |
| PDM | 最大許容損失 |
| VDG | 最大ドレイン-ゲート間電圧 |
| VDS | 最大ドレイン-ソース間電圧 |
| VGS | 最大ゲート-ソース間電圧 |
| TJ | 最高接合温度 |
| RJC | 接合部-ケース間熱抵抗 |
| RCA | ケース-周囲間熱抵抗 |
MESFET
| パラメーター名 | 説明 |
|---|---|
| ID | 最大ドレイン電流 |
| IG | 最大順方向ゲート電流 |
| PDM | 最大許容損失 |
| VDG | 最大ドレイン・ゲート間電圧 |
| VDS | 最大ドレイン・ソース間電圧 |
| VGS | 最大ゲート・ソース間電圧 |
| TJ | 最大接合温度 |
| RJC | 接合部・ケース間熱抵抗 |
| RCA | ケース・周囲間熱抵抗 |
MOSFET
| パラメーター名 | 説明 |
|---|---|
| ID | 最大ドレイン電流 |
| IG | 最大順方向ゲート電流 |
| PDM | 最大許容損失 |
| VDG | 最大ドレイン・ゲート間電圧 |
| VDS | 最大ドレイン・ソース間電圧 |
| VGSF | 最大順方向ゲート・ソース間電圧 |
| VGSR | 最大逆方向ゲート・ソース間電圧 |
| TJ | 最大接合温度 |
| RJC | 接合部・ケース間熱抵抗 |
| RCA | ケース・周囲間熱抵抗 |
スイッチ
| パラメーター名 | 説明 |
|---|---|
| PDSW | スイッチの定格電力 |
| SI | スイッチの定格電流 |
| SV | スイッチの定格接点電圧 |
IGBT
| パラメーター名 | 説明 |
|---|---|
| IC | 最大コレクター電流 |
| IG | 最大ゲート電流 |
| PDM | 最大許容損失 |
| VCE | 最大コレクター・エミッター間電圧 |
| VCG | 最大コレクター・ゲート間電圧 |
| VGEF | 最大順方向ゲート・エミッター間電圧 |
| VGER | 最大逆方向ゲート・エミッター間電圧 |
| TJ | 最大接合温度 |
| RJC | 接合部・ケース間熱抵抗 |
| RCA | ケース・周囲間熱抵抗 |
OpAmp3
| パラメーター名 | 説明 |
|---|---|
| IPLUS | 非反転入力電流 |
| IMINUS | 反転入力電流 |
| IOUT | 出力電流 |
| VDIFF | 差動入力電圧 |
OpAmp5
| パラメーター名 | 説明 |
|---|---|
| VSMAX | 最大電源電圧差 |
| VSMIN | 最小電源電圧差 |
| VPMAX | 入力電圧(非反転)と正電源電圧の最小差 |
| VPMIN | 入力電圧(非反転)と負電源電圧の最小差 |
| VMMAX | 入力電圧(反転)と正電源電圧の最小差 |
| VMMIN | 入力電圧(反転)と負電源電圧の最小差 |
| VEEMAX | 最大負電源電圧 |
| VCCMAX | 最大正電源電圧 |
| IPLUS | 非反転入力電流 |
| IMINUS | 反転入力電流 |
| IOUT | 出力電流 |
| VDIFF | 差動入力電圧 |
電流源
| パラメーター名 | 説明 |
|---|---|
| IV | 電流源が耐えられる最大電圧 |
電圧源
| パラメーター名 | 説明 |
|---|---|
| VI | 電圧源が耐えられる最大電流 |
ブリッジ
| パラメーター名 | 説明 |
|---|---|
| IF1 | ダイオード1の最大順方向電流 |
| IF2 | ダイオード2の最大順方向電流 |
| IF3 | ダイオード3の最大順方向電流 |
| IF4 | ダイオード4の最大順方向電流 |
| PDM | 最大許容損失 |
| VR1 | ダイオード1のピーク逆電圧 |
| VR2 | ダイオード2のピーク逆電圧 |
| VR3 | ダイオード3のピーク逆電圧 |
| VR4 | ダイオード4のピーク逆電圧 |
| TJ | 最大接合温度 |
| RJC | 接合部・ケース間熱抵抗 |
| RCA | ケース・周囲間熱抵抗 |
フォトカプラー
| パラメーター名 | 説明 |
|---|---|
| IC | 最大コレクター電流 |
| IFD | 最大順方向電流 |
| PDM | 最大許容損失 |
| VCEO | 最大コレクター・エミッター間電圧 |
| VD | 最大逆電圧 |
| VECO | 最大エミッター・コレクター間電圧 |
NPNフォトカプラー
| パラメーター名 | 説明 |
|---|---|
| IC | 最大コレクター電流 |
| IFD | 最大順方向電流 |
| PDM | 最大許容損失 |
| VCEO | 最大コレクター・エミッター間電圧 |
| VD | 最大逆電圧 |
| VECO | 最大エミッター・コレクター間電圧 |
| VCBO | 最大コレクター・ベース間電圧 |
| VEBO | 最大エミッター・ベース間電圧 |
バリスター
| パラメーター名 | 説明 |
|---|---|
| ITM | ピーク電流 |
| TJ | 最大接合温度 |
| RJC | 接合部・ケース間熱抵抗 |
| RCA | ケース・周囲間熱抵抗 |
サイリスター
| パラメーター名 | 説明 |
|---|---|
| IGM | 最大ゲート電流 |
| IT | 最大アノード電流 |
| VDRM | 最大アノード・カソード間電圧 |
| VRRM | 最大カソード・アノード間電圧 |
| TJ | 最大接合温度 |
| RJC | 接合部・ケース間熱抵抗 |
| RCA | ケース・周囲間熱抵抗 |
トランス
| パラメーター名 | 説明 |
|---|---|
| Primary_Current | 一次側電流 |
| Secondary_Current | 二次側電流 |
| Isolation_Voltage | 一次側と二次側の間の絶縁電圧 |
二次巻線が2つのトランス
| パラメーター名 | 説明 |
|---|---|
| Primary_Current | 一次側電流 |
| Isolation_Voltage1 | 一次側と二次側の間の絶縁電圧 |
| Isolation_Voltage2 | 一次側と二次側の間の絶縁電圧 |
| Secondary_one_Current | 第1二次側電流 |
| Secondary_two_Current | 第2二次側電流 |
リンクされたモデルの直接編集
コンポーネントで現在使用(参照)されているモデルを変更するには、プレビューの右上にある
コントロールをクリックします。対応する一時エディター(シンボルの場合は 回路図シンボルエディター、フットプリントの場合は PCBフットプリントエディター)、または Sim Modelダイアログ(シミュレーションモデルの場合)が開き、必要に応じてモデルを変更できます。編集が完了したら、保存してエディターを閉じるか、ダイアログで OK をクリックします。変更したモデルが Models 領域に再びリンクされて表示されます。コンポーネントをWorkspaceに保存すると、変更したモデルも自動的にWorkspaceに保存され、その親アイテムの次のリビジョンになります。
モデルのコピー
参照されている既存のドメインモデルをコピーするには、モデルのプレビューの右上にある
コントロールをクリックし、メニューから Make a copy を選択します。そのモデルタイプに対応する一時エディターが開き、コピーされたモデルを必要に応じて変更できます(区別できるように新しいモデルの名前を変更することもできます)。編集が完了したら、保存してエディターを閉じます。コピーされたモデルが Models 領域に再びリンクされて表示されます。モデルのプレビューの下にある Revision State フィールドには、Not released と表示されます。コンポーネントをWorkspaceに保存すると、コピーされたモデルも自動的にWorkspaceに保存され、新しいアイテムの初期リビジョンになります。

既存のモデルをコピーする例。最初から作り直すことなく、その場で新しいモデルをすばやく作成し、コンポーネントで使用できます。
モデルの参照
Explorerパネルでモデルをすばやく表示するには、モデルのプレビューの右上にある
コントロールをクリックし、メニューから Show in Explorer を選択します。パネルが開くか、既に開いているパネルにフォーカスが移り、そのモデルとリビジョンが表示されます。
最新ではないモデル
コンポーネントをWorkspaceに保存しようとすると、コンポーネントエディターによって検証(Component Rule Check)が実行されます。このとき、リンクされたモデルが最新のリビジョンではないことをエディターが検出すると、検証失敗ダイアログで通知され、問題の詳細が Messages パネルに表示されます。リビジョンの状態情報は、参照されているモデルのリビジョンのグラフィカルプレビューの下に表示されます。モデルに新しいリビジョンがある場合、Revision State フィールドでは、現在のリビジョンのライフサイクル状態の右側に Out of date というテキストが表示されます。最新のリビジョンが参照されている場合は、Up to date と表示されます。

コンポーネントエディターによる自動コンポーネント検証チェックで、モデルが最新ではないことを検出する例。
保存をキャンセルして問題を修正するか、違反を無視してそのまま保存するかを選択できます。モデルの最新リビジョンを使用するようにリンクを更新するには、モデルのプレビューの右上にある
コントロールをクリックし、メニューから Update to Latest を選択します。
複数のフットプリントモデルへの対応
コンポーネントが参照できるシンボルは1つですが、フットプリントモデルは任意の数を参照できます。これは、異なる密度レベルのIPC要件を満たす3つのフットプリント、すなわち L(銅箔量が最小)、M(銅箔量が最大)、N(銅箔量が標準または中間)を参照するコンポーネントを作成したい場合に便利な機能です。このため、フットプリントモデルをリンクした後も、Add Footprint コントロールは引き続き使用できます。最初にリンクしたフットプリントがデフォルトとなり、モデルの左上にある
アイコンで識別できます。

コンポーネントは複数のフットプリントモデルを参照できます。デフォルトのフットプリント(オレンジ色で強調表示)は、左上隅のアイコンで識別できます。
モデルのピンからパッドへのクロスプローブ
コンポーネントにシンボルとフットプリントモデルの両方を追加すると、そのシンボルのピンとフットプリントモデルの対応するパッドとの間で、クロスプローブによる視覚的なハイライト表示を使用できます。フットプリントモデルは2Dで表示する必要があり、クロスプローブは一方向のみ(ピンからパッドのみ)に対応しています。

編集中のコンポーネントで、シンボルのピンと2Dフットプリントモデルのパッド間をクロスプローブでハイライト表示する例。
モデルの削除
モデルを削除するには、モデルのプレビューの右上にある
コントロールをクリックし、メニューから Remove を選択します。
モデルの名前変更
モデルの名前を変更するには、モデルのプレビューの右上にある
コントロールをクリックし、メニューから Rename を選択します。続いて表示される Rename ダイアログで、必要に応じて名前と説明を変更し、関連するリリースノートも追加します。
ピンマッピングの編集
コンポーネントのピンマッピング(参照先の回路図シンボルのピンと、参照先のフットプリントおよびシミュレーションモデルのパッド/ピンとの対応関係)を表示・編集するには、モデルのプレビューの右上にある
コントロールをクリックして、Pins パネルを開きます。 このパネルでは、デフォルトの1対1のピンとパッドのマッピングを、1つのピンを複数のフットプリントパッドに接続するなど、ピン番号とパッド番号が一致しない任意の対応関係に変更できます。このパネルでは、 ピンとパッド間のマッピングを定義・編集・表示できます。

Pins パネルを開き、必要に応じて、コンポーネントの各設計ドメイン間のピンマッピングを定義します。
デフォルトでは、シンボルの番号付きピンは、参照先のフットプリントおよびシミュレーションモデルの同じ番号のパッド/ピンにマッピングされます。モデルのセルをクリックして必要な値を入力することで、マッピング先のパッド/ピンを直接変更できます。これにより、カスタムのピンマッピングが可能になります。カスタムマッピングを設定すると、該当するドメインモデルのプレビューの右上に
アイコンが表示されます。
フットプリントモデルでは、デフォルトの1対1のピンとパッドのマッピングを変更して、1つのピンを複数のフットプリントパッドに接続したり、ピン番号とパッド番号が一致しない任意の対応関係を設定したりできます。1つのピンを複数のパッドにマッピングする場合は、カンマ区切りの数値形式(1,2,3,4など)で入力します。

コンポーネントのシンボルの1つのピンを、参照先のフットプリントモデルの複数のパッドにマッピングする例。
ピンをマッピングする際の注意事項:
- 対象モデルのパッド/ピンのセルは空欄にできません。必ずマッピングする必要があります。
- モデルに存在しないパッド/ピン番号は入力できません。
- モデルのパッド/ピンを複数のシンボルピンに割り当てることはできません。
これらのいずれかに該当すると、セルに
アイコンが表示されます。該当する問題を修正してください。
パラメーター
エディターのこの領域では、コンポーネントにパラメーターデータを追加します。ここでは、次の3種類のパラメーターを手動で追加できます。
-
Parameter – 標準のユーザー定義パラメーター。
-
Link – メーカーのWebサイトやオンラインデータシートなど、WebページへのURLリンク。
-
Datasheet – Workspaceにアップロードされ、コンポーネントから参照されるデータシート(任意の形式)へのリンク。

コンポーネントにパラメーターデータを追加するためのコントロールを備えた Parameters 領域。
これらの種類のパラメーターは、必要に応じていくつでも追加できます。追加するには、領域の下部にある
ボタンのドロップダウン部分をクリックし、メニューから該当する項目を選択します。新しいパラメーターは、次のようにリストに追加されます。
-
Parameter – リストで現在選択されている項目の下に追加されます。名前はデフォルトの
Parameter n形式になります。必要に応じて、Name フィールドをクリックして変更します。Value フィールドをクリックし、必要な値を入力します。 - Link – リストの末尾に追加されます。Name フィールドをクリックして、必要な名前を入力します。この名前は、回路図シートに配置されたコンポーネントのインスタンスを右クリックして References サブメニューを開いたときに表示されます。Value フィールドに、リンク先ページのURLを入力(または貼り付け)します。これはハイパーリンクとなり、リンク先にアクセスできます。
- Datasheet – 標準のWindowsの Open ダイアログが表示され、必要なデータシートを参照して選択できます。このダイアログでは、複数のデータシートを同時に追加できます。各データシートはリストの末尾に追加されます。Name には、最初はファイル自体の名前が設定され、Explorer パネルや、回路図シートに配置したコンポーネントの References サブメニューに表示されます。必要に応じて、より適切なキャプションに変更してください。Value には、ファイルの名前、形式、ディスク上のサイズが表示されます。これはハイパーリンクとなり、データシートにすばやくアクセスできます。
ドラッグ&ドロップによるデータシートの添付
前のセクションで説明した Open ダイアログからの手動添付に加えて、次の方法でも1つ以上のデータシートをコンポーネントに添付できます。
-
WindowsのエクスプローラーからParameters領域内の任意の場所にドラッグ&ドロップします。

ローカルドライブからデータシートを添付し、メインのデータシートのローカルキャプションを編集する例。 -
外部のWebブラウザーで開いたWebページから、データシートのリンクをParameters領域内の任意の場所にドラッグ&ドロップします。

Webページからデータシートを添付する例。
テンプレートパラメーター
また、コンポーネントがコンポーネントテンプレートを参照している場合、そのテンプレートで定義されているパラメーターが取り込まれ、Parameters領域に追加されます。

参照先のコンポーネントテンプレートに含まれるパラメーターの例。
注意事項:
-
標準のテンプレートパラメーター(読み取り専用または必須に指定されていないもの)は、Parameters領域で
アイコンによって識別されます。
-
読み取り専用に指定されたテンプレートパラメーターは、Parameters領域で
アイコンによって識別されます。
-
必須に指定されたテンプレートパラメーターは、Parameters領域で
アイコンによって識別されます。
-
辞書で定義されたテンプレートパラメーターは、Parameters領域で
アイコンによって識別されます。
- リンクされたコンポーネントテンプレート内のパラメーターと同じ名前を持つ既存のユーザー定義パラメーターは、テンプレートのパラメーターに置き換えられます。そのパラメーターの既存の値は保持されます(テンプレート内の値で上書きされることはありません)。
- 読み取り専用に指定されたテンプレートベースのパラメーターの値フィールドは編集できません。読み取り専用に指定されていない、その他すべてのテンプレートベースのパラメーターについては、必要に応じて自由に値を変更できます。
-
テンプレートベースのパラメーターが必須に指定されているにもかかわらず、テンプレートで値が設定されていない場合、その値フィールドに
アイコンが表示され、そのパラメーターに値が必要であることを知らせます。すべての必須パラメーターに値を設定するまで、コンポーネントをWorkspaceに保存することはできません。
-
テンプレート内のパラメーターに説明が定義されている場合、コンポーネントエディターのParameters領域にDescription列が表示されます。
単位を認識するコンポーネントパラメーターのデータ型のサポート
コンポーネントエディターは、参照先のコンポーネントテンプレートで定義された、単位を認識するコンポーネントパラメーターのデータ型をサポートしています。該当するフィールドに、2.2k、2k2、4M、2.5GHzなどのさまざまな形式でパラメーターの値を直接入力できます。Workspaceには、これらの入力が表す数値を認識する機能が備わっています。
コンポーネントテンプレートのこの機能により、Workspaceの検索機能を使用して、的を絞った検索ができます。この検索機能では、コンポーネントの種類による検索だけでなく、範囲を指定した、より高度な検索も可能です。単位を認識するコンポーネントパラメーターを活用すれば、たとえば静電容量が47uF~220uFのすべてのコンデンサーを検索する条件をすばやく設定できます。

参照先のコンポーネントテンプレートに含まれる、単位を認識するデータ型を持つコンポーネントパラメーター。
単位を認識するデータ型を使用するコンポーネントパラメーターに値を入力する際は、以下の点に注意してください。
-
値はさまざまな形式で入力できます。
-
数値のみ(例:
10)。データ型に単位がある場合は、その単位が自動的に適用されます。単位を持つデータ型では、名前の後の括弧内に単位が表示されます。 -
科学表記の数値(例:
1e10、1E6)。 -
数値と単位(例:
10F))。 -
接頭辞付きの数値(例:
10k)。該当する場合は、適切な単位が自動的に追加されます。 -
接頭辞と単位が付いた数値(例:
10kF)。 -
一般的な工学表記形式の接頭辞付き数値(抵抗値の例:
2k2、2K2、10r2、10R2)。値は自動的に適切な形式に正規化されます(例:2K2は2.2kになります)。
-
数値のみ(例:
-
接頭辞や単位は、数値の後にスペースを入れても入れなくても入力できます(例:
10uFまたは10 uF)。スペースは自動的に削除されます。
サポートされる単位
以下の単位を認識するデータ型がサポートされています。
- ボルト(V)
- アンペア(A)
- オーム
- ファラド(F)
- ヘンリー(H)
- ワット(W)
- ヘルツ(Hz)
- 摂氏(C)
- デシベル(dB)
- パーセント(%)
- メートル(m)
- グラム(g)
- 秒(s)
サポートされる接頭辞
次の表は、単位を認識するパラメーター型に値を入力する際に使用できる接頭辞の一覧です。
| 接頭辞 | 名称 | 値(科学表記) | 値(通常表記) |
|---|---|---|---|
| T | テラ | 1 x 1012 | 1,000,000,000,000 |
| G | ギガ | 1 x 109 | 1,000,000,000 |
| M | メガ | 1 x 106 | 1,000,000 |
| k | キロ | 1 x 103 | 1,000 |
| m | ミリ | 1 x 10-3 | 1 / 1,000 |
| u | マイクロ | 1 x 10-6 | 1 / 1,000,000 |
| n | ナノ | 1 x 10-9 | 1 / 1,000,000,000 |
| p | ピコ | 1 x 10-12 | 1 / 1,000,000,000,000 |
| f | フェムト | 1 x 10-15 | 1 / 1,000,000,000,000,000 |
パラメーター値の検証
コンポーネントパラメーターに単位対応のデータ型を使用すると、入力した値が指定のデータ型に照らして検証されます。これにより、単位が入力されている場合、そのデータ型に適した測定単位が使用されていることが確認されます。たとえば、型がCelsiusのパラメーターに、値10Vを設定することはできません。
Component Editorでパラメーターに無効な値を入力すると、入力値が無効であることを知らせるダイアログが表示されます。セル間で値をコピー&ペーストした場合も同様です。ダイアログでOKをクリックすると、値は以前の入力内容に戻ります。

データ検証 – Component Editorは、単位対応パラメーターに入力された値とそのデータ型の不一致を検出し、警告します。
辞書で定義されたコンポーネントパラメーターのデータ型のサポート
Component Editorは、参照先のコンポーネントテンプレート内で設定された、辞書で定義されたコンポーネントパラメーターのデータ型をサポートしています。Value列をクリックし、ドロップダウンを使用すると、辞書で定義された選択肢からパラメーター値を選択できます。Value列をクリックして値の入力を始めると、ドロップダウンが開き、最も近い値がリスト内でハイライトされます。

参照先のコンポーネントテンプレートに含まれる、単位対応データ型のコンポーネントパラメーター。
Workspaceの管理者であれば、Valueフィールドの右側にある
アイコンをクリックすると、Workspaceのブラウザーインターフェースの Settings – Vault – Dictionaries ページが開き、辞書を管理できます。
動的(アイテムレベル)パラメーター
Altium Designerは、接続されたWorkspaceと連携して、動的パラメーター(アイテムレベルパラメーター)の概念をサポートしています。これらのパラメーターは親のコンポーネントアイテムに追加され、そのパラメーターを取り込むためにアイテムを新しいリビジョンとして再リリースしなくても、リリース済みのすべてのリビジョンで利用できます。この機能により、新しいコンポーネントリビジョンを作成することなく、コンポーネントを更新できます。新しいリビジョンを作成すると、それらのコンポーネントが使用されている関連設計にも影響が及びます。たとえば、コストパラメーターの変更を、その場で動的に適用することができます。
動的パラメーターは、Component EditorのSingle Component Editingモードでコンポーネントアイテムのリビジョンを編集する際に確認できます。これらのパラメーターには、エディターの Parameters 領域で区別できるように、異なるアイコン(
)が表示されます。アイコンにカーソルを合わせると、テキスト Dynamicが表示されます。

コンポーネントアイテムに追加され、そのリビジョンで利用できる動的パラメーターの例。
部品候補
エディターのこの領域では、コンポーネントに対して1つ以上のPart Choicesを指定します。これらは、実装基板上でそのコンポーネントとして使用できる「許可された」メーカー部品です。メーカー(および部品番号)、サプライヤー(および部品番号)、説明、価格、在庫状況からなる実際のサプライチェーン情報は、WorkspaceのローカルPart Catalogと該当する部品ソースから取得されます。

定義中のコンポーネントの部品候補リストの例。メーカー部品が1つ含まれています。
コンポーネントの部品候補リストにメーカー部品を追加するには、次の2つの方法があります。
- 手動で追加する。
- メーカー部品の検索時に自動的に追加する。詳細については、メーカー部品検索からのコンポーネントの作成を参照してください。
部品候補を手動で追加するには、この領域の下部にある
ボタンをクリックします。Add Part Choicesダイアログが表示されます。このダイアログは、メーカー部品検索パネルと同じ方法で使用できます(UI要素の詳細については、このページを参照してください)。必要なメーカー部品を検索し、部品を選択してからOKボタンをクリックします。メーカー部品のSPNsエントリ(Supplier Part Numbers)をクリックすると、その部品を取り扱うサプライヤーを確認でき、在庫状況や価格などに基づいて、適切な部品候補であるかを判断できます。

部品候補の手動選択 – Add Part Choicesダイアログで必要なメーカー部品を検索し、そのエントリを選択してOKをクリックします。
部品候補を削除するには、リストで選択し、
ボタンをクリックします。
メーカー部品検索からのコンポーネントの作成
Altium Designerでは、コンポーネントの作成を効率化するため、メーカー部品検索機能を使用して実在するメーカー部品を検索し、その部品(またはデータの一部)をコンポーネントエディターに追加できます。これにより、コンポーネントを一から作成することなく、Workspaceに追加する新しいコンポーネントをすばやく定義できます。その部品の名前、説明、パラメーター、データシート、部品候補、定義済みのモデルなど、すべてのデータを取り込めるため、いわば「車輪の再発明」をする必要はありません。
この機能には、いくつかの方法でアクセスできます。詳しくは、折りたたみセクションをクリックしてください。
いずれの場合も、Use Component Dataダイアログが開き、現在作成/編集中のコンポーネントに適用するデータ(名前、説明、パラメーター、モデル、データシート)を選択できます。コンポーネントにまだデータが定義されていない場合、このダイアログでは、その部品で利用可能なすべてのデータがデフォルトで有効になり、コンポーネントに読み込まれます。コンポーネントの名前、説明、シンボルのいずれかがすでに定義されている場合、該当するオプションはダイアログでデフォルトで無効になりますが、選択した部品のデータで置き換えることもできます。

Use Component Dataダイアログで、選択した部品からコンポーネントに追加するデータを選択します。
コンポーネントデータを使用ダイアログのオプションとコントロール
-
Show only matching with template – このオプションを有効にすると、コンポーネントテンプレートに一致するデータのみが表示されます。無効にすると、選択した部品で利用可能なすべてのデータが表示されます。
-
Parameter Import Options – クリックすると、Preferencesダイアログのデータ管理 – 部品プロバイダーページが開き、パラメーターのインポートオプションを設定できます。
-
Parameters (nn)、Models (nn)、Datasheets (nn) – タブを使用して対応するデータを確認し、コンポーネントに含める項目を選択します。
-
Model Info – クリックすると、部品に割り当てられているモデルの詳細情報を表示する領域が展開されます。コントロールの右側にあるアイコンは、モデルの品質レベルを示します。
モデルデータの詳細については、メーカー部品の検索ページを参照してください。
名前フィールドから
Nameフィールドからは、次の2つの方法でメーカー部品検索機能にアクセスできます。
-
Typing Directly – Nameフィールドに2文字以上入力すると、一致するメーカー部品の一覧がポップアップ表示されます(右側にメーカーが表示されます)。使用する部品を選択してください。

必要なメーカー部品の名前を入力し、便利なポップアップリストから該当する項目を選択します。画像は、その部品のすべてのデータがコンポーネントエディターに取り込まれた状態を示しています。 -
Using the Manufacturer Part Search dialog – フィールドの右端にある
ボタンをクリックして、Manufacturer Part Searchダイアログを開きます。必要なメーカー部品を検索して項目を選択し、OKボタンをクリックします。

Manufacturer Part Searchダイアログを使用して必要なメーカー部品を検索し、選択してからOKをクリックします。画像は、その部品のすべてのデータがコンポーネントエディターに取り込まれた状態を示しています。
パラメーターとテンプレートの不一致の解消
Workspaceに保存するコンポーネントとWorkspace内のテンプレートとの間でパラメーター名の不一致が検出された場合、保存時にその場で修正し、変更内容をグローバル環境設定に保存できます。Use Component DataダイアログでShow only matching with templateオプションを無効にすると、すべてのコンポーネントパラメーターが表示されます。不一致が検出されたパラメーターについては、Fixコントロールを使用してParameter Mapping Configurationダイアログを開き、必要に応じて変更を適用します。

Parameter Mapping Configurationダイアログを使用して、コンポーネントパラメーターとコンポーネントテンプレートの不一致を解消します。
コンポーネントルールチェックの実行
コンポーネントエディターで定義または編集したWorkspaceライブラリコンポーネントを、接続先のWorkspaceに保存して設計で使用できるようにする前に、そのコンポーネントが設定済みの条件に基づく要件を満たしていることを確認する必要があります。コンポーネントエディターでは、コンポーネントをWorkspaceに保存しようとしたとき、またはこの機能を手動で実行したときに、検証(Component Rule Check)が実行されます。
。
。
)というComponent Namingオプションがあります。テンプレートでこのオプションが有効になっている場合、新しいコンポーネントの作成時にIDを編集できます。
)というDefault Folderオプションがあります。テンプレートでこのオプションが有効になっている場合、新しいコンポーネントの作成時に、コンポーネントの保存先フォルダーを編集できます。










)。元のモデルとコピーの両方をコンポーネントにリンクしたままにするには、Yes を選択します。元のモデルへのリンクをコピーへのリンクに置き換えるには、No を選択します。



