リジッド領域とフレックス領域の設計 - アドバンストモード

概略

この記事では、Altium DesignerのAdvanced Rigid-Flexモードを使用して、リジッド領域とフレックス領域を計画・配置する方法を説明します。標準モードとの違いを明確に比較し、高度なワークフローがどのような場合に必要になるかを解説します。基板領域の定義方法、PCBで使用されているリジッドフレックスモードの確認方法、基板プランニングモードでの操作方法に加え、領域の配置、命名、レイヤースタックの割り当て、正確な編集方法を順に紹介します。また、より複雑なリジッドフレックスレイアウトを作成する際に重要となる、配置時の動作、ショートカット、領域のプロパティについても取り上げます。高度なリジッドフレックス基板領域の設定と管理を、より確実に行うための実践的なガイドをお探しの方は、ぜひ読み進めてください。

- Standard Rigid-FlexモードとAdvanced Rigid-Flexモードの違いと、それによって基板領域の作成・定義方法がどのように変わるかを学べます。
- 基板プランニングモードで基板領域を配置・編集する方法を確認できます。名前やレイヤースタックの割り当てに加え、ガイドやスナップを使用して精度を高める方法も紹介します。
- 複雑なリジッドフレックスPCBレイアウトを効率よく扱うための、便利なショートカット、配置モード、プロパティ設定を習得できます。
AIでさらに深掘り:

AltiumのPCB設計ソフトウェアでは、2つのリジッドフレックス設計モードを使用できます。従来の標準モードであるリジッドフレックスは、シンプルなリジッドフレックス設計に対応しています。フレックス領域の重なりなど、より複雑なリジッドフレックス要件がある設計には、高度なリジッドフレックスモード(リジッドフレックス2.0とも呼ばれます)が必要です。モードは、レイヤースタックマネージャーのToolsメニューで選択します。

両モードの根本的な違いは、従来のモードでは分割線を配置して基板外形を個別の基板領域に分割し、その分割線が、ある基板領域の終点と別の基板領域の始点を定義するオブジェクトとして残ることです。高度なモードでは、各基板領域を個別に配置します。また、大きな領域をスライスすると、2つの独立した領域オブジェクトになります。高度なモードでは、分割線の存在ではなく、隣接する基板領域のエッジによって、2つの領域が接する位置が定義されます。この違いにより、高度なリジッドフレックスモードでは分割線オブジェクトは存在しません。

► 詳細については、リジッドフレックスPCBの設計

を参照してください。Viewメニューには、覚えやすいショートカットが割り当てられた3つのPCBエディター作業モードがあり、次のモードをすばやく切り替えられます。

  • Board Planning Mode(1)
  • 2D Layout Mode(2)
  • 3D Layout Mode(3)

2D表示モードと3D表示モードを切り替える際、デフォルトでは、各表示モードのズームと向きの設定が個別に保持されます。切り替え時に基板の同じ位置と向きを表示するには、2または3の代わりに、 Ctrl+Alt+2 または Ctrl+Alt+3を押します。

PCBを開いたばかりで、標準のリジッドフレックスモードと高度なリジッドフレックスモードのどちらが使用されているかを確認したい場合は、どうすればよいでしょうか。

レイヤースタックマネージャーを開いて確認できます。または、基板プランニングモード(ショートカット:1)に切り替えて、アクティブバーを確認することもできます。

標準リジッドフレックスモード
高度なリジッドフレックスモード

基板領域の配置

基板領域は、標準的なポリゴンオブジェクトの配置手法で配置する多角形のオブジェクトです。基板外形は正確に定義する必要があるため、基板を構成する領域を要件どおりに正確に作成することが重要です。以下の動画では、あらかじめ配置した設計スペースガイドにエッジを合わせて基板領域を作成する方法を示しています。この手法の利点は、Propertiesパネルで座標を編集することで、設計スペースガイドの位置を正確に定義できることです。

あらかじめ定義したワークスペースガイドを、基板領域を配置する際の基準として使用します。

基板領域の配置と変更は、Board Planning Modeで行います。

  1. View » Board Planning Modeを選択するか、ショートカット 1を押して、Board Planning Modeに入ります。既存のデフォルトの基板領域が、緑色の長方形で表示されます。
  2. Place » Board Regionを選択して新しい領域を配置します(または、Active Barのボタンをクリックします)。
  3. カーソルを移動してクリックし、基板領域の開始頂点を固定します。基板領域は、リージョンやポリゴンと同様の多角形オブジェクトであり、配置(および編集)の手順も同じです。
  4. カーソルを移動し、2番目の頂点を配置する準備をします。デフォルトでは、クリックするたびに2つのエッジが配置され、その間のコーナー形状はユーザー定義の形状になります。Spacebarを押すと、コーナーの方向を切り替えられます。コーナーモードの変更について詳しくは、以下のPlacement Modesセクションを参照してください。
  5. 引き続きマウスを移動してクリックし、頂点を配置して、基板領域全体の形状を定義するために必要なエッジを作成します。
  6. 最後の頂点を配置したら、右クリックするかEscを押して、基板外形を閉じて定義を完了します。最後に配置した点と開始点が自動的に接続されて形状が完成するため、手動で基板外形を閉じる必要はありません。
  7. 各基板領域には、一意に識別するための名前を付けます。Propertiesパネルの基板領域モードにあるNameフィールドに適切な名前を入力します(パネルにプロパティを表示するには、設計スペースで基板領域を選択する必要があります)。
  8. 各基板領域には、レイヤースタックを割り当てる必要があります。新しい基板領域を作成すると、Board Layer Stackという名前のデフォルトのレイヤースタックが割り当てられます。PropertiesパネルのBoard Regionモードで、必要なレイヤースタックを割り当てます。レイヤースタックの定義と命名は、レイヤースタックマネージャーで行います。
  9. 最終的なPCBに複数の基板領域が必要な場合は、引き続き追加の領域を定義します。
  • 各領域には、領域名と割り当てられたレイヤースタック名をRegion Name - Layer Stack Nameの形式で示すラベルが表示されます。基板領域の名前はPropertiesパネルのBoard Regionモードで設定し、レイヤースタックの名前はレイヤースタックマネージャーで設定します。
  • 必要な基板外形を構成するために、基板領域はいくつでも配置できます。基板領域は重ねることができますが、この重なりによって、ある領域が隣接する領域に入り込む距離が定義されるわけではありません。その距離は、レイヤースタックマネージャーのレイヤースタック設定の一部として定義します。
  • 基板領域は多角形オブジェクトです。形状を変更するには、1回クリックして選択し、エッジまたは編集ハンドルをクリックしてドラッグします。詳しくは、多角形オブジェクトの編集を参照してください。高度なモードでは、基板領域を対話的に編集するため、基板プランニングモードのDesignメニューに編集用のコマンドはありません。
  • 基板領域を削除するには、選択してキーボードのDeleteキーを押します。常に少なくとも1つの基板領域が必要なため、最後の1つは削除できません。
  • 基板領域は、描画するだけでなく、プリミティブから作成することもできます。詳しくは、このページの2D描画プリミティブと基板定義オブジェクト間の変換セクションを参照してください。
  • 基板領域の配置中または編集中は、現在のスナップグリッド、スナップ対象として使用できるオブジェクト、ワークスペースガイドの有無、軸スナップ設定などのカーソルスナップ設定によって、カーソルの動きが制限されます。これらの機能を活用して、必要な形状を作成してください。

    ► 詳しくは、スナップ動作についてを参照してください。

また、 Tab キーを押して配置を一時停止し、 Properties パネルの基板領域モードにアクセスして、その場でプロパティを変更することもできます。配置を再開するには、設計スペースに重ねて表示される一時停止ボタン()をクリックします。

Placement Modes

基板外形を再定義する際には、5つのコーナーモードを使用できます。そのうち4つには、コーナー方向のサブモードもあります。再定義中は、次の操作が可能です。

  • Shift+Spacebarを押すと、使用可能な5つのコーナーモードが順に切り替わります。
  • Spacebarを押すと、2つのコーナー方向サブモードが切り替わります。
  • いずれかの円弧コーナーモードでは、 を押したままにします。キーで円弧を縮小するか、キーで拡大します。キーを押す際にShiftキーを押したままにすると、円弧のサイズ変更が速くなります。
  • 1ショートカットキーを押すと、クリックごとに2つの辺を配置するモードと、1つの辺を配置するモードを切り替えられます。後者のモードでは、破線の辺を先読みセグメントと呼びます(下の一連の画像の最後の画像を参照)。
  • Backspaceキーを押すと、最後の頂点が削除されます。

Shift+Spacebarを押すと、使用可能な5つのコーナーモードが順に切り替わります。ショートカットキーの1を押すと、2つの辺を配置するモードと1つの辺を配置するモードを切り替えられます。 
 
 
Shift+Spacebarを押すと、使用可能な5つのコーナーモードが順に切り替わります。ショートカットキーの1を押すと、2つの辺を配置するモードと1つの辺を配置するモードを切り替えられます。

3Dボディから基板領域を作成する

3Dモードで Create Board Region from 3D Body コマンドを使用すると、3Dボディオブジェクトから基板領域を作成することもできます。手順は次のとおりです。

  1. 基板が3Dで表示されていることを確認します(3D表示でない場合は、キーボードショートカット 3 を使用すると、すばやくこのモードに切り替えられます)。
  2. メインメニューから Design » Board Shape » Create Board Region from 3D body コマンドを選択します。
  3. PCBの基板領域の生成に使用する3Dモデルの上にカーソルを置き、クリックするか、Enterを押します。モデルが透明になります。
  4. 3Dモデル上でカーソルを移動して面を探します。カーソルの下に平面が見つかると、その面が不透明になり、細い青色の枠線で囲まれます。
  5. 適切な面が見つかったら、クリックするか、Enter を押します。新しい基板領域が作成されます(設計スペース内で以前に定義されていた基板領域が置き換えられます)。
  6. Board Outline Creation Successfulダイアログが表示され、作成が正常に完了したことを確認できます。このダイアログでは、モデル部品を非表示にし、DRCチェックの対象から除外できます。また、モデルの高さを変更して面を上面または下面に合わせるか、位置を変更しないかを選択することもできます。
基板領域を定義するには、選択した面の基板外形をPCB基板に位置合わせする必要があります。 

基板切り抜き領域の作成

基板内部に切り抜きを作成するには、基板切り抜き領域を配置します(Place » Define Board Cutout、またはActive Barのボタンをクリック)。基板切り抜きもポリゴンオブジェクトであるため、配置手順は基板領域自体と同じです。下の画像は、2つの基板切り抜きがある基板領域を示しています。これらは基板の製造時に穴になります。

基板領域に配置した基板切り抜きは、完成した基板では穴になります。 基板領域に配置した基板切り抜きは、完成した基板では穴になります。

基板外形を領域に分割する

既存の基板領域は、スライスすることで2つの領域に分割できます。この操作は、PCBエディターがBoard Planning Modeのときに行います。

基板は、Slice Regionコマンドを使用して3つの基板領域に分割されています。

基板領域を分割するには:

  1. View » Board Planning Modeを選択するか、ショートカットの1を押して、Board Planning Modeに切り替えます。
  2. Design » Slice Board Regionを選択するか、Active Barの  ボタンをクリックして、Slice Board Regionモードに切り替えます。
  3. このコマンドを選択すると、配線配置モードに似た分割モードになります。分割する領域の外側から開始し、クリックして分割線を定義する一連の頂点を配置します。分割線の定義中にShift+Spacebar を押すと、コーナーモードを順に切り替えられます。 Spacebar を押すと始点側と終点側のコーナーモードが切り替わり、 Backspace キーを押すと最後に配置したコーナーを削除できます。分割線の終点は、基板領域の端を越えた位置に配置してください。分割線の定義が完了したら、右クリックするか Escを押してコマンドを終了します。
  4. 確認ダイアログが開き、この操作で分割されるポリゴン(領域)の数と、作成されるポリゴン(領域)の数が表示されます。 Yes をクリックして作成を確定します。

作成された各領域には、元の領域に含まれていたコンポーネントが1つ以上引き継がれる場合があります。これらのコンポーネントがコンポーネントクラスに属している場合は、新しい領域ごとに新しいクラスが作成され、所属情報もそれに応じて更新されます。

選択したオブジェクトからの基板領域の作成

基板の形状によっては、複数の基板領域を作成して形状を組み立てる方が効率的な場合があります。前述のとおり、領域は対話的に配置することも、トラックとアークのオブジェクトで定義された外形をトレースして作成することもできます。以下の動画では、選択したオブジェクトから3つの基板領域を定義する方法を紹介しています。動画では、領域同士が接する隣接辺の定義に同じオブジェクトを使用することで、各領域を正確に配置している点に注目してください。

一般的な方法は、トラックとアークを使用して領域の外形を定義し、その外形を選択して基板領域を作成することです。

2D作図プリミティブと基板定義オブジェクト間の変換

基板形状と、その形状内に必要な基板領域を定義する一般的な方法として、メカニカルCADソフトウェアから図面をインポートする方法があります。たとえば、機構の詳細図をDWGファイルからインポートすると、メカニカルレイヤー上に一連の線(トラック)が作成されます。これらの線で、基板形状、形状内の領域、さらにリジッドフレックス設計の場合はフレキシブル領域内のベンドラインの位置を定義できます。

このソフトウェアには、2D作図プリミティブから基板定義オブジェクト(領域、カットアウト、ベンドライン)を作成するためのコマンドと、基板定義オブジェクトを作図プリミティブに戻すための対応するコマンドが用意されています。

オブジェクト 選択した2D作図プリミティブから 基板設計オブジェクトから
基板領域 Create Board Region from Selected Objects
(Design » Board Shapeサブメニュー)
Explode Region to Free Primitives
基板カットアウト Create Board Cutout from Selected Primitives Explode Board Cutout to Free Primitives
ベンドライン Convert Selected Line to Bend Line Explode Bend Line

注意事項:

  • 双方向の変換コマンドは、該当するViewモードのTools » Convertサブメニューにあります。ただし、Create Board Region from Selected ObjectsコマンドはDesign » Board Shapeサブメニューにあります。
  • 2D作図プリミティブを基板定義オブジェクトに変換するには、表示を2D Layout Modeに切り替えます。
    • コマンドを実行する前に、プリミティブを選択しておく必要があります。
    • 領域またはカットアウトを作成するには、プリミティブが閉じた形状を形成している必要があります。この形状の要件については、下の警告ボックスを確認してください。
  • 基板定義オブジェクトを2D作図オブジェクトに変換するには、表示をBoard Planning Modeに切り替えます。
    • これらのコマンドでは、事前にオブジェクトを選択する必要はありません。ただし、すでにオブジェクトが選択されている場合は、そのオブジェクトに対して実行されます。
    • 基板領域が複数ある場合、プリミティブに分解した領域は削除されます。基板領域が1つしかない場合は、プリミティブが作成され、対象の基板領域も残ります(基板領域は常に1つ以上存在する必要があります)。
    • 2D作図オブジェクトは、Board Shapeメカニカルレイヤー上に作成されます。このレイヤータイプのレイヤーが基板に存在しない場合は、レイヤータイプをBoard Shapeに設定したメカニカルレイヤーが追加されます。詳細は、メカニカルレイヤーとレイヤータイプを参照してください。
    • 分解したオブジェクトを再結合する専用コマンドはありませんが、 Undoコマンドを使用すれば同じ結果を得られます。
線(トラック)とアークで構成された外形に基づいてポリゴン形状を作成するコマンドはすべて、選択したオブジェクトの中心線をたどって形状の検出を試みます。あるトラック/アークセグメントの終点座標が、次のトラック/アークセグメントの座標と完全に一致していない場合、境界の識別アルゴリズムは失敗し、失敗した位置を示すメッセージが表示されます。その後、代わりにトレースアルゴリズムを使用するかどうかを確認されます。トレースアルゴリズムはトラック/アークオブジェクトの外縁をたどるため、中心線から作成した形状とはわずかに異なります。この違いによる設計への影響を許容できる場合にのみ、このオプションを選択してください。

基板領域の変更

標準リジッドフレックスモードを使用するようにPCBを設定している場合、隣接する2つの領域が接する位置は、移動可能な青い分割線で定義されます。アドバンストリジッドフレックスモードではこの方式を使用せず、各領域が独立した閉じたポリゴン形状になります。各領域はポリゴン形状なので、標準のポリゴン形状の編集手法を使用して、必要に応じて調整できます。ただし、ポリゴンの追加や減算など、基板領域の変更には使用できないポリゴン編集コマンドもあります。

基板領域の形状を変更して隣接する領域と重なった場合、ソフトウェアは、重なり部分にはレイヤー数が最も多い領域が存在するものと見なします。

ポリゴンオブジェクトを編集する際の注意点:

  • 頂点またはポリゴンの辺をクリックしてドラッグすると、スライド、折り曲げ、曲線化の3つの変形モードを使用できます。ドラッグ中にShift+Spacebarを押すと、モードを順に切り替えられます。現在のモードは、ステータスバーとヘッドアップディスプレイに表示されます。
  • カーソルのスナップ動作は、現在のカーソルスナップ設定によって制御されます。これには、現在のスナップグリッド、スナップ対象のオブジェクト、ワークスペースガイドの有無、軸スナップの設定が含まれます。これらの機能を活用して、目的の形状に調整してください。詳細は、スナップ動作についてを参照してください。

レイヤースタックの割り当てと基板領域名の編集

Related page: レイヤースタックの定義

新しい基板を作成すると、Default Layer Stack Regionという名前の領域が1つ作成されます。この領域には、Board Layer Stackという名前のデフォルトのレイヤースタックが割り当てられます。

基板形状を複数の領域に分割すると、新しい各領域にもデフォルトのレイヤースタックが割り当てられます。レイヤースタックマネージャーで必要なレイヤースタックを定義したら、各領域にスタックを割り当て、 わかりやすい名前を付けることができます。

各領域には、その名前と割り当てられたレイヤースタック名が Region Name - Layer Stack Nameの形式で表示されます。選択したレイヤースタックでフレックス設定が有効になっている場合は、(flex)も表示されます。スタックのフレックス設定は、Layer Stack Managerで有効にします。

レイヤースタックを割り当て、領域に名前を付けるには:

  1. View » Board Planning Modeを選択するか、 1ショートカットを押してBoard Planning Modeに切り替えます。
  2. ワークスペース下部の Multi-Layerタブをクリックして、アクティブレイヤーにします(レイヤータブが表示されていない場合は、Lを押してView Configurationパネルを開き、表示を有効にします)。
  3. 基板領域をダブルクリックして Board Regionダイアログを開くか、基板領域をシングルクリックしてPropertiesパネルを開きます。領域が選択されず、ダイアログも開かない場合は、選択フィルターで領域が除外されていないことを確認してください。
  4. Layer stackドロップダウンから必要なスタックを選択して、レイヤースタックを割り当てます。
  5. 必要に応じてNameを編集します。

基板領域の名前と割り当てられたレイヤースタックは、その領域の幾何学的中心に表示されます。割り当てられたスタックがフレックスとして設定されている場合は、(Flex)も表示されます。
基板領域の名前と割り当てられたレイヤースタックは、その領域の幾何学的中心に表示されます。割り当てられたスタックがフレックスとして設定されている場合は、(Flex)も表示されます。

AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
Nav
Contents
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Contents