リジッド領域とフレックス領域の設計 - アドバンストモード
概略
- Standard Rigid-FlexモードとAdvanced Rigid-Flexモードの違いと、それによって基板領域の作成・定義方法がどのように変わるかを学べます。
- 基板プランニングモードで基板領域を配置・編集する方法を確認できます。名前やレイヤースタックの割り当てに加え、ガイドやスナップを使用して精度を高める方法も紹介します。
- 複雑なリジッドフレックスPCBレイアウトを効率よく扱うための、便利なショートカット、配置モード、プロパティ設定を習得できます。
基板領域の配置
基板領域は、標準的なポリゴンオブジェクトの配置手法で配置する多角形のオブジェクトです。基板外形は正確に定義する必要があるため、基板を構成する領域を要件どおりに正確に作成することが重要です。以下の動画では、あらかじめ配置した設計スペースガイドにエッジを合わせて基板領域を作成する方法を示しています。この手法の利点は、Propertiesパネルで座標を編集することで、設計スペースガイドの位置を正確に定義できることです。
あらかじめ定義したワークスペースガイドを、基板領域を配置する際の基準として使用します。
基板領域の配置と変更は、Board Planning Modeで行います。
- View » Board Planning Modeを選択するか、ショートカット 1を押して、Board Planning Modeに入ります。既存のデフォルトの基板領域が、緑色の長方形で表示されます。
-
Place » Board Regionを選択して新しい領域を配置します(または、Active Barの
ボタンをクリックします)。
- カーソルを移動してクリックし、基板領域の開始頂点を固定します。基板領域は、リージョンやポリゴンと同様の多角形オブジェクトであり、配置(および編集)の手順も同じです。
- カーソルを移動し、2番目の頂点を配置する準備をします。デフォルトでは、クリックするたびに2つのエッジが配置され、その間のコーナー形状はユーザー定義の形状になります。Spacebarを押すと、コーナーの方向を切り替えられます。コーナーモードの変更について詳しくは、以下のPlacement Modesセクションを参照してください。
- 引き続きマウスを移動してクリックし、頂点を配置して、基板領域全体の形状を定義するために必要なエッジを作成します。
- 最後の頂点を配置したら、右クリックするかEscを押して、基板外形を閉じて定義を完了します。最後に配置した点と開始点が自動的に接続されて形状が完成するため、手動で基板外形を閉じる必要はありません。
- 各基板領域には、一意に識別するための名前を付けます。Propertiesパネルの基板領域モードにあるNameフィールドに適切な名前を入力します(パネルにプロパティを表示するには、設計スペースで基板領域を選択する必要があります)。
-
各基板領域には、レイヤースタックを割り当てる必要があります。新しい基板領域を作成すると、
Board Layer Stackという名前のデフォルトのレイヤースタックが割り当てられます。PropertiesパネルのBoard Regionモードで、必要なレイヤースタックを割り当てます。レイヤースタックの定義と命名は、レイヤースタックマネージャーで行います。 - 最終的なPCBに複数の基板領域が必要な場合は、引き続き追加の領域を定義します。
また、 Tab キーを押して配置を一時停止し、 Properties パネルの基板領域モードにアクセスして、その場でプロパティを変更することもできます。配置を再開するには、設計スペースに重ねて表示される一時停止ボタン(
)をクリックします。
Placement Modes
基板外形を再定義する際には、5つのコーナーモードを使用できます。そのうち4つには、コーナー方向のサブモードもあります。再定義中は、次の操作が可能です。
- Shift+Spacebarを押すと、使用可能な5つのコーナーモードが順に切り替わります。
- Spacebarを押すと、2つのコーナー方向サブモードが切り替わります。
-
いずれかの円弧コーナーモードでは、
を押したままにします。キーで円弧を縮小するか、
キーで拡大します。キーを押す際にShiftキーを押したままにすると、円弧のサイズ変更が速くなります。
- 1ショートカットキーを押すと、クリックごとに2つの辺を配置するモードと、1つの辺を配置するモードを切り替えられます。後者のモードでは、破線の辺を先読みセグメントと呼びます(下の一連の画像の最後の画像を参照)。
- Backspaceキーを押すと、最後の頂点が削除されます。



Shift+Spacebarを押すと、使用可能な5つのコーナーモードが順に切り替わります。ショートカットキーの1を押すと、2つの辺を配置するモードと1つの辺を配置するモードを切り替えられます。
基板領域のプロパティ

PropertiesパネルのBoard Regionモード。
アクション
これらのコントロールは、現在の基板領域にカバーレイを追加したり、基板領域からカバーレイを削除したりするために使用します。Add ボタンとRemove Coverlay ボタンを有効にするには、Is Flexオプションが有効で、レイヤー構成にカバーレイ層が含まれているレイヤースタックを基板領域に割り当てる必要があります。
- Add Coverlay - 自動生成されたカバーレイポリゴンを、選択した基板領域に追加します。
- Remove Coverlay - 自動生成されたカバーレイポリゴンと手動で定義したカバーレイポリゴンを、選択した基板領域から削除します。
のフレックス領域へのカバーレイの追加について詳しく見る 位置
- (X/Y) - 基板領域の作成時に最初に配置した頂点のX座標とY座標です。現在の設計スペースの原点を基準とします。編集すると、基板領域のX位置またはY位置を変更できます。値はメートル法またはヤード・ポンド法のどちらでも入力できます。現在のデフォルトと異なる単位の値を入力する場合は、単位も指定してください。
プロパティ
- Name - この基板領域のユーザー定義名です。設計に複数の領域がある場合は、各基板領域に名前を付けると便利です。
- Layer Stack - この基板領域に割り当てるレイヤースタックを指定します。ドロップダウンリストには、レイヤースタックマネージャーで定義されているすべてのレイヤースタック(サブスタック)が表示されます。
- Color - クリックするとカラーパレットが開き、選択した基板領域の色を設定または変更できます。色の変更は、選択した基板領域と同じレイヤースタックを使用するすべての基板領域に適用されます。
- Priority - 優先度の値は、最後に描画する基板領域を決定するために使用されます。リジッド領域の基板切り抜き内にフレックス領域がある基板を設計する場合に使用します。フレックス領域の優先度は、周囲のリジッド領域よりも高く設定する必要があります(また、基板切り抜きは、その内部のフレックス領域を囲む形状にする必要があります)。
- 3D Locked - このチェックボックスをオンにすると、3D表示モードで基板を折り曲げる際に、この基板領域が固定されます。ロックできるリジッド基板領域は1つだけです。
外形の頂点
この領域では、現在選択されている基板領域オブジェクトの各頂点を変更できます。必要に応じて、既存の頂点の位置を変更したり、新しい頂点を追加したり、頂点を削除したりできます。頂点間の接続を円弧として定義することもできます。また、右クリックメニューから、頂点情報をCSV形式のファイルにエクスポートしたり、CSV形式のファイルからインポートしたりすることもできます。
-
Vertices Grid - 基板領域に現在定義されているすべての頂点を、次の項目で一覧表示します。
- Index - 頂点に割り当てられたインデックス(編集不可)。
- X - 頂点のX座標(水平方向)。クリックして編集します。
- Y - 頂点のY座標(垂直方向)。クリックして編集します。
-
Arc Angle (Neg = CW) - この頂点から次の頂点までを接続する円弧の角度です。デフォルトでは直線の辺で接続され、このフィールドは空欄になります。クリックして編集し、必要な円弧角度を入力します。正の値を入力すると、反時計回りの円弧が描画されます。時計回りの円弧を描画するには、負の値を入力します。
-
Add - クリックすると、新しい頂点が追加されます。新しい頂点は、現在フォーカスされている頂点の項目の下に追加され、初期状態ではその項目と同じX、Y座標になります。
をクリックすると、現在選択されている頂点が削除されます。
3Dボディから基板領域を作成する
3Dモードで Create Board Region from 3D Body コマンドを使用すると、3Dボディオブジェクトから基板領域を作成することもできます。手順は次のとおりです。
- 基板が3Dで表示されていることを確認します(3D表示でない場合は、キーボードショートカット 3 を使用すると、すばやくこのモードに切り替えられます)。
- メインメニューから Design » Board Shape » Create Board Region from 3D body コマンドを選択します。
- PCBの基板領域の生成に使用する3Dモデルの上にカーソルを置き、クリックするか、Enterを押します。モデルが透明になります。
- 3Dモデル上でカーソルを移動して面を探します。カーソルの下に平面が見つかると、その面が不透明になり、細い青色の枠線で囲まれます。
- 適切な面が見つかったら、クリックするか、Enter を押します。新しい基板領域が作成されます(設計スペース内で以前に定義されていた基板領域が置き換えられます)。
- Board Outline Creation Successfulダイアログが表示され、作成が正常に完了したことを確認できます。このダイアログでは、モデル部品を非表示にし、DRCチェックの対象から除外できます。また、モデルの高さを変更して面を上面または下面に合わせるか、位置を変更しないかを選択することもできます。
基板切り抜き領域の作成
基板内部に切り抜きを作成するには、基板切り抜き領域を配置します(Place » Define Board Cutout、またはActive Barの
ボタンをクリック)。基板切り抜きもポリゴンオブジェクトであるため、配置手順は基板領域自体と同じです。下の画像は、2つの基板切り抜きがある基板領域を示しています。これらは基板の製造時に穴になります。
基板領域に配置した基板切り抜きは、完成した基板では穴になります。
基板外形を領域に分割する
既存の基板領域は、スライスすることで2つの領域に分割できます。この操作は、PCBエディターがBoard Planning Modeのときに行います。
基板は、Slice Regionコマンドを使用して3つの基板領域に分割されています。
基板領域を分割するには:
- View » Board Planning Modeを選択するか、ショートカットの1を押して、Board Planning Modeに切り替えます。
-
Design » Slice Board Regionを選択するか、Active Barの
ボタンをクリックして、Slice Board Regionモードに切り替えます。
- このコマンドを選択すると、配線配置モードに似た分割モードになります。分割する領域の外側から開始し、クリックして分割線を定義する一連の頂点を配置します。分割線の定義中にShift+Spacebar を押すと、コーナーモードを順に切り替えられます。 Spacebar を押すと始点側と終点側のコーナーモードが切り替わり、 Backspace キーを押すと最後に配置したコーナーを削除できます。分割線の終点は、基板領域の端を越えた位置に配置してください。分割線の定義が完了したら、右クリックするか Escを押してコマンドを終了します。
-
確認ダイアログが開き、この操作で分割されるポリゴン(領域)の数と、作成されるポリゴン(領域)の数が表示されます。 Yes をクリックして作成を確定します。
選択したオブジェクトからの基板領域の作成
基板の形状によっては、複数の基板領域を作成して形状を組み立てる方が効率的な場合があります。前述のとおり、領域は対話的に配置することも、トラックとアークのオブジェクトで定義された外形をトレースして作成することもできます。以下の動画では、選択したオブジェクトから3つの基板領域を定義する方法を紹介しています。動画では、領域同士が接する隣接辺の定義に同じオブジェクトを使用することで、各領域を正確に配置している点に注目してください。
一般的な方法は、トラックとアークを使用して領域の外形を定義し、その外形を選択して基板領域を作成することです。
2D作図プリミティブと基板定義オブジェクト間の変換
基板形状と、その形状内に必要な基板領域を定義する一般的な方法として、メカニカルCADソフトウェアから図面をインポートする方法があります。たとえば、機構の詳細図をDWGファイルからインポートすると、メカニカルレイヤー上に一連の線(トラック)が作成されます。これらの線で、基板形状、形状内の領域、さらにリジッドフレックス設計の場合はフレキシブル領域内のベンドラインの位置を定義できます。
このソフトウェアには、2D作図プリミティブから基板定義オブジェクト(領域、カットアウト、ベンドライン)を作成するためのコマンドと、基板定義オブジェクトを作図プリミティブに戻すための対応するコマンドが用意されています。
注意事項:
- 双方向の変換コマンドは、該当するViewモードのTools » Convertサブメニューにあります。ただし、Create Board Region from Selected ObjectsコマンドはDesign » Board Shapeサブメニューにあります。
-
2D作図プリミティブを基板定義オブジェクトに変換するには、表示を2D Layout Modeに切り替えます。
- コマンドを実行する前に、プリミティブを選択しておく必要があります。
- 領域またはカットアウトを作成するには、プリミティブが閉じた形状を形成している必要があります。この形状の要件については、下の警告ボックスを確認してください。
-
基板定義オブジェクトを2D作図オブジェクトに変換するには、表示をBoard Planning Modeに切り替えます。
- これらのコマンドでは、事前にオブジェクトを選択する必要はありません。ただし、すでにオブジェクトが選択されている場合は、そのオブジェクトに対して実行されます。
- 基板領域が複数ある場合、プリミティブに分解した領域は削除されます。基板領域が1つしかない場合は、プリミティブが作成され、対象の基板領域も残ります(基板領域は常に1つ以上存在する必要があります)。
- 2D作図オブジェクトは、Board Shapeメカニカルレイヤー上に作成されます。このレイヤータイプのレイヤーが基板に存在しない場合は、レイヤータイプをBoard Shapeに設定したメカニカルレイヤーが追加されます。詳細は、メカニカルレイヤーとレイヤータイプを参照してください。
- 分解したオブジェクトを再結合する専用コマンドはありませんが、 Undoコマンドを使用すれば同じ結果を得られます。
基板領域の変更
標準リジッドフレックスモードを使用するようにPCBを設定している場合、隣接する2つの領域が接する位置は、移動可能な青い分割線で定義されます。アドバンストリジッドフレックスモードではこの方式を使用せず、各領域が独立した閉じたポリゴン形状になります。各領域はポリゴン形状なので、標準のポリゴン形状の編集手法を使用して、必要に応じて調整できます。ただし、ポリゴンの追加や減算など、基板領域の変更には使用できないポリゴン編集コマンドもあります。
ポリゴンオブジェクトを編集する際の注意点:
- 頂点またはポリゴンの辺をクリックしてドラッグすると、スライド、折り曲げ、曲線化の3つの変形モードを使用できます。ドラッグ中にShift+Spacebarを押すと、モードを順に切り替えられます。現在のモードは、ステータスバーとヘッドアップディスプレイに表示されます。
- カーソルのスナップ動作は、現在のカーソルスナップ設定によって制御されます。これには、現在のスナップグリッド、スナップ対象のオブジェクト、ワークスペースガイドの有無、軸スナップの設定が含まれます。これらの機能を活用して、目的の形状に調整してください。詳細は、スナップ動作についてを参照してください。
レイヤースタックの割り当てと基板領域名の編集
Related page: レイヤースタックの定義
新しい基板を作成すると、Default Layer Stack Regionという名前の領域が1つ作成されます。この領域には、Board Layer Stackという名前のデフォルトのレイヤースタックが割り当てられます。
基板形状を複数の領域に分割すると、新しい各領域にもデフォルトのレイヤースタックが割り当てられます。レイヤースタックマネージャーで必要なレイヤースタックを定義したら、各領域にスタックを割り当て、 わかりやすい名前を付けることができます。
レイヤースタックを割り当て、領域に名前を付けるには:
- View » Board Planning Modeを選択するか、 1ショートカットを押してBoard Planning Modeに切り替えます。
- ワークスペース下部の Multi-Layerタブをクリックして、アクティブレイヤーにします(レイヤータブが表示されていない場合は、Lを押してView Configurationパネルを開き、表示を有効にします)。
- 基板領域をダブルクリックして Board Regionダイアログを開くか、基板領域をシングルクリックしてPropertiesパネルを開きます。領域が選択されず、ダイアログも開かない場合は、選択フィルターで領域が除外されていないことを確認してください。
- Layer stackドロップダウンから必要なスタックを選択して、レイヤースタックを割り当てます。
- 必要に応じてNameを編集します。

基板領域の名前と割り当てられたレイヤースタックは、その領域の幾何学的中心に表示されます。割り当てられたスタックがフレックスとして設定されている場合は、(Flex)も表示されます。