CAM Editor のショートカット

概略

このリファレンスでは、Altium DesignerのCAMtasticエディター固有のキーボードおよびマウスのショートカットを紹介します。日常的な編集、選択、ドキュメントの表示、グリッド、レイヤー、オブジェクトの操作、解析を網羅しています。また、インタラクティブコマンドの実行中に使用できるショートカットや、設計スペースからポップアップメニューに直接アクセスするためのキーも紹介します。日々のCAM編集作業に役立つショートカットをご確認ください。

- オブジェクトの選択と変更、レイヤーの管理、CAMドキュメント内の移動に使えるショートカットを確認できます。
- オブジェクトやネットの情報へのアクセス、距離の測定、表示モードの切り替え方法を学べます。
- ショートカットの表記、インタラクティブコマンドの操作、ポップアップメニューへのクイックアクセスについて理解できます。
AIでさらに深掘り:

以下のセクションでは、CAMtasticエディター固有のショートカットキーを紹介します。ショートカットキーへのアクセスと編集、Altium環境全般のショートカット、およびアクセラレーターキーなど、ショートカットキーに関する一般的な情報については、Altium Designerのショートカットキーを参照してください。

ショートカットキーの一覧を見る際は、以下の点に注意してください。

  • ショートカットでプラス(+)記号が使われている場合は、示された順序でキーボードの複数のキーを押したままにすることを表します。たとえば、Shift+F1は、Shiftキーを押したままF1キーを押すことを意味します。同様に、Shift+Ctrl+PgUpは、Shift キーを押したままCtrl キーも押し、その両方を押した状態でPgUpキーを押すことを意味します。
  • 標準のマウスボタンを使用する場合、Click はマウスの左ボタンのシングルクリック、Double-Clickはマウスの左ボタンのダブルクリック、Right-Clickはマウスの右ボタンのシングルクリックを表します。

標準ショートカット

以下は、CAMtasticエディターの標準ショートカットです。通常の操作時に使用でき、対話型の操作を実行している必要はありません。

General Editing

Right-Click デザインスペースのコンテキストメニューを開きます。対話型コマンドの実行中の場合は、現在の操作を終了します。
Ctrl+C 現在のドキュメントで選択したオブジェクトを、CAMtasticエディターの内部クリップボードにコピーします。
Ctrl+X 現在のドキュメントで選択したオブジェクトを削除し、CAMtasticエディターの内部クリップボードにコピーします。
Ctrl+V CAMtasticエディターの内部クリップボードの内容を、現在のドキュメントに貼り付けます。
Ctrl+Z 元に戻します。
Ctrl+Y やり直します。

Selecting

Alt+C ユーザーが定義した領域内のデザインオブジェクトを選択します。オブジェクト全体が、定義した領域の境界内に収まっている必要はありません。
Alt+P 前回選択したオブジェクトを再選択します。
Alt+O ワークスペース内のオブジェクトを1つずつ選択します。
Ctrl+F フラッシュ/ポイント選択モードのオンとオフを切り替えます。
Ctrl+T ドロー選択モードのオンとオフを切り替えます。

Viewing the CAM Document

Home 現在のドキュメントで、有効になっているすべてのレイヤー上の全オブジェクトを表示します。
Shift+P 現在のドキュメント内の指定した点を中心に、表示領域を再設定します。
PgUp 現在のカーソル位置を中心に拡大します。
Ctrl+Mouse Wheel Up メイン表示ウィンドウの中心を基準に拡大します。Ctrl キーの使用はデフォルト設定であり、Preferencesダイアログのシステム - マウスホイール設定ページで変更できます。
PgDn 現在のカーソル位置を中心に縮小します。
Ctrl+Mouse Wheel Down メイン表示ウィンドウの中心を基準に縮小します。Ctrl キーの使用はデフォルト設定であり、Preferencesダイアログのシステム - マウスホイール設定ページで変更できます。
Mouse Wheel デザインスペース内を垂直方向にスクロールします。これはデフォルト設定であり、Preferencesダイアログのシステム - マウスホイール設定ページで変更できます。
Shift+Mouse Wheel デザインスペース内を水平方向にスクロールします。これはデフォルト設定であり、Preferencesダイアログのシステム - マウスホイール設定ページで変更できます。
Right-Click, Hold&Drag メインデザインウィンドウ内で表示をパンします。
Shift+V 拡大(PgUp)または縮小(PgDn)コマンドを使用する前の画面表示に戻します。
End デザインスペースを更新します。現在のドキュメントを再描画し、描画の更新によって生じた不要な表示の乱れを取り除きます。
D ダイナミックパンモードに入ります。このモードでは、マウスの左ボタンを押したままドキュメントをパンできます。
Alt+Home 現在のDコードで描画されたすべてのオブジェクトを表示し、ハイライトします。
Ctrl+Home メインデザインウィンドウの表示を変更し、現在のフィルムボックスとその内容を表示します。
Shift+E 外接ボックスの表示を切り替えます。このボックスは、メインデザインスペース内に描画範囲を表示するために使用します。
Shift+F ドキュメントの表示を、塗りつぶしモードと輪郭スケッチモードの間で切り替えます。
Shift+H 現在のDコードに基づくオブジェクトのハイライト表示を切り替えます。これにより、特定のDコードがどのオブジェクトに関連付けられているかを正確に確認できます。
N ドキュメントの表示を、ネガ表示と標準表示の間で切り替えます。
Shift+T 半透明表示モードのオンとオフを切り替えます。このモードでは、ドキュメント内のオブジェクトが半透明で表示され、他のオブジェクトに一部または全体が重なっているオブジェクトを確認できます。
Shift+B 現在のフィルムボックスの表示を切り替えます。

Working with Grids

Ctrl+G スナップグリッドのX(水平方向)およびY(垂直方向)のステップ値を、選択した値に同時に設定します(Enter Gridダイアログを使用)。
Shift+S Offスナップモードと、前回選択したスナップモード(Off以外)を切り替えます。

Closed Polyline Conversion Tools

Shift+Y 閉じたポリラインを塗りつぶしポリゴンに変換します。
Shift+Z 閉じたポリラインをカットアウトポリゴンに変換します。
Shift+X 閉じたポリラインを塗りつぶしポリゴン領域に変換します。

Working with Layers

Ctrl+L 選択したレイヤーオブジェクトを基準にレイヤーの位置を合わせます(操作対象のレイヤーのみが有効になっていることを確認してください)。
L 既存のレイヤーを統合して新しいレイヤーを作成します。Select Layer for Mergingダイアログが表示され、統合するレイヤーを選択できます。
K Set Layers OFFダイアログを開き、オフにするレイヤーを指定します。
Alt+K Set Layers ONダイアログを開き、オンにするレイヤーを指定します。
+(テンキー) デザインの現在のレイヤーを、レイヤーリストの次のレイヤーに変更します。
-(テンキー) デザインの現在のレイヤーを、レイヤーリストの前のレイヤーに変更します。
*(テンキー) デザインの現在のレイヤーを、レイヤーリストの次の信号レイヤーに変更します。

Working with Objects

Ctrl+A 選択したオブジェクトをコピーし、指定した配列でドキュメント内に配置します。
Ctrl+D ドキュメント内で選択したオブジェクトの形状やレイヤーを変更します。
Ctrl+I ドキュメントの新しい原点を設定します。
Ctrl+U 指定した基準点と倍率に基づいて、ドキュメント内で選択したオブジェクトを拡大・縮小します。
Ctrl+M ドキュメント上で定義したミラー線を軸に、選択したオブジェクトを反転します。
Ctrl+R ドキュメント内で指定した回転基準点を中心に、選択したオブジェクトを回転します。
Ctrl+E 選択したオブジェクトをドキュメントから削除します。

解析

Q ドキュメント内で選択した単一のオブジェクトに関する情報を取得します。
Shift+N ドキュメント内で選択した単一のネットに関する情報を取得します。
Shift+M ドキュメント内の任意の2点間の距離を測定し、表示します。

Miscellaneous

Shift+G PreferencesダイアログのCAM Editor - Drawing Modesページを開きます。
Shift+A Edit Aperturesダイアログを開き、新しいアパーチャ形状の作成や、既存のアパーチャ形状の編集、削除を行います。
Shift+Ctrl+R 直前の配置/編集コマンドを繰り返します。

対話型ショートカット

以下のショートカットは、新しいデザインオブジェクトの配置や既存のオブジェクトの移動など、対話型の操作を開始すると使用できるようになります。使用できるショートカットは、対話型コマンドと、そのコマンドの対象となるデザインオブジェクトによって異なります。

PgUp 拡大します。
PgDn 縮小します。
Right-Click 現在のコマンドを終了します。
Esc 現在のコマンドを終了します。現在のコマンドのいずれかの段階でダイアログが使用されている場合、この機能ではダイアログのみが閉じられます。コマンドを完全に中止するには、この機能をもう一度使用する必要があります。

ポップアップメニューのショートカット

以下のショートカットを使用すると、設計スペース内から特定のコマンドのポップアップメニューに直接アクセスできます。 これらの一部は、エディターのメインメニュー内にあるサブメニューとしておなじみのものです。各メインメニューにも、設計スペース内からすばやくアクセスするためのポップアップキーが定義されています。 詳細については、アクセラレーターキーを参照してください。

B Toolbars サブメニュー (メインのViewメニュー内)。
C Circle サブメニュー (メインのEditメニュー内)。
G スナップグリッドコマンドを含むポップアップメニュー。
I Importサブメニュー (メインのFileメニュー内)。
O Objects サブメニュー (メインのEditメニュー内)。
S Selection サブメニュー (メインのEditメニュー内)。
X Export サブメニュー (メインのFileメニュー内)。
Z ズームコマンドを含むポップアップメニュー。

 

AI-LocalizedAI で翻訳
問題が見つかった場合、文字/画像を選択し、Ctrl + Enter キーを押してフィードバックをお送りください。
Contents
機能の提供状況

ご利用可能な機能は、お使いのAltiumソリューション(Altium Develop、Altium Agile Teams、Altium Agile Enterprise、または有効な契約期間中のAltium Designer)によって異なります。

実際にお使いのソフトウェアに文書化されている機能が表示されない場合は、詳細についてAltium Sales までお問い合わせください。

従来のドキュメント

Altium Designer のドキュメントは、バージョンごとに掲載されなくなりました。Altium Designer の旧バージョンのドキュメントは、Other Installers ページの Legacy Documentation の項目をご覧ください。

Contents