심볼 및 풋프린트 수정

개요

Altium Designer에서 데이터베이스에 연결된 심볼과 풋프린트를 유지 관리하는 작업은 표준 DbLib 라이브러리와 버전 관리되는 SVNDbLib 라이브러리에서 서로 다른 워크플로로 진행됩니다. 이 문서에서는 참조된 심볼과 기본 풋프린트를 열고 편집하는 방법, SVN 라이브러리용 로컬 작업 폴더를 설정하는 방법, Storage Manager 패널을 사용하여 저장소 변경 사항을 관리하고 리비전을 비교하는 방법을 설명합니다. 다음 라이브러리 업데이트를 자신 있게 진행할 수 있도록 계속 읽어 보세요.

- 참조된 심볼과 기본 풋프린트에 접근하고 이를 편집 및 저장하는 방법을 알아봅니다.
- 라이브러리 체크아웃부터 상태 새로 고침, 파일 업데이트, 변경 사항 커밋까지 SVN 워크플로를 이해합니다.
- 라이브러리 리비전을 시각적으로 비교하고 감지된 차이점을 검토하는 방법을 알아봅니다.
AI로 더 깊이 알아보기:

데이터베이스 자체의 콘텐츠를 유지 관리하는 것 외에도, 필요에 따라 참조된 심볼과 모델을 유지 관리해야 합니다. 여기에는 Schematic 심볼과 풋프린트 모델의 수정이 포함됩니다. 표준 데이터베이스 라이브러리(DbLib)의 경우에는 시뮬레이션 모델 파일의 정의도 수정해야 합니다.

표준 라이브러리와 버전 관리 라이브러리, 두 유형의 데이터베이스 라이브러리 모두 DbLib/SVNDbLib 문서가 활성 문서로 열려 있을 때 기본 문서 보기에서 참조된 심볼과 풋프린트 모델에 직접 접근하여 편집할 수 있습니다. 다음 섹션에서는 그 방법을 살펴봅니다. SVNDbLib를 사용할 때는 절차가 조금 더 복잡하지만, 더 강력한 기능을 제공합니다.

해당 데이터베이스 라이브러리 파일이 활성화되어 있을 때, 이 파일을 통해 편집할 수 있는 것은 컴포넌트 레코드의 심볼과 Default 풋프린트뿐입니다. Default 풋프린트 모델은 Design Parameter [Footprint Ref]에 매핑된 Database Field Name에 입력된 모델이라는 점을 기억하세요.

DbLib 사용 시

컴포넌트가 참조하는 심볼/풋프린트 모델 라이브러리 파일을 열어 편집하려면, Table Browser에서 컴포넌트의 Entry를 마우스 오른쪽 버튼으로 클릭한 다음 컨텍스트 메뉴에서 Open Symbol 또는 Open Footprint 중 적절한 명령을 선택합니다. 해당 라이브러리 파일이 열리고 심볼/풋프린트가 설계 공간에 활성 개체로 표시되어 편집할 수 있는 상태가 됩니다.

참조된 심볼/풋프린트가 있는 라이브러리가 열립니다. 데이터베이스에 라이브러리 정보가 있으면 해당 정보로 라이브러리를 찾고, 정보가 없으면 Database Library Options 대화 상자의 Symbol and Model Search Paths 탭에 정의된 경로를 사용합니다(해당 라이브러리가 지정된 경로에 실제로 있는지도 확인하세요). 데이터베이스 라이브러리의 심볼 및 모델 라이브러리 위치 지정 섹션을 다시 참조하세요.

필요한 변경을 완료한 후 라이브러리 파일을 저장합니다.

DbLib에서 데이터베이스 컴포넌트가 참조하는 심볼에 직접 접근하는 예. DbLib에서 데이터베이스 컴포넌트가 참조하는 심볼에 직접 접근하는 예.

DbLib 파일 외부에서도 소스 라이브러리 파일에 접근할 수 있습니다. 라이브러리 Editor의 File » Open 명령으로 필요한 라이브러리를 찾아 열거나, Windows 탐색기에서 라이브러리 파일을 Altium Designer로 직접 끌어다 놓습니다.

SVNDbLib 사용 시

앞서 언급했듯이, SVNDbLib 파일을 통해 데이터베이스 컴포넌트가 참조하는 심볼과 모델에 접근하여 편집하는 기능은 조금 더 복잡하지만 더 강력합니다. 수정은 SVN 저장소에 저장된 라이브러리의 로컬 작업 복사본에서 이루어집니다.

로컬 작업 공간 지정

컴포넌트 심볼과 풋프린트 모델을 수정하려면 저장소의 파일을 로컬 작업 디렉터리로 체크아웃해야 합니다. Preferences 대화 상자의 Data Management - SVN Libraries 페이지에서 사용할 디렉터리를 지정합니다. Default 작업 폴더 위치는 \Users\<ProfileName>\Documents\My Designs\SVNDBlib Working Folder로 정의되어 있습니다. 필요에 따라 Button used to browse and select the repository working folder 버튼을 클릭하여 기존 폴더를 찾거나 폴더 경로를 직접 입력하여 변경합니다.

로컬 작업 디렉터리로 지정한 폴더에는 버전 관리 대상 파일의 복사본만 저장해야 합니다. *.SVNDbLib, *.mdb, *.xls 등의 다른 파일은 버전 관리 대상이 아니므로 다른 디렉터리에 저장해야 합니다.

로컬 작업 디렉터리 지정.로컬 작업 디렉터리 지정.

Default 작업 폴더 위치는 Default 상태에서는 실제로 존재하지 않습니다. 이 폴더는 저장소에서 파일을 체크아웃할 때 생성됩니다. 현재 존재하지 않는 폴더를 경로를 직접 입력하여 지정한 경우에도 마찬가지입니다.

저장소의 모든 심볼 및 풋프린트 모델 라이브러리를 지정된 로컬 작업 폴더로 빠르게 체크아웃하려면 SVNDatabaseLib Editor의 기본 Tools 메뉴에서 Check Out All Working Folders 명령을 실행합니다. 체크아웃되는 폴더는 Database Library Options 대화 상자의 SVN Repository 탭에 있는 Models Location Region에 지정된 폴더입니다.

SVN 저장소에 저장되어 있고 Database Library Options의 일부로 지정된 심볼과 풋프린트를 로컬 작업 폴더로 체크아웃한 예.SVN 저장소에 저장되어 있고 Database Library Options의 일부로 지정된 심볼과 풋프린트를 로컬 작업 폴더로 체크아웃한 예.

변경하기

심볼 및 풋프린트 모델 라이브러리를 지정된 로컬 작업 폴더로 체크아웃한 후에는 필요할 때 수정할 수 있습니다. 이 과정에서는 Schematic 심볼과 풋프린트 모델의 로컬 복사본을 수정한 다음 변경 사항을 SVN 저장소에 커밋합니다.

DbLib와 마찬가지로, 다음 방법으로 심볼/모델에 접근하여 편집할 수 있습니다.

  • SVNDbLib 문서의 Table Browser에서 컴포넌트의 Entry를 마우스 오른쪽 버튼으로 클릭한 다음 컨텍스트 메뉴에서 Open Symbol 또는 Open Footprint 중 적절한 명령을 선택합니다.
참조된 심볼/풋프린트가 있는 로컬 라이브러리가 열립니다. 데이터베이스에 라이브러리 정보가 있으면 해당 정보로 라이브러리를 찾고, 정보가 없으면 Database Library Options 대화 상자의 SVN Repository 탭에 정의된 모델 위치를 사용합니다. 데이터베이스 라이브러리의 심볼 및 모델 라이브러리 위치 지정 섹션을 다시 참조하세요.
  • SVNDbLib가 Available File-based Libraries 목록에 추가되어 있으면 컴포넌트 Panel에서 직접 편집 명령에 접근할 수 있습니다. 필요한 컴포넌트 Entry를 선택한 다음, 각각 Edit Symbol 명령(Components Region의 마우스 오른쪽 버튼 컨텍스트 메뉴) 또는 Edit Footprint 명령(Models Region의 마우스 오른쪽 버튼 컨텍스트 메뉴)을 사용합니다.
  • 라이브러리 Editor의 File » Open 명령으로 로컬 작업 폴더에 있는 필요한 라이브러리를 찾아 엽니다.
  • Windows 탐색기에서 로컬 작업 폴더에 있는 라이브러리 파일을 Altium Designer로 직접 끌어다 놓습니다.

어떤 방법을 사용하든 필요한 변경을 완료한 후에는 라이브러리 파일을 저장합니다.

다만, 로컬 작업 폴더로 체크아웃된 폴더 및 파일과 저장소 자체 사이의 기본 인터페이스는 Storage Manager Panel입니다. SVNDbLib 파일이 활성 문서이면 Storage Manager Panel에 로컬 작업 폴더로 체크아웃된 심볼 및 모델 폴더가 표시됩니다. 표시되는 폴더는 Database Library Options 대화 상자의 SVN Repository 탭에 있는 Model Locations Region에 지정된 폴더입니다.

Altium Designer에서 SVNDbLib 파일이 활성 문서인 경우, Storage Manager Panel은 로컬 작업 폴더의 내용을 표시합니다. Altium Designer에서 SVNDbLib 파일이 활성 문서인 경우, Storage Manager Panel은 로컬 작업 폴더의 내용을 표시합니다.

라이브러리 파일을 열어 편집하려면 Panel의 All Files Region에서 해당 Entry를 마우스 오른쪽 버튼으로 클릭한 다음 나타나는 컨텍스트 메뉴에서 Open을 선택합니다. 필요에 따라 변경한 후, 관련 Editor의 표준 Save 명령을 사용하여 평소와 같이 파일을 저장합니다.

저장소에 변경 사항 커밋

Panel page: Storage Manager

라이브러리를 열어 편집하는 방법은 여러 가지이지만, Altium Designer within에서 변경 사항을 커밋하는 작업은 Storage Manager Panel을 통해서만 수행할 수 있습니다.

Altium Designer에서 저장소에 커밋하고 저장소에서 업데이트하는 컨트롤은 Storage Manager Panel에서만 사용할 수 있습니다. 물론 외부 SVN 클라이언트의 기능을 사용하면 Altium Designer 외부에서도 커밋, 업데이트 및 변경 사항 확인을 수행할 수 있습니다.

Storage Manager Panel을 사용할 때 기억해야 할 가장 중요한 사항 중 하나는 로컬 작업 폴더/파일(Panel에 표시됨)과 소스 제어 저장소의 해당 폴더/파일 간 연결 상태를 새로 고치는 것입니다. 개별적으로 선택한 라이브러리의 경우 Panel의 All Files Region에서 마우스 오른쪽 버튼을 클릭하면 나타나는 메뉴의 Refresh 명령을 사용하여 이 작업을 수행할 수 있습니다. 전체 폴더의 상태를 빠르게 새로 고치려면 Ctrl+F5 키보드 단축키를 사용하십시오.

여러 사람이 소스 심볼 및 모델 파일 저장소를 유지 관리하는 다중 라이브러리 관리자 환경에서는 소스 라이브러리의 상태를 새로 고치는 작업이 더욱 중요합니다.

로컬 심볼 및 모델 라이브러리 작업과 관련된 상태 항목은 다음과 같습니다.

아이콘 상태 설명
SVN icon - Normal No modification 라이브러리의 로컬 복사본이 저장소의 복사본과 동일합니다. 파일을 열고 자유롭게 수정할 수 있습니다.
SVN icon - Out of Date Out of date 작업 폴더에 있는 파일의 로컬 복사본이 저장소의 해당 파일보다 오래되어 최신 상태가 아닙니다. 파일을 수정하고 변경 사항을 커밋하려면 먼저 저장소에서 최신 버전의 파일을 가져와 로컬 작업 복사본을 업데이트해야 합니다. 마우스 오른쪽 버튼 클릭 컨텍스트 메뉴의 Update 명령을 사용하여 저장소에서 최신 파일을 가져오십시오.
SVN icon - Modified Modified 파일의 로컬 복사본이 Altium Designer에서 수정되어 작업 폴더에 저장되었습니다. 로컬 변경 사항을 저장소에 반영하려면 파일 항목을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Commit 명령을 선택하십시오. 저장소에 체크인되면 상태가 No modification(으)로 돌아갑니다.
SVN icon - Conflict Conflict 사용자가 편집하고 저장한 파일 버전을 커밋하기 전에 다른 Altium Designer 사용자가 해당 파일을 커밋했습니다. Update 또는 Resolve 명령을 사용하여 저장소의 최신 리비전으로 사용할 파일 버전을 결정하십시오.
SVN icon - Locked Locked 사용자 본인 또는 다른 사용자가 파일을 잠갔습니다. 잠긴 파일은 강제로 잠금을 해제하지 않는 한 다른 사용자가 저장소에서 새 리비전으로 업데이트할 수 없습니다. 이 상태는 Modified SVN icon - Locked and Modified 또는 No Modification SVN icon - Locked not Modified 등의 다른 상태 조건도 적용되는 경우 해당 아이콘과 함께 표시될 수 있습니다.
버전 제어 작업에 대한 자세한 내용은 외부 버전 제어 사용을 참조하십시오.

리비전의 Physical 비교

동일한 심볼(모델 라이브러리)의 두 리비전 간에 Physical 비교를 수행할 수 있습니다. 이를 통해 파일의 연속된 리비전이나 연속되지 않은 리비전 간에 발생한 변경 사항을 시각적으로 명확하게 확인할 수 있습니다.

Storage Manager Panel에서는 Panel 하단의 VCS Revisions Region에서 비교를 수행합니다.

Storage Manager Panel은 VCS 리비전과 로컬 기록을 별도의 Region으로 구분하여 선택한 파일의 기록을 두 가지 보기로 제공합니다. Storage Manager Panel은 VCS 리비전과 로컬 기록을 별도의 Region으로 구분하여 선택한 파일의 기록을 두 가지 보기로 제공합니다.

어떤 두 리비전 간에도 비교할 수 있습니다. Windows의 Ctrl+click 선택 방식을 사용하여 Panel의 VCS Revisions Region에서 비교할 라이브러리 리비전 두 개를 선택한 다음, 마우스 오른쪽 버튼을 클릭하고 Compare을 선택하십시오.

Compare 명령을 실행하면 선택한 두 문서 리비전이 워크스페이스에 나란히 열리고 그래픽 비교가 수행되며, 두 리비전 사이에서 감지된 차이점이 Differences Panel에 나열됩니다.

라이브러리 Editor의 설계 공간에서 직접 수행하는 그래픽 비교.라이브러리 Editor의 설계 공간에서 직접 수행하는 그래픽 비교.

AI-LocalizedAI로 번역됨
만약 문제가 있으시다면, 텍스트/이미지를 선택하신 상태에서 Ctrl + Enter를 누르셔서 저희에게 피드백을 보내주세요.
Nav
Contents
기능 가용성

사용할 수 있는 기능은 보유한 Altium 솔루션(Altium Develop, Altium Agile Teams, Altium Agile Enterprise, 또는 Altium Designer(활성 기간 중))에 따라 달라집니다.

실제 소프트웨어에서 문서화된 기능이 보이지 않는 경우, Altium 영업팀에 문의하여 자세한 내용을 확인하세요.

구버전 문서

Altium Designer 문서는 더 이상 버전별로 제공되지 않습니다. 이전 버전의 Altium Designer 문서가 필요하신 경우, Other Installers 페이지의 Legacy Documentation 섹션을 방문해 주세요.

Contents