데이터베이스 라이브러리 마이그레이션 도구

개요

Altium Designer에서 제공하는 데이터베이스 라이브러리 마이그레이션 도구를 살펴보고, 통합 라이브러리를 표준 데이터베이스 라이브러리(DbLib) 또는 버전 관리형 SVN 데이터베이스 라이브러리(SVNDbLib)로 변환하는 단계별 방법을 알아보세요. 이 문서에서는 변환 마법사가 컴포넌트 데이터, 심볼 및 풋프린트를 처리하는 방식을 설명하고, 데이터베이스 제약 사항과 설정 요구 사항을 짚어봅니다. 계속 읽으며 적합한 변환 방식을 선택하고 라이브러리 마이그레이션을 준비하세요.

- DbLib와 SVNDbLib를 각각 어떤 경우에 사용해야 하는지 알아보세요.
- 변환 마법사를 구성하고, 원본 라이브러리를 선택하며, 대상 데이터베이스와 저장소를 지정하는 방법을 알아보세요.
- Access만 지원하는 변환 기능, SVN 저장소 사전 준비, 모델 링크 처리 등 주요 요구 사항과 제한 사항을 확인하세요.
AI로 더 깊이 알아보기:

Altium 설계 소프트웨어에서는 데이터베이스 라이브러리를 생성하고 사용하여 회사 데이터베이스에서 직접 컴포넌트를 배치할 수 있습니다. 사용할 데이터베이스 라이브러리 유형은 소스 심볼 및 모델 라이브러리를 관리하는 방식에 따라 달라집니다. 라이브러리를 하드 디스크나 네트워크 드라이브에 보관하려면 Database Library(DbLib)를 사용하면 됩니다. 반면, Subversion 저장소를 사용하여 라이브러리를 소스 제어 하에 관리하려면 SVN Database Library(SVNDbLib)를 사용합니다.

어떤 유형의 데이터베이스 라이브러리를 사용하든 이 기능의 기본 원리는 같습니다. 즉, 연결된 외부 데이터베이스에서 직접 배치할 수 있다는 것입니다. 이 강력한 기능을 최대한 쉽게 활용할 수 있도록 기존 라이브러리를 데이터베이스 라이브러리 구조로 빠르게 옮기는 도구가 제공됩니다. 이러한 도구를 사용하면 다음과 같은 마이그레이션이 가능합니다.

  • 통합 라이브러리에서 Database Library(DbLib 또는 SVNDbLib)로 마이그레이션.
  • Database Library(DbLib 또는 SVNDbLib)에서 통합 라이브러리로 마이그레이션.
  • 소스 Schematic/PCB 라이브러리에서 SVN Database Library로 마이그레이션.
  • Database Library에서 SVN Database Library로 마이그레이션.
  • OrCAD 컴포넌트 정보 시스템(CIS)에서 Database Library(DbLib)로 마이그레이션.

다음 섹션에서는 소프트웨어 내에서 이러한 마이그레이션을 수행하는 방법을 자세히 살펴봅니다.

통합 라이브러리에서 데이터베이스 라이브러리 생성하기

통합 라이브러리는 본질적으로 안전하며, 회사 외부로 전달되는 설계에 적합한 뛰어난 이식성도 갖추고 있습니다. 설계를 사내에 보관하거나 Altium 설계 컴포넌트를 회사 데이터베이스와 긴밀하게 연동하려는 경우에는 데이터베이스 라이브러리가 가장 적합합니다. 소프트웨어에서는 회사의 통합 라이브러리를 Database Library(DbLib) 또는 SVN Database Library(SVNDbLib) 구조로 빠르게 변환할 수 있습니다. 여러 통합 라이브러리를 한 번에 변환할 수 있으며, 각 라이브러리는 타겟 데이터베이스에 별도의 테이블로 추가됩니다.

DbLib로 변환하기

통합 라이브러리(IntLib)에서 표준 데이터베이스 라이브러리(DbLib)를 생성하려면 Integrated Library to Database Library Translator Wizard를 사용합니다. 이 Wizard는 기본적으로 지정된 통합 라이브러리를 디컴파일하여 선택한 타겟 데이터베이스에 라이브러리별로 별도의 데이터베이스 테이블을 생성합니다. 이때 라이브러리 내 컴포넌트에서 추출한 파라미터 및 모델 정보도 함께 포함됩니다. 그런 다음 지정된 데이터베이스 라이브러리 파일을 사용하여 해당 데이터베이스에 대한 연결을 제공합니다.

이 Wizard를 사용하면 기존 DbLib 파일을 통해 연결된 기존 데이터베이스로 추가 컴포넌트를 가져오거나 덧붙일 수도 있습니다.
변환은 Access 유형의 데이터베이스만 지원합니다.

하나 이상의 소스 통합 라이브러리를 데이터베이스 라이브러리 구조로 옮기는 작업은 Integrated Library to Database Library Translator Wizard를 통해 간편하게 수행할 수 있습니다.하나 이상의 소스 통합 라이브러리를 데이터베이스 라이브러리 구조로 옮기는 작업은 Integrated Library to Database Library Translator Wizard를 통해 간편하게 수행할 수 있습니다.

절차는 다음과 같습니다.

  1. 새 데이터베이스 라이브러리 파일(*.DbLib)을 생성하거나 기존 파일을 엽니다. 일반적으로 하나 이상의 통합 라이브러리를 기존 Access 데이터베이스로 변환할 때는 해당 데이터베이스에 현재 연결되어 있는 기존 DbLib 파일을 사용합니다.
  2. Database Library 파일(*.DbLib)이 활성 문서로 열린 상태에서 기본 메뉴의 Tools » Import From Integrated Libraries 명령을 선택하여 Integrated Library to Database Library Translator Wizard에 액세스합니다.
  3. Wizard의 첫 번째 Specify your Database details 페이지에서 타겟 데이터베이스를 새 Access 데이터베이스 또는 기존 데이터베이스로 지정합니다. 새 데이터베이스를 생성하는 경우 Database Location 필드 오른쪽의 폴더 아이콘을 클릭하여 표준 Open 대화상자를 엽니다. 이 대화상자에서 새 데이터베이스를 생성할 위치와 이름을 지정합니다. 선택한 이름과 경로는 Database Location 필드에 입력됩니다.

    기존 DbLib 파일에서 Wizard를 실행한 경우 Existing Access Database 옵션이 기본적으로 선택되며, Database Location 필드에는 해당 DbLib 파일이 연결된 데이터베이스가 미리 입력됩니다.
  4. Wizard의 다음 Specify your Target Database Library 페이지에서 타겟 데이터베이스 라이브러리 파일을 지정합니다. 생성할 새 DbLib 파일의 경로와 이름을 지정하거나 기존 파일을 찾아 엽니다. 일반적으로 하나 이상의 통합 라이브러리를 기존 Access 데이터베이스로 변환할 때는 해당 데이터베이스에 현재 연결되어 있는 기존 DbLib 파일을 사용합니다. 기본적으로 이 필드에는 활성 DbLib 파일이 미리 입력됩니다.

    기존 DbLib 파일을 사용하면서 타겟 데이터베이스를 변경하면, Wizard가 완료된 후 해당 DbLib 파일은 새 타겟 데이터베이스에 연결됩니다.
  5. Wizard의 다음 Locate the Integrated Libraries to Import 페이지에서 변환할 통합 라이브러리를 지정합니다. Add 버튼을 사용하여 Select Source Integrated Libraries 대화상자를 열고 필요한 라이브러리를 찾아 선택합니다. 통합 라이브러리를 구성하는 Schematic 심볼 및 모델 라이브러리(있는 경우)는 추출되어 Destination Folder 필드에 지정된 위치에 저장됩니다. Remove  및 Clear  버튼을 사용하여 선택한 라이브러리를 목록에서 제거하거나 삭제합니다.

    기본적으로 Destination Folder는 DbLib 파일이 있는 폴더(Wizard의 이전 페이지에서 지정한 폴더) 아래의 하위 폴더인 Libraries를 가리킵니다.
  6. 소스 통합 라이브러리를 선택한 후 Next를 클릭하여 변환을 진행합니다. 진행률 표시줄과 현재 변환 중인 라이브러리에 대한 정보가 표시됩니다. 변환이 완료되면 Wizard의 마지막 페이지에서 Finish를 클릭하여 지정된 DbLib 파일을 기본 설계 창에서 활성화합니다(아직 활성화되지 않은 경우).

    변환에 포함된 각 통합 라이브러리는 데이터베이스에 해당 통합 라이브러리의 이름을 가진 별도의 테이블로 생성됩니다. 기존 데이터베이스에 통합 라이브러리와 이름이 같은 테이블이 이미 있는 경우에는 해당 라이브러리의 정보가 기존 테이블에 추가됩니다.

변환 프로세스가 완료된 후의 DbLib 파일.
변환 프로세스가 완료된 후의 DbLib 파일.

변환 프로세스가 완료되면 소스 Schematic 라이브러리로 이동하여 심볼에서 모든 파라미터 및 모델 정보를 제거할 수 있습니다. 그런 다음 필요에 따라 DbLib 문서의 필드 매핑 설정을 세부 조정하여 적절한 데이터베이스 열을 참조하도록 할 수 있습니다. 자세한 내용은 데이터베이스 라이브러리 생성 및 정의 페이지의 데이터베이스 필드를 설계 파라미터에 매핑하기 섹션을 참조하세요.

Wizard는 풋프린트 모델 정보 중 모델 참조와 정의된 모델의 경로만 추출합니다. 시뮬레이션 모델의 경우 링크 정보를 외부 데이터베이스에 수동으로 입력해야 합니다.
IntLib 내 Schematic 라이브러리 컴포넌트에 Part Number 파라미터가 없는지 확인하세요. 데이터베이스에 입력되는 부품 번호 정보(각 컴포넌트 레코드를 식별하는 데 사용됨)는 선택한 라이브러리 컴포넌트의 속성을 확인할 때 표시되는 Properties 패널의 General 탭에 있는 Properties 섹션의 Design Item ID 필드에서 가져옵니다. 이 정보를 파라미터로도 입력하면 값이 중복되어 변환이 실패합니다.

SVNDbLib로 변환하기

통합 라이브러리(IntLib)에서 버전 관리되는 데이터베이스 라이브러리(SVNDbLib)를 생성하려면 SVN Database Library Conversion Wizard을 사용합니다. 이 Wizard는 기본적으로 지정된 통합 라이브러리를 디컴파일하며, 각 라이브러리를 사용해 새 타겟 데이터베이스에 별도의 데이터베이스 테이블을 생성합니다. 각 테이블에는 해당 라이브러리의 컴포넌트에서 추출한 파라미터 및 모델 정보가 포함됩니다. 그런 다음 지정된 SVN 데이터베이스 라이브러리 파일이 생성되며, 이 파일을 통해 해당 데이터베이스에 연결합니다. 통합 라이브러리를 구성하는 Schematic 및 PCB 라이브러리는 분할되어 지정된 SVN 버전 관리 리포지토리의 지정 디렉터리에 커밋되며, SVNDbLib 파일은 이러한 디렉터리를 참조합니다.

변환 시에는 Access 유형의 데이터베이스만 사용할 수 있습니다.

하나 이상의 원본 통합 라이브러리를 SVN 데이터베이스 라이브러리 구조로 가져오는 작업은 SVN Database Library Conversion Wizard을 사용하여 간편하게 수행할 수 있습니다.하나 이상의 원본 통합 라이브러리를 SVN 데이터베이스 라이브러리 구조로 가져오는 작업은 SVN Database Library Conversion Wizard을 사용하여 간편하게 수행할 수 있습니다.

이 과정은 다음 단계로 이루어집니다.

  1. SVN Database Library Conversion Wizard에 액세스합니다. 다음 방법을 사용할 수 있습니다.
  • Schematic 라이브러리 편집기, PCB 라이브러리 편집기 또는 데이터베이스 라이브러리 편집기의 기본 메뉴에서 Tools » SVN Database Library Maker 명령을 선택합니다.
  • Projects 패널에서 프로젝트 라이브러리(SchLib, PcbLib 또는 IntLib) 항목을 마우스 오른쪽 버튼으로 클릭한 다음 컨텍스트 메뉴에서 SVN Database Library Maker 명령을 선택합니다.
  1. Libraries to Convert 페이지에서 변환할 통합 라이브러리를 지정합니다. 목록에는 처음에 하나 이상의 라이브러리가 미리 채워져 있습니다(접근 방법에 따라 활성 라이브러리 또는 프로젝트에 추가된 모든 프로젝트 라이브러리). 변환할 통합 라이브러리를 선택하기 전에 목록에서 이러한 항목을 제거합니다. Add 버튼을 사용해 Library Files 대화상자를 열고 필요한 통합 라이브러리를 찾아 선택합니다.
  2. Options 페이지에서 원본 라이브러리를 분할하는 방법, 저장할 리포지토리와 해당 디렉터리, SVNDbLib 파일의 출력 디렉터리 등 변환 관련 옵션을 정의합니다. Schematic 라이브러리의 경우, 각 구성 컴포넌트에서 파라미터 및/또는 모델 정보를 제거하여 심볼만 남길 수 있는 두 가지 옵션도 제공됩니다.

    SVN 리포지토리와 폴더 구조는 미리 정의되어 있어야 합니다. 여기서는 분할된 라이브러리 파일을 저장할 리포지토리와 그 구조 내의 폴더를 지정하기만 합니다. 리포지토리와 폴더는 작업 중에 자동으로 생성되지 않습니다.
  3. 원본 통합 라이브러리를 선택하고 필요에 따라 관련 변환 옵션을 설정한 후 Next 을 클릭하여 변환을 진행합니다. 현재 변환 중인 라이브러리에 대한 정보와 함께 진행률 표시줄이 나타납니다. 변환 과정에는 다음 작업이 포함됩니다.
    1. 제공된 통합 라이브러리에서 원본 라이브러리를 추출합니다.
    2. Schematic 및 PCB 라이브러리를 싱글 심볼/풋프린트 라이브러리 파일로 분할합니다.
    3. 분할된 심볼 및 풋프린트 라이브러리를 리포지토리의 지정된 기본 디렉터리에 커밋합니다.
    4. Wizard는 풋프린트 모델 참조 정보만 추출합니다. 버전 관리되는 데이터베이스 라이브러리(SVNDbLib)에서는 연결된 시뮬레이션 모델을 지원하지만, Subversion 리포지토리에 시뮬레이션 모델 파일을 저장하는 것은 지원하지 않습니다. 이러한 링크가 있으면 파라미터로 추가됩니다.
    5. 변환되는 각 통합 라이브러리에 대해 생성된 Access 데이터베이스(SVNDbLib에 지정한 이름과 동일한 이름 사용)에 별도의 데이터베이스 테이블을 생성하며, 해당 라이브러리의 컴포넌트에서 추출한 파라미터 및 모델 정보를 포함합니다. 각 테이블의 이름은 통합 라이브러리 이름에 _IntLib 접미사를 붙여 지정합니다(예: Capacitor - Ceramic_IntLib).
    6. 지정된 SVNDbLib 파일을 생성하고 데이터베이스 및 리포지토리에 연결합니다.
  4. 변환이 완료되면 Finish 을 클릭하여 Wizard를 닫고 SVNDbLib 파일을 활성 문서로 설정합니다.

변환 과정이 완료된 후의 SVNDbLib 파일.변환 과정이 완료된 후의 SVNDbLib 파일.

IntLib의 Schematic 라이브러리 컴포넌트에 Part Number 파라미터가 없는지 확인하세요. 데이터베이스에 입력되는 부품 번호 정보(각 컴포넌트 레코드 식별용)는 선택한 라이브러리 컴포넌트의 속성을 확인할 때 Properties 패널의 General 탭에 있는 Properties 섹션의 Design Item ID 필드에서 가져옵니다. 이를 파라미터로도 입력하면 값이 중복되어 변환에 실패합니다.

데이터베이스 라이브러리에서 통합 라이브러리 생성하기

데이터베이스 라이브러리는 Altium 설계 컴포넌트를 회사 데이터베이스와 긴밀하게 연계하려는 경우에 이상적인 선택입니다. 설계를 회사 외부로 전달해야 하거나 설계자가 안전한 통합 라이브러리를 사용해 작업하도록 하려는 경우에도 손쉽게 대응할 수 있습니다. 이 소프트웨어는 표준 데이터베이스 라이브러리(DbLib) 또는 버전 관리되는 SVN 데이터베이스 라이브러리(SVNDbLib)에서 직접 통합 라이브러리를 컴파일하는 기능을 제공합니다. 이를 통해 CAD 라이브러리 관리자는 데이터베이스 라이브러리를 계속 사용하고, 설계자는 정기적으로 다시 생성되는 통합 라이브러리를 사용하여 이른바 '오프라인' 방식으로 작업할 수 있습니다.

변환은 Offline Integrated Library Maker을 사용하여 수행합니다. 이 과정은 데이터베이스 테이블별로 진행되며, 변환할 데이터베이스 테이블을 완전히 제어할 수 있습니다. 변환 과정에는 Schematic 컴포넌트, PCB, PCB3D 및 시뮬레이션 모델이 포함됩니다. 포함된 각 테이블에 대해 별도의 통합 라이브러리가 생성됩니다. 해당 테이블은 개별 통합 라이브러리로 변환된 후 Installed Libraries에 추가됩니다.

Offline Integrated Library Maker.
Offline Integrated Library Maker.

을 사용하여 데이터베이스 라이브러리(DbLib 또는 SVNDbLib)를 '오프라인' 통합 라이브러리로 변환하세요. 이 과정은 다음 단계로 이루어집니다.

  1. 변환할 데이터베이스 라이브러리 파일(*.DbLib) 또는 SVN 데이터베이스 라이브러리 파일(*.SVNDbLib)을 활성 문서로 연 상태에서 기본 메뉴의 Tools » Offline Integrated Library Maker 명령을 선택하여 Offline Integrated Library Maker에 액세스합니다.
  2. Library to Convert 페이지에서 처리할 DbLib 또는 SVNDbLib를 지정합니다. 기본적으로 Offline Integrated Library Maker 에 액세스할 때 활성 상태였던 라이브러리가 변환할 라이브러리로 지정됩니다. 필요한 경우 다른 데이터베이스 라이브러리를 자유롭게 찾아 선택할 수 있습니다.

  3. Options 페이지에서 연결된 데이터베이스의 테이블 중 변환에 포함할 테이블을 지정합니다. 기본적으로 모든 데이터베이스 테이블이 포함됩니다. 테이블을 제외하려면 해당 Convert 옵션을 비활성화합니다. 이 페이지에서는 생성된 통합 라이브러리를 저장할 출력 디렉터리도 지정할 수 있습니다. 이 기본 디렉터리의 경로를 직접 입력하거나, 필드 오른쪽의 Browse icon 아이콘을 클릭하여 대화상자를 열고 필요한 디렉터리를 찾아 선택합니다. 포함된 각 데이터베이스 테이블에 대해 생성된 출력물(통합 라이브러리)은 지정된 출력 디렉터리 내의 개별 하위 폴더에 저장되며, 하위 폴더에는 해당 테이블의 이름이 사용됩니다.

  4. 데이터베이스 라이브러리를 선택하고 필요에 따라 관련 변환 옵션을 설정한 후, Next 을 클릭하여 변환을 진행합니다. 진행률 표시줄과 함께 현재 변환 중인 데이터베이스 테이블에 대한 정보가 표시됩니다. 변환하도록 지정한 각 데이터베이스 테이블에 대해 변환 프로세스가 수행된다는 점을 기억하세요. 이 프로세스의 주요 단계는 다음과 같습니다.
    1. 통합 라이브러리 패키지(*.LibPkg)가 생성되고 Projects Panel에서 열립니다. 패키지 이름은 테이블 이름을 사용하여 지정됩니다. 예를 들어 테이블 이름이 Capacitor - Ceramic이면 패키지 이름은 Capacitor - Ceramic.LibPkg이 됩니다.
    2. Schematic 라이브러리 문서가 생성되어 LibPkg에 추가됩니다. 이 Schematic의 이름도 테이블 이름을 사용하여 지정됩니다(예: Capacitor - Ceramic.SchLib).
    3. 그런 다음 테이블의 각 레코드를 검토하여 해당 Altium 설계 컴포넌트를 구성합니다. 이를 위해 참조된 Schematic 심볼을 해당 소스 라이브러리에서 가져와 새 Schematic 라이브러리 문서에 컴포넌트로 추가합니다. 이후 레코드에 정의된 파라미터 및 모델 링크 정보를 해당 컴포넌트에 추가합니다.
    4. 레코드에서 참조하는 풋프린트 모델을 가져와 PCB 라이브러리 문서에 추가합니다. 이 문서의 이름도 테이블 이름을 따릅니다(예: Capacitor - Ceramic.PcbLib). 그런 다음 PCB 라이브러리 문서를 LibPkg에 추가합니다.
    5. 소스 라이브러리가 DbLib이고 데이터베이스 레코드에 시뮬레이션 모델 링크가 정의되어 있으면, 참조된 시뮬레이션 모델 파일도 LibPkg에 추가됩니다. 이러한 모델의 위치는 변경되지 않습니다. 모델의 전체 경로는 해당 모델 링크의 일부로 지정됩니다.
    6. 그런 다음 LibPkg를 컴파일하여 통합 라이브러리(예: Capacitor - Ceramic.IntLib)를 생성하고, 이를 소프트웨어의 설치된 라이브러리에 추가합니다.

현재 설치된 라이브러리는 Available File-based Libraries 대화 상자의 Installed 탭에서 확인할 수 있습니다. 이 대화 상자는 컴포넌트 Panel 오른쪽 상단의 Open Libraries dialogs in Components Panel 버튼을 클릭한 다음 File-based Libraries Preferences을 선택하여 열 수 있습니다.

변환 프로세스 결과: 구성 요소인 심볼 및 풋프린트 모델 문서가 포함된 라이브러리 패키지 프로젝트와 컴파일된 IntLib입니다. IntLib는 설치된 라이브러리로도 추가되므로 모든 PCB 설계 프로젝트에서 사용할 수 있습니다.
변환 프로세스 결과: 구성 요소인 심볼 및 풋프린트 모델 문서가 포함된 라이브러리 패키지 프로젝트와 컴파일된 IntLib입니다. IntLib는 설치된 라이브러리로도 추가되므로 모든 PCB 설계 프로젝트에서 사용할 수 있습니다.

소스 라이브러리(SCHLib/PCBLib)에서 SVNDbLib 생성하기

SVN Database Library Conversion Wizard는 Schematic, PCB, 데이터베이스 및 통합 라이브러리를 SVN 데이터베이스 라이브러리로 변환하는 데 도움이 됩니다. 이 Wizard는 다양한 컴포넌트 관리 방식을 SVN 데이터베이스 라이브러리(*.SVNDBLib)로 전환하는 프로세스를 간소화합니다. SVN 데이터베이스 라이브러리는 데이터베이스에서 직접 컴포넌트를 배치하는 기능을 기반으로, 이러한 연결 방식을 확장하여 소스 제어되는 라이브러리를 지원합니다. 이때 Schematic 심볼과 풋프린트 모델은 Subversion 기반 저장소에 보관됩니다. 저장소 및 외부 데이터베이스에 대한 링크는 SVN 데이터베이스 라이브러리 파일(*.SVNDBLib) 내에 정의됩니다. 이 파일은 데이터베이스 라이브러리 파일(*.DBLib)의 확장 형식이며, 흔히 Version-Controlled Database Library라고 합니다.

Wizard를 사용하여 소스 라이브러리 분할 방식, 저장할 저장소와 디렉터리, SVNDBLib 파일의 출력 디렉터리 등 변환 관련 옵션을 정의합니다. 

변환할 데이터베이스 또는 Schematic(*.SchLib), PCB(*.PcbLib), 통합 라이브러리(*.IntLib)를 선택해야 하며, 선택한 라이브러리는 변환 후 SVN 저장소에 체크인됩니다. 하나의 SVN 데이터베이스 라이브러리도 생성됩니다. 

이 Wizard에서는 SVN 저장소 연결, 심볼 및 모델의 기본 디렉터리, SVN 데이터베이스 라이브러리 문서의 경로를 정의할 수 있습니다. 기본적으로 출력 디렉터리는 소스 라이브러리가 저장된 디렉터리와 동일하게 설정됩니다.

생성된 SVNDBLib 파일과 데이터베이스를 같은 위치에 두려면 기본적으로 두 가지 방법이 있습니다. 첫 번째는 SVNDBLib의 출력 경로를 데이터베이스가 현재 위치한 디렉터리와 동일하게 설정하는 것입니다. 두 번째는 SVNDBLib를 다른 디렉터리에 생성한 다음 데이터베이스를 해당 디렉터리로 이동하는 것입니다. 이 경우 SVNDBLib 파일 내의 연결을 수정하여 새 위치의 데이터베이스를 가리키도록 한 후 다시 연결해야 합니다.

  • 분할된 라이브러리 파일은 SVN 저장소에 추가되므로, 저장소에서 사용할 심볼/모델 파일의 폴더 구조를 로컬 하드 디스크에 별도로 설정해야 합니다. 저장소 내 폴더 구조는 TortoiseSVN과 같은 SVN 클라이언트를 사용하여 관리합니다.
  • 컴퓨터에 SVN 저장소와 SVN 버전 제어 시스템이 설치되어 있거나 네트워크를 통해 이를 사용할 수 있어야 합니다. 또한 Preferences 대화 상자의 Data Management - Version Control 페이지에서 Provider가  SVN - Subversion로 설정되어 있는지 확인하세요.
  • 변환에는 Access 형식의 데이터베이스만 사용할 수 있습니다.

SVN Database Library Conversion Wizard하나 이상의 소스 Schematic 및 PCB 라이브러리를 SVN 데이터베이스 라이브러리 구조로 가져오는 작업은 SVN Database Library
Conversion
Wizard를 사용하면 간편하게 수행할 수 있습니다.

이 프로세스는 다음 단계로 진행됩니다.

  1. 다음 방법으로 SVN Database Library Conversion Wizard를 엽니다.

    • Schematic 라이브러리 파일(*.SchLib), PCB 라이브러리 파일(*.PcbLib), 통합 라이브러리 파일(*.IntLib) 또는 데이터베이스 라이브러리 파일(*.DbLib)에서 Tools » SVN Database Library Maker을 클릭합니다. 단, Schematic 라이브러리에서 Wizard를 열어 연결된 풋프린트 모델도 변환에 포함하려면 해당 PCB 풋프린트 라이브러리를 찾아 추가해야 합니다. 또한 PCB 풋프린트 라이브러리만 변환하는 것은 일반적인 사용 사례가 아니므로 해당 Schematic 컴포넌트 라이브러리를 찾아 추가해야 합니다.
    • Projects Panel에서 필요한 라이브러리(*.SchLib, *.PcbLib 또는 *.IntLib) 항목을 마우스 오른쪽 버튼으로 클릭한 다음 SVN Database Library Maker을 선택합니다. Wizard가 모든 프로젝트 라이브러리를 자동으로 불러옵니다. 이 방법이 가장 간단하며, 소스 Schematic 및 PCB 라이브러리가 프로젝트에 추가되어 있어야 합니다. 통합 라이브러리를 사용하지 않은 경우에는 대개 이러한 조건이 충족됩니다.
    Wizard는 실행된 위치에 따라 라이브러리 항목을 미리 채웁니다. 따라서 시간을 절약하려면 아래 설명에 따라 적절한 편집기에서 Wizard를 실행하세요.

  2. Libraries to Convert 페이지에서 변환할 라이브러리를 선택합니다. 데이터베이스 라이브러리 또는 Schematic, PCB 및 통합 라이브러리 중에서 선택할 수 있습니다. 선택한 라이브러리는 개별 컴포넌트 라이브러리로 분할된 다음 SVN 저장소에 체크인됩니다. 하나의 SVN 데이터베이스가 생성됩니다.

    • Converting a Database Library

      Database Libraries 변환 시 변환 과정에는 다음이 포함됩니다.

      1. 연결된 데이터베이스의 컴포넌트 레코드에서 참조하는 Schematic 및 PCB 라이브러리를 싱글 심볼/풋프린트 라이브러리 파일로 분할합니다.
      2. 분할된 심볼 및 풋프린트 라이브러리를 저장소의 지정된 기본 디렉터리에 커밋합니다.
      3. 지정된 SVNDBLib 파일을 생성하고 데이터베이스 및 저장소에 연결합니다.
    • Converting Schematic, PCB, and Integrated Libraries

      Add 버튼을 사용하여 표준 대화 상자를 열고 추가할 파일을 검색하여 선택합니다. 현재 선택된 라이브러리를 제거하려면 Remove 버튼을 클릭합니다.

      Schematic, PCB 및 통합 라이브러리 변환 시 변환 과정에는 다음이 포함됩니다.

      1. 제공된 통합 라이브러리에서 소스 라이브러리를 추출합니다.
      2. Schematic 및 PCB 라이브러리를 싱글 심볼/풋프린트 라이브러리 파일로 분할합니다.
      3. 분할된 심볼 및 풋프린트 라이브러리를 저장소의 지정된 기본 디렉터리에 커밋합니다.
      4. Wizard는 풋프린트 모델 참조 정보만 추출합니다. SVNDBLib는 연결된 PCB3D 및 시뮬레이션 모델을 지원하지 않습니다. 이러한 링크가 있으면 파라미터로 추가됩니다.
      5. 변환할 각 Schematic 라이브러리 및/또는 통합 라이브러리에 대해 생성된 Access 데이터베이스에 별도의 데이터베이스 테이블을 만들고, 컴포넌트에서 추출한 파라미터 및 모델 정보를 포함합니다. 각 테이블의 이름은 Schematic 라이브러리 이름에 _SchLib 접미사를 붙이거나(예: Mixer_SchLib), 통합 라이브러리 이름에 _IntLib 접미사를 붙여 지정합니다(예: AD Differential Amplifier_IntLib).
      6. 지정된 SVNDBLib 파일을 생성하고 데이터베이스 및 저장소에 연결합니다.
  3. Options 페이지에서 소스 라이브러리 분할 방식, 저장할 저장소와 디렉터리, SVNDbLib 파일의 Output 디렉터리 등 변환 관련 옵션을 정의합니다. Schematic 라이브러리의 경우 각 구성 컴포넌트에서 파라미터 및/또는 모델 정보를 제거하여 심볼만 남길 수 있는 두 가지 옵션도 제공됩니다.

    SVN 저장소와 폴더 구조는 미리 정의되어 있어야 합니다. 여기서는 분할된 라이브러리 파일을 저장할 저장소와 그 구조 내의 폴더를 지정하기만 합니다. 저장소와 폴더는 작업 중에 자동으로 생성되지 않습니다.

    SVN Options

    이 Region에서 SVN 저장소 연결 설정을 정의합니다. 

    Method 드롭다운에서 연결 방식을 선택합니다. file(파일 기반 저장소), http(클라우드 기반 저장소), https(보안 클라우드 기반 저장소), svn 또는 svn+ssh 중에서 선택할 수 있습니다. 

    Location  Region(Method에 file을 선택한 경우에만 사용 가능)은 저장소의 위치 경로를 설정하는 데 사용됩니다. 폴더 찾아보기 아이콘을 사용하여 원하는 위치를 검색하고 선택합니다. 

    Server Region(Method에 file이 not 선택된 경우에만 사용 가능)은 원하는 서버를 설정하는 데 사용됩니다.

    Server Port을 Default 또는 Non-Default으로 설정합니다. Non-Default를 선택한 경우 텍스트 상자에 서버 포트를 입력합니다. 텍스트 상자에 Repository folder의 이름도 입력해야 합니다.

    Server Port 및 Repository folder 옵션은 선택한 Method이 not file인 경우에만 사용할 수 있습니다. 

    ...을 클릭하여 각각 원하는 폴더를 검색하고 선택함으로써 Symbols 및 Footprints의 저장소 기본 디렉터리를 지정합니다.

    SVN DB Library Options

    SVN DB Library Options Region에서는 SVN 데이터베이스 라이브러리 문서의 경로를 지정할 수 있습니다. 현재 백엔드 Access 데이터베이스가 없으면 같은 폴더에 생성됩니다. 폴더 찾아보기 아이콘을 사용하여 경로를 검색하고 선택합니다.

    생성된 SVNDBLib 파일과 데이터베이스를 같은 위치에 두려면 기본적으로 두 가지 방법이 있습니다. 첫 번째는 SVNDBLib의 Output 경로를 데이터베이스가 현재 있는 디렉터리로 설정하는 것입니다. 두 번째는 다른 디렉터리에 SVNDBLib를 생성한 다음 데이터베이스를 해당 디렉터리로 이동하는 것입니다. 이 경우 SVNDBLib 파일 내의 연결이 새 위치의 데이터베이스를 가리키도록 수정하고 다시 연결해야 합니다.

    Library Splitting Options

    드롭다운을 사용하여 파일에 Overwrite Existing Files 또는 Append Incrementing Number To File Names 방식을 적용할지 선택합니다(라이브러리 분할 시 접미사가 추가된 새 파일 생성).  Overwrite Existing Files 을 선택하면 라이브러리가 분할될 때 저장소의 기존 파일을 덮어씁니다. Append Incrementing Number To File Names을 선택하면 지정된 저장소의 모든 파일이 보호되어 덮어쓰이지 않으며, 이름이 같은 새 컴포넌트 라이브러리에는 "_#IncrementNumber" 접미사가 추가됩니다.

    Schematic 라이브러리의 경우 분할된 Schematic 컴포넌트에서 파라미터 및/또는 모델 정보를 제거하여 심볼만 남길 수 있는 두 가지 옵션도 제공됩니다. Remove All Parameters 및/또는 Remove All Models를 선택합니다. 원본 DBLib 파일에 연결된 외부 데이터베이스가 이미 존재하므로 새 데이터베이스는 생성되지 않습니다. 데이터베이스는 현재 위치에 그대로 유지됩니다.

  4. 소스 Schematic 및 PCB 라이브러리를 선택하고 관련 변환 옵션을 필요에 맞게 설정한 후 Next 을 클릭하여 변환을 진행합니다. 현재 변환 중인 라이브러리 정보와 함께 진행률 표시줄이 표시됩니다. 변환 과정에는 다음이 포함됩니다.
    1. Schematic 및 PCB 라이브러리를 싱글 심볼/풋프린트 라이브러리 파일로 분할합니다.
    2. 분할된 심볼 및 풋프린트 라이브러리를 저장소의 지정된 기본 디렉터리에 커밋합니다.
    3. Wizard는 풋프린트 모델 참조 정보만 추출합니다. 버전 관리 데이터베이스 라이브러리(SVNDbLib)는 연결된 시뮬레이션 모델을 지원하지만, Subversion 저장소에 시뮬레이션 모델 파일을 저장하는 것은 지원하지 않습니다. 이러한 링크가 있으면 파라미터로 추가됩니다.
    4. 변환할 각 Schematic 라이브러리에 대해 생성된 Access 데이터베이스(SVNDbLib에 지정된 이름과 동일한 이름 사용)에 별도의 데이터베이스 테이블을 만들고, 해당 라이브러리의 컴포넌트에서 추출한 파라미터 및 모델 정보를 포함합니다. 각 테이블의 이름은 Schematic 라이브러리 이름에 _SchLib 접미사를 붙여 지정합니다(예: Capacitor - Ceramic_SchLib).
    5. 지정된 SVNDbLib 파일을 생성하고 데이터베이스 및 저장소에 연결합니다.
  5. 변환이 완료되면 Finish 을 클릭하여 Wizard를 닫고 SVNDbLib 파일을 활성 문서로 설정합니다.

변환 과정이 완료된 후의 SVNDbLib 파일입니다. 변환 과정이 완료된 후의 SVNDbLib 파일입니다. 

Schematic 라이브러리 컴포넌트에 Part Number 파라미터가 없는지 확인하십시오. 데이터베이스에서 각 컴포넌트 레코드를 식별하기 위해 입력하는 부품 번호 정보는 선택한 라이브러리 컴포넌트의 속성을 확인할 때 Properties 패널의 General 탭에 있는 Properties 섹션의 Schematic 컴포넌트 Design Item ID 필드에서 가져옵니다. 이 정보를 파라미터로도 입력하면 값이 중복되어 변환에 실패합니다. 프로세스 자체는 완료되지만, 이 파라미터가 있는 Schematic 컴포넌트는 데이터베이스에 생성되지 않으므로 SVNDbLib 문서의 Table Browser 탭에 있는 데이터베이스 컴포넌트 목록에도 표시되지 않습니다.

DbLib를 SVNDbLib로 변환

기존 통합 라이브러리를 DbLib 구조로 변환했거나 DbLib를 처음부터 생성하여 이미 데이터베이스 라이브러리 기능의 강력함을 활용하고 있을 수 있습니다. 여기서 더 나아가 소스 심볼 및 풋프린트 라이브러리를 안전하게 보호되는 소스 제어 저장소로 옮기고 싶을 수도 있습니다. 이 소프트웨어는 현재의 표준 데이터베이스 라이브러리(DbLib)를 버전 관리형 데이터베이스 라이브러리(SVNDbLib)로 마이그레이션하는 수단을 제공합니다.

변환은 통합 라이브러리를 변환할 때와 거의 동일한 방식으로 SVN Database Library Conversion Wizard을 사용하여 수행합니다.

SVN Database Library Conversion Wizard기존 표준 데이터베이스 라이브러리(DbLib)를 버전 관리형 데이터베이스 라이브러리(SVNDbLib)로 변환하는 작업은 SVN Database
Library Conversion Wizard
을 사용하면 간편하게 수행할 수 있습니다.

프로세스는 다음 단계로 이루어집니다.

  1. 변환할 기존 DbLib를 연 다음 기본 메뉴에서 Tools » SVN Database Library Maker을 선택합니다. SVN Database Library Conversion Wizard이 열립니다.
  2. Libraries to Convert 페이지에서 변환할 소스 데이터베이스 라이브러리를 지정합니다. Database Libraries 옵션은 이미 활성화되어 있으며, 관련 필드에는 활성 라이브러리의 경로가 미리 입력되어 있습니다. 다른 DbLib를 변환하려면 Browse icon 버튼을 클릭하고 나타나는 대화 상자에서 해당 파일을 찾습니다.
  3. Next을 클릭하면 선택한 DbLib 파일이 분석되고 백엔드 데이터베이스가 수정될 수 있음을 알리는 확인 대화 상자가 나타납니다. 계속하려면 Yes 을 클릭합니다.
  4. Options 페이지에서 소스 라이브러리 분할 방식, 저장할 저장소와 디렉터리, SVNDbLib 파일의 출력 디렉터리 등 변환 관련 옵션을 정의합니다. Schematic 라이브러리의 경우 각 구성 컴포넌트에서 파라미터 및/또는 모델 정보를 제거하여 심볼만 남길 수 있는 두 가지 옵션도 제공됩니다.
SVN 저장소와 폴더 구조는 미리 정의되어 있어야 합니다. 여기서는 분할된 라이브러리 파일을 저장할 저장소와 그 구조 내의 폴더를 지정하기만 합니다. 저장소와 폴더는 작업 중에 즉석으로 생성되지 않습니다.
외부 데이터베이스는 원본 DbLib 파일에 연결된 상태로 이미 존재하므로 새로 생성되지 않습니다. 데이터베이스는 현재 위치에 그대로 유지됩니다. 생성된 SVNDbLib 파일과 데이터베이스를 같은 위치에 두려면 기본적으로 두 가지 방법이 있습니다. 첫 번째는 SVNDbLib의 출력 경로를 데이터베이스가 현재 있는 디렉터리로 설정하는 것입니다. 두 번째는 다른 디렉터리에 SVNDbLib를 생성한 다음 데이터베이스를 해당 디렉터리로 옮기는 것입니다. 이 경우 SVNDbLib 파일 내의 연결 설정을 수정하여 새 위치의 데이터베이스를 가리키도록 하고 다시 연결해야 합니다.
  1. 소스 DbLib 파일을 선택하고 필요에 따라 관련 변환 옵션을 설정한 후 Next 을 클릭하여 변환을 진행합니다. 변환 중인 라이브러리에 대한 정보와 함께 진행률 표시줄이 나타납니다. 변환 프로세스에는 다음 작업이 포함됩니다.
    1. 연결된 데이터베이스의 컴포넌트 레코드가 참조하는 Schematic 및 PCB 라이브러리를 단일 심볼/풋프린트 라이브러리 파일로 분할합니다.
    2. 분할된 심볼 및 풋프린트 라이브러리를 저장소의 지정된 기본 디렉터리에 커밋합니다.
    3. 지정된 SVNDbLib 파일을 생성하고 데이터베이스 및 저장소에 연결합니다.
  2. 변환이 완료되면 Finish 을 클릭하여 Wizard를 닫고 SVNDbLib 파일을 활성 문서로 설정합니다.

변환 프로세스가 완료된 후 생성된 SVNDbLib 파일.변환 프로세스가 완료된 후 생성된 SVNDbLib 파일.

필드 매핑에 대한 참고 사항

생성된 SVNDbLib에서 Field Mappings 탭의 데이터베이스 필드와 설계 파라미터 간 매핑은 원래 DbLib에 정의된 상태로 유지됩니다.

원본 DbLib와 생성된 SVNDbLib의 필드 매핑은 동일하게 유지됩니다.원본 DbLib와 생성된 SVNDbLib의 필드 매핑은 동일하게 유지됩니다.

다만 다음 두 가지 중요한 사항에 유의해야 합니다.

  • 심볼 및 풋프린트 모델에 정의된 경로 매핑은 모두 무시됩니다. SVNDbLib는 저장소에 커밋된 라이브러리에서 필요한 심볼과 풋프린트를 찾을 때 매핑된 참조 필드인 [Library Ref] 및 [Footprint Ref]만 사용합니다. 데이터베이스에 정의된 경로 정보는 하드 디스크나 기타 로컬/네트워크 매체에 있는 라이브러리를 가리키므로 무시됩니다.
데이터베이스에 경로 정보를 계속 포함하려면 저장소의 라이브러리를 가리키도록 해당 정보를 수정하십시오. 데이터베이스에 라이브러리 경로 정보를 지정하지 않는 편이 변경에 훨씬 유연하게 대응할 수 있다는 점을 기억해 두십시오. 저장소 위치 및/또는 내부 폴더 구조가 변경되어도 데이터베이스를 업데이트할 필요가 없습니다.
  • 정의된 시뮬레이션 모델 매핑도 SVNDbLib 파일에 그대로 유지됩니다. 그러나 Subversion 저장소에 시뮬레이션 모델 파일을 저장하는 것은 지원되지 않습니다. 배치 시 컴포넌트 인스턴스에 모델 링크는 추가되지만, 모델 자체는 찾을 수 없습니다.

OrCAD® CIS 직접 지원

데이터베이스 라이브러리 시스템을 기반으로 구축된 이 소프트웨어는 기존 OrCAD 컴포넌트 정보 시스템(CIS)에 대한 연결 및 사용을 완벽하게 지원합니다. CIS 구조는 기본적으로 Altium Designer의 표준 데이터베이스 라이브러리 구조(DbLib)로 변환됩니다.

OrCAD에서 Altium Designer로 - 필요한 변환

외부 데이터베이스(*.mdb, *.xls)에서 직접 배치할 수 있도록 하려면 다음 파일 변환이 필요합니다.

  • 외부 데이터베이스 연결을 처리하고 데이터베이스 필드와 설계 파라미터 간 매핑 정보를 포함하는 OrCAD CIS Configuration 파일(*.dbc)을 Altium Designer 데이터베이스 라이브러리 파일(*.DbLib)로 변환해야 합니다.
Altium Designer는 현재 바이너리 형식의 OrCAD CIS .dbc 파일만 지원합니다.
  • 관련 OrCAD 라이브러리 파일을 Altium Designer 라이브러리 파일로 변환해야 합니다.
    • OrCAD Capture 라이브러리(*.olb) ---> Schematic 라이브러리(*.SchLib).
    • OrCAD Max 라이브러리 파일(*.llb) ---> PCB 라이브러리(*.PcbLib).

데이터베이스 라이브러리 자동 생성

DbLib 파일과 소스 Altium Designer 라이브러리를 생성하는 가장 간단하고 효율적인 방법은 Import Wizard(File » Import Wizard)를 사용하는 것입니다. Wizard의 두 번째 페이지에서 가져올 파일 유형으로 OrCAD CIS Configuration Files and Libraries 항목이 선택되어 있는지 확인하십시오.

Import Wizard을 사용하면 CIS Configuration 파일과 관련 OrCAD 라이브러리를 Altium Designer DbLib 및 소스 라이브러리(SchLib 및 PcbLib) 파일로 빠르게 변환할 수 있습니다.
Import Wizard을 사용하면 CIS Configuration 파일과 관련 OrCAD 라이브러리를 Altium Designer DbLib 및 소스 라이브러리(SchLib 및 PcbLib) 파일로 빠르게 변환할 수 있습니다.

Import Wizard을 사용하면 CIS Configuration 파일과 관련 OrCAD 라이브러리를 Altium NEXUS DbLib 및 소스 라이브러리(SchLib 및 PcbLib) 파일로 빠르게 변환할 수 있습니다.
Import Wizard을 사용하면 CIS Configuration 파일과 관련 OrCAD 라이브러리를 Altium NEXUS DbLib 및 소스 라이브러리(SchLib 및 PcbLib) 파일로 빠르게 변환할 수 있습니다.

Wizard의 다음 페이지들을 따라 진행하면서 아래 항목을 지정합니다.

  • 외부 데이터베이스의 위치.
  • CIS Configuration 파일(*.dbc)의 위치. 이 파일은 XML이 아닌 바이너리 형식이어야 합니다.
  • 타겟 DbLib 파일을 생성할 위치와 파일 이름.
  • 외부 데이터베이스에서 참조하는 OrCAD Schematic 및/또는 PCB 라이브러리.
OrCAD 소스 라이브러리를 지정할 때 생성되는 Altium Designer 라이브러리의 저장 위치도 설정할 수 있습니다. 기본적으로 이러한 라이브러리는 타겟 DbLib 파일과 동일한 디렉터리에 있는 \Libraries 하위 폴더에 저장됩니다.

Wizard의 각 페이지를 따라 진행하면서 데이터베이스, CIS Configuration 파일, 소스 OrCAD 라이브러리 및 타겟 DbLib 파일을 지정합니다.
Wizard의 각 페이지를 따라 진행하면서 데이터베이스, CIS Configuration 파일, 소스 OrCAD 라이브러리 및 타겟 DbLib 파일을 지정합니다.

Wizard의 각 페이지를 따라 진행하면서 데이터베이스, CIS Configuration 파일, 소스 OrCAD 라이브러리 및 타겟 DbLib 파일을 지정합니다.
Wizard의 각 페이지를 따라 진행하면서 데이터베이스, CIS Configuration 파일, 소스 OrCAD 라이브러리 및 타겟 DbLib 파일을 지정합니다.

필요에 따라 소스 및 타겟 파일과 디렉터리를 지정한 후 Next을 클릭하여 Import를 진행합니다. Import가 완료되면 Finish 을 클릭하여 Wizard를 닫고 DbLib 파일을 활성 문서로 설정합니다.

Import 프로세스가 완료된 후 생성된 DbLib 파일.
Import 프로세스가 완료된 후 생성된 DbLib 파일.

Import 프로세스가 완료된 후 생성된 DbLib 파일.
Import 프로세스가 완료된 후 생성된 DbLib 파일.

유의 사항:

  • Database Library Options 대화 상자의 Symbol & Model Search Paths 탭에서 DbLib 파일에 라이브러리 검색 경로가 자동으로 추가되며, 이 경로는 변환된 라이브러리 파일이 있는 디렉터리를 가리킵니다.
  • 정의된 조회 키를 포함한 파라미터 매핑 정보는 OrCAD CIS Configuration 파일에서 직접 가져옵니다.
  • 두 개의 모델 매핑 항목이 자동으로 설정됩니다. 해당 항목의 데이터베이스 필드 이름과 할당된 Design Parameter 항목의 예는 다음과 같습니다.
    • Footprint Name ---> [Orcad Footprint]
    • Symbol Name ---> [Orcad Library]

이 항목들은 외부 데이터베이스의 특정 컴포넌트 레코드를 소스 Schematic 심볼 및 해당 컴포넌트에 연결된 PCB 풋프린트 모델과 연결합니다.

데이터베이스 라이브러리 수동 생성

  1. Import Wizard을 사용하여 DbLib 파일을 생성하는 것이 가장 빠른 방법이지만, 유일한 방법은 아닙니다. DbLib 파일을 수동으로 생성할 수도 있습니다. 방법은 다음과 같습니다.
  2. 새 DbLib 파일을 생성하고 외부 데이터베이스에 연결한 다음, 필요에 따라 매핑 및 파라미터 업데이트 옵션을 정의합니다.
  3. 그런 다음 OrCAD 라이브러리를 Import해야 합니다. Import Wizard을 사용하여 OrCAD 라이브러리 파일(*.olb, *.llb)을 Altium Designer 라이브러리(*.SchLib, *.PcbLib)로 변환할 수 있습니다.
    1. Import할 파일 형식을 선택할 때 OrCAD Designs and Libraries Files 항목을 선택합니다.

    2. Importing OrCAD Designs 페이지는 건너뛰고 Importing OrCAD Libraries 페이지로 이동합니다. 데이터베이스에서 참조하는 모든 소스 OrCAD 라이브러리를 추가합니다.

    3. 설계 파일의 Import와 관련된 나머지 후속 페이지는 건너뜁니다.

    4. Output Library Options 페이지에서 기본 Output Libraries as PCB Project 옵션을 활성화된 상태로 둡니다.

    5. Output Libraries 페이지에서 생성된 라이브러리 파일의 Output 디렉터리를 지정합니다.

데이터베이스에서 참조하는 심볼과 풋프린트가 포함된 OrCAD 소스 라이브러리 Import.
데이터베이스에서 참조하는 심볼과 풋프린트가 포함된 OrCAD 소스 라이브러리 Import.

데이터베이스에서 참조하는 심볼과 풋프린트가 포함된 OrCAD 소스 라이브러리 Import.
데이터베이스에서 참조하는 심볼과 풋프린트가 포함된 OrCAD 소스 라이브러리 Import.

  1. Import가 완료되면 지정된 디렉터리에 Imported OrCAD Libraries.PrjPcb이라는 이름의 폴더가 생성됩니다. 생성된 Altium Designer 라이브러리는 필요에 따라 다른 위치로 이동할 수 있습니다. 예를 들어 DbLib 파일이 있는 디렉터리 안에 Libraries이라는 폴더를 생성하고 라이브러리를 해당 폴더로 이동할 수 있습니다.
  2. 심볼 및 풋프린트 라이브러리가 준비되면 DbLib 파일로 돌아가서 라이브러리 검색 경로(Database Library Options 대화 상자의 Symbol & Model Search Paths 탭)가 해당 라이브러리가 저장된 디렉터리 폴더를 가리키도록 설정해야 합니다.
AI-LocalizedAI로 번역됨
만약 문제가 있으시다면, 텍스트/이미지를 선택하신 상태에서 Ctrl + Enter를 누르셔서 저희에게 피드백을 보내주세요.
Nav
Contents
기능 가용성

사용할 수 있는 기능은 보유한 Altium 솔루션(Altium Develop, Altium Agile Teams, Altium Agile Enterprise, 또는 Altium Designer(활성 기간 중))에 따라 달라집니다.

실제 소프트웨어에서 문서화된 기능이 보이지 않는 경우, Altium 영업팀에 문의하여 자세한 내용을 확인하세요.

구버전 문서

Altium Designer 문서는 더 이상 버전별로 제공되지 않습니다. 이전 버전의 Altium Designer 문서가 필요하신 경우, Other Installers 페이지의 Legacy Documentation 섹션을 방문해 주세요.

Contents