Constraint Manager를 사용하여 설계 요구사항 정의하기

Altium Training

Altium Essentials: Schematic Updating

This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.

개요

이 문서에서는 PCB 프로젝트가 제약 조건 관리자를 사용하는지 확인하는 방법, Altium Designer에서 제약 조건 관리자에 접근하는 방법, 스프레드시트와 유사한 인터페이스를 통해 설계 제약 조건을 정의하고 관리하는 방법을 설명합니다. 클리어런스, Physical, 전기적 뷰와 PCB에서 접근할 때 사용할 수 있는 모든 규칙 뷰를 살펴보고, 필터링, 값 복사, 변경 사항 저장, 데이터 새로 고침, 클리어런스 매트릭스 작업 등 실무에 유용한 워크플로 세부 사항도 소개합니다. 이 환경에서 제약 조건을 정의하는 방식을 더 명확히 이해하고 핵심 도구를 사용하는 방법을 익히고 싶다면 계속 읽어보세요. 기본 사용법을 파악하고 더 자신 있게 작업을 시작하는 데 도움이 될 것입니다.

- 프로젝트에서 제약 조건 관리자를 사용할 수 있는지 확인하는 방법과 프로젝트가 여전히 기존 규칙 관리 방식을 사용하고 있다는 것이 어떤 의미인지 알아봅니다.
- 제약 조건 관리자의 구성, 각 뷰에서 정의할 수 있는 제약 조건 유형, Schematic 또는 PCB Editor에서 접근하는 방법을 살펴봅니다.
- 변경 사항 저장 및 새로 고침, 기본값과 사용자 지정 값 확인, 매트릭스에서 클리어런스 정의 등 일상적인 작업에 필요한 주요 사용법을 익힙니다.
AI로 더 깊이 알아보기:

Do I have the Constraint Manager?

  • 제약 조건 Manager는 프로젝트 생성 시 Create Project 대화 상자에서 Constraint Management 옵션을 활성화한 경우에만 PCB 설계 프로젝트에서 사용할 수 있습니다. 다음 사항에 유의하세요.

    • PCB 프로젝트에서 제약 조건 Manager를 활성화한 경우, PCB Editor에서 PCB Rule 및 제약 조건 Editor 대화 상자 (Design » Rules)를 not 사용할 수 있습니다.

    • PCB 프로젝트에서 제약 조건 Manager를 not 활성화한 경우에는 설계 제약 조건을 정의하는 기존 방식(설계 지시문 및 PCB Rule and Constraints Editor 대화 상자 사용)만 사용할 수 있습니다.

    Advanced Settings 대화 상자에서 System.ConstraintManager 옵션을 활성화하면 Create Project 대화 상자에서 Constraint Management 옵션이 기본적으로 활성화됩니다.

  • 현재 PCB 프로젝트에서 설계 제약 조건을 정의하는 데 어떤 방식을 사용하는지 빠르게 확인하려면, 프로젝트의 Schematic/PCB 문서를 연 상태에서 Schematic 또는 PCB Editor의 기본 메뉴에 Design » Constraint Manager 명령이 있는지 확인하세요. 이 명령이 있으면 해당 프로젝트는 제약 조건 Manager를 사용합니다. 그렇지 않으면 해당 프로젝트는 PCB Rule and Constraints Editor 대화 상자(PCB Editor의 Design » Rules)를 사용합니다.

  • PCB 프로젝트가 기존 Rule 관리 시스템을 사용하는 경우 제약 조건 Manager로 마이그레이션할 수 있습니다. 자세히 알아보기.

  • PCB 프로젝트에서 제약 조건 Manager를 활성화한 경우, 해당 기능에 대한 접근 권한이 없는 사용자가 열면 제약 조건 Manager가 View Only 모드로 표시됩니다. 이 경우 사용자는 정의된 제약 조건을 볼 수 있지만 수정할 수는 없습니다. 제약 조건 Manager 상단의 메시지는 제약 조건 Manager가 View Only 모드임을 알려줍니다().

제약 조건 Manager는 PCB 설계에 사용되는 설계 제약 조건을 보고, 생성하고, 관리할 수 있는 문서 기반의 스프레드시트형 사용자 인터페이스입니다.

특히 Net, 클래스 등이 많은 복잡한 설계에서 제약 조건 Manager를 사용할 때 얻을 수 있는 이점은 다음과 같습니다.

  • 프로젝트 수준에서 사용할 수 있어 Schematic 캡처 및 PCB 설계 영역 모두에서 유사한 방식으로 설계 제약 조건 관리 기능에 접근할 수 있습니다.

  • 쿼리 기반의 Rule 적용 범위 지정 방식에서 적용 대상 객체 유형을 일치시키는 방식으로 전환하여 제약 조건 Rule 생성을 간소화합니다.

  • 제약 조건 세트를 사용하여 제약 조건을 정의하는 과정을 단축합니다.

  • Rule 우선순위는 설계 객체의 고유한 계층 구조에 따라 자동으로 지정됩니다.

  • 대화 상자 대신 문서 기반 표시 인터페이스를 사용하므로 Schematic 및 PCB Editor와 관련 기능이 활성 상태로 유지되어 계속 사용할 수 있습니다.

제약 조건 Manager 접근하기

Schematic 또는 PCB Editor의 기본 메뉴에서 Design » Constraint Manager 명령을 선택하여 제약 조건 Manager에 접근할 수 있습니다.

Design 메뉴에 Constraint Manager 명령이 없나요? 제약 조건 Manager를 사용할 수 있는지 확인하세요. 자세히 알아보기.

Schematic Editor에서 제약 조건 Manager에 접근하기
Schematic Editor에서 제약 조건 Manager에 접근하기

PCB Editor에서 제약 조건 Manager에 접근하기
PCB Editor에서 제약 조건 Manager에 접근하기

다음 이미지와 같이 제약 조건 Manager의 문서 탭은 접근한 경로에 따라 달라집니다.

제약 조건 유형

제약 조건 Manager 왼쪽 상단의 버튼을 사용하여 보기 간에 전환하고 다양한 제약 조건 유형을 정의할 수 있습니다.

Clearances – Net 및/또는 Differential Pair 클래스 간의 전기적 이격 거리를 정의할 수 있는 매트릭스입니다.

Physical – Net, Differential Pair, xNet 및 해당 클래스의 목록으로, 도체 폭, Differential Pair의 간격 등 설계의 Physical 제약 조건을 정의할 수 있습니다. PCB에서 제약 조건 Manager에 접근하면 PCB 문서에 현재 정의된 룸이 여기에 나열되며, 룸에 대한 Physical 제약 조건을 정의할 수 있습니다.

Electrical – Net, xNet, Net 클래스 및 xNet 클래스의 목록으로, 토폴로지, 임피던스 등 설계의 전기적 제약 조건을 정의할 수 있습니다. Differential Pair와 xSignal도 각각의 전용 탭에 나열됩니다.

 

PCB Editor에서 제약 조건 Manager에 접근하면 All Rules 보기가 추가로 제공됩니다. 이 보기는 설계 제약 조건을 Rule 중심으로 표시하며, PCB 설계의 모든 Rule을 나열하고 쿼리 기반의 Custom Rule을 생성할 수 있습니다. 자세히 알아보기.

제약 조건 Manager 사용 시 참고 사항:

  • Properties Panel의 Units 옵션(또는 기본 메뉴의 Tools » Measurement Units 하위 메뉴에 있는 해당 옵션, 단축키: Ctrl+Q)을 사용하여 제약 조건 Manager의 Grid 영역에 표시되는 값의 측정 단위(mm 또는 mils)를 전환할 수 있습니다.

  • Properties Panel의 Show Default Values 옵션(또는 View 기본 메뉴나 Grid 영역의 마우스 오른쪽 버튼 클릭 메뉴에 있는 View Options 하위 메뉴의 해당 옵션)을 사용하여 제약 조건 Manager에서 Default 값(예: Net 클래스 또는 Differential Pair에서 상속된 값)의 표시 여부를 전환할 수 있습니다. Default 값을 표시하면 제약 조건 Manager의 Grid 영역에 회색으로 표시됩니다. Custom 값은 제약 조건 Manager의 Grid 영역에 흰색으로 표시됩니다.

  • Physical 또는 Electrical 보기에서는 Properties Panel의 Show Only Object Custom Values 옵션(또는 View 기본 메뉴나 Grid 영역의 마우스 오른쪽 버튼 클릭 메뉴에 있는 View Options 하위 메뉴의 해당 옵션)을 사용하여 Default 값을 가진 객체 항목의 표시 여부를 전환할 수 있습니다. 즉, 이 옵션을 활성화하면 Default 값을 가진 항목이 필터링되어 표시되지 않습니다.

  • 셀 간 값 복사 및 붙여넣기가 지원됩니다. 컨텍스트 메뉴의 Copy/Paste Values 하위 메뉴에 있는 명령이나 Ctrl+C 및 Ctrl+V 단축키를 사용하세요.

  • 제약 조건 Manager 오른쪽 상단의 Search 필드에 검색 문자열을 입력하여 객체 목록을 필터링할 수 있습니다. 현재 지정된 검색 문자열을 지우려면 Search 표시줄 오른쪽의 아이콘을 클릭하세요.

  • 제약 조건/Rule의 셀이 선택된 상태에서 Constraint Manager 하단의 Comment 필드를 사용하여 해당 제약 조건/Rule에 설명을 추가할 수 있습니다. 예를 들어, 사용 목적을 알기 쉽게 설명할 수 있습니다 (). Constraint Manager 하단에서 여러 Rule의 제약 조건을 정의할 수 있는 경우, Rule 드롭다운()으로 현재 Rule을 전환하여 각각에 개별 설명을 정의할 수 있습니다.

  • 변경 사항을 설계에 반영하려면 Constraint Manager에서 저장 작업을 수행해야 합니다. 이를 위해 Constraint Manager의 기본 메뉴에서 File » Save(Schematic에서 Constraint Manager에 액세스한 경우) 또는 File » Save to PCB (PCB에서 Constraint Manager에 액세스한 경우) 명령을 사용하거나 Ctrl+S 단축키를 사용하십시오.

  • Schematic 측에서 Constraint Manager에 액세스하여 처음 저장하면 Schematic 제약 조건 문서(Constraints.xml)가 프로젝트에 추가되며, Projects 패널의 Settings/Constraints 하위 폴더에서 사용할 수 있게 됩니다(). 또한 연결된 워크스페이스에서 프로젝트를 업데이트하면 문서의 제약 조건 데이터가 다시 로드/새로 고침됩니다.

  • Schematic 설계 또는 PCB 레이어 스택에 변경 사항이 있는 경우(레이어 및/또는 임피던스 프로파일에 영향을 주는 변경), 해당 편집기에서 액세스한 Constraint Manager 상단의  버튼을 클릭하여 이러한 변경 사항을 Constraint Manager에 반영하십시오. 이 버튼을 클릭하면 Schematic의 지시문을 Constraint Manager로 가져올 수도 있습니다. 자세히 알아보기. Constraint Manager에 아직 저장하지 않은 변경 사항이 있으면, 해당 변경 사항이 손실된다는 경고 대화상자가 표시되어 확인을 요청합니다.

    Layer Stack Manager에서 임피던스 프로파일을 변경한 경우, Constraint Manager에서 을 클릭하면 해당 Rule의 Preferred Width 값만 업데이트되며, Min Width 및 Max Width 값(해당하는 경우)은 업데이트되지 않습니다. 제약 조건 정의가 올바르지 않으면 Physical 보기 상단 그리드의 폭 값이 빨간색으로 표시됩니다. 이러한 값을 확인하고 필요에 따라 업데이트/조정해야 합니다. 이러한 변경 사항을 설계에 반영하고 라우팅에 사용할 수 있도록 하려면 Constraint Manager에서 저장 작업도 수행해야 합니다.

  • Schematic 또는 PCB에서 Constraint Manager에 액세스하면 Clearances 및 Physical 보기의 Properties 패널에 있는 Clearances Settings 영역에서 다음 전역 옵션을 사용할 수 있습니다.

    • Ignore Pad to Pad clearances within a footprint – 이 옵션을 사용하면 정의된 모든 클리어런스 Rule에 설정을 적용할 수 있습니다. 이 옵션을 통해 동일한 컴포넌트 풋프린트 내 패드 간의 클리어런스를 무시할지 지정할 수 있습니다.

    • Apply zero Keepout clearance – 이 옵션을 활성화하면 Keepout과 설계 내 다른 모든 프리미티브 사이에 간격이 ‘0’인 기본 클리어런스 Rule이 적용됩니다. 이 Rule은 Constraint Manager의 어떤 보기에도 표시되지 않으므로 수정할 수 없습니다. 비활성화된 경우 일반 클리어런스 매트릭스 값이 적용됩니다.

  • 설계 공간 왼쪽 상단의 을 사용하거나 기본 메뉴의 Edit » Undo/Redo을 사용하여 Constraint Manager에서 수행한 변경 사항을 빠르게 실행 취소하거나 다시 실행할 수 있습니다. 이 기능은 Rule, 범위, 제약 조건 세트를 비롯한 대부분의 영역에서 사용할 수 있습니다. 소프트웨어의 다른 영역과 마찬가지로, 작업을 수행한 경우에만 실행 취소 아이콘/명령을 사용할 수 있고, 실행 취소를 수행한 경우에만 다시 실행 아이콘/명령을 사용할 수 있습니다.

클리어런스 매트릭스 작업

기본적으로 Constraint Manager의 Clearances 보기에 있는 클리어런스 매트릭스에는 All Net Classes에서 All Net Classes으로의 단일 항목이 포함되며, 이를 통해 설계 내 모든 Net 사이의 기본 클리어런스 값을 정의할 수 있습니다. 매트릭스 왼쪽 상단의 Add 컨트롤을 사용하거나, 클리어런스 매트릭스의 셀을 마우스 오른쪽 버튼으로 클릭하고 상황에 맞는 메뉴에서 Add 명령을 사용하면 현재 정의된 Net 및 Differential Pair 클래스 목록이 팝업으로 표시됩니다. 필요한 클래스를 하나 이상 선택하고(Shift+Click 또는 Ctrl+Click 방식으로 여러 클래스 항목을 선택할 수 있음) Add 버튼을 클릭하십시오. 선택한 각 클래스의 행과 열이 매트릭스에 추가됩니다.

두 클래스의 행과 열이 교차하는 셀을 클릭하여 선택하면 Constraint Manager 하단에 세부 클리어런스 설정이 표시됩니다. 여기에서 서로 다른 객체 간 및 서로 다른 레이어의 구체적인 클리어런스 값을 정의할 수 있습니다.

하단의 Clearance 필드를 사용하여 이 클래스 쌍의 모든 객체 조합과 모든 레이어에 적용할 값을 입력하십시오. 또는 상단 매트릭스의 셀을 두 번 클릭하여 필요한 값을 직접 입력할 수도 있습니다.

표에서 특정 객체 쌍에 필요한 클리어런스 값을 입력하십시오. 클리어런스 매트릭스의 셀에는 표에 정의된 최솟값과 최댓값의 범위가 표시됩니다.

  • 세부 클리어런스 설정에서는 선택한 행/열 내의 다중 편집이 지원됩니다. 행 또는 열의 머리글을 클릭하여 선택하고 필요한 값을 입력한 다음, Enter을 누르거나 클릭하면 해당 행/열의 모든 셀에 이 값이 적용됩니다.

  • 트랙과 프리미티브 간의 값을 변경하면 텍스트와 프리미티브 사이에도 동일한 클리어런스가 적용됩니다.

Clearances 보기 작업 시 참고 사항:

  • 클리어런스 매트릭스에서 셀이 선택된 상태로 클리어런스 매트릭스의 셀 또는 Clearance 필드에 값을 입력하면, 해당 값이 Constraint Manager 하단 그리드 영역의 모든 필드에 자동으로 적용됩니다. 객체 유형에 따라 클리어런스를 정의해야 할 때만 그리드 영역에서 편집하면 됩니다.

  • Constraint Manager 하단의 세부 클리어런스 설정에서 선택한 클래스에 대해 Creepage 제약 조건을 활성화하고 연면거리 값()을 정의할 수도 있습니다. 이 제약 조건은 비도금 홀, 컷아웃 및 보드 가장자리를 따라 보드 표면을 지나는 대상 신호 간의 연면거리를 검사합니다.

  • Constraint Manager 하단의 세부 클리어런스 설정에서 선택한 클래스에 대해 Z-Axis Clearance 제약 조건을 활성화하고 Z축 클리어런스 값()을 정의할 수도 있습니다. 이 제약 조건은 서로 다른 구리 레이어에 있는 프리미티브 간의 최소 클리어런스를 검사하는 데 사용됩니다.

    이 기능은 오픈 베타 상태이며, 고급 설정 대화상자에서 PCB.Rules.ZAxisClearanceRule 옵션을 활성화하면 사용할 수 있습니다.

  • 특정 객체 쌍(예: Track와 Track 쌍)의 클리어런스 값을 기본값(즉, All Net Classes와 All Net Classes 항목에 정의된 값)으로 재설정하려면 하단 표에서 해당 셀을 선택하고 Delete 키를 누르거나, 셀을 마우스 오른쪽 버튼으로 클릭한 후 상황에 맞는 메뉴에서 Reset to Default 명령을 선택합니다.

  • 클리어런스 매트릭스의 특정 항목(예: 한 Net 클래스와 다른 Net 클래스 간의 항목)에 속한 모든 객체 쌍의 클리어런스 값을 기본값으로 재설정하려면 클리어런스 매트릭스에서 해당 셀을 마우스 오른쪽 버튼으로 클릭하고 상황에 맞는 메뉴에서 Remove Rule 명령을 선택합니다.

  • 클리어런스 매트릭스에서 클래스를 제거하려면 클리어런스 매트릭스에서 해당 클래스 행의 아무 셀이나 마우스 오른쪽 버튼으로 클릭하고 상황에 맞는 메뉴에서 Remove Scope 명령을 선택합니다.

제약 조건 Manager에서 클래스 간 클리어런스를 설정하면 Applicable Binary Rules 대화 상자를 사용하여 PCB 문서의 설계 공간에 있는 객체의 관련 Net 클래스를 확인할 수 있습니다. 이 대화 상자를 열려면 PCB Editor에서 설계 공간을 마우스 오른쪽 버튼으로 클릭하고 상황에 맞는 메뉴에서 Applicable Binary Rules를 선택한 다음, 설계 내의 객체 두 개를 클릭합니다. 대화 상자의 Clearance Constraint 항목에는 제약 조건 Manager에서 클리어런스 Rule이 정의된 객체의 관련 Net 클래스가 표시됩니다().

레이어별 클리어런스 구성

표 아래의 탭을 사용하여 레이어별 클리어런스 값을 정의할 수도 있습니다. Add 컨트롤을 사용하여 특정 레이어의 탭을 추가합니다.

  • Schematic Editor에서 제약 조건 Manager에 액세스하는 경우 특정 레이어로 Top 및 Bottom 레이어만 추가할 수 있습니다. PCB Editor에서 제약 조건 Manager에 액세스하는 경우 PCB 설계에 현재 존재하는 모든 Signal 레이어를 추가할 수 있습니다.

  • 내부 및 외부 레이어의 값을 빠르게 정의하려면 상단 클리어런스 매트릭스의 셀에 슬래시로 구분된 두 값(예: 5/6)을 입력할 수도 있습니다. 첫 번째 값은 내부 레이어에 적용되고 두 번째 값은 외부 레이어에 적용됩니다.

  • 더 구체적인 레이어/레이어 그룹에 적용된 제약 조건은 우선순위가 더 높습니다. 즉, 특정 레이어(예: Top Layer 또는 Bottom Layer)의 객체 쌍에 적용된 값은 해당 그룹(Inner Layers 또는 Outer Layers)의 동일한 객체 쌍에 적용된 값보다 우선순위가 높으며, Inner Layers 또는 Outer Layers 그룹의 객체 쌍에 적용된 값은 All Layers 그룹의 동일한 객체 쌍에 적용된 값보다 우선순위가 높습니다.

클래스 필터링

Clearances 뷰에서 많은 수의 클래스를 효율적으로 다루려면 필터링/그룹화 기능을 사용할 수 있습니다. 이 기능으로 클래스 필터(또는 그룹)를 구성하여 클리어런스 매트릭스에서 필요한 하위 집합 간에 전환하며 작업할 수 있습니다.

Clearances 뷰의 오른쪽 상단에 있는  버튼을 사용하여 필터를 생성, 편집, 제거하고 활성화/비활성화할 수 있는 팝업을 엽니다.

새 필터를 생성하려면  버튼을 클릭한 다음 표시되는 팝업에서  버튼을 클릭합니다.

새 필터의 고유한 이름을 지정하고 필요한 클래스 그룹을 활성화합니다. Search 필드를 사용하여 입력한 검색 문자열에 따라 목록을 필터링하고, Reset 컨트롤을 사용하여 목록에서 활성화된 모든 항목을 빠르게 비활성화합니다. 필요한 클래스를 선택한 후 을 클릭합니다.

필터를 생성한 후에는 팝업의 컨트롤을 사용하여 필요에 따라 필터를 활성화, 비활성화, 편집 또는 제거합니다. Clear All 컨트롤을 사용하면 활성화된 모든 필터를 빠르게 비활성화할 수 있습니다. 하나 이상의 필터가 활성화되면 오른쪽 상단의 버튼이 으로 표시됩니다.

 

Physical 및 전기적 제약 조건 작업

제약 조건 Manager의 Physical 또는 Electrical 뷰에서 Grid 영역의 셀을 클릭하면 제약 조건 Manager 하단에 해당 Rule의 설정이 표시되며, 여기에서 제약 조건 값을 정의할 수 있습니다.

 

Physical 뷰에서는 다음 제약 조건을 구성할 수 있습니다. 

  • Width – 이 제약 조건은 Signal 레이어에 배치되는 Track의 너비를 지정합니다.

  • Diff Pair Gap – 이 제약 조건은 적용 대상 Differential Pair 내 Net 간의 클리어런스(또는 간격)를 지정합니다.

  • Clearance – 이 제약 조건은 적용 대상 Net의 객체와 설계 내 다른 Net의 객체 사이에 허용되는 최소 클리어런스를 지정합니다.

  • Via Style – 이 제약 조건은 라우팅 시 사용할 수 있는 비아의 스타일을 지정합니다. 비아의 직경과 홀 크기에 대해 구체적인 최소/최대/선호 값을 정의할 수 있습니다(Min/Max Preferred). 또는 PCB에서 제약 조건 Manager에 액세스하거나 특정 레이어 스택의 제약 조건을 구성하는 경우(자세히 알아보기), 보드 설계에서 사용할 수 있는 템플릿을 사용할 수 있습니다(Templates).

  • Polygon Connect – 이 제약 조건은 컴포넌트 Pad 또는 라우팅된 비아와 폴리곤 푸어 간의 Connection 스타일을 지정합니다.

    Advanced 컨트롤을 사용하여 모든 Pad와 비아에 적용되는 공통 Connection 스타일을 정의하는 단순 모드와, 연결되는 각 요소(스루홀 Pad, SMD Pad, 비아)에 서로 다른 Connection 스타일을 지정할 수 있는 고급 모드 간에 전환합니다.

    제약 조건 값에 대한 자세한 내용은 플레인 Rule 유형 페이지를 참조하세요.

  • Same Net Clearance – 이 제약 조건은 동일한 Net에 속하는 두 프리미티브 객체 사이에 허용되는 최소 클리어런스를 지정합니다(예: 동일한 Net의 비아와 Pad 사이 또는 동일한 Net의 두 Track 세그먼트 사이).

  • Routing Neck Down – 이 제약 조건은 적용되는 너비 제약 조건에 정의된 Min Width과 Preferred Width 사이의 너비를 갖는 연속 라우팅의 최대 허용 길이를 지정합니다.

Electrical 뷰에서는 다음 제약 조건을 구성할 수 있습니다.

  • Nets 탭:

    • Topology – 이 제약 조건은 보드에서 Net을 라우팅할 때 사용할 토폴로지를 지정합니다. Net의 토폴로지는 핀 간 Connection의 배열 또는 패턴입니다.

      제약 조건 값에 대한 자세한 내용은 라우팅 Rule 유형 페이지를 참조하세요.

      Custom 토폴로지를 사용하여 xSignals를 정의할 수 있습니다. 자세한 내용은 아래의 xSignal 정의 섹션을 참조하십시오.

    • Impedance – 이 제약 조건은 허용되는 최소 및 최대 Net 임피던스를 지정합니다.

    • All Layer Sets – 이 제약 조건은 라우팅에 사용할 수 있는 레이어를 지정합니다.

    • Maximum Via Count – 이 제약 조건은 허용되는 최대 비아 수를 지정합니다.

    • Min / Max Total Length – 이 제약 조건은 Net의 최소 및 최대 길이를 지정합니다.

    • Max Stub Length – 이 제약 조건은 데이지 체인 토폴로지를 사용하는 Net의 최대 허용 스텁 길이를 지정합니다.

    • Max Via Stub Length – 스텁은 비아 또는 Pad 배럴에서 해당 비아/Pad가 연결되는 마지막 사용 Signal 레이어 너머로 돌출된 부분의 길이입니다. 타겟 Net의 적합한 비아/Pad에는 활성화된 보드 면별 Layer 체크박스와 Layer Stack Manager의 Back Drills 탭에 정의된 백드릴 쌍에 따라 백드릴링이 적용됩니다.

      제약 조건 값에 대한 자세한 내용은 고속 Rule 유형 페이지를 참조하십시오.

      백드릴링에 대한 자세한 내용은 깊이 제어 드릴링(백드릴링) 페이지를 참조하십시오.

  • Diff Pairs 탭:

    • Impedance – 이 제약 조건은 허용되는 최소 및 최대 Net 임피던스를 지정합니다.

    • Gap – 이 제약 조건은 적용 범위에 속하는 Differential Pair의 Net 사이 클리어런스(또는 간격)를 지정합니다.

    • Width – 이 제약 조건은 Differential Pair를 라우팅할 때 트랙에 사용할 수 있는 너비를 지정합니다.

    • Max Uncoupled Length – 이 제약 조건은 Differential Pair 내 양극 및 음극 Net 사이의 최대 허용 비결합 길이를 지정합니다.

    • Tolerance – 이 제약 조건은 Differential Pair에서 가장 긴 Net과 비교할 때의 길이 허용 오차를 지정합니다.

    • Dynamic Phase Tolerance – 이 제약 조건은 Differential Pair의 트랙 사이에 허용되는 위상 불일치를 지정하며, 이 값을 초과하면 보정이 필요합니다.

    • Matching Distance – 이 제약 조건은 허용 오차를 초과한 후 보정을 적용해야 하는 거리를 지정합니다.

  • xSignals 탭:

    • Tolerance – 이 제약 조건은 xSignal 클래스 내 각 xSignal을 해당 클래스의 Matching Target(으)로 선택된 xSignal과 비교할 때의 길이 허용 오차를 지정합니다.

Physical 또는 Electrical 뷰 작업 시 참고 사항:

  • 제약 조건 관리자는 이러한 뷰에서 Rule의 우선순위를 자동으로 정의합니다. 우선순위는 All (가장 낮음), 객체 클래스, 객체(가장 높음) 순서입니다.

  • 특정 Rule에 정의된 Custom 제약 조건 값을 제거하려면(즉, 해당 Rule의 값을 Default 값으로 재설정하려면), Grid에서 해당 셀을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Remove rule 명령을 선택하십시오.

  • 객체의 모든 Rule에 대한 Custom 제약 조건 값을 제거하려면 Grid에서 해당 객체 행의 아무 셀이나 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Remove rules from scope 명령을 선택하십시오.

  • 미리 정의된 노드(예: All Nets)를 제외한 모든 노드는 Physical  및 Electrical  뷰에서 기본적으로 접혀 있습니다. 마우스 오른쪽 버튼 클릭 메뉴의 Expand All 및 Collapse All 명령을 사용하여 Grid 노드를 제어할 수 있습니다.

  • Physical 뷰의 상단 Grid에서 싱글 Net 또는 xNet(Min Width 또는 Preferred Width), Differential Pair(Min Width, Preferred Width 또는 Preferred Diff Pair Gap) 또는 Net/xNet/Differential Pair 클래스에 값을 입력하면, 이 값이 아래 제약 조건 영역의 해당 너비(Min Width/Preferred Width/Max Width) 또는 간격(Min Gap/Preferred Gap/Max Gap) 필드에 전파됩니다. 입력한 값은 해당 객체에 특정 Rule이 정의되어 있지 않은 경우에만 다른 필드로 전파됩니다.

  • Physical 뷰에서 최소, 최대 및 권장 라우팅 너비와 Differential Pair 간격 값을 정의할 때, 뷰 하단의 Values by Layer 표는 유효하지 않은 입력값을 빨간색 텍스트로 강조 표시합니다. 예를 들어 최소 제약 조건 값을 최대 제약 조건 값보다 크게 지정하면 이러한 상황이 발생할 수 있습니다. 뷰 상단 Grid의 너비/간격 값도 빨간색으로 바뀌어 잘못된 제약 조건 정의를 추가로 강조 표시합니다.

레이어별 제약 조건 값 구성

Schematic에서 제약 조건 관리자에 접근할 때 선택한 레이어 스택의 레이어에 대해 너비 및 Differential Pair 라우팅 제약 조건을 구성할 수 있습니다.

제약 조건 관리자 상단의 드롭다운에서 설계 프로젝트의 특정 PCB 문서에 해당하는 Entry를 선택하십시오. 선택한 PCB에 레이어 스택이 여러 개 있는 경우, 해당 Rule을 선택한 상태에서 제약 조건 관리자 하단의 탭을 사용하여 제약 조건을 구성할 스택을 선택할 수 있습니다. 또한 선택한 임피던스 프로파일을 사용할 수 있습니다(선택한 PCB의 레이어 스택에 정의되어 있는 경우).

Differential Pair 정의

Differential Pair는 제약 조건 관리자의 Physical 뷰 또는 Electrical 뷰의 Diff Pairs 탭에서 생성합니다. 제약 조건 관리자가 Net으로부터 Differential Pair를 생성하려면, 쌍을 이룰 Net의 이름에 일관된 명명 규칙이 적용되어 있어야 합니다. 즉, 공통 어근 뒤에 일관된 양극/음극 접미사가 와야 합니다(예: TX0_P 및 TX0_N).

Physical 뷰 또는 Electrical 뷰의 Diff Pairs 탭에서 Grid 영역의 아무 곳이나 마우스 오른쪽 버튼으로 클릭한 후, 컨텍스트 메뉴에서 Differential Pairs » Create Differential Pairs From Nets 명령을 선택하여 Create Differential Pairs From Nets 대화상자를 열고 Differential Pair 생성 옵션을 정의하십시오. 대화상자 상단의 필터를 사용하면 Net이 속한 Net 클래스와, 쌍을 이룰 양극 및 음극 Net을 구분하는 데 사용된 특정 구분 요소(예: _P 및 _N)를 기준으로 해당 Net을 빠르게 지정할 수 있습니다. 생성되는 Differential Pair 객체에 추가할 접두사를 정의하고, 이 객체들을 추가할 Differential Pair 클래스를 지정할 수도 있습니다.

대화상자에는 각 Differential Pair 객체를 구성하는 양극 및 음극 Net이 표시됩니다. 기본적으로 생성 가능한 모든 Differential Pair 객체가 생성 대상으로 선택되어 있으며, 해당 Create 체크박스를 해제하여 개별 객체를 제외할 수 있습니다. 

모든 옵션을 필요에 맞게 설정한 후  버튼을 클릭하면 Differential Pair 객체가 생성되어 제약 조건 관리자의 Physical 뷰에 표시되며, 각 Entry 아래에 구성 Net이 나열됩니다.

Differential Pair는 xNet에서도 생성할 수 있습니다. Create Differential Pairs From Nets 대화상자 상단의 드롭다운에서 All xNets 또는 특정 xNet 클래스를 선택하십시오. 대화상자의 다른 옵션을 필요에 맞게 구성한 후  버튼을 클릭하면 설정에 따라 Differential Pair가 생성됩니다.

xNet 차동 쌍이라는 개념은 제약 조건 관리자 내에서만 존재합니다. PCB에 저장할 때는 일반 차동 쌍으로 '분해'됩니다(xNet에 포함된 모든 Net 쌍에 대해 생성되며, 모든 규칙이 각 쌍에 복제됩니다). 제약 조건 관리자에 다시 접근하면, 가능한 경우 구성 요소인 일반 차동 쌍들이 xNet 차동 쌍으로 다시 결합됩니다. 또한 Schematic 지시문에서 Import하거나 문서를 동기화할 때도 xNet 차동 쌍이 분해되고 다시 결합됩니다. 문서 동기화 시에는 Constraint Manager Data ECO 객체가 xNet 차동 쌍 정의를 전달하여 차동 쌍을 xNet 차동 쌍으로 다시 결합할 수 있도록 합니다.

차동 쌍을 제거하려면 해당 Entry를 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Differential Pairs » Remove Differential Pair 명령을 선택합니다. 여러 차동 쌍을 제거하려면 Ctrl+Click, Shift+Click 또는 Click, Hold&Drag 방식으로 해당 Entry들을 선택한 다음, 선택 영역을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Differential Pairs » Remove Differential Pair 명령을 선택합니다.

Electrical 뷰의 Diff Pairs 탭에서도 차동 쌍을 직접 관리할 수 있습니다. 이 탭에는 설계에 포함된 차동 쌍의 계층 구조 목록이 표시됩니다. 차동 쌍 또는 차동 쌍 클래스의 셀을 선택하면 제약 조건 관리자 하단에 해당 항목의 제약 조건이 표시됩니다.

xNet 정의

소스 컴포넌트에서 하나 이상의 직렬 컴포넌트를 거쳐 대상 컴포넌트로 이어지는 경로를 xNet으로 정의할 수 있습니다.

소스 또는 대상 컴포넌트(Sources/Destinations)와 직렬 컴포넌트(Discretes)로 사용할 수 있는 컴포넌트의 지정자 접두사를 쉼표로 구분한 목록은 프로젝트 옵션 대화 상자의 옵션 탭에 있는 xNets Creation Region에서 정의할 수 있습니다.

Project Options 대화 상자에 있는 Options 탭의 xNets Creation Region
Project Options 대화 상자에 있는 Options 탭의 xNets Creation Region

제약 조건 관리자에서 xNet으로 정의할 수 있는 경로의 예 (위에 표시된 xNet 생성 설정 기준)
제약 조건 관리자에서 xNet으로 정의할 수 있는 경로의 예 (위에 표시된 xNet 생성 설정 기준)

제약 조건 관리자의 Physical 또는 Electrical 뷰에서(Schematic 또는 PCB에서 접근한 경우), 새 xNet에 포함할 Net을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 xNets » Create xNets From Selected Nets 명령을 선택합니다. 새 xNet이 생성되어 제약 조건 관리자의 Physical 또는 Electrical 뷰에 표시되며, 해당 Entry 아래에 구성 Net들이 나열됩니다.

xNet 생성은 핀이 2개보다 많은 직렬 컴포넌트도 지원합니다. 다음과 같은 직렬 컴포넌트가 지원됩니다.

  • Dual-inline component with an even number of pins – 컴포넌트의 첫 번째 핀과 마지막 핀에 연결된 Net, 두 번째 핀과 끝에서 두 번째 핀에 연결된 Net 등의 순서로 xNet을 생성할 수 있습니다. ()

  • Single-inline component with an even number of pins – 컴포넌트의 첫 번째 핀과 두 번째 핀에 연결된 Net, 세 번째 핀과 네 번째 핀에 연결된 Net 등의 순서로 xNet을 생성할 수 있습니다. () 컴포넌트에는 이름이 PinPairsConfiguration이고 값이 SIP인 파라미터가 포함되어야 합니다. 그렇지 않으면 듀얼 인라인 컴포넌트와 같은 방식으로 xNet이 생성됩니다.

  • Component with an odd number of pins – 컴포넌트의 모든 핀에 연결된 Net으로 하나의 xNet이 생성됩니다. ()

xNet을 제거하려면 해당 Entry를 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 xNets » Remove xNet 명령을 선택합니다. 여러 xNet을 제거하려면 Ctrl+Click, Shift+Click 또는 Click, Hold&Drag 방식으로 해당 Entry들을 선택한 다음, 선택 영역을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 xNets » Remove xNet 명령을 선택합니다.

xSignal 정의

제약 조건 관리자에서는 PCB의 두 노드 사이에 사용자가 정의한 Signal 경로인 xSignal도 정의할 수 있습니다. 제약 조건 관리자의 Electrical 뷰에서 Net 또는 xNet의 Topology 열에 있는 셀을 선택하고, 제약 조건 관리자 하단의 드롭다운에서 Custom를 선택한 다음, 제공되는 컨트롤을 사용하여 Custom 토폴로지를 정의하고 해당 xSignal을 선택합니다.

아래에 표시된 xNet에 대해 xSignal을 정의하는 예를 이어서 설명하고 시연합니다.

xSignal을 생성할 xNet의 예.
xSignal을 생성할 xNet의 예.

제약 조건 관리자 하단의 토폴로지 그래프를 사용하여 Custom 토폴로지를 정의할 수 있습니다. 그래프 영역의 마우스 오른쪽 버튼 메뉴를 사용하여 노드를 추가하거나 제거하고, 노드 유형을 Source에서 Destination로 또는 그 반대로 변경하며, 노드를 Click, Hold&Drag하여 토폴로지를 정의합니다.

제안된 xSignal 목록(<SourceNetName> (<SourcePinDesignator> → <DestinationPinDesignator>) 명명 방식 사용)이 Grid 영역 오른쪽에 표시됩니다. 목록은 소스에서 대상으로 이어지는 xSignal(S-T)과 한 대상에서 다른 대상으로 이어지는 xSignal(T-T)의 두 그룹으로 나뉩니다. 그룹 또는 개별 xSignal의 확인란을 사용하여 생성할 xSignal을 선택하거나 선택 해제합니다. 선택한 xSignal은 Electrical 뷰의 xSignals 탭에 표시됩니다.

토폴로지 그래프를 사용하여 xSignal을 생성하는 예

또는 테이블을 사용하여 Custom 토폴로지를 정의할 수 있습니다. Pin 열을 사용하여 필요한 핀과 직렬 컴포넌트를 추가하고, Role 열에서 해당 역할(Source, Destination 또는 Discrete)을 선택한 다음, Order 열에서 원하는 순서를 정의합니다.

테이블 사용자 인터페이스를 사용하여 xSignal을 생성하는 예

토폴로지 그래프 기능은 고급 설정 대화 상자에서 ConstraintManager.TopologyGraphAvailable 옵션을 활성화하면 사용할 수 있습니다. 이 옵션을 비활성화하면 테이블 사용자 인터페이스가 사용됩니다.

  • 제약 조건 관리자의 xSignals 탭 또는 PCB 문서에 표시되는 생성된 xSignal의 이름에는 다음 명명 방식이 사용됩니다.

    <SourceNetName>_<SourcePinDesignator>_<DestinationPinDesignator>

  • 정의한 Custom 토폴로지를 xNet/Net에 빠르게 전파하고 유사한 구조의 xSignal을 여러 개 생성하려면, Custom 토폴로지가 있는 xNet/Net에 대해 제약 조건 세트를 생성한 다음 다른 xNet/Net에 적용하면 됩니다. Custom 토폴로지가 포함된 제약 조건 세트를 편집하면 토폴로지 변경 사항이 이 제약 조건 세트가 적용된 다른 객체에도 전파됩니다.

  • xSignal은 Electrical 뷰의 xSignals 탭에서 제거할 수 있습니다. xSignal을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 xSignals » Remove xSignal 명령을 선택합니다.

  • Custom에서 변경하면 연결된 xSignal이 자동으로 제거됩니다. 토폴로지를 선택한 Net/xNet에 대해 미리 정의된 토폴로지 중 하나로 설정합니다.

  • 2핀 Net 또는 단순한 xNet(소스 하나, 대상 하나가 있고 각 Net 쌍 사이에 개별 컴포넌트가 있는 xNet)에 대해 Custom 토폴로지를 선택하면 해당 핀이 사용자 지정 토폴로지의 노드로 자동 추가되고, 제안된 xSignal이 자동으로 선택됩니다. xNet이 핀이 두 개보다 많은 개별 소자(예: 하나의 부품에 포함된 저항 뱅크)를 통과하는 경우도 지원됩니다.

생성된 xSignal 클래스에 대해 (자세한 내용은 아래 클래스 정의 섹션 참조)  Tolerance 제약 조건을 정의할 수 있으며, 이 클래스 내의 xSignal을 Matching Length로 선택할 수 있습니다. PCB 측에서 제약 조건 Manager에 접근하면 Actual Value 및 Margin 열도 사용할 수 있습니다.

PCB 문서에서 정의된 xSignal은 xSignals 모드의 PCB 패널에서 찾아볼 수 있습니다. 또한 해당 From-To가 생성되며, From-To Editor 모드의 PCB 패널에서 찾아볼 수 있습니다.

PCB 문서에서 생성된 xSignal은 PCB 패널의 xSignals 모드에서 찾아볼 수 있습니다.

From-To도 생성되며, PCB 패널의 From-To Editor 모드에서 찾아볼 수 있습니다.

 

클래스 정의

제약 조건 Manager에서는 Net, 차동 쌍, xNet 및 xSignal의 클래스를 정의할 수 있습니다.

  • 제약 조건 Manager의 Physical 또는 Electrical 보기에서 객체를 기존 클래스에 추가하려면 Ctrl+Click, Shift+Click 또는 Click, Hold&Drag 방식으로 여러 객체 항목을 선택한 다음, 선택 항목을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴의 Classes » Add Selected to Class 하위 메뉴에서 원하는 클래스를 선택합니다.

    클래스가 30개를 초과하면 클래스 목록 대신 Classes » Add Selected to Class » Existing Class 명령이 표시됩니다. 이 명령을 사용하여 선택한 객체를 추가할 기존 클래스를 선택할 수 있는 대화 상자를 엽니다.

  • 제약 조건 Manager의 Physical 또는 Electrical 보기에 나열된 객체로 새 클래스를 추가하려면 해당 객체를 선택한 다음, 선택 항목을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Classes » Add Selected to Class » New Class 명령을 선택하여 Add Class 대화 상자를 엽니다. 클래스의 Name (고유해야 하며 비어 있으면 안 됨) 및 클래스 멤버 집합을 정의합니다. 대화 상자를 열기 전에 선택한 객체는 이미 Member 목록에 포함되어 있습니다. 필요한 경우 화살표 버튼을 사용하여 Non-Members 목록과 Member 목록 사이에서 객체 항목을 이동하여 클래스 멤버 집합을 추가로 구성합니다.

  • 또는 Grid 영역을 마우스 오른쪽 버튼으로 클릭하고 Clearances 또는 Electrical 보기에서 Classes » Add Class 명령을 선택하거나, (Net 클래스를 추가하기 위한) 명령 또는 Classes » Add Class 하위 메뉴의 명령을 선택하여 Add Class 대화 상자를 열 수 있습니다. 이 방식으로 대화 상자를 열면 Member 목록은 처음에 비어 있습니다.

  • 객체가 현재 추가되어 있는 클래스에서 해당 객체를 제거하려면 객체를 선택한 다음, 선택 항목을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Classes » Remove Selected from Class 명령을 선택합니다.

  • 클래스를 편집하려면 해당 항목을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Classes » Edit Class 명령을 선택하여 Edit Class 대화 상자를 엽니다. 이 대화 상자에서 클래스의 이름과 멤버를 편집할 수 있습니다.

  • 기존 클래스를 제거하려면 해당 항목을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Classes » Remove Class 명령을 선택합니다.  Ctrl+Click, Shift+Click 또는 Click, Hold&Drag 방식으로 여러 클래스 항목을 선택한 후, 선택 항목을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Classes » Remove Class 명령을 선택하여 여러 클래스를 제거할 수도 있습니다.

또는 Object Class Explorer 대화 상자를 사용하여 클래스를 추가, 편집 및 제거할 수 있습니다. Grid 영역을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Classes » Class Explorer 명령을 선택하여 대화 상자를 엽니다.

대화 상자 왼쪽의 폴더 트리 창에는 지원되는 객체 클래스 유형과 각 유형의 기존 객체 클래스가 나열됩니다.

  • 루트 Object Classes 폴더를 클릭하면 대화 상자의 기본 편집 영역에 모든 객체 클래스 유형에 걸쳐 정의된 모든 개별 클래스의 요약 목록이 표시됩니다.
  • 하위 객체 클래스 유형 폴더를 클릭하면 해당 유형에 대해 정의된 모든 개별 클래스의 요약 목록이 표시됩니다.
  • 특정 클래스의 항목을 클릭하거나 요약 목록에서 해당 항목을 두 번 클릭하면 해당 클래스의 객체 멤버를 관리하는 컨트롤이 표시됩니다.

Object Class Explorer 대화 상자에서 새 사용자 정의 클래스를 추가하려면 생성하려는 클래스의 범주 내부를 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Add Class 을 선택합니다. 사용자 정의 클래스의 이름을 변경하거나 삭제하려면 해당 이름을 마우스 오른쪽 버튼으로 클릭하고 각각 Rename Class 또는 Delete Class를 선택합니다.

Default 시스템 클래스(All Nets, All Differential Pairs, All xNets, All xSignals)는 편집하거나 이름을 변경하거나 삭제할 수 없습니다. Object Class Explorer 대화 상자에서는 이러한 클래스의 이름이 <>로 둘러싸여 있어 다른 클래스와 구분됩니다.

제약 조건 세트

객체의 제약 조건을 더 빠르게 정의할 수 있도록 제약 조건 Manager는 제약 조건 집합을 제약 조건 세트로 저장한 다음 객체에 적용하는 기능을 제공합니다.

현재 객체에 정의된 제약 조건 집합을 제약 조건 세트로 저장하려면 해당 객체의 셀을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴에서 Save as Constraint Set 명령을 선택합니다. New Constraint Set 팝업에서 원하는 제약 조건 세트 이름을 입력하고(고유해야 하며 비어 있으면 안 됨) Create를 클릭합니다.

새로 생성된 제약 조건 세트는 해당 세트를 생성할 때 사용한 객체에 적용됩니다. 제약 조건 세트를 다른 객체에 적용하려면 해당 객체의 셀을 마우스 오른쪽 버튼으로 클릭하고 컨텍스트 메뉴의 Select Constraint Set 하위 메뉴에서 원하는 제약 조건 세트를 선택합니다. 제약 조건 세트가 적용된 셀은 왼쪽 위 모서리에 있는 심볼(예: )로 구분되며, Physical 또는 Electrical 보기에서는 적용된 제약 조건 세트의 이름이 Constraint Set 열에 표시됩니다.

기존 제약 조건 세트의 값을 편집하려면 이 제약 조건 세트가 적용된 객체를 선택하고 을 클릭합니다. 버튼. 필요에 따라 제약 조건 값을 변경한 다음, 표시되는 팝업에서 Save 버튼을 클릭하여 변경 사항을 저장합니다. 변경 사항은 현재 해당 제약 조건 세트가 선택된 모든 객체에 적용됩니다.

현재 정의된 제약 조건 세트는 Properties Panel의 Constraint Sets Region에 나열됩니다. 제약 조건 세트의 Entry를 클릭하면 해당 제약 조건 값이 표시됩니다. Properties Panel에서 선택한 제약 조건 세트는 Constraint Sets Region 하단의  버튼을 클릭하여 제거할 수 있습니다. 제거된 제약 조건 세트가 선택되어 있던 객체는 제거 전에 해당 제약 조건 세트가 적용한 제약 조건 값을 유지합니다.

Schematic에서 제약 조건 관리자를 열고 서로 다른 레이어 스택의 제약 조건을 구성할 때(자세한 내용은 레이어별 제약 조건 값 구성 참조), 제약 조건 세트는 자신이 생성된 레이어 스택을 기억합니다. 현재 선택한 레이어 스택에는 다른 레이어 스택용으로 생성된 제약 조건 세트를 할당하거나 수정할 수 없습니다. 이러한 경우 Properties Panel에 This Constraint Set was created for a different layer stack 메시지가 표시됩니다().

Schematic에서 지시문 Import하기

이 기능은 고급 설정 대화 상자에서 ConstraintManager.ImportFromDirectives 옵션이 활성화되어 있을 때 사용할 수 있습니다.

Schematic 소스 문서에 배치하고 정의한 파라미터 세트 및 Differential Pair 설계 지시문에서 Net 클래스, 차동 쌍 클래스, 차동 쌍 및 제약 조건을 제약 조건 관리자로 Import할 수 있습니다. 이 작업을 수행하려면 Schematic 측에서 제약 조건 관리자를 연 상태에서  버튼을 클릭합니다. Refresh Constraint Manager 대화 상자에는 Schematic에서 제약 조건 관리자로 Import할 내용의 요약이 표시되며, 대화 상자의  버튼을 클릭하면 Import가 완료됩니다.

제약 조건 관리자의 제약 조건과 Schematic에 배치된 지시문에 정의된 해당 제약 조건 간의 동기화 상태가 표시됩니다.

  • Schematic의 객체에 파라미터 세트 또는 Differential Pair 지시문이 배치되어 있고, 이 지시문의 제약 조건 값이 제약 조건 관리자에서 동일한 객체에 정의된 값과 다른 경우, Schematic에서 제약 조건 관리자를 열면 제약 조건 관리자의 Physical 또는 Electrical 보기에서 해당 셀 왼쪽에 주황색 막대로 이 값들이 표시됩니다(예: ).

  • 제약 조건 관리자와 지시문 간에 제약 조건 값이 동기화되면 표시가 녹색 막대로 바뀝니다(예: ).

지시문에서 Import한 Net 클래스, 차동 쌍 및 차동 쌍 클래스의 동기화 상태도 표시됩니다. 변경 사항(요소 추가/제거)이 감지되면 동기화가 필요한 불일치가 해당 객체 이름 왼쪽에 주황색 막대로 표시됩니다(예: ). 동기화된 상태는 녹색 막대로 표시됩니다(예: ).

제약 조건 관리자로 지시문을 Import할 때의 참고 사항:

  • 제약 조건 관리자를 통해 Net/Net 클래스/차동 쌍/차동 쌍 클래스에 이미 정의된 기존 제약 조건은 우선 적용되며, Import 처리 시에도 유지됩니다. 따라서 Import 후 제약 조건 관리자에서 지시문과 동기화된 제약 조건 값을 편집하면, 이후 다시 Import해도 해당 값은 동기화되지 않습니다.

  • 지시문의 데이터를 제약 조건 관리자로 Import하여 데이터를 동기화하고 제약 조건 관리자에서 변경 사항을 저장하면:

    • Import한 지시문은 설계 공간에서 파란색과 약간 다른 심볼로 구분됩니다().

    • 제약 조건 관리자로 Import한 클래스 및 Rule의 항목은 Properties Panel의 Parameters Region 상단에 있는 Constraint Manager 버튼을 사용하여 표시되지 않도록 필터링할 수 있습니다.

    • 싱글 와이어에 연결된 파라미터 세트 지시문의 경우, 제약 조건 관리자의 관련 데이터(Net/차동 쌍 클래스 이름 및 Rule 설정)를 Schematic 시트의 해당 지시문 근처에 표시할 수 있습니다. 정의된 Net 클래스를 포함하고 블랭킷에 연결된 파라미터 세트 지시문의 경우, 제약 조건 관리자와 동기화하거나 제약 조건 관리자로 Import한 후 설계 공간에서 Net 클래스 지시문 정보의 표시 여부를 전환할 수도 있습니다. 블랭킷에 연결된 Differential Pair 지시문의 경우, 지시문을 제약 조건 관리자와 동기화하거나 제약 조건 관리자로 Import한 후 설계 공간에서 차동 쌍 클래스 및 관련 Rule 정보의 표시 여부를 전환할 수 있습니다. 지시문을 선택한 상태에서 Properties Panel의 해당 데이터 Entry 왼쪽에 있는 표시 제어 기능()을 사용합니다.

    • 해당 지시문의 Properties Panel에서는 새 Net 클래스, 차동 쌍 클래스 또는 컴포넌트 클래스를 추가하거나 기존 클래스를 제거하는 컨트롤이 비활성화됩니다.

    • 해당 지시문의 Properties Panel에서는 새 Rule을 추가하거나 기존 Rule을 편집/제거하는 컨트롤을 계속 사용할 수 있습니다. Net 클래스의 이름도 편집할 수 있습니다. 이미 Import한 지시문의 Rule 및/또는 Net 클래스 이름에 대한 변경 사항을 제약 조건 관리자의 데이터에 적용하려면, Schematic 측에서 제약 조건 관리자를 연 상태에서  버튼을 클릭합니다.

  • 파라미터 세트 지시문에 추가된 Rule 중 Physical 및 Electrical 보기에 표시되지 않는 Rule은 PCB에서 제약 조건 관리자를 열 때 모든 Rule 보기에 표시되는 고급 Rule로 자동 생성됩니다. 고급 Rule은 지시문 Import 및 이후 Schematic에서 PCB로의 ECO가 완료되면 생성됩니다.

  • 지시문을 사용하여 정의한 Net 클래스를 제약 조건 관리자로 Import하려면 프로젝트 옵션 대화 상자의 클래스 생성 탭에서 Generate Net Classes 옵션을 활성화해야 합니다. Net 클래스를 제약 조건 관리자로 Import한 후 Generate Net Classes 옵션을 비활성화하면, 이후 제약 조건 관리자로 Import할 때 Import한 Net 클래스를 제거하라는 제안이 표시됩니다. 

Schematic에 파라미터 세트 및 Differential Pair 지시문이 배치되어 있습니다. 이 지시문은 다음을 정의합니다:

  • Net A00의 폭 제약 조건.

  • Net A09의 Net 클래스(Control) 및 폭 제약 조건.

  • Net DQS0R_P 및 DQS0R_N의 차동 쌍.

제약 조건 관리자의 Physical 보기에서 Net의 폭 제약 조건과 관련된 셀 A00 및 A09에는 해당 값이 지시문과 동기화되지 않았음을 나타내는 주황색 막대가 표시됩니다.

버튼을 클릭합니다. 제약 조건 Manager로 가져올 데이터를 검토할 수 있는 Refresh Constraint Manager 대화상자가 열립니다. 검토 후 버튼을 클릭하여 지시문의 모든 데이터를 가져옵니다.

이제 너비 제약 조건, Net 클래스 및 차동 쌍이 제약 조건 Manager로 가져와집니다. A00 및 A09의 너비 제약 조건과 관련된 셀과 Net 클래스 Control 및 차동 쌍 DQS0R의 셀에는 이제 값/멤버가 지시문과 동기화되었음을 나타내는 녹색 막대가 표시됩니다.

Schematic 설계 공간에서 지시문의 모양이 변경됩니다. 지시문 속성에서 Rule을 추가, 편집 및 제거하는 것은 여전히 가능하지만, 클래스를 추가, 편집 및 제거하는 컨트롤은 이제 회색으로 비활성화됩니다.

 

읽기 전용 문서에서 가져온 지시문 수정

읽기 전용 문서(예: 디바이스 시트 및 관리 시트)에서 가져온 지시문은 Preferences 대화상자의 Data Management - Device Sheets 페이지에서 Make Device Sheets In Projects Read-Only 옵션이 활성화(선택)되어 있으면 수정할 수 없습니다.

이 옵션이 비활성화(선택 해제)되어 있으면 지시문을 수정할 수 있습니다. 옵션이 활성화된 상태에서 지시문을 가져오면 제약 조건 Manager에서 해당 Rule이 파란색으로 강조 표시됩니다.

제약 조건 및 제약 조건 세트 가져오기와 내보내기

설계 간에 제약 조건과 제약 조건 세트를 가져오고 내보낼 수 있습니다. 이 기능에 액세스하려면 제약 조건 Manager의 Clearances, Physical, 또는 Electrical 보기에서 마우스 오른쪽 버튼을 클릭한 다음 Import 또는 Export을 선택합니다.

Import을 선택하면 설계로 가져올 제약 조건/제약 조건 세트(*.CstrDot )를 선택할 수 있는 표준 File Explorer 대화상자가 열립니다. 이어서 현재 설계로 가져올 제약 조건/제약 조건 세트를 선택할 수 있는 Constraints to Import 대화상자가 열립니다. 선택한 제약 조건/제약 조건 세트는 타겟 설계의 해당 객체에 적용됩니다.

  • 가져오도록 선택한 Net이 타겟 설계에 없으면 제약 조건 Manager에 해당 Entry가 추가됩니다. 설계에 해당 Net이 없으므로 이 Entry에는  아이콘이 표시됩니다. 이 Entry에서 제약 조건 값을 복사하여 기존 객체에 붙여넣을 수 있습니다. 설계에 동일한 이름의 Net을 추가한 다음 제약 조건 Manager의 데이터를 새로 고치면 이 문제를 해결할 수 있습니다. 또는 일치하지 않는 객체의 Entry를 마우스 오른쪽 버튼으로 클릭하고 Delete unmatched object ()를 선택하여 제약 조건 Manager에서 해당 객체를 제거할 수 있습니다.

  • 가져오도록 선택한 차동 쌍 또는 xNet이 타겟 설계에 없으면 설계에 추가되지 않습니다.

  • 가져오도록 선택한 Net / 차동 쌍 / xNet 클래스가 타겟 설계에 없으면 설계에 자동으로 추가됩니다.

Exporting Constraints and Constraint Sets

Clearances 보기에서 하나 이상의 셀을 선택하거나 Physical 또는 Electrical 보기에서 하나 이상의 행을 선택한 다음 Export을 선택하면, 명령을 선택하기 전에 선택한 모든 객체의 제약 조건과 제약 조건 세트가 Grid에 나열된 Constraints to Export 대화상자가 열립니다. 체크박스를 사용하여 내보낼 제약 조건/제약 조건 세트를 선택합니다(현재 보기와 관련된 제약 조건은 대화상자에서 기본적으로 선택됩니다). Export items 버튼을 클릭하면 제약 조건/제약 조건 세트의 이름을 지정하고 저장할 수 있는 표준 File Explorer 대화상자가 열립니다. 파일은 *.CstrDot 확장자로 내보내지며, 이후 다른 설계로 가져올 수 있습니다.

PCB 측에서 모든 Rule 작업하기

PCB Editor에서 제약 조건 Manager에 액세스하면 PCB 설계의 모든 Rule 목록이 표시되는 All Rules 보기를 사용할 수 있습니다. 여기에서 일치 범위에 더 복잡한 쿼리 표현식을 사용하는 고급 Rule을 생성할 수 있습니다.

  • 고급 Rule(All Rules 보기의 Advanced Rules 목록에 나열됨)은 제약 조건 Manager의 다른 보기에서 정의된 Rule(All Rules 보기의 Basic Rules 목록에 나열됨)보다 우선합니다. Priority 열()에 필요한 우선순위를 입력하여 고급 Rule의 우선순위를 재정의할 수 있습니다(1이 가장 높은 우선순위). Basic Rules 목록에 나열된 Rule의 우선순위는 재정의할 수 없습니다.

  • 클리어런스 매트릭스에서 클리어런스 제약 조건이 구성된 각 클래스 쌍은 Electrical 범주에서 Clearance Rule 유형을 선택하면 All Rules 보기에 각각의 기본 Rule로 표시됩니다. 클리어런스 매트릭스에서 레이어별로 제약 조건 값을 구성한 경우(위의 세부 정보 참조)에도 해당 쌍은 All Rules 보기에 하나의 기본 Rule로 표시되며, 더 구체적인 레이어 / 레이어 그룹에 적용된 값이 더 높은 우선순위를 가집니다.

  • Comment 열을 사용하여 Rule에 Comment를 추가할 수 있습니다. 예를 들어 해당 Rule의 용도를 알기 쉽게 설명할 수 있습니다.

새 고급 Rule 생성

제약 조건 Manager의 All Rules 보기에서 새 고급 Rule을 생성하려면 마우스 오른쪽 버튼 클릭 컨텍스트 메뉴에서 Add Advanced Rule을 선택하거나, Grid 영역에서 선택된 Rule이 없을 때 제약 조건 Manager 하단의  버튼을 사용합니다. 그런 다음 열 Grid 또는 하단의 그래픽 표현 영역에 쿼리 기반 일치 범위와 제약 조건 매개변수를 입력합니다.

 

 

 

제약 조건 Manager에서 새 고급 Rule을 구성하는 방법은 PCB Rules and Constraints Editor 대화상자에서 Rule을 구성하는 방법과 비슷합니다. 이 대화상자와 제약 조건 Manager의 All Rules 보기에서 사용할 수 있는 Rule 유형에 대한 자세한 내용은 PCB Design Rule 유형 페이지를 참조하십시오.

구문 등의 문제로 범위 쿼리 표현식이 유효하지 않은 것으로 판단되면 경고 대화상자가 표시됩니다.

유효하지 않은 범위를 유지하려면 대화상자에서 Yes 을 클릭합니다. 그러면 아래와 같이 유효하지 않은 Rule이 빨간색으로 강조 표시됩니다. 이전의 유효한 범위로 되돌리려면 No 을 클릭합니다.

범위 라이브러리 관리

고급 Rule을 반복적으로 생성하는 과정을 간소화하기 위해 Constraints Manager에서는 쿼리 기반 객체 일치 범위를 범위 라이브러리에 저장할 수 있습니다. 라이브러리는 Scopes Library을 사용하여 관리합니다. Properties Panel의 Scopes Library Region에서 Edit Library 버튼을 클릭하여 액세스하는 대화 상자입니다. 라이브러리는 Properties Panel에 표시되며, 여기서 Custom 범위를 XML 파일로 가져오거나 내보낼 수 있습니다. 이 파일은 다른 Altium Designer 설치의 Scopes Library를 채우는 데 사용할 수 있습니다.

범위를 라이브러리로 내보내거나 라이브러리에서 가져오려면 제약 조건 Manager 하단의 Object Match / Second Object Match 필드 옆에 있는  버튼의 메뉴 명령을 사용합니다. 라이브러리 기반 범위를 Rule에 적용하면 해당 범위의 이름이 Grid 영역의 Object Match / Second Object Match 열과 Object Match / Second Object Match 필드 위에 표시됩니다. 필드의  메뉴를 사용하여 범위를 쿼리 기반 형식(Detach Scope)으로 되돌릴 수 있습니다.

Rule 활성화/비활성화

All Rules 뷰에 나열된 기본 및 고급 Rule을 활성화하거나 비활성화할 수 있습니다. Enabled 열은 Rule의 상태를 나타냅니다: True (활성화) 또는 False (비활성화). 해당 열의 셀을 두 번 클릭하여 특정 Rule의 상태를 전환합니다. 비활성화된 기본 Rule에 해당하는 셀은 (Disabled)로 표시되며, Physical 및 Electrical 뷰에서 회색으로 표시됩니다.

특정 유형이나 범주의 고급 Rule 또는 모든 고급 Rule의 활성화 상태는 Rule Class 트리의 해당 Entry를 마우스 오른쪽 버튼으로 클릭하면 나타나는 컨텍스트 메뉴의 명령으로도 전환할 수 있습니다.

Javascript ID: CM_EnableDisableAdvancedRules_AD25_8

Rule Class 트리에서 Rule 유형 Entry를 마우스 오른쪽 버튼으로 클릭하여 해당 유형의 고급 Rule을 활성화하거나 비활성화합니다.

Rule Class 트리에서 Rule 범주 Entry를 마우스 오른쪽 버튼으로 클릭하여 해당 범주의 고급 Rule을 활성화하거나 비활성화합니다.

Rule Class 제목을 마우스 오른쪽 버튼으로 클릭하여 모든 고급 Rule을 활성화하거나 비활성화합니다.

Rule 가져오기 및 내보내기

All Rules 뷰에서 고급 및/또는 기본 Rule을 가져오고 내보낼 수 있습니다.

내보내려면 Ctrl+Click, Shift+Click 또는 Click, Hold&Drag을 사용하여 목록에서 여러 Rule을 선택한 다음, 마우스 오른쪽 버튼을 클릭하고 Export Selected Rules (x) 명령을 선택합니다(x은 선택한 Rule의 수를 나타냅니다). Rule Class 트리의 해당 Entry를 마우스 오른쪽 버튼으로 클릭하면 나타나는 컨텍스트 메뉴의 명령을 사용하여 Rule을 내보낼 수도 있습니다.

  • 트리에서 Rule 유형의 Entry를 마우스 오른쪽 버튼으로 클릭하고 Export <RuleType> Rules 명령을 선택하여 해당 유형의 Rule을 내보냅니다.

  • 트리에서 Rule 범주의 Entry를 마우스 오른쪽 버튼으로 클릭하고 Export <RuleCategory> Rules 명령을 선택하여 해당 범주의 Rule을 내보냅니다.

  • 트리의 Rule Class 제목을 마우스 오른쪽 버튼으로 클릭하고 Export All Rules 명령을 선택하여 모든 Rule을 내보냅니다.

Export 명령을 선택하면 Constraints to Export 대화 상자가 열립니다. 여기서 나중에 다른 프로젝트로 가져올 수 있는 *.CstrDot 파일로 내보낼 Rule을 선택할 수 있습니다. Export x Items 버튼을 클릭하면(x는 대화 상자에서 선택한 항목의 수를 나타냅니다) 표준 File Explorer 대화 상자가 열리며, 여기서 파일의 이름과 위치를 지정할 수 있습니다. Rule은 *.CstrDot 파일로 내보내지며, 이 파일은 나중에 다른 설계로 가져올 수 있습니다.

Javascript ID: CM_ImportExport_AllRules_Export_AD25_8

선택한 하나 이상의 Rule을 마우스 오른쪽 버튼으로 클릭하여 내보냅니다.

Rule Class 트리에서 Rule 유형 Entry를 마우스 오른쪽 버튼으로 클릭하여 해당 유형의 Rule을 내보냅니다.

Rule Class 트리에서 Rule 범주 Entry를 마우스 오른쪽 버튼으로 클릭하여 해당 범주의 Rule을 내보냅니다.

Rule Class 제목을 마우스 오른쪽 버튼으로 클릭하여 모든 Rule을 내보냅니다.

가져오려면 All Rules 뷰의 목록 Region 또는 Rule Class 트리에서 마우스 오른쪽 버튼을 클릭하고 Import Rules 명령을 선택합니다. 표준 File Explorer 창이 열리면 원하는 *.CstrDot 파일을 선택한 다음 Open을 클릭합니다. Constraints to Import 대화 상자가 열리며, 여기서 현재 설계로 가져올 Rule을 선택할 수 있습니다. 가져올 때 관련 Custom 범위가 자동으로 적용됩니다.

고급 Rule 삭제

현재 선택한 고급 Rule을 삭제하려면 해당 Rule을 마우스 오른쪽 버튼으로 클릭하고 Remove Advanced Rule을 선택합니다. 여러 고급 Rule을 한 번에 삭제하려면 Ctrl+Click, Shift+Click 또는 Click, Hold&Drag을 사용하여 여러 Rule을 선택한 다음, 마우스 오른쪽 버튼을 클릭하고 Remove Advance Rules (x)을 선택합니다. 'x'는 제거할 Rule의 수를 나타냅니다. Rule Class 트리의 해당 Entry를 마우스 오른쪽 버튼으로 클릭하면 나타나는 컨텍스트 메뉴의 명령을 사용하여 특정 유형이나 범주의 모든 고급 Rule 또는 모든 고급 Rule을 제거할 수도 있습니다.

Javascript ID: CM_RemoveAdvancedRules_AD25_8

선택한 여러 Rule을 마우스 오른쪽 버튼으로 클릭하여 제거합니다.

Rule Class 트리에서 Rule 유형 Entry를 마우스 오른쪽 버튼으로 클릭하여 해당 유형의 고급 Rule을 제거합니다.

Rule Class 트리에서 Rule 범주 Entry를 마우스 오른쪽 버튼으로 클릭하여 해당 범주의 고급 Rule을 제거합니다.

Rule Class 제목을 마우스 오른쪽 버튼으로 클릭하여 모든 고급 Rule을 제거합니다.

모든 경우에 Rule은 확인 절차 없이 즉시 삭제됩니다.

크로스 프로빙

제약 조건 Manager에는 해당 문서에서 관련 객체를 시각적으로 강조 표시하는 크로스 프로브 기능이 포함되어 있습니다. 객체를 크로스 프로브하려면 해당 Entry를 마우스 오른쪽 버튼으로 클릭한 다음 컨텍스트 메뉴에서 Cross Probe 옵션을 선택하거나, 고급 Rule의  메뉴에서 Cross Probe을 선택합니다.

Javascript ID: CM_CrossProbe_AD24_1

크로스 프로빙 설정을 구성하려면 Properties Panel에서 Cross Probe View Settings을 설정합니다.

크로스 프로브 강조 표시를 초기화하려면 Schematic/PCB Editor의 Clear Filter 옵션을 사용합니다(설계 공간에서 마우스 오른쪽 버튼을 클릭하고 Clear Filter 선택, 단축키: Shift+C).

Altium Designer의 크로스 프로빙에 대한 자세한 내용은 크로스 프로빙 및 선택 페이지를 참조하세요.

크로스 선택

크로스 선택 기능을 사용하면 객체를 동적으로 양방향 선택할 수 있습니다. 크로스 선택 모드가 활성화되면( Cross Select Mode을 사용하여 명령을 Tools 제약 조건 Manager, Schematic 또는 PCB Editor의 메인 메뉴에서 선택하면), 제약 조건 Manager에서 선택한 객체가 Schematic 및 PCB 문서에서도 선택되며, 그 반대도 마찬가지입니다.

Altium Designer의 교차 선택에 대한 자세한 내용은 교차 탐색 및 선택 페이지를 참조하세요.

Schematic과 PCB 간 제약 조건 전송

제약 조건 Manager에서 적용한 변경 사항은 Engineering Change Order(ECO) 프로세스를 통해 Schematic과 PCB 설계 간에 전송됩니다. 반대쪽의 제약 조건을 업데이트할 명령을 선택하세요.

  • Schematic에서 PCB로 변경 사항을 전송하려면 – Schematic Editor의 메인 메뉴에서 Design » Update PCB Document <PCBDocumentName> 명령을 선택하세요.

  • PCB에서 Schematic으로 변경 사항(제약 조건 Manager의 Clearances, Physical 및/또는 Electrical 보기에서 적용한 변경 사항)을 전송하려면 – PCB Editor의 메인 메뉴에서 Design » Update Schematics in <PCBProjectName> 명령을 선택하세요.

이어서 표시되는 Engineering Change Order 대화 상자에서 변경 사항을 검토하고, 유효성을 검사하고, 실행하세요.

Schematic에서 PCB로 변경 사항을 전달하는 과정에서 ECO 대화 상자를 열면, Rule/클래스에 적용된 변경 사항으로 제약 조건 Manager가 자동으로 새로 고쳐집니다. 단, 제약 조건 Manager가 이미 열려 있는 경우에는 저장되지 않은 변경 사항이 없어야 이 동기화가 수행됩니다.

Schematic에서 PCB로 변경 사항을 전송할 때는 제약 조건 Manager에 정의된 Rule, Net 클래스, Differential Pair 및 Differential Pair 클래스만 전송된다는 점에 유의하세요. 다음 항목은 감지되거나 전송되지 않습니다.

  • 파라미터 Set 및 Differential Pair 지시문이나 Schematic 문서 옵션의 Properties Panel을 사용하여 정의한 Rule.

  • 자동으로 생성된 Net 클래스(Project Options 대화 상자의 Class Generation 탭 설정에 따라 생성).

  • 파라미터 Set 및 Differential Pair 지시문을 사용하여 정의한 Net 및 Differential Pair 클래스.

  • Differential Pair 지시문을 사용하여 정의한 Differential Pair.

제약 조건 Manager에 정의된 Net 클래스는 Project Options 대화 상자의 Class Generation 탭 설정과 관계없이 전송됩니다.

Schematic에 배치된 지시문에서 Rule, Net 클래스, Differential Pair 및 Differential Pair 클래스를 제약 조건 Manager로 Import할 수 있습니다 – 자세히 알아보기.

  • Schematic과 PCB를 동기화할 때 제약 조건 Manager에서 적용한 변경 사항이 저장되지 않았다면 Engineering Change Order 대화 상자에 알림이 표시됩니다. 경고에는 변경 사항이 저장되지 않은 쪽이 Schematic인지, PCB인지, 아니면 둘 다인지 표시됩니다().

  • Schematic에 존재하는 설계 지시문 중 제약 조건 Manager로 이전에 Import하지 않은 지시문이 있으면 Engineering Change Order 대화 상자에 경고가 표시됩니다().

  • 일부 클래스의 범위(멤버 목록)가 변경되었지만 원본 Schematic과 제약 조건 Manager 간에 동기화되지 않은 경우, Schematic에서 PCB를 업데이트하려고 하면 Engineering Change Order 대화 상자에 경고가 표시됩니다().

자세한 내용은 Schematic과 PCB의 동기화 유지 페이지를 참조하세요.

Design Rule에서 제약 조건 Manager로 마이그레이션

이 기능은 Advanced Settings 대화 상자에서 ConstraintManager.ProjectMigrationWizard 옵션이 활성화된 경우 사용할 수 있습니다.

PCB 프로젝트가 기존 Rule 관리 시스템(즉, PCB Rules and Constraints Editor 대화 상자)을 사용하는 경우, 제약 조건 Manager로 일회성 단방향 마이그레이션을 수행할 수 있습니다.

PCB 및 Schematic Editor의 메인 메뉴에서 Design » Migrate Project to Constraint Manager Flow 명령을 사용하세요. Migration Required 대화 상자가 열리고, 마이그레이션이 수행되며  버튼을 클릭한 후에는 되돌릴 수 없다는 경고가 표시됩니다.

PCB Design Rule과 Schematic 지시문은 모두 제약 조건 Manager 내의 해당하는 제약 조건으로 전송됩니다. 마이그레이션이 성공적으로 완료되면 제약 조건 Manager가 열립니다(마이그레이션을 수행할 때 활성화되어 있던 Editor의 컨텍스트로 열림).

  • Default 범위를 갖는 Design Rule이 PCB Rules and Constraints Editor 대화 상자에 없는 경우(예: 범위가 All인 Width Rule이 없는 경우), 마이그레이션 과정에서 해당 Rule이 제약 조건 Manager에 생성됩니다.

  • 클리어런스 Rule의 첫 번째 및 두 번째 범위 표현식(Where the First Object Matches 및 Where the Second Object Matches)이 All로 설정된 경우, 프로젝트를 제약 조건 Manager로 마이그레이션할 때 Net 범위 / 연결 검사 옵션이 다음과 같이 반영됩니다.

    • Different Nets Only – Rule이 Clearances 보기의 클리어런스 매트릭스에서 All Nets – All Nets 셀에 추가됩니다.

    • Different Differential Pair – Rule이 Clearances 보기의 클리어런스 매트릭스에서 All Nets – All Differential Pairs 셀에 추가됩니다.

    • Same Net Only – Rule이 Physical 보기에서 All Nets 에 해당하는 Same Net Clearance 셀에 추가됩니다.

    • Same Differential Pair – Rule이 Physical 보기에서 All Differential Pairs 에 해당하는 Same Net Clearance 셀에 추가됩니다.

  • 마이그레이션 전에 파라미터 Set 지시문에 추가된 Rule 중 제약 조건 Manager의 Physical 및 Electrical 보기에 표시되지 않는 Rule이 있는 경우, PCB에서 제약 조건 Manager를 열면 해당 Rule이 모든 Rule 보기에 표시되는 고급 Rule로 자동 생성됩니다. 이러한 고급 Rule은 기존 Rule 관리 시스템에서 마이그레이션하고 이어서 Schematic에서 PCB로 ECO를 수행할 때 생성됩니다.

AI-LocalizedAI로 번역됨
만약 문제가 있으시다면, 텍스트/이미지를 선택하신 상태에서 Ctrl + Enter를 누르셔서 저희에게 피드백을 보내주세요.
Contents
기능 가용성

사용할 수 있는 기능은 보유한 Altium 솔루션(Altium Develop, Altium Agile Teams, Altium Agile Enterprise, 또는 Altium Designer(활성 기간 중))에 따라 달라집니다.

실제 소프트웨어에서 문서화된 기능이 보이지 않는 경우, Altium 영업팀에 문의하여 자세한 내용을 확인하세요.

구버전 문서

Altium Designer 문서는 더 이상 버전별로 제공되지 않습니다. 이전 버전의 Altium Designer 문서가 필요하신 경우, Other Installers 페이지의 Legacy Documentation 섹션을 방문해 주세요.

Contents