PCB의 연결성 이해
개요
- 래츠네스트의 개념, 연결선이 Net 연결 상태를 나타내는 방식, Net 토폴로지가 연결선 배치에 미치는 영향을 알아봅니다.
- 복잡한 PCB 레이아웃에서 개별 Net이나 Net 그룹을 빠르게 찾고, 강조 표시하고, 필터링하고, 살펴보는 방법을 알아봅니다.
- PCB Panel에서 Net과 Net 클래스를 탐색하는 방법과 이곳에서 확인할 수 있는 연결 상태 및 길이 정보의 종류를 살펴봅니다.
PCB Editor에서는 Net 내 노드 간의 연결 관계가 일련의 점대점 Connection 선으로 표시되며, 이를 통칭하여 래츠네스트(ratsnest)라고 합니다. Schematic에서 설계를 전송하면(Design » Update PCB) 컴포넌트가 PCB 설계 공간에 배치되고 Connection 선이 가는 실선으로 표시됩니다.
개별 Net 내에서 Connection 선은 해당 Net의 모든 노드를 연결합니다. 연결 패턴 또는 순서를 Net Topology라고 하며, 이는 아래에서 설명합니다.

Net 내 노드는 적용 가능한 라우팅 토폴로지 Rule에 따라 Connection 선으로 연결됩니다(기본값은 Shortest).

이 설계에서는 GND 및 5V Net의 Connection 선에 서로 다른 색상을 사용합니다.
Connection 선은 컴포넌트 배치 시 유용한 가이드일 뿐만 아니라 인터랙티브 라우팅 및 자동 라우팅 중에도 유용한 가이드가 됩니다.
PCB Editor에는 설계 공간에 있는 모든 객체의 위치를 지속적으로 모니터링하고, Net 유형 객체를 편집할 때마다(객체 이동 포함) Connection 선을 업데이트하는 Net 분석기가 포함되어 있습니다. 예를 들어 컴포넌트를 이동하면, 적용 가능한 Design Rule에 정의된 토폴로지를 유지하도록 Connection 선이 업데이트되므로 해당 컴포넌트에서 나오는 각 Connection의 반대쪽 끝이 한 타겟 Pad에서 다른 타겟 Pad로 바뀔 수 있습니다. 아래 동영상의 GND Net에서 이러한 예를 확인할 수 있습니다. 이 Net의 토폴로지는 Shortest입니다.

저항을 이동할 때 전체 Connection 길이를 최단으로 유지하도록 GND Connection 선이 자동으로 재배열되며 연결 위치가 바뀌는 모습을 확인하세요.
보드에서 Net 찾기
라우팅되지 않은 보드는 수많은 Connection 선이 보드 전체를 가로질러 얽혀 있어 복잡하게 느껴질 수 있습니다. 라우팅을 진행하는 좋은 방법은 중요한 컴포넌트와 핵심 Net을 쉽게 찾을 수 있는 Schematic에서 시작하는 것입니다. Schematic의 컴포넌트와 Net에서 직접 교차 선택 및 크로스 프로빙을 수행하여 PCB의 해당 Item을 강조 표시할 수 있습니다. 자세한 내용은 Schematic과 보드 간 작업을 참조하세요.
PCB Editor의 유용한 기능 중 하나는 설계 공간의 객체를 마스킹하거나 흐리게 표시하는 기능입니다. 이 필터링 기능은 필터를 통과하는 객체를 제외한 모든 객체를 희미하게 표시합니다. 아래 이미지는 하나의 Net을 선택하고, 필터를 통과하지 못하는 모든 객체를 Dim하도록 필터링 시스템을 설정한 상태를 보여 줍니다.
이 기능을 살펴보려면 PCB Panel을 Nets 모드로 설정하세요. 그러면 보드의 Net 목록이 표시됩니다. 아래 이미지와 같이 드롭다운에서 필터 모드를 Dim 또는 Mask로 설정한 다음, Select 및 Zoom 옵션을 활성화하세요.
Panel에서 Net 이름을 클릭하면 설계 공간 표시가 바뀌면서 해당 Net의 노드가 보이도록 확대되고, 해당 Net의 Pad와 Connection 선을 제외한 모든 항목이 희미해집니다. 사실상 해당 Net만 보드의 나머지 부분에서 분리해 보여 주는 것입니다. 워크스페이스를 클릭해도 필터가 유지되므로 선택한 Net이 계속 선명하게 표시되어 쉽게 검토하거나 라우팅할 수 있습니다.

필터 기능을 사용하면 Net 또는 Net 클래스를 더 쉽게 찾을 수 있습니다.
PCB Panel 상단의 Clear 버튼을 클릭하여 필터를 지우고 전체 설계 공간을 정상 밝기로 복원하세요(또는 Shift+C 단축키를 누르세요).
개별 Net뿐 아니라 Panel의 Net Classes 영역에서 Net 클래스를 필터링할 수도 있으며(클래스가 정의된 경우), 여러 Net을 인터랙티브하게 선택할 수도 있습니다(Ctrl 키를 누른 상태에서 PCB Panel의 Net 이름을 클릭하여 선택).
Net 탐색
PCB Panel의 Nets 모드에서는 세 개의 주요 영역이 현재 PCB 설계의 Net 계층 구조를 반영하도록 바뀝니다(위에서부터 순서대로).
- Net Classes: 보드에 정의된 항목입니다.
- 클래스 내 개별 멤버 Nets .
- Net 내 개별 Primitives (Pad, 비아, 트랙 및 필).
Net 클래스
Panel 상단 영역(Net Classes)에서 Net 또는 Net Item 항목을 마우스 오른쪽 버튼으로 클릭한 다음, 표시되는 메뉴에서 Properties 를 선택하거나 해당 항목을 직접 두 번 클릭하면 Net 클래스 편집 대화상자에 액세스할 수 있습니다. 이 대화상자에서 클래스에 속한 Net을 확인하거나 편집하고, 클래스 이름을 변경하거나 클래스를 추가할 수 있습니다.
메인 메뉴의 Design » Netlist 하위 메뉴 또는 선택한 Net 객체의 오른쪽 클릭 메뉴에 있는 Net Actions 하위 메뉴에서 다음 명령을 사용하여 Net 클래스를 관리할 수도 있습니다.
- Create NetClass from Selected Nets - 이 명령은 설계 공간에서 선택한 두 개 이상의 Net으로 새 Net 클래스를 생성하는 데 사용됩니다. 명령을 실행하면 Object Class Name 대화상자가 열립니다. 여기에서 새 Net 클래스에 사용할 이름을 지정하세요. OK을 클릭하면 Net 클래스가 생성되고 선택한 Net이 멤버로 추가됩니다.
- Add Selected Net(s) to NetClass - 이 명령은 선택한 하나 이상의 Net을 기존 Net 클래스에 추가하는 데 사용됩니다. 명령을 실행하면 Choose Net Class 대화상자가 열립니다. 이 대화상자에는 기존 Net 클래스가 모두 나열됩니다. 타겟 클래스를 선택한 다음 OK을 클릭하세요. 해당 Net이 그 클래스의 멤버로 추가됩니다.
- Remove Selected Net(s) From NetClass - 이 명령은 선택한 하나 이상의 Net을 기존 Net 클래스에서 제거하는 데 사용됩니다. 명령을 실행하면 Choose Net Class 대화상자가 열립니다. 이 대화상자에는 기존 Net 클래스가 모두 나열됩니다. 타겟 클래스를 선택한 다음 OK을 클릭하세요. 해당 Net이 그 클래스의 멤버에서 제거됩니다.

Choose Net Class 대화상자
Net
Panel의 가운데 Region에는 위쪽 Region에서 선택한 Net 클래스에 속한 Net이 표시됩니다.
각 Net에는 기본적으로 다음 정보가 표시됩니다.
-
- 이 기능에는 두 가지 역할이 있습니다.
- Color background - Net에 지정된 색상입니다. 이 색상은 항상 Net의 연결선에 적용됩니다. Net 색상 표시 재정의 기능을 사용하여 해당 Net의 라우팅에도 적용할 수 있습니다. 이 Net의 색상을 편집하려면 두 번 클릭하고, 현재 선택한 모든 Net의 색상을 편집하려면 마우스 오른쪽 버튼을 클릭합니다.
-
checkbox - 이 Net의 라우팅에 색상을 적용하려면 선택합니다(Net 색상 표시 재정의 기능 활성화). 현재 선택한 모든 Net의 표시 재정의 기능을 활성화하거나 비활성화하려면 마우스 오른쪽 버튼을 클릭합니다. 설계 공간에서 Net 색상 표시 재정의를 활성화하거나 비활성화하려면 F5을 누릅니다.
► 자세한 내용은 Net 색상 재정의 - 라우팅된 Net에 Net 색상 표시하기를 참조하십시오.
-
Name - Net의 이름입니다.
-
Node Count - 이 Net에 있는 Pad의 총개수입니다.
-
Routed Length - 라우팅을 구성하는 배치된 Track 및 Arc 세그먼트의 길이에 비아를 통과하는 수직 거리를 더한 값입니다(아래 참고 사항 참조). 라우팅 길이 계산기는 겹치는 Track 세그먼트나 Pad 내부의 라우팅 굴곡을 보정하지 않습니다.
-
Signal Length - 노드 간 총거리를 정확하게 계산한 값입니다. 배치된 객체를 분석하여 적층되거나 겹치는 객체와 Pad 내부의 우회 경로를 보정하고 비아 길이를 포함합니다. Net의 라우팅이 완료되지 않은 경우 연결선의 맨해튼(X + Y) 길이도 포함됩니다.
Signal 길이 계산에는 다음 참고 사항이 적용됩니다.
-
Pad 내부의 겹침과 굴곡을 보정합니다.
-
Track 및 Arc 이외의 객체(예: Region 또는 Fill)로 생성된 라우팅 경로도 처리합니다.
-
비아를 통과하는 수직 거리를 포함합니다(아래 참고 사항 참조).
-
이 Net의 Total Pin/Package Length을 포함합니다.
-
이 Net의 Unrouted (Manhattan) 길이를 포함합니다.
-
해당 Length/Matched Length 설계 Rule을 충족하지 않으면 Signal 길이가 색상 배경에 표시됩니다. Signal 길이가 너무 짧으면 노란색, 너무 길면 빨간색으로 표시됩니다.
► Length 및 Matched Length 설계 Rule이 적용되는 방식에 대한 자세한 내용은 길이 튜닝을 참조하십시오.
-
Signal은 지점 간 엔티티입니다. 따라서 Panel의 Nets 모드에서는 노드가 두 개인 Net에만 Signal 길이가 표시됩니다(노드 수가 다른 Net에는
0이 표시됩니다). 노드가 세 개 이상인 Net의 Signal 길이를 계산하려면 xSignals를 정의하십시오.► PCB - xSignals를 참조하십시오.
► xSignals에 대한 자세한 내용은 xSignals로 고속 Signal 경로 정의하기를 참조하십시오.
-
-
Total Pin/Package Length - 해당 Net의 모든 Pad에 있는 핀 패키지 길이 값의 합계입니다. 이 값은 PCB Pad의 속성으로 정의되며 Schematic 핀에서도 지정할 수 있습니다.
-
Unrouted (Manhattan) - 라우팅되지 않은 모든 구간의 수직 거리와 수평 거리를 더한 값(X+Y)입니다.
Region에서 마우스 오른쪽 버튼을 클릭한 다음 Columns 하위 메뉴를 사용하여 다음 열을 추가합니다.
-
Min/Max - 해당 Length 및 Matched Length 설계 Rule의 설정입니다. 적용 가능한 Rule이 정의되어 있지 않으면 내부 기본값인
Min=0mil및Max=99999mil가 사용됩니다.► Length 및 Matched Length 설계 Rule에서 Min 및 Max 설정이 산출되는 방식에 대한 자세한 내용은 길이 튜닝을 참조하십시오.
- Estimated Length - Routed Length에 아직 라우팅되지 않은 구간의 연결선 길이를 더한 값입니다. 라우팅되지 않은 부분에는 Manhattan 길이를 사용하지 않고, 지점 간 직선거리를 사용합니다.
- Delay - Signal이 해당 경로를 따라 전파되는 데 걸리는 시간입니다.
Nets Region에서 특정 Net의 항목을 두 번 클릭하거나, Net 항목을 마우스 오른쪽 버튼으로 클릭한 다음 상황에 맞는 메뉴에서 Properties 명령을 선택하면 Edit Net 대화 상자가 열리며, 여기에서 Net의 속성을 수정할 수 있습니다.
Edit Net 대화 상자의 옵션 및 컨트롤
속성
- Net Name - 필요한 경우 Net의 이름을 변경합니다.
- Connection Color - 클릭하면 지정된 Net의 연결 색상을 선택할 수 있는 Choose Color 대화 상자가 열립니다. Net 색상 재정의 기능이 활성화되어 있으면 이 Net 색상을 라우팅된 Net에도 적용할 수 있습니다(F5 누름).
- Hide Connections - 연결 와이어를 숨기려면 활성화합니다.
- Hide Jumpers - 점퍼 또는 라우팅된 세그먼트 사이의 짧은 연결을 숨기려면 활성화합니다.
- Remove Loops - 이 Net에 포함된 불필요한 루프를 자동으로 제거하려면 활성화합니다.
다른 Net의 핀
PCB에 있는 모든 핀의 목록입니다. 현재 Net에 할당된 핀에는 해당 Net 이름이 괄호 안에 표시됩니다. 편집 중인 Net에 추가할 핀을 선택합니다. Shift 및 Ctrl을 사용합니다. 키를 사용하여 여러 핀을 선택합니다. 제어 버튼을 사용하여 선택한 핀을 현재 Net 목록으로 이동하거나, 마우스 오른쪽 버튼을 클릭하고 컨텍스트 메뉴를 사용하여 선택한 핀을 목록에서 제거합니다.
버튼
-
- 모든 Pins in Other Nets을(를) Pins in This Net에 추가할 때 사용합니다.
-
- 선택한 Pins in Other Nets을(를) Pins in This Net에 추가할 때 사용합니다. 여러 핀을 선택하려면 Shift 및 Ctrl 키를 사용합니다.
-
- 모든 Pins in This Net을(를) Pins in Other Nets(으)로 이동할 때 사용합니다.
-
- 선택한 Pins in This Net을(를) Pins in Other Nets(으)로 이동할 때 사용합니다. 여러 핀을 선택하려면 Shift 및 Ctrl 키를 사용합니다.
Pins in Other Nets 목록에서 Pins in This Net 목록으로 핀을 이동한 후, 이동한 핀을 마우스 오른쪽 버튼으로 클릭하고 Remove One 명령을 선택하여 Pins in Other Nets 목록으로 다시 이동할 수 있습니다.
이 Net의 핀
이 Net에 있는 모든 핀을 나열합니다. 이 Net에서 제거할 핀을 선택합니다. 여러 핀을 선택하려면 Shift 및 Ctrl 키를 사용합니다. 제어 버튼을 사용하여 선택한 핀을 현재 Net 목록 밖으로 이동하거나, 마우스 오른쪽 버튼을 클릭하고 컨텍스트 메뉴를 사용하여 선택한 핀을 제거합니다.
현재 인터랙티브 라우팅 설정
Grid
Grid 영역에는 현재 인터랙티브 라우팅 설정이 나열됩니다.
- Track Width - 현재 인터랙티브 라우팅 설정의 Track 너비 필드를 표시합니다. 이 필드는 편집할 수 있으며, 기본 설정 및/또는 설계 요구 사항에 맞게 변경할 수 있습니다.
- Name - Current Routing, Layer Stack Reference 및 Absolute Layer을(를) 나열합니다.
- Index - 인덱스 번호를 표시합니다.
다이어그램
- Via Hole Size - Net에 저장된 현재 비아 홀 크기의 사용자 선택 값을 나타냅니다. 이 대화 상자에서 현재 인터랙티브 라우팅 설정의 현재 값을 수정할 수 있습니다. 값이 0이면 이 대화 상자의 사용자 선택 값이 사용되지 않으며, 이 보드에서 마지막으로 사용한 값이 사용됩니다.
- Via Diameter - 이 Net에 저장된 현재 비아 크기의 사용자 선택 값을 나타냅니다. 이 대화 상자에서 현재 인터랙티브 라우팅 설정의 현재 값을 수정할 수 있습니다. 값이 0이면 이 대화 상자의 사용자 선택 값이 사용되지 않으며, 이 보드에서 마지막으로 사용한 값이 사용됩니다.
- All Widths - Net에 저장된 현재 사용자 선택 값을 나타내는 현재 라우팅 및 해당 레이어 참조 값입니다. 현재 인터랙티브 라우팅 설정의 현재 값을 수정할 수 있습니다. 값이 0이면 이 대화 상자의 사용자 선택 값이 사용되지 않으며, 이 보드에서 마지막으로 사용한 값이 사용됩니다.
- Layers in Layer-Stack only - 레이어 스택에 있는 레이어에만 비아 매개변수를 적용하려면 활성화합니다.
프리미티브
Panel 하단의 Primitives 영역에서 각 Net Item 유형의 표시 및 포함 여부는 Nets 또는 Primitives 영역에서 액세스하는 마우스 오른쪽 버튼 메뉴에서 해당 옵션이 활성화되어 있는지에 따라 달라집니다.

Net 또는 Net Item 항목을 마우스 오른쪽 버튼으로 클릭하여 포함할 Item을 선택합니다.
Primitives 목록의 마우스 오른쪽 버튼 컨텍스트 메뉴에는 선택한 두 Item 사이에 xSignal을 생성하는 옵션도 있습니다. 자세한 내용은 PCB - xSignals를 참조하십시오.
Connection 선 표시 관리
Related page: PCB 보기
Connection 선은 부품을 배치하고 방향을 지정하는 데 유용하며 라우팅 중에도 길잡이 역할을 합니다. 하지만 화면을 상당히 복잡하게 만들 수도 있습니다. 이를 해결하기 위해 PCB Editor는 설계자가 Connection 선의 표시를 관리할 수 있도록 아래에 설명된 기능을 제공합니다.
Connection 선 색상 변경
설계를 Schematic에서 PCB 워크스페이스로 전송하면 기본 레이어 및 색상 설정이 적용됩니다. 이 과정에서 모든 Connection 선에는 뷰 Configuration Panel(L 단축키)의 Layers & Colors 탭에 있는 System Colors 섹션에 정의된 기본 Connection Lines 색상이 지정됩니다. 뷰 구성은 2D 및 3D 워크스페이스 모두에서 사용할 수 있으며, 저장한 후 다시 적용할 수 있습니다(View Configuration Panel의 View Options 탭).
라우팅 과정에서 중요한 Net을 눈에 띄게 만드는 간단한 방법은 해당 Connection 선의 색상을 변경하는 것입니다. 이렇게 하려면 PCB Panel에서 Net 이름을 두 번 클릭하여 Edit Net 대화 상자를 연 다음 Connection 선 색상을 편집합니다(Panel을 Nets 모드로 설정).
또는 하나 or 여러 Net의 색상을 변경하려면 먼저 PCB Panel에서 필요한 Net을 선택한 다음, 선택한 Net을 마우스 오른쪽 버튼으로 클릭하고 Change Net Color 명령을 선택합니다.

PCB Panel에서 선택한 Net을 마우스 오른쪽 버튼으로 클릭하여 Connection 선의 색상을 변경합니다.
레이어 색상을 사용하여 Connection 선 표시
개별 Net에 Connection 선 색상을 지정하는 것 외에도, Connection 선이 연결하는 시작 레이어와 끝 레이어의 색상을 사용하여 Connection 선을 표시할 수 있습니다. Connection 선이 한 레이어의 객체에서 다른 레이어의 객체로 이어지는 경우, Connection은 첫 번째 객체가 있는 레이어의 색상으로 시작한 다음, 끝 레이어의 객체에 가까워질수록 해당 레이어의 색상으로 점차 바뀝니다(아래 이미지 참조).
이 기능은 라우팅 중인 Connection이 도달해야 하는 타겟 레이어를 나타내므로 다층 보드를 라우팅할 때 유용합니다. 색상의 점진적 변화는 한 레이어에서 다른 레이어로 이어지는 Connection에만 적용됩니다. Connection이 같은 레이어에서 시작하고 끝나는 경우에는 지정된 Net 색상이 유지됩니다.
레이어 색상 기능을 사용하려면 아래와 같이 View Configurations Panel의 View Options 탭에서 Use Layer Colors for Connection Drawing 옵션을 활성화합니다.

Connection 선을 시작 레이어와 끝 레이어의 색상으로 표시할 수 있습니다. 오른쪽 이미지에서는 Connection 선이 어떻게 표시되는지 보여주기 위해 여러 Net의 라우팅 세그먼트를 제거했습니다.
싱글 레이어 모드에서 Connection 선 표시
다층 기판은 시각적으로 복잡하여 상태를 파악하기 어려울 수 있습니다. 이때 Shift+S 단축키를 누르면 활성화된 레이어 표시에서 싱글 레이어 모드로 쉽게 전환할 수 있습니다.
일반적으로 이렇게 전환하면 현재 레이어에서 시작하거나 끝나지 않는 모든 Connection 선도 관련이 없는 것으로 간주되어 숨겨집니다. Connection 선을 항상 표시하려면 아래 그림과 같이 View Configurations Panel의 View Options 탭에서 All Connections in Single Layer Mode 옵션을 활성화합니다.

싱글 레이어 모드에서 Connection 선 표시를 제어합니다.
Connection 선 숨기기/표시하기
PCB Panel을 통해 Net을 필터링하는 대신, Connection 선을 하나, 여러 개 또는 모두 완전히 숨길 수 있습니다. View » Connections 하위 메뉴에는 Connection 선 표시를 제어하는 여러 명령이 있습니다. 작업 중에 N 단축키를 눌러 이러한 명령에 접근할 수도 있습니다. 사용 가능한 명령으로 다음 작업을 수행할 수 있습니다.
Net 토폴로지
Net의 노드들이 서로 연결되는 패턴이나 순서를 Net 토폴로지라고 합니다. Net 토폴로지는 해당 라우팅 토폴로지 Design Rule에 의해 제어되며, 기본 토폴로지는 Shortest입니다. Shortest는 해당 Net의 전체 Connection 길이가 가장 짧아지도록 Net의 노드들을 서로 연결하는 패턴을 의미합니다. 컴포넌트를 이동하는 동안 이 전체 길이를 모니터링하며, 전체 길이를 최단으로 유지하도록 Connection 선의 패턴이 동적으로 변경됩니다. 위 애니메이션에서 이동 중인 컴포넌트의 아래쪽으로 연결된 선들이 컴포넌트 이동에 따라 갑자기 바뀌는 모습을 확인할 수 있습니다. 이는 연결된 Pad 중 하나가 해당 Net의 다른 Pad에 더 가까워질 때마다 발생합니다.
라우팅 토폴로지 Design Rule을 사용하여 사전 정의된 토폴로지 적용하기
라우팅 토폴로지 Design Rule을 추가로 생성하여 Net 또는 Net 클래스가 다른 토폴로지를 사용하도록 구성할 수 있습니다. 아래 그림의 왼쪽에는 기본 토폴로지 Rule이 적용된 모습이, 오른쪽에는 동일한 Net에 새로운 Starburst 라우팅 토폴로지가 적용된 모습이 나와 있습니다. Starburst 토폴로지에서는 Electrical Type이 Source인 Pad에서 Connection이 방사형으로 뻗어 나갑니다. 모든 Pad의 기본 유형은 Load입니다.

기본 토폴로지에서는 전체 Connection 길이가 가장 짧아지도록 Connection 선이 배치됩니다. Starburst 토폴로지에서는 모든 Connection 선이 Source Pad에서 방사형으로 뻗어 나갑니다.
Custom 토폴로지 적용하기
개별 Net 내에서 두 노드 사이의 Connection을 From-To라고 합니다. 개별 핀 간 수준에서 Connection 선의 경로를 제어하려면 Net 내에 From-To를 수동으로 정의하여 Custom Net 토폴로지를 만들 수 있습니다.
From-To는 PCB Panel을 From-To Editor 모드로 설정하여 정의합니다. From-To를 정의하려면 Panel에서 두 개의 Nodes on Net를 선택하고 Add From To 버튼을 클릭합니다. 설계 공간에서 From-To를 명확하게 식별할 수 있도록 실선 대신 파선으로 표시됩니다.

두 Pad 사이에 From-To가 정의되었습니다. From-To 선이 실선이 아닌 파선으로 표시되는 점에 주목하세요.
PCB Panel의 From-To Editor 모드는 세 영역으로 나뉩니다.
- Nets
- Nodes선택한 Net의
- From-Tos on Net
Net Entry를 클릭하면 해당 Net의 모든 노드가 Panel의 가운데 Region에 로드됩니다. Net Entry를 두 번 클릭하면 Edit Net 대화 상자가 열리며, 여기서 노드 구성원을 비롯한 Net 속성을 편집할 수 있습니다.
From-To 추가하기
선택한 Net의 두 노드 사이에 사용자 정의 From-To를 추가하려면 Panel의 Nodes on Net Region에서 두 노드를 선택한 다음 Add From To 버튼을 클릭합니다.
새로 추가한 From-To는 Panel의 From-To on Net Region에 나열되며, 설계 공간에서는 두 노드 사이의 점선으로 표시됩니다.

Net에 새 From-To가 생성되었습니다.

설계 공간의 사용자 정의 From-To.
From-To를 제거하려면 패널의 From-To on Net 영역에서 해당 항목을 선택한 다음 Remove 버튼을 클릭합니다.
사전 정의된 토폴로지 선택
네트의 토폴로지는 핀 간 연결의 배치 또는 패턴을 의미합니다. 기본적으로 각 네트의 핀 간 연결은 전체 연결 길이가 가장 짧아지도록 배치됩니다.
네트에 토폴로지를 적용하는 이유는 다양합니다. 신호 반사를 최소화해야 하는 고속 설계에서는 네트를 데이지 체인 토폴로지로 배치하고, 접지 네트에는 모든 트랙이 공통 지점으로 돌아오도록 스타 토폴로지를 적용할 수 있습니다. 네트 내 노드 쌍에 전용 From-To를 생성하거나, 사용 가능한 사전 정의된 라우팅 토폴로지 중 하나를 기반으로 네트의 From-To를 생성할 수 있습니다.
다음 토폴로지를 사용할 수 있으며, 패널의 From-To on Net 영역에서 Generate 버튼을 클릭하여 접근할 수 있습니다.
- Shortest - 이 토폴로지는 전체 연결 길이가 가장 짧아지도록 네트의 모든 노드를 연결합니다.
-
Daisy Simple - 이 토폴로지는 모든 노드를 차례로 체인 형태로 연결합니다. 연결 순서는 전체 길이가 가장 짧아지도록 계산됩니다. 소스 Pad와 종단 Pad를 지정하면 나머지 모든 Pad가 두 Pad 사이에서 가능한 한 가장 짧은 길이로 체인 연결됩니다. 소스 또는 종단을 여러 개 지정하면 각 끝에서 서로 체인 연결됩니다.
-
Daisy Balanced - 이 토폴로지는 모든 부하를 균등한 체인으로 나누며, 전체 체인 수는 종단 수와 같습니다. 그런 다음 이 체인들을 스타 형태로 소스에 연결합니다. 소스 노드가 여러 개이면 서로 체인 연결됩니다.
-
Daisy Mid-Driven - 이 토폴로지는 소스 노드를 데이지 체인의 중앙에 배치하고, 부하를 균등하게 나누어 소스의 양쪽에 체인 연결합니다. 양 끝에 하나씩, 총 두 개의 종단이 필요합니다. 소스 노드가 여러 개이면 중앙에서 서로 체인 연결됩니다. 종단이 정확히 두 개가 아니면 Daisy-Simple 토폴로지가 사용됩니다.
- Starburst - 이 토폴로지는 각 노드를 소스 노드에 직접 연결합니다. 종단이 있으면 각 부하 노드 뒤에 연결됩니다. 소스 노드가 여러 개이면 Daisy Balanced 토폴로지와 마찬가지로 서로 체인 연결됩니다.
Properties 패널의 Pad 모드에서 Electrical Type 필드의 항목을 적절히 변경하여 Pad를 Source, Terminator 또는 Load로 정의할 수 있습니다. Nodes on Net 영역에서 해당 Pad의 항목을 두 번 클릭하면 Properties 패널의 Pad 모드에 접근할 수 있습니다.

Properties 패널의 Pad 모드에서 Pad의 Electrical Type을 Source로 설정하는 모습.
Pad의 전기적 유형을 Source 또는 Terminator로 변경하면 설계 공간에 "[S]" 또는 "[T]"가 표시되어 이를 구분할 수 있습니다.
참고 사항
-
시스템이 생성한 연결선은 설계 공간에 별도 개체로 표시되지 않습니다. From-To와 연관된 핀 간 연결선만 표시되며, 이 연결선은 대화형 라우팅/자동 라우팅의 가이드로 사용됩니다.
-
사용자 정의 From-To는 설계 공간에 점선으로 표시되며, FromTo를 추가할 때 함께 표시되는 핀 간 연결선과는 별개로 구분됩니다. 사용자 정의 From-To 선은 연관된 핀 간 연결선의 시작점과 끝점을 제어합니다. 예를 들면 더 쉽게 이해할 수 있습니다. 논리적으로 연결된 두 부품의 핀 사이에 사용자 정의 From-To를 추가한 경우를 살펴보겠습니다. 연결선도 추가되어 표시됩니다(PCB 패널이 Nets 모드로 설정됨).
-
라우팅에 사용되는 핀 간 연결선이 별개로 존재하는 사용자 정의 From-To 선을 가리고 있습니다. 그러나 연결을 라우팅하기 시작하면 두 선이 서로 별개임을 확인할 수 있습니다.
-
이 상태에서 라우팅을 중단하면 네트 분석기가 필요한 토폴로지를 유지하도록 연결선을 추가합니다. 이 연결선은 점선(Broken Net Marker라고 함)으로 표시되며, 사용자가 사용자 정의 FromTo를 추가하여 지정한 토폴로지를 유지하려면 이 두 지점 사이를 라우팅해야 함을 나타냅니다.
-
네트의 일부에만 사용자 정의 From-To를 지정하면 PCB 편집기는 나머지 핀 간 연결(시스템 생성 From-To)에 Shortest 토폴로지를 설정합니다.
-
From-To의 유형에 따라, 예를 들어 네트 객체를 이동하거나 네트의 일부를 수동으로 라우팅할 때 Connectivity Analyzer가 설계 공간의 연결선을 처리하는 방식이 달라집니다.
- 시스템 생성 From-To - 네트의 기본 토폴로지(즉, Shortest)를 유지하기 위한 네트 분석기의 재최적화 과정에서 필요에 따라 연결선을 이동할 수 있습니다.
- 사용자 정의 From-To - 사전 정의된 토폴로지를 선택하여 생성한 From-To가 아니라면, 해당 연결선은 네트 분석기의 재최적화 과정에 포함되지 않습니다. From-To가 Shortest 이외의 사전 정의된 네트 토폴로지에 속하면, 선택한 토폴로지가 유지되는 한 네트 분석기가 이를 재최적화에 포함할 수 있습니다.
-
From-To로 정의한 사용자 지정 토폴로지가 올바르게 구현되었는지는 해당 네트에 적용된 Routing Topology 설계 규칙의 일괄 Design Rule 검사(DRC) 중에 확인할 수 있습니다. From-To의 Pad 사이에 전기적 연결이 있고 최단 경로에 이 네트의 다른 Pad가 하나 이상 포함되어 있으면 위반이 감지됩니다.
세 개의 Pad 사이에 Pad 1에서 Pad 2로, Pad 2에서 Pad 3으로 이어지는 두 개의 From-To가 생성됩니다.
From-To 구성에 따라 라우팅이 생성되어 Pad 1과 2 사이 및 Pad 2와 3 사이에 라우팅이 존재합니다. Routing Topology 규칙 위반은 감지되지 않습니다.
라우팅이 T자 분기 형태로 생성됩니다. From-To 구성에 따른 경로에 추가 Pad가 없으므로 Routing Topology 규칙 위반은 감지되지 않습니다.
Pad 1과 Pad 3 사이, Pad 2와 Pad 3 사이에 라우팅이 생성됩니다. Pad 1과 Pad 2 사이의 경로에 Pad 3이 추가로 포함되어 있어 이 라우팅은 From-To 구성과 일치하지 않습니다. 따라서 Pad 1과 Pad 2 사이의 From-To에 대해 Routing Topology 규칙 위반이 감지됩니다.
넷리스트 관리자
메인 메뉴에서 Design » Netlist » Edit Nets 명령을 선택하여 여는 Netlist Manager 대화 상자는 보드의 넷리스트를 효과적으로 관리하는 컨트롤을 제공합니다. 필요에 따라 네트를 추가, 편집 또는 삭제할 수 있으며, 해당 네트에 속한 컴포넌트의 핀(또는 패드) 속성도 편집할 수 있습니다. 이 대화 상자에서는 PCB의 연결된 구리를 기반으로 넷리스트를 생성하거나 PCB에서 넷리스트를 내보내는 기능을 비롯한 다른 넷리스트 관리 도구에도 접근할 수 있습니다.
Netlist Manager 대화 상자
넷리스트 관리자 대화 상자의 옵션 및 컨트롤
-
Nets In Board - 대화 상자의 이 영역에는 보드에 정의된 모든 네트가 이름별로 표시됩니다. 목록 위의 마스크 필드를 사용하면 내용을 빠르게 필터링할 수 있습니다.
- Edit - 클릭하면 Net 편집 대화 상자가 열리며, 현재 선택한 네트의 속성을 확인하고 수정할 수 있습니다. 목록에서 여러 네트를 선택한 경우에는 포커스된 네트의 속성이 표시됩니다. 포커스된 네트는 점선 테두리로 표시됩니다.
- Add - 클릭하면 보드에 새 네트가 추가됩니다. 네트 속성을 정의할 수 있는 Edit Net 대화 상자가 열립니다. 새 네트의 초기 기본 이름은 NewNet이며, 필요에 따라 변경할 수 있습니다.
-
Delete - 클릭하면 현재 선택한 네트가 보드에서 삭제됩니다. 확인 대화 상자가 나타나면 Yes 을(를) 클릭하여 삭제를 진행합니다.
-
Pins In Focused Net - 이 영역에는 현재 선택한/포커스된 네트에 연결되거나 속한 모든 핀(컴포넌트 패드)이 표시됩니다. 목록의 각 항목에는 핀 식별자가 <ComponentDesignator>-<PinDesignator> 형식으로 표시됩니다. 목록 위의 마스크 필드를 사용하면 내용을 빠르게 필터링할 수 있습니다.
- Edit - 클릭하면 Pad 대화 상자가 열리며, 현재 선택한 핀(패드)의 속성을 확인하고 수정할 수 있습니다.
-
Menu - 클릭하면 다음 명령을 제공하는 메뉴가 열립니다.
- Add Net - 보드에 새 네트를 추가합니다. 네트 속성을 정의할 수 있는 Edit Net 대화 상자가 열립니다.
- Delete Net - 현재 선택한 네트를 보드에서 삭제합니다. 확인 대화 상자가 나타나면 Yes 을(를) 클릭하여 삭제를 진행합니다.
-
Update Free Primitives From Component Pads - 라우팅 프리미티브의 네트 이름을 해당 프리미티브가 연결된 패드의 네트 이름과 다시 동기화합니다. 명령을 실행하면 자유 프리미티브의 네트를 컴포넌트 패드의 네트로 업데이트할지 묻는 확인 대화 상자가 나타납니다. Yes을(를) 클릭하면 각 패드를 시작점으로 연결된 구리가 선택되고, 각 프리미티브의 네트 이름이 해당 패드의 네트 이름과 일치하도록 설정됩니다.
- Clear All Nets - 현재 설계 문서에서 모든 네트를 제거하여 내부 PCB 넷리스트를 완전히 비웁니다. 소스 회로도 문서에서 네트 정보를 변경한 후 PCB를 소스 회로도의 넷리스트 정보와 완전히 다시 동기화하려는 경우에 유용합니다. 명령을 실행하면 이 작업으로 PCB의 모든 네트 정보가 지워진다는 확인 대화 상자가 나타납니다. Yes을(를) 클릭하면 모든 네트 정보가 제거됩니다. 이미 라우팅된 트랙은 그대로 유지되지만, No Net이(가) 할당됩니다. 라우팅되지 않은 논리적 연결은 모두 제거됩니다.
- Export Netlist From PCB - 현재 문서의 내부 PCB 넷리스트를 파일로 내보냅니다. 명령을 실행하면 PCB에서 넷리스트를 내보낼지 묻는 확인 대화 상자가 나타납니다. Yes을(를) 클릭하면 PCB 설계 문서와 동일한 폴더에 넷리스트(Exported <PCBDocumentName>.Net)가 생성됩니다.
-
Create Netlist From Connected Copper - 현재 설계에서 라우팅으로 형성된 연결을 기반으로 넷리스트 파일을 생성합니다. 명령을 실행하면 PCB의 구리를 기반으로 넷리스트를 생성할지 묻는 확인 대화 상자가 나타납니다. Yes을(를) 클릭하면 PCB 설계 문서와 동일한 폴더에 넷리스트(Generated <PCBDocumentName>.Net)가 생성되고, 메인 설계 창에서 활성 문서로 자동으로 열립니다.
Pad 대화 상자의 옵션 및 컨트롤
Pad 템플릿
- Template - 드롭다운에서 Pad 템플릿을 선택합니다.
- Library - Pad 템플릿이 연결된 라이브러리를 표시하며, 해당 라이브러리와 템플릿의 연결을 해제하는 옵션을 제공합니다.
위치
- X - 현재 원점을 기준으로 한 패드 중심의 현재 X 위치입니다. 값을 편집하여 원점을 기준으로 패드 위치를 변경할 수 있습니다.
- Y - 현재 원점을 기준으로 한 Pad 중심의 현재 Y 위치입니다. 원점을 기준으로 Pad의 위치를 변경하려면 값을 편집합니다.
- Rotation - Pad의 현재 회전 각도(도)입니다. Pad의 회전을 변경하려면 값을 편집합니다. 최소 각도 분해능은 0.001°입니다.
홀 정보
- Hole Size - Pad의 현재 홀 크기입니다. 이 값은 제조 중 Pad에 드릴로 가공할 홀의 직경(mil 또는 mm)을 지정합니다. SMD Pad나 에지 커넥터와 같은 단일 레이어 Pad의 경우 이 값은 자동으로 0으로 설정됩니다. 홀 크기는 0~1000mil 범위에서 설정할 수 있으며, Pad 영역보다 크게 설정하여 구리가 없는 기계적 홀을 정의할 수도 있습니다. Pad의 홀 크기를 변경하려면 이 필드의 값을 편집합니다. 값은 mm 또는 mil 단위로 입력할 수 있습니다.
- Tolerance - 홀 공차 속성을 설정하면 보드의 끼워맞춤과 허용 한계를 결정하는 데 도움이 됩니다. 설계의 최소(-) 및 최대(+) 홀 공차를 지정합니다.
다음 옵션 중 하나를 선택하여 홀의 모양을 지정합니다.
- Round - Pad의 홀 모양을 원형(기본값)으로 지정합니다.
- Square - Pad의 홀 모양을 정사각형(펀칭)으로 지정합니다.
- Slot - Pad의 홀 모양을 양 끝이 둥근 슬롯형으로 지정합니다.
- Plated - 이 옵션은 Pad에 도금된 홀이 있는지 여부를 결정합니다. 설계에 도금된 Pad와 도금되지 않은 Pad가 모두 있는 경우, NC 드릴 파일에서 비도금 홀은 도금 홀과 다른 공구를 사용하도록 설정됩니다.
속성
- Designator - Pad의 현재 Designator입니다. Pad가 컴포넌트의 일부인 경우, Designator는 일반적으로 해당 컴포넌트의 핀 번호로 설정됩니다. Designator는 최대 20자까지 사용할 수 있으며 공백은 포함할 수 없습니다. 독립 Pad에는 Designator를 지정하거나 이 필드를 비워 둘 수 있습니다. Designator가 숫자로 시작하거나 끝나는 경우, 여러 Pad를 연속으로 배치하면 해당 숫자가 자동으로 증가합니다. Pad의 Designator를 변경하려면 이 필드의 값을 편집합니다. 필요한 경우 동일한 컴포넌트 풋프린트 내의 여러 Pad가 동일한 Designator를 공유할 수 있습니다.
-
Layer - Pad가 현재 할당된 레이어입니다. Pad는 사용 가능한 모든 레이어에 할당할 수 있습니다. 모든 신호 레이어에 Pad 모양을 정의하려면 Layer을
Multi-Layer으로 설정합니다. - Net - Pad가 현재 할당된 Net입니다. 필드를 클릭하고 드롭다운 목록에서 Net을 선택하여 Net 할당을 변경합니다. Pad가 어떤 Net에도 연결되지 않도록 지정하려면 No Net을 선택합니다. Net 속성은 Design Rule 검사기가 PCB 객체의 배치가 규칙에 맞는지 판단하는 데 사용됩니다.
- Electrical Type - 이 필드는 Pad의 현재 전기적 상태를 표시합니다. 이 상태는 컴포넌트 Pad에만 적용되며 해당 Pad의 전송선 특성을 설정합니다. Pad는 부하, 소스 또는 종단으로 지정할 수 있습니다. 소스 및 종단 설정은 Net에 데이지 체인 라우팅 토폴로지 중 하나가 필요한 경우 사용됩니다. 전기적 유형을 변경하려면 필드를 클릭하고 드롭다운 목록에서 선택합니다.
- Pin/Pkg Length - 핀 패키지 길이는 PCB 패널에 표시되는 Signal Length 계산에 자동으로 포함됩니다. 선택한 Net에 있는 핀의 Pin/Pkg Length 값을 확인하거나 편집하려면 PCB 패널을 Nets 모드로 설정합니다.
- Jumper ID - 이 Pad가 점퍼 컴포넌트 풋프린트의 일부임을 나타내려면 0이 아닌 값(1~1000 범위)을 설정합니다. 점퍼 컴포넌트는 트랙을 사용하는 대신 와이어 링크로 Pad를 물리적으로 연결하는 단면 PCB에서 사용할 수 있습니다. Jumper ID 값은 소프트웨어에 어떤 Pad를 '연결된' 것으로 취급할지 알려 줍니다. 점퍼 연결은 동일한 컴포넌트 풋프린트 내의 Pad 사이에서만 생성할 수 있습니다. 이들 Pad는 Jumper ID 값이 같아야 하며 동일한 Net에 할당되어야 합니다. 또한 컴포넌트의 Type가 Jumper로 설정되어 있어야 합니다. 이러한 조건이 충족되면 PCB Editor에서 점퍼 연결이 곡선 연결선으로 표시됩니다.
- Locked - Pad가 그래픽 방식으로 편집되지 않도록 보호하려면 활성화합니다. 위치나 크기가 중요한 Pad는 잠그십시오. 잠긴 프리미티브를 편집하려고 하면 해당 프리미티브가 잠겨 있다는 알림과 함께 작업을 계속할지 묻는 메시지가 표시됩니다. 이 옵션을 선택 해제하면 확인 메시지 없이 프리미티브를 자유롭게 편집할 수 있습니다. Locked 체크박스는 컴포넌트에 속한 Pad에는 영향을 주지 않습니다. 컴포넌트가 잠겨 있지 않으면 컴포넌트를 이동할 때 Pad도 함께 이동합니다. 이 경우 실수로 이동하는 것을 방지하려면 컴포넌트를 잠그십시오.
테스트포인트 설정
이 영역에서 Fabrication 및/또는 Assembly 테스트포인트 파일 생성을 위한 테스트포인트로 이 Pad를 정의합니다. 테스트포인트는 보드가 올바르게 작동하는지 확인하기 위해 테스트 프로브가 PCB에 접촉할 수 있는 위치입니다. 필요한 테스트포인트 유형 및 레이어 체크박스를 활성화하여 모든 Pad 또는 비아를 테스트포인트로 지정할 수 있습니다. 이렇게 하면 Pad 또는 비아가 자동으로 잠기며, Pad가 컴포넌트에 속해 있으면 해당 컴포넌트도 잠깁니다. 이동이 필요한 경우 Pad/비아/컴포넌트의 잠금을 일시적으로 해제할 수 있습니다. 테스트포인트 설정을 비활성화해도 Pad/비아/컴포넌트의 잠금은 자동으로 해제되지 않으므로 수동으로 해제해야 합니다.
- Top - 이 Pad를 상단 레이어 테스트포인트로 정의하려면 이 옵션을 활성화합니다.
- Bottom - 이 Pad를 하단 레이어 테스트포인트로 정의하려면 이 옵션을 활성화합니다.
크기 및 모양
Pad의 구리 영역(랜드 영역)은 X 및 Y 크기와 모양 설정으로 정의됩니다.
- Simple - 단순 Pad는 모든 레이어에서 크기와 모양이 동일한 Pad입니다.
-
Top-Middle-Bottom - 상단-중간-하단 레이어 구조의 Pad는 상단 레이어, 모든 중간 신호 레이어, 하단 레이어에 대해 X 및 Y 크기와 모양을 각각 다르게 정의할 수 있습니다.
- X-Size - Pad의 현재 X(가로) 크기입니다. 1~10000mil 범위의 값을 입력합니다. X 및 Y 크기를 서로 독립적으로 설정하여 비대칭 Pad 모양을 정의할 수 있습니다.
- Y-Size - Pad의 현재 Y(수직) 크기입니다. 1~10000mil 범위의 값을 입력합니다. X 및 Y 크기를 독립적으로 설정하여 비대칭 Pad 모양을 정의할 수 있습니다.
-
Shape - 기본 Pad 모양입니다. 기본 Pad 모양에는
Round,Rectangular,Octagonal또는Rounded Rectangle이 포함됩니다. X 및 Y 크기 설정을 변경하여 기본 모양을 비대칭 Pad 모양으로 조정할 수 있습니다. -
Corner Radius - 이 옵션은 Shape이
Rounded Rectangle으로 설정된 경우 사용할 수 있습니다. 이 값은 Pad의 가장 짧은 변 길이의 절반에 대한 백분율이므로, 0%는 직사각형 Pad에, 100%는 원형 Pad에 해당합니다. - Offset From Hole Center (X/Y) - Pad 랜드 영역을 Pad 홀 중심에서 오프셋할 값을 입력합니다.
-
Full Stack - 각 레이어에서 서로 다른 홀 크기와 직경을 편집할 수 있습니다(모든 신호 레이어 및 플레인 포함).
-
Edit Full Pad Layer Definitions - 클릭하면 각 레이어의 Pad 모양, 크기, X/Y 위치 등 Pad/비아 설정과 관련된 컨트롤을 제공하는 Pad Layer Editor 대화상자가 열립니다. 이 버튼을 사용하려면 Full Stack를 선택해야 합니다.
Options and Controls of the Pad Layer Editor Dialog
- Main Grid - Pad Stack은 스택의 레이어별 Pad 모양과 크기에 관한 Pad 정보의 모음입니다. 이 Grid에서 속성 중 하나를 클릭하면 스택의 현재 레이어에 대한 값을 편집할 수 있습니다. Pad Stack의 레이어는 Layer Stack Manager(Design » Layer Stack Manager)에서 가져옵니다.
-
Attributes on Layer
- Shape - 드롭다운 목록에서 Pad 모양을 선택합니다: Round, Rectangular, Octagonal 또는 Rounded Rectangle.
- X Size - 클릭하여 Pad의 X 크기를 지정합니다.
- Y Size - 클릭하여 Pad의 Y 크기를 지정합니다.
- Corner Radius (%) - 클릭하여 Pad의 모서리 반경을 지정합니다. 이 필드는 Rounded Rectangle에 대해서만 편집할 수 있습니다.
-
Layer Stack Reference
- Name - Pad 레이어가 참조하는 레이어입니다.
- Index - 레이어의 상대 인덱스입니다.
-
Absolute Layer
- Name - 기본적으로 정의되는 레이어 이름입니다.
- Index - 모든 레이어(숨겨진 레이어 포함)에서 Pad의 절대 인덱스입니다.
- Only show layers in layerstack - 이 옵션을 활성화하면 레이어 스택에서 Layer Stack Manager에서 가져온 레이어만 표시됩니다. 사용 중인 레이어를 확인하려면 Layer Stack Manager (Design » Layer Stack Manager)를 확인하십시오. 이 옵션을 비활성화하면 사용 가능한 모든 PCB 레이어가 표시됩니다.
-
Paste Mask Expansion
소프트웨어는 Pad와 동일한 모양의 개구부를 페이스트 마스크에 자동으로 생성합니다. 이 설정에 따라 개구부는 Pad 자체보다 클 수도 있고(양의 확장 값), 작을 수도 있습니다(음의 확장 값). 일반적으로 페이스트 마스크 개구부는 Pad보다 작지만 예외도 있습니다.
- Expansion value from rules - 이 옵션을 활성화하면 이 Pad의 페이스트 마스크 확장은 해당 Paste Mask Expansion 설계 규칙에 따라 정의됩니다.
- Specify expansion value - 이 옵션을 활성화하면 규칙을 재정의하고 이 Pad의 페이스트 마스크 확장 값을 지정할 수 있습니다.
솔더 마스크 확장
소프트웨어는 Pad와 동일한 모양의 개구부를 솔더 마스크에 자동으로 생성합니다. 이 설정에 따라 개구부는 Pad 자체보다 클 수도 있고(양의 확장 값), 작을 수도 있습니다(음의 확장 값). 일반적으로 솔더 마스크 개구부는 Pad보다 크지만 예외도 있습니다.
- Expansion value from rules - 이 옵션을 활성화하면 이 Pad의 솔더 마스크 확장은 해당 Solder Mask Expansion 설계 규칙에 따라 정의됩니다.
- Specify expansion value - 이 옵션을 활성화하면 규칙을 재정의하고 이 Pad의 솔더 마스크 확장 값을 지정할 수 있습니다.
- Solder Mask From The Hole Edge - 이 대화상자에서 확장 값을 지정하는 경우, 이 옵션을 활성화하여 Pad 가장자리 대신 홀 가장자리를 기준으로 솔더 마스크 확장을 정의할 수도 있습니다.
- Force complete tenting on top - 텐팅이라는 용어는 to close off을 의미합니다. 이 옵션을 활성화하면 해당 솔더 마스크 확장 설계 규칙의 설정이 재정의되어 이 Pad의 상단 솔더 마스크 레이어에 개구부가 생성되지 않습니다. 이 옵션을 활성화하면 Expansion value from rules 및 Specify expansion value 옵션은 무시됩니다.
- Force complete tenting on bottom - 텐팅이라는 용어는 to close off을 의미합니다. 이 옵션을 활성화하면 해당 솔더 마스크 확장 설계 규칙의 설정이 재정의되어 이 Pad의 하단 솔더 마스크 레이어에 개구부가 생성되지 않습니다. 이 옵션을 활성화하면 Expansion value from rules 및 Specify expansion value 옵션은 무시됩니다.
Net 보고서 생성
활성 PCB 문서에서 넷리스트 상태 보고서를 생성하려면 주 메뉴에서 Reports » Netlist Status 명령을 선택합니다. 이 보고서는 라우팅된 보드의 넷리스트에 관한 상세 정보를 제공합니다. 모든 Net을 나열하고 각 Net에 대해 라우팅에 사용된 레이어와 물리적으로 라우팅된 Track의 총 길이를 표시합니다. 명령을 실행하면 Net Status - <PCBDocumentName>.html 보고서가 생성되어 활성 문서로 열립니다. 각 Net이 목록에 표시되며, Net 이름을 클릭하면 PCB 문서에서 해당 Net이 강조 표시됩니다. 물리적으로 라우팅된 Track 길이 데이터는 처음에는 보드 설계 자체에 지정된 측정 단위로 표시됩니다. 보고서의 Units 필드를 사용하면 필요에 따라 영국식 단위와 미터법 단위를 빠르게 전환할 수 있습니다.
)








