PCB의 룸 작업
개요
- PCB의 룸이 무엇이며, 지정된 보드 영역 내에서 객체 배치와 설계 요구 사항을 제어하는 데 어떻게 사용되는지 알아봅니다.
- 대화형 배치, 선택한 컴포넌트에서 생성, 설계 제약 조건을 통한 생성 등 PCB Editor에서 룸을 만드는 주요 방법을 살펴봅니다.
- Altium Designer에서 룸 객체와 Room Definition 제약 조건이 어떻게 연동되는지 이해하고, PCB Rules and Constraints Editor와 Constraint Manager에서 이를 어떻게 적용하는지 알아봅니다.
요약
룸은 PCB 표면 레이어 중 하나에 정의된 영역입니다. 룸은 보드의 해당 영역 내에서 다음과 같은 설계 요구 사항을 정의하는 데 사용됩니다: these components must be in this area 또는 route these nets this width 또는 use routing vias of this size.
룸은 다른 다각형 객체와 마찬가지로 직사각형 또는 다각형 형태로 배치됩니다.
각 룸은 보드에서 이름이 지정된 X-Y 형상으로 존재할 뿐만 아니라, 이름이 지정된 Room Definition 설계 제약 조건으로도 자동 생성됩니다. Room Definition 제약 조건의 설정은 룸이 적용되는 objects, 해당 객체를 룸의 inside or outside에 유지할지 여부, 룸이 적용되는 layer를 정의합니다.
Room Definition 제약 조건이 직접 지정하는 단순한 keep these objects in (or out) 요구 사항 외에도, 룸을 사용하여 다른 설계 제약 조건이 적용되는 보드 영역을 정의할 수 있습니다. 예를 들어 BGA 아래의 라우팅에는 특정 폭이 필요할 수 있으며, BGA 아래의 Differential Pair 라우팅에는 특정 임피던스 프로파일을 적용해야 할 수 있습니다
사용 가능 여부
룸은 PCB Editor에서만 배치하거나 생성할 수 있습니다. 다음 방법으로 룸을 생성할 수 있습니다:
-
Design » Rooms 하위 메뉴에서 필요한 명령을 선택한 다음, 룸 형상을 대화형으로 정의하거나(Place 명령을 선택한 경우) 룸을 자동으로 생성합니다(Create 명령을 선택한 경우).
-
새 Room Definition 설계 제약 조건을 추가하고 새 룸 제약 조건을 편집한 다음, Define 버튼을 클릭하여 다각형 룸의 형상을 대화형으로 정의합니다.
-
Tools » Convert » Create Room from Selected Primitives 명령을 사용하여 트랙/호 세트로 이루어진 닫힌 Outline(선택된 상태)을 기반으로 룸을 생성합니다.
-
Schematic에서 PCB로 설계를 동기화하는 동안 룸을 자동으로 생성합니다. 자동 생성된 룸에 대해 자세히 알아보세요(비활성화하는 방법 포함).
룸 생성
PCB 문서에서 룸을 생성하는 절차는 룸을 대화형으로 배치하는지 또는 생성하는지, 그리고 어떤 배치/생성 방법을 선택했는지에 따라 달라집니다.
룸을 배치하거나 생성하는 데 다양한 방법을 사용할 수 있습니다.
대화형 룸 배치
직사각형 또는 다각형 룸은 설계의 상단 또는 하단 레이어에 배치할 수 있습니다. 어떤 레이어가 활성화되어 있든 룸을 배치할 수 있지만, 룸이 적용되는 레이어는 Room Definition 설계 제약 조건에서 지정됩니다.
직사각형 룸
Design » Rooms » Place Rectangular Room 명령을 실행하면 커서가 십자선으로 바뀌고 룸 배치 모드로 전환됩니다. 다음 순서로 배치합니다:
-
클릭하거나 Enter 키를 눌러 룸의 첫 번째 모서리를 고정합니다.
-
연결된 Room Definition 제약 조건의 속성을 즉석에서 편집하려면 배치 중에 Tab 키를 누릅니다.
-
커서를 이동하여 룸의 크기를 조정한 다음, 클릭하거나 Enter 키를 눌러 대각선 반대쪽 모서리를 고정하고 룸 배치를 완료합니다.
-
계속해서 다른 룸을 배치하거나, 마우스 오른쪽 버튼을 클릭하거나 Esc 키를 눌러 배치 모드를 종료합니다.
다각형 룸
Design » Rooms » Place Polygonal Room 명령을 실행하면 커서가 십자선으로 바뀌고 룸 배치 모드로 전환됩니다. 다음 순서로 배치합니다:
-
커서를 원하는 위치에 놓고 클릭하여 룸의 시작점을 고정합니다.
-
커서를 이동하고 클릭하여 룸의 다각형 형상을 정의하는 일련의 꼭짓점을 고정합니다.
-
마지막 꼭짓점을 배치한 후 마우스 오른쪽 버튼을 클릭하거나 Esc 키를 눌러 룸 배치를 완료합니다. 소프트웨어가 시작점과 마지막으로 배치한 점을 연결하여 형상을 자동으로 완성하므로 다각형을 직접 닫을 필요는 없습니다.
-
계속해서 다른 다각형 룸을 배치하거나, 마우스 오른쪽 버튼을 클릭하거나 Esc 키를 눌러 배치 모드를 종료합니다.
선택한 컴포넌트 기반
컴포넌트가 이미 보드에 배치되어 있고 해당 배치에 맞는 새 룸을 생성하려면 세 가지 Create xxx Room from selected components 명령 중 하나를 사용합니다. 이 명령 중 하나를 사용하면 설계 공간에서 현재 선택된 컴포넌트를 기반으로 비직교형, 직교형 또는 직사각형 룸을 자동으로 생성할 수 있습니다. 각 경우의 생성 방법은 동일합니다:
-
룸을 생성할 컴포넌트를 모두 선택합니다. Schematic에서 PCB 컴포넌트를 선택하려면 Tools » Cross Select Mode 명령을 실행한 다음 Schematic에서 컴포넌트를 선택합니다.
-
PCB Editor에서 해당 생성 명령(Design » Rooms » Create xxx Room from selected components)을 실행합니다. 선택된 컴포넌트를 포함하는 컴포넌트 클래스가 자동으로 생성됩니다(기존 클래스가 없는 경우).
-
그러면 선택한 룸 유형이 생성되고, 해당 룸의 Room Definition Design Rule이 생성된 컴포넌트 클래스에 자동으로 연결됩니다.
-
룸 크기는 컴포넌트의 선택 사각형을 기준으로 선택한 모든 컴포넌트가 들어가도록 조정됩니다.
-
룸을 클릭하고 드래그하여 이동하면 연결된 컴포넌트 클래스의 모든 컴포넌트도 함께 이동합니다.
Room Definition 설계 제약 조건을 추가하여 생성
PCB Rule and Constraints Editor 또는 Constraint Manager에서 새 제약 조건을 정의하여 새 룸을 생성할 수도 있습니다.
설계 제약 조건을 정의하는 데 어떤 방식을 사용하나요?
Altium Designer는 설계 제약 조건을 정의하는 두 가지 방식을 지원합니다. 제약 조건 Manager 및 PCB Rule and 제약 조건 Editor입니다.
PCB Rule and Constraints Editor 는 PCB Editor에서 제약 조건을 정의하기 위해 처음 개발된 인터페이스입니다. PCB Rule and Constraints Editor 를 사용하는 경우 설계자는 what objects the constraint (rule) applies to 및 how those objects are to be constrained을 정의합니다. 이 방식은 설계자가 제약 조건을 적용할 객체를 정확하게 지정할 수 있다는 점에서 강력합니다. 모든 객체(예: 모든 Net)에 적용하거나 보드의 특정 객체(예: 특정 Pad)만 정밀하게 지정할 수 있습니다. 이처럼 설계 객체를 유연하게 지정하는 방식은 쿼리 언어를 기반으로 구동되는 Rule 엔진을 통해 구현됩니다.
Constraint Manager는 제약 조건 정의 작업에 객체 중심 접근 방식을 도입합니다. 설계자는 스프레드시트와 유사한 인터페이스에서 객체를 중심으로 작업하며 설계에 필요한 다양한 전기적 및 Physical 제약 조건을 적용합니다. Constraint Manager에서 객체를 선택하면 그래픽 Editor에서 해당 객체가 강조 표시됩니다. 이를 통해 설계자는 객체의 모든 요구 사항을 쉽게 구성하고 검토할 수 있습니다. 예를 들어 특정 Net 클래스를 지정된 폭과 클리어런스로, 지정된 라우팅 비아와 폴리곤 Connection 스타일을 사용하여 라우팅하도록 설정할 수 있습니다. 또한 해당 Net 클래스를 특정 레이어에서 특정 임피던스로 라우팅하도록 요구할 수도 있습니다. 이러한 객체 중심 보기는 PCB Rule and Constraints Editor에서는 제공되지 않습니다. 최종적으로 소프트웨어는 객체 중심 제약 조건을 PCB Rule and Constraints Editor에서 정의되는 것과 동일한 Rule 형식으로 변환합니다. 이를 확인하려면 PCB Editor에서 제약 조건을 연 다음 All Rules 보기로 전환하세요.
이 문서 페이지에는 PCB Rule and Constraints Editor 대화 상자와 Constraint Manager에서 각각 정의된 제약 조건 이미지가 나와 있습니다. constraint 및 rule 용어는 같은 의미로 사용됩니다.
새 Room Definition 설계 제약 조건 추가
PCB Rules and 제약 조건 Editor에서
룸을 배치하거나 생성할 때마다 연결된 Room Definition 설계 제약 조건이 자동으로 생성됩니다. 반대의 경우도 마찬가지로, 이 유형의 새 Rule을 추가하면 해당 룸 객체가 설계 공간에 나타납니다. 삭제할 때도 동일하게 적용됩니다. 그래픽 Editor에서 룸을 삭제하면 제약 조건이 자동으로 삭제되며, 설계 제약 조건을 삭제하면 그래픽 객체도 삭제됩니다.
PCB Rules and Constraint Editor에서 룸 제약 조건을 정의하는 경우 절대 원점(편집 공간의 왼쪽 아래)에서 1인치 떨어진 위치에 기본 크기 5인치 × 5인치의 룸 객체가 생성됩니다. 원점 마커는 사용자가 정의한 상대 원점을 표시하며, 상대 원점은 편집 공간의 어느 곳에나 설정할 수 있습니다.
새 룸 제약 조건을 추가하면 편집 공간에 기본 룸이 정의됩니다.
제약 조건을 추가한 후 편집 공간으로 돌아가 그래픽 방식으로 룸을 편집할 수 있습니다. 또는 PCB Rules and Constraints Editor 에서 룸 제약 조건을 편집한 다음 Define 버튼을 클릭하여 대화형으로 형상을 정의할 수 있습니다. 룸은 보드의 영역을 정의하므로, 일반적으로는 대화형으로 룸을 배치하고 설계 제약 조건이 자동으로 생성되도록 하는 방식을 사용합니다.
PCB Rules and 제약 조건 Editor에서 새 제약 조건을 추가하는 방법을 자세히 알아보세요.
제약 조건 Manager에서
Constraint Manager: 에서 새 영역 제한(룸) 제약 조건을 생성하려면 All Rules 보기로 전환하고 Placement 범주에서 Room Definition을 선택합니다. 그런 다음 아래와 같이 Advanced Rules 목록에서 마우스 오른쪽 버튼을 클릭하고 컨텍스트 메뉴에서 Add Advanced Rule을 선택합니다.
제약 조건 Manager에서 새 룸 제약 조건을 추가할 수 있습니다.
이 단계에서는 그래픽 편집 공간에 룸 객체가 아직 존재하지 않습니다. 이제 Define 버튼을 클릭하여 PCB Editor로 전환한 후 룸의 형상을 정의해야 합니다. 이 작업을 완료하면 룸 제약 조건과 룸 객체가 모두 존재하게 되며, 제약 조건을 저장할 수 있습니다.
-
룸 제약 조건을 사용하여 객체를 보드의 해당 영역 내부(또는 외부)에 배치하도록 제한하려면, 다음 단계로 Constraint Manager 하단의 Object Match 및 기타 제약 조건 설정을 구성해야 합니다. 자세한 내용은 이어지는 설명을 참조하세요.
-
룸 제약 조건을 라우팅 폭과 같은 다른 유형의 제약 조건에서 영역 정의로 사용하려면 룸 내 제약 조건 정의 섹션을 참조하세요.
제약 조건 Manager에서 새 제약 조건을 추가하는 방법을 자세히 알아보세요.
룸 제약 조건이란?
앞서 설명한 대로 룸은 PCB 표면 레이어 중 하나에 정의된 영역으로, 보드의 해당 영역 내 설계 요구 사항을 정의하는 데 사용됩니다.
모든 설계 제약 조건에는 두 가지 핵심 요소가 있습니다.
-
what objects this constraint applies to 및
-
how those objects are to be constrained
컴포넌트가 없는 보드 영역에 룸 제약 조건을 정의하면 Object Match 기준(the objects this constraint applies to)은 기본적으로 False로 설정됩니다. 이는 이 제약 조건이 어떤 객체에도 적용되지 않음을 의미합니다. 필요에 따라 수정하세요.
새로 생성된 룸 정의입니다. Rule 적용 범위가 False이므로 어떤 객체에도 적용되지 않습니다.
컴포넌트 클래스에 제약 조건 적용하기
룸 제약 조건의 일반적인 용도는 컴포넌트 클래스의 위치를 정의하여 해당 클래스의 컴포넌트를 보드의 특정 영역에 고정하는 것입니다.
Encoder 클래스의 컴포넌트는 보드의 상단 레이어에 있는 Room-Encoder라는 룸 내부로 제한됩니다.
위 이미지는 PCB Rules and Constraints Editor에서 Encoder 클래스의 컴포넌트가 보드의 Top side에 있는 Room-Encoder 룸 within로 제한되는 방식을 보여줍니다(Constraint Manager
에서도 기본적으로 동일합니다). 컴포넌트를 룸에 할당하면 룸을 이동할 때 컴포넌트도 함께 이동합니다. 컴포넌트를 이동하지 않고 룸만 이동하려면 연결된 Room Definition Rule을 일시적으로 비활성화하십시오.
Room Definition 설계 제약 조건에 대해 자세히 알아보십시오.
PCB Editor에는 룸 작업을 위한 강력한 도구가 다양하게 포함되어 있습니다. 자세한 내용은 이 페이지의 룸 작업하기 섹션을 참조하십시오.
룸은 그 자체로 설계 제약 조건(Room Definition)이기도 하지만, Width, 클리어런스 또는 Via Style과 같은 다른 설계 제약 조건의 적용 범위를 보드의 특정 영역으로 한정하는 객체로도 사용할 수 있습니다. 이 내용은 이 페이지의 룸 내부의 제약 조건 정의하기 섹션에서 다룹니다.
Schematic에서 PCB로 설계 동기화 시 생성
설계를 Schematic에서 PCB로 전송할 때 각 Schematic 시트의 컴포넌트를 포함하는 룸을 생성하도록 선택할 수 있습니다. 다단계 계층형 설계에서는 활용도가 낮을 수 있지만, 규모가 큰 평면형 설계에서는 시트별 룸이 있으면 보드에 컴포넌트를 배치할 때 도움이 됩니다.
Project Options 대화 상자의 Class Generation 탭에는 설계의 각 시트에 대해 룸을 생성하는 옵션이 포함되어 있습니다 Generate Rooms 옵션을 선택하면 Design » Update 명령을 실행할 때 해당 시트의 룸이 생성되고, 해당 시트의 모든 컴포넌트로 구성된 클래스가 그 룸에 할당됩니다. 각 시트의 컴포넌트는 컴포넌트 클래스에 추가되므로, Generate Rooms 옵션을 사용하려면 해당하는 Component Class 옵션도 활성화해야 합니다.
PCB에서는 각 룸 제약 조건의 적용 범위가 InComponentClass('<SheetSymbolDesignator>')로 설정되어 생성됩니다. 시트에 컴포넌트가 없으면 룸은 생성되지 않습니다. Schematic을 PCB로 처음 전송할 때 각 컴포넌트 클래스의 컴포넌트가 한 줄로 정렬된 다음, 아래 이미지와 같이 해당 컴포넌트 클래스를 둘러싸는 룸이 생성됩니다.
자동으로 생성되는 룸이 필요하지 않으면 Project Options 대화 상자에서 Generate Rooms 체크박스를 선택 해제하십시오.
초기 설계 동기화 후의 PCB — 각 시트에 대한 룸이 생성되고, 해당 시트의 컴포넌트 클래스가 룸에 할당되어 있습니다.
Schematic 프로젝트에서 룸, 컴포넌트 클래스 및 Net 클래스를 자동으로 생성하기에 대해 자세히 알아보십시오.
설계 동기화에 대한 자세한 내용은 Schematic과 PCB의 동기화 유지하기 페이지를 참조하십시오.
선택한 Track 및 Arc로 생성
선택한 Track 및/또는 Arc 객체로 이루어진 닫힌 경계를 사용하여 룸 객체를 정의할 수 있습니다. 이렇게 하려면 설계 공간에서 닫힌 경계를 구성하는 모든 Track 및 Arc 프리미티브를 선택하고 주 메뉴에서 Tools » Convert » Create Room from Selected Primitives 명령을 선택하십시오. 아래 슬라이드쇼는 해당 절차를 보여줍니다.
|
Encoder 컴포넌트에 사용할 수 있는 보드 영역을 정의하기 위해 기계 레이어에 Track을 배치했습니다. Tools » Convert » Create Room from Selected Primitives 명령을 실행하여 동일한 형상의 Room Definition을 생성합니다. 제약 조건의 매개변수를 정의할 수 있도록 Edit Room Definition 대화 상자가 나타납니다. 이 룸에 룸의 형상을 조정하려면 클릭하여 룸을 선택한 다음 Design » Rooms » Edit Polygonal Verticies 명령을 실행하고, 꼭짓점이나 모서리를 클릭하여 룸의 형상을 변경합니다. |
룸 편집하기
룸의 X-Y 형상과 보드상의 위치는 대화형으로 수정할 수 있습니다. 룸을 대화형으로 편집하는 방법에는 두 가지가 있습니다. 선택 사각형을 기준으로 편집하는 방법(크기 및 위치 변경하기 섹션 참조)과 형상 편집 꼭짓점을 기준으로 편집하는 방법(형상 변경하기 섹션 참조)입니다.
Design » Rooms 하위 메뉴에서 명령에 접근할 수 있을 뿐만 아니라, 배치된 룸을 마우스 오른쪽 버튼으로 클릭하고 Room Actions 하위 메뉴를 선택하여 상황에 맞는 룸 명령에 접근할 수도 있습니다.
룸을 마우스 오른쪽 버튼으로 클릭하면 룸 전용 명령에 접근할 수 있습니다.
크기 및 위치 변경하기
룸을 한 번 클릭하여 선택하면, 룸이 처음에 직사각형으로 배치되었든 다각형으로 배치되었든 관계없이 다음 편집 핸들을 사용할 수 있습니다.
룸을 클릭하여 선택하면 편집 핸들이 나타납니다.
룸 크기 변경
-
모서리 핸들(A)을 드래그하면 룸의 가로와 세로 크기가 동시에 조정됩니다.
-
가장자리 핸들(B)을 드래그하면 해당 방향(가로 또는 세로)으로 객체의 크기가 조정됩니다.
-
드래그하는 동안 다음 키를 눌러 룸을 회전하거나 뒤집을 수 있습니다.
-
Spacebar 키를 누르면 객체가 시계 반대 방향으로 회전하고, Shift+Spacebar 키를 누르면 시계 방향으로 회전합니다. 회전은 Preferences 대화 상자의 PCB Editor - General 페이지에 정의된 Rotation Step 값에 따라 이루어집니다.
-
X 또는 Y 키를 누르면 객체가 X축 또는 Y축을 기준으로 뒤집힙니다.
-
L 키를 누르면 객체가 보드 반대쪽 면으로 뒤집힙니다. 룸에 연결된 컴포넌트가 있으면 해당 컴포넌트도 룸과 함께 뒤집힙니다.
-
룸 이동
룸을 클릭한 채 드래그하여 새 위치로 이동합니다. 메인 메뉴의 Design » Rooms » Move Room 명령이나 룸의 컨텍스트 메뉴에 있는 Room Actions » Move Room 명령을 사용하여 룸 객체를 이동할 수도 있습니다. 명령을 실행하면 커서가 십자선으로 바뀌고 룸 이동 모드로 전환됩니다. 이동할 룸을 클릭하십시오.
룸을 이동하기 위해 클릭하면 다음과 같이 동작합니다.
-
룸이 커서에 붙습니다. 룸을 잡는 지점은 현재 Object Snap Options에 따라 달라지며, 커서는 활성화된 Snap 지점(컴포넌트 Pad, 컴포넌트 기준점 또는 룸 꼭짓점) 중 가장 가까운 지점에 맞춰집니다.
-
룸을 원하는 위치로 이동한 다음 클릭하거나 Enter 키를 눌러 배치를 완료합니다.
-
다른 룸을 계속 이동하거나 마우스 오른쪽 버튼을 클릭하거나 Esc 키를 눌러 종료합니다.
-
이동 중인 룸에 컴포넌트가 있으면 이동하는 동안 Shift 또는 Ctrl 키를 눌러 녹색 동적 정렬 안내선을 표시할 수 있습니다. 활성 Grid에 계속 맞추려면 Shift 키를 사용하고, Grid를 일시적으로 무시하고 기존의 Grid 밖 객체에 정렬하려면 Ctrl 키를 사용합니다.
-
룸에 Net이 없는 객체 또는 잠긴 객체가 있으면 Room containing No Net/Locked Objects 대화 상자가 열립니다. 이 대화 상자에서 해당 객체를 룸과 함께 이동할지 결정한 다음 OK을 클릭합니다. 이 대화 상자가 나타나려면 Preferences 대화 상자의 PCB Editor - General 페이지에서 Ask when moving rooms containing No Net/Locked Objects 옵션이 활성화되어 있어야 합니다.

Room containing No Net / Locked Objects 대화 상자
Net이 없는 객체 / 잠긴 객체가 포함된 룸 대화 상자 |
|
| No Net Objects | Net이 없는 객체를 룸과 함께 이동하려면 활성화합니다. |
| Locked Objects | 잠긴 객체를 룸과 함께 이동하려면 활성화합니다. |
| Don't ask me about moving room's locked/no net objects until next PCB session (use currently selected settings) | 선택한 설정을 저장하고 현재 PCB 세션이 끝날 때까지 계속 사용하려면 이 옵션을 활성화합니다. 새 세션이 시작될 때까지 대화 상자가 다시 열리지 않습니다. |
형상 변경
룸의 경계 형상은 Edit Polygonal Room Vertices 명령을 실행하여 수정합니다. 이 명령은 Design » Rooms 하위 메뉴 또는 마우스 오른쪽 버튼 클릭 시 나타나는 Room Actions 컨텍스트 하위 메뉴에서 실행할 수 있습니다.
명령을 실행하면 룸의 다각형 경계에 대한 편집 핸들이 표시되며, 다음 작업을 수행할 수 있습니다.
-
A 핸들을 클릭한 다음 커서를 이동하여 해당 꼭짓점을 이동합니다. 새 위치에서 다시 클릭하여 꼭짓점을 배치합니다.
-
A 핸들을 이동하는 동안 키보드의 Delete 키를 누르면 해당 꼭짓점이 룸에서 제거됩니다.
-
B 또는 가장자리(핸들 사이)를 클릭한 다음 커서를 이동하여 해당 가장자리를 슬라이드합니다. 가장자리를 이동하는 동안 Shift+Spacebar 키를 누르면 사용 가능한 가장자리 동작 모드(가장자리 슬라이드, 가장자리 분할, 가장자리 안쪽 굽힘)가 순환 전환됩니다.
-
Ctrl+Click B 또는 가장자리를 따라 Ctrl+Click 한 다음 커서를 이동하면 해당 가장자리에 꼭짓점이 추가되면서 꼭짓점을 이동할 수 있습니다. 새 위치에서 다시 클릭하여 꼭짓점을 배치합니다. 그러면 새 꼭짓점이 A 꼭짓점이 되고, 이 꼭짓점과 원래의 A 꼭짓점 사이에 새 B 꼭짓점이 추가됩니다.
-
Grid 밖의 핸들에 접근하려면 Ctrl 키를 누른 상태로 유지하여 Grid Snap을 일시적으로 무시합니다.
-
필요에 따라 룸 형상을 계속 수정하거나, 마우스 오른쪽 버튼을 클릭하거나 Esc 키를 눌러 중지합니다. 룸 표시는 새 경계 형상에 맞게 업데이트됩니다.
이 명령은 타겟 룸의 잠금 여부와 관계없이 사용할 수 있습니다.
룸 분할
배치된 룸 객체를 그래픽 방식으로 두 개 이상의 개별 룸으로 slice하는 명령을 사용할 수 있습니다. 분할 과정은 선을 배치하는 과정과 유사하며 동일한 모서리 모드를 포함합니다(실제로 분할 객체의 너비는 현재 Default 선 너비입니다). 분할 경로를 표시하는 데 사용되는 객체는 실제로 배치되는 객체가 아니라 분할 경로를 표시하기 위한 용도로만 나타나며, 분할 과정이 완료되면 제거됩니다. 또한 룸의 가장자리에서 정확히 분할을 시작할 필요는 없습니다. 룸에서 약간 벗어난 지점에서 시작하고 끝내는 것이 더 쉽습니다.
두 가지 슬라이스 명령을 사용할 수 있습니다. 두 명령 모두 슬라이스 경로를 정의하는 과정은 같지만, 분할할 룸에 있는 컴포넌트를 처리하는 방식이 다릅니다. 각 명령의 차이점은 슬라이스 과정을 설명한 후에 다룹니다.
|
룸을 마우스 오른쪽 버튼으로 클릭하면 Room Actions 메뉴의 Slice 명령에 액세스할 수 있습니다. 아래에 설명된 과정에 따라 두 개의 슬라이스를 정의했습니다. 세 개의 룸이 생성되었습니다. |
슬라이스 과정
Slice 명령을 실행한 후:
-
커서가 십자선으로 바뀌고 슬라이스의 시작점을 선택하라는 메시지가 표시됩니다.
-
분할하려는 룸의 바로 바깥쪽에 커서를 놓고 클릭하거나 Enter 키를 누릅니다. 이제 슬라이스 모드로 전환됩니다(기본적으로 선 배치 모드).
-
커서를 룸 안으로 이동하여 첫 번째 슬라이스 모서리를 정의한 다음, 클릭하거나 Enter 키를 눌러 해당 모서리의 끝점을 고정합니다.
-
계속해서 커서를 이동하고 클릭하여 슬라이스의 모양을 결정하는 일련의 꼭짓점을 정의합니다.
-
마지막 꼭짓점을 룸 바로 바깥쪽에 배치한 후, 마우스 오른쪽 버튼을 클릭하거나 Esc 키를 눌러 해당 슬라이스 배치를 완료합니다.
-
이제 룸에 다른 슬라이스를 시작하거나, 마우스 오른쪽 버튼을 클릭하거나 Esc 키를 눌러 슬라이스 모드를 종료할 수 있습니다.
-
원래 룸이 몇 개의 룸으로 분할될지 알려주는 확인 대화 상자가 열립니다. Yes을 클릭하면 만든 슬라이스가 적용되고, No 을 클릭하면 취소됩니다. 그에 따라 새로 생성된 룸 객체가 업데이트되고, 관련 Room Definition Rule이 생성되어 연결됩니다.
-
슬라이스 작업 중 다음 키를 누릅니다:
-
Shift+Spacebar 모서리 모드를 순환하여 전환합니다.
-
Spacebar 모서리 방향을 전환합니다.
-
각 슬라이스 모서리에는 시작점과 끝점이 필요합니다.
-
슬라이스 배치 모드에 모서리가 포함되어 있으면 1 단축키를 눌러 클릭당 모서리 하나 배치와 모서리 두 개 배치 사이를 전환합니다.
-
Backspace 마지막으로 배치한 슬라이스 모서리를 제거합니다.
-
기존 룸의 경계 다시 맞추기
기존 룸의 모양을 수정하는 또 다른 방법은 해당 룸에 할당된 컴포넌트 클래스를 둘러싸도록 룸의 경계를 다시 맞추는 것입니다. 슬라이드쇼에 표시된 것처럼, 마우스 오른쪽 버튼 클릭 시 표시되는 Room Actions 하위 메뉴와 Design » Rooms 하위 메뉴에는 모두 세 가지 Wrap Room 명령이 있습니다.
|
룸 내 컴포넌트 배치를 변경한 경우 세 가지 Wrap 명령 중 하나를 사용하여 룸 모양을 업데이트합니다. Wrap Non-Orthogonal 명령은 컴포넌트 경계의 최외곽 지점을 연결하도록 룸 모서리를 배치합니다. Wrap Orthogonal 명령은 컴포넌트 경계 주위에 수직 및 수평 룸 모서리를 배치합니다. Wrap Rectangular 명령은 컴포넌트 경계를 둘러싸는 가장 작은 직사각형 룸을 배치합니다. |
Properties 패널에서 편집하기
룸 객체는 객체인 동시에 설계 제약 조건이라는 독특한 특성이 있습니다.
Properties 패널을 통한 편집
룸을 선택하면 Properties Panel에서 편집 공간 내 위치와 모양을 포함한 룸 객체의 속성을 편집할 수 있습니다. 설계 공간 오른쪽 아래의 Panels 버튼에 있는 Panels 메뉴 또는 View » Panels » Properties 명령을 통해 Panel을 표시할 수 있습니다.
Properties Panel을 사용하여 룸의 그래픽 속성을 편집할 수 있습니다.
| Name | 룸의 현재 이름(및 연결된 Room Definition Rule의 이름)입니다. 필요에 따라 변경할 수 있습니다. 이름은 각 룸을 식별하는 데 도움이 될 뿐만 아니라, Design Rule에서 특정 룸을 타겟으로 지정하는 데도 사용할 수 있습니다. |
| (X/Y) (필드 2개) | 현재 원점을 기준으로 한 룸의 첫 번째 꼭짓점의 현재 X 및 Y 위치입니다. 필드의 값을 편집하여 현재 원점에 대한 룸의 위치를 변경합니다. 값은 미터법 또는 야드파운드법으로 입력할 수 있습니다. 현재 기본 단위와 다른 단위의 값을 입력할 때는 단위를 함께 입력해야 합니다. Default 단위(미터법 또는 야드파운드법)는 상태 표시줄에 표시되며, Properties 패널의 Other 영역에서 설정합니다(설계 공간에서 선택된 객체가 없을 때). 이 값은 X/Y 옵션의 잠금이 해제된 경우에만 편집할 수 있습니다( |
Outline 꼭짓점 |
|
| Vertices Grid | 현재 룸에 정의된 모든 꼭짓점을 룸을 배치할 때 정의한 순서대로 나열합니다. 각 꼭짓점은 다음 꼭짓점과 직선 모서리로 연결됩니다. 원호로 연결하려면 필요한 Arc Angle 값을 입력합니다. 시작 꼭짓점에 해당하는 필드에 값을 입력하면 이 꼭짓점에서 목록의 바로 아래에 있는 다음 꼭짓점까지 원호가 그려집니다. 마우스 오른쪽 버튼을 클릭하여 Copy / Paste 또는 Import / Export to CSV 작업을 수행합니다. |
| Index | 꼭짓점에 할당된 인덱스입니다(편집할 수 없으며, 룸을 정의할 때 배치한 순서를 기준으로 함). |
| X | 꼭짓점의 X(수평) 좌표입니다. 클릭하여 편집합니다. |
| Y | 꼭짓점의 Y(수직) 좌표입니다. 클릭하여 편집합니다. |
| Arc Angle (Neg = CW) | 이 꼭짓점을 다음 꼭짓점에 연결하는 원호의 각도입니다. 기본적으로 직선 모서리로 연결되며 이 필드는 비어 있습니다. 클릭하여 편집한 다음 필요한 원호 각도를 입력합니다. 양수 값을 입력하면 원호가 반시계 방향으로 그려집니다. 시계 방향으로 원호를 그리려면 음수 값을 입력합니다. |
룸 작업
이 소프트웨어는 룸과 룸 내부의 객체를 다루는 데 도움이 되는 다양한 기능을 제공합니다. 여기에는 룸을 격자 패턴으로 정렬하고, 룸을 현재 스냅 격자에 맞춰 이동하고, 반복되는 회로 구간이 포함된 설계에서 한 룸의 배치 및 라우팅을 다른 룸으로 복사하는 명령이 포함됩니다.
또한 룸을 사용하여 다른 설계 제약 조건의 적용 범위를 보드의 특정 영역으로 제한할 수 있습니다. 예를 들어 이 룸 내에서는 네트를 특정 폭과 클리어런스로 라우팅하거나 차동 쌍을 특정 임피던스 프로파일로 라우팅하도록 요구할 수 있습니다.
8채널 믹서에서 첫 번째 입력 채널을 배치하고 라우팅한 다음, Copy Room Format 명령을 사용하여 나머지 7개 입력 채널에 복제했습니다.
룸 내부의 제약 조건 정의
객체가 룸 내부 또는 외부에 위치하도록 제한하는 것(룸 정의 설계 제약 조건 섹션에서 설명) 외에도, 룸을 사용하여 다른 설계 제약 조건의 적용 영역을 제한할 수 있습니다. 예를 들어 라우팅 폭 제약 조건을 통해 BGA 아래의 라우팅을 다른 폭으로 생성하도록 요구하거나, 전기적 클리어런스 제약 조건을 통해 보드의 특정 영역에 다른 클리어런스를 적용하도록 요구할 수 있습니다.
룸 정의의 설정에 따라 룸 내부의 라우팅 폭과 클리어런스가 자동으로 조정됩니다.
이는 아래 슬라이드쇼에 표시된 라우팅 폭 제약 조건과 전기적 클리어런스 제약 조건을 추가하여 구현합니다.
제약 조건 관리자에서
Constraint Manager의 All Rules 보기에서 룸 제약 조건을 추가하면 해당 룸 객체를 Physical 보기에서도 사용할 수 있게 됩니다. 이 보기를 사용하면 라우팅 폭, 전기적 클리어런스, 라우팅 비아 스타일, 차동 쌍 속성, 라우팅 넥다운, 폴리곤 연결 스타일 등 룸 내부에 적용해야 하는 영역 기반 제약 조건을 빠르게 정의할 수 있습니다. 아래 슬라이드쇼는 위 동영상에 나온 보드의 제약 조건을 보여줍니다.
|
이 룸 내부의 모든 라우팅 객체는 지정된 범위 내의 폭을 가져야 합니다. 이 룸 내부의 모든 라우팅 객체는 다른 네트에 속한 객체와 최소한 이 값 이상의 클리어런스를 유지해야 합니다. 이 룸 내부의 모든 라우팅 객체는 최소한 이 값 이상의 전기적 클리어런스를 유지해야 합니다. 이 룸 내부의 모든 Differential Pair는 |
PCB 규칙 및 제약 조건 편집기에서
PCB Rules and Constraint Editor에서 동일한 결과를 얻으려면 룸의 영역을 정의하는 쿼리를 생성합니다. 룸 내부의 객체를 감지하는 방법은 두 가지입니다. 룸 내부에 완전히 포함된 객체를 대상으로 하거나(WithinRoom 키워드 사용), 룸에 닿아 있는 객체를 대상으로 할 수 있습니다(TouchesRoom 키워드 사용). 아래 슬라이드쇼는 이전 Constraint Manager 슬라이드쇼에 나온 것과 동일한 라우팅 폭, 전기적 클리어런스, 라우팅 비아 스타일 및 차동 쌍 속성을 보여줍니다.
선택한 룸 정렬
설계 공간 내에서 선택한 룸을 정렬하려면 Design » Rooms » Arrange Rooms 명령을 사용할 수 있습니다. 필요한 룸을 선택한 다음 명령을 실행하여 Arrange Rooms 대화 상자를 엽니다.
Arrange Rooms 대화 상자.
룸의 정렬 방식과 배치 순서를 지정합니다. 또한 대화 상자에 X-Y 좌표를 입력하거나 워크스페이스에서 클릭하여 시작 위치를 지정하고, 인접한 룸 사이의 간격도 지정할 수 있습니다. OK을 클릭하면 선택한 룸이 지정된 위치로 이동합니다.
열/행 |
|
| Columns | 룸 배치에 사용할 열 수입니다. 필요에 따라 이 필드를 편집합니다. |
| Rows | 룸 배치에 사용할 행 수입니다. 필요에 따라 이 필드를 편집합니다. 사용자 지정 행 및 열 구성에 배치할 수 있는 수보다 룸이 많으면 위쪽에 행이 추가됩니다. |
정렬 기준 |
|
| SortBy | 선택한 정렬 순서, 즉 첫 번째 룸과 다음 룸을 구분하는 데 사용되는 기준을 표시합니다. 사용 가능한 옵션은 아래에 자세히 설명되어 있습니다. |
| Channel Name | 채널 이름을 기준으로 룸을 영숫자순으로 정렬합니다. 다중 채널 설계에 대해 자세히 알아보세요. |
| Room Area | 면적을 기준으로 룸을 정렬합니다. |
| Room Component Count | 룸에 포함된 컴포넌트 수를 기준으로 룸을 정렬합니다. |
| Room Width | 룸의 X(가로) 크기를 기준으로 룸을 정렬합니다. |
| Room Height | 룸의 Y(세로) 크기를 기준으로 룸을 정렬합니다. |
| Sort in Ascending order | 현재 SortBy 기준에 따라 룸을 오름차순(작은 것부터 큰 것 순)으로 정렬하려면 활성화합니다. 이 옵션을 비활성화하면 내림차순(큰 것부터 작은 것 순)으로 정렬됩니다. |
위치 |
|
| Origin X | 룸 배치를 시작할 X(가로) 위치를 정의합니다. 이 필드를 편집하여 X 좌표를 변경할 수 있으며, mm 또는 mil 단위로 지정할 수 있습니다. 숫자를 입력할 때 단위를 지정하려면 값 뒤에 mm 또는 mil 을 붙입니다. Default 단위(미터법 또는 야드파운드법)는 Properties 패널의 Units 설정에 따라 결정되며, 단위를 지정하지 않으면 이 단위가 사용됩니다. |
| Origin Y | 룸 배치를 시작할 Y(세로) 위치를 정의합니다. 이 필드를 편집하여 Y 좌표를 변경할 수 있으며, mm 또는 mil 단위로 지정할 수 있습니다. 숫자를 입력할 때 단위를 지정하려면 값 뒤에 mm 또는 mil 을 붙입니다. Default 단위(미터법 또는 야드파운드법)는 Properties 패널의 Units 설정에 따라 결정되며, 단위를 지정하지 않으면 이 단위가 사용됩니다. |
| Select Origin Using Mouse | 활성화하면 룸 배열의 원점을 수동으로 설정하라는 메시지가 표시됩니다. Origin X 및 Origin Y을 편집하려면 옵션을 비활성화해야 합니다. |
| X-Spacing | 인접한 룸 사이에 둘 X(가로) 간격을 정의합니다. |
| Y-Spacing | 인접한 룸 사이에 둘 Y(세로) 간격을 정의합니다. |
| Auto Spacing | 활성화하면 X(가로) 및 Y(세로) 간격이 동일하도록 룸을 배열합니다. X-Spacing 및 Y-Spacing을 편집하려면 옵션을 비활성화해야 합니다. |
| Place On Grid | 룸이 현재 PCB Snap Grid에 맞춰 배열되도록 강제하려면 활성화합니다. |
룸 형식 복사
룸의 가장 강력한 기능 중 하나는 한 룸의 모양, 배치 및 라우팅을 동일한 컴포넌트 세트를 포함하는 다른 룸으로 복사하는 기능입니다. 이 명령은 다중 채널 설계의 레이아웃 작업 시 특히 유용하며, 한 채널에서 수행한 배치와 라우팅을 다른 모든 채널에 적용할 수 있습니다.
룸의 형식을 다른 룸으로 복사하려면 다음을 수행합니다.
-
메인 메뉴에서 Design » Rooms » Copy Room Formats을 클릭합니다.
-
상태 표시줄에 원본 룸을 선택하라는 메시지가 표시됩니다. 원본 룸 위에 커서를 놓고 클릭하거나 Enter을 누릅니다.
-
상태 표시줄에 대상 룸을 선택하라는 메시지가 표시됩니다. 형식을 복사할 룸 위에 커서를 놓고 클릭하거나 Enter을 누릅니다. 여러 룸에 형식을 적용하려는 경우, 두 번째 클릭은 해당 룸 중 어느 룸에서나 할 수 있습니다.
-
Confirm Channel Format Copy 대화상자가 열립니다. 옵션을 사용하여 필요한 형식 복사 설정을 지정합니다. 기본적으로 선택한 Source Room에서 선택한 Destination Room으로 형식이 복사됩니다. 원본 룸에서 감지된 채널 클래스의 각 룸으로 복사하려면 Apply to Specified Channels 옵션을 활성화하고, 대상 룸에 필요한 Copy 체크박스가 선택되어 있는지 확인합니다.
-
대화상자에서 OK을 클릭하여 대상 룸을 업데이트합니다.
-
계속해서 추가 대상 룸을 선택하거나, 마우스 오른쪽 버튼을 클릭하여 종료할 수 있습니다.
룸 |
|
| Source Room | 컴포넌트 배치 및 라우팅을 복사할 원본 룸(Schematic의 채널을 나타냄)의 이름입니다. |
| Destination Room | 이 필드에는 복사한 배치 및 라우팅을 적용할 대상 룸(Schematic의 채널을 나타냄)의 이름이 표시됩니다. 프로젝트가 다중 채널 설계이고 원본 및 대상 채널이 동일한 채널 클래스의 구성원인 경우, 대화상자의 Channel Class 영역 에서 활성화된 채널에 형식 복사가 적용됩니다. 원본 채널(룸)의 형식을 다른 채널(룸)에 복사하려면 원본 채널(룸)과 대상 채널(룸)이 동일한 채널 클래스에 속해야 합니다. |
옵션 |
|
| Copy Component Placement | 원본 룸의 컴포넌트 배치를 대상 룸으로 복사합니다. |
| Copy Designator and Comment Formatting | 원본 룸의 Designator 및 Comment 형식을 대상 룸으로 복사합니다. |
| Copy Routed Nets | 원본 룸의 라우팅 레이아웃(네트 라우팅에 사용되는 트랙/호 및 비아)을 대상 룸으로 복사합니다. |
| Copy Room Size/Shape | 원본 룸의 모양을 복사하여 대상 룸에 적용합니다. 대화상자에서 Copy Room Orientation 옵션이 활성화되어 있으면 대상 룸의 시작점(왼쪽 하단)을 기준으로 모양이 변경됩니다. 즉, 대상 룸의 왼쪽 하단 점은 변경되지 않습니다. |
| Copy Room Orientation | 룸의 방향을 복사합니다. Altium Designer는 핀 수가 가장 많은 컴포넌트의 회전 각도를 기준으로 룸의 방향을 감지합니다. 핀 수가 동일하게 가장 많은 컴포넌트가 여러 개이면 면적이 가장 큰 컴포넌트를 기준으로 합니다. 이 방향 정보를 사용하여 대상 룸을 회전합니다. |
| Copy Selected Objects Only | 원본 룸에서 선택한 객체의 형식을 대상 룸으로 복사합니다. |
접촉 객체 옵션 |
|
| Copy All Objects Touching the Room | 룸에 완전히 또는 부분적으로 포함된 객체(컴포넌트 및 라우팅 트랙/아크 & 비아 제외)를 포함합니다. Region, 폴리곤, 킵아웃 등 Net 객체와 비 Net 객체를 모두 한 룸에서 다른 룸으로 복사하려면 이 옵션을 활성화해야 합니다. |
| Exclude NoNet Objects | Net이 할당되지 않은 객체를 제외합니다. |
완전히 포함된 객체만 / 포함되거나 접하는 객체 |
|
| Fully Enclosed Objects Only | Copy All Objects Touching the Room 옵션이 활성화된 경우, 완전히 포함된 객체만 복사하려면 이 옵션을 활성화합니다. |
| Enclosed & Touching Objects | Copy All Objects Touching the Room 옵션이 활성화된 경우, 포함된 객체와 접하는 객체를 모두 복사하려면 이 옵션을 활성화합니다. |
채널 간 컴포넌트 매칭 |
|
| Match Components by Channel Offsets | Schematic에서 PCB 설계로 전송할 때 반복 채널의 각 컴포넌트에 채널 오프셋이 할당됩니다. 이 채널 오프셋을 사용하여 각 채널에서 동일한 컴포넌트를 식별합니다. |
| Match Components by Source Designator | 또는 소스(Schematic) Designator를 사용하여 각 채널에서 일치하는 컴포넌트를 식별합니다. |
영향을 받는 연결 제거 |
|
| Whole connections | 채널 형식 복사가 처리된 후에는 소프트웨어에서 영향을 받는 연결을 어떻게 제거할지 알아야 합니다. 이 옵션을 선택하면 룸 내부와 외부에서 영향을 받는 연결이 제거됩니다. |
| Touching parts of connections only | 이 옵션을 선택하면 룸에 접하는 연결 중 영향을 받는 연결만 제거됩니다. |
| Contained parts of connections only | 이 옵션을 선택하면 룸 내부에서 영향을 받는 연결만 제거됩니다. |
채널 클래스 |
|
| Channel Class | 다중 채널 설계를 Schematic에서 PCB로 전송하면 반복 회로(채널)가 PCB Editor의 Object Class Explorer 대화 상자에서 채널 클래스로 식별됩니다. 이 채널 클래스는 형식 복사를 적용할 채널을 식별하는 데 사용됩니다. 대화 상자의 Channel Class Region이 비어 있으면 Object Class Explorer 대화 상자(Design » Classes)에서 채널 클래스가 올바르게 정의되어 있는지 확인하세요. 식별된 채널 클래스가 없으면 복사 명령은 소스 룸에서 대상 룸으로만 적용됩니다. |
| Channel Members | 이 목록에는 룸 이름으로 식별되는 채널이 표시됩니다. 소스 룸이 정의된 채널 클래스에 속하면 해당 클래스와 모든 멤버가 나열됩니다. 각 채널의 레이어(룸이 배치된 보드 면)와 컴포넌트 수가 표시됩니다. 각 채널에는 해당 채널에 형식 복사를 적용할지 제어하는 체크박스가 있으며, Apply To Specified Channel 옵션이 활성화되면 이 체크박스를 사용할 수 있습니다. |
| Apply To Specified Channel | Default 동작은 Source Room의 형식을 소스 룸(채널)이 속한 채널 클래스의 모든 채널에 복사하는 것입니다. 이 옵션을 활성화하면 각 채널의 Copy 체크박스를 사용할 수 있으므로, 클래스 내에서 형식 복사를 적용할 채널을 선택적으로 제어할 수 있습니다. |
룸 숨기기
뷰 Configuration Panel의 View Options 탭에 있는 옵션을 사용하여 문서 내 모든 룸을 표시하거나 숨기거나 드래프트 모드로 표시할 수 있습니다.
룸의 객체 가시성 슬라이더를 조정하여 편집 공간에서 룸을 흐리게 표시하거나 숨길 수 있습니다.
)


).
)
).
).




)
)








)