구성 요소 배치
Altium Essentials: PCB Component Placement
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
개요
- 패드와 실크스크린 요소부터 선택적인 3D 바디까지, PCB 컴포넌트 풋프린트에 무엇이 포함되는지 이해할 수 있습니다.
- Altium Designer에서 어떤 컴포넌트 속성이 배치, 방향, 레이어 할당 및 식별에 영향을 미치는지 알아볼 수 있습니다.
- PCB Editor에서 다양한 컴포넌트 유형과 면적 정의를 어떻게 처리하는지 살펴볼 수 있습니다.
PCB 설계는 배치가 90%, 라우팅이 10%라는 말이 있습니다. 각각의 비율에 대해서는 이견이 있을 수 있지만, 좋은 컴포넌트 배치가 좋은 보드 설계에 매우 중요하다는 점은 일반적으로 인정됩니다. 라우팅 중에도 배치를 조정해야 할 수 있다는 점을 기억하세요.
컴포넌트 풋프린트는 실제 컴포넌트를 인쇄 회로 기판에 실장하는 데 필요한 공간과 연결 지점을 정의합니다. 풋프린트는 패드, 선, 호 등의 단순한 기본 객체와 기타 설계 객체로 구성된 그룹 객체입니다.

컴포넌트 풋프린트는 PCB에서 컴포넌트의 실장 및 연결을 정의하며, 실제 컴포넌트를 정의하는 3D Body 객체를 포함할 수도 있습니다.
패드는 컴포넌트 핀의 실장 및 연결 지점을 제공합니다. 컴포넌트 오버레이(실크스크린) 레이어에 컴포넌트 형상의 Outline을 정의하기 위해 선과 호 같은 추가 설계 기본 객체를 포함하는 경우가 많습니다.
컴포넌트 풋프린트에는 선택적으로 3D Body 객체를 포함할 수도 있습니다. 이 객체는 보드에 실장되는 실제 컴포넌트의 물리적 공간 또는 외형 범위를 정의합니다. 실제 컴포넌트가 3D Body 객체나 가져온 STEP 모델을 사용하여 정의되어 있으면 3차원 컴포넌트 클리어런스 검사를 수행할 수 있습니다.
컴포넌트 풋프린트는 PCB 풋프린트 Editor에서 적절한 설계 객체를 배치하여 컴포넌트를 실장하고 연결하는 데 필요한 형상을 만드는 방식으로 생성합니다. 컴포넌트 기준점은 PCB 풋프린트 Editor 설계 공간의 원점이며, Editor에서 핀 1, 기하학적 중심 또는 컴포넌트의 사용자 정의 위치로 설정할 수 있습니다. 풋프린트 생성에 대한 자세한 내용은 PCB 풋프린트 생성 페이지를 참조하세요.
컴포넌트 속성

Properties Panel의 Component 모드.
일반 탭
위치
-
(X/Y)
-
X (첫 번째 필드) – 현재 설계 공간 원점을 기준으로 한 컴포넌트 기준점의 현재 X(수평) 좌표입니다. 값을 편집하여 컴포넌트의 X 위치를 변경합니다. 값은 미터법 또는 야드파운드법 단위로 입력할 수 있습니다. 현재 기본 단위가 아닌 단위의 값을 입력할 때는 단위를 함께 입력하세요. 컴포넌트 풋프린트의 기준점은 라이브러리 Editor에서 설정합니다.
-
Y (두 번째 필드) – 현재 원점을 기준으로 한 컴포넌트 기준점의 현재 Y(수직) 좌표입니다. 값을 편집하여 컴포넌트의 Y 위치를 변경합니다. 값은 미터법 또는 야드파운드법 단위로 입력할 수 있습니다. 현재 기본 단위가 아닌 단위의 값을 입력할 때는 단위를 함께 입력하세요. 컴포넌트 풋프린트의 기준점은 라이브러리 Editor에서 설정합니다.
-
-
Rotation – 0도( 3 o'clock 수평)를 기준으로 반시계 방향으로 측정한 컴포넌트의 회전 각도(도 단위)입니다. 값을 편집하여 컴포넌트의 회전을 변경합니다. 최소 각도 분해능은 0.001°입니다.
속성
-
Layer – 컴포넌트를 배치할 레이어를 설정합니다. 컴포넌트는 상단 레이어 또는 하단 레이어에 할당할 수 있습니다. 드롭다운을 사용하여 다른 레이어를 선택하세요. 레이어를 변경하면 컴포넌트의 모든 기본 객체가 각 레이어에 대응하는 반대쪽 레이어로 이동합니다. 예를 들어 상단 레이어의 컴포넌트를 하단 레이어로 이동하면 싱글 레이어 패드가 상단에서 하단 레이어로 이동하고, Top Overlay의 기본 객체는 Bottom Overlay로 재할당되며, 쌍을 이루는 기계 레이어의 기본 객체는 해당 쌍의 다른 기계 레이어로 이동합니다. 컴포넌트의 방향은 X축을 기준으로 뒤집히며, 컴포넌트 오버레이 텍스트는 아래쪽에서 읽는 방향이 됩니다.
-
Reuse Block – 컴포넌트가 재사용 블록의 일부인 경우 이 필드에는 상위 재사용 블록의 이름이 표시됩니다. Reuse Block 하이퍼링크를 클릭하면 이 재사용 블록의 속성을 볼 수 있습니다.
-
Designator – 컴포넌트의 Designator는 최대 255자의 영숫자 문자열입니다. 각 컴포넌트에는 고유한 Designator 문자열이 있어야 합니다.
또는
을 전환하여 Designator를 표시하거나 숨깁니다. Designator 하이퍼링크를 클릭하면 컴포넌트의 Designator 속성이 열립니다.
-
Comment – 컴포넌트의 Comment는 최대 255자의 영숫자 문자열입니다.
또는
를 전환하여 Comment를 표시하거나 숨깁니다. Comment 하이퍼링크를 클릭하면 컴포넌트의 Comment 속성이 열립니다.
-
Area – 배치된 컴포넌트의 면적을 현재 보드 단위로 표시합니다. 면적은 사용자가 정의할 수 있으며, 정의하지 않으면 컴포넌트의 선택 영역을 기준으로 자동 계산됩니다.
-
컴포넌트 영역을 정의하려면 PCB 풋프린트 Editor에서 풋프린트의 Properties 패널에 있는 Area을 편집합니다. 업데이트된 풋프린트를 열려 있는 PCB에 적용하려면 PCB Library 패널에서 풋프린트 이름을 마우스 오른쪽 버튼으로 클릭한 다음 컨텍스트 메뉴에서 Update PCB With <ComponentName>을 선택합니다.
-
PCB에 이미 배치된 컴포넌트를 선택한 다음 이 필드에 값을 입력하여 컴포넌트 영역을 사용자 정의할 수도 있습니다.
-
PCB에 배치된 컴포넌트의 영역을 사용자 정의 영역에서 계산된 영역으로 전환하려면 이 필드의 값을 삭제합니다. 그러면 자동으로 계산된 값이 필드에 다시 입력됩니다.
-
자동으로 계산된 영역은 컴포넌트를 클릭하여 선택할 때 강조 표시되는 영역입니다. 선택 영역은 Courtyard 레이어의 형상으로 결정됩니다. 해당 레이어가 없으면 실크스크린 레이어, 3D Body 객체 및 구리 레이어의 형상을 조합하여 결정됩니다(문자열은 제외). 아래의 위쪽 이미지들은 Courtyard 레이어에 Outline이 정의된 경우의 컴포넌트 영역을 보여주며, 아래쪽 이미지는 실크스크린 레이어, 3D Body 객체 및 구리 레이어의 형상으로 계산된 영역을 보여줍니다.
► 선택 영역이 계산되는 방식과 선택 영역을 결정하는 데 사용할 수 있는 다른 모드에 대해 자세히 알아보세요.
► 기계 레이어 작업에 대해 자세히 알아보세요.
-
-
Description – 이 컴포넌트에 대한 컴포넌트 수준의 설명입니다. 일반적으로 설명은 컴포넌트를 생성할 때 정의하지만, Schematic에 있는 컴포넌트에서도 편집하거나 추가할 수 있습니다. 이 설명은 컴포넌트 패널에 표시됩니다.
-
Type – 여기에서 컴포넌트 풋프린트에 대해 다음 컴포넌트 유형 중 하나를 선택합니다. 사용 가능한 유형은 다음과 같습니다.
-
Standard– 이 컴포넌트는 표준 전기적 속성을 가지며, Schematic과 PCB 간에 항상 동기화되고(풋프린트, 핀/Pad 및 Net 할당이 모두 일치해야 함), BOM에 포함됩니다. 저항과 같은 표준 전기 컴포넌트가 그 예입니다. -
Mechanical– 이 컴포넌트는 전기적 속성이 없고, 동기화되지 않으며(두 Editor에 각각 수동으로 배치해야 함), BOM에 포함됩니다. 방열판이 그 예입니다. -
Graphical– 이 컴포넌트는 전기적 속성이 없고, 동기화되지 않으며(두 Editor에 각각 수동으로 배치해야 함), BOM에 not 포함되지 않습니다. 회사 로고가 그 예입니다. -
Net Tie (in BOM)– 이 컴포넌트는 서로 다른 두 개 이상의 Net을 단락하는 데 사용됩니다. Schematic과 PCB 간에 항상 동기화되며(풋프린트, 핀/Pad 및 Net 할당이 모두 일치해야 함), BOM에 포함됩니다. 풋프린트 내부의 구리로 형성된 연결을 검사하지 않는다는 점에서 Standard 컴포넌트와 다릅니다. 이 구리를 통해 Net을 단락할 수 있습니다. 참고: 컴포넌트 내부에 연결되지 않은 구리가 없는지 확인하려면 Design Rule Checker 대화 상자에서 Verify Shorting Copper 옵션을 활성화하세요. -
Net Tie– 이 컴포넌트는 서로 다른 두 개 이상의 Net을 단락하는 데 사용됩니다. Schematic과 PCB 간에 항상 동기화되며(풋프린트, 핀/Pad 및 Net 할당이 모두 일치해야 함), BOM에 not 포함되지 않습니다. 풋프린트 내부의 구리로 형성된 연결을 검사하지 않는다는 점에서 Standard 컴포넌트와 다릅니다. 이 구리를 통해 Net을 단락할 수 있습니다. 참고: 컴포넌트 내부에 연결되지 않은 구리가 없는지 확인하려면 Design Rule Checker 대화 상자에서 Verify Shorting Copper 옵션을 활성화하세요. -
Standard (No BOM)– 이 컴포넌트는 표준 전기적 속성을 가지며, Schematic과 PCB 간에 항상 동기화되지만(풋프린트, 핀/Pad 및 Net 할당이 모두 일치해야 함), BOM에는 not 포함되지 않습니다. BOM에서 제외하려는 테스트포인트 컴포넌트가 그 예입니다. -
Jumper– 이 컴포넌트는 PCB 설계에 와이어 링크를 포함하는 데 사용됩니다. 예를 들어 하나의 레이어에서 배선을 모두 완료할 수 없는 단면 PCB에 사용할 수 있습니다. 이 컴포넌트 유형에서는 컴포넌트 풋프린트와 핀이 Schematic과 PCB 간에 동기화되지만 Net 할당은 동기화되지 않으며, 컴포넌트는 BOM에 포함됩니다. 컴포넌트 수준에서 이 옵션을 선택하는 것 외에도 컴포넌트의 두 Pad에 대해 JumperID를 0이 아닌 동일한 값으로 설정해야 합니다. Jumper 유형 컴포넌트는 Schematic에서 배선할 필요가 없으며, BOM에 필요한 경우에만 Schematic에 포함하면 됩니다. BOM에 필요하지 않으면 PCB에 직접 배치하고, 여기서 Component Type 및 JumperIDs 을 설정한 다음 Pad에 Nets 을 수동으로 할당할 수 있습니다.
-
-
Design Item ID – 선택한 컴포넌트의 설계 Item ID를 표시합니다. 이 필드는 편집할 수 없습니다.
-
Source – 컴포넌트의 소스 문서를 표시합니다.
을 클릭하면 다른 소스 문서를 찾아 선택할 수 있는 대화 상자가 열립니다.
-
Revision State – 워크스페이스 라이브러리 컴포넌트 리비전의 수명 주기 상태와 리비전 상태를 표시합니다. 즉, 해당 컴포넌트의 최신 릴리스 리비전(
Up to date)인지 이전 리비전(Out of date)인지 보여줍니다. -
Height – 컴포넌트의 높이 필드입니다. 이 필드는 3D Body 객체가 도입되기 전에 PCB 컴포넌트의 높이를 정의하는 데 사용되었습니다. 하지만 3D 충돌 감지 등의 작업에서는 3D 모델을 사용하는 것이 컴포넌트 높이를 정의하는 더 나은 방법입니다. Altium MCAD CoDesigner는 3D 모델의 높이가 아니라 이 Height 필드에 정의된 값을 사용한다는 점에 유의하세요(자세히 알아보기).
-
3D Body Opacity – 원하는 불투명도 백분율을 입력하거나 슬라이더 막대를 사용합니다.
-
Primitives – 연결된 잠금 아이콘을 클릭하여 잠그거나 잠금을 해제합니다.
– 컴포넌트를 하나의 객체로 취급할 수 있도록 컴포넌트의 모든 프리미티브를 잠급니다.
– 컴포넌트를 구성하는 개별 프리미티브를 수정할 수 있도록 잠금을 해제합니다. 편집 후에는 컴포넌트 프리미티브를 다시 잠가야 합니다.
-
Strings – 연결된 자물쇠 아이콘을 클릭하여 잠그거나 잠금을 해제합니다.
– 컴포넌트의 모든 문자열을 잠급니다.
– 컴포넌트의 문자열을 수정할 수 있도록 잠금을 해제합니다.
풋프린트
- Footprint Name – 선택한 컴포넌트에 해당하는 풋프린트의 이름을 표시합니다.
- Design Item ID – 선택한 컴포넌트의 식별 정보입니다.
- Source – 선택한 컴포넌트가 배치된 워크스페이스의 이름입니다.
- Description – PCB 풋프린트 편집기에서 정의된 컴포넌트 풋프린트의 설명입니다.
스와핑 옵션
- Enable Pin Swapping – 핀 스와핑 기능을 허용하려면 선택합니다.
- Enable Part Swapping – 파트 스와핑 기능(예: 74 시리즈 IC의 4개 파트)을 허용하려면 선택합니다.
Schematic 참조 정보
- Designator – 이 PCB 컴포넌트와 연결된 Schematic 컴포넌트의 Designator입니다.
- Hierarchical Path – Schematic의 계층 구조에서 이 컴포넌트가 있는 위치를 표시합니다.
- Channel Offset – 설계가 Schematic에서 PCB로 처음 전송될 때 각 Schematic 시트의 각 컴포넌트에 고유한 채널 오프셋이 부여됩니다.
파라미터 탭
- Table – 나열된 각 파라미터의 Name, Value 및 Source을 표시합니다.
컴포넌트 Designator 및 Comment
Designator 및 Comment 필드는 PCB 컴포넌트(파트)의 하위 파라미터 객체입니다. Designator는 배치된 각 파트를 고유하게 식별하여 프로젝트의 모든 PCB 문서에 배치된 다른 모든 파트와 구분하는 데 사용됩니다. Comment는 배치된 객체에 추가 정보를 제공하는 데 사용됩니다. Comment와 Designator는 모두 상위 컴포넌트 파트 객체를 배치한 후에 구성합니다. 직접 배치할 수 있는 설계 객체는 아닙니다.

배치된 Designator 객체
첫 컴포넌트의 Designator가 숫자로 끝나면 배치 중에 PCB 2D/3D 컴포넌트의 Designator가 1씩 자동 증가합니다. 배치하기 전에 속성 패널에서 첫 번째 컴포넌트의 Designator를 변경합니다.
Designator의 문자 또는 숫자를 1 이외의 간격으로 증가시키려면 Paste Array 기능을 사용합니다. 이 기능의 컨트롤은 붙여넣기 배열 설정 대화 상자에 있으며, Paste Special 대화 상자(Edit » Paste Special)에서 Paste Array 버튼을 눌러 열 수 있습니다.
그래픽 편집 방식에서는 설계 공간에서 배치된 Designator 또는 Comment 객체를 직접 선택하여 위치, 회전, 방향 및 크기를 변경할 수 있습니다.
Designator 또는 Comment 객체를 선택하면 다음 편집 핸들을 사용할 수 있습니다.

선택된 Designator
- B을 클릭하고 드래그하여 기준점 A (작은 x로 표시됨)을 중심으로 Designator/Comment를 회전합니다.
- C을 클릭하고 드래그하여 Designator/Comment 경계 상자의 크기를 수직 및 수평 방향으로 동시에 조절합니다.
- D을 클릭하고 드래그하여 Designator/Comment 경계 상자의 크기를 수직 및 수평 방향으로 각각 조절합니다.
-
편집 핸들을 제외한 Designator/Comment의 아무 곳이나 클릭한 다음 드래그하여 위치를 변경합니다. 드래그하는 동안 Comment를 회전하거나 반전할 수 있습니다.
- Spacebar을 누르면 Designator/Comment가 시계 반대 방향으로 회전하고, Shift+Spacebar을 누르면 시계 방향으로 회전합니다. 회전은 Preferences 대화 상자의 PCB Editor – 일반 페이지에 정의된 Rotation Step 값에 따라 이루어집니다.
- X 또는 Y 키를 눌러 Designator/Comment를 X축 또는 Y축을 기준으로 반전합니다.
Designator 또는 Comment 객체의 속성은 Properties 패널의 Parameter 모드에서 수정할 수 있습니다.
파라미터 속성

Properties 패널의 Parameter 모드입니다.
위치
-
(X/Y)
-
X (첫 번째 필드) - 현재 작업 공간 원점을 기준으로 한 Designator 기준점의 현재 X(수평) 좌표입니다. Designator의 X 위치를 변경하려면 편집합니다. 값은 미터법 또는 야드파운드법 단위로 입력할 수 있습니다. 현재 기본 단위와 다른 단위로 값을 입력할 때는 단위를 함께 입력해야 합니다.
-
Y (두 번째 필드) - 현재 원점을 기준으로 한 Designator 기준점의 현재 Y(수직) 좌표입니다. Designator의 Y 위치를 변경하려면 편집합니다. 값은 미터법 또는 야드파운드법 단위로 입력할 수 있습니다. 현재 기본 단위와 다른 단위로 값을 입력할 때는 단위를 함께 입력해야 합니다.
-
- Rotation - 0도(3 o'clock 수평)를 기준으로 시계 반대 방향으로 측정한 Designator의 회전 각도(도 단위)입니다. Designator의 회전을 변경하려면 편집합니다. 최소 각도 분해능은 0.001°입니다.
속성
-
Parameter type - 파라미터 유형(컴포넌트, 시트 심볼 등)과 파라미터 이름을 표시합니다.
-
Name - Designator의 이름입니다.
-
Value - 이 필드에 원하는 Designator 값을 입력합니다. 눈 아이콘을 클릭하여 설계 공간에서 값의 표시 여부를 전환합니다.
-
Layer - 드롭다운에서 원하는 레이어를 선택합니다. 필요한 경우 Mirror 을 활성화합니다.
-
Autoposition - 드롭다운에서 연결된 객체를 기준으로 원하는 자동 위치를 선택합니다.
-
Text Height - 이 필드에 원하는 텍스트 높이를 입력합니다.
-
Font Type
-
TrueType - PC의 \Windows\Fonts 폴더에 있는 글꼴을 사용하려면 선택합니다. TrueType 글꼴은 유니코드를 완벽하게 지원합니다. 기본적으로 소프트웨어는 사용된 TrueType 글꼴에 연결합니다(글꼴은 PCB 파일에 저장되지 않음). 따라서 설계를 다른 PC로 옮기면 해당 PC에도 동일한 글꼴이 있어야 합니다. 또는 Preferences 대화 상자의 PCB Editor - True Type Fonts 페이지에 있는 옵션을 사용하여 사용된 TrueType 글꼴을 PCB 파일에 포함할 수 있습니다. 이 페이지에서는 포함되지 않은 글꼴을 사용할 수 없을 때 대신 사용할 Substitution Font 도 선택할 수 있습니다.
-
Justification - 테두리 사각형 내에서 Designator의 위치를 설정합니다.
- Left - 왼쪽 버튼을 클릭하여 가로 텍스트를 왼쪽으로 정렬합니다.
- Center - 가운데 버튼을 클릭하여 가로 텍스트를 가운데로 정렬합니다.
- Right - 왼쪽 버튼을 클릭하여 가로 텍스트를 오른쪽으로 정렬합니다.
- Above - 위쪽 버튼을 클릭하여 세로 텍스트를 위쪽으로 정렬합니다.
- Middle - 가운데 버튼을 클릭하여 세로 텍스트를 가운데로 정렬합니다.
- Below - 아래쪽 버튼을 클릭하여 세로 텍스트를 아래쪽으로 정렬합니다.
-
Font - 드롭다운에서 원하는 TrueType 글꼴을 선택합니다. 필요에 따라 B (bold) 및/또는 I (italic) 옵션을 사용하여 텍스트를 강조합니다.
-
Inverted - 을 사용하면 텍스트가 반전되어 표시되며 텍스트 주위의 테두리 크기를 조절할 수 있습니다. 다음 옵션을 사용하여 텍스트를 추가로 구성할 수 있습니다.
-
Size (Width/Height) -
- Width - 테두리 사각형의 너비입니다.
- Height - 테두리 사각형의 높이입니다.
-
Size (Width/Height) -
-
Inverted - 을 사용하면 텍스트가 반전되어 표시되며 텍스트 주위의 테두리 크기를 조절할 수 있습니다. 다음 옵션을 사용하여 텍스트를 추가로 구성할 수 있습니다.
-
-
Stroke
-
Justification - 테두리 사각형 내에서 Designator의 위치를 설정합니다.
- Left - 왼쪽 버튼을 클릭하여 가로 텍스트를 왼쪽으로 정렬합니다.
- Center - 가운데 버튼을 클릭하여 가로 텍스트를 가운데로 정렬합니다.
- Right - 왼쪽 버튼을 클릭하여 가로 텍스트를 오른쪽으로 정렬합니다.
- Above - 위쪽 버튼을 클릭하여 세로 텍스트를 위쪽으로 정렬합니다.
- Middle - 가운데 버튼을 클릭하여 세로 텍스트를 가운데로 정렬합니다.
- Below - 아래쪽 버튼을 클릭하여 세로 텍스트를 아래쪽으로 정렬합니다.
-
Font - 드롭다운에서 원하는 스트로크 글꼴을 선택합니다. 선택 가능한 항목은 다음과 같습니다.
-
Default- 펜 플로팅 및 벡터 포토 플로팅용으로 설계된 단순한 벡터 글꼴입니다. -
Sans Serif- Gerber와 같은 벡터 출력 생성 속도를 느리게 하는 복잡한 글꼴입니다. -
Serif- Gerber와 같은 벡터 출력 생성 속도를 느리게 하는 복잡한 글꼴입니다.
-
- Stroke Width - 스트로크의 너비를 표시합니다.
-
Justification - 테두리 사각형 내에서 Designator의 위치를 설정합니다.
-
TrueType - PC의 \Windows\Fonts 폴더에 있는 글꼴을 사용하려면 선택합니다. TrueType 글꼴은 유니코드를 완벽하게 지원합니다. 기본적으로 소프트웨어는 사용된 TrueType 글꼴에 연결합니다(글꼴은 PCB 파일에 저장되지 않음). 따라서 설계를 다른 PC로 옮기면 해당 PC에도 동일한 글꼴이 있어야 합니다. 또는 Preferences 대화 상자의 PCB Editor - True Type Fonts 페이지에 있는 옵션을 사용하여 사용된 TrueType 글꼴을 PCB 파일에 포함할 수 있습니다. 이 페이지에서는 포함되지 않은 글꼴을 사용할 수 없을 때 대신 사용할 Substitution Font 도 선택할 수 있습니다.
-
Border Mode
-
Margin - 이 버튼을 클릭하면 Margin Border 옵션을 편집할 수 있습니다.
- Text Offset - Designator가 정렬 기준이 되는 가장자리/모서리에서 안쪽으로 떨어진 거리입니다. Center 정렬 모드를 선택한 경우 이 옵션은 적용되지 않습니다. 이 옵션은 Margin에는 사용할 수 없습니다.
-
Offset - 이 버튼을 클릭하면 Text Offset 옵션을 편집할 수 있습니다.
- Margin Border - Designator 주위의 여백 테두리 크기를 지정합니다. 이 옵션은 Offset에는 사용할 수 없습니다.
-
Margin - 이 버튼을 클릭하면 Margin Border 옵션을 편집할 수 있습니다.
PCB에서의 컴포넌트 가용성
설계를 Schematic Editor에서 PCB Editor로 전송하면 사용 가능한 라이브러리에서 PCB 컴포넌트 풋프린트가 자동으로 배치됩니다. 이를 설계 동기화라고 하며, Schematic과 PCB 간의 차이를 감지하고 해결하는 과정입니다.
Altium Designer는 PCB 설계 공간에 필요한 컴포넌트 풋프린트를 쉽게 배치할 수 있도록 다양한 도구를 지원합니다. 이러한 도구에 대한 자세한 내용은 다음 페이지를 참조하십시오.
배치된 컴포넌트 찾아보기
PCB Panel의 Components 모드에서는 세 개의 주요 영역이 현재 PCB 설계의 컴포넌트 계층 구조를 반영하도록 변경됩니다(위에서부터 순서대로).
- Component Classes
- Components 클래스 내
- Component Primitives

PCB Panel 영역에서는 컴포넌트 클래스에서 개별 컴포넌트, 컴포넌트 프리미티브까지 누적 필터 선택을 수행할 수 있습니다.
컴포넌트 또는 컴포넌트 프리미티브 항목을 마우스 오른쪽 버튼으로 클릭한 다음 Properties 명령을 선택하거나 해당 항목을 직접 두 번 클릭하면 Properties Panel이 열립니다. 이 Panel에서 필요에 따라 컴포넌트/프리미티브의 속성을 확인하거나 수정할 수 있습니다.
컴포넌트 클래스 항목을 마우스 오른쪽 버튼으로 클릭한 다음 Properties을 선택하거나 해당 항목을 직접 두 번 클릭하면 해당 클래스의 컴포넌트 클래스 편집 대화 상자가 열립니다. 이 대화 상자에서 클래스에 속한 컴포넌트를 확인하거나 수정하고, 클래스 이름을 변경하거나 클래스를 추가할 수 있습니다.
Panel의 Component Primitives 영역에 각 컴포넌트 프리미티브 유형이 표시되거나 포함되는지는 Components 또는 Component Primitives 영역에서 여는 마우스 오른쪽 버튼 메뉴에서 각 유형의 해당 옵션이 활성화되어 있는지에 따라 달라집니다.

컴포넌트 또는 컴포넌트 프리미티브 항목을 마우스 오른쪽 버튼으로 클릭하여 포함할 항목을 선택합니다.
탐색 중에 Components 영역의 Footprint 열 오른쪽에 있는 상자를 두 번 클릭하면 컴포넌트를 쉽게 잠그거나 잠금을 해제할 수 있습니다.

PCB Panel에서 잠금/잠금 해제를 수행하면 Properties Panel로 이동할 필요가 없습니다.
컴포넌트 선택 경계 상자
컴포넌트를 클릭하여 선택하면 선택 경계 상자가 나타납니다. 경계 상자를 정의하는 데 사용할 레이어를 제어하려면 고급 설정 대화 상자의 PCB.ComponentSelection 옵션을 사용할 수 있습니다. 이 옵션은 세 가지 모드를 지원합니다(0, 1 또는 2 값을 입력하며, Default 모드는 2입니다).
-
0 - legacy mode- 실크스크린의 Designator 및 Comment 문자열을 제외한 모든 레이어의 형상을 결합하는 모드입니다. -
1 - by layer mode- 아래 레이어 중 객체가 포함된 첫 번째 레이어의 형상을 다음 우선순위에 따라 사용합니다.-
Courtyard 레이어 유형
-
3D Body 레이어(STEP 모델은 해당 모델을 포함하는 최소 직육면체 크기의 3D Body 객체에 저장됩니다. 컴포넌트를 선택할 때는 STEP 모델의 형상이 아니라 이 3D Body가 사용됩니다)
-
실크스크린 레이어 및 구리 레이어
-
구리 레이어
-
-
2 - by graphic mode- Courtyard 레이어 유형, 실크스크린, 3D Body 객체 및 구리 레이어에서 감지된 형상을 결합하는 모드입니다. 문자열은 제외됩니다.
컴포넌트에 프리미티브 추가하기
메인 메뉴에서 Tools » Convert » Add Selected Primitives to Component 명령을 선택하여 선택한 프리미티브를 컴포넌트에 추가할 수 있습니다. 명령을 선택한 후, 선택한 프리미티브를 추가할 컴포넌트를 선택합니다. 확인하면 새 프리미티브가 하나의 컴포넌트 객체에 속한 요소로 인식되며, 컴포넌트의 기존 프리미티브와 함께 사용할 수 있습니다.
이 작업을 수행하려면 타겟 컴포넌트의 프리미티브 잠금이 해제되어 있어야 합니다. 컴포넌트 속성의 Primitives 잠금 아이콘을 사용하여 컴포넌트 프리미티브의 잠금을 해제하세요.
컴포넌트를 프리미티브로 분해하기
메인 메뉴의 Tools » Convert » Explode Component to Free Primitives 명령을 사용하거나, 배치된 컴포넌트 위에서 마우스 오른쪽 버튼을 클릭한 다음(선택 여부 무관) 컨텍스트 메뉴에서 Component Actions » Explode Component To Free Primitives (또는 Explode Selected Components To Free Primitives) 명령을 선택하여 컴포넌트를 구성 프리미티브 객체로 변환할 수 있습니다. 분해된 컴포넌트는 더 이상 컴포넌트가 아니므로 Designator와 Comment가 제거되고, 컴포넌트를 구성하던 다양한 프리미티브로 되돌아갑니다.
분해는 해당 소스 라이브러리에 저장된 풋프린트 모델에는 영향을 주지 않으며, PCB 문서에 배치된 컴포넌트 중 변환된 인스턴스에만 영향을 줍니다.
클릭 가능한 참조 정보 링크에 액세스하기
컴포넌트에 이름이 지정된 문서 링크가 추가되어 있으면, 선택한 컴포넌트 또는 커서 아래에 있는 컴포넌트에 대해 지정된 문서/페이지 URL을 열 수 있습니다. 이 URL은 기본 URL 링크 파라미터를 통해 지정됩니다. 이 기능을 통해 Schematic 컴포넌트에서 전송된 이름이 지정된 문서 링크를 PDF, 텍스트 파일 또는 HTML 페이지로 연결되는 이름이 지정된 PCB 컴포넌트 링크로 표시할 수 있습니다. 이는 컴포넌트의 이름이 지정된 문서 링크가 Schematic에서 PCB로 업데이트될 때 이루어집니다(Design » Update PCB Document). 이 업데이트 프로세스(ECO를 통해 수행) 중에 Schematic의 이름이 지정된 문서 링크가 해당 PCB 컴포넌트의 ComponentLink 파라미터 쌍(ComponentLinknDescription/ComponentLinknURL)으로 변환됩니다. 예:
| Schematic 컴포넌트 파라미터 | PCB 컴포넌트 파라미터 | |||
|---|---|---|---|---|
| Name | Url |
⇒ |
Name | Value |
STM32 Family Web Page |
http://www.st.com/stm32 |
ComponentLink1Description |
STM32 Family Web Page |
|
ComponentLink1URL |
http://www.st.com/stm32 |
|||
컴포넌트 파라미터에 사용되는 링크 인덱스 번호(n)는 References 하위 메뉴에서 해당 PCB 컴포넌트 링크의 순서를 결정합니다. PCB에서 컴포넌트를 선택하면 정의된 ComponentLink 파라미터 쌍이 Properties 패널의 Parameters 섹션에 표시됩니다.
명령을 실행하면 웹 기반 URL의 타겟 페이지 또는 지정된 문서가 바로 열립니다(사용 가능한 경우).



).