Creating Pad & Via Templates and Libraries
W skrócie
- Dowiedz się, jak utworzyć bibliotekę od podstaw lub na bazie padów i przelotek z istniejącej płytki PCB.
- Poznaj sposoby dodawania, usuwania i edytowania szablonów padów i przelotek.
- Zapoznaj się z opcjami konfiguracji wymiarów otworów, masek, stosów padów i przelotek oraz ustawień połączeń termicznych.
Wraz z obiektami ścieżek pola lutownicze i przelotki stanowią podstawowe elementy wszystkich projektów płytek drukowanych. Aby zwiększyć możliwości ponownego wykorzystania projektów oraz zarządzania polami lutowniczymi i przelotkami w projektach PCB, Altium Designer obsługuje biblioteki szablonów pól lutowniczych i przelotek.
Koncepcja szablonów pól lutowniczych i przelotek, które można gromadzić w bibliotece, przypomina koncepcję bibliotek footprintów PCB, choć jest nieco prostsza. Biblioteka szablonów pól lutowniczych i przelotek nie przechowuje samych pól lutowniczych ani przelotek, lecz wstępnie skonfigurowane definicje, które są stosowane do instancji pola lutowniczego lub przelotki podczas jej umieszczania. Zapisane biblioteki szablonów pól lutowniczych i przelotek można wczytywać i wykorzystywać do umieszczania instancji wstępnie zdefiniowanych pól lutowniczych i przelotek w dowolnym projekcie PCB lub footprintcie PCB.
Biblioteki szablonów pól lutowniczych i przelotek to kolejny typ dokumentu projektowego, który można tworzyć w Altium Designer. Ich pliki mają rozszerzenie *.PvLib. Biblioteki szablonów pól lutowniczych i przelotek można dołączać jako dokumenty projektu. W takim przypadku ich szablony są zawsze dostępne w danym projekcie za pośrednictwem panelu PCB Pad Via Templates. Biblioteki szablonów można również instalować w panelu, dzięki czemu będą dostępne we wszystkich otwartych projektach. Więcej informacji o udostępnianiu szablonów znajdziesz na stronie Praca z szablonami pól lutowniczych i przelotek.
Szablony pól lutowniczych i przelotek tworzy się i edytuje po otwarciu pliku PvLib. Szablony pól lutowniczych i przelotek zawarte w pliku PvLib są wyświetlane w panelu Pad Via Library, a wybrany szablon pola lutowniczego lub przelotki jest wyświetlany w edytorze szablonów pól lutowniczych i przelotek, jak pokazano poniżej.
|
Zarówno szablony pól lutowniczych, jak i przelotek edytuje się po otwarciu pliku PvLib. Opcje edytora zmieniają się w zależności od typu edytowanego obiektu. Tutaj pokazano edytor szablonów pól lutowniczych. Zarówno szablony pól lutowniczych, jak i przelotek edytuje się po otwarciu pliku PvLib. Opcje edytora zmieniają się w zależności od typu edytowanego obiektu. Tutaj pokazano edytor szablonów przelotek. |
Tworzenie biblioteki szablonów pól lutowniczych i przelotek
Nową bibliotekę szablonów pól lutowniczych i przelotek można utworzyć na następujące sposoby:
-
Wybierz polecenie File » New » Library z menu głównego, a następnie opcję Pad Via Library w sekcji File otwartego okna dialogowego New Library i kliknij Create. Nowa biblioteka szablonów pól lutowniczych i przelotek otrzyma domyślną nazwę
PvLib1.PvLib. Na tym etapie plik nie został jeszcze zapisany na dysku twardym; istnieje tylko w pamięci komputera. Ponieważ nie jest zapisany, przy pierwszym zapisie otworzy się okno dialogowe Save As z propozycją zapisania go w lokalizacji Default Location zdefiniowanej na stronie System – Domyślne lokalizacje okna dialogowego Preferences. -
Nową bibliotekę szablonów pól lutowniczych i przelotek można również dodać do bieżącego projektu, klikając projekt prawym przyciskiem myszy w panelu Projects i wybierając Add New to Project » Pad Via Library z menu kontekstowego. Plik pojawi się w folderze
Libraries/Pad Via Library Documentsw strukturze projektu. Podczas zapisywania pliku domyślną lokalizacją będzie folder projektu. -
Bibliotekę szablonów pól lutowniczych i przelotek można utworzyć na podstawie pól lutowniczych i przelotek na otwartej płytce PCB w trybie Pad & Via Templates panelu PCB. Korzystając ze standardowych metod zaznaczania w systemie Windows, zaznacz szablony pól lutowniczych i przelotek, które mają zostać zapisane w bibliotece, a następnie kliknij przycisk Save as Library. Nowy plik PvLib otworzy się i będzie gotowy do edycji, ale nie będzie jeszcze zapisany na dysku twardym. Zapisz plik w odpowiedniej lokalizacji, nadając mu wybraną nazwę. Przy pierwszym otwarciu biblioteki szablonów pól lutowniczych i przelotek w edytorze szablonów w panelu Pad Via Library może być widoczny tylko jeden szablon pola lutowniczego (szablon domyślny). W takim przypadku zapisz, zamknij i ponownie otwórz plik, aby odświeżyć listę szablonów w panelu Pad Via Library.

Bibliotekę szablonów pól lutowniczych i przelotek można utworzyć na podstawie zaznaczonych pól lutowniczych i przelotek na bieżącej płytce PCB.
Panel biblioteki pól lutowniczych i przelotek
Panel Pad Via Library zapewnia dostęp do szablonów zawartych w aktywnej bibliotece pól lutowniczych i przelotek. Panel Pad Via Library dostępny w edytorze szablonów pól lutowniczych i przelotek zawiera listę szablonów pól lutowniczych i przelotek znajdujących się w bieżącej bibliotece szablonów pól lutowniczych i przelotek. Preferowane jednostki dla bieżącej sesji edycji wybiera się z menu rozwijanego Display Units u góry panelu.
Dostęp do panelu
Panel można otworzyć z poziomu edytora szablonów pól lutowniczych i przelotek (gdy dokument *.PvLib jest otwarty jako aktywny dokument w obszarze projektowym) na następujące sposoby:
- Kliknij przycisk Panels w prawym dolnym rogu obszaru projektowego, a następnie wybierz Pad Via Library.
- Wybierz View » Panels » Pad Via Library z menu głównego.
Tworzenie szablonu pola lutowniczego lub przelotki
Aby utworzyć nowy szablon pola lutowniczego lub przelotki, kliknij prawym przyciskiem myszy wewnątrz panelu, a następnie wybierz Add Pad template lub Add Via template z menu kontekstowego. Użyj Delete, aby usunąć szablon z biblioteki.

Panel zapewnia dostęp do szablonów zawartych w bieżącej bibliotece pól lutowniczych i przelotek. Kliknij prawym przyciskiem myszy, aby dodać nowy szablon.
Edytor szablonów pól lutowniczych i przelotek
Pad Template Editor służy do konfigurowania podstawowych opcji szablonu pola lutowniczego lub przelotki, który można następnie zastosować do pola lutowniczego lub przelotki w dokumencie PCB lub footprintu PCB. Obejmują one główne właściwości konfiguracji pola lutowniczego lub przelotki, natomiast właściwości zależne od dokumentu (takie jak położenie, orientacja, warstwa itp.) definiuje się podczas umieszczania pola lutowniczego lub przelotki w dokumencie projektowym.

Edytor szablonów służy do konfigurowania szablonu pola lutowniczego lub przelotki aktualnie wybranego w panelu Pad Via Library.
Większość opcji konfiguracji pól lutowniczych i przelotek to standardowe, znane ustawienia pól lutowniczych i przelotek w Altium Designer (rozmiar, otwór, maska itp.). Edytor szablonów pól lutowniczych ma taki sam układ interfejsu i wiele wspólnych opcji z edytorem szablonów przelotek. Poniżej opisano poszczególne sekcje edytora szablonów, zaznaczając opcje specyficzne dla pól lutowniczych lub przelotek.
Ogólne
-
Name – domyślnie nazwa jest generowana automatycznie na podstawie atrybutów pola lutowniczego lub przelotki, zgodnie z IPC-7251/7351 Padstack naming conventions (opis tutaj). W razie potrzeby można zdefiniować nazwę ręcznie, a następnie ją usunąć, klikając przycisk
. Jeśli szablon z nazwą nadaną ręcznie został użyty w projekcie płytki, a następnie odłączony od biblioteki szablonów (co umożliwia edycję jego właściwości), nazwa nadana ręcznie zostanie zastąpiona nazwą automatyczną.
- Description – opcjonalny opis.
- Pad Type (tylko pola lutownicze) – montaż powierzchniowy lub przewlekany.
Informacje o otworze
- Hole Size – oznaczana w nazwie jako h<Value>, średnica otworu.
- Tolerance – oznaczane w nazwie jako Tol, w razie potrzeby wprowadź dodatnią i ujemną tolerancję otworu. Wprowadź N/A, jeśli nie dotyczy.
- Hole Type (tylko pola lutownicze) – okrągły, kwadratowy lub podłużny.
- Length (tylko pola lutownicze) – oznaczane przez dodanie _<Value> do rozmiaru otworu w nazwie; długość otworu kwadratowego lub podłużnego.
- Rotation (tylko pola lutownicze) – kąt obrotu otworu kwadratowego lub podłużnego.
- Plated (tylko pola lutownicze) – metalizowany lub niemetalizowany (otwór niemetalizowany jest oznaczany przez n w nazwie).
Maska pasty lutowniczej (tylko pola lutownicze)
- Manual Expansion – zaznacz to pole, aby ręcznie określić wartość rozszerzenia, która zastąpi wartość z reguły projektowej po umieszczeniu pola lutowniczego w projekcie PCB. Wartość ta jest oznaczana przez p<Value> w nazwie szablonu pola lutowniczego.
- Expansion – wartość, o jaką otwór w masce pasty lutowniczej ma zostać powiększony (wartość dodatnia) lub pomniejszony (wartość ujemna). Można ją określić jako wartość bezwzględną (mil/mm) lub procent powierzchni pola lutowniczego. Po określeniu wartości bezwzględnej po prawej stronie pola wyświetlana jest wartość procentowa i odwrotnie. Usuń zaznaczenie pola Use Paste po lewej stronie, aby wyłączyć użycie maski pasty lutowniczej dla szablonu pola lutowniczego.
Maska lutownicza
- Manual Expansion – oznaczana przez m<Value> w nazwie, gdzie m<Value> to całkowity rozmiar otworu w masce lutowniczej. Element nazwy przyjmuje postać m<Value>mx<Value>, jeśli wartości rozszerzenia dla warstwy górnej i dolnej nie są powiązane.
- Top/Bottom – wartość rozszerzenia mierzona od krawędzi pola lutowniczego/przelotki, chyba że włączono opcję Solder mask from the hole edge.
-
– wartości dla warstwy górnej i dolnej są powiązane (identyczne); kliknij, aby określić różne wartości dla tych warstw.
- Tented – włącz, aby zamknąć otwór w masce lutowniczej (rozmiar otworu zostanie ustawiony na zero).
- Solder mask from the hole edge – włącz, aby wartość rozszerzenia była mierzona od krawędzi otworu zamiast od krawędzi pola lutowniczego/przelotki.
Typy i cechy przelotek (tylko przelotki)
- IPC 4761 Via Type – użyj listy rozwijanej, aby wybrać typ przelotki zgodnie z normą IPC 4761, Design Guide for Protection of Printed Board Via Structures.
-
Grid – pojawia się, gdy na liście rozwijanej IPC 4761 Via Type wybrano typ przelotki inny niż
None. Wybierz Side płytki i wpisz Material dla cech dostępnych dla wybranego typu przelotki.
Rozmiar i kształt
- Offset From Hole Center (X/Y) (tylko pola lutownicze) – oznaczane przez o<Xvalue>_<Yvalue> w nazwie; wartość przesunięcia otworu względem środka pola lutowniczego.
-
Mode – typ stosu pola lutowniczego/przelotki; dostępne opcje to
Simple,Top-Middle-BottomlubFull Stack(w przypadku pól lutowniczych opcja ta jest dostępna tylko wtedy, gdy Pad Type ma wartość Otwór przelotowy). Umożliwia nadanie polom lutowniczym/przelotkom różnych właściwości rozmiaru i kształtu na warstwach dostępnych w danym trybie. Element nazwy x<Xvalue_Yvalue> jest dodawany, gdy dla warstwy dolnej określono inny rozmiar lub kształt. Element nazwy z<Xvalue_Yvalue> jest dodawany, gdy dla warstw wewnętrznych określono inny rozmiar lub kształt. -
Attributes on Layer – standardowe atrybuty pola lutowniczego/przelotki.
-
Shape (tylko pola lutownicze) – oznaczane przez c<SizeValue> (okrągłe); s<SizeValue> (kwadratowe) lub r<xSizeValue_ySizeValue> (prostokątne), w zależności od tego, czy wymiary X/Y są takie same, czy różne; s<SizeValue>c<Value> (ośmiokątne); s<Sizevalue>r<Radius%Value> lub r<xSizeValue_ySizeValue>r<Radius%Value> (prostokątne z zaokrąglonymi narożnikami).
-
X & Y Size (tylko pola lutownicze) – wymiary pola lutowniczego w płaszczyźnie X i Y.
-
Corner Radius (tylko pola lutownicze) – bezwzględna wartość promienia narożnika pola lutowniczego. Wartość musi być mniejsza lub równa połowie długości najkrótszego boku pola lutowniczego. Wprowadź wartość, a po niej symbol
%, aby określić promień jako procent połowy długości najkrótszego boku pola lutowniczego; wartość100%powoduje całkowite zaokrąglenie najkrótszego boku. Opcja ta jest dostępna tylko wtedy, gdy dla właściwości Shape pola lutowniczego wybrano Rounded Rectangle. -
Diameter (tylko przelotki) – średnica przelotki (przelotki mogą być wyłącznie okrągłe).
-
-
Thermal Relief – ustawienia połączenia termicznego tego pola lutowniczego z otaczającym je poligonem należącym do tej samej sieci; usuń zaznaczenie pola From Rule, aby edytować i stosować te ustawienia lokalne.
- From Rule – gdy ta opcja jest włączona, ustawienia lokalne nie są stosowane; wyłącz ją, aby określić i stosować ustawienia lokalne.
- Connect Style – styl połączenia termicznego.
- Air Gap – odległość od krawędzi pola lutowniczego do otaczającego poligonu.
- Conductors – liczba przewodników łączących pole lutownicze z otaczającym poligonem.
- Width – szerokość przewodników łączących pole lutownicze z otaczającym poligonem.
- Angle – układ kątowy przewodników połączenia termicznego.
- Layer – warstwy w tym stosie pola lutowniczego/przelotki; dostępne warstwy zależą od bieżącego ustawienia Mode; kliknij prawym przyciskiem myszy, aby dodać, usunąć lub zresetować warstwy, gdy Mode ma wartość Pełny stos.


