Building & Maintaining Your Components and Libraries
Projekt elektroniczny to zbiór połączonych komponentów. Satysfakcjonującą częścią rozwoju produktu jest wymyślanie ciekawych sposobów rozwiązywania wyzwań inżynierskich i łączenia tych komponentów w unikalny projekt.
Jednak znaczną część pracy — dla wielu projektantów tę bardziej żmudną — stanowi tworzenie komponentów. Choć może to nie być ekscytujące, komponenty stają się cennym zasobem firmy, dlatego muszą dokładnie odwzorowywać rzeczywiste elementy.
Element, który kupujesz i lutujesz na płytce lub wykorzystujesz w wiązce przewodów, jest elementem rzeczywistym, ale trzeba go odwzorować w każdej dziedzinie projektowania elektronicznego, w której ma być używany.
W zależności od planowanego sposobu realizacji projektu komponent może zawierać symbol do schematu, model symulacyjny do symulatora obwodów, model IBIS do analizy integralności sygnałów, wzorzec lub footprint do projektowania PCB oraz model 3D do wizualizacji, sprawdzania odstępów w 3D i eksportu do środowiska mechanicznego CAD.
Zarządzanie komponentami
Skuteczne zarządzanie danymi komponentów jest niezbędne w projektowaniu elektroniki, a zarządzanie komponentami używanymi w projekcie zawsze było podstawowym elementem oprogramowania projektowego Altium. Wraz z rozwojem oprogramowania na przestrzeni lat metody zarządzania komponentami przeszły długą drogę: od prostych, oddzielnych bibliotek modeli schematowych i PCB, przez biblioteki bazodanowe, po komponenty obszaru roboczego, które umożliwiają wykorzystanie reprezentacji komponentów projektowych w szerszym procesie rozwoju produktu, a jednocześnie oferują nowoczesne i łatwe w użyciu funkcje zapewniające wyjątkowe możliwości współpracy w całym procesie projektowania.
| Biblioteka obszaru roboczego | Komponenty przechowywane w połączonym obszarze roboczym, który zapewnia całemu zespołowi projektowemu jedno źródło aktualnych i ustandaryzowanych danych komponentów. Wyszukiwanie parametryczne i fasetowe pozwala sprawnie i szybko znajdować oraz umieszczać potrzebne elementy. Komponenty te są ściśle powiązane z rzeczywistymi, produkowanymi elementami oraz danymi dotyczącymi łańcucha dostaw, dostępnymi już podczas projektowania, co znacznie ogranicza koszty i czas zaopatrzenia na etapie produkcji i montażu produktu. |
|
| Biblioteka bazodanowa | Chcesz ściśle powiązać komponenty projektowe z firmową bazą danych? Zapoznaj się z bibliotekami bazodanowymi. Każdy rekord to komponent zawierający odwołania do wymaganych modeli i danych parametrycznych komponentu. Łącza do modeli oraz parametry są dodawane do symbolu podczas jego umieszczania, przekształcając go w komponent Altium Designer. | |
| Biblioteka bazodanowa SVN | Biblioteka bazodanowa SVN jest rozszerzeniem modelu biblioteki bazodanowej, z tą różnicą, że symbol źródłowy i modele są objęte kontrolą wersji. Biblioteki źródłowe są tworzone, uzupełniane i utrzymywane w repozytorium opartym na systemie Subversion. Łącze do repozytorium oraz do zewnętrznej bazy danych jest zdefiniowane w pliku biblioteki bazodanowej SVN (*.SVNDbLib). |
|
| Łącze do bazy danych | W tej metodzie plik łącza do bazy danych (*.DbLink) definiuje powiązanie między komponentem schematu a pasującym rekordem w bazie danych. Dopasowanie rekordu odbywa się przez powiązanie pól kluczowych: pojedynczego pola (na przykład numeru części) lub wielu pól (przez zdefiniowanie klauzuli WHERE). |
|
| Biblioteka zintegrowana | Wolisz mieć komponenty przygotowane i zweryfikowane w jednym pliku? Skompiluj źródłowe modele schematowe, PCB i symulacyjne, aby wygenerować bibliotekę zintegrowaną (*.IntLib). |
|
| Biblioteka schematowa | Biblioteka schematowa (*.SchLib) może być biblioteką modeli przechowującą symbole komponentów. Jeśli do każdego symbolu zostaną dodane łącza do modeli i dane parametryczne, staje się biblioteką komponentów. |
|
| Biblioteka PCB | Biblioteka do przechowywania modeli footprintów PCB (*.PcbLib). W razie potrzeby do każdego footprintu można dodać model 3D. Modele 3D są tworzone z obiektów brył 3D lub z modelu STEP zaimportowanego do obiektu bryły 3D. |
Biblioteka obszaru roboczego
Komponenty są przechowywane w Twoim obszarze roboczym — jednym centralnym, bezpiecznym miejscu na wszystkie dane projektowe, dostępnym dla całego zespołu projektowego. Korzystanie z komponentów przechowywanych w obszarze roboczym przynosi wiele korzyści. Oto niektóre z nich:
-
Single source of component data – dzięki obszarowi roboczemu dostępnemu dla całego zespołu inżynierowie mogą pobierać aktualne i ustandaryzowane komponenty z jednego bezpiecznego miejsca, uzyskiwać dane o łańcuchu dostaw w czasie rzeczywistym oraz korzystać z wyszukiwania parametrycznego i fasetowego, aby znaleźć dokładnie te komponenty, których potrzebują.
-
Design-time choice of physical components – dla każdego komponentu można wybrać części producentów, które mogą zostać użyte do jego realizacji podczas montażu płytki.
-
Real-time supply-chain information – dane przekazywane ze zbiorczej bazy części Altium Parts Provider (która łączy się z aktywnymi dostawcami i gromadzi oferowane przez nich części) informują projektanta o bieżących cenach i dostępności wybranych części u wszystkich sprzedawców, którzy je oferują (zgodnie z lokalnym katalogiem części obszaru roboczego). Informacje te można dodać do komponentu w dowolnym momencie, także po zapisaniu go w obszarze roboczym — bez bezpośredniej edycji komponentu, a zatem bez wpływu na projekty, w których jest już używany — a następnie wykorzystać w zestawieniu materiałowym (BOM).
-
Concurrent editing of the library – ponieważ biblioteka obszaru roboczego jest w istocie zbiorem przechowywanych w nim elementów komponentów, wielu użytkowników może niezależnie edytować lub tworzyć nowe komponenty w tej bibliotece, bez czekania, aż inni użytkownicy zakończą swoją pracę.
-
Component Models Reuse – komponent można traktować jako „pojemnik” na wszystkie informacje parametryczne i modele dziedzinowe, w tym symbol schematowy, footprinty PCB oraz modele okablowania wiązek i modele symulacyjne. Komponent nie zawiera samych modeli dziedzinowych, lecz łącza do odpowiednich elementów modeli, które również znajdują się w obszarze roboczym. Dzięki temu jeden model dziedzinowy może być używany przez wiele komponentów. Jeśli model ulegnie zmianie, otrzymasz sugestię aktualizacji wszystkich komponentów, które go używają, co pozwala uniknąć korzystania z nieaktualnych modeli.
-
Direct Component Editing – jeśli komponent wymaga edycji, możesz otworzyć go do edycji bezpośrednio z obszaru roboczego. Tymczasowa instancja edytora komponentów umożliwia edycję wszystkich aspektów komponentu, w tym modyfikowanie powiązanych z nim modeli dziedzinowych, bez konieczności korzystania z dokumentów zapisanych w plikach.
-
Use of Component Templates – stosuj szablony oparte na parametrach i taksonomii komponentów, aby każdy nowy typ komponentu automatycznie otrzymywał właściwy zestaw parametrów zgodny z wymaganiami BOM, a także aby zautomatyzować stosowanie odpowiednich schematów nazewnictwa, rewizji i cyklu życia.
-
Component Lifecycle Validation – jeśli komponent ma status „koniec cyklu życia”, „przestarzały” lub „porzucony”, otrzymasz ostrzeżenie przed rozpoczęciem produkcji płytek, które go wykorzystują.
-
Where-used Component Traceability – można prześledzić wszystkie miejsca użycia komponentów: jeśli część stanie się przestarzała, możesz sprawdzić, w których projektach została użyta, aby ustalić, które wymagają aktualizacji. Jeśli symbol lub footprint zawiera błąd, możesz wyświetlić wszystkie komponenty, które go używają, aby je poprawić.
-
Requests of new components – inżynier może przesyłać do wyznaczonych opiekunów bibliotek zgłoszenia dotyczące nowych lub brakujących komponentów i otrzymywać powiadomienia, gdy dany komponent będzie dostępny do wykorzystania w projektach przez zgłaszającego oraz innych inżynierów w firmie.
Tworzenie nowego komponentu w bibliotece przestrzeni roboczej
Fizyczny komponent montowany na płytce lub używany do produkcji wiązki przewodów jest reprezentowany przez symbol schematowy podczas tworzenia schematu oraz przez footprint PCB podczas projektowania płytki (opcjonalnie z modelem 3D służącym do wizualizacji, sprawdzania odstępów w 3D i eksportu do mechanicznego systemu CAD). Komponent projektowy może również zawierać model symulacyjny dla symulatora obwodów oraz model IBIS do analizy integralności sygnałów. Aby powiązać komponent projektowy z szerszym procesem rozwoju produktu, można dodać do niego jeden lub więcej wariantów części.
Komponenty do projektu można tworzyć i umieszczać w bibliotece przestrzeni roboczej firmy. Umieszcza się je za pośrednictwem panelu Components, który korzysta z zaawansowanej wyszukiwarki komponentów w Altium Designer.
Nowy komponent biblioteki przestrzeni roboczej tworzy się w edytorze komponentów, w którym można ręcznie zdefiniować wszystkie dane komponentu (modele dziedzinowe, parametry, warianty części itp.) lub użyć danych pobranych z panelu Manufacturer Part Search.
Aby utworzyć nowy komponent w bibliotece przestrzeni roboczej:
-
Wybierz polecenie tworzenia komponentu. Jest ono dostępne w następujących miejscach:
-
Wybierz polecenie File » New » Component z menu głównego.
-
Wybierz File » New » Library z menu głównego, a następnie w otwartym oknie dialogowym New Library wybierz Create Library Content » Component w sekcji Workspace tego okna.
-
W panelu komponentów kliknij prawym przyciskiem myszy obszar listy komponentów i wybierz polecenie Create z menu kontekstowego.
-
-
W otwartym oknie dialogowym Create new component wybierz typ komponentu. Jeśli z wybranym typem komponentu jest powiązany szablon komponentu, jego dane zostaną użyte do wstępnego zdefiniowania komponentu.

Otwórz okno dialogowe Create new component, aby wybrać typ tworzonego komponentu. -
Po kliknięciu OK otworzy się edytor komponentów w trybie edycji pojedynczego komponentu. Udostępnia on uproszczony interfejs do definiowania i edycji pojedynczego komponentu.
-
Zdefiniuj komponent, dodając jego szczegóły w edytorze komponentów:
- W sekcji Component edytora komponentów zdefiniuj Name i Description komponentu. Te informacje są niezbędne do późniejszego wyszukiwania komponentów, gdy zechcesz użyć potrzebnego komponentu w swoim projekcie.
-
Kliknij element sterujący Advanced Settings, aby zdefiniować lub zmienić inne szczegóły komponentu, takie jak jego Id używany dla komponentu zapisanego w przestrzeni roboczej oraz Folder w docelowej przestrzeni roboczej, w której komponent zostanie zapisany.
-
W sekcji Parameters edytora komponentów zdefiniuj dodatkowe szczegóły komponentu: standardowe parametry, łącza URL do stron internetowych (na przykład witryny producenta) oraz łącza do kart katalogowych (w dowolnym formacie).
-
W sekcji Part Choices edytora komponentów określ co najmniej jeden wariant części dla komponentu – „dozwolone” części producentów, które mogą służyć jako fizyczna realizacja komponentu na zmontowanej płytce.
-
W sekcji Models edytora komponentów dodaj łącza do zapisanych (lub tworzonych na bieżąco) modeli dziedzinowych, z których ma korzystać komponent. Komponent może mieć jeden symbol schematowy oraz wiele footprintów PCB i modeli symulacyjnych albo jeden model okablowania wiązki. Komponent musi mieć co najmniej jeden model.
-
Zweryfikuj zdefiniowany komponent, aby upewnić się, że spełnia wymagania zgodnie z ustawieniami na stronie Zarządzanie danymi – sprawdzanie reguł komponentów w oknie dialogowym Preferences. Zapisz komponent lokalnie (File » Save), a następnie wybierz polecenie Tools » Component Rule Check z menu głównego. Wszelkie wykryte naruszenia zostaną wyświetlone w panelu Messages.
-
Po zdefiniowaniu komponentu wybierz polecenie File » Save to Server z menu głównego, aby zapisać komponent w przestrzeni roboczej. Pojawi się okno dialogowe Edit Revision, w którym możesz zmienić nazwę i opis oraz w razie potrzeby dodać informacje o wydaniu. Po zapisaniu edytor zostanie zamknięty.
Nowy komponent będzie można wyszukiwać i wykorzystywać za pośrednictwem panelu komponentów.
Uwagi
-
Aby utworzyć nowy komponent podobny do istniejącego komponentu w przestrzeni roboczej, możesz skopiować ten komponent. W panelu Components odszukaj odpowiedni komponent, kliknij go prawym przyciskiem myszy i wybierz polecenie Operations » Make a copy. Otworzy się edytor komponentów z komponentem wstępnie zdefiniowanym na podstawie danych wybranego komponentu.
-
Komponent można zdefiniować na podstawie danych udostępnianych przez funkcję wyszukiwania części producentów. Zacznij wpisywać tekst w polu Name i wybierz pasującą część producenta lub dodaj wariant części do definiowanego komponentu. Otworzy się okno dialogowe Użyj danych komponentu, w którym można wybrać dane do zastosowania w aktualnie tworzonym lub edytowanym komponencie: nazwę, opis, parametry, modele i karty katalogowe.

Dane komponentu można pobrać za pomocą wyszukiwania części producentów. Pokazano tu przykład uzyskania dostępu do tej funkcji przez wpisanie nazwy komponentu w polu Name i wybranie pasującej pozycji z listy podręcznej. -
Edytor komponentów może również działać w trybie zbiorczej edycji komponentów, który udostępnia interfejs do definiowania i edytowania wielu komponentów. Gdy edytor komponentów działa w trybie Single Component Editing, do trybu zbiorczej edycji można przejść, wybierając polecenie Tools » Switch to Batch Editor z menu głównego edytora.
-
Aby szybko zaimportować istniejące biblioteki plikowe i bazodanowe (SchLib, PcbLib, IntLib, DbLib, SVNDbLib) do przestrzeni roboczej, można użyć Importera bibliotek. Importer bibliotek oferuje rozwiązanie wymagające jednego kliknięcia, które automatycznie analizuje wybrane biblioteki i importuje je do przestrzeni roboczej, z którą aktualnie nawiązane jest połączenie.
-
Nowy komponent można również utworzyć, klikając prawym przyciskiem myszy wpis połączonej przestrzeni roboczej w panelu Projects i wybierając z menu polecenie Create Component.
-
Aby edytować komponent przestrzeni roboczej, kliknij prawym przyciskiem myszy jego wpis w panelu Komponenty i wybierz polecenie Edit z menu kontekstowego. Edytor komponentów otworzy się w trybie Single Component Editing, z definicją komponentu gotową do edycji. Wprowadź wymagane zmiany, a następnie zapisz definicję komponentu jako kolejną rewizję komponentu przestrzeni roboczej.
-
W ten sam sposób możesz zaznaczyć wiele komponentów w panelu Komponenty i wybrać polecenie Edit z menu kontekstowego. Jeśli zaznaczone komponenty odwołują się do tego samego szablonu komponentu, otworzy się jedna instancja edytora komponentów w trybie zbiorczej edycji komponentów. W przeciwnym razie dla każdej grupy komponentów korzystających z tego samego szablonu otworzy się osobna instancja edytora komponentów.
-
Komponenty przestrzeni roboczej otwarte do edycji są wyświetlane pod wpisem Workspace Components w panelu Projects.
Z menu kontekstowego wpisu Workspace Component, dostępnego po kliknięciu prawym przyciskiem myszy, można otworzyć komponenty w grupie, zamknąć je, zapisać lokalnie, zapisać w połączonej przestrzeni roboczej lub odrzucić zmiany (zamknąć bez wprowadzania zmian)
. Jeśli po użyciu polecenia Close All okaże się, że zmodyfikowano wiele komponentów w grupie, zostanie wyświetlone okno dialogowe potwierdzenia zapisu z opcjami odpowiednimi do pracy z elementem przestrzeni roboczej otwartym do edycji
-
Przy próbie otwarcia komponentu przestrzeni roboczej do edycji przez użytkownika mającego jedynie uprawnienia do wyświetlania edytor komponentów otworzy się i umożliwi dostęp do szczegółów komponentu, ale bez możliwości zapisania zmian w przestrzeni roboczej. W takim przypadku wpis tego komponentu w panelu Projects jest oznaczony etykietą Local Edits Only
-
Podczas zapisywania edytowanego komponentu w bibliotece przestrzeni roboczej można zachować jego bieżący stan cyklu życia. Służy do tego opcja Preserve lifecycle state (not recommended) dostępna w oknie dialogowym Edit Revision podczas ponownego zapisywania (pokaż obraz). Gdy jest włączona, nowa rewizja komponentu automatycznie otrzymuje stan cyklu życia poprzedniej rewizji. Ta możliwość jest dostępna dla użytkowników z przypisanym uprawnieniem operacyjnym Allow to skip lifecycle state change for new revisions (dowiedz się więcej o ustawianiu globalnych uprawnień operacyjnych dla przestrzeni roboczej).
Biblioteki bazodanowe
Altium Designer umożliwia umieszczanie komponentów bezpośrednio z firmowej bazy danych przez utworzenie i użycie Database Library. Komponenty umieszcza się z panelu Components, który po zainstalowaniu biblioteki bazodanowej pełni funkcję przeglądarki bazy danych.
Po umieszczeniu komponentów informacje o parametrach projektu można synchronizować między umieszczonymi komponentami a odpowiadającymi im powiązanymi rekordami w bazie danych. Można przeprowadzać pełne aktualizacje komponentów — obejmujące symbol graficzny, odwołania do modeli i parametry. Informacje o parametrach z bazy danych można również uwzględnić w końcowym zestawieniu materiałowym (BOM), gotowym do wykorzystania przy zakupie komponentów.
Przeczytaj o bibliotekach bazodanowych.
Biblioteki plikowe
Jeśli musisz przechowywać komponenty lokalnie, w swoim systemie plików, możesz zorganizować je w biblioteki plikowe.
Biblioteka plikowa w Altium Designer to dowolny zbiór modeli lub komponentów. Sposób organizacji modeli lub komponentów w bibliotekach zależy od Ciebie. Możesz uporządkować biblioteki według dostawców elementów lub pogrupować komponenty według funkcji, na przykład tworząc bibliotekę wszystkich mikrokontrolerów używanych w Twojej firmie.
Symbole schematowe komponentów tworzy się w bibliotekach schematowych (*.SchLib). Komponenty w tych bibliotekach odwołują się następnie do footprintów i innych modeli zdefiniowanych w osobnych bibliotekach footprintów (*.PcbLib) oraz plikach modeli. Jako projektant możesz umieszczać komponenty z tych oddzielnych bibliotek komponentów lub skompilować biblioteki symboli, biblioteki footprintów i pliki modeli do bibliotek zintegrowanych (*.IntLib).
Przeczytaj o plikowych bibliotekach komponentów.
Modele
Z perspektywy projektanta komponent skupia w jednym elemencie wszystkie informacje potrzebne do jego reprezentacji we wszystkich dziedzinach projektowania. W tym ujęciu można więc traktować go jako kontener.
Każdy komponent jest zbiorem powiązanych modeli i danych parametrycznych komponentu. To modele zawierają szczegółowe informacje potrzebne w każdej dziedzinie projektowania.
Można używać następujących typów modeli:
| Symbol schematowy | Symbol reprezentuje komponent na arkuszu schematu. Tworzy się go za pomocą standardowych obiektów rysunkowych, a wyprowadzenia nadają mu właściwości elektryczne. |
| Model SPICE | Symuluj zachowanie połączonych komponentów za pomocą symulatora SPICE. Modele SPICE zazwyczaj pochodzą od dostawców elementów. |
| Model integralności sygnałów | Wraz ze wzrostem szybkości przełączania elementów i układów połączenia na PCB stają się częścią obwodu. Modele IBIS opisują zachowanie wyprowadzeń, umożliwiając symulatorowi integralności sygnałów w Altium Designer analizę ścieżek. |
| Footprint PCB | Każdy komponent musi mieć zdefiniowane miejsce na PCB, w którym jest montowany i łączony z obwodem — footprint jest modelem definiującym ten obszar na PCB. Footprint PCB tworzy się z zestawu standardowych obiektów, a pola lutownicze zapewniają połączenia elektryczne. |
| Model 3D | Dzisiejsze produkty elektroniczne są kompaktowe, mają ciasno upakowane elementy i nietypowe kształty, a ich płytki PCB mogą być zaginane, aby zmieściły się w obudowie. Aby zaprojektować taki produkt, potrzebujesz możliwości modelowania PCB w 3D — pozwala to zwizualizować gotową płytkę, sprawdzić odstępy w przestrzeni 3D i przenieść płytkę z zamontowanymi komponentami do środowiska mechanicznego CAD. W tym celu potrzebny jest model 3D każdego komponentu. |
Przeczytaj o tworzeniu symboli, modeli obudów PCB, modeli symulacyjnych i modeli 3D oraz zarządzaniu nimi w przestrzeni roboczej.
Panel Components
Panel Components zapewnia w Altium Designer bezpośredni dostęp do wszystkich dostępnych komponentów, w tym komponentów z przestrzeni roboczej, bibliotek bazodanowych i bibliotek opartych na plikach.
Panel pobiera komponenty z przestrzeni roboczej oraz wszelkich otwartych lub zainstalowanych plików bibliotek. Udostępnia pełne informacje o wybranym komponencie (parametry, modele, warianty części, dane dostawców itp.), umożliwia porównywanie komponentów, a w przypadku komponentów z przestrzeni roboczej oferuje wyszukiwanie parametryczne oparte na filtrach, pozwalające określić docelowe parametry komponentu. Dzięki dynamicznym filtrom kontekstowym funkcja wyszukiwania w panelu pozwala szybko znaleźć dokładnie tę część, której potrzebujesz, w połączonej przestrzeni roboczej Twojej firmy.
Przeczytaj o panelu Components.
Panel Manufacturer Part Search
Możesz także wyszukiwać rzeczywiste części dostępne na rynku za pomocą panelu Manufacturer Part Search, który korzysta z podstawowych funkcji wyszukiwarki i widoku zastosowanych w panelu Components. Wybrana część producenta może posłużyć jako podstawa do utworzenia nowego komponentu w połączonej przestrzeni roboczej. Możesz też dodać jej parametry i karty katalogowe do umieszczonego komponentu.
Ikona
we wpisie części oznacza, że do tego komponentu przypisano modele (symbole schematowe, obudowy PCB, modele symulacyjne). Podczas tworzenia nowego komponentu na podstawie tej części producenta zostaną również pobrane jej modele. Możesz też pobrać tę część lokalnie lub umieścić ją bezpośrednio na schemacie.
Przeczytaj o panelu Manufacturer Part Search.
Co dalej?
Tworzenie symbolu schematowego
Tworzenie komponentu okablowania wiązki
Praca z szablonami i bibliotekami pól lutowniczych oraz przelotek



).
).



