Praca z parametrami obiektu projektu
W skrócie
- Dowiedz się, gdzie występują parametry w Altium Designer — na poziomie obiektów, dokumentów i projektów — oraz czym różnią się parametry systemowe od parametrów użytkownika.
- Zobacz, jak dodawać, edytować, przesuwać i blokować ciągi parametrów oraz zarządzać nimi w panelu Properties, w obszarze projektowania i podczas pracy z bibliotekami.
- Poznaj specyfikę działania parametrów komponentów, w tym oznaczeń, automatycznego pozycjonowania i specjalnych typów parametrów, takich jak łącza.
Parametry to uniwersalne ciągi tekstowe będące obiektami podrzędnymi obiektu nadrzędnego. Identyfikują obiekt nadrzędny i uzupełniają go o dodatkowe informacje. Po zaznaczeniu ich na arkuszu schematu są dostępne bezpośrednio w panelu Properties.
Na przykład parametry są szeroko stosowane w komponentach schematu. Uniwersalne parametry komponentów mogą pełnić różne funkcje, w tym przechowywać szczegółowe dane komponentu, takie jak moc, napięcie itp., dane dostawcy, w tym jego nazwę i numer części, dane projektowe komponentu bibliotecznego, takie jak numer rewizji symbolu, oraz informacje dotyczące dokumentacji, takie jak adres URL prowadzący do karty katalogowej komponentu.
Parametry można również definiować na poziomie arkusza schematu (dokumentu) i projektu. Parametry na poziomie dokumentu służą do definiowania pól takich jak tytuł i numer dokumentu, natomiast parametry na poziomie projektu idealnie nadają się do definiowania pól takich jak projektant lub nazwa projektu.
Parametry obiektów, dokumentów i projektów służą do dodawania szczegółowych informacji do projektu. Na powyższej ilustracji pokazano komponent.
Parametry są dodawane lub automatycznie uwzględniane jako właściwości obiektu nadrzędnego i nie są umieszczane niezależnie, tak jak ciągi tekstowe. Dostępne parametry można ogólnie podzielić na systemowe i użytkownika, przy czym te drugie są dodawane ręcznie.
Identyfikator i parametry systemowe
Obiekty umieszczane na schemacie automatycznie otrzymują zestaw kluczowych parametrów systemowych. Dostarczają one podstawowych informacji o obiekcie, używanych przez system do rozpoznawania nazwy, typu i źródła danych obiektu nadrzędnego. Do nieodłącznych parametrów systemowych obiektów należą między innymi właściwości Comment, Description i Design Item ID (odwołanie do biblioteki). Parametry systemowe obiektu są dostępne w sekcji General panelu Właściwości (na karcie General) po zaznaczeniu obiektu nadrzędnego Gdy pojedynczy parametr jest widoczny i zaznaczony w obszarze projektowym, można uzyskać do niego dostęp w odpowiednim trybie panelu Właściwości, jak opisano poniżej
Parametry użytkownika
Parametry można dodawać do każdego z poniższych obiektów projektowych.
| Component | Parametry zdefiniowane przez użytkownika można dodawać w obszarze Parameters panelu Właściwości po zaznaczeniu obiektu komponentu (części) lub podczas definiowania komponentu w edytorze bibliotek schematów. Parametry systemowe, takie jak oznaczenie i komentarz, są zawsze obecne w obiekcie komponentu, jak opisano powyżej. Panel Properties można otworzyć, klikając dwukrotnie obiekt lub klikając go prawym przyciskiem myszy i wybierając Properties z menu kontekstowego. Jeśli panel Properties jest już aktywny, zaznacz obiekt w obszarze projektowym. |
| Part | W obszarze Parameters panelu Properties po zaznaczeniu obiektu Część. |
| Pin | Na karcie Parameters panelu Properties po zaznaczeniu obiektu Pin w pliku *.SchLib. |
| Port | Na karcie Parameters panelu Properties po zaznaczeniu obiektu Port. |
| Sheet Symbol | Na karcie Parameters panelu Properties po zaznaczeniu obiektu Symbol arkusza. |
| Document | Na karcie Parameters panelu Właściwości w trybie Document Options (usuń zaznaczenie wszystkich obiektów schematu lub kliknij puste miejsce na arkuszu dokumentu). Nowy arkusz schematu automatycznie otrzymuje zestaw parametrów domyślnych, zgodnie z zastosowanym lub domyślnym szablonem arkusza. |
| Project | W oknie dialogowym Opcje projektu (Project » Opcje projektu). Parametry na poziomie projektu są wyświetlane i dodawane na karcie Parameters tego okna dialogowego. |
Parametry użytkownika są dostępne w obszarze Parameters panelu Properties lub modalnego okna dialogowego po zaznaczeniu obiektu nadrzędnego. Parametry można zarówno dodawać, jak i edytować. Wyjątkiem są parametry projektu (dostępne w oknie dialogowym Opcje projektu) oraz parametry pinów komponentu (dostępne w oknie Właściwości pinu lub w modalnym widoku okna dialogowego Pin ). Gdy pojedynczy parametr jest widoczny i zaznaczony w obszarze projektowym, można uzyskać do niego dostęp w odpowiednim trybie panelu Właściwości lub modalnego okna dialogowego, jak opisano poniżej.
Po pierwsze: parametry użytkownika komponentu w panelu Properties (obszar Parameters). Po drugie: pojedynczy parametr systemowy w panelu Properties.
Edycja graficzna
Widoczne ciągi tekstowe parametrów można edytować graficznie bezpośrednio w obszarze projektowym.
Kliknij i przeciągnij parametr, aby zmienić jego położenie. Aby edytować tekst parametru bezpośrednio w miejscu jego wyświetlania:
-
Przeciągnij kursor myszy wokół obiektu parametru, przytrzymując przycisk myszy.
-
Po zaznaczeniu obiekt zostanie wyróżniony zieloną ramką.
-
Wybierz
Enter, aby rozpocząć edycję tekstu. -
Po zakończeniu edycji naciśnij ponownie
Enterlub kliknij poza tekstem, aby wyjść z trybu edycji w miejscu.
Tekst parametru można zaznaczyć i edytować bezpośrednio w obszarze projektowym. Zaznacz cały tekst, aby zastąpić go nowym.
Parametry widoczne i możliwe do zaznaczenia w obszarze projektowym można przeciągać w nowe miejsce i obracać w trakcie tej czynności. Kliknij i przeciągnij tekst parametru, użyj klawiszy Spacebar i Shift+Spacebar, aby obracać go co 90°, a następnie kliknij, aby zatwierdzić nowe położenie i orientację.
Informacje o opcji Autopositioning parametru komponentu i powiązanych opcjach panelu Properties znajdziesz poniżej w sekcji Pozycjonowanie tekstu parametrów.
Zablokowane parametry
Parametr będący obiektem podrzędnym obiektu Część komponentu można zablokować, co oznacza, że jego ciągi tekstowe Name i Value nie będą edytowalne. Można to zrobić przez:
-
przełączenie ikony kłódki powiązanej z jego wpisem w obszarze Parameters panelu Properties lub modalnego okna dialogowego obiektu nadrzędnego albo
-
zaznaczenie opcji Lock Parameter w panelu Właściwości, gdy parametr jest bezpośrednio zaznaczony w obszarze projektowym.
Po zablokowaniu ciągu tekstowego parametru nie można go edytować w panelu Properties, w modalnym oknie dialogowym (w sekcji Parameters obiektu nadrzędnego) ani bezpośrednio w obszarze projektowania.
Parametry komponentów
Parametry komponentów, najbardziej oczywiste i najczęściej używane parametry schematu, obejmują dodatkowe zestawy dedykowanych parametrów i funkcji, które rozszerzają możliwości definiowania obiektów komponentów.
Definiowanie parametrów w bibliotece schematów
Parametry podrzędne nadrzędnego obiektu komponentu można zdefiniować w źródłowej bibliotece komponentów przed o umieszczeniem go na schemacie. Panel Properties służy do edytowania i dodawania parametrów do wpisu komponentu w edytorze bibliotek schematów w taki sam sposób jak podczas pracy z parametrami w edytorze schematów.
Po otwarciu dokumentu biblioteki komponentów schematowych wybierz wpis komponentu w panelu SCH Library, aby uzyskać dostęp do właściwości jego parametrów w panelu Properties.
Aby uzyskać dostęp do właściwości komponentu bibliotecznego, wybierz jego wpis w panelu SCH Library.
Oznaczenie i komentarz komponentu bibliotecznego nie są domyślnie widoczne w obszarze projektowania edytora bibliotek schematów, ale można je wyświetlić, zaznaczając opcję Show Comment/Designator w trybie Library Options panelu Properties (Tools » Document Options) — dostępnym, gdy w obszarze projektowania nie jest zaznaczony żaden obiekt.
Parametry należące do komponentu bibliotecznego definiuje się i edytuje w taki sam sposób jak parametry komponentów umieszczonych na schemacie. Klawisz Tab umożliwia tworzenie lub edytowanie parametrów na bieżąco podczas umieszczania obiektu w obszarze projektowania. Dostęp do parametrów można uzyskać za pośrednictwem panelu Properties lub modalnego okna dialogowego. Podstawowe parametry systemowe są dostępne na karcie General panelu, a parametry użytkownika dodaje się i edytuje w sekcji rozwijanej Parameters panelu.
Parametr oznaczenia
W edytorze bibliotek schematów parametrowi Designator komponentu zwykle przypisuje się odpowiedni prefiks zakończony znakiem zapytania. Po umieszczeniu komponentu z biblioteki na schemacie znak zapytania jest wykrywany przez narzędzie do numeracji edytora schematów i zastępowany odpowiednim sufiksem liczbowym podczas numeracji projektu.
Edytor schematów udostępnia również prostą funkcję automatycznego zwiększania numeru oznaczenia, której można używać podczas umieszczania wielu instancji tego samego elementu. Aby z niej skorzystać, naciśnij Tab, gdy pierwszy komponent jest dołączony do kursora, aby wstrzymać umieszczanie, a następnie wprowadź odpowiednie oznaczenie w panelu Properties, na przykład R1. Kolejne komponenty otrzymają wówczas oznaczenia R2, R3 itd.
Jeśli podczas umieszczania komponentów wieloczęściowych początkowe oznaczenie zostanie przypisane w ten sposób, sufiks części zostanie dodany automatycznie, na przykład U3A, U3B itd. Jeśli początkowe oznaczenie nie zostanie przypisane, wszystkie części będą miały ten sam sufiks. Można to skorygować za pomocą funkcji numeracji w edytorze schematów. Sufiks części może być literowy lub liczbowy, zgodnie z ustawieniem opcji Alpha Numeric Suffix na stronie Schemat — Ogólne okna dialogowego Preferences.
Pozycjonowanie ciągu tekstowego parametru
Domyślnie ciąg tekstowy parametru komponentu jest pozycjonowany automatycznie (tj. zachowuje orientację), gdy komponent jest obracany podczas umieszczania lub po nim. Jeśli takie zachowanie nie jest wymagane, wyłącz opcję Autoposition dla wpisu parametru komponentu w sekcji Parameters panelu Properties. Aby uzyskać dostęp do tej opcji, zaznacz parametr na liście, a następnie kliknij Other. Pamiętaj, że podczas umieszczania komponentu do obracania służą klawisze Spacebar i Shift+Spacebar. Umieszczony obiekt komponentu można obrócić za pomocą menu Rotation w sekcji Location panelu Properties lub zaznaczając komponent i naciskając Spacebar albo Shift+Spacebar.
Kliknij i przeciągnij widoczny parametr, aby ręcznie zmienić jego położenie na schemacie; obowiązują przy tym standardowe skróty klawiszowe zmiany orientacji. Jeśli opcja Autoposition jest wyłączona dla tego parametru and opcja Mark Manual Parameters jest włączona na stronie Schemat — Edycja graficzna okna dialogowego Preferences, ręcznie przesunięte parametry będą oznaczone kropką w lewym dolnym rogu ich ramki zaznaczenia.
Parametry komponentów o specjalnym przeznaczeniu
Parametry komponentów o specjalnym przeznaczeniu umożliwiają tworzenie odnośników do powiązanych adresów URL lub dokumentacji w plikach. Dla zaznaczonego komponentu dodaje się je, klikając Add w sekcji Parameters panelu Properties, a następnie wybierając Link z listy rozwijanej, lub na karcie Parameters w przypadku dedykowanych odnośników do pomocy, aktywowanych klawiszem F1.
Parametry odnośników
Funkcja odnośników umożliwia definiowanie i wyświetlanie nazwanych odnośników do dowolnej liczby adresów URL lub dokumentów referencyjnych.
Aby dodać odnośnik referencyjny do komponentu, zaznacz komponent w obszarze projektowania, a następnie kliknij Links w sekcji Parameters panelu Properties. Wybierz Link z menu rozwijanego Add u dołu sekcji Parameters . Wprowadź Name i Value odnośnika (docelowy adres URL lub ścieżkę do pliku) w tabeli. Odnośnik będzie następnie dostępny po kliknięciu komponentu prawym przyciskiem myszy w obszarze projektowania i wybraniu odnośnika <name> z podmenu References.
Odnośniki komponentu, widoczne w panelu i obszarze projektowania, są wewnętrznie oparte na parach nazwa/wartość w formacie ComponentLinknDescription/ComponentLinknURL (gdzie n jest numerem odnośnika na liście, zgodnym z kolejnością tworzenia). Więcej szczegółów można znaleźć we wpisie tego komponentu w edytorze tabeli parametrów.
Parametr HelpURL
Podobnie jak parametr odnośnika, parametr HelpURL umożliwia zdefiniowanie odnośnika z komponentu do dokumentu zewnętrznego, takiego jak plik PDF, lub do adresu URL strony internetowej. Po dodaniu go jako parametru komponentu odnośnik jest aktywowany po naciśnięciu klawisza F1, gdy kursor znajduje się nad komponentem na arkuszu schematu lub gdy komponent jest zaznaczony w panelu Libraries. Pamiętaj, że to działanie zastępuje standardową funkcję klawisza F1, która otwiera odpowiednią stronę dokumentacji online Altium.
Odnośnik do pomocy dodaje się jako parametr użytkownika w panelu Properties, gdy komponent jest zaznaczony w obszarze projektowania. Kliknij Parameters w sekcji Parameters panelu Properties, a następnie wybierz Parameter z menu rozwijanego Add u dołu sekcji Parameters . Wprowadź „HelpURL” jako Name parametru, a docelową ścieżkę lub adres URL jako Valueparametru.
Wartością parametru może być adres URL, bezwzględna ścieżka do dokumentu lub sama nazwa dokumentu. Po naciśnięciu klawisza F1, gdy kursor znajduje się nad umieszczonym obiektem komponentu, lub po wybraniu opcji References » Help z menu kontekstowego wyszukiwanie odwołania do pomocy przebiega następująco:
- Jeśli podano ścieżkę, wskazana lokalizacja jest przeszukiwana jako pierwsza.
-
Jeśli dokumentu nie można znaleźć w tej lokalizacji lub nie podano ścieżki, przeszukiwany jest folder
\Helpw katalogu instalacyjnym oprogramowania. - Jeśli elementem docelowym jest adres URL, strona internetowa zostanie otwarta w wewnętrznej lub zewnętrznej przeglądarce, zależnie od stanu opcji Open internet links in external Web browser na stronie System - Widok okna dialogowego Preferences.
Odwołanie pośrednie — parametr jako wartość ciągu tekstowego
Większość parametrów komponentów można wyświetlić na arkuszu schematu, włączając ikonę widoczności (jeśli jest dostępna) w panelu Properties. Parametry identyfikacyjne i systemowe są dostępne na karcie General panelu, a parametry użytkownika — w sekcji Parameters.
Innych parametrów, takich jak parametry dokumentu i projektu, nie można jednak wyświetlać bezpośrednio na arkuszu schematu. Można je natomiast wstawić do standardowego obiektu tekstowego za pomocą techniki określanej jako String Indirection. Odwołanie pośrednie polega na wpisaniu jako wartości obiektu tekstowego nazwy dostępnego parametru (np. parametru dokumentu lub projektu) poprzedzonej znakiem równości, na przykład =Title.
Oprogramowanie automatycznie wykrywa takie ciągi i sprawdza, czy istnieje dostępny parametr o nazwie zgodnej z wartością umieszczonego obiektu tekstowego. W przykładzie Title zostaje rozpoznany jako parametr dokumentu, dzięki czemu ciąg tekstowy jest interpretowany i wyświetla wartość parametru tytułu, na przykład MyDocument. Nazwę parametru można przypisać do wartości wybranego ciągu tekstowego przez edycję bezpośrednią (tj. wpisując =Title) lub, korzystając z bardziej przejrzystej metody, za pomocą menu rozwijanego Text w panelu Właściwości, które pozwala wybrać jeden z dostępnych ciągów parametrów.
Ciągi specjalne
Ciągi parametrów dostępne jako ciągi z odwołaniem pośrednim (patrz wyżej) są określane jako special strings. Wartość prezentowana przez te ciągi jest na bieżąco ustalana na podstawie szablonów lub danych systemowych i źródłowych. Na przykład ciąg specjalny =Time wykrywa i wyświetla bieżący czas systemowy, a =DocumentName wyświetla nazwę pliku bieżącego dokumentu schematu (np. MySchematic.SchDoc).
Dostępnych jest wiele predefiniowanych ciągów specjalnych. Więcej informacji o nich można znaleźć na stronie Praca z obiektami tekstowymi na schemacie. Każdy parametr dokumentu lub projektu zdefiniowany przez użytkownika również może służyć jako ciąg specjalny i być przywoływany pośrednio w ciągu tekstowym na arkuszu schematu.
Parametry mają strukturę hierarchiczną, co oznacza, że na różnych poziomach projektu można utworzyć parametry o tej samej nazwie, ale różnych wartościach. W przypadku parametru komponentu Altium Designer rozstrzyga tę kwestię według następującej kolejności:
-
Parametr komponentu (najwyższy priorytet)
-
Wariant
-
Dokument schematu
-
Symbol arkusza (aby zobaczyć wartość parametru nadrzędnego symbolu arkusza, wybierz kartę Compiled u dołu obszaru projektowego)
-
Projekt
Większość opcji i elementów sterujących w tym panelu jest intuicyjna i nie wymaga dodatkowych wyjaśnień. Poniżej opisano opcję, która wymaga omówienia.
-
Allow Synchronization with Database (tylko okno dialogowe Preferences ) — włącz, aby synchronizować z bazą danych. Ta opcja określa, czy komentarz może być aktualizowany. Domyślnie opcje te są włączone, aby zawsze umożliwiać synchronizację z biblioteką źródłową lub bazą danych. Możesz wyłączyć tę opcję, aby komentarz nie był uwzględniany w procesie aktualizacji.
Korzystanie z menedżera parametrów
Atrybuty projektowe zdefiniowane przez użytkownika dodaje się do projektu za pomocą parametrów. Parametry można dodawać i edytować pojedynczo lub użyć okna dialogowego Parameter Table Editor (Tools » Parameter Manager), aby dodawać i edytować parametry w całym projekcie lub całej bibliotece. Są to parametry należące do różnych typów obiektów w źródłowych dokumentach schematu aktywnego projektu lub do komponentów w aktywnej bibliotece. Pozwala to szybko i sprawnie zebrać wszystkie parametry w jednym miejscu do edycji, a także utworzyć zlecenie zmiany inżynieryjnej (ECO), aby wprowadzić zmiany parametrów bezpośrednio w każdym obiekcie projektowym, do którego należą.
Po otwarciu okna dialogowego zbiera ono wszystkie dane parametrów z całego projektu i przedstawia je w formie tabeli. Gdy uruchomisz je ze schematu, otworzy się okno dialogowe Parameter Editor Options. Wybierz typ parametrów, które mają zostać wczytane do okna dialogowego Parameter Table Editor. Na przykład podczas pracy z parametrami komponentów wyłącz wszystkie opcje w sekcji Include Parameters Owned By z wyjątkiem Parts. Zakres uwzględnianych obiektów można dodatkowo zawęzić za pomocą pola rozwijanego na środku okna dialogowego. Możesz uwzględnić wszystkie obiekty, tylko obiekty z istniejącymi parametrami albo tylko obiekty z istniejącymi parametrami, które są faktycznie używane.
Inny przykład: podczas pracy z parametrami dokumentu włącz tylko opcję Documents. Pamiętaj, że opcja Exclude System Parameters obejmuje między innymi ustawienia modeli komponentów, parametry dokumentu zdefiniowane w szablonie itp. Zapoznaj się z tą opcją, gdy nabierzesz większej wprawy w zarządzaniu parametrami.
Jeśli chcesz edytować parametry tylko wybranych obiektów w projekcie, zaznacz odpowiednie obiekty i włącz opcję Selected Objects Only. Uwzględnione zostaną wyłącznie zaznaczone obiekty, pod warunkiem że odpowiedni typ obiektu został włączony w sekcji Include Parameters Owned By okna dialogowego.
Po wybraniu potrzebnych opcji kliknij OK, aby otworzyć okno dialogowe Parameter Table Editor.
Większość opcji i pól w tym oknie dialogowym jest intuicyjna. Poniżej wyjaśniono te, które wymagają omówienia.
-
Remove Columns — kliknij, aby usunąć kolumny. Ta opcja jest dostępna tylko dla kolumn zawierających informacje statyczne.
-
Add Column — kliknij, aby dodać kolumnę. Otworzy się okno dialogowe Add Parameter, w którym możesz zdefiniować nazwę parametru.
-
Reset Column Order — kliknij, aby wyświetlić kolumny w kolejności alfabetycznej.
-
Accept Changes (Create ECO) — aby zastosować te zmiany do komponentów, należy wygenerować zlecenie zmiany inżynieryjnej (ECO). Kliknij, aby otworzyć okno dialogowe Engineering Change Order.
Menu kontekstowe
-
Revert — kliknij, aby cofnąć zmiany w zaznaczonych komórkach.
-
Add — kliknij, aby dodać informacje do zaznaczonej komórki. Wybierz żądane informacje z wyświetlonej listy rozwijanej.
-
Rename Column - kliknij, aby otworzyć okno dialogowe Rename Existing Parameter, w którym można zmienić nazwę istniejącego parametru.
-
Remove Columns - kliknij, aby usunąć wybraną kolumnę.
-
Report - kliknij, aby otworzyć okno dialogowe Report Preview i wygenerować raport.
-
Cross Probe - kliknij, aby zlokalizować wybrany obiekt na schemacie. Wybrany obiekt zostanie podświetlony na arkuszu schematu.
Uwagi
-
Możesz przeciągać i upuszczać kolumny w obszarze tabeli, aby zmienić kolejność ich wyświetlania. Nowa kolejność jest zapisywana w pliku projektu, dzięki czemu zostaje zachowana po ponownym otwarciu okna dialogowego.
-
Aktualizację parametrów można zablokować na następujące sposoby:
- Na poziomie parametru pojedynczego komponentu włącz opcję Lock Parameter w trybie Component panelu Properties (kliknij dwukrotnie komponent, aby uzyskać dostęp). Opcja Allow Synchronization With Database służy również do określania, czy komentarz może być aktualizowany. Domyślnie opcja ta jest włączona, aby zawsze umożliwiać synchronizację ze źródłową biblioteką lub bazą danych. Możesz wyłączyć tę opcję, aby wykluczyć komentarz z procesu aktualizacji.
- Na poziomie powiązania z bazą danych — sekcja Field Mapping odpowiedniego dokumentu powiązania z bazą danych (plik *.DbLink, *.DbLib lub *.SvnDbLib) zawiera szereg opcji określających, czy parametry mogą być aktualizowane, w tym Update Values, Add to Design i Remove from Design.
To okno dialogowe służy do dodawania, edytowania i usuwania parametrów w całym projekcie. Można w nim bezpośrednio edytować istniejące parametry projektu lub konfigurować aktualizacje parametrów z powiązanej bazy danych (połączonej za pośrednictwem pliku DbLink, DbLib lub SvnDbLib). Należy pamiętać, że te pliki powiązań z bibliotekami baz danych zawierają opcje określające, czy dany parametr ma być aktualizowany. Zmiany są następnie wprowadzane za pomocą zlecenia zmian inżynierskich (ECO), które tworzy się w tym oknie dialogowym.
Dodawanie parametru
Aby dodać nowy parametr, kliknij przycisk (lub kliknij prawym przyciskiem myszy w dowolnym miejscu głównej tabeli i wybierz polecenie Add Column z menu kontekstowego). Otworzy się okno dialogowe Add Parameter. Aby tylko utworzyć nowy parametr, bez przypisywania wartości do żadnego z obiektów, wprowadź jego nazwę i kliknij OK. Jeśli chcesz dodać parametr do wszystkich obiektów wraz z określoną wartością, włącz opcję Add to all objects, wprowadź żądaną wartość, a następnie kliknij OK. Kolumna nowego parametru zostanie dodana za istniejącymi kolumnami (na samym końcu listy, po prawej stronie).
Zmiana nazwy parametru
Aby zmienić nazwę parametru, kliknij prawym przyciskiem myszy komórkę w kolumnie, której nazwę chcesz zmienić, a następnie wybierz Rename Column z menu rozwijanego. Otworzy się okno dialogowe Rename Existing Parameter. Wprowadź nową nazwę w polu Enter the new name for the parameter , a następnie kliknij OK. Zwróć uwagę, że nagłówek kolumny uległ zmianie, a obok nazwy pojawił się mały niebieski trójkąt. Ta ikona wskazuje, że wartość tej komórki została zmieniona.

Okno dialogowe Rename Existing Parameter
Dodawanie parametru do wybranych komponentów
Aby dodać parametr do komponentów, zaznacz komórki w edytorze okna dialogowego Parameter Table Editor za pomocą kombinacji klawiszy Shift+Click lub Ctrl+Click, kliknij prawym przyciskiem myszy, a następnie wybierz Add z menu rozwijanego. Po wybraniu Add w każdej komórce pojawi się mały zielony symbol plusa. Oznacza to, że dodano nowy parametr.
Po dodaniu parametru możesz określić typ każdego komponentu. Okno dialogowe Parameter Table Editor obsługuje standardowe skróty klawiaturowe do edycji tabel. Możesz nacisnąć F2, aby edytować komórkę, a następnie nacisnąć Enter , aby zatwierdzić zmianę. Aby edytować wiele komórek, zaznacz je, a następnie kliknij prawym przyciskiem myszy i wybierz Edit z menu. Wprowadź nową wartość, a następnie naciśnij Enter , aby zastosować zmianę do wszystkich zaznaczonych komórek.
Wprowadzanie zmian parametrów
Wprowadzone przed chwilą zmiany parametrów są obecnie przechowywane w oknie dialogowym Parameter Table Editor i nie zostały jeszcze zastosowane do komponentów na arkuszach schematu. Aby zastosować te zmiany do komponentów, należy wygenerować zlecenie ECO, a następnie zastosować je w projekcie. W oknie dialogowym Parameter Table Editor kliknij przycisk Accept Changes (Create ECO) . Okno dialogowe Parameter Editor Table zostanie zamknięte i otworzy się okno dialogowe Engineering Change Order.
Kliknij przycisk Validate Changes, aby sprawdzić, czy zmiany mogą zostać zastosowane. Jeśli są poprawne, w kolumnie Check pojawi się zielony znacznik wyboru.
Kliknij Execute Changes, aby zastosować zmiany parametrów do komponentów. Po zastosowaniu zmian zamknij okno dialogowe Engineering Change Order .
).
).







