Working with Directives on a Schematic
Altium Essentials: Schematic Updating
This content is part of the official Altium Professional Training Program. For full courses, materials and certification, visit Altium Training.
W skrócie
- Dowiedz się, czym są dyrektywy projektowe i jak wykorzystuje się je podczas tworzenia i walidacji schematów.
- Zrozum, kiedy używać dyrektywy No ERC, a kiedy maski kompilacji, aby wyeliminować niepożądane komunikaty walidacyjne.
- Zobacz, jak umieszczać, włączać, wyłączać i edytować maski kompilacji w edytorze schematów.
Dyrektywy projektowe to obiekty umieszczane na schemacie podczas jego tworzenia, umożliwiające określanie instrukcji przekazywanych do innych części oprogramowania. Dostępne są różne dyrektywy projektowe, wykorzystywane na dwa poniższe sposoby:
- Dyrektywy związane z automatyczną kompilacją źródłowych dokumentów schematów.
- Dyrektywy służące do przekazywania na PCB informacji zdefiniowanych na arkuszu schematu.
W kolejnych sekcjach dokładniej omówiono te obszary oraz powiązane z nimi dyrektywy.
Dyrektywy związane z kompilacją
Projekty ewoluują z czasem i są tworzone etapami. Po dopracowaniu danego etapu często zachodzi potrzeba sprawdzenia go niezależnie od pozostałej części projektu. Kompilacja pojedynczego dokumentu schematu (lub całego projektu) na kolejnych etapach tworzenia często powoduje wyświetlenie szeregu komunikatów o błędach wynikających z obwodów, które nie zostały jeszcze narysowane, lub z nieukończonych połączeń między fragmentami obwodu. Takie komunikaty nie mają rzeczywistej wartości, ponieważ jedynie utrudniają dostrzeżenie istotnych informacji. Najszybszym i najprostszym sposobem wyeliminowania tych błędów kompilacji jest umieszczenie dyrektyw No ERC lub Compile Mask.
Dyrektywa No ERC
Dyrektywę No ERC umieszcza się w węźle obwodu, aby wyłączyć zgłaszanie wszystkich ostrzeżeń i/lub błędów naruszenia reguł elektrycznych wykrywanych podczas walidacji projektu schematu. Więcej informacji można znaleźć na stronie Walidacja projektu.
Dyrektywa Compile Mask
Dyrektywy No ERC doskonale sprawdzają się przy wyłączaniu zgłaszania naruszeń dotyczących niewielkiej liczby wyprowadzeń, portów, wejść arkusza lub sieci w projekcie. W niektórych przypadkach pożądane może być jednak wyłączenie całego fragmentu projektu, łącznie z komponentami. Użyj dyrektywy Compile Mask (polecenie Place » Directives » Compile Mask) lub kliknij przycisk Compile Mask na liście rozwijanej dyrektyw na pasku Active Bar, aby skutecznie ukryć przed kompilatorem objęty nią obszar projektu. Pozwala to ręcznie wyłączyć sprawdzanie błędów w obwodach, które mogą być jeszcze nieukończone i o których wiadomo, że będą generować błędy kompilacji. Jest to bardzo przydatne, gdy trzeba skompilować aktywny dokument lub projekt, aby sprawdzić poprawność innych, konkretnych obszarów projektu, ale bez zbędnych komunikatów kompilatora dotyczących nieukończonych fragmentów.
Jak sugeruje nazwa, dyrektywa ta nakazuje kompilatorowi ignorowanie wszystkich obiektów znajdujących się completely w granicach zdefiniowanej maski. Maskę umieszcza się tak samo jak notatkę lub prostokąt.
Rozważ przykładowy obwód na poniższym schemacie, na którym połączenia z układem LCD1 nie są jeszcze ukończone. Kompilacja samego tego schematu (Project » Validate PCB Project) spowoduje wyświetlenie licznych komunikatów o naruszeniach (pokazanych poniżej), z których każdy wynika z nieukończonego obwodu. Najedź kursorem na ilustrację, aby zobaczyć efekt umieszczenia dyrektywy Compile Mask wokół nieukończonego obwodu. Kompilator zignoruje te naruszenia, sprawdzając jednocześnie pozostałą część obwodu na schemacie, której połączenia są już kompletne. Zwróć uwagę, że obiekty rzeczywiście objęte maską — czyli znajdujące się całkowicie wewnątrz prostokąta wyznaczającego jej granice — są wyszarzone.

Najedź kursorem na ilustrację, aby zobaczyć efekt użycia dyrektywy Compile Mask do ukrycia naruszeń zgłaszanych przez kompilator z powodu nieukończonego obwodu.
Maska kompilacji
Umieszczona maska kompilacji, widoczna po lewej stronie powyższego schematu.
Podsumowanie
Maska kompilacji to dyrektywa projektowa służąca do skutecznego ukrywania przed kompilatorem objętego nią obszaru projektu podczas walidacji wykonywanej za pomocą polecenia Project » Validate Project . Umożliwia ręczne wyłączenie sprawdzania błędów w obwodach, które mogą być jeszcze nieukończone i będą generować błędy walidacji. Maska kompilacji jest przydatna, gdy trzeba przeprowadzić walidację bieżącego projektu w celu sprawdzenia poprawności innych, konkretnych obszarów, a jednocześnie uniknąć nadmiaru komunikatów kompilatora dotyczących nieukończonych fragmentów projektu.
Dostępność
Maski kompilacji można umieszczać wyłącznie w edytorze schematów. Aby umieścić maskę kompilacji:
- Wybierz polecenie Place » Directives » Compile Mask z menu głównego.
- Kliknij przycisk Compile Mask na liście rozwijanej dyrektyw na pasku Active Bar znajdującym się u góry obszaru projektowego. Kliknij i przytrzymaj przycisk Active Ba, aby uzyskać dostęp do innych powiązanych poleceń. Po użyciu polecenia stanie się ono pierwszą pozycją w tej sekcji paska Active Bar.
- Kliknij prawym przyciskiem myszy w edytorze schematów, a następnie kliknij Place » Directives » Compile Mask.
Umieszczanie
Po uruchomieniu polecenia kursor przyjmie postać krzyżyka, sygnalizując tryb umieszczania maski kompilacji. Umieszczanie odbywa się w następującej kolejności:
- Ustaw kursor, a następnie kliknij lub naciśnij Enter, aby ustalić pierwszy narożnik maski.
- Przesuń kursor, aby dostosować rozmiar maski tak, by całkowicie obejmowała obszar projektu, który ma zostać ukryty przed kompilatorem. Następnie kliknij lub naciśnij Enter , aby ustalić przeciwległy narożnik i zakończyć umieszczanie maski. Obiekty projektu znajdujące się całkowicie w granicach maski zostaną wyszarzone.
- Kontynuuj umieszczanie kolejnych masek kompilacji lub kliknij prawym przyciskiem myszy albo naciśnij Esc, aby wyjść z trybu umieszczania.
Edycja graficzna
Ta metoda edycji umożliwia zaznaczenie umieszczonej maski kompilacji bezpośrednio w obszarze projektowym oraz graficzną zmianę jej rozmiaru, kształtu lub położenia.
Maska kompilacji może być wyświetlana w trybie aktywnym (pełna ramka) lub zwiniętym (trójkąt w ramce), co odpowiada odpowiednio włączonej i wyłączonej masce. Aby przełączyć tryb wyświetlania, kliknij ikonę ▲ lub ▼ w lewym górnym narożniku umieszczonej maski kompilacji.
Kliknij trójkąt w lewym górnym narożniku, aby zwinąć (i wyłączyć) maskę kompilacji.
Po zaznaczeniu aktywnej (rozwiniętej) maski kompilacji dostępne są następujące uchwyty edycyjne:
Zaznaczona maska kompilacji (w stanie aktywnym).
- Kliknij i przeciągnij A, aby zmienić rozmiar maski kompilacji jednocześnie w pionie i w poziomie.
- Kliknij i przeciągnij B, aby zmienić rozmiar maski kompilacji niezależnie w pionie i w poziomie.
- Kliknij w dowolnym miejscu maski kompilacji — z dala od uchwytów edycji — i przeciągnij, aby zmienić jej położenie. Podczas przeciągania maskę kompilacji można obracać (Spacebar/Shift+Spacebar) lub odbijać lustrzanie (klawisze X lub Y umożliwiają odbicie odpowiednio względem osi X lub Y).
Edycja niegraficzna
Dostępne są następujące metody edycji niegraficznej.
Edycja za pomocą okna dialogowego Compile Mask lub panelu Properties
Panel page: Właściwości maski kompilacji
Ta metoda edycji wykorzystuje powiązane okno dialogowe Compile Mask oraz tryb panelu Properties do modyfikowania właściwości obiektu maski kompilacji.
Po umieszczeniu obiektu okno dialogowe Compile Mask można otworzyć:
- Klikając dwukrotnie umieszczony obiekt maski kompilacji.
- Zaznaczając obiekt maski kompilacji, klikając prawym przyciskiem myszy, a następnie wybierając Properties z menu kontekstowego.
Podczas umieszczania obiektu tryb Compile Mask panelu Properties można otworzyć, naciskając klawisz Tab. Po umieszczeniu maski kompilacji pojawią się wszystkie opcje.
Po umieszczeniu obiektu tryb Compile Mask panelu Properties można otworzyć na jeden z następujących sposobów:
- Jeśli panel Properties jest już aktywny — zaznaczając obiekt maski kompilacji.
- Po zaznaczeniu obiektu maski kompilacji wybierz panel Properties za pomocą przycisku Panels w prawej dolnej części obszaru projektowego lub wybierając View » Panels » Properties z menu głównego.
Edycja wielu obiektów
Panel Properties obsługuje edycję wielu obiektów, umożliwiając modyfikowanie ustawień właściwości, które są identyczne we wszystkich aktualnie zaznaczonych obiektach. Gdy wiele obiektów tego samego typu zostanie zaznaczonych ręcznie, za pomocą okna dialogowego Znajdź podobne obiekty lub panelu Filter bądź List, wartość w polu panelu Properties, która nie jest wyświetlana jako gwiazdka (*), można edytować dla wszystkich zaznaczonych obiektów.
Edycja za pomocą panelu List
Panel pages: Panele List, SCH Filter
Panel List wyświetla typy obiektów projektu z jednego lub większej liczby dokumentów w formie tabeli, umożliwiając szybkie sprawdzanie i modyfikowanie atrybutów obiektów. W połączeniu z odpowiednim filtrowaniem — przez wybór typów obiektów (za pomocą opcji Include panelu) lub użycie odpowiedniego panelu Filter bądź okna dialogowego Znajdź podobne obiekty — umożliwia wyświetlanie tylko tych obiektów, które spełniają kryteria aktywnego filtra. Właściwości wyświetlonych obiektów można następnie edytować bezpośrednio w panelu List.
Właściwości maski kompilacji
Właściwości obiektów edytora schematów to konfigurowalne opcje określające wygląd, zawartość i zachowanie umieszczonego obiektu. Ustawienia właściwości każdego typu obiektu definiuje się w następujący sposób:
- Post-placement settings – wszystkie właściwości obiektu maski kompilacji są dostępne do edycji w oknie dialogowym Compile Mask oraz w panelu Properties po zaznaczeniu umieszczonej maski kompilacji w obszarze projektowym.
Położenie
-
(X/Y)
- X (pierwsze pole) — bieżąca współrzędna X (pozioma) punktu odniesienia obiektu względem bieżącego początku układu współrzędnych obszaru projektowego. Zmień tę wartość, aby zmienić położenie obiektu na osi X. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych; podczas wprowadzania wartości w jednostkach innych niż domyślne należy podać jednostkę.
- Y (drugie pole) — bieżąca współrzędna Y (pionowa) punktu odniesienia obiektu względem bieżącego początku układu współrzędnych. Zmień tę wartość, aby zmienić położenie obiektu na osi Y. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych; podczas wprowadzania wartości w jednostkach innych niż domyślne należy podać jednostkę.
Właściwości
- Width — wprowadź szerokość obiektu.
- Height — wprowadź wysokość obiektu.
- Border — wybierz żądane obramowanie z listy rozwijanej.
- Fill Color — kliknij pole koloru, aby wybrać żądany kolor obiektu.
- Collapsed and Disabled — zaznacz to pole, aby zwinąć i wyłączyć obiekt.
Dyrektywy dotyczące PCB
Jako ujednolicone środowisko projektowe Altium Designer umożliwia definiowanie wymagań dotyczących PCB przed rozpoczęciem projektowania układu płytki. W tym celu do obiektów umieszczonych na arkuszach schematu dodaje się parametry i określa ich wartości.
W przypadku niektórych obiektów schematu — takich jak komponenty, symbole arkuszy, porty itp. — polega to na dodaniu odpowiednich parametrów do właściwości danego obiektu. W przypadku obiektów sieci, takich jak przewody i magistrale, parametrów nie można dodać bezpośrednio jako właściwości przewodu lub magistrali. Zamiast tego parametry przechowujące wymagane informacje określa się za pomocą specjalnych dyrektyw projektowych.
Za pomocą dyrektyw można określić następujące informacje, które podczas synchronizacji projektu zostaną przeniesione do odpowiednich definicji na PCB:
- Ograniczenia dotyczące układu PCB
- Pary różnicowe
- Klasy sieci
Umieszczając dyrektywy projektowe na schemacie, inżynierowie mogą określać konkretne ograniczenia projektowe i zapewnić, że schemat pozostanie nadrzędnym źródłem informacji o projekcie. Wszelkie zmiany w projekcie są wówczas wprowadzane wyłącznie na schemacie, a następnie przenoszone do PCB. Może to być szczególnie istotne, gdy nad projektem pracuje wiele osób — zwłaszcza w różnych lokalizacjach. Zamiast uzgadniać wszystko w długich wątkach e-mailowych lub przez telefon, osoba opracowująca schemat może zadbać o to, aby określone ograniczenia rzeczywiście były stosowane podczas projektowania układu PCB.
Podstawą tej funkcjonalności jest dyrektywa zestawu parametrów.
Są to zasadniczo definiowane przez użytkownika obiekty zestawów parametrów, które można powiązać z obiektem sieci w projekcie schematu. Umieść dyrektywę układu PCB na przewodzie, magistrali lub wiązce sygnałowej, aby określić co najmniej jedno ograniczenie projektowe dla powiązanych sieci. Podczas tworzenia PCB na podstawie schematu informacje zawarte w dyrektywie układu PCB służą do utworzenia odpowiednich reguł projektowych PCB. Informacje określone przez dyrektywę układu PCB dotyczą wyłącznie sieci (lub zestawu sieci), do której dyrektywa jest podłączona.
Pełni ona funkcję kontenera na dowolną liczbę parametrów dotyczących sieci, do której jest podłączona. Można umieścić domyślną dyrektywę zestawu parametrów, która nie zawiera żadnych parametrów (Place » Directives » Parameter Set), a odpowiednie parametry dodać później. W kolejnych sekcjach dokładniej omówiono korzystanie z tych dyrektyw opartych na parametrach. Dostępne są zarówno dyrektywy zestawów parametrów definiowane przez użytkownika (zestaw parametrów), jak i predefiniowane (para różnicowa). Jedyna różnica między pustym a predefiniowanym zestawem parametrów polega na tym, że zestawy predefiniowane zawierają parametr, co opisano poniżej.
Zestaw parametrów
Podsumowanie
Zestaw parametrów to dyrektywa projektowa umożliwiająca powiązanie specyfikacji projektowych z obiektem typu sieć w projekcie schematu. Można go na przykład użyć do zadeklarowania, że dwie sieci tworzą parę różnicową. Na podstawie obecności parametrów o określonych nazwach w zestawie oprogramowanie rozpoznaje, jaką dyrektywę projektową umieszczasz.
Dostępność
Zestawy parametrów można umieszczać wyłącznie w edytorze schematów. Dostępne są zarówno domyślne (puste), jak i predefiniowane (para różnicowa) dyrektywy zestawów parametrów. Jedyna różnica między pustym a predefiniowanym zestawem parametrów polega na tym, że zestawy predefiniowane zawierają parametr, co opisano poniżej.
Odpowiednie polecenia są dostępne w menu głównym Place w następujący sposób:
| • | Place » Directives » Parameter Set | |
| • | Place » Directives » Differential Pair | |
Umieszczanie
Zestawu parametrów można użyć do dołączenia parametrów do następujących obiektów:
- Przewód
- Magistrala
- Wiązka sygnałowa
- Symbol arkusza
Po uruchomieniu polecenia kursor zmieni się w krzyżyk i zostanie włączony tryb umieszczania dyrektywy projektowej. Aby umieścić dyrektywę, wykonaj następujące czynności:
- Ustaw kursor nad przewodem lub innym obiektem sieci i kliknij albo naciśnij Enter, aby umieścić dyrektywę.
- Kontynuuj umieszczanie kolejnych dyrektyw albo kliknij prawym przyciskiem myszy lub naciśnij Esc, aby wyjść z trybu umieszczania.
Podczas umieszczania, gdy zestaw parametrów nadal jest dołączony do kursora, można wykonać następujące dodatkowe czynności:
-
Naciśnij klawisz Tab, aby wstrzymać umieszczanie i przejść do trybu zestawu parametrów w panelu Properties, gdzie można na bieżąco zmieniać jego właściwości. Kliknij przycisk pauzy wyświetlany w obszarze roboczym , aby wznowić umieszczanie.
-
Naciśnij klawisz Alt, aby ograniczyć kierunek ruchu do osi poziomej lub pionowej, zależnie od początkowego kierunku ruchu.
-
Naciśnij Spacebar, aby obrócić łuk przeciwnie do ruchu wskazówek zegara, lub Shift+Spacebar, aby obrócić go zgodnie z ruchem wskazówek zegara. Czynność tę można również wykonać podczas przeciągania obiektu. Obrót odbywa się co 90°.
-
W trybie umieszczania naciśnij klawisz X lub Y, aby odbić zestaw parametrów względem osi X lub Y.
Edycja graficzna
Ta metoda edycji umożliwia zaznaczenie umieszczonej dyrektywy zestawu parametrów bezpośrednio w obszarze roboczym oraz graficzną zmianę jej położenia lub orientacji.
Po zaznaczeniu dyrektywy zestawu parametrów w obszarze roboczym pojawi się wokół niej przerywana ramka. Obejmuje ona wyłącznie obszar zajmowany przez dyrektywę. Dla każdego parametru zestawu, którego widoczność jest włączona, wyświetlana jest przerywana linia łącząca pole tekstowe parametru z korpusem dyrektywy, co potwierdza ich powiązanie:
Kliknij w dowolnym miejscu wewnątrz przerywanej ramki, a następnie przeciągnij, aby odpowiednio zmienić położenie zestawu parametrów. Podczas przeciągania zestaw parametrów można obracać (Spacebar/Shift+Spacebar) lub odbijać lustrzanie (klawisze X lub Y umożliwiają odbicie względem osi X lub Y).
Rozmiar pól tekstowych zestawu parametrów (które można edytować graficznie niezależnie od nadrzędnej dyrektywy) można zmieniać wyłącznie za pomocą opcji Style na stronie Schematic – Defaults okna dialogowego Preferences. Dlatego po zaznaczeniu dowolnego z tych obiektów uchwyty edycji nie są dostępne.
Kliknij w dowolnym miejscu wewnątrz przerywanej ramki, a następnie przeciągnij, aby odpowiednio zmienić położenie obiektu tekstowego. Podczas przeciągania obiekt tekstowy można obracać (Spacebar/Shift+Spacebar) lub odbijać lustrzanie (klawisze X lub Y umożliwiają odbicie względem osi X lub Y).
Jeśli opcja Enable In-Place Editing jest włączona na stronie Schematic – General okna dialogowego Preferences, można edytować wartość parametru bezpośrednio w obszarze projektowym (z wyjątkiem parametrów dodanych jako reguły). Zaznacz obiekt tekstowy, a następnie kliknij go jeden raz, aby uruchomić tę funkcję. Wpisz nową wartość, a następnie kliknij poza obiektem tekstowym lub naciśnij Enter, aby zatwierdzić zmianę.
Edycja niegraficzna
Dostępne są następujące metody edycji niegraficznej.
Edycja za pomocą okna dialogowego Parameter Set lub panelu Properties
Panel page: Właściwości zestawu parametrów
Ta metoda edycji wykorzystuje powiązane okno dialogowe Parameter Set oraz tryb Properties panelu do modyfikowania właściwości obiektu zestawu parametrów.

Okno dialogowe Parameter Set na pierwszej ilustracji oraz tryb Parameter Set panelu Properties na drugiej ilustracji
Po umieszczeniu obiektu okno dialogowe Parameter Set można otworzyć na następujące sposoby:
- Klikając dwukrotnie umieszczony obiekt zestawu parametrów.
- Umieszczając kursor nad obiektem zestawu parametrów, klikając prawym przyciskiem myszy i wybierając Properties z menu kontekstowego.
Podczas umieszczania obiektu dostęp do trybu Parameter Set panelu Properties można uzyskać, naciskając klawisz Tab. Po umieszczeniu zestawu parametrów wyświetlane są wszystkie opcje.
Po umieszczeniu obiektu dostęp do trybu Parameter Set panelu Properties można uzyskać na jeden z następujących sposobów:
- Jeśli panel Properties jest już aktywny — zaznaczając obiekt zestawu parametrów.
- Po zaznaczeniu obiektu zestawu parametrów wybierając panel Properties za pomocą przycisku Panels w prawym dolnym rogu obszaru projektowego lub wybierając View » Panels » Properties z menu głównego.
Edycja wielu obiektów
Panel Properties obsługuje edycję wielu obiektów, umożliwiając modyfikowanie ustawień właściwości, które są identyczne we wszystkich aktualnie zaznaczonych obiektach. Gdy wiele obiektów tego samego typu zostanie zaznaczonych ręcznie, za pomocą okna dialogowego Find Similar Objects lub panelu Filter bądź List, wartość pola w panelu Properties, która nie jest wyświetlana jako gwiazdka (*), można edytować dla wszystkich zaznaczonych obiektów.
Edycja za pomocą panelu List
Panel pages: Panele List, SCH Filter
Panel List umożliwia wyświetlanie obiektów projektowych z jednego lub większej liczby dokumentów w formie tabeli, co pozwala szybko przeglądać i modyfikować atrybuty obiektów. W połączeniu z odpowiednim filtrowaniem — za pomocą właściwego panelu Filter lub okna dialogowego Find Similar Objects — umożliwia wyświetlanie wyłącznie obiektów objętych aktywnym filtrem, co pozwala precyzyjniej i wydajniej wybierać oraz edytować wiele obiektów projektowych.
Uwagi
- Podczas umieszczania domyślnej dyrektywy zestawu parametrów nie zawiera ona żadnych parametrów. Po jej umieszczeniu dodaj odpowiednie parametry w sekcji Parameters panelu Properties .
- Dyrektywa zestawu parametrów umożliwia przypisanie informacji dotyczących projektu PCB do sieci na schemacie. Podczas tworzenia PCB na podstawie schematu informacje zawarte w zestawie parametrów służą do tworzenia odpowiednich reguł projektowych PCB. Informacje określone w dyrektywie zestawu parametrów są stosowane wyłącznie do sieci, do których jest ona podłączona.
- Po dodaniu dyrektywy zestawu parametrów do sieci pola Power Net i High Speed stają się dostępne w panelu Properties tej sieci. Podczas aktualizowania dokumentu PCB na podstawie schematów proponowane jest dodanie reguły projektowej Supply Nets do każdej sieci z włączonym parametrem Power Net.
- Dyrektywy klasy sieci umożliwiają tworzenie na schemacie klas sieci zdefiniowanych przez użytkownika. Podczas tworzenia PCB na podstawie schematu informacje zawarte w dyrektywie klasy sieci służą do utworzenia odpowiedniej klasy sieci na PCB. Aby przypisać sieć do klasy sieci, dołącz dyrektywę zestawu parametrów do odpowiedniego przewodu lub magistrali i dodaj klasę o żądanej nazwie. Aby korzystać z tej funkcji, opcja Generate Net Classes (dla klas zdefiniowanych przez użytkownika) musi być włączona na karcie Class Generation okna dialogowego Project Options.
- Jeśli dla sieci zdefiniowano dyrektywę klasy sieci, wszystkie reguły projektowe PCB utworzone przez ten sam obiekt zestawu parametrów będą miały zakres klasy sieci po przeniesieniu projektu do edytora PCB.
- Dyrektywę klasy sieci można utworzyć na podstawie umieszczonej dyrektywy zestawu parametrów, dodając klasę, której wartość należy ustawić na wymaganą klasę sieci PCB.
-
Obiekt Blanket w połączeniu z dyrektywą zestawu parametrów może również służyć do przypisywania klas i parametrów komponentom znajdującym się w całości w obszarze wyznaczonym przez ten obiekt. W tym celu użyj opcji Component Class i Parameter z menu rozwijanego przycisku Add we właściwościach dyrektywy zestawu parametrów dołączonej do obiektu Blanket. Informacje o klasie komponentów i parametrze zostaną przeniesione do dokumentu PCB projektu w ramach procesu ECO podczas aktualizacji PCB.
Właściwości zestawu parametrów
Właściwości obiektów edytora schematów to konfigurowalne opcje określające wygląd, zawartość i zachowanie umieszczonego obiektu.
Ustawienia właściwości każdego typu obiektu definiuje się na dwa sposoby:
-
Pre-placement settings – większość właściwości obiektu zestawu parametrów lub te, które można logicznie zdefiniować z wyprzedzeniem, są dostępne jako edytowalne ustawienia domyślne na stronie Schematic – Defaults okna dialogowego Preferences (otwieranego przyciskiem
w prawym górnym rogu obszaru projektowego). Wybierz obiekt w Primitive List, aby wyświetlić jego opcje po prawej stronie.
-
Post-placement settings – wszystkie właściwości obiektu zestawu parametrów można edytować w oknach dialogowych Parameter Set oraz w panelu Properties, gdy zestaw parametrów jest zaznaczony w obszarze projektowym.
Położenie
-
(X/Y)
- X (pierwsze pole) – bieżąca współrzędna X (pozioma) punktu odniesienia obiektu względem bieżącego początku układu współrzędnych obszaru projektowego. Edytuj ją, aby zmienić położenie obiektu w osi X. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych; jeśli używasz jednostek innych niż aktualnie domyślne, podaj je wraz z wartością.
- Y (drugie pole) – bieżąca współrzędna Y (pionowa) punktu odniesienia obiektu względem bieżącego początku układu współrzędnych. Edytuj ją, aby zmienić położenie obiektu w osi Y. Wartość można wprowadzić w jednostkach metrycznych lub imperialnych; jeśli używasz jednostek innych niż aktualnie domyślne, podaj je wraz z wartością.
- Rotation – wybierz obrót z listy rozwijanej.
Właściwości
- Label – etykieta zestawu parametrów. W razie potrzeby możesz ją edytować.
- Style – wybierz styl z listy rozwijanej. Kliknij pole koloru, aby otworzyć listę rozwijaną, z której można wybrać kolor domyślny.
Parametry
- Grid – wyświetla Name i Value parametrów powiązanych z aktualnie wybranym parametrem. Po dodaniu można edytować pola Name i Value. Nazwę Value można nadać, klikając pole i wpisując żądany tekst. Pole Name można zmienić wyłącznie w trybie Properties panelu dla obiektu zestawu parametrów, korzystając z opcji Ctrl+Click. Spowoduje to otwarcie panelu Properties w trybie Parameter, w którym można wprowadzić żądaną nazwę w polu Name. Użyj ikony kłódki , aby zablokować lub odblokować parametr na liście. Użyj ikony oka, aby pokazać lub ukryć parametr. Przełączając przycisk All i przyciski poszczególnych parametrów, można wyświetlić w tym obszarze wszystkie parametry, wybrane parametry lub żaden z nich. Parametry są wyłączone, gdy odpowiadające im przyciski są szare, a włączone, gdy przyciski są niebieskie.
-
Add – użyj listy rozwijanej, aby dodać klasę określonego typu:
-
Net Class – wybierz, aby dodać nową klasę sieci.
- Component Class – wybierz, aby dodać nową klasę komponentów. Ta opcja jest dostępna tylko w wariancie okna dialogowego Parameter Set lub panelu Properties dla zestawu parametrów.
-
Diff. Pair Net Class – wybierz, aby dodać nową klasę sieci par różnicowych. Ta opcja jest dostępna tylko w wariancie okna dialogowego Parameter Set lub panelu Properties dla pary różnicowej.
-
Parameter – wybierz, aby dodać nowy parametr.
-
Rule – kliknij, aby otworzyć okno dialogowe Select Design Rule Type, w którym można wybrać typ nowej reguły Po wybraniu typu reguły i kliknięciu
otworzy się okno dialogowe Edit PCB Rule (From Schematic), w którym można w razie potrzeby edytować nową regułę.
-
Kliknij ikonę ołówka , aby otworzyć okno dialogowe Edit PCB Rule (From Schematic) i edytować wybrany element. Kliknij
, aby usunąć wybrany element.
- Font Settings – kliknij wyświetlaną czcionkę, aby zmienić jej styl. Ta opcja jest dostępna dopiero po dodaniu klasy sieci, klasy sieci par różnicowych, parametru lub reguły.
-
Other – jeśli dodano klasę sieci, klasę sieci par różnicowych, parametr lub regułę, kliknij, aby otworzyć listę rozwijaną umożliwiającą zmianę dodatkowych opcji:
- Show Parameter Name – włącz, aby wyświetlić nazwę parametru.
- Allow Synchronization with Database – włącz, aby synchronizować z bazą danych.
- X/Y – wprowadź współrzędne X i Y.
- Rotation – wybierz kąt obrotu z listy rozwijanej.
- Autoposition – zaznacz, aby włączyć automatyczne pozycjonowanie.
Umieszczanie dyrektyw zestawu parametrów
Umieść dyrektywę tego typu, wybierając polecenie Place » Directives » Parameter Set z menu głównego lub z menu kontekstowego dostępnego po kliknięciu prawym przyciskiem myszy w obszarze projektowym. Domyślna dyrektywa zestawu parametrów w chwili umieszczania nie zawiera żadnych parametrów. Zestaw parametrów to dyrektywa projektowa, która umożliwia powiązanie specyfikacji projektowych z obiektem typu sieć na schemacie. Można na przykład użyć zestawu parametrów, aby określić, że dwie sieci należą do pary różnicowej. Na podstawie obecności parametrów o określonych nazwach w zestawie oprogramowanie rozpoznaje, jaką dyrektywę projektową umieszczasz.
Oprócz dyrektyw parametrów definiowanych przez użytkownika można zdefiniować dyrektywę parametru opartą na regule w oknie dialogowym Choose Design Rule Type, dostępnym w powiązanym z parametrem trybie panelu Properties. Aby uzyskać do niego dostęp:
-
Naciśnij
Tabprzed umieszczeniem zestawu parametrów lub kliknij dwukrotnie już umieszczoną dyrektywę zestawu parametrów, aby wyświetlić jej właściwości w panelu Properties. -
Następnie kliknij przycisk
w sekcji Parameters panelu Properties i wybierz Rule z listy rozwijanej, aby wybrać regułę w oknie dialogowym Select Design Rule Type.
W oknie dialogowym Select Design Rule Type wybierz typ reguły, którą chcesz dodać do dyrektywy jako parametr reguły. Dwukrotne kliknięcie typu reguły otworzy odpowiednie okno dialogowe Edit PCB Rule (From Schematic), w którym można zdefiniować ograniczenia reguły.

Określanie ograniczeń wybranej reguły.
Wpis w sekcji Parameters będzie zawierać wybrany typ reguły wraz z określonymi ograniczeniami. Poniższy obraz przedstawia zdefiniowane parametry reguły ograniczenia szerokości dla dyrektywy Parameter Set. Aby wyświetlić regułę w obszarze projektowym, kliknij ikonę widoczności w sekcji Rules.

Wiele ograniczeń reguł zdefiniowanych dla jednej sieci za pomocą dyrektywy zestawu parametrów.
Podczas przenoszenia projektu do PCB w procesie synchronizacji zostaną utworzone odpowiednie reguły projektowe na podstawie informacji zawartych w dyrektywie. W nazwie każdej wygenerowanej reguły używane jest słowo Schematic, aby wskazać jej źródło.

Reguły projektowe wygenerowane po stronie PCB.
Umieszczanie dyrektyw klasy sieci
Dyrektywa klasy sieci umożliwia tworzenie na schemacie klas sieci definiowanych przez użytkownika. Aby umieścić dyrektywę klasy sieci, wybierz polecenie Place » Directives » Parameter Set z menu głównego, a następnie zdefiniuj zestaw parametrów jako dyrektywę klasy sieci zgodnie ze wskazówką nr 2 na stronie tego polecenia. Podczas tworzenia PCB na podstawie schematu informacje zawarte w dyrektywie klasy sieci są wykorzystywane do utworzenia odpowiedniej klasy sieci na PCB. Aby dodać sieć do klasy sieci, dołącz dyrektywę klasy sieci do odpowiedniego przewodu, magistrali lub wiązki sygnałowej, a następnie ustaw parametr ClassName dyrektywy na nazwę żądanej klasy. Aby korzystać z tej funkcji, należy włączyć opcję Generate Net Classes (dla klas definiowanych przez użytkownika) na karcie Class Generation w oknie dialogowym Project Options.
Jeśli dla sieci zdefiniowano dyrektywę klasy sieci, wszelkie reguły projektowe PCB tworzone przez ten sam obiekt zestawu parametrów będą po przeniesieniu projektu do edytora PCB obejmować swoim zakresem klasę sieci. Dyrektywę klasy sieci można utworzyć z umieszczonej dyrektywy zestawu parametrów, dodając klasę, której wartość należy ustawić na żądaną klasę sieci PCB.
Ważne wymagania dotyczące opcji projektu
Aby zestawy parametrów zdefiniowane na schemacie były przenoszone na PCB, w oknie dialogowym Options for PCB Project należy skonfigurować następujące opcje:
- Włącz opcję Generate Net Classes znajdującą się w sekcji User-Defined Classes na karcie Class Generation tego okna dialogowego.
-
Na karcie Comparator tego okna dialogowego ustaw tryb sprawdzania Differences Associated with Nets » Extra Net Classes na
Find Differences.

Aby przenosić dyrektywy zestawu parametrów na PCB, należy skonfigurować dwie opcje projektu. Najpierw włącz opcję Generate Net Classes na karcie Class Generation. Najedź kursorem na obraz, aby wyświetlić kartę Comparator, na której należy ustawić opcję Extra Net Classes na Find Differences.
Podczas przenoszenia projektu do PCB w procesie synchronizacji zostaną utworzone odpowiednie klasy sieci na podstawie informacji zawartych w dyrektywie.
Umieszczanie dyrektyw Blanket
Dyrektywy Parameter Set mogą dotyczyć tylko konkretnej sieci, do której są dołączone, ale w połączeniu z dyrektywą Blanket ich zakres można rozszerzyć na wszystkie sieci objęte tym obszarem.
Umieść dyrektywę tego typu, wybierając polecenie Place » Directives » Blanket z menu głównego. Podczas umieszczania obszaru Blanket można zdefiniować prosty kształt prostokątny lub wielokątny. Ten drugi umożliwia dokładniejsze objęcie wymaganych obiektów sieci na arkuszu.
Obszar Blanket wskazuje sieci, których ma dotyczyć dyrektywa — umieść dyrektywę Parameter Set w dowolnym miejscu na jego krawędzi, aby zastosować wymagania projektowe do tych sieci. Aby dyrektywa umieszczona na obwodzie dotyczyła sieci pod obszarem Blanket, obiekt powiązany z tą siecią — pin, port, etykieta sieci, port zasilania, segment przewodu, magistrali lub wiązki (wraz z oboma końcami) — musi znajdować się w granicach tego obszaru. W przypadku identyfikatorów sieci, takich jak etykiety sieci, wewnątrz obszaru Blanket musi znajdować się punkt aktywny. Jeśli sieci składowe nie są przenoszone do zestawu parametrów PCB zgodnie z oczekiwaniami, spróbuj odpowiednio dostosować granice obszaru Blanket.

Przykład użycia dyrektywy Blanket do zastosowania dyrektywy Parameter Set do sieci znajdujących się w jej obszarze.
Przykładowe zastosowania dyrektywy Blanket:
- Dołączenie dyrektywy Parameter Set do obiektu Blanket, aby jej parametry reguł były stosowane do każdej sieci objętej tym obszarem.
- Dołączenie dyrektywy Parameter Set do obiektu Blanket w celu utworzenia zestawu parametrów, którego elementami są poszczególne sieci objęte tym obszarem.
- Dołączenie dyrektywy Differential Pair do obiektu Blanket w celu utworzenia obiektów par różnicowych na podstawie sieci różnicowych znajdujących się w granicach tego obszaru.
Obszar Blanket w połączeniu z dyrektywą Parameter Set może również służyć do przypisywania klas komponentów i parametrów do komponentów znajdujących się całkowicie w jego granicach. W tym celu użyj opcji Component Class i Parameter z menu rozwijanego przycisku Add we właściwościach dyrektywy Parameter Set dołączonej do obszaru Blanket. Informacje o klasie komponentu i parametrze zostaną przeniesione do dokumentu PCB projektu w ramach procesu ECO podczas aktualizacji PCB.
Obszar Blanket
Prostokątny i wielokątny obszar Blanket — każdy z dołączoną dyrektywą
Podsumowanie
Blanket to prostokątny lub wielokątny obiekt dyrektywy grupowej, umieszczany nad zbiorem sieci i/lub komponentów. Dyrektywa (obiekt Parameter Set) zastosowana do obszaru Blanket będzie dotyczyć wszystkich sieci i komponentów, które on obejmuje. Podczas umieszczania obszaru Blanket można zdefiniować prosty kształt prostokątny lub wielokątny. Ten drugi umożliwia dokładniejsze objęcie wymaganych obiektów sieci na arkuszu.
Obszar Blanket dotyczy wszystkich sieci, które:
- znajdują się całkowicie w granicach obszaru Blanket lub
- mają co najmniej jeden podłączony wierzchołek końcowy przewodu / magistrali / wiązki w obszarze Blanket lub
- mają etykietę sieci dołączoną do przewodu / magistrali / wiązki, a etykieta ta znajduje się w obszarze Blanket.
W przypadku komponentów obszar Blanket dotyczy wszystkich komponentów znajdujących się w jego granicach.
Dyrektywa zastosowana do obwodu obszaru Blanket (Place » Directive), taka jak No ERC, Differential Pair lub określony zestaw parametrów reguł/klas Parameter Set, będzie dotyczyć wszystkich sieci i komponentów rozpoznanych przez obiekt Blanket. Obszary Blanket można wyłączać i ukrywać.
Dostępność
Obszary Blanket można umieszczać wyłącznie w edytorze schematów. Aby umieścić obszar Blanket:
- Kliknij Place » Directives » Blanket w menu głównym.
- Kliknij przycisk Blanket w menu rozwijanym dyrektyw na Active Bar u góry obszaru projektowego. Kliknij i przytrzymaj przycisk Active Bar, aby uzyskać dostęp do innych powiązanych poleceń. Po użyciu polecenia stanie się ono pierwszą pozycją w tej sekcji Active Bar.
- Kliknij prawym przyciskiem myszy w edytorze schematów, a następnie kliknij Place » Directives » Blanket.
Umieszczanie
Aby umieścić prostokątny obszar Blanket:
- Uruchom polecenie zgodnie z powyższym opisem.
- Ustaw kursor, a następnie kliknij lub naciśnij Enter , aby umieścić lewy górny narożnik.
- Ustaw kursor, a następnie kliknij lub naciśnij Enter , aby umieścić prawy dolny narożnik.
- Kliknij prawym przyciskiem myszy lub naciśnij Enter , aby zakończyć umieszczanie.
- Kontynuuj umieszczanie kolejnych obszarów Blanket lub kliknij prawym przyciskiem myszy bądź naciśnij Esc , aby wyjść z trybu umieszczania.
Aby umieścić wielokątny obszar Blanket:
- Uruchom polecenie umieszczania.
- Ustaw kursor, a następnie kliknij lub naciśnij Enter , aby ustalić punkt początkowy obszaru Blanket.
- Ustawiaj kursor, a następnie klikaj lub naciskaj Enter , aby wyznaczyć kolejne segmenty definiujące kształt obszaru Blanket.
- Po umieszczeniu ostatniego segmentu kliknij prawym przyciskiem myszy lub naciśnij Esc , aby zakończyć umieszczanie. Nie trzeba „zamykać” wielokąta, ponieważ oprogramowanie automatycznie uzupełni kształt, dodając segmenty niezbędne do połączenia punktu początkowego z ostatnim umieszczonym segmentem.
- Kontynuuj umieszczanie kolejnych obszarów Blanket lub kliknij prawym przyciskiem myszy bądź naciśnij Esc , aby wyjść z trybu umieszczania.
Podczas umieszczania segmentów obszaru Blanket można wykonać następujące dodatkowe czynności:
- Naciśnij klawisz Tab, aby wstrzymać umieszczanie i uzyskać dostęp do trybu Blanket panelu Właściwości, w którym można na bieżąco zmieniać właściwości linii. Kliknij przycisk pauzy wyświetlany nad obszarem projektowym , aby wznowić umieszczanie.
- Naciśnij Spacebar, aby zmienić kierunek narożnika niezatwierdzonego segmentu.
- Naciśnij Backspace aby usunąć poprzednio zatwierdzony segment podczas definiowania wielokątnego kształtu obiektu Blanket. Kolejne użycia Backspace spowodują usuwanie poprzednich segmentów w odwrotnej kolejności.
Edycja graficzna
Ta metoda edycji umożliwia zaznaczenie umieszczonego obiektu Blanket bezpośrednio w obszarze projektowym i graficzną zmianę jego rozmiaru, kształtu lub położenia. Po zaznaczeniu obiektu Blanket dostępne są następujące uchwyty edycyjne:
Zaznaczone prostokątne i wielokątne obiekty Blanket z widocznymi uchwytami edycji graficznej.
Kliknij i przeciągnij uchwyt edycyjny na środku segmentu, aby przesunąć daną krawędź obiektu Blanket.
W przypadku prostokątnego obiektu Blanket kliknij i przeciągnij narożny uchwyt edycyjny, aby zmienić rozmiar jednocześnie w pionie i w poziomie.
Kliknij w dowolnym miejscu obrysu obiektu Blanket poza uchwytami edycyjnymi i przeciągnij, aby zmienić jego położenie. Podczas przeciągania obiekt Blanket można obracać lub odbijać:
- Naciśnij Spacebar, aby obrócić obiekt Blanket przeciwnie do ruchu wskazówek zegara wokół pozycji kursora. Shift+Spacebar obraca obiekt Blanket zgodnie z ruchem wskazówek zegara wokół kursora. Obrót odbywa się co 90°.
- Naciśnij klawisz X lub Y, aby odbić obiekt Blanket wzdłuż osi X lub Y względem pozycji kursora.
Edycja niegraficzna
Dostępne są następujące metody edycji niegraficznej.
Edycja za pomocą okna dialogowego Blanket lub panelu Właściwości
Panel page: Właściwości obiektu Blanket
Ta metoda edycji wykorzystuje odpowiedni tryb okna dialogowego Blanket i tryb panelu Properties do modyfikowania właściwości obiektu Blanket.
Okno dialogowe Blanket po lewej i tryb Blanket panelu Właściwości po prawej
Po umieszczeniu obiektu okno dialogowe Blanket można otworzyć:
- Klikając dwukrotnie umieszczony obiekt Blanket.
- Umieszczając kursor nad obiektem Blanket, klikając prawym przyciskiem myszy, a następnie wybierając Properties z menu kontekstowego.
Podczas umieszczania obiektu tryb Blanket panelu Properties można otworzyć, naciskając klawisz Tab. Po umieszczeniu obiektu Blanket wyświetlane są wszystkie opcje.
Po umieszczeniu obiektu tryb Blanket panelu Properties można otworzyć na jeden z następujących sposobów:
- Jeśli panel Properties jest już aktywny — zaznaczając obiekt Blanket.
- Po zaznaczeniu obiektu Blanket wybierając panel Properties za pomocą przycisku Panels w prawym dolnym rogu obszaru projektowego lub wybierając View » Panels » Properties z menu głównego.
Edycja wielu obiektów
Panel Properties obsługuje edycję wielu obiektów, umożliwiając modyfikowanie ustawień właściwości, które są identyczne we wszystkich aktualnie zaznaczonych obiektach. Po zaznaczeniu wielu obiektów tego samego typu ręcznie, za pomocą okna dialogowego Znajdź podobne obiekty lub panelu Filtr bądź Lista, wartość pola w panelu Properties, która nie jest wyświetlana jako gwiazdka (*), można edytować dla wszystkich zaznaczonych obiektów.
Edycja za pomocą panelu Lista
Panel pages: Panele Lista, Filtr SCH
Panel List wyświetla typy obiektów projektowych z jednego lub większej liczby dokumentów w formie tabeli, umożliwiając szybkie przeglądanie i modyfikowanie atrybutów obiektów. W połączeniu z odpowiednim filtrowaniem — przez wybór typów obiektów (za pomocą opcji Include panelu) albo użycie odpowiedniego panelu Filter lub okna dialogowego Znajdź podobne obiekty — umożliwia wyświetlanie tylko tych obiektów, które spełniają kryteria aktywnego filtra. Właściwości wyświetlonych obiektów można następnie edytować bezpośrednio w panelu List.
Obsługa filtrowania
Dostępne są dwa szczególnie przydatne słowa kluczowe do wyszukiwania obiektów Blanket za pomocą logicznych wyrażeń zapytań. Uzupełniają one zestaw pozostałych słów kluczowych używanych do wyszukiwania obiektów Blanket na podstawie ich właściwości.
-
Collapsed— obiekt jest zwinięty (przydatne również podczas wyszukiwania masek kompilacji). To słowo kluczowe można znaleźć w kategorii SCH Functions - Fields podczas korzystania z Pomocnika zapytań. -
IsBlanket— sprawdza, czy obiekt jest obiektem Blanket. To słowo kluczowe można znaleźć w kategorii SCH Functions - Object Type Checks podczas korzystania z Pomocnika zapytań.
Twórz logiczne wyrażenia zapytań, aby wyszukiwać obiekty Blanket w projekcie zgodnie z potrzebami. Oto kilka przykładów logicznych wyrażeń zapytań wyszukujących obiekty Blanket:
IsBlanket And Collapsed — wyszukuje wszystkie obiekty Blanket, które są obecnie zwinięte.
IsBlanket And Not Collapsed — wyszukuje wszystkie obiekty Blanket, które obecnie nie są zwinięte.
Wyłączanie obiektu Blanket
Po umieszczeniu obiekty Blanket można tymczasowo wyłączyć, klikając mały trójkąt w lewym górnym rogu Kliknij raz, aby wyłączyć i ukryć obiekt Blanket; kliknij ponownie, aby go włączyć. Jest to wygodny sposób kontrolowania wpływu obiektu Blanket bez konieczności całkowitego usuwania go z projektu.
Właściwości obszaru Blanket
Właściwości obiektów edytora schematów to konfigurowalne opcje określające wygląd, zawartość i zachowanie umieszczonego obiektu. Ustawienia właściwości poszczególnych typów obiektów definiuje się na dwa sposoby:
-
Pre-placement settings – większość właściwości obiektu Blanket, a także te, które można logicznie zdefiniować z wyprzedzeniem, jest dostępna jako edytowalne ustawienia domyślne na stronie Schemat – Ustawienia domyślne okna dialogowego Preferences (dostępnego po kliknięciu przycisku
w prawym górnym rogu obszaru projektowego). Wybierz obiekt w Primitive List, aby wyświetlić jego opcje po prawej stronie.
- Post-placement settings – wszystkie właściwości obiektu Blanket są dostępne do edycji w oknie dialogowym Blanket i panelu Properties po zaznaczeniu umieszczonego obszaru Blanket w obszarze projektowym.
Właściwości
- Border Width - użyj listy rozwijanej, aby wybrać żądaną szerokość obramowania.
- Styl linii - użyj listy rozwijanej, aby wybrać żądany styl linii.
- Border Color - kliknij pole koloru, aby wybrać żądany kolor obramowania.
- Fill Color - kliknij pole koloru, aby wybrać żądany kolor wypełnienia.
- Collapsed and Disabled - zaznacz, aby zwinąć i wyłączyć obszary Blanket.
Dyrektywy pośrednie (oparte na parametrach)
Dyrektywy zestawu parametrów są niezbędne w przypadku obiektów na schemacie, które nie mogą zawierać parametrów. W przypadku obiektów, które mogą je zawierać, dyrektywy projektowe można stosować pośrednio, dodając je (i definiując) jako parametry odpowiedniego obiektu schematu. W istocie są one parameter-based directives.
Przykłady zastosowania dyrektyw opartych na parametrach obejmują ograniczenie wysokości określonego komponentu lub dodanie ograniczenia odstępu dotyczącego wszystkich obiektów w projekcie. Wymagany parametr definiujący ograniczenie jest dodawany do obiektu jako reguła.
Podczas synchronizacji z PCB dyrektywy oparte na parametrach, dodane do obiektów na schemacie, stają się regułami projektowymi PCB. Zakres odpowiedniej reguły projektowej PCB jest określany przez rodzaj obiektu, do którego pierwotnie przypisano parametr. Poniższa tabela podsumowuje obsługiwane sposoby powiązania parametrów schematu z zakresem reguł PCB.
| Dodaj parametr (jako regułę) do... | Z poziomu... | Aby uzyskać zakres reguły PCB obejmujący... |
|---|---|---|
| Wyprowadzenie | karty Parameters w trybie Wyprowadzenie panelu Właściwości. | Pad |
| Port | karty Parameters w trybie Port panelu Właściwości. | Sieć |
| Komponent | sekcji Parameters w trybie Komponenty panelu Właściwości. | Komponent |
| Symbol arkusza | karty Parameters w trybie Symbol arkusza panelu Właściwości, gdy w sekcji Źródło wybrano opcję Lokalny. | Klasa komponentów |
| Symbol arkusza urządzenia | karty Parameters w trybie Symbol arkusza panelu Właściwości, gdy w sekcji Źródło wybrano opcję Urządzenie. | Klasa komponentów |
| Symbol zarządzanego arkusza | sekcji Parameters w trybie Symbol arkusza panelu Właściwości, gdy w sekcji Źródło wybrano opcję Zarządzany. | Klasa komponentów |
| Arkusz | karty Parameters w trybie Opcje dokumentu panelu Właściwości. | Wszystkie obiekty |
W każdym przypadku sposób dodawania parametru opartego na regule jest taki sam. Na odpowiedniej karcie lub w oknie dialogowym wykonaj następujące czynności:
- Dodaj parametr jako regułę.
- Wybierz typ reguły.
- Skonfiguruj ograniczenia dla wybranego typu reguły.
Definiowanie klas komponentów
Podobnie klasy komponentów można definiować na schemacie, dodając parametr ClassName do wybranych komponentów i ustawiając jego wartość na żądaną nazwę klasy. Podczas przenoszenia projektu na PCB zostaną utworzone zdefiniowane klasy komponentów.
Aby klasy komponentów zdefiniowane na schemacie zostały przeniesione na PCB, w oknie dialogowym Project Options należy ustawić następujące opcje:
- Włącz opcję Generate Component Classes znajdującą się w sekcji User-Defined Classes na karcie Generowanie klas tego okna dialogowego.
-
Na karcie Komparator tego okna dialogowego ustaw opcję Differences Associated with Components » Extra Component Classes Mode na
Find Differences.
Wymienioną powyżej opcję karty Class Generation przedstawiono na poniższym obrazie. Najedź kursorem na obraz, aby zobaczyć ustawienie opcji karty Comparator .

Aby przenieść klasy komponentów na PCB, włącz opcję Generate Component Classes na karcie Class Generation. Najedź kursorem na obraz, aby wyświetlić kartę Comparator, na której należy ustawić opcję Extra Component Classes Mode na Find Differences.
Po zdefiniowaniu klasy można zablokować w sekcji Properties panelu Properties właściwości danego komponentu.
Sterowanie drukowaniem dyrektyw
Domyślnie wszystkie dyrektywy projektowe są uwzględniane na wydrukach arkuszy schematu. Można to jednak zmienić:
- W oknie dialogowym Właściwości wydruku schematu, podczas drukowania bezpośrednio ze schematu lub w ramach wyjścia skonfigurowanego w pliku konfiguracji zadań wyjściowych.
- W sekcji Schematics include na stronie Additional PDF Settings kreatora Smart PDF.

Dostosuj drukowanie dyrektyw do swoich potrzeb. W przypadku dyrektyw No ERC możesz drukować wybrane style symboli, a pozostałe pomijać.




).

).