Altium Designer Documentation

Creating a New Component in Altium Designer

Created: 07.06.2022 | Updated: 02.09.2022

Parent page: Building & Maintaining Your Components and Libraries

The real-world component that gets mounted on the board is represented as a schematic symbol during design capture, and as a PCB footprint for board design (optionally, with a 3D model for visualization, 3D clearance checking, and export to the mechanical CAD domain). A design component can also include a simulation model for the circuit simulator, an IBIS model for signal integrity analysis. To provide a representation of design components to a wider product development arena, one or more Part Choices can be added to it.

Components for your PCB design project can be created in and placed from your company's Workspace library. These components are placed through the Components panel that uses Altium Designer's advanced component search engine.

A new Workspace library component is created using the Component Editor where you can define all component data (domain models, parameters, part choices, etc.) manually, or use data acquired from the Manufacturer Part Search panel.

To create a new Workspace library component:

  1. Select the File » New » Component command from the main menus. Alternatively, select File » New » Library from the main menus, then in the New Library dialog that opens, select Create Library Content » Component from the Workspace region of the dialog.
  2. In the Create new component dialog that opens, choose a component type. If there is a component template linked to the selected component type, this template will be used to predefine the component with the data from it.

    • If a component type is referenced by multiple Component Templates, these Templates will be presented under the entry of this component type.
    • If a Component Template has no default component type defined, it will be presented under the <Undefined> entry of the Create new component dialog.
    When connected to an Altium 365 Workspace, note that Component Templates are not supported with the Altium Designer Standard Subscription.

    Access the Create new component dialog to select a component type of the component to be created.
    Access the Create new component dialog to select a component type of the component to be created.

  3. After clicking OK, the Component Editor in its Single Component Editing mode opens. It provides a streamlined interface when defining/editing a single component.
  4. Define the component by adding its details in the Component Editor:

    1. In the Component region of the Component Editor, define the component's Name and Description. These details are essential for further component search when it comes to use a needed component in your PCB design project.
    2. Click the Advanced Settings control to define or change some other component details such as the component's Id used for the saved component in the Workspace and Folder in the target Workspace where the component will be saved.

    3. In the Parameters region of the Component Editor, define further component details: standard parameters, URL links to website pages (for example, a manufacturer's website), and links to datasheets (in any format).

    4. In the Part Choices region of the Component Editor, specify one or more Part Choices for the component – the 'allowed' manufacturer parts that can be used to implement the component on the assembled board.

    5. In the Models region of the Component Editor, add links to saved (or created on-the-fly) domain models, for use by the component. A component can have one schematic symbol and multiple PCB footprint and simulation models. A component must have at least one model.

      ► Learn more about Creating a Schematic Symbol

      ► Learn more about Creating a PCB Footprint

  5. Verify the defined component to make sure that this component meets the requirements in accordance with the settings on the Data Management – Component Rule Checks page of the Preferences dialog. Save your component locally (File » Save) then choose the Tools » Component Rule Check command from the main menus. Any violations that are found are listed in the Messages panel.
  6. With the component defined, select the File » Save to Server command from the main menus to save the component to the Workspace. The Edit Revision dialog will appear, in which you can change Name and Description, and add release notes as required. The editor will close after the save.

Your new component will be available to browse for and work with, through the Components panel.

Notes

  • To create a new component similar to an existing component in your Workspace, you can clone this component. In the Components panel, browse to a required component, right-click on it, and select the Operations » Clone command. The Component Editor will open with the component predefined with data from the chosen component.
  • A component can be defined using data provided by the Manufacturer Part Search functionality. Start typing in the Name field and select a matching manufacturer part or add a part choice to the component being defined, and the Use Component Data dialog will open providing controls for selecting data you would like to apply to the component being currently created/edited: name, description, parameters, models, and datasheets.

    Component data can be acquired from manufacturer part search. Shown here is an example of accessing the functionality by typing a component name in the Name field and selecting a matching entry from the pop-up list.
    Component data can be acquired from manufacturer part search. Shown here is an example of accessing the functionality by typing a component name in the Name field and selecting a matching entry from the pop-up list.

  • The Component Editor can also operate in its Batch Component Editing mode which provides the interface for defining/editing multiple components. With the Component Editor in its Single Component Editing mode, access to batch editing mode is made by choosing the Tools » Switch to Batch Editor command, from the Editor's main menus.
  • Altium Designer provides a streamlined and highly automated process to quickly import your existing libraries, relating to older component management methodologies (SchLib, PcbLib, IntLib, DbLib, SVNDbLib), to that Workspace. The interface to this process – the Library Importer – presents a one-click solution that automatically analyses the selected libraries and imports them to the Workspace to which you are actively connected.
  • A new component can also be created by right-clicking on the entry of the connected Workspace in the Projects panel and choosing the Create Component command from the menu.
Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

We're sorry to hear the article wasn't helpful to you.
Could you take a moment to tell us why?
200 characters remaining
Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе: