Создание и сопровождение ваших компонентов и библиотек
Электронный проект — это совокупность соединённых между собой компонентов. Самая увлекательная часть разработки продукта — находить интересные способы решения инженерных задач и соединять компоненты, создавая свой уникальный проект.
Однако значительную часть работы, которую многие разработчики считают более рутинной, составляет создание компонентов. Хотя этот процесс может быть не слишком увлекательным, компоненты становятся ценным ресурсом вашей компании, поэтому крайне важно, чтобы они точно представляли реальные изделия.
Компонент, который вы покупаете и припаиваете к плате или используете в кабельном жгуте, — это реальное изделие. Но для его использования в каждой из областей электронного проектирования необходимо создать соответствующую модель.
В зависимости от планируемых задач проектирования компонент может включать условное графическое обозначение для принципиальной схемы, модель для симулятора электрических цепей, модель IBIS для анализа целостности сигналов, посадочное место для проектирования печатной платы, а также 3D-модель для визуализации, проверки зазоров в 3D и экспорта в механическую САПР.
Управление компонентами
Эффективное управление данными компонентов необходимо для электронного проектирования, а управление компонентами, используемыми в проекте, всегда было одним из ключевых элементов программного обеспечения Altium. За годы развития программного обеспечения подходы к управлению компонентами прошли долгий путь: от простых отдельных библиотек моделей для схем и печатных плат через библиотеки баз данных до компонентов рабочего пространства, которые позволяют использовать данные компонентов в более широком контексте разработки продукта и предоставляют современные, удобные функции для эффективной совместной работы на протяжении всего процесса проектирования.
| Библиотека рабочего пространства | Компоненты хранятся в подключённом рабочем пространстве, которое служит единым источником актуальных и стандартизированных данных компонентов для всей команды разработчиков. Параметрический и фасетный поиск позволяют быстро и эффективно находить и размещать нужные компоненты. Эти компоненты тесно связаны с реальными изделиями производителей и данными цепочки поставок, доступными во время проектирования, что позволяет значительно сократить затраты и время на закупку при изготовлении готового изделия. |
|
| Библиотека базы данных | Хотите тесно связать компоненты проекта с базой данных вашей компании? Тогда рассмотрите библиотеки баз данных. Каждая запись представляет собой компонент и содержит ссылки на необходимые модели и параметрические данные компонента. При размещении к условному обозначению добавляются ссылки на модели и параметры, превращая его в компонент Altium Designer. | |
| Библиотека базы данных SVN | Библиотека базы данных SVN расширяет модель библиотеки базы данных: её отличие заключается в том, что исходное условное обозначение и модели хранятся под управлением системы контроля версий. Исходные библиотеки создаются, пополняются и поддерживаются в репозитории на базе Subversion. Ссылки на репозиторий и внешнюю базу данных задаются в файле библиотеки базы данных SVN (*.SVNDbLib). |
|
| Связь с базой данных | При использовании этого метода файл связи с базой данных (*.DbLink) задаёт связь между компонентом схемы и соответствующей записью в базе данных. Соответствие устанавливается по ключевым полям: это может быть одно ключевое поле (например, номер детали) или несколько ключевых полей (путём задания условия WHERE). |
|
| Интегрированная библиотека | Предпочитаете хранить предварительно собранные и проверенные компоненты в одном файле? Тогда скомпилируйте исходные модели для схем, печатных плат и моделирования, чтобы создать интегрированную библиотеку (*.IntLib). |
|
| Библиотека схем | Библиотека схем (*.SchLib) может быть библиотекой моделей, содержащей условные обозначения компонентов. Если же к каждому обозначению добавить ссылки на модели и параметрические данные, она становится библиотекой компонентов. |
|
| Библиотека печатных плат | Библиотека для хранения моделей посадочных мест компонентов печатной платы (*.PcbLib). При необходимости к каждому посадочному месту можно добавить 3D-модель. 3D-модели создаются из объектов 3D-тел или путём импорта модели STEP в объект 3D-тела. |
Библиотека рабочего пространства
Компоненты хранятся в вашем рабочем пространстве — едином централизованном защищённом хранилище всех проектных данных, доступном всей команде разработчиков. Использование компонентов, размещённых в рабочем пространстве, даёт множество преимуществ. Вот некоторые из них:
-
Single source of component data — благодаря рабочему пространству, доступному всей команде, инженеры могут получать актуальные и стандартизированные компоненты из единого защищённого источника, получать данные цепочки поставок в реальном времени и использовать параметрический и фасетный поиск для поиска именно тех компонентов, которые им нужны.
-
Design-time choice of physical components — для каждого компонента можно выбрать изделия производителей, которые допустимо использовать для его реализации при сборке платы.
-
Real-time supply-chain information — данные поступают из сводной базы данных компонентов Altium Parts Provider (которая, в свою очередь, взаимодействует с подключёнными поставщиками и собирает сведения об их компонентах), чтобы разработчик знал текущие цены и наличие выбранных изделий у всех поставщиков, которые их продают (согласно локальному каталогу компонентов рабочего пространства). Эти сведения можно добавить к компоненту в любой момент, в том числе после его сохранения в рабочем пространстве, — без непосредственного редактирования компонента и, следовательно, без влияния на проекты, где он уже используется, — а затем использовать в составе спецификации.
-
Concurrent editing of the library — поскольку библиотека рабочего пространства по сути представляет собой набор объектов компонентов, размещённых в этом рабочем пространстве, несколько пользователей могут независимо редактировать или создавать новые компоненты для библиотеки, не дожидаясь завершения работы других пользователей.
-
Component Models Reuse — компонент можно представить как «контейнер», в котором хранится вся параметрическая информация и модели для различных областей проектирования, включая условное обозначение на схеме, посадочные места на печатной плате, модели для разводки кабельных жгутов и моделирования. Компонент содержит не сами модели, а ссылки на соответствующие объекты моделей, которые также находятся в рабочем пространстве, поэтому одна модель может использоваться несколькими компонентами. При изменении модели вам будет предложено обновить все компоненты, которые её используют, чтобы ни один компонент не использовал устаревшую модель.
-
Direct Component Editing — если компонент требуется изменить, его можно открыть для редактирования непосредственно из рабочего пространства. Временный экземпляр редактора компонентов позволяет редактировать любые свойства компонента, в том числе изменять связанные с ним модели для различных областей проектирования, без работы с файловыми документами.
-
Use of Component Templates — применяйте шаблоны, основанные на параметрах и классификации компонентов, чтобы каждый новый тип компонента автоматически получал правильный набор параметров для спецификации, а также корректные схемы именования, ревизий и жизненного цикла.
-
Component Lifecycle Validation — если компонент находится в состоянии «окончание жизненного цикла», «устарел» или «снят с производства», вы получите предупреждение до начала изготовления плат, в которых он используется.
-
Where-used Component Traceability — можно проследить все случаи использования компонентов: если изделие устарело, вы можете узнать, в каких проектах оно использовалось, и определить, какие из них необходимо обновить. Если в условном обозначении или посадочном месте есть ошибка, вы можете найти все компоненты, использующие это обозначение или посадочное место, и исправить их.
-
Requests of new components — инженер может отправлять запросы на создание новых или отсутствующих компонентов специалистам по ведению библиотек и получать уведомления, когда компонент становится доступен для использования в проектах как автору запроса, так и другим инженерам компании.
Создание нового компонента библиотеки рабочего пространства
Реальный компонент, устанавливаемый на плату или используемый при изготовлении кабельного жгута, при разработке схемы представлен условным графическим обозначением, а при проектировании платы — посадочным местом (при необходимости с 3D-моделью для визуализации, проверки зазоров в 3D и экспорта в механическую САПР). Компонент проекта также может включать модель для моделирования схемы и IBIS-модель для анализа целостности сигналов. Чтобы представить компонент проекта в более широком контексте разработки изделия, к нему можно добавить один или несколько вариантов выбора комплектующих.
Компоненты для вашего проекта можно создавать и размещать в библиотеке рабочего пространства вашей компании. Они размещаются через панель Components, которая использует расширенную систему поиска компонентов Altium Designer.
Новый компонент библиотеки рабочего пространства создается в редакторе компонентов, где можно вручную задать все данные компонента (модели для различных областей проектирования, параметры, варианты выбора комплектующих и т. д.) или использовать данные, полученные из панели Manufacturer Part Search.
Чтобы создать новый компонент библиотеки рабочего пространства:
-
Выберите команду создания компонента. Она доступна следующими способами:
-
Выберите команду File » New » Component в главном меню.
-
Выберите File » New » Library в главном меню, затем в открывшемся диалоговом окне New Library выберите Create Library Content » Component в области Workspace этого окна.
-
На панели Components щелкните правой кнопкой мыши в области списка компонентов и выберите команду Create в контекстном меню.
-
-
В открывшемся диалоговом окне Create new component выберите тип компонента. Если с выбранным типом компонента связан шаблон компонента, его данные будут использованы для предварительного заполнения компонента.

Откройте диалоговое окно Create new component, чтобы выбрать тип создаваемого компонента. -
После нажатия OK откроется редактор компонентов в режиме редактирования одного компонента. Он предоставляет упрощенный интерфейс для задания и редактирования одного компонента.
-
Задайте компонент, добавив его сведения в редакторе компонентов:
- В области Component редактора компонентов задайте Name и Description компонента. Эти сведения необходимы для дальнейшего поиска нужного компонента при его использовании в вашем проекте.
-
Нажмите элемент управления Advanced Settings, чтобы задать или изменить другие сведения о компоненте, например Id, используемый для сохраненного компонента в рабочем пространстве, и Folder в целевом рабочем пространстве, где будет сохранен компонент.
-
В области Parameters редактора компонентов задайте дополнительные сведения о компоненте: стандартные параметры, URL-ссылки на веб-страницы (например, сайт производителя) и ссылки на техническую документацию (в любом формате).
-
В области Part Choices редактора компонентов укажите один или несколько вариантов выбора комплектующих для компонента — «разрешенных» изделий производителей, которые можно использовать для реализации компонента на собранной плате.
-
В области Models редактора компонентов добавьте ссылки на сохраненные (или создаваемые на лету) модели для различных областей проектирования, используемые компонентом. Компонент может иметь одно условное графическое обозначение и несколько моделей посадочных мест и моделей для моделирования либо одну модель соединений кабельного жгута. У компонента должна быть как минимум одна модель.
-
Проверьте заданный компонент, чтобы убедиться, что он соответствует требованиям согласно настройкам на странице Data Management – Component Rule Checks диалогового окна Preferences. Сохраните компонент локально (File » Save), затем выберите команду Tools » Component Rule Check в главном меню. Все обнаруженные нарушения будут перечислены на панели Messages.
-
После задания компонента выберите команду File » Save to Server в главном меню, чтобы сохранить компонент в рабочем пространстве. Появится диалоговое окно Edit Revision, в котором можно изменить имя и описание, а также при необходимости добавить примечания к выпуску. После сохранения редактор закроется.
Новый компонент будет доступен для поиска и использования на панели Components.
Примечания
-
Чтобы создать новый компонент, похожий на существующий компонент в вашем рабочем пространстве, можно сделать копию этого компонента. На панели Components найдите нужный компонент, щелкните по нему правой кнопкой мыши и выберите команду Operations » Make a copy. Откроется редактор компонентов с данными, предварительно заполненными на основе выбранного компонента.
-
Компонент можно определить с помощью данных, предоставляемых функцией поиска компонентов производителей (Manufacturer Part Search). Начните вводить текст в поле Name и выберите подходящий компонент производителя либо добавьте вариант компонента к определяемому компоненту. Откроется диалоговое окно Use Component Data с элементами управления для выбора данных, которые вы хотите применить к создаваемому или редактируемому компоненту: имени, описания, параметров, моделей и технической документации.

Данные компонента можно получить с помощью поиска компонентов производителей. Здесь показан пример использования этой функции: ввод имени компонента в поле Name и выбор подходящей записи из всплывающего списка. -
Редактор компонентов также может работать в режиме пакетного редактирования компонентов, который предоставляет интерфейс для определения и редактирования нескольких компонентов. Когда редактор компонентов находится в режиме Single Component Editing, перейти в режим пакетного редактирования можно, выбрав команду Tools » Switch to Batch Editor в главном меню редактора.
-
Для быстрого импорта существующих файловых библиотек и библиотек баз данных (SchLib, PcbLib, IntLib, DbLib, SVNDbLib) в рабочее пространство можно использовать Library Importer. Library Importer позволяет выполнить импорт одним щелчком: он автоматически анализирует выбранные библиотеки и импортирует их в рабочее пространство, к которому вы подключены.
-
Новый компонент также можно создать, щелкнув правой кнопкой мыши запись подключенного рабочего пространства на панели Projects и выбрав в меню команду Create Component.
-
Чтобы отредактировать компонент рабочего пространства, щелкните правой кнопкой мыши запись компонента на панели Components и выберите команду Edit в контекстном меню. Откроется редактор компонентов в режиме Single Component Editing с определением компонента, доступным для редактирования. Внесите необходимые изменения, затем сохраните определение компонента в следующую ревизию компонента рабочего пространства.
-
Аналогичным образом можно выбрать несколько компонентов на панели Components и выбрать команду Edit в контекстном меню. Если выбранные компоненты ссылаются на один и тот же шаблон компонента, откроется один экземпляр редактора компонентов в режиме пакетного редактирования компонентов. В противном случае для каждой группы компонентов, использующих один и тот же шаблон компонента, откроется отдельный экземпляр редактора компонентов.
-
Компоненты рабочего пространства, открытые для редактирования, отображаются под записью Workspace Components на панели Projects.
Из контекстного меню записи Workspace Component можно открыть компоненты группы, закрыть их, сохранить локально, сохранить в подключенное рабочее пространство или отменить изменения (закрыть без изменений)
. При использовании команды Close All, если в группе изменено несколько компонентов, появится диалоговое окно подтверждения сохранения с вариантами действий, применимыми к объекту рабочего пространства, открытому для редактирования
-
Если пользователь с правами только на просмотр попытается открыть компонент рабочего пространства для редактирования, откроется редактор компонентов, позволяющий просматривать сведения о компоненте, но не сохранять изменения в рабочее пространство. В этом случае запись компонента рабочего пространства на панели Projects отображается с меткой Local Edits Only
-
При сохранении отредактированного компонента в библиотеку рабочего пространства можно сохранить его текущее состояние жизненного цикла. Для этого служит параметр Preserve lifecycle state (not recommended), доступный в диалоговом окне Edit Revision при повторном сохранении (показать изображение). Если он включен, новой ревизии компонента автоматически назначается состояние жизненного цикла предыдущей ревизии. Эта возможность доступна пользователям, которым назначено разрешение на операцию Allow to skip lifecycle state change for new revisions (подробнее см. Настройка глобальных разрешений на операции для рабочего пространства).
Библиотеки баз данных
Altium Designer позволяет размещать компоненты непосредственно из базы данных компании, создав и используя Database Library. Размещение выполняется с панели Components, которая после установки библиотеки базы данных служит средством просмотра вашей базы данных.
После размещения информацию о параметрах проекта можно синхронизировать между размещенными компонентами и соответствующими связанными записями в базе данных. Можно выполнять полное обновление компонентов, включая графическое условное обозначение, ссылки на модели и параметры. Информацию о параметрах из базы данных также можно включить в итоговую спецификацию (BOM), подготовленную для закупки компонентов.
Подробнее см. Библиотеки баз данных.
Файловые библиотеки
Если вам необходимо хранить компоненты локально, в файловой системе, их можно организовать в файловые библиотеки.
Файловая библиотека Altium Designer — это произвольный набор моделей или компонентов. Способ организации моделей или компонентов в библиотеки вы выбираете сами. Можно структурировать библиотеки по поставщикам устройств или сгруппировать компоненты по функциям, например создать библиотеку всех микроконтроллеров, используемых в вашей компании.
Условные обозначения компонентов схемы создаются в библиотеках схем (*.SchLib). Компоненты этих библиотек ссылаются на посадочные места и другие модели, определенные в отдельных библиотеках посадочных мест (*.PcbLib) и файлах моделей. Как разработчик, вы можете размещать компоненты из этих отдельных библиотек компонентов либо компилировать библиотеки условных обозначений, библиотеки посадочных мест и файлы моделей в интегрированные библиотеки (*.IntLib).
Подробнее см. Файловые библиотеки компонентов.
Модели
С точки зрения разработчика компонент объединяет в одном объекте всю информацию, необходимую для его представления во всех областях проектирования. Поэтому в этом отношении его можно рассматривать как контейнер.
Каждый компонент представляет собой набор связанных моделей и параметрических данных компонента. Именно модели содержат подробную информацию, необходимую для каждой области проектирования.
Можно использовать следующие типы моделей:
| Условное обозначение на схеме | Условное обозначение представляет компонент на листе схемы. Оно создается с помощью стандартных графических объектов, а выводы добавляют электрические свойства. |
| Модель SPICE | Моделируйте поведение соединенных компонентов с помощью симулятора SPICE. Модели SPICE обычно предоставляются поставщиками устройств. |
| Модель целостности сигналов | По мере увеличения скорости переключения устройств и схем межсоединения на печатной плате становятся частью электрической цепи. Модели IBIS описывают поведение выводов, позволяя симулятору целостности сигналов Altium Designer анализировать трассы. |
| Посадочное место на печатной плате | Для каждого компонента необходимо определить место на печатной плате, где он будет установлен и подключен. Посадочное место — это модель, определяющая эту область платы. Посадочное место создается из набора стандартных объектов, а контактные площадки обеспечивают электрическое соединение. |
| 3D-модель | Современное электронное изделие компактно, имеет плотную компоновку и необычную форму, а его печатная плата вполне может быть сложена, чтобы поместиться в корпус. Для проектирования такого изделия необходимо иметь возможность моделировать печатную плату в 3D — это позволяет визуализировать готовую плату, выполнять трехмерную проверку зазоров и передавать плату с установленными компонентами в механическую САПР. Для этого вам понадобится 3D-модель каждого компонента. |
Узнайте о создании и управлении условными графическими обозначениями, моделями посадочных мест, моделями для моделирования и 3D-моделями в вашем рабочем пространстве.
Панель Components
Панель Components обеспечивает прямой доступ ко всем доступным компонентам в Altium Designer, включая компоненты рабочего пространства, библиотек баз данных и файловых библиотек.
Панель получает компоненты из рабочего пространства, а также из всех открытых или установленных файлов библиотек. Она предоставляет подробную информацию о выбранном компоненте (параметры, модели, варианты деталей, данные поставщиков и т. д.), позволяет сравнивать компоненты, а для компонентов рабочего пространства — выполнять параметрический поиск с использованием фильтров для задания требуемых параметров. Благодаря контекстным динамическим фильтрам поиск на панели позволяет быстро найти именно ту деталь, которая вам нужна, в подключенном рабочем пространстве вашей компании.
Узнайте о панели Components.
Панель Manufacturer Part Search
Вы также можете искать реально выпускаемые детали с помощью панели Manufacturer Part Search, которая использует базовые функции поискового механизма и представление, применяемые на панели Components. Выбранную деталь производителя можно использовать как основу для нового компонента в подключенном рабочем пространстве, а ее параметры и техническую документацию можно добавить к размещенному компоненту.
Значок
в записи детали означает, что этому компоненту назначены модели (условные графические обозначения, посадочные места печатной платы, модели для моделирования). При создании нового компонента на основе этой детали производителя ее модели также будут получены. Кроме того, вы можете скачать эту деталь локально или разместить ее непосредственно на схеме.
Узнайте о панели Manufacturer Part Search.
Что дальше?
Создание условного графического обозначения
Создание посадочного места печатной платы
Создание компонента схемы соединений жгута
Работа с шаблонами и библиотеками контактных площадок и переходных отверстий



).
).



