Altium Designer Documentation

Create Project (File Menu)

Последнее изменение: Tiffany Cullen; 05.05.2020


The Create Project dialog

Summary

The Create Project dialog is used to create a new project. Every design starts with a project file that stores project level settings, such as links to each of the design documents within that project. As well as creating the new project file on the hard drive, this dialog supports adding the new project to version control or creating it as a managed project in your server or workspace.

The new project can be created:

  • As a managed project in an Altium Designer workspace.
  • As a managed project in a self-managed server.
  • In your version control system with a working copy in your preferred location.
  • In a folder on the local hard drive.

Access

The dialog is accessed by choosing File » New » Project from the main menus.

Options/Controls

Locations – this section allows you to choose the location of the project you want to open. The rightmost pane will display projects within the chosen location. 

Select the target location of the project.

The Create Project dialog when no workspace has been activated.

  • Activate Workspace - use to open the Activate section of the Altium 365 Intro guide, from which you may activate an already existing workspace.

The Create Project dialog when not signed in on the left and when signed in to a managed content server on the right. 

If you are not currently signed in to your server, do so by clicking the corresponding button for the server in the main area of the dialog. All known self-managed servers will be listed in which you will be prompted to sign in using your server credentials unless Sign in Automatically has been enabled from your Sign In dialog. Alternatively, you can sign in to a different server using the Custom button. Remember that while it is possible to have connections to different servers (these are listed as Known Servers), you can only be actively signed into one managed content server through the software at a time. You can check which servers you are connected to from the Data Management - Servers page of the Preferences dialog. 
  • Project Type - use to select the type and template of the project. All available templates are listed.
  • Project Name - a default name appears; enter a meaningful name for the project.
  • Description - enter a meaningful description of the project.
  • Enable Formal Version Control - allows multiple contributors to work on this project - enable this option to allow version control. 
  • Folder - enter a name for the folder of this project in the repository. Use  to open the Choose Folder dialog in which you can navigate to and select the desired folder within the repository.  
  • Local Storage - use  to open a dialog in which you can browse to and select the desired local storage location.
  • Parameters - use this region to add custom Parameters to the project as the project is being created. Project Parameters for a managed project are read-only and can be accessed on the Server Parameters tab of the Project Options dialog (Project » Project Options).
    • Name - the name of the parameter.
    • Value - the parameter's value.
    • Add - click to add a parameter.
    •  - click to delete the selected parameter(s).

The Create Project dialog when creating a project under Version Control

  • Project Type - use to select the type and template of the project. All available templates are listed.
  • Project Name - a default name appears; enter a meaningful name for the project.
  • Repository - use the drop-down to display the connected repositories defined in the Data Management - Design Repositories page of the Preferences dialog. Click  to open the Preferences dialog from where you can connect to a repository.
  • Repository Folder - enter a name for the folder of this project in the repository. Use  to open the Choose Folder dialog in which you can navigate to and select the desired folder within the repository.  
  • Local Storage - use  to open a dialog in which you can browse to and select the desired local storage location.
  • Parameters - use this region to add custom Parameters to the project as the project is being created. Project Parameters for a version-controlled project can be accessed on the  Parameters tab of the Project Options dialog (Project » Project Options).
    • Name - the name of the parameter.
    • Value - the parameter's value.
    • Add - click to add a parameter.
    •  - click to delete the selected parameter(s).

The Create Project dialog when creating a Local Project 

  • Project Type - use to select the type and template of the project. All available templates are listed.
  • Project Name - a default name appears; enter a meaningful name for the project.
  • Folder - a default name appears; enter a meaningful name for the project. Use  to open a dialog in which you can browse to and select the desired local folder.
  • Parameters - use this region to add custom Parameters to the project as the project is being created. Project Parameters for a local project can be accessed on the Parameters tab of the Project Options dialog (Project » Project Options).
    • Name - the name of the parameter.
    • Value - the parameter's value.
    • Add - click to add a parameter.
    •  - click to delete the selected parameter(s).

Additional Controls

  • Create - click to create and save the project and associated files. The new project will be listed in the Projects panel.
When you click Create for a version-controlled or managed project, it will be added to the specified folder within the target repository then checked out to the local working folder defined in the Local Storage field. 
Обнаружили проблему в этом документе? Выделите область и нажмите Ctrl+Enter, чтобы оповестить нас.

Связаться с нами

Связаться с нашими Представительствами напрямую

Вы сообщаете о проблеме, связанной со следующим выделенным текстом
и/или изображением в активном документе:
Бесплатная пробная версия Altium Designer
Бесплатная пробная версия Altium Designer
Давайте приступим. Для начала, Вы или Ваше предприятие уже используете Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

В таком случае, для чего Вам необходима пробная лицензия?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вам для этого не нужна пробная лицензия.

Нажмите кнопку ниже, чтобы загрузить установщик самой новой версии Altium Designer

Загрузить установщик Altium Designer

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Пожалуйста, заполните форму ниже, чтобы получить ценовое предложение.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Если Ваша подписка Altium активна, у Вас нет необходимости в пробной лицензии.

Если у Вас нет активной подписки Altium, пожалуйста, заполните форму ниже, чтобы получить пробную версию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Для чего Вы хотите попробовать Altium Designer?

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы нашли нужное место! Пожалуйста, заполните форму ниже, чтобы начать использование пробной версии.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Great News!

Valid students can get their very own 6-month Altium Designer Student License for FREE! Just fill out the form below to request your Student License today.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.

Замечательно! Создавать новое - отличное занятие. У нас есть превосходная программа для Вас.

Upverter - бесплатная платформа, разработанная специально для любителей проектирования.

Нажмите здесь, чтобы попробовать!

Если Вы хотите поговорить с представителем, пожалуйста, свяжитесь с местным офисом Altium.
Copyright © 2019 Altium Limited

Вы можете загрузить бесплатную лицензию средства просмотра Altium Designer Viewer сроком действия 6 месяцев.

Пожалуйста, заполните форму ниже, чтобы запросить эту лицензию.

Нажимая [Получить бесплатнную пробную версию], Вы соглашаетесь с нашей Политикой конфиденциальности. Вам могут приходить сообщения от компании Altium, и Вы можете изменить настройки уведомлений в любой момент.