Làm việc với Keepout Cụ thể theo Đối tượng trên Bảng mạch
Sơ lược
- Hiểu vùng cấm theo loại đối tượng là gì, cách chúng hoạt động trong Altium Designer và những vị trí nên sử dụng chúng khi bố trí PCB.
- Tìm hiểu cách cấu hình vùng cấm để chỉ hạn chế một số loại đối tượng nhất định, giúp bạn kiểm soát linh hoạt hơn việc đi dây, bố trí đồng và sử dụng via.
- Nắm được các thao tác cơ bản để đặt và chỉnh sửa đối tượng vùng cấm, bao gồm vùng cấm dạng đường mạch và cung tròn, trong trình biên tập PCB và trình biên tập thư viện PCB.
Một Keepout trong thiết kế PCB là vùng hoặc đường bao do người dùng xác định, được đặt trong bố trí mạch mà các đối tượng đồng không được phép giao cắt. Thường được sử dụng để kiểm soát vùng dành cho các thao tác đặt đồng tự động, chẳng hạn như đổ đồng đa giác và đi dây tương tác, vùng cấm (Keepout) cũng là vị trí không hợp lệ khi đặt thủ công các đối tượng đồng.
Là các vùng “không được phép” được chỉ định trong quá trình bố trí thiết kế, các đối tượng Keepout sử dụng Quy tắc ràng buộc khoảng cách hiện có để kiểm soát việc đi dây và phát hiện vi phạm khi đặt đối tượng. Tuy nhiên, khác với các đối tượng được đặt khác, chúng không thể được gán cho một Net và không xuất hiện trong dữ liệu đầu ra hoặc bản in được tạo. Hiểu đơn giản nhất, Keepout đóng vai trò là đối tượng “cản trở”, ngăn các đối tượng đồng khác giao cắt với vùng của nó, theo quy định của Quy tắc khoảng cách toàn cục. Các đối tượng Keepout có thể được đặt trên lớp Keep-out (áp dụng cho tất cả các lớp tín hiệu), hoặc trên một lớp tín hiệu (chỉ áp dụng cho các đối tượng trên lớp đó).
Altium Designer cho phép tạo và áp dụng các vùng cấm thông qua khả năng hỗ trợ Object Specific Keepouts. Các đối tượng Keepout đã đặt có thể được cấu hình để chỉ định loại đối tượng chịu tác động, chẳng hạn như đường mạch, vùng đồng, via và pad, giúp tăng đáng kể tính linh hoạt và hiệu quả của vùng cấm.

Các đối tượng Keepout thuộc nhiều loại khác nhau được đặt trong thiết kế PCB.
Trong trình biên tập PCB và thư viện PCB, các đối tượng Keepout được hiển thị bằng họa tiết gạch chéo. Các đối tượng Keepout đặt trên lớp Keep-Out (tức là áp dụng cho tất cả các lớp tín hiệu) được hiển thị bằng màu của lớp Keep-Out, còn các vùng cấm đặt trên một lớp tín hiệu cụ thể (tức là chỉ áp dụng cho lớp tín hiệu đó) được hiển thị bằng màu của lớp tín hiệu tương ứng.
Vùng cấm rất phù hợp để xác định các vùng trên bo mạch không được phép đi dây (chẳng hạn như vùng nhạy cảm về điện hoặc vùng điện áp cao), các vị trí đồng cần để lộ như điểm chuẩn định vị và điểm kiểm tra, hoặc các vùng không phù hợp về mặt cơ khí (chẳng hạn như lỗ lắp hoặc các góc của PCB). Khả năng cấu hình của vùng cấm theo loại đối tượng cũng cho phép đặt chúng đè lên các đối tượng khác khi đã gán các Keepout Restrictions cụ thể. Ví dụ, khi được thiết lập để chỉ hạn chế via, một vùng cấm có thể được đặt đè lên các vùng đồng hiện có (chẳng hạn như Vùng đổ đồng đa giác) để kiểm soát phạm vi Khâu via tự động.
Có thể đặt vùng cấm theo loại đối tượng trong trình biên tập PCB và trình biên tập thư viện PCB.
Để biết thêm thông tin về cách đặt và chỉnh sửa các đối tượng vùng cấm trên PCB, hãy tham khảo các mục có thể thu gọn bên dưới:
Vùng cấm dạng đường mạch

Một vùng cấm dạng đường mạch đã được đặt
Đường mạch là một đối tượng thiết kế cơ bản. Ngoài đường mạch tiêu chuẩn được sử dụng cho các tác vụ thiết kế, còn có một loại đường mạch thứ hai, được gọi là vùng cấm dạng đường mạch. Có thể đặt vùng cấm dạng đường mạch dưới dạng đối tượng vùng cấm áp dụng cho một lớp cụ thể hoặc cho tất cả các lớp, chẳng hạn để làm rào cản khi đặt đối tượng hoặc đi dây. Điểm khác biệt giữa đường mạch tiêu chuẩn và vùng cấm dạng đường mạch là các vùng tô kiểu vùng cấm dành riêng cho từng lớp không được đưa vào dữ liệu đầu ra, chẳng hạn như Gerber hoặc ODB++. Vùng cấm được nhận diện bằng đường viền có màu Keepout.
Sau khi khởi chạy lệnh đặt vùng cấm dạng đường mạch, con trỏ sẽ chuyển thành dấu chữ thập và bạn sẽ vào chế độ đặt vùng cấm dạng đường mạch. Thực hiện việc đặt theo trình tự thao tác sau:
- Nhấp chuột hoặc nhấn Enter để cố định điểm bắt đầu của đoạn vùng cấm dạng đường mạch đầu tiên.
- Di chuyển con trỏ để xác định đoạn vùng cấm dạng đường mạch, sau đó nhấp chuột hoặc nhấn Enter để cố định điểm kết thúc của đoạn đầu tiên này, cũng là điểm bắt đầu của đoạn nối tiếp theo.
- Tiếp tục định vị con trỏ rồi nhấp chuột hoặc nhấn Enter để cố định một loạt đỉnh xác định chuỗi các đoạn vùng cấm dạng đường mạch nối tiếp nhau.
- Nhấp chuột phải hoặc nhấn Esc để kết thúc chuỗi các đoạn vùng cấm dạng đường mạch nối tiếp hiện tại.
Các thao tác bổ sung có thể thực hiện trong khi đặt bao gồm:
- Nhấn phím * trên bàn phím số để lần lượt chuyển qua các lớp tín hiệu khả dụng. Ngoài ra, sử dụng tổ hợp Shift+Ctrl+Wheel Roll để chuyển qua các lớp đi dây; mỗi nấc cuộn của con lăn chuột sẽ chuyển sang lớp tín hiệu khả dụng tiếp theo (hoặc trước đó).
- Nhấn các phím + và - trên bàn phím số để lần lượt chuyển tiến và lùi qua tất cả các lớp hiện đang hiển thị trong thiết kế.
Khi đặt các đoạn vùng cấm dạng đường mạch, có năm chế độ góc khả dụng, trong đó bốn chế độ còn có các chế độ phụ về hướng góc. Trong khi đặt:
- Nhấn Shift+Spacebar để lần lượt chuyển qua năm chế độ góc khả dụng.
- Nhấn Spacebar để chuyển đổi giữa hai chế độ phụ về hướng góc.
- Khi ở một trong các chế độ góc dạng cung, giữ phím , hoặc . để thu nhỏ hoặc mở rộng cung. Giữ phím Shift đồng thời để tăng tốc độ thay đổi kích thước cung.
- Nhấn phím tắt 1 để chuyển đổi giữa việc đặt một đoạn mỗi lần nhấp chuột hoặc hai đoạn mỗi lần nhấp chuột. Trong chế độ thứ nhất, đoạn đường mạch rỗng được gọi là đoạn xem trước.
- Nhấn phím Backspace để xóa đỉnh cuối cùng.
Phương pháp chỉnh sửa đồ họa cho phép bạn chọn trực tiếp một đối tượng vùng cấm dạng đường mạch đã đặt trong không gian thiết kế và thay đổi kích thước, hình dạng hoặc vị trí của nó bằng thao tác đồ họa.
Khi chọn một vùng cấm dạng đường mạch, các điểm điều khiển chỉnh sửa sau sẽ xuất hiện:
- Nhấp vào các điểm điều khiển ở hai đầu để định vị lại các điểm đầu cuối của đường mạch.
- Nhấp và kéo điểm điều khiển ở giữa để thay đổi hình dạng của đường mạch.
Thuộc tính vùng cấm dạng đường mạch

Chế độ Keepout - Track của bảng Properties.
Vị trí
-
(X/Y)
- X (trường thứ nhất) - tọa độ X (ngang) hiện tại của điểm tham chiếu của vùng cấm dạng đường mạch so với gốc tọa độ hiện tại. Chỉnh sửa để thay đổi vị trí X của vùng cấm dạng đường mạch. Có thể nhập giá trị theo hệ mét hoặc hệ inch; hãy kèm đơn vị khi nhập giá trị có đơn vị khác với đơn vị mặc định hiện tại.
- Y (trường thứ hai) - Tọa độ Y (dọc) hiện tại của điểm tham chiếu của vùng cấm dạng đường mạch so với gốc tọa độ hiện tại. Chỉnh sửa để thay đổi vị trí Y của vùng cấm dạng đường mạch. Có thể nhập giá trị theo hệ mét hoặc hệ inch; hãy kèm đơn vị khi nhập giá trị có đơn vị khác với đơn vị mặc định hiện tại.
Thuộc tính
- Component – trường này chỉ được hiển thị trong trình biên tập PCB khi vùng cấm dạng đường mạch được chọn là một phần cấu thành của linh kiện PCB, và hiển thị ký hiệu định danh của linh kiện PCB chứa nó. Chọn mục có thể nhấp Component liên kết để mở chế độ Component của bảng Properties cho linh kiện cha.
- Restricted for Layer - sử dụng danh sách thả xuống để chọn lớp bị hạn chế.
- Width - hiển thị độ rộng hiện tại của đoạn đường mạch cấm. Chỉnh sửa trường này để thay đổi độ rộng của đoạn đường mạch cấm trong phạm vi từ 0.001mil đến 10000mil.
- Start (X/Y) - hiển thị tọa độ X/Y hiện tại của điểm đầu đoạn đường mạch cấm so với gốc tọa độ hiện tại.
- End (X/Y) - hiển thị tọa độ X/Y hiện tại của điểm cuối đoạn đường mạch cấm, so với gốc tọa độ hiện tại.
- Length - hiển thị chiều dài hiện tại của đoạn đường mạch cấm. Chỉnh sửa trường này để thay đổi chiều dài của đoạn đường mạch cấm trong phạm vi từ 0.001mil đến 10000mil.
Các hạn chế của vùng cấm
Sử dụng khu vực này để chọn những loại đối tượng sẽ bị hạn chế bởi vùng cấm. Khi bỏ chọn một loại đối tượng, vùng cấm sẽ cho phép loại đối tượng đó xâm nhập (không bị ngăn cấm) bằng cách không áp dụng quy tắc khoảng hở tương ứng. Các lựa chọn bao gồm:
- Via
- Track
- Copper
- SMD Pad
- TH Pad
Cung tròn cấm

Hai cung tròn cấm trên lớp dưới cùng: bên trái là cung tròn cấm dạng đường tròn hoàn chỉnh; bên phải là cung tròn cấm được chọn để chỉnh sửa.
Cung tròn cấm là một đối tượng thiết kế cơ bản. Về bản chất, đây là một đoạn đường mạch hình cung tròn có thể đặt trên bất kỳ lớp nào. Ngoài cung tròn tiêu chuẩn được dùng cho các tác vụ thiết kế như xác định đường bao linh kiện hoặc đi dây cong, còn có một loại cung tròn thứ hai, được gọi là cung tròn cấm. Có thể đặt cung tròn cấm trên một lớp tín hiệu để tạo rào chắn hoặc vùng không được phép xâm nhập dành riêng cho lớp đó. Cũng có thể đặt chúng trên lớp Keepout, khi đó chúng sẽ áp dụng cho tất cả các lớp tín hiệu. Điểm khác biệt giữa cung tròn tiêu chuẩn và cung tròn cấm là các cung tròn cấm dành riêng cho từng lớp không được đưa vào dữ liệu đầu ra, chẳng hạn như Gerber hoặc ODB++. Cung tròn cấm được nhận biết bằng đường bao mang màu Keepout.
Cách đặt cung tròn phụ thuộc vào phương pháp đặt cụ thể mà bạn đã chọn. Có bốn phương pháp đặt cung tròn được hỗ trợ:
- Place arc by center – phương pháp này cho phép đặt đối tượng cung tròn bằng cách lấy tâm cung tròn làm điểm bắt đầu.
- Place arc by edge – phương pháp này cho phép đặt đối tượng cung tròn bằng cách lấy mép cung tròn làm điểm bắt đầu. Góc cung tròn được cố định ở 90°.
- Place arc by edge (any angle) – phương pháp này cho phép đặt đối tượng cung tròn bằng cách lấy mép cung tròn làm điểm bắt đầu. Góc cung tròn có thể là bất kỳ giá trị nào.
- Place full circle arc – phương pháp này cho phép đặt một cung tròn 360° (đường tròn hoàn chỉnh).
Placing a Keepout Arc Starting at the Center
Sau khi khởi chạy lệnh, con trỏ sẽ chuyển thành dấu chữ thập và bạn sẽ vào chế độ đặt cung tròn cấm. Thực hiện theo trình tự sau để đặt:
- Nhấp hoặc nhấn Enter để cố định tâm của cung tròn cấm.
- Di chuyển con trỏ để điều chỉnh bán kính của cung tròn cấm, sau đó nhấp hoặc nhấn Enter để xác lập bán kính.
- Di chuyển con trỏ để điều chỉnh điểm đầu của cung tròn cấm, sau đó nhấp hoặc nhấn Enter để cố định điểm đó.
- Di chuyển con trỏ để thay đổi vị trí điểm cuối của cung tròn cấm, sau đó nhấp hoặc nhấn Enter để cố định điểm đó và hoàn tất việc đặt cung tròn cấm.
- Tiếp tục đặt các cung tròn cấm khác hoặc nhấp chuột phải hoặc nhấn Esc để thoát chế độ đặt.
Placing a Keepout Arc Starting at the Edge
Sau khi khởi chạy lệnh, con trỏ sẽ chuyển thành dấu chữ thập và bạn sẽ vào chế độ đặt cung tròn cấm. Thực hiện theo trình tự sau để đặt:
- Nhấp hoặc nhấn Enter để cố định điểm đầu của cung tròn cấm.
- Di chuyển con trỏ để thay đổi vị trí điểm cuối của cung tròn cấm, sau đó nhấp hoặc nhấn Enter để cố định điểm đó và hoàn tất việc đặt cung tròn cấm.
- Tiếp tục đặt các cung tròn cấm khác hoặc nhấp chuột phải hoặc nhấn Esc để thoát chế độ đặt.
Placing a Keepout Arc Starting at the Edge (any angle)
Sau khi khởi chạy lệnh, con trỏ sẽ chuyển thành dấu chữ thập và bạn sẽ vào chế độ đặt cung tròn cấm. Thực hiện theo trình tự sau để đặt:
- Nhấp hoặc nhấn Enter để cố định điểm đầu của cung tròn cấm.
- Di chuyển con trỏ để điều chỉnh bán kính của cung tròn cấm, sau đó nhấp hoặc nhấn Enter để cố định tâm.
- Di chuyển con trỏ để thay đổi vị trí điểm cuối của cung tròn cấm, sau đó nhấp hoặc nhấn Enter để cố định điểm đó và hoàn tất việc đặt cung tròn cấm.
- Tiếp tục đặt các cung tròn cấm khác hoặc nhấp chuột phải hoặc nhấn Esc để thoát chế độ đặt.
Placing a Full Circle Keepout Arc
Sau khi khởi chạy lệnh, con trỏ sẽ chuyển thành dấu chữ thập và bạn sẽ vào chế độ đặt cung tròn cấm. Thực hiện theo trình tự sau để đặt:
- Nhấp hoặc nhấn Enter để cố định tâm của cung tròn cấm.
- Di chuyển con trỏ để điều chỉnh bán kính của cung tròn cấm, sau đó nhấp hoặc nhấn Enter để xác lập bán kính và hoàn tất việc đặt cung tròn cấm.
- Tiếp tục đặt các cung tròn cấm khác hoặc nhấp chuột phải hoặc nhấn Esc để thoát chế độ đặt.
Với tất cả các phương pháp (trừ cung tròn dạng đường tròn hoàn chỉnh), nhấn Spacebar trước khi xác định điểm cuối của cung tròn cấm để vẽ cung tròn theo hướng ngược lại.
Phương pháp chỉnh sửa đồ họa cho phép chọn trực tiếp một đối tượng cung tròn đã đặt trong không gian thiết kế và thay đổi kích thước, hình dạng hoặc vị trí của nó bằng thao tác đồ họa.
Khi một đối tượng cung tròn cấm được chọn, các điểm điều khiển chỉnh sửa sau sẽ xuất hiện:

Một cung tròn cấm được chọn
- Nhấp và kéo A để điều chỉnh bán kính.
- Nhấp và kéo B để điều chỉnh các điểm đầu và cuối (góc bắt đầu và góc kết thúc).
-
Nhấp vào bất kỳ vị trí nào trên cung tròn cách xa các điểm điều khiển chỉnh sửa, rồi kéo để di chuyển cung tròn. Ngoài ra, có thể nhấp và kéo tại tâm cung tròn. Trong khi kéo, có thể xoay hoặc lật đối xứng cung tròn:
- Nhấn Spacebar để xoay cung ngược chiều kim đồng hồ hoặc Shift+Spacebar để xoay theo chiều kim đồng hồ. Góc xoay tuân theo giá trị của Rotation Step được xác định trên trang PCB Editor – General trong hộp thoại Preferences.
- Nhấn phím X hoặc Y để lấy đối xứng cung qua trục X hoặc trục Y tương ứng.
Thuộc tính vùng cấm dạng cung

Chế độ Keepout - Arc của bảng Properties.
Vị trí
-
(X/Y)
- X (trường thứ nhất) - tọa độ X (ngang) hiện tại của điểm tham chiếu của vùng cấm dạng cung, so với gốc tọa độ hiện tại của không gian thiết kế. Chỉnh sửa để thay đổi vị trí X của vùng cấm dạng cung. Có thể nhập giá trị theo hệ mét hoặc hệ Anh; hãy kèm đơn vị khi nhập giá trị có đơn vị khác với đơn vị mặc định hiện tại.
- Y (trường thứ hai) - Tọa độ Y (dọc) hiện tại của điểm tham chiếu của vùng cấm dạng cung, so với gốc tọa độ hiện tại. Chỉnh sửa để thay đổi vị trí Y của vùng cấm dạng cung. Có thể nhập giá trị theo hệ mét hoặc hệ Anh; hãy kèm đơn vị khi nhập giá trị có đơn vị khác với đơn vị mặc định hiện tại.
Thuộc tính
- Component – trường này chỉ hiển thị trong trình biên tập PCB khi vùng cấm dạng cung được chọn là một phần cấu thành của linh kiện PCB và hiển thị ký hiệu định danh của linh kiện PCB mẹ. Chọn liên kết Component có thể nhấp để mở chế độ Component của bảng Properties cho linh kiện mẹ.
- Restricted Layer - trường này hiển thị lớp bị hạn chế mà vùng cấm dạng cung hiện được gán vào. Để thay đổi lớp, nhấp vào trường và chọn một lớp từ danh sách thả xuống.
- Width - trường này hiển thị độ rộng đường của vùng cấm dạng cung. Nhập giá trị độ rộng khác nếu cần.
- Radius - trường này hiển thị bán kính cung được đo từ tâm đến đường tâm của vùng cấm dạng cung. Nhập giá trị bán kính khác nếu cần.
- Start Angle - trường này hiển thị góc bắt đầu của vùng cấm dạng cung, được đo từ trục X trong góc phần tư thứ nhất (hình học phẳng). Nhập giá trị góc bắt đầu khác nếu cần.
- End Angle - trường này hiển thị góc kết thúc của vùng cấm dạng cung. Nhập giá trị góc kết thúc khác nếu cần.
Các hạn chế của vùng cấm
Sử dụng khu vực này để chọn loại đối tượng sẽ bị vùng cấm hạn chế. Bỏ chọn một loại đối tượng sẽ khiến vùng cấm cho phép loại đối tượng đó đi vào (không bị ngăn cản) bằng cách không áp dụng quy tắc khoảng cách tương ứng. Các lựa chọn bao gồm:
- Via
- Track
- Copper
- SMD Pad
- TH Pad
Vùng cấm dạng miền

Vùng cấm dạng miền
Vùng cấm dạng miền là một đối tượng thiết kế cơ bản. Ngoài miền tiêu chuẩn được sử dụng cho các tác vụ thiết kế, còn có một loại miền thứ hai, được gọi là vùng cấm dạng miền. Có thể đặt vùng cấm dạng miền làm đối tượng vùng cấm trên một lớp cụ thể hoặc trên tất cả các lớp, chẳng hạn để ngăn việc đặt linh kiện hoặc đi dây. Điểm khác biệt giữa miền tiêu chuẩn và miền vùng cấm là các vùng tô kiểu vùng cấm trên lớp cụ thể không được đưa vào dữ liệu đầu ra, chẳng hạn như Gerber hoặc ODB++. Miền vùng cấm được nhận biết bằng đường viền có màu Keepout.
Sau khi khởi chạy lệnh đặt vùng cấm dạng miền (Place » Keepout » Solid Region), con trỏ sẽ chuyển thành hình chữ thập và bạn sẽ vào chế độ đặt vùng cấm dạng miền. Thực hiện việc đặt theo trình tự sau:
- Định vị con trỏ rồi nhấp để cố định đỉnh bắt đầu của vùng cấm dạng miền.
- Di chuyển con trỏ để chuẩn bị đặt đỉnh thứ hai. Theo mặc định, mỗi lần nhấp sẽ đặt hai cạnh, với hình dạng góc do người dùng xác định giữa chúng.
- Tiếp tục di chuyển chuột và nhấp để đặt các đỉnh tiếp theo.
- Sau khi đặt đỉnh cuối cùng, nhấp chuột phải hoặc nhấn Esc để khép kín và hoàn tất việc đặt vùng cấm dạng miền. Không cần khép kín miền thủ công vì phần mềm sẽ tự động hoàn thiện hình dạng bằng cách nối điểm bắt đầu với điểm cuối cùng đã đặt.
- Tiếp tục đặt các vùng cấm dạng miền khác hoặc nhấp chuột phải hay nhấn Esc để thoát chế độ đặt.
Phương pháp chỉnh sửa bằng đồ họa cho phép bạn chọn trực tiếp một đối tượng đã đặt trong không gian thiết kế và thay đổi kích thước, hình dạng hoặc vị trí của đối tượng bằng thao tác đồ họa.

Vùng cấm dạng miền được chọn
Move Region Vertices
Vùng cấm dạng miền có hai loại điểm, hay “tay nắm”, để chỉnh sửa hình dạng miền.
- Full Handles - nằm tại các góc của vùng cấm dạng miền.
- Empty Handles - nằm ở giữa các đoạn được tạo bởi các tay nắm đặc.
Có thể thay đổi hình dạng của vùng cấm dạng miền hiện có bằng cách di chuyển các tay nắm, hay đỉnh, nằm tại mỗi góc hoặc ở giữa mỗi cạnh.
Để sửa đổi hình dạng vùng cấm dạng miền:
-
Nhấp và chọn một vùng cấm dạng miền để làm nổi bật các đỉnh của vùng cấm và đổi con trỏ thành hình chữ thập.
- Click trên một tay nắm đặc để di chuyển góc đó.
- Click dọc theo một cạnh để di chuyển toàn bộ cạnh.
- Click trên một tay nắm rỗng để di chuyển toàn bộ cạnh (đối với đường mạch và cung).
- Ctrl+Click trên một tay nắm rỗng để tách cạnh đó thành hai cạnh. Ctrl chỉ cần được giữ lúc bắt đầu di chuyển. Sau đó có thể dùng các phím tắt Shift+Spacebar để chuyển lần lượt giữa các chế độ (cung, vát góc và góc bất kỳ).
- Nếu chế độ đặt “góc bất kỳ” tạo ra các đỉnh không mong muốn, hoặc để loại bỏ các đỉnh thừa nói chung, hãy nhấp Ctrl và nắm lấy tay nắm đặc ở giữa. Biểu tượng X xuất hiện trên tay nắm và việc kéo cạnh sẽ giảm số đỉnh trên cạnh đó xuống còn một.
Modify Region Border
Ngoài chỉnh sửa đỉnh, bạn cũng có thể dùng lệnh Modify Region Border để dễ dàng thay đổi hình dạng của đa giác. Lệnh được chạy bằng cách nhấp chuột phải vào đa giác mong muốn rồi chọn Polygon Actions » Modify Polygon Border. Khi lệnh được khởi chạy, con trỏ trở thành hình chữ thập. Mỗi lần bạn nhấp, một đỉnh mới sẽ được thêm vào. Tương tự khi đặt vùng cấm dạng miền, có thể dùng các phím tắt Shift+Spacebar để thay đổi hình dạng góc.
Thuộc tính vùng cấm dạng miền

Chế độ Keepout - Region của bảng Properties.
Thuộc tính
- Component – trường này chỉ hiển thị trong trình biên tập PCB khi Region Keepout được chọn là một phần của linh kiện PCB và hiển thị ký hiệu định danh của linh kiện PCB mẹ. Chọn liên kết Component có thể nhấp để mở chế độ Component của bảng Properties cho linh kiện mẹ.
- Restricted for Layer - sử dụng danh sách thả xuống để chọn lớp chứa vùng cấm.
- Arc Approximation - nhập độ lệch tối đa so với một cung tròn lý tưởng.
- Area - tổng diện tích của đối tượng đã đặt.
- Locked (chỉ trong bảng Properties) - bật để khóa vùng cấm.
Các đỉnh đường bao
Khu vực này được dùng để chỉnh sửa từng đỉnh của đối tượng vùng đang được chọn. Bạn có thể thay đổi vị trí các đỉnh hiện có, thêm đỉnh mới hoặc xóa đỉnh theo nhu cầu. Có thể xác định các đoạn nối dạng cung giữa các đỉnh; đồng thời, bạn cũng có thể xuất thông tin đỉnh ra và nhập từ tệp định dạng CSV.
-
Vertices Grid - liệt kê tất cả các đỉnh hiện được xác định cho vùng theo các thông tin sau:
- Index - chỉ số được gán cho đỉnh (không thể chỉnh sửa).
- X - tọa độ X (ngang) của đỉnh. Nhấp để chỉnh sửa.
- Y - tọa độ Y (dọc) của đỉnh. Nhấp để chỉnh sửa.
- Arc Angle (Neg = CW) - góc của cung được vẽ để nối đỉnh này với đỉnh tiếp theo. Theo mặc định, các đoạn nối là cạnh thẳng và trường này được để trống. Nhấp để chỉnh sửa rồi nhập góc cung theo yêu cầu. Nhập giá trị dương sẽ tạo cung ngược chiều kim đồng hồ. Để vẽ cung theo chiều kim đồng hồ, hãy nhập giá trị âm.
-
Add - nhấp để thêm một đỉnh mới. Đỉnh mới sẽ được thêm bên dưới mục đỉnh đang được chọn để chỉnh sửa và ban đầu có cùng tọa độ X,Y với mục đó. Nhấp
để xóa đỉnh hiện đang được chọn.
Các hạn chế của vùng cấm
Sử dụng khu vực này để chọn những loại đối tượng bị hạn chế bởi vùng cấm. Khi bỏ chọn một loại đối tượng, vùng cấm sẽ cho phép loại đối tượng đó xâm nhập (không bị loại trừ) bằng cách không áp dụng quy tắc khoảng cách tương ứng. Các lựa chọn bao gồm:
- Via
- Track
- Copper
- SMD Pad
- TH Pad
Vùng cấm dạng Fill
Vùng cấm dạng Fill là một đối tượng thiết kế cơ bản có thể được đặt trên bất kỳ lớp nào. Ngoài đối tượng Fill tiêu chuẩn được dùng cho các tác vụ thiết kế như xác định đường bao linh kiện, còn có một loại Fill thứ hai được gọi là vùng cấm dạng Fill. Vùng cấm dạng Fill có thể được đặt dưới dạng đối tượng vùng cấm dành riêng cho một lớp hoặc vùng cấm trên tất cả các lớp, chẳng hạn để tạo rào cản khi đặt linh kiện hoặc đi dây. Điểm khác biệt giữa Fill tiêu chuẩn và Fill vùng cấm là các Fill vùng cấm dành riêng cho từng lớp không được đưa vào dữ liệu đầu ra, chẳng hạn như Gerber hoặc ODB++. Fill vùng cấm được nhận biết qua đường bao có màu Keepout.
Sau khi khởi chạy lệnh đặt vùng cấm dạng Fill, con trỏ sẽ chuyển thành dấu chữ thập và bạn sẽ vào chế độ đặt vùng cấm dạng Fill. Thực hiện theo trình tự sau để đặt:
- Nhấp hoặc nhấn Enter để cố định góc đầu tiên của vùng cấm dạng Fill.
- Di chuyển con trỏ để điều chỉnh kích thước vùng cấm dạng Fill rồi nhấp hoặc nhấn Enter để cố định góc đối diện theo đường chéo và hoàn tất việc đặt vùng cấm dạng Fill.
- Tiếp tục đặt các vùng cấm dạng Fill khác hoặc nhấp chuột phải hay nhấn Esc để thoát chế độ đặt.
Phương pháp chỉnh sửa bằng đồ họa cho phép bạn chọn trực tiếp một đối tượng đã đặt trong không gian thiết kế và thay đổi kích thước, hình dạng hoặc vị trí của đối tượng bằng thao tác đồ họa.
Khi chọn một đối tượng vùng cấm dạng Fill, các điểm điều khiển chỉnh sửa sau sẽ xuất hiện:

Một vùng cấm dạng Fill được chọn
- Nhấp, giữ và kéo các điểm điều khiển ở góc để thay đổi kích thước vùng cấm dạng Fill theo cả chiều dọc và chiều ngang cùng lúc.
- Nhấp, giữ và kéo các điểm điều khiển ở cạnh bên, cạnh trên và cạnh dưới để thay đổi kích thước vùng cấm dạng Fill riêng theo chiều dọc hoặc chiều ngang.
- Nhấp, giữ và kéo điểm điều khiển ở giữa để xoay vùng cấm dạng Fill quanh tâm.
-
Nhấp vào vị trí bất kỳ trên vùng cấm dạng Fill ngoài các điểm điều khiển chỉnh sửa rồi giữ và kéo để thay đổi vị trí. Trong khi kéo, bạn có thể xoay hoặc lật đối xứng vùng cấm dạng Fill:
- Nhấn Spacebar để xoay vùng cấm dạng Fill ngược chiều kim đồng hồ hoặc Shift+Spacebar để xoay theo chiều kim đồng hồ. Góc xoay tuân theo giá trị Rotation Step được xác định trên trang PCB Editor – General của hộp thoại Preferences.
- Nhấn phím X hoặc Y để lật đối xứng vùng cấm dạng Fill theo trục X hoặc trục Y.
Thuộc tính vùng cấm dạng Fill

Chế độ Keepout - Fill của bảng Properties.
Vị trí
-
(X/Y)
- X (trường thứ nhất) - tọa độ X (ngang) hiện tại của điểm tham chiếu của vùng cấm dạng Fill, tính theo gốc tọa độ hiện tại của không gian thiết kế. Chỉnh sửa để thay đổi vị trí X của vùng cấm dạng Fill. Có thể nhập giá trị theo hệ mét hoặc hệ Anh; hãy kèm đơn vị khi nhập giá trị có đơn vị khác với đơn vị mặc định hiện tại.
- Y (trường thứ hai) - tọa độ Y (dọc) hiện tại của điểm tham chiếu của vùng cấm dạng Fill, tính theo gốc tọa độ hiện tại. Chỉnh sửa để thay đổi vị trí Y của vùng cấm dạng Fill. Có thể nhập giá trị theo hệ mét hoặc hệ Anh; hãy kèm đơn vị khi nhập giá trị có đơn vị khác với đơn vị mặc định hiện tại.
- Rotation - góc xoay của vùng cấm dạng Fill (tính bằng độ), đo ngược chiều kim đồng hồ từ vị trí 0 (phương ngang 3 o'clock). Chỉnh sửa để thay đổi góc xoay của vùng cấm dạng Fill. Độ phân giải góc nhỏ nhất là 0.001°.
Thuộc tính
- Component – trường này chỉ hiển thị trong trình biên tập PCB khi Fill Keepout được chọn là một phần của linh kiện PCB và hiển thị ký hiệu định danh của linh kiện PCB mẹ. Chọn liên kết Component có thể nhấp để mở chế độ Component của bảng Properties cho linh kiện mẹ.
- Restricted for Layer - sử dụng danh sách thả xuống để chọn lớp bị hạn chế.
- Area - cung cấp diện tích của đối tượng đã đặt.
- Length - hiển thị chiều dài hiện tại của vùng cấm dạng Fill. Chỉnh sửa trường này để thay đổi chiều dài trong phạm vi từ 0.001mil đến 10000mil.
- Width - hiển thị chiều rộng hiện tại của vùng cấm dạng Fill. Chỉnh sửa trường này để thay đổi chiều rộng trong phạm vi từ 0.001mil đến 10000mil.
Các hạn chế của vùng cấm
Sử dụng khu vực này để chọn những loại đối tượng sẽ bị vùng cấm hạn chế. Khi bỏ chọn một loại đối tượng, vùng cấm sẽ cho phép loại đối tượng đó đi vào (không bị ngăn cấm) bằng cách không áp dụng quy tắc khoảng hở tương ứng. Các lựa chọn bao gồm:
- Via
- Track
- Copper
- SMD Pad
- TH Pad
Đặt vùng cấm
Vùng cấm được đặt trong không gian thiết kế của trình biên tập từ menu Place » Keepout, trong đó kiểu vùng cấm đã chọn (đường mạch, vùng tô, vùng hoặc cung) sẽ được đặt trên lớp hiện đang hoạt động. Chọn thuộc tính của vùng cấm để chỉnh sửa các đặc tính hình học, lớp hoặc các hạn chế theo loại đối tượng. Các thuộc tính Keepout liên quan gồm:
- Restricted for Layer – thiết lập lớp của vùng cấm, từ đó xác định lớp bo mạch mà các đối tượng đồng sẽ bị hạn chế (không được đi vào). Đối với vùng cấm áp dụng cho tất cả các lớp, hãy chọn Keep-Out Layer.
- Keepout Restrictions – xác định những loại đối tượng sẽ bị vùng cấm hạn chế. Khi bỏ chọn một loại đối tượng, vùng cấm sẽ cho phép loại đối tượng đó đi vào (không bị ngăn cấm) bằng cách không áp dụng quy tắc khoảng hở tương ứng.
Trong hình bên dưới, hai vùng cấm dạng Fill được áp dụng các hạn chế khác nhau về lớp và đối tượng. Các thiết lập này cho phép vùng cấm dạng Fill trên lớp trên cùng (bên trái) chấp nhận pad xuyên lỗ (TH) trong khi hạn chế tất cả các loại đối tượng khác, còn vùng cấm trên lớp Keep-Out (bên phải) chỉ chấp nhận đường mạch.

Ví dụ về hai vùng cấm dạng Fill được đặt trên các lớp khác nhau của PCB và được cấu hình để hạn chế việc đặt các loại đối tượng khác nhau.
Tính linh hoạt vốn có của vùng cấm cho phép sử dụng chúng cho nhiều tác vụ kiểm soát bố trí PCB. Vì các vùng cấm có thể được đặt chồng lên nhau, gán cho bất kỳ lớp tín hiệu nào (chẳng hạn như lớp trên cùng hoặc dưới cùng) và cấu hình để ngăn các đối tượng cụ thể, nên có thể sử dụng chúng để kiểm soát chặt chẽ, ví dụ như việc bố trí via liên kết và đổ đồng đa giác.
Kiểm soát đổ đồng đa giác
Trong ví dụ bố trí PCB bên dưới, các vùng cấm dạng Fill đã được thêm xung quanh các pad đa lớp trong một khu vực có khả năng có điện áp cao, cần được cách ly điện đủ mức với các vùng đổ đồng đa giác nối đất sắp được thêm vào. Các vùng cấm dạng Fill được đặt trên lớp trên cùng và cấu hình để chỉ hạn chế các đối tượng đồng, tức là ngăn các vùng đổ đồng đa giác, vùng tô và vùng, nhưng vẫn chấp nhận các đường mạch và pad hiện có, v.v. – nói cách khác, quy tắc kiểm tra vi phạm khoảng hở sẽ chỉ áp dụng cho các đối tượng được phân loại là “đồng”.

Các vùng cấm dạng Fill được đặt trên lớp Keep-Out và cấu hình để chỉ áp dụng cho các đối tượng đồng.
Cách bố trí các vùng cấm ở trên sẽ buộc các vùng đổ đồng đa giác được đặt trên các lớp tín hiệu (trong trường hợp này là lớp trên cùng và lớp dưới cùng) phải tránh cả ba khu vực vùng cấm. Tuy nhiên, pads trên lớp trên cùng liên quan đến khu vực cần chú ý sẽ không có khoảng hở đủ lớn với vùng đổ đồng trên lớp trên cùng.
Trong trường hợp này, có thể thêm các vùng cấm vào lớp trên cùng để vùng đổ đồng đa giác của lớp này tránh tất cả các pad liên quan với khoảng cách phù hợp. Trong hình bên dưới, hai vùng cấm dạng Fill khác đã được thêm vào lớp trên cùng, được hiển thị ở đây trong chế độ một lớp để dễ quan sát. Lưu ý rằng phạm vi vùng cấm được minh họa có thể được tạo từ một vùng duy nhất thay vì hai vùng tô chồng lên nhau.

Các vùng cấm dạng Fill được đặt trên lớp trên cùng và cấu hình để chỉ áp dụng cho các đối tượng đồng.
Khi các vùng đổ đồng đa giác được thêm vào bố trí, tập hợp các vùng cấm sẽ kiểm soát việc đổ đồng để tạo ra hình dạng khoảng hở khác nhau cho từng lớp quanh khu vực này. Lưu ý rằng trong ví dụ này, khoảng hở liên quan đến vùng cấm lớn hơn khoảng hở dành cho các đối tượng thông thường do có quy tắc khoảng hở vùng cấm tùy chỉnh (xem bên dưới).

Các vùng đổ đồng đa giác tránh những đối tượng vùng cấm đã đặt.
Có thể thấy rõ ảnh hưởng của tập hợp vùng cấm lên các vùng đổ đồng đa giác khi xem bố trí ở chế độ 3D một lớp, như minh họa bên dưới – lớp trên cùng ở bên trái và lớp dưới cùng ở bên phải.

Lớp trên cùng (bên trái) và lớp dưới cùng (bên phải) của PCB được hiển thị ở chế độ 3D một lớp.
Kiểm soát bố trí via liên kết
Việc áp dụng các hình dạng vùng cấm được cấu hình để hạn chế đối tượng via trên các khu vực đồng đa lớp có thể kiểm soát phạm vi bố trí via liên kết tự động (Tools » Via Stitching/Shielding). Có thể thiết lập các hình dạng vùng cấm cho bất kỳ lớp nào hoặc một trong các lớp của khu vực đồng để các via nối giữa những lớp đó bị ngăn không cho đi vào (bị hạn chế).
Trong ví dụ bên dưới, các hình dạng vùng cấm đã được thêm vào góc trên bên trái và góc dưới bên trái của bố trí. Chúng được cấu hình để hạn chế đối tượng via, ngăn chức năng bố trí via liên kết tự động đặt via bên trong các đường bao đó.

Các vùng cấm dạng Region được cấu hình để chỉ áp dụng cho via.
Ngoài việc tránh các đường mạch, pad và via hiện có như thông thường, chức năng bố trí via liên kết còn tránh các hình dạng vùng cấm theo quy tắc khoảng hở tương ứng.

PCB sau khi thêm các via liên kết.
Vùng cấm trong linh kiện
Vùng cấm được thêm vào footprint linh kiện trong trình biên tập thư viện PCB theo cùng cách áp dụng trong không gian thiết kế của trình biên tập PCB.
Vùng cấm được thêm vào footprint linh kiện bên dưới được cấu hình để hạn chế tất cả các đối tượng nhưng cho phép đường mạch – nhờ đó cho phép kết nối net trong bố trí sử dụng linh kiện này, đồng thời hạn chế việc đặt các loại đối tượng khác ở quá gần.

Cũng có thể thêm đối tượng vùng cấm vào footprint linh kiện trong trình biên tập thư viện PCB.
Làm việc với vùng cấm
Cơ chế vùng cấm theo đối tượng cụ thể của Altium Designer được tích hợp vào tất cả các chức năng liên quan, bao gồm khả năng tương thích với các truy vấn (và do đó với các quy tắc thiết kế), bảng PCB List, cũng như các tài liệu thiết kế PCB được nhập vào hoặc thuộc phiên bản cũ.
Quy tắc khoảng hở vùng cấm
Tương tự các đối tượng cơ bản khác, quy tắc khoảng hở điện hiện tại sẽ xác định các ràng buộc khoảng hở cho vùng cấm – xem Design » Rules. Nếu cần một ràng buộc khoảng hở khác cho vùng cấm, hãy tạo quy tắc riêng bằng cách áp dụng phép kiểm tra thuộc tính IsKeepOut dưới dạng truy vấn tùy chỉnh.
Đảm bảo quy tắc khoảng hở Keepout tùy chỉnh được đặt mức ưu tiên cao hơn quy tắc khoảng hở hiện có (toàn cục). Trong ví dụ dưới đây, một quy tắc đã được tạo cho các vùng Keepout (Clearance_Keepout) với khoảng cách ràng buộc khoảng hở gấp đôi quy tắc khoảng hở cơ sở (Clearance). Như thể hiện trong phần bố trí bo mạch, đường mạch được đi giữa hai pad tránh vùng Keepout (bên phải) với khoảng cách lớn hơn so với vùng trên lớp Top Layer (bên trái).

Có thể tạo thêm một quy tắc khoảng hở cho các đối tượng Keepout.
Chuyển đổi đối tượng nguyên thủy thành Keepout
Các đối tượng nguyên thủy hiện có trên các lớp tín hiệu có thể được chuyển đổi thành Keepout trên cùng lớp bằng lệnh Convert Primitives to Keepouts (Tools » Convert » Convert Selected Primitives to Keepout).

Có thể chuyển đổi một đối tượng nguyên thủy thành đối tượng Keepout tương đương (và ngược lại).
Truy cập qua các bảng
Có thể truy cập các Keepout dành riêng cho từng loại đối tượng trong thiết kế bo mạch qua các bảng PCB List và PCB Filter.
Bảng PCB Filter cho phép sử dụng từ khóa truy vấn IsKeepOut để tìm và (tùy chọn) chọn các đối tượng Keepout trong thiết kế.

Có thể sử dụng bảng PCB Filter để tìm các đối tượng Keepout trong thiết kế.
Có thể sử dụng bảng PCB List để liệt kê, chọn và chỉnh sửa các đối tượng Keepout thuộc loại đã chọn — ví dụ: các vùng tô Keepout, như minh họa trong hình bảng List bên dưới. Một vùng tô Top Layer thông thường (được liệt kê cuối cùng) cũng được hiển thị để so sánh. Nếu all các vùng tô (hoặc các loại đối tượng khác, chẳng hạn như vùng) có trong thiết kế được chỉ định là Keepout, thì bảng PCB List sẽ bao gồm đầy đủ các thuộc tính hạn chế của đối tượng Keepout.

Có thể sử dụng bảng PCB List để liệt kê, chọn và chỉnh sửa các đối tượng Keepout thuộc loại đã chọn.
Nhập thiết kế PCB
Altium Designer có thể nhập các tệp thiết kế từ nhiều công cụ thiết kế khác bằng khả năng chuyển đổi tự động do Import Wizard (File » Import Wizard) cung cấp. Các đối tượng kiểu Keepout có trong tệp thiết kế PCB từ các công cụ thiết kế khác, trong đó một số dành riêng cho từng loại đối tượng, sẽ được trình hướng dẫn chuyển đổi thành Keepout dành riêng cho từng loại đối tượng khi có thể.
Quy trình chuyển đổi Keepout của trình hướng dẫn tương thích với các thiết kế bo mạch từ những hệ thống ECAD phổ biến như Mentor® Graphics Pads™ và Cadence® Allegro™. Các Keepout cũng được diễn giải chính xác trong quá trình xuất IDF.
